Altium Designer Documentation

OLE Object Support in PCB Documents

Modified by Jason Howie on Apr 11, 2017

Altium Designer 15 expands its smart data interpretation capabilities with the ability to place or paste OLE objects directly into a PCB document.

This is enabled by the introduction of Object Linking and Embedding (OLE) technology in the PCB Editor, which allows data supplied by Windows OLE applications to be embedded in a PCB design while actively linked back to the source application. In many cases, this allows the embedded PCB data to be edited from within the application that created it.

Typical objects that might be placed in a PCB document include common Excel documents, Word documents or graphics objects from a suitable OLE image application. The supported file types include universal formats such as CSV and XLS format spreadsheets, DOC and RTF word documents, and 8-bit BMP and JPG image files.

Placing an object

Use the Place » Object From File command to navigate to and place/embed an OLE object into a PCB from the Choose File dialog.

Altium Designer’s Smart Paste capability also allows a selection in an OLE application to be copied and pasted (Edit » Paste) into the PCB document as an OLE object. The text paste option (Edit » Paste Text) can be used to strip the text elements from an OLE object if required. These will be placed as Altium Designer PCB text objects.


A placed sequence of OLE objects – image, spreadsheet cells and word document text (top to bottom).

Once placed, embedded objects can be proportionally scaled by dragging on their selection handles. With text-based objects such as Word and Excel documents, the embedded text is automatically scaled in size and thickness to suit the new dimensions.

The placed object’s angle and layer can be set from the OLE Object dialog, where its Rotation is defined in degrees (CCW) and its layer selected from the drop down Layers menu.


The OLE Object properties dialog. Note the Edit data button.

Support for embedded OLE objects is also included in Altium Designer’s PCB Inspector and PCB List panels.

Editing an object

Use the Edit data button to open the object for editing in its matching OLE application. When the file is saved in the application, the results will be reflected in the embedded PCB object.

When editing a embedded OLE spreadsheet object (CSV, XLS, etc) in its source application (Excel), note that while the cell contents can be successfully updated, a change in the number of cells will not transfer to the OLE object in Altium Designer.

An OLE Object can also be converted to a collection of free primitive objects using the Tools » Convert » Explode OLE Object to Free Primitives command. This will break the object into appropriate Regions and/or Text objects.

A convert to free primitives option is also offered if the matching OLE application cannot be found when attempting to edit an OLE Object.

If you'd like to comment on the content on this page, use the Ctrl+Enter keyboard shortcut to send us your feedback. To include a section of the page in your comment (a typo, missing/wrong info, or incorrect imagery), highlight the text (max. 200 chars) and/or image first. Please restrict your feedback to documentation issues - for technical assistance refer to the Altium Forums.

Contact Us

Contact our corporate or local offices directly.

You are reporting an issue with the following selected text and/or image within the active document:
Request Free Trial

Complete this form to request a free 15 day trial of Altium Designer: