Altium Designer Documentation

View Configurations - Board Layers and Colors tab

Modified by Rob Evans on Jun 19, 2017


The Board Layers and Colors tab of the View Configurations dialog

Summary

The Board Layers and Colors tab of the View Configurations dialog allows you to configure the display of layers for the board and the colors assigned to those layers.

Access

This is one of four tabs available for a 2D view configuration – accessed from within the View Configurations dialog. This dialog can be accessed from both the PCB Editor and the PCB Library Editor in the following ways:

  • In 2D Layout Mode, click Design » Board Layers & Colors in a PCB editor or Tools » Layers & Colors in a PCB library editor.
  • Press the L key.
To access 2D view-related tabs, either ensure the workspace is in 2D Layout Mode prior to accessing the dialog or select a 2D configuration in the Select PCB View Configuration region after the dialog is accessed.

Options/Controls

Signal Layers

This region displays a list of signal layers for the board. Each layer in the list is presented in terms of:

  • Layer Name - the name of the layer. This field is not editable. For a layer that has an entry in brackets after its name (Top Layer, Bottom Layer and Mid-Layers 1-9), use that entry as a keyboard shortcut to quickly toggle that layer's visibility in the workspace (toggling its Show field).
    Signal layer naming is user-definable from the Layer Stack Manager dialog (Design » Layer Stack Manager). While the unused mid layers are shown as 'Mid-Layer n', be aware that when adding a mid layer to the layer stack, it will be given a default name in the form 'Signal Layer n'.
  • Color - displays the color currently assigned to the layer. To change, simply click the color swatch and select a new color from a variant of the 2D System Colors dialog (which only allows changing the color for that specific layer).
  • Show - reflects the visibility of the layer in the workspace. Enabled (checked) means the layer will be visible in the workspace. Click to toggle as required.

The following additional option is available to manipulate the layers presented in the list:

  • Only show layers in layer stack - enable this option to work only with used signal layers (i.e., those defined as part of the layer stack for the board) in the Layer Stack Manager dialog.

Internal Planes

This region displays a list of internal plane layers for the board. Each layer in the list is presented in terms of:

  • Layer Name - the name of the layer. This field is not editable.
  • Color - displays the color currently assigned to the layer. To change, simply click the color swatch and select a new color from a variant of the 2D System Colors dialog (which only allows changing the color for that specific layer).
  • Show - reflects the visibility of the layer in the workspace. Enabled (checked) means the layer will be visible in the workspace. Click to toggle as required.

The following additional option is available to manipulate the layers presented in the list:

  • Only show planes in layer stack - enable this option to only work with used internal plane layers, those defined as part of the layer stack for the board, in the Layer Stack Manager dialog.

Mechanical

This region displays a list of mechanical layers for the board. Each layer in the list is presented in terms of:

  • Layer Name - the name of the layer. The name can be changed from the default naming scheme (Mechanical 1, Mechanical 2, etc) to a more meaningful name that is reflective of what the layer is being used for. To do so, click once on the name field to focus it, then click again to edit.
  • Color - displays the color currently assigned to the layer. To change, simply click the color swatch and select a new color from a variant of the 2D System Colors dialog (which only allows changing the color for that specific layer).
  • Show - reflects the visibility of the layer in the workspace. Enabled (checked) means the layer will be visible in the workspace. Click to toggle as required. Note that the layer's Enable option must also be enabled before the layer can be made visible in the workspace.
  • Enable - reflects whether the layer is enabled as part of the PCB's layer set. A mechanical layer will only be available (visible) in the workspace as a tabbed layer provided this option is enabled (and its Show option is also enabled). With this option enabled, it is considered to be 'in use' and part of the set of layers defined and stored as part of the PCB document. Toggle this option to enable/disable the layer as required. If the layer contains component primitives, you cannot disable the layer. If it contains non-component primitives, you can disable the layer. A confirmation dialog will appear asking whether you wish to delete all primitives from the layer and remove it from the set of layers.
  • Single - enable this option to be able to display design objects on the layer when viewing in single layer mode. This option works in conjunction with the Single Layer Mode option on the View Options tab of the dialog.
  • Linked - enable this option for the layer to be linked to the PCB sheet. By placing objects on mechanical layers and then linking those layers to the sheet, you can create your own drawing templates that can be displayed or hidden as required, such as a border, grid reference, and title block.
The PCB sheet can be resized automatically to fit the objects on linked mechanical layer(s) by enabling the Auto-size to linked layers command in the Board Options dialog. With this option enabled, either use the View » Fit Sheet command or the Design » Board Shape » Auto-Position Sheet command, then refresh the view of the workspace (View » Refresh or press the End key).
Note that if display of the sheet is disabled (by disabling the Display Sheet option in the Board Options dialog) then the linked mechanical layer(s) will also be hidden.

The following additional option is available to manipulate the layers presented in the list:

  • Only show enabled mechanical Layer - enable this option to list and work only with enabled mechanical layers.

Mask Layers

This region displays a list of mask layers (solder and paste) for the board. Each layer in the list is presented in terms of:

  • Layer Name - the name of the layer. This field is not editable.
  • Color - displays the color currently assigned to the layer. To change, simply click the color swatch and select a new color from a variant of the 2D System Colors dialog (which only allows changing the color for that specific layer).
  • Show - reflects the visibility of the layer in the workspace. Enabled (checked) means the layer will be visible in the workspace. Click to toggle as required.
Use the Solder Masks region on the View Options tab of the dialog to further refine how solder masks are displayed.

Other Layers

This region displays a listing of the following layers for the board: Drill Guide, Keep-Out Layer, Drill Drawing, and Multi-Layer. Each layer in the list is presented in terms of:

  • Layer Name - the name of the layer. This field is not editable.
  • Color - displays the color currently assigned to the layer. To change, simply click the color swatch and select a new color from a variant of the 2D System Colors dialog (which only allows changing the color for that specific layer).
  • Show - reflects the visibility of the layer in the workspace. Enabled (checked) means the layer will be visible in the workspace. Click to toggle as required.

System Colors

This region of the tab displays a list of the special, layer-independent system items that can be displayed on a PCB document. Each entry in the list is presented in terms of:

  • Item Name - the name of the special system item. This field is not editable.
  • Color - displays the color currently assigned to the item. To change, simply click the color swatch and select a new color from a variant of the 2D System Colors dialog (which only allows changing the color for that specific layer).
  • Show - reflects the visibility of the item in the workspace. Enabled (checked) means the item will be visible in the workspace. Click to toggle as required.

Silkscreen Layers

This region of the tab displays a list of the silkscreen layers for the board. Each layer in the list is presented in terms of:

  • Layer Name - the name of the layer. This field is not editable. Use the entry in brackets after its name as a keyboard shortcut to quickly toggle that layer's visibility in the workspace (toggling its Show field).
  • Color - displays the color currently assigned to the layer. To change, simply click the color swatch and select a new color from a variant of the 2D System Colors dialog (which only allows changing the color for that specific layer).
  • Show - reflects the visibility of the layer in the workspace. Enabled (checked) means the layer will be visible in the workspace. Click to toggle as required.

Additional Controls

The following sections describe additional controls available that apply to a specific region of the tab, all regions of the tab, or are available on the tab's right-click menu.

Region-Specific

  • All On - click this control to make all layers/items in the current list visible in the workspace (Show option enabled). Note that for mechanical layers, this control does not enable the layers. You must also enable a mechanical layer in order to make it visible in the workspace.
  • All Off - click this control to make all layers/items in the current list hidden from the workspace (Show option disabled).
  • Used On - click this control to make only those layers/items in the current list that are in use (for example a layer that has one or more design primitives placed on it) visible in the workspace (Show option enabled). All other layers/items currently not in use will be hidden from the workspace (Show option disabled).

Global

  • All Layers On - click this control to make all layers/items across all current lists visible in the workspace (Show option enabled). Note that for mechanical layers, this control does not enable the layers. You must also enable a mechanical layer in order to make it visible in the workspace.
  • All Layers Off - click this control to make all layers/items across all current lists hidden from the workspace (Show option disabled).
  • Used Layers On - click this control to make only those layers/items across all current lists that are in use (for example a layer that has one or more design primitives placed on it) visible in the workspace (Show option enabled). All other layers/items currently not in use will be hidden from the workspace (Show option disabled).
  • Selected Layers On - click this control to make selected layers/items across all current lists visible in the workspace (Show option enabled). Note that for mechanical layers, this control does not enable the layers. You must also enable a mechanical layer in order to make it visible in the workspace.
  • Selected Layers Off - click this control to make selected layers/items across all current lists hidden from the workspace (Show option disabled).
    Select multiple layer/item entries in the tab using standard Ctrl+click and Shift+click keyboard shortcuts.
  • Clear All Layers - click this control to deselect all currently selected layers/items across all current lists in the tab.

Right-Click Menu

  • Change Color - use this command to access a variant of the 2D System Colors dialog in order to change the color for the currently focused layer/item.
  • Show/Hide - use this command to toggle the visibility (Show option) for the currently focused layer/item.
  • Rename - this option is only available for Mechanical layers. Use this option to easily change the name of a Mechanical Layer.
  • Default Color Scheme - use this command to quickly change assigned layer/item colors across all regions of the tab to those defined in the Default color profile (Default.PCBSysColors).
  • DXP 2004 Color Scheme - use this command to quickly change assigned layer/item colors across all regions of the tab to those defined in the DXP2004 color profile (DXP2004.PCBSysColors).
  • Classic Color Scheme - use this command to quickly change assigned layer/item colors across all regions of the tab to those defined in the Classic color profile (Classic.PCBSysColors).
Color profiles are defined in the 2D System Colors dialog, which is accessed by clicking on the 2D Color Profiles button at the bottom left of the View Configurations dialog. All default color profiles are stored in the following folder (for a default installation of Altium Designer): \Users\<ProfileName>\AppData\Roaming\Altium\Altium Designer <GUID>\ViewConfigurations.
English
If you'd like to comment on the content on this page, use the Ctrl+Enter keyboard shortcut to send us your feedback. To include a section of the page in your comment (a typo, missing/wrong info, or incorrect imagery), highlight the text (max. 200 chars) and/or image first. Please restrict your feedback to documentation issues - for technical assistance refer to the Altium Forums.

Contact Us

Contact our corporate or local offices directly.

You are reporting an issue with the following selected text and/or image within the active document:
Request Free Trial

Complete this form to request a free 15 day trial of Altium Designer: