Altium Designer Documentation

Board Shape

Modified on Apr 11, 2017

Parent page: PCB Objects

The Board Shape defines the shape of the finished board.

Summary

The board shape, also referred to as the board outline, is a closed polygon that defines the boundary, or extents, of the board. As well as providing a visual guideline of the extents of the space available for the placement and routing of the design, the board shape is also used by the internal power planes as the reference for the power plane edge pullback and the edge for splitting power planes.

Availability

The board shape is available only in the PCB editor. When a new PCB file is created it opens with a default board shape.

For a blank PCB project, or additional PCB documents added to an existing project, the default board shape is a rectangular shape (6Inch x 4Inch, or 6000mil x 4000mil, or 152.4mm x 101.6mm). For specific project templates that can be used when creating a new PCB project, the associated PCB document in each case has a specific board shape, according to the form factor of the board.

There are a number of ways this shape can be altered. The commands available depend on the current View mode:

  • Board Planning Mode - when viewing the board in planning mode, the following commands are available from the main Design menu:
    • Redefine Board Shape - use this command to interactively draw a new shape.
    • Edit Board Shape - use this command to interactively modify the shape of the board by moving vertices or sliding the edges of the shape.
    • Modify Board Shape - use this command to interactively modify by the board by adding new vertices.
    • Move Board Shape - use this command to move the location of the board shape within the workspace.
  • 2D Layout Mode - when viewing the board in 2D, the following commands are available from the Design » Board Shape sub-menu:
    • Define From Selected Objects - select a set of line and/or arc primitives that define a closed shape, then use this command to redefine the board shape to match this shape.
    • Create Primitives From Board Shape - use this command when the board shape exists but there are currently no objects along the boundary.
    • Define Board Cutout - use this command to define a region that will result in a hole being cut through the board when the board is fabricated.
    • Auto-Position Sheet - use this command to automatically resize the displayed PCB Sheet to exactly enclose the objects on mechanical layers linked to that sheet (will require a refresh of the workspace).
  • 3D Layout Mode - when viewing the board in 3D, the following command is available from the Design » Board Shape sub-menu:
    • Define From 3D Body - use this command to define the board shape by selecting the desired surface of a 3D model.
The current viewing mode for the PCB document can be changed using the corresponding commands from the main View menu. Alternatively, change views quickly using the 1 (Board Planning Mode), 2 (2D) and 3 (3D) keyboard shortcuts, respectively.

Redefining Board Shape

After launching the Redefine Board Shape command (in Board Planning Mode), the cursor will change to a crosshair and you will enter the standard polygonal object placement mode. Board shape definition is made by performing the following sequence of actions:

  1. Position the cursor and click to anchor the starting vertex for the board shape.
  2. Move the cursor ready to place the second vertex. The default behavior is to place 2 edges with each click, with a user-defined corner shape between them. Refer to the Placement Modes section below for more details on changing corner modes.
  3. Continue to move the mouse and click to place further vertices.
  4. After placing the final vertex, right-click or press Esc to close and complete the definition of the board shape. There is no need to manually close the board shape as the software will automatically complete the shape by connecting the start point to the final point placed.

Placement Modes

When redefining the board shape there are 5 available corner modes, 4 of which also have corner direction sub-modes. During redefinition:

  • Press Shift+Spacebar to cycle through the 5 available corner modes: 45 degree, 45 degree with arc, 90 degree, 90 degree with arc, and Any Angle.
  • Press Spacebar to toggle between the two corner direction sub-modes.
  • When in either of the arc corner modes, hold the  or  keys to shrink or grow the arc. Hold the Shift key as you press to accelerate arc resizing.
  • Press the 1 shortcut key to toggle between placing 2 edges per click, or one edge per click. In this second mode the dashed edge is referred to as the look-ahead segment (as shown in the last image in the set below).
  • Press the Backspace key to remove the last vertex.

Press Shift+Spacebar to cycle through the 5 available corner modes, press the 1 shortcut to toggle placement between 2 edges or 1 edge.

Graphically Editing the Board Shape

Edit Board Shape

After launching the Edit Board Shape command (in Board Planning Mode), the existing board shape will go green. The outer shape is defined by a series of edges: where each edge is represented by an end vertex, shown as a solid white square; and a center vertex, shown as a hollow white square. Each end vertex represents the location where 2 edges meet.

Editing handles for an example board shape after entering edit mode.

  • Click and drag A to move the applicable end vertex.
  • Click and drag B to move the applicable center vertex, effectively creating a new end vertex, and splitting the original edge into two.
  • Click anywhere along an edge, away from editing handles, and drag to slide that edge.
  • Ctrl+click anywhere along an edge, away from editing handles, to insert a new end vertex.
  • Click and hold on an end vertex, and press Delete, to remove that vertex.
Exit editing mode by clicking anywhere in the workspace (on or away from the board shape).

Modify Board Shape

The Modify Board Shape command allows designers to easily change the shape of their board. The command is accessed in Board Planning Mode and is run by  selecting Design » Modify Board Shape. Once the command is launched, the cursor becomes a crosshair. Each time you click, a new vertex is added. The Shift+Spacebar keys can be used to change corner shapes.


Modifying the board shape.

Graphically Moving the Board Shape

After launching the Move Board Shape command (in Board Planning Mode), the existing board shape will go green and an outline copy of the shape will be attached to the cursor. Simply move the shape to the desired new location within the workspace and click, or press Enter, to effect placement. While moving, the board shape can be rotated or mirrored:

  • Press the Spacebar to rotate the board shape anti-clockwise, or Shift+Spacebar for clockwise rotation. The Rotation Step size is defined on the PCB Editor – General page of the Preferences dialog.
  • Press the X or Y keys to mirror the board shape along the X-axis or Y-axis respectively.
To cancel without moving, simply right-click or press Esc.

An outline copy of the board shape attaches to the cursor, while the original shape can be used as a reference.

Defining the Shape from selected objects

The board shape can also be defined from selected objects (in 2D Layout Mode). Typically this will be a set of lines and/or arcs placed on the Keepout layer, or a mechanical layer. Use the following sequence of steps:

  1. All the objects on a layer can be selected using the Edit » Select » All on Layer command, from the main menus.
  2. Once all the objects are selected, run the Design » Define From Selected Objects command. The board shape will update to follow the path defined by the selected lines. A warning dialog will appear if the software is unable to follow the centerline of the selected objects.

This Board Shape has been defined from a set of selected lines and arcs placed on the Keepout layer.

The software will attempt to find the shape based on the centerline of the selected objects. If the coordinates for the end of one track/arc segment do not exactly match the coordinates of the next track/arc segment then the boundary identification algorithm will fail and a message will be displayed showing the failure location. It will offer to use a tracing algorithm instead. Note that the tracing algorithm follows the outer edge of the track/arc objects, so the board shape will be slightly different than the one created from the centerlines. Only choose this option if your design can accept the impact of this difference.

Defining the Shape from a 3d body

This feature is accessed by using the Design » Board Shape » Define From 3D Body command from the main menus (when in 3D Layout Mode). Prior to launching this command, you must have already placed a 3D body in the workspace. To define a board shape from the 3D body:

  1. After launching the command, click the 3D body to select it, the cursor will change to a crosshair, ready to select the desired surface.
  2. Move the cursor around the model, when a surface is found, it is highlighted by the rest of the model being made somewhat transparent.
  3. Click on a flat surface of the model - this surface will become the new board shape.
Only surfaces aligned with the X-Y plane can be used to create the board shape from. If you select a model surface that requires alignment in the X-Y plane, you will be asked, via a Confirmation dialog, to align the surface before you can continue. This dialog also allows you to vertically position the model, using the selected face, in relation to either the top or bottom surface of the board. This means that the vertical position of the model can also be set at the same time. After alignment you will need to run the Define From 3D Body command again.

An example of redefining the board shape based on the selected surface of a 3D body.

Creating Primitives from the Board Shape

As well as defining the board shape from selected primitives, it is also possible to create primitives from the board shape. Use this command when the board shape exists but there are currently no objects along the boundary. Situations where this command can be useful include:

  • You want to modify the board shape (or board cutouts) by modifying track and arc primitives first.
  • You need a keepout boundary for the board, or keepout boundaries for board cutouts. This is discussed in more detail below in the section Important Design Considerations When Using Board Cutouts.

Cutting a Hole in the Board Shape

A board cutout can be placed anywhere in the board shape. To place a cutout, switch to view the board in 2D Layout Mode, then use the Design » Board Shape » Define Board Cutout command from the main menus. Note that the cutout is actually a Solid Region object configured to be a negative object. To learn more about placing this type of object, refer to the Region object.

A Board Cutout has been placed on the Board Shape.

Important Design Considerations When Using Board Cutouts

Keeping the Polygon Back from the Edge of a Board Cutout

Polygons that overlay a solid region board cutout will pour as close to the edge of the cutout as allowed by the applicable Clearance design rule. A specific Clearance design rule can be created if required, which could for example be scoped to apply between IsBoardCutoutRegion and InPolygon.

Defining a Rout Tool Path Around the Edge of the Board and Cutouts

A common approach used to cut the finished board from the fabrication panel is to mill or rout the board out of the panel. Board cutouts can also be routed out. A Rout Tool path is defined by placing Line and/or Arc objects on a mechanical layer. This can be done manually, or automatically by the software.

To define a Rout Tool path for the board and any board cutouts:

  1. With the board in 2D Layout Mode, run the Design » Board Shape » Create Primitives From Board Shape command. The Line/Arc Primitive From Board Shape dialog will appear.
  2. Define a suitable Width for the objects that will define the Rout Tool path. Consult with your fabricator if you are unsure of this.
  3. Select an available mechanical layer, this layer should be reserved for just the Rout Tool path definition.
  4. Enable the Include Cutouts option if the board has cutouts in it.
  5. Enable the Rout Tool Outline option. When this option is enabled the line/arc objects are placed so their edge touches the edge of the board shape and the edge of the cutout.
  6. Click OK to create the Rout Tool objects on the chosen mechanical layer. 
  7. The mechanical layer used must be set as the Rout Tool layer, to do this open the Board Options dialog (right-click in the workspace and select Options » Board Options) and select the required Layer in the Rout Tool Path option.

The images below show the Rout Tool path defined on a mechanical layer.

A Board Cutout shown on the left, with a Rout Tool path defined in the image on the right.

Using PCB Sheets

The PCB Sheet is a special drawing feature used to represent the printed page in 2D Layout Mode. The sheet is not a design object, rather it is a display feature designed to work with objects placed on a mechanical layer. In the image below, dimension objects have been placed on a mechanical layer, and the sheet has been linked to this layer on the Board Layers And Colors tab of the View Configurations dialog. Because it is linked and the Auto-size to linked layer option enabled (Board Options dialog), the Design » Board Shape » Auto-Position Sheet command can be used to automatically resize the Sheet to exactly enclose the objects on that mechanical layer. This gives a professional, print-ready presentation of the board.

Refresh the workspace using the View » Refresh command (or End keyboard shortcut), after running the Auto-Position Sheet command.

The sheet has been linked to the contents of the mechanical layer upon which the dimension objects have been placed,
resulting in a professional, print-ready presentation of the design.

When you create a new PCB file, a default sheet is automatically created. It is not shown initially, but when enabled in the Board Options dialog it appears as the white shape behind the design objects present in the workspace. Altium Designer's \Templates sub-folder (\Users\Public\Documents\Altium\AD15\Templates for a default install of the software) includes a variety of template PCB files that include sheet borders for different paper sizes - open the appropriate sized template and copy the contents of the relevant mechanical layers into your current PCB design.
As well as automatically defining the sheet size from the contents of the linked mechanical layers, the sheet size and location can be defined manually using the Sheet Position options in the Board Options dialog.

Controlling the Display of the Sheet

To make the sheet visible in the PCB Editor:

  • Run the Design » Board Options command to open the Board Options dialog, then enable the Display Sheet option in the Sheet Position region. The sheet can be hidden at any time by disabling the Display Sheet option. All linked mechanical layers will also be hidden.
  • The color of the sheet can be changed on the Board Layers And Colors tab of the View Configurations dialog (press L shortcut). Select a new color for the Sheet Area Color and Sheet Line Color in the System Colors region of the tab.

Keepouts

As well as the board shape, you should also define a placement and routing boundary around the edge of the board. This can be created automatically, from the board shape itself, using the Design » Board Shape » Create Primitives From Board Shape command (in 2D Layout Mode). Alternatively, this can be done manually, by placing objects on the keepout layer. Objects placed on this layer define a no-crossing-allowed boundary for components and routing. Typically you want objects such as components and routing to be a certain distance from the edge of the board, this distance can be controlled by setting the applicable routing and component placement design rules. You can also define other routing and component keepouts areas for mechanical objects such as screw heads, or other mounting requirements.


A keepout boundary defined by placing standard line objects on the keepout layer.

Keepout boundaries can be defined by placing any standard design objects: such as lines, arcs, fills and regions, on the Keepout layer. Objects placed on the Keepout layer create a keepout on all signal layers.

You can also define layer-specific keepouts on any copper layer. To do this:

  1. Click on the layer tab of the required layer.
  2. Define the boundary or area of the keepout area by placing layer-specific keepout objects (Place » Keepout submenu). Layer specific keepouts are simply standard objects with the Keepout attribute enabled. They are displayed in the same color as the layer, with a keepout colored edge. Note that layer-specific keepout objects are not included in the Gerber or ODB++ output files.

Tips

  1. The board shape is not used for output generation, it is only the placed objects that are used.

 

English
If you'd like to comment on the content on this page, use the Ctrl+Enter keyboard shortcut to send us your feedback. To include a section of the page in your comment (a typo, missing/wrong info, or incorrect imagery), highlight the text (max. 200 chars) and/or image first. Please restrict your feedback to documentation issues - for technical assistance refer to the Altium Forums.

Contact Us

Contact our corporate or local offices directly.

You are reporting an issue with the following selected text and/or image within the active document:
Request Free Trial

Complete this form to request a free 15 day trial of Altium Designer: