Altium Designer Documentation

Collaborate, Compare and Merge

Modified by Annika Krilov on Apr 11, 2017

Parent page: PCB Panel


The Collaborate, Compare and Merge panel.

The Collaborate, Compare and Merge panel is command-central for performing a copper comparison between two versions of the same PCB design. It requires that the board is currently under version control, and that the repository that it is stored in is configured in the Data Management - Design Repositories page of the Preferences dialog. The panel checks if the board is the latest revision (known as the Head revision). If it is not it indicates what must be done to bring it up to date, such as Merge Required.

When you click on a command in the Actions section of the panel to initiate a Comparison, such as Merge to head revision, Altium Designer compares your file against the latest revision in the repository, and displays the differences in the Difference Map in the panel, and also in the main editing workspace.

The board is divided into cells in the Difference Map, when you click on a cell the differences in that cell are detailed in the lower section of the panel, and also in the main workspace. The Difference Map also includes Layer tabs, use these to examine the differences on each layer.

Panel Access

  • To display the Collaborate, Compare and Merge panel, click the PCB button at the bottom-right of Altium Designer when the PCB Editor is active and select the Collaborate, Compare and Merge entry from the pop-up menu.
  • You can also access the panel through the View » Workspace Panels » PCB » PCB sub-menu.
  • The panel can also be opened by selecting two versions of the PCB document in the Time Line region of the Storage Manager panel and right-clicking. From the context menu, select Compare to open the Collaborate, Compare and Merge panel.

Panels can be configured to be floating in the editor space or docked to sides of the screen. If the Collaborate, Compare and Merge panel is currently in a group of panels, use the Collaborate, Compare and Merge tab located at the bottom of the panels to bring it to the front.

Terminology and Status Messages

Head

The latest revision committed to the version control system

Base

The revision the local copy of the document was derived from. Also know as the checked out revision

Working Copy

Local copy of the version controlled document on which editing is performed

Local changes

Changes made on the working copy that have not been committed to version control

Status : Up to Date

The base revision is the head revision and no local changes have been made

Status : Out of Date

The base revision is older than the head revision and no changes have been made to the working copy

Status : Modified

The base revision is the head revision and changes have been made the working copy

Status : Merge required

The base revision is older than the head revision and local changes have been made. In other words the file is both modified and out of date

Resolve

The act of updating the base revision number to the head revision number. This will transform the status from merge required to modified

Actions section

The Actions section of the panel is used for 2 tasks:

  1. To display, define and clear Progress Regions in the main workspace.
  2. To indicate if the board is up-to-date with the repository, define what must be done if it is not, and to initiate Compare and Merge actions.

Work in Progress Regions

Work in Progress regions are polygonal areas that each designer working on a board can place to show where they are currently working. These can then be displayed, hidden or removed.

The 2 Show work in progress commands display current regions in the Map and main editor respectively. These can be hidden again by clicking the red cross that appears when either command is run.

The Manually mark an area command presents you with an editing cursor in the main editing window. The placement behavior is the same as placing a solid polygonal region on your board, click to place each corner, press Shift+Spacebar to change the corner mode, Spacebar to change the corner start/end, right-click to close the shape.

You can clear your own Work in progress regions at any time using the Clear all My Work in Progress Regions command.

Version Control Status

When the panel is opened, Altium Designer automatically checks the revision number of your board and compares it to the revision number of the Head revision. If they are not the same, the Version Control Status will indicate what needs to be done to make them the same.

Difference Map section

When a comparison is performed, the board is divided into cells (the cell size is defined at the top of the panel). The Difference Map presents these cells in a checkerboard fashion, as you hover the cursor over a cell its cell reference is displayed, such as G4. Click on a cell to display that cell in the main editing window.

Cells that contain differences are shaded in color, the choice of color reflecting ownership of those changes, as defined in the color key just below the map of the board. Clicking on a colored cell details all the differences in the Cell Differences section at the bottom of the panel.

The Difference Map also includes Layer tabs, use these to examine the differences on each layer.

Details section

The section at the bottom of the panel displays the differences detected in the currently selected cell. The Previous and Next buttons can be used to move backward or forward through the cells in a logical pattern, layer by layer.

Supported Objects

When working in Collaborative PCB Design, some objects/features are not supported by the merge process. Supported/not supported objects are detailed below.

Supported:

  • Tracks
  • Arcs
  • Fills
  • Solid Regions
  • Pads
  • Vias (also Blind & Buried)
  • Dimensions
  • Coordinates
  • Components

Not supported:

  • Polygon + cutout + board cutout
  • Embedded board array
  • Rooms
  • Origin
  • Grid
  • Free 3D Bodies
  • Guides
  • Rules

Multi-channel design is also not supported by the Collaborative PCB feature.

 

English
If you'd like to comment on the content on this page, use the Ctrl+Enter keyboard shortcut to send us your feedback. To include a section of the page in your comment (a typo, missing/wrong info, or incorrect imagery), highlight the text (max. 200 chars) and/or image first. Please restrict your feedback to documentation issues - for technical assistance refer to the Altium Forums.

Contact Us

Contact our corporate or local offices directly.

You are reporting an issue with the following selected text and/or image within the active document:
Request Free Trial

Complete this form to request a free 15 day trial of Altium Designer: