Altium Designer Documentation

Release Notes for Altium Designer

Modified on Feb 7, 2018

The following sections list the release notes for publically released versions of Altium Designer 18.0

For a summary of new features and enhancements in Altium Designer 18.0, see New in Altium Designer.

Version 18.0.11

Build: 651 Date: 30 January 2018 

New Features and Improvements

In PCB

10572 Drill symbols display correctly on the Drill Drawing layer now, when the Show Drill Symbols option is enabled (BC:8633).
24199 Added ability to use different background color settings for 2D and 3D display modes (BC:8635).
24200 Improved layers hierarchy and the 'Layer Type' labels in the View Configuration panel.
24208 Added defaults for component 'Designator' and 'Comments' fields (BC:8723).
24209 3D layer visibility no longer affected by the 2D layer visibility option, the transparency slider is used to control the 3D layer visibility (BC:8599).

Other

24210 Schematic - Added new setting 'Display Names of Special Strings that have no Value Defined' to the Schematic - Graphical Editing page of the Preferences dialog.
24332 Interactive Properties Panel - Updated Pad/Via properties for solder mask tenting.
24545 Data Management - Removed 'deci' prefix from the display value.

Bug Fixes

Draftsman

23841 Disabling usage of a Component Parameter as the source for a Callout.
23912 "Object reference not set to an instance of an object" Access Violation appearing during document loading when access to the file was blocked.
24016 "Link Location To Embedded Board Origin" property for Embedded Board Array in PCB being ignored by Draftsman (BC: 8634).
23594 Regression resulting in the incorrect parameters displaying in the Properties panel or on the Page.
23940 Bug in Draftsman that causes AD to crash on startup when a used font was not available.
23995 Bug where it was not possible to create a new .PCBDwf document if there was no PCB project open (BC:8621).

PCB

23917 Access Violation during removal of a snap guide from the Interactive Properties Panel (Board info).
24005 Access Violation occurred while renaming a component in the PCBLib panel, after importing the library from Ultra Librarian.
24198 Disabling adding an existing Mechanical Layer into a Layer Pair (BC:8710).
24201 Failure to present Mechanical layers in an Embedded Board Array (BC:8731).
24232 Connection line disappearing and an 'Un-Routed' net being treated as 'Routed', after moving tracks segments in such a way that it would create 3 overlapping primitives.
23592 Regression where a project parameter value was not automatically displayed on the Draftsman document, when it was defined in the Draftsman template.
24154 Pads on shelved polygon were randomly not connecting to polygons with reliefs (BC:8640).
24211 It was impossible to type in the list of Net names, in the Properties panel.
24113 PCB 3D Export - Components were stretched abnormally on PCB 3D print previews and PCB 3D prints were cut off at the PCB borders (BC:8666).

New Graphic Engine

23760 Embedded board array being sometimes only partially displayed in the 3D view, after switching from 2D to 3D, or after editing the source PCB (BC:8790).
23688 Regression resulting in possibility of Access Violation Error occurring when working on a panelized PCB, and the source PCB was closed.
24401 Incorrect rendering of 3D Model Standoff height with a greater gap from the board surface (BC:8663).
23309 3D origin was offset along the Z axis.

Platform

24007 Access Violation that occurs during a second compilation, after removal of some of the sch documents from the project.
24181 "Control "ViewXXX" access violation appearing with no parent window" when dragging documents between AD instances.
24309 Properties Panel disappearing from Altium Designer after Windows update (BC:8750).
23924 Regression resulting in "Stack overflow, gdi32full.dll" error message if the Supplier Links dialog was empty and the Currency drop-down menu was accessed.
24052 Performance regression observed during 'Pick&Place' output generation.
24117 Regression resulting in additional time needed to close documents located on a network share.
24185 Regression leading to absence of 'UseTempFile' property in TXCeedZip (BC:8688).
23347 Regression where was impossible to add expression to the Watch List (BC:8680).

Other

24205 Interactive Properties Panel - Regression causing a 3D body disappearing (opacity ->0) after sequentially selecting a component with 3D model (or free model), and then some other type of primitive (BC:8660).
24004 Interactive Properties Panel - "Object reference not set to an instance of an object" Access Violation error occurred on selecting primitive in PCB or SCH.
24264 Regression leading to a noticeable delay while editing a text string on a schematic.
24522 Regression involving missing footprints on Gerber file.
24179 Schematic - Bug, which, in some cases, would lead to "Object reference not set to an instance of an object" exception when changing the units.
23770 Data Management - Bug where for the just placed component BOM status has 'Component revision is out of date' wrong value.
24551 Data Management - Bug with bad/invalid supplier links and not actual supplier data.
24147 Regression where the Access Violation error occurred in module 'ADVPCB.DLL' after the attempt to open Preferences after closing the PCB where Defaults PCB primitives were accessed.

 

Version 18.0.9

Build: 584 Date: 15 December 2017 

New Features and Improvements

7079 Multi-board - Added support for multi-board designs (BC:4338).
8087 New Graphics Engine - Added new graphical engine for PCB.
9870 PCB - Performance of net handling has been optimized.
11595 New UI - Updated user interface.
10090 PCB - Improved interactive routing - large arcs are no longer fractured during routing preparation.
14214 PCB - Implemented GPU rendering for Camtastic module to increase rendering speed.
13401 Multi-board - Created a 3D transformation gizmo for move/rotate operations on selected objects (BC:4338).
17374 New UI - Implemented UI for advanced settings.
16686 Interactive Properties Panel - Added Document Options values and controls to the new Properties panel.
17119 Schematic - Improved the SCH editor for simplified and more intuitive design.
20118 Platform - Improved crash reporting process, the Error dialog now defaults to auto-send mode. This mode does not send screen captures or preferences , and sends data in the background.
15641 Importer-Eagle ® - Added support to the Eagle importer for Eagle hierarchical modules.
15357 PCB - Improved ActiveRoute to color Route Guide the same color as the selected layer (when a single layer is selected).
15476 PCB - Added control to allow the user to prevent excessive meandering.
15716 PCB - Added support for object specific keepouts in ActiveRoute.
17120 PCB - Improved the PCB editor for simplified and more intuitive design.
17637 PCB - When Retrace is used to change the gap of a diffpair, its center line stays in place unless forced to move by surrounding obstructs or increased turn radius.
18155 PCB - Added output to Message Panel from Gloss and Retrace to explain their behaviour in potentially confusing cases.
18493 PCB - Changed diff pair Gloss to preserve the gap of the original pair.
19279 PCB - A massive Gloss/Retrace operation can now be interrupted by hitting the Esc key. Intermediate results will be presented. Use Undo to restore the design to the state prior to running the command.
19736 PCB - Optimized interactively moving a PCB component.
20189 PCB - added advanced option to support Live/ Non Live updating of a Drill Table, as live updating can impact performance (default is off). The Drill Table is automatically updated during output, regardless of the option's setting.
20279 PCB - Footprint dragging has been optimized.
20401 PCB - Merged Clear and Delete commands into a single command (Edit > Delete). When nothing selected behaves as former Delete command (prompts to select), when object(s) selected behaves as former Clear command (deletes selected object(s)).
21906 PCB - Netbuild - Improved broken net analyzer behavior to better handle unconnected copper.
12418 Draftsman - Implemented new design for Draftsman Properties panel.
15057 Draftsman - Added Bookmarks panel. This is Navigation tool which shows the document structure, allows to add, delete and drag sheets, lets users change the document view format and helps work with the document objects.
15058 Draftsman - Added Arcs support.
16118 Draftsman - Support for an Embedded Board Array has been added to the Board Assembly View, Drill Drawing View, Board Detail View, Board Fabrication View and Drill Table (BC:7013).
17165 Draftsman - Added backwards compatibility for Draftsman files.
18367 Draftsman - Added check that PCB and Draftsman documents are up to date.
18435 Draftsman - Region feature now supports adding sophisticated polygon shapes (BC:7322).
18436 Draftsman - Added "Component View" and support for placing dimensions and callouts to the component.
20518 Draftsman - Added ability to save the custom table in a sheet template and a document template.
8574 Data Management - Added a new Single Component Editor which includes Create Model and Edit Model functionalities and options for fileless editing.
14440 Data Management - Added ActiveBOM support.
14811 Data Management - Added ability to select which settings to import from a previous install of Altium Designer.
15276 Data Management - Added ability to use PCB Footprint Generator in Single Component Editor.
15486 Data Management - Added ability to use currency converter in Single Component Editor.
15774 Data Management - Added support for Git (BC:1391, BC:2379).
15867 Data Management - Added a new approach for document linking and uploading to Vault.
15952 Data Management - Added item Names, to replace Comments , and introduced HRID as a technical parameter.
15970 Data Management - Added ability to use PCB document as source (primary and secondary) in BOM.
15984 Data Management - Added ability to batch edit Part Choice Lists (PCLs).
16295 Data Management - Improved Vault connectivity ambiguity including how a user connects to the Vault, how the Vault is configured on the client, and fast switching between Vaults.
16315 Data Management - Improved the Save To Vault command so it displays a warning message with a suggestion to use the Library Migrator.
16568 Data Management - Improved the component validation process during release to Vault to increase the thoroughness of validation and provide clear feedback to users.
16575 Data Management - Moved the Library Migrator to the File menu.
16582 Data Management - Moved the Release Manager to the legacy menu.
16585 Data Management - Added ability to edit Release Notes when "Send to Vault..." action is executed.
16680 Data Management - Added the ability to call the Release Manager Migration Tools from the corresponding Tools menu.
16770 Data Management - Implemented a new approach for document linking and upload to Vault.
16802 Data Management - Improved Component creation for a more intuitive user experience.
17222 Data Management - Improved component list selection in the Content Cart.
17313 Data Management - Improved CmpLib documents to update model names after editing the name attribute in the model document.
17333 Data Management - Improved model documents to update model names after editing the name attribute in the parent CmpLib document.
18357 Data Management - Improved the SchLib release process to include options for fileless editing.
19407 Data Management - Added check for the restricted names of parameters in Component Rule Check.
19458 Data Management - Unification of the attribute names in the Library and Component domains (Design Item ID, Comment, Name, Component, Symbol and Lib Reference etc.)
20459 Data Management - Resolved an issue in which invalid information showed for a component template when using "Where used" feature.
20563 Data Management - Reviewed and streamlined the Project Release process, based on user-feedback.
20705 Data Management - Added support for VersionControl_RevNumber and VersionControl_ProjFolderRevNumber parameters in the Excel-BOM templates (BC:4992).
21006 Data Management - added support for managing properties that are now supported by ActiveBOM rather than Draftsman, when opening an older Draftsman file in AD18.
21901 Data Management - Login to an Altium Vault has been disabled in AD18.0.6. You need to install and use Altium NEXUS to connect and use your Vault.
22017 Data management - improved validation of default component naming to prevent names being created that use incorrect naming syntax.
22032 Data Management - resolved issue where an exception would occur when attempting to run the Item Manager to match schematic sheet components to Vault components, when those component included unrecognized schematic parameters.
22101 Data Management - A default ActiveBOM can now be defined in the New Documents Defaults page of the Preferences. Use this to pre-configure: column visibility and order, currency, the number of supply chain solutions, designator groupings, and so on.
23011 Data Management - Added support page for 32Bit DBlibs provider and 3D mouse.

Data Management

15092 Data Management - Fixed bug causing the release of DWG/DXF/3DPDF files to fail.
15394 Data Management - Fixed bug causing the irregular appearance of the "Convert to Managed Project" command.
16524 Data Management - Fixed bug that caused slow performance when sorting columns in Vault Explorer.
16795 Data Management - Fixed bug causing slow sign-in to Altium Vault when VCS were not configured properly.
17030 Data Management - Fixed bug in the ProjectReleaser causing Item naming changes.
17057 Data Management - Fixed bug where Component names were not updated in the Projects panel after editing the Name attribute.
17110 Data Management - Fixed bug where model documents where duplicated in the Projects panel.
17338 Data Management - Fixed bug where child documents were not closed after executing the Cancel Edit command for CmpLib documents.
17383 Data Management - Fixed bug where added datasheets were not displayed in the Projects panel.
17587 Data Management - Fixed bug causing BOM generation to leave unclosed Excel instances.
17713 Data Management - Removed old suppliers as part of the effort to clean up the UI.
18197 Data Management - Fixed bug where Smart PDF would crash during export of a BomDoc.
18318 Data Management - Fixed bug during cloning of managed projects where default value was not set for the "Repository" ComboBox.
19039 Data Management - Fixed bug where an output file would be missing when releasing two schematic PDFs with the same folder structure.
19261 Data Management - Fixed regression where the error "Integer overflow" appears when trying to refresh the BOM after modification of the project structure.
19889 Data Management - Fixed regression where it required two attempts to open a project template.
19948 Data Management - Fixed bug where supplier search did not work when logged in to SolidWorks PCB Services.
19978 Data Management - Fixed an issue whereby a vault component would lose its datasheet when updating that component as a result of editing and re-releasing one of its domain models.
21056 Data Management - Fixed bug where a multiplicity of "GetALU_Items" requests occur, which resulted in the software hanging after a release or opening a component for editing in a large DB.
22121 Data Management - Fixed bug where Symbol and Footprint Item Revision fields were not being mapped into the appropriate schlib and pcblib component attributes , when the component was opened via file-less editing.
22154 Data Management - Fixed bug where unit-aware component parameters break if a client used different regional settings from the creator.
22881 Data Management - Fixed bug where BOM component height not filled if datasource is [project] or [ActiveBOM].

Bug Fixes

16714 PCB - Fixed bug causing Single Layer Keepouts to appear as copper in Generated 3DPDF Output.
17135 PCB - Fixed Bug where X2 Gerbers of PTH/HPTH Drill files did not contain board-array holes (BC:7756).
17233 PCB - Fixed bug in STEP exporter causing incorrect component locations in folded state flex.
17530 PCB - Fixed bug causing rounding issues for 3D models in IDF export.
18196 PCB - Fixed a regression where component primitives were not edited after using them in a union.
19664 PCB - Fixed bug where a particular project released in AD 17 without DRC errors, has clearance constraint violations.
20033 PCB - Removed the Flipped on layer option from the PCB component, up/down orientation is now defined by the layer's Orientation option in the Layer Stack Manager. Component's orientation now depends on which layer it has been placed on (BC:4391).
21068 PCB - Fixed regression in PCB where an error occurred when trying to repour a polygon during the placement of a via, pad, arc etc.
22912 PCB - Fixed bug where an Undo after a Move Component operation would result in the Solder Mask Expansion values changing , if the Top and Bottom Solder Mask values were different.
23282 PCB - Fixed regression where the polygon layer and net could not be changed in the PcbList panel.
23554 PCB - Fixed regression where a polygon could not be flipped during pasting.
17455 Draftsman - Fixed bug where Text Settings were missing from Draftsman Callout (BC:7803).
18347 Draftsman - Fixed regression where manual designator position was broken.
19828 Draftsman - Fixed bug where Show Out of Board Copper did not work for Fabrication View (BC:8118).
21208 Draftsman - Fixed bug where Draftsman documents were not visible by default in a documents list during document opening.
17514 Platform - Fixed bug causing text on the System - Account Management page of the Preferences dialog to appear clipped.
18394 Platform - Fixed bug where DXP.EXE stopped working during project compilation.
18050 Interactive Properties panel - Fixed bug where was possible to add duplicate parameters (BC:1334).
23483 New Graphics Engine - Fixed bug that caused a crash "DXGI_ERROR_DEVICE_REMOVED in F3D.TengMain.BeginRender".
15924 Importer-xDxDesigner ® - Fixed bug in the xDx Importer causing multipart components on different sheets to be recognized as duplicates.
17715 Importer-xDxDesigner ® - Fixed bug causing missing components after importing from xDxDesigner.
17829 Importer-CADSTAR ® - Fixed bug preventing CADSTAR libraries from importing.
20934 Importer-Allegro® - Fixed bug where rotated components import with incorrectly sized pads.
20935 Importer-Expedition® - Fixed bug where net names were not added to the plane and or polygon.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

If you'd like to comment on the content on this page, use the Ctrl+Enter keyboard shortcut to send us your feedback. To include a section of the page in your comment (a typo, missing/wrong info, or incorrect imagery), highlight the text (max. 200 chars) and/or image first. Please restrict your feedback to documentation issues - for technical assistance refer to the Altium Forums.

Contact Us

Contact our corporate or local offices directly.

You are reporting an issue with the following selected text and/or image within the active document:
Request Free Trial

Complete this form to request a free 15 day trial of Altium Designer: