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This application note highlights the key differences you need 
to be aware of when moving from P-CAD to Altium 
Designer. It will help you ramp up your productivity and 
quickly take advantage of this powerful and flexible 
electronic product development environment. 

 

 

You’ve made the switch to Altium Designer – a single, unified application that incorporates all the 
technologies and capabilities necessary for complete electronic product development – and now you’re 
eager to start designing. This application note gives you a jump start on the basics of designing in 
Altium Designer, and maps out the key differences you need to understand when moving from the P-
CAD environment to Altium Designer. It also shows how easy it is to transfer your current P-CAD 
schematic and PCB designs and libraries into Altium Designer.  

Getting Started – Transferring Your P-CAD Design 
Translating complete P-CAD designs, including schematics, PCB layout, and library files can all be 
directly handled by Altium Designer’s Import Wizard without converting to ASCII first – thus avoiding 
the need for having P-CAD installed. The Import Wizard removes much of the headache normally 
found with design translation by analyzing your files and offering many defaults and suggested settings 
for project structure, layer mapping, PCB pattern (footprint) naming, and more. Complete flexibility is 
found in all pages of the wizard, giving you as little or as much control as you would like over the 
translation settings before committing to the actual translation process. 

File Translation 
P-CAD design files in the Import Wizard translate as follows: 

• P-CAD PCB (*.PCB) files translate into Altium Designer PCB files (*.PcbDoc). 

• P-CAD schematic (*.SCH) files translate into Altium Designer schematic files (*.SchDoc). Each 
sheet within a .SCH file is imported as a single Altium Designer schematic file (*.SchDoc). Design 
hierarchy is maintained, including complex hierarchy. 

• These files will be grouped into an Altium Designer PCB project (*.PrjPCB) that is automatically 
created. 

• P-CAD PCB files generate an output job document (*.OutJob) if necessary. This document will 
contain all the print settings from the P-CAD PCB. 

P-CAD library (*.LIB and *.LIA) files translate as follows: 

• Libraries that contain solely pattern information translate into Altium Designer PCB library files 
(*.PcbLib). 
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• Libraries that contain both pattern and symbol information translate into both Altium Designer PCB 
library files (*.PcbLib), and schematic library files (*.SchLib) respectively. 

• Libraries that contain both component and symbol information translate into Altium Designer 
schematic library files (*.SchLib). Libraries which contain solely symbol information do not import 
as Altium Designer does not have the same concept of a symbol as P-CAD (described later). 

Translated P-CAD libraries are automatically grouped in an integrated library package (*.LibPkg).  

Translation Overview 
The steps for translating your P-CAD designs using the Import Wizard look like this: 

Renaming occurs to cater for:
1) Multiple pattern graphics
2) Pin to pad mismatches
Mapping can be adjusted to suit your requirements

Steps for translating your P-CAD designs

Project » Project Options, Class
Generation tab. Check that Room  and Class
generation options are correctly configured.

Project » Component Links dialog. Click Add
Pairs Matched By button.

Project » Show Differences dialog. Use
right-click menu options to set Update
direction.
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Select Files for Translation

Map Pattern to Footprint Names

Map PCB Layers

Create Altium Designer Project

Set Project Options

Assign UIDs to matching PCB and
schematic components

Resolve footprint name differences

Resolve net name differences

Perform PCB DRC

Perform Synchronization (Generate
ECOs and apply)
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Project » Show Differences dialog. Use
right-click menu options to set Update
direction.

 
Figure 1. An overview for stepping you through the basics of importing your P-CAD designs. 
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The steps for translating your P-CAD libraries using the Import Wizard look like this: The steps for translating your P-CAD libraries using the Import Wizard look like this: 

Renaming occurs to cater for:
1) Multiple pattern graphics
2) Pin to pad mismatches
Mapping can be adjusted to suit your requirements

Steps for translating your P-CAD libraries

Double-click on a message in the panel to
launch the Compile Errors panel.

Double-click on warning/error in Compile
Errors panel to go directly to that warning to
resolve. Then Project » Recompile.

Project » Project Options dialog, Library
Options tab to reconfigure compiled integrated
library location.
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Select Files for Translation

Map Pattern to Footprint Names

File Translation

Compile Library Package
Install Generated Integrated Library

Click on Libraries button in the panel to install
the new libraries.

Libraries are compiled and validated. Cross-
checked for symbol to pin mapping.

Review Messages panel for warnings/
errors

Resolve errors and recompile

Move/copy new SchLib/PcbLib/IntLib
to your preferred storage location.

Install new libraries into Altium
Designer Libraries panel

Place components from Libraries panel
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Figure 2. An overview for stepping you through the basics of importing your P-CAD libraries. 

For a tutorial that steps you through all the basics of creating 
components, read Creating Library Components. From the Knowledge Center in Help, 

links and videos for understanding the 
essentials of component, model, and 
library concepts in Altium Designer can 
be found in the Documentation Library 
» Library and Component 
Management.

The fundamentals of how components are defined, their 
properties, and basic relationships between components, 
models and library concepts are explained further in 
Component, Model, and Library Concepts. 
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Using the Import Wizard 
The Import Wizard can be launched from the Altium Designer File menu. Simply click on this menu 
command to launch the wizard as shown below in Figure 3. Right-mouse command menus are 
available for further control over the translation process through each page of the wizard. 

 
Figure 3. Import Wizard as started from the File Menu. You can also launch this wizard by opening a P-CAD file 
through File » Open. 

The Altium Designer Environment 
The Altium Designer environment offers a complete electronic product development environment for all 
areas of design – from schematic capture to the generation of PCB output, as well as complete FPGA 
design, development and on-chip debugging. 

Perhaps the single biggest difference that you will notice when you start working in Altium Designer is 
that there is only one application used to create and edit all design files, regardless of the type of file – 
schematics, PCB, library, text, and so on. No longer will you have to switch between different 
applications when you want to move from viewing the schematic to the PCB. All the files (also referred 
to as documents) open in the same executable, each appearing on a separate document Tab within 
Altium Designer. As you move from one type of document to another the menus and toolbars 
automatically switch, giving you the right editing environment for that document. 

Altium Designer has full support for multiple monitors too. If you have multiple monitors on your PC you 
can easily drag a document out of Altium Designer and drop it on the second monitor, greatly 
enhancing your design productivity.  

To get you started let’s review some of the basic terminology that you’ll need to know as you work in 
Altium Designer. 
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Working with Documents 
In P-CAD, all design work begins on the sheet, the logical working area of the design. There can be 
multiple schematic sheets within a single P-CAD schematic design file (.SCH file).  

In Altium Designer, the logical design area begins with a document, and for each document there is a 
file stored on the hard drive. This means that for each Altium Designer schematic document (sheet) 
there is a file, an important conceptual 
difference to remember. 

There can also be multiple design 
documents of varying types depending on 
the nature of the design you’ll be working on. 
Getting started, most P-CAD users will be 
interested in the schematic and PCB 
document types as these are the files that 
their designs will be translated to (see Figure 
4). 

New schematic and PCB document types 
can easily be created via the File » New 
menu, or by right-clicking on the project in 
the Projects panel (Figure 9). 

Workspace Panels 
Many elements of the environment will 
appear intuitive to P-CAD users, helping as 
you start exploring the system. For example, 
the Projects panel will appear similar to the 
P-CAD Design Manager; except that since it 
is not limited to design data it can include the 
PCB, all libraries, output files, as well as 
other project documents, such as Microsoft 
Word or Excel files. 

You will also notice that your translated files 
will be grouped somewhat differently than 
you are used to seeing. Whether you need to 
open a specific document such as a 
schematic, or need information or control to 
design on a more global, system-wide level, 
it can all be done using the Projects panel. 

As you open and make active the documents 
within various editors you will notice that the 
resources and available panels will change 
dynamically; the menus, available panels, and toolbars will quickly change to match the document type 
you are currently focused on for editing. You’ll want to familiarize yourself with how to access these 

 
Figure 4. P-CAD design files are displayed immediately after 
translation in the Projects panel.
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panels, manage, group, and control your display modes to get the most out of the productivity features 
that are provided here. Press F1 when the cursor is over a panel for more information on that panel. 

Where’s all my stuff? Some Basics on Storage Management 
All design documents and generated output files, including your translated P-CAD design files are 
stored as individual files on your hard disk. Your design files can be accessed by opening the project 
first and then opening the individual documents or any individual document can be opened directly, 
using the File » Open menu command. 

Projects Panel 
Altium Designer, like P-CAD, also features project management capabilities but there are conceptual 
differences you’ll need to get firm in your mind first. The Altium Designer approach to managing your 
project is that all design documents (schematic, PCB, libraries, etc.) are linked to the project file, both 
for management and access to certain design features such as design verification, comparison, and 
synchronization. The Altium Designer presentation through the Projects panel provides high visibility 
and a complete view of everything you need in your project. The project file, which is what you are 
viewing in the Projects panel, contains links to all your documents in your design, as well as any other 
project-level definitions. 

The essentials of project-based design are discussed later in the Project-based design section. 

Storage Manager 

Figure 5. The Storage Manager panel 
is invoked by clicking on the System 
button at the bottom of the Altium 
Designer application window. 

 Altium Designer features a dedicated Storage Manager panel to allow you greater control over the 
management of files in your projects. It allows you to navigate the active project in terms of its file 
storage in Windows. Not only can you see immediately which documents are part of the project and 
where they are stored, but also see other files that are stored but not explicitly added to the project. 
The Storage Manager is multi-functional and can be used for 
everything from general everyday file management tasks such as 
renaming or deleting files, management of backups, through to 
integrating with your company’s version control system. 
Your project file is listed at the top of the panel in the Folders 
region, corresponding to the root directory, with all other folders and 
sub-folders contained within that directory displayed below, in their 
storage hierarchy. 
This Files in Project region of the panel lists all documents 
currently stored in the root directory or sub-folder thereof, for the 
active project. 
If the active project in the Folders region of the panel is under 
version control and you are using either the CVS or SVN version 
control systems, then selecting a document belonging to that 
project (in the Files region of the panel) will populate the VCS 
Revisions region with a history list for that document. 

The Local History region of the panel presents a local history for 
the currently focused document in the Files region of the panel.  

6 AP0130 (v2.8) February 11, 2008 



Moving to Altium Designer From P-CAD 

 

 
Figure 6. The Storage Manager panel has four key regions: Folders, Files in Project, VCS Revisions, and Local 
History. 

Refer to the document Welcome to the Altium Designer Environment for an introduction to Altium 
Designer and an overview of its unique and unified environment. It provides an illustrated and easy 
approach to using Workspace panels, storage management, environment customization and much 
more. 

Navigation Toolbar – Direct Document Navigation 
Because you can have many design documents and projects open at any time, Altium Designer 
provides a Navigation toolbar to find the specific design you need quickly. Since everything is 
integrated into Altium Designer there is no need to switch to another application when you need to view 
a different type of design file. The Navigation toolbar (seen below in Figure 7) is available to assist in 
the direct navigation of design documents, and can be accessed at any time from within any of the 
document editors. 

 
Figure 7. The Navigation Toolbar.
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Browsing Viewed Documents 
The field at the left of the bar allows you to navigate to any directory or document on a network or local 
storage directly, as well as any page on the internet. Browsing previously viewed documents is easy 
using the left and right arrow buttons to go forward and back through previous areas just as you would 
within an Internet Browser. 

Integrated Navigation Home Page 
Click the Go to Home Page button    to access the Integrated Navigation Home Page, a top level 
page where all navigation support pages can be accessed as shown in Figure 8. 

 
Figure 8. The Navigation Home Page. 

Favorites 
Like your internet browser, Altium Designer supports the concept of defining Favorites. Once the 
Favorites panel is displayed (click the System button on the Status bar) you can right-click in the 
Favorites panel to mark the current view of the active document as a favorite. Simply double-click on a 
favorite to return to that document, zoomed to the exact area and location you require.  

As well as views of documents in your design, favorites can include links to any directory or document 
on the network or local storage, as well as any page on the internet.  
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Immediate Access to Help 

 
Figure 9. Right-click shows all project-related menu commands. 

For further information about the 
Favorites panel as well as many other 
topics in Altium Designer, open the 
Knowledge Center panel (click the 
Help button on Status line). When the 
Knowledge Center panel is open it will 
auto-load help on the object, command, 
or menu entry currently under the 
cursor if you pause, or alternatively you 
can press F1 to load the topic 
immediately. 

Project-based Design 
Now that we’ve covered some of the 
basics of the Altium Designer 
environment, it’s time to talk about 
designing. The starting point for every 
design created in Altium Designer is a 
project. 

It’s a simple and important concept – 
an Altium Designer project is a set of 
design documents whose output 
defines a single implementation. For 
example, the schematics and PCB in a 
PCB project output the fileset required 
to manufacture a single printed circuit 
board, while the schematics and HDL in 
an FPGA project the fileset required to 
program a single FPGA. The project file 
brings together all those design 
documents that make up the project. 

Altium Designer supports a number of different types of projects, including: PCB, FPGA, Embedded 
Projects, Core Projects, Integrated Libraries, and Script Projects. 

Projects Panel 
In Altium Designer, all items related to a project are linked to a Project document, and are easily 
accessible and manageable in one location. The Projects panel is probably one of the more 
commonly-used panels in day to day work as it allows you to make changes to your project options, 
add to and remove documents from the project, change the display options of projects, change the 
order of documents within a project, or even how you would like to display information in the Projects 
panel. 
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All of your translated files will appear within the Projects panel with their own respective projects 
automatically created for them. Right-click on the project document to display a context-sensitive 
command menu, giving access to project-relevant editing commands (Figure 9). 

Refer to the application note Project Essentials for all the basics of creating project files, adding and 
removing files from a project, setting project options, as well as understanding the various project 
types. It also explains how to group related projects together into a Workspace, ideal for managing 
multi-board projects. 

Compilation – a Cornerstone of Altium Designer 
Compilation is a cornerstone concept of the Altium Designer environment, and a fundamental 
difference from P-CAD. Compilation is a process that allows you to harness many powerful design 
features and can be done with your translated P-CAD schematics, or even just a netlist! Compilation 
can also be done on other types of documents such as library documents (described later in this 
application note). 
When you select Compile Project from the Project menu the compilation process works out the 
structural relationships between the source schematic (or HDL) documents in the project, then 
determines the net-level connectivity within each sheet, and finally the connectivity between the sheets. 
All this component and connective intelligence from your schematics design is written into an internal 
data structure that can then be used for many post-compilation activities, such as comparing and 
showing differences between schematics, parameter managing, parametric navigation of your design, 
cross probing back and forth between the schematics and PCB, and much more. 

Where are my nets and components from my design? 
You’re going to notice that connectivity is not explicit in your design as it was before in P-CAD, but 
rather has to be extracted from the design using the compilation process. This is available through the 
right-click menu in the Project panel, or using the Project » Compile Project menu command. 

Once the design is compiled the sheet-level hierarchy, as well as all the components, nets and buses 
are displayed in the Navigator panel. From here you can easily locate any component, bus, net or pin 
throughout the entire design. And if you hold the Alt key as you click on an object in the Navigator 
panel it is highlighted on the PCB as well as the schematic – no longer will you need to inspect netlists 
to review design connectivity. 

Verifying Your Design– Expanded Error Checking 
Another benefit that results from compiling a project in Altium Designer is built-in error reporting. This is 
completely configurable for your needs and can be done before your project is compiled. Simply right-
click either on the project file and invoking the Project Options command, or also through the Project 
menu. 
The Error Reporting tab allows you to fully configure all the errors and warnings that you’d like to run 
before running a compile, as shown in Figure 10. 
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Figure 10. Error Reporting tab in Project Options dialog. 

You may wish to get a better picture of the entire development cycle and how it unfolds from an 
Engineer’s perspective by reading An Overview of Electronic Product Development in Altium 
Designer. 

Defining Your Net Connectivity – it is Different 
In P-CAD, net connectivity is made using sheet connectors, ports, modules, and power parts. Nets 
between sheets within a single schematic design (.SCH file) are connected through sheet connectors 
and ports. Hierarchy is represented using modules while power parts are used to create global nets 
throughout the design. There are no net identifiers for referencing a schematic external to the 
schematic design file. 

Altium Designer uses a slightly different set of net identifiers to create net connectivity. Within a 
schematic sheet you can use Wires and Net Labels. Between schematic sheets, nets in a flat design 
are typically connected using Ports, but Off-Sheet Connectors are also available. Nets in a hierarchical 
design are connected from a Port on the lower sheet to a Sheet Entry of the same name, in the sheet 
symbol that represents the lower sheet. Power/ground nets are connected using Power Ports. 

Configuring the Design Connectivity 
Altium Designer supports different types of design connectivity, and this must be set to suit the 
structure of the design. The type of sheet-to-sheet connectivity is referred to as the Net Identifier 
Scope. It is set in the Options tab of the Options for Project dialog, and saved with the project. 
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From the Project menu, select the Project Options menu command, and go to the Options tab as 
shown in Figure 11. 

 
Figure 11. The Net Identifier scope can be set from within the Options tab of Project Options. 

In the Net Identifier Scope drop-down you may select from the following connectivity options: 

• Automatic (Based on project contents) 

• Flat (Only ports global) 

• Hierarchical (Sheet entry <-> port connections) 

• Global (Net labels and ports global) 
The Import Wizard handles connectivity automatically through the translation process and will give 
you the Automatic (Based on project contents) configuration by default. This option is simply an 
instruction to Altium Designer’s design compiler to determine which of the other three options are best 
suited for the connectivity in your design. Hierarchical modules are mapped as sheet symbols, and 
they will translate to sheet symbols in Altium Designer. Pins in modules are created as sheet entries in 
the sheet symbol. In Automatic mode, the design compiler then looks at the sheet symbols on the top 
sheet. If there are sheet entries (hierarchical pins) in them, it will assume vertical connectivity, and 
internally use the Hierarchical option. If there are no sheet symbols on the top sheet, or if there are 
sheet symbols but they do not include any sheet entries, it will assume horizontal connectivity for which 
there are two ways that Altium Designer supports this: Flat and Global. In order to determine which of 
these two options to use, the design compiler looks for ports or off-sheet connectors on the sub-sheets. 
If there are any it uses the Flat option, if there are no ports it uses the Global option. 
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Remember that you can easily go back and change this configuration after the translation process 
through the Project Options dialog from the Projects menu. 
Remember that you can easily go back and change this configuration after the translation process 
through the Project Options dialog from the Projects menu. 

Defining net connectivity, net identifiers, scoping and how it all relates to multi-sheet design is a 
must read for P-CAD users and is fully explained in the article Connectivity and Multi-Sheet Design.
Defining net connectivity, net identifiers, scoping and how it all relates to multi-sheet design is a 
must read for P-CAD users and is fully explained in the article Connectivity and Multi-Sheet Design.

Design Synchronization Design Synchronization 
Design synchronization is fully integrated in Altium Designer without the need for passing a netlist. 
Synchronization in Altium Designer is also bi-directional, allowing you to make annotation changes and 
component property updates in both directions between your schematic and PCB, in a single 
operation. 

Design synchronization is fully integrated in Altium Designer without the need for passing a netlist. 
Synchronization in Altium Designer is also bi-directional, allowing you to make annotation changes and 
component property updates in both directions between your schematic and PCB, in a single 
operation. 

Again, an important and fundamental premise of Altium Designer is that the setup of the design's 
connectivity is driven from the schematic through to the PCB. If you are making connectivity changes in 
the opposite direction (from PCB to Schematic), a report is generated and these updates can then be 
performed on the schematic. 

Again, an important and fundamental premise of Altium Designer is that the setup of the design's 
connectivity is driven from the schematic through to the PCB. If you are making connectivity changes in 
the opposite direction (from PCB to Schematic), a report is generated and these updates can then be 
performed on the schematic. 

The synchronization feature is used when you first transfer from the schematic to the new blank board, 
or when you make design changes that need to be passed over.  
The synchronization feature is used when you first transfer from the schematic to the new blank board, 
or when you make design changes that need to be passed over.  

For more information on design transfer and design synchronization, read the article Finding 
Differences and Synchronizing Designs. 
For more information on design transfer and design synchronization, read the article Finding 
Differences and Synchronizing Designs. 

As well as being able to detect electrical differences, such as changed designators, component values 
or net connectivity, Altium Designer also include a physical difference engine, which can find schematic 
and PCB layout changes – ideal for examining changes between different revisions of a board. 

As well as being able to detect electrical differences, such as changed designators, component values 
or net connectivity, Altium Designer also include a physical difference engine, which can find schematic 
and PCB layout changes – ideal for examining changes between different revisions of a board. 

The Schematic Symbol Is the Component… The Schematic Symbol Is the Component… 
As an expert P-CAD user, you’ll know that components form 
the basic building blocks of design in P-CAD, and the symbol 
is merely a graphical representation of that component in the 
schematic. But in Altium Designer the symbol is effectively 
the component for all phases of design, and not just the 
schematic capture portion of it. A little comparison will help 
show the differences of how the two are modeled between 
the respective systems for a better understanding. 

From the Knowledge Center in Help, links 
and videos for understanding the essentials of 
component, model, and library concepts in 
Altium Designer can be found in the 
Documentation Library » Library and 
Component Management.
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P-CAD Components 

P-CAD Component

One symbol
graphic

P-CAD Pattern

=
Multiple
pattern

graphics

 
Figure 12. P-CAD components have a single symbol graphic and one or more pattern graphics for each pattern 

In P-CAD, all of the logical and electrical data that is held in the component can be seen in Library 
Executive in the Pins View dialog.  Pin and gate swapping component pin to symbol pin, and pattern 
pad mapping, along with the pin's electrical and logical data is the only component information 
available. Because this information relates primarily to the pins and is somewhat limited, there are 
inherent restrictions to the number of ways that P-CAD components can be represented throughout the 
design process.  An Altium Designer component, on the other hand, contains more information and is 
more flexible in terms of how it can be represented. 

Altium Designer Components 
Altium Designer Component

Multiple Simulation / 3D /
SI models

Multiple footprints

=

1..n

=

1..n

=
1..255

symbols

 
Figure 13. Altium Designer symbols can have multiple footprints (pattern graphics) and symbol models 
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In Altium Designer, the logical symbol is assumed to be the essential starting point of a component. It 
can be initially defined at minimum as a name in a schematic library to which pins and any graphical 
symbols or alternative display options needed for implementation may be added. This flexibility allows 
a component to be represented in different ways during the design and capture process. This may not 
only be as a logical symbol on the schematic, but also be a footprint on the PCB or even as a SPICE 
definition for simulation. 

The fundamentals of how components are defined, their properties, and basic relationships 
between components, models and library concepts are explained further in the article Component, 
Model, and Library Concepts. 

True Multi-channel Design 
Finally Arrives 

 
Figure 14.Project hierarchy is easily viewed in the Projects 
panel. 

Complex hierarchy is the general term used 
throughout the industry to describe the process of 
using multiple instances of the same sheet in a 
schematic hierarchy. This important concept is 
supported by Altium Designer.  

Multi-channel Design 
Traditionally, a design that included complex 
hierarchy had to go through a process of 
‘flattening’ or ‘expanding’ the hierarchy at some 
point, to uniquely instantiate every component 
and net. Altium Designer does not need to do this, 
so this multiple-instantiation capability is referred 
to as multi-channel design instead of complex 
hierarchy. 

Like complex hierarchy, multi-channel design is 
the ability to reference a child sheet multiple 
times. It can be done by placing multiple sheet 
symbols, each referencing the same sub-sheet, or 
it can be done by placing a single sheet-symbol 
and using the Repeat statement to generate an 
array of sub-sheets. This is built on the complex 
hierarchy architecture of multiple instances, but in 
this case the parent object is expanded by the 
design compiler at the time of compilation. 

Multi-channel design also supports multiple levels. 
For example, a 32-channel design could be 
structured over two levels, having 4-banks of 8-
channels, to create the final 32-channels. 
Additionally you can wire signals to either all of 
the channels or use a bus where one member of 

AP0130 (v2.8) February 11, 2008 15 



Moving to Altium Designer From P-CAD 

the bus goes to each channel. Altium Designer is the only electronic design platform to offer this 
concept. 

There are several example multi-channel designs that come with Altium Designer that you may 
wish to look at. These include the Multi-Channel Mixer, Peak Detector and PortSwitcher. All three 
designs can be found in the \Examples\Reference Design folder. Once you have opened one of the 
examples you should compile it, and then look for the tabs at the bottom of each schematic sheet. 

For more information on multi-channel designs, refer to the article Multi-Channel Design Concepts. 

Libraries 
Altium Designer supports working directly from the source symbol or model libraries, an ideal approach 
when the schematic and PCB are designed by separate organizations. There are also integrated 
libraries, a term used in both Altium Designer and P-CAD, yet each having distinct differences.  

In P-CAD, an integrated library is a single library file that has both the pattern (called a footprint in 
Altium Designer) and symbol information. Components within these libraries have the logical pin 
designators and pin data specific to the type of component. As explained earlier there are some 
fundamental differences about how a component is defined between the two environments. In P-CAD, 
the component definition provides the symbol and patterns with any connectivity intelligence; patterns 
and symbols alone do not contain any logical information such as pin designator values because they 
are only a graphical representation.  

Altium Designer Libraries 
In Altium Designer an integrated library, like in P-CAD, is also one where the source symbol, footprint, 
and all other information (e.g. SPICE and other model files) are contained in a single library file. 
However, all this information must be compiled before it can be accessed. During compilation checks 
are made to see how relationships are defined, validating the relationship between the models and the 
symbols and bundling them into a single integrated library. Unlike P-CAD, this file can not be directly 
edited in Altium Designer, offering portability and security. 
You can create an integrated library through the Project panel via the command Compile Project 
(Figure 9). All of Altium Designer’s 70,000+ components are supplied in integrated libraries, from which 
the source libraries can be extracted at any time if required. All libraries may be viewed and managed 
at any time from the Projects and Library Panels. 

Library Types 
There are four types of libraries used in the Altium Designer environment: model, schematic, integrated 
and database. 

Model 
These libraries contain the models for each component representation as per their design domain and 
are each stored in their respective “model containers”, called model libraries. In some domains, there 
will be typically one model per file and they are referred to as model files (*.mdl, *.ckt). In other design 
domains, models are usually grouped into library files according to how the user has grouped them 
such as PCB footprints grouped into package-type libraries (*.PcbLib). 
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Schematic 
These libraries contain source schematic components and their model interface definitions (*SchLib). 

Integrated 
An integrated library (*.IntLib) is a compiled file, that includes schematic libraries along with all models 
referenced in the symbols’ model interface definitions; which could include footprint model libraries, 
simulation model files, and three-dimensional model libraries. 

Database 
Database libraries provide similar functionality to a component information system. When you place 
from an installed database library (*DBLib) all data in the component comes from the referenced 
database. 

Where are my libraries? Some Basics on Library Management  
You’ll be able to view your source schematic and PCB library files immediately after translation through 
the Projects panel. Your translated P-CAD libraries are automatically grouped into one PCB project. 

Like P-CAD, libraries are installed (added) to the Altium Designer environment, making their 
components available in all open projects. Display the Libraries panel, from there you can install and 
remove libraries. Libraries can also be linked to any project, and you can also define project search 
paths, useful for referencing simulation models. 

You’ll be able to view your source schematic and PCB library files immediately after translation through 
the Projects panel. Libraries are not automatically translated as Altium Designer integrated (compiled) 
libraries. They will, however, be automatically grouped into integrated library projects. To create an 
integrated library from an integrated library project, you will need to do this manually through the 
Project panel via the Compile Project command in the right-click menu (Figure 9) when you select a 
source library. 

Refer to the article Enhanced Library Management Using Integrated Libraries for a further 
discussion on library management. 

A Brief Note on Database Linking 
Appreciating the fact that many designers like to link from the components in their electronic design 
software to their company database, Altium Designer has strong support for linking and transferring 
database data through the design process and into the Bill of Materials.  

Two techniques are supported, one where the Altium Designer library symbol holds all model 
references and also includes links into an external database, the second where the database holds all 
model references and other company information. While database connections in Altium Designer are 
set up for MS Access databases (*.mob files) by default, any ODBC-compliant database can be 
accessed. 

To learn more about linking from Altium Designer components to an external database, refer to the 
application note Linking Existing Components to Your Company Database. 

For information on placing components directly from a company component database, read the 
application note Using Components Directly from Your Company Database. 

AP0130 (v2.8) February 11, 2008 17 



Moving to Altium Designer From P-CAD 

How do I setup this new workspace? Designing the PCB 
A tutorial that covers all the basics of PCB design transfer, including the topics mentioned and 
much more can be found in Getting Started with PCB Design. 

PCB Board Wizard 
Before you can transfer your design from the Schematic Editor to the PCB Editor, you’ll need to have at 
the very least a blank PCB with at least a board outline. The PCB Board Wizard allows you to easily 
create a basic PCB design using many industry-standard board outlines as well as create your own 
custom board sizes. 
The PCB Board Wizard is launched from the Files panel in the New from template section. At any 
stage you can use the Back button to check or modify previous pages in the wizard. 

Placement Grid and Units 
All options for the placement grid, measurement units, sheet position, and designator display are found 
in the Board Options dialog. With a PCB document active in the main design window (for this and all of 
the following context-sensitive dialogs), select Design » Board Options [shortcut: D, O] from the main 
menu to open the Board Options dialog. 

PCB Preferences 
Preferences that assist in positioning components easier such as Online DRC, Snap to Center, 
Selection preferences are found in the Preferences dialog for PCB Documents. Select Tools » 
Preferences [shortcut: T, P] from the main menu to open the Preferences dialog. 

View Configurations (Layers and Colors) 
View configurations are settings that control many PCB workspace display options for both 2D and 3D 
environments, and apply to the PCB and PCB Library Editors. The view configuration last used when 
saving any PCB document is also saved with the file. This enables it to be viewed on another instance 
of Altium Designer using its associated view configuration. View configurations can also be saved 
locally and be used and applied at any time to any PCB document. Any PCB files that you open which 
do not have an associated view configuration are displayed using a system default one. 
Note: The View Configurations dialog provides access to 2D color settings for layers and other system-
based color settings – these are system settings, that is, they will apply to all PCB documents and are 
not part of a view configuration. Color profiles for the 2D workspace can also be created and saved, 
similarly to view configurations, and can be applied at any time. 
Select Design » Board Layers & Colors [shortcut: L] from the main menu to open the View 
Configurations dialog. This dialog enables you to define, edit, load and save view configurations. It has 
settings to control which layers to display, how to display display common objects such as polygons, 
pads, tracks, strings etc, displaying net names and reference markers, transparent layers and single 
layer mode display, 3D surface opacity and colors and 3D body display.  

You can apply view configurations using the View 
Configurations dialog or by selecting them directly from the 
drop-down list on the PCB Standard toolbar.  
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You can quickly navigate between the layers of your design by selecting the layer tabs at the bottom of 
the main design window. Helpful shortcut keys from the numeric keypad include the ‘+’ and ‘–‘ for 
cycling through all visible layers, and the ‘ * ‘ to cycle through visible signal layers. 

Layer Stack Manager 
Layers are easily managed using the Layer Stack Manager dialog. Select Design » Layer Stack 
Manager [shortcut: D, K] from the main menu to open it. You can associate nets to planes, change the 
number of layers, define layer and substrate thickness and reassign electrical layer data in this dialog.  

 
Figure 15. The Layer Stack Manager dialog shows a cross-section of the board as you design. Layers may be 
added or redefined in this dialog. 

For further information on setting up your board, refer to the tutorial Preparing the Board for Design 
Transfer. 

Design Rules 
The PCB Editor is a powerful and dynamic rules-driven environment. This means that as you work in 
the PCB Editor and do things that change the design (such as placing traces, moving components, or 
routing  the board), the PCB Editor constantly monitors each action and checks to see if the design still 
complies with the design rules. If it doesn’t an error is immediately flagged for your attention. 
With the PCB as the active document, select Design » Rules from the main command menu to launch 
the PCB Rules and Constraint Editor dialog as shown in Figure 16. 
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Figure 16. The PCB Rules and Constraint Editor where all design rules can be managed. 

One of the powerful features of Altium Designer’s design rule system is that multiple rules of the same 
type can be defined, each targeting different objects. This is called scoping, a new concept for P-CAD 
users, it allows you to exactly target rules to objects in your design. To say it another way, the exact set 
of objects that each rule targets is defined by that rule’s scope. The hierarchy of rules is also user-
defined – this is the priority setting that you can see in Figure 16. This combination of rule scoping and 
priority gives an unprecedented level of control that allows you to precisely target the design rules for 
your board. 

Interactive Route 
As with P-CAD, you must have a signal layer active before you can begin routing. Enable the layer that 
you would like to start on by pressing the L shortcut key to display the View Configurations  dialog. 
Enable the Show checkbox to display a layer – the same as you would do in P-CAD. Once you are 
showing your signal layer, the tab for it will display in the PCB Editor window. Click on the layer tab at 
the bottom of the workspace to make it the current or active layer, ready to route on. 

There are various interactive routing modes available in Altium Designer. These can be invoked 
through the Place menu or simply selecting the required routing button in the toolbar. 

The following tips will assist you to get a quick start for placing traces (many of these will be the same 
as in P-CAD): 
• ENTER or Left-click – Places a start or end vertex in the trace. Placed trace segments will show in 

the appropriate layer color. 
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• SPACEBAR – Allows you to toggle between the start and end modes for the trace you are placing. 

• SHIFT + SPACEBAR – Allows you to change the corner mode of your current route 

• END – Allows you to redraw the screen at any time. 

• Shortcut keys V, F – Redraw the screen to fit all objects (View Extent). 

• PAGEUP, PAGEDOWN – Allow you to zoom in or out, centered on the cursor position. The mouse 
wheel will help you to pan left and right, holding the CTRL key down to zoom in and out with the 
mouse-wheel. 

• BACKSPACE – Will let you unplace the last trace segment. 

• ESC or Right-click – Will complete your trace. 

Display the Shortcuts panel for a dynamic list of shortcut keys available for use wherever you are 
currently working in Altium Designer, including context-sensitive shortcuts available while running a 
command. The Shortcuts panel can be enabled by clicking the Help button in the Status line. 

So how do I get my board manufactured? Setting Up Output Files 
Manufacturing an electronic product requires a multitude of output files to be generated. These can 
include schematic prints for the handbook, assembly drawings, fabrication files, drill files, pick-and-
place files, test point reports and the Bill of Materials (BOM). 

To manage these outputs Altium Designer includes a specialized output job document (*.OutJob) that 
can be added to a project to centralize output generation. Any number of outputs can be configured 
within an output job document, and multiple output jobs can be added to a single project. Once you 
have defined the sets of output files you require, you can then generate all outputs in a single batch 
process. 

Because output jobs are stored within the project, you can easily regenerate output files at any time. 
You can work on multiple projects simultaneously, maintaining independent output configurations and 
file sets for each project. Output configurations can be saved and reused in subsequent projects, 
allowing you to set up multiple configurations for different manufacturers and produce the correctly 
configured file set for each fabrication and assembly house. 

OutputJobs Editor 
The OutputJobs Editor allows you to define and manage Output Job Configuration files (*.OutJob). The 
Output Job file allows you to define all your design output configurations – assembly, fabrication, 
reports, netlists, etc, all in a single location. You can even create multiple Output Job files and add 
them to your projects to create a separate assembly output from the fabrication output. 
You can create a new file of this type for any active project by using either the File » New » Output 
Job File (as shown in Figure 17) command or right-clicking on a project in the Projects panel and 
choosing Add New to Project » Output Job File from the pop-up menu that appears. 
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Figure 17. A fabrication output job file for the Multi-Channel Mixer. 

The Output Job file is divided into a number of categories that reflect the function of the output. These 
include Assembly, Documentation, Fabrication, Netlist, and Report Outputs. You’ll want to familiarize 
yourself with how to configure for these and more. 

A comprehensive technical reference for setting up and configuring your output jobs through the 
OutputJobs editor may be found in the OutputJob Editor Reference. You can open this by pressing 
F1 when the cursor is over an open OutJob. 

Smart PDF 
Smart PDF is a built-in PDF generation wizard that quickly generates a PDF of a single schematic 
sheet, drawings of the PCB, or all the schematics and PCB in a project, complete with clickable 
bookmarks to each component, net and pins in your design. 
The Altium Designer Smart PDF wizard is launched from the File menu, and will guide you through the 
steps required to export a design to PDF. 

 
Figure 18. Use Smart PDF to generate live, bookmarked PDFs of your designs, ideal for design reviews and product 
documentation. 
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Bonus Technologies 
The Bonus Technologies form a more integrated solution in the Altium Designer environment than they 
previously did in P-CAD. As a result of that there are some key differences to launching and using 
them that you should be aware of. 

Situs Autorouter 
Altium’s Situs Topological Autorouter engine is fully integrated into the PCB editor. 

The Situs engine uses topological analysis to map the board space. Topological mapping provides 
greater flexibility in route path determination and allows non-orthogonal routing corridors to be more 
efficiently exploited. Altium Designer also includes full bi-directional support for the SPECCTRA 
autorouter. During export you can automatically preserve existing board routing, control the mapping of 
Altium Designer via rules to SPECCTRA pad stacks, and propagate net classes to SPECCTRA to 
allow efficient generation of class-based routing constraints as you did with P-CAD. 

With your active PCB document complete and everything positioned, you’re ready to start! 
Select the command Auto Route » All to open the Situs Routing Strategies dialog, just as before in P-
CAD. Selecting Route All from this dialog will launch the autorouter. 

Routing a board can be a big challenge. For further points on your board setup, configuring your 
design rules, and running the autorouter, take a look at Situs Autorouting Essentials. 

Fabrication and Assembly Files 
Altium Designer provides a wide choice of outputs that allow you to generate appropriate files for any 
manufacturing requirements in the PCB editor. This includes support for all popular Gerber formats, 
with full control over generated layers and the manual listing or automatic embedding of aperture 
information. 

NC drilling and routing files, automatic pick and place files, and all other relevant manufacturing files 
can be easily generated, checked and edited from the command File » Fabrication Output. 

There is a tutorial that explores the Quick Load command by importing supplied Gerber, ODB++, 
and other file types into CAMtastic in the tutorial CAMtastic Imports and Exports. 

Mixed-signal Circuit Simulation 
Mixed-signal circuit simulation is a unified part of the capture process, and is fully integrated with the 
schematic editing environment. 

Before you launch the Mixed-signal circuit simulation, make sure that any schematic sheet within the 
project is open. Simulation models need to be associated with every component in the schematic 
document before simulation can be launched from the command Design » Simulate » Mixed Sim. 
Simulation is done for the entire project.  

If you need to do simulation for only one schematic sheet, then you can create a separate project and 
add only that sheet to the project. As before in P-CAD, the Analyses Setup dialog will launch first so 
that you can setup all analyses information before running simulation. 
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Signal Integrity   
Signal Integrity is fully integrated into Altium Designer, unlike P-CAD where it is a stand-alone 
application. It requires that you have, at the very least, a project file that contains at least one PCB and 
one schematic source document. This is a slightly different requirement from P-CAD where only a PCB 
design is required. 
Signal Integrity is run from the command Tools » Signal Integrity where the Model Assignments 
Analyses dialog will launch before Signal Integrity will run. 

A full tutorial that covers the setting up of design parameters like design rules, and Signal Integrity 
models, starting up Signal Integrity from the schematic and PCB editors, and configuring your tests 
further can be found in the tutorial Performing Signal Integrity Analyses. 

Viewer Edition license 
A Viewer Edition license is also available to replace the P-CAD viewer that you may have used before 
for design exploration and as a cross probing tool, putting the right set of functionality into the hands of 
designers and engineers across your organization. 

The Viewer Edition licensing option of Altium Designer provides quick, easy, and secure read-only 
exploration of design projects and documents that have been created using Altium Designer. Users 
can view, print and interrogate all aspects of a design created by Altium Designer making design data 
more accessible to the entire design-chain. The Viewer Edition not only enhances collaboration within 
an organization, but also between the design team and external parties, greatly improving design work 
flow and project productivity. 

The Altium Designer Viewer Edition is provided free of charge. You can deploy the Viewer Edition 
across your organization using your existing Altium Designer license. For non-license holders, simply 
contact your nearest Altium sales office to apply for a Viewer Edition license. The license is activated 
online and registered to the user every 12 months.

For Further Reference 
Below are references to other articles and tutorials in the Altium Designer Documentation Library that 
talk more about the conceptual information as well as walking you through specific tasks. Remember, 
you can also browse through the Help contents, and use F1 and What’s This at any time in a dialog 
for more details. 

For more PCB project options, refer to the tutorial, Getting Started with PCB Design

For more FPGA project options, refer to the tutorial, Getting Started with FPGA Design. 

You can find both of these in the Getting Started with Altium Designer book. 

A tutorial that steps you through all the basics of creating components may be found in Creating 
Library Components. 

A tutorial that steps you through all the basics of editing multiple objects may be found in Editing 
Multiple Objects. 

For getting started with embedded software, refer to the tutorial Getting Started with Embedded 
Software. 
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