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This is a high-level roadmap to guide you in understanding how P-CAD terminology translates 
and can be found in Altium Designer. High-level points of interest or difference are noted where 
appropriate. Resources for additional reading in the Altium Designer Knowledge Center to 
further your understanding of this new design environment are also given. 

 

The Knowledge Center panel (Help » Knowledge Center or F1) will assist you as you learn about designing your electronic product in 
Altium Designer. Reference topics automatically load in response to your actions in the environment. In the lower region of the panel you 
will find links to PDFs that will help you perform design tasks, or understand the concepts behind Altium Designer. You can also bring up 
a list of shortcuts at any time through the Help » Shortcuts panel near the lower right of the workspace. 

P-CAD Terms 
The following is a list of the more commonly-used P-CAD terms and their closest respective Altium Designer equivalents. 

P-CAD Term Altium Designer Term Comments

Ascend/Descend Up/Down Hierarchy Used for moving the focus to the next level up or down in the design 
hierarchy, from the current document. 
Found in the Tools menu.  

Board Outline Board Shape
 

The Board Shape defines the physical edge of the board, and is used to 
calculate the automatic power plane pullback. By default the board is shown 
in black, bounded by the Board Shape. Commands to modify the board 
shape are in the Design » Board Shape submenu. During import of a  
P-CAD PCB the P-CAD board outline is mapped to an Altium Designer 
layer, which is then used to define the Board Shape. 
See Also: TU0110 Preparing the Board for Design Transfer
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Polygon Solid Region Solid multi-sided polygonal object. Does not pour around obstacles. 

Connections Connections Connections are not graphical objects that can be assigned through a pad, 
but instead display once a pad is assigned to a net.  Pads can be editted 
through their Properties dialog to be assigned to a net provided that the net 
already exists. Nets are created though Design » Netlist » Edit Nets.   

Copper Pour Polygon Pour Intelligent object that pours around existing copper objects, such as routing 
and component pads. Can be poured solid (uses solid region objects), or 
hatched (uses tracks and arcs).  
See Also: AP0101 Polygon Pours and Copper Regions  

Copy Matrix ; Paste 
From File / Circuit

Snippets; Rubber Stamp Sections of circuitry can be stored and re-used, using the Snippets system. 
After selecting the circuitry right click and choose from the Snippets 
commands. Snippets are placed and managed from the Snippets panel. 

Design Manager PCB Panel Used to browse, locate and edit PCB: Components, Nets, Rules, From-Tos, 
Split Planes, Differential Pairs, Polygons. 

Design Rules Design Rules Rules in Altium Designer are defined separately from the objects (Design » 
Rules). The objects that they apply to is determined by the Scope of the 
rule, which is expressed as a Query, such as InNet(GND). The Rule priority, 
in combination with the rule scope, determines which rule applies to each 
object. Right Click on any object and choose an Applicable Rule command 
to see which rules are being applied to it.  

Note that some rules specify design requirements or preferences, such as 
Solder Mask expansion or Routing Corner Style, these type of rules are not 
checked by the DRC command. 
See Also: AR0111 Specifying the PCB Design Rules and Resolving 
Violations and TR0116 Design Rules Reference. 

ECO/Netlist Design Transfer Once a project is compiled, the equivalent of a netlist load of the design can 
be made using the Design » Update command. This will generate ECOs 
that transfer the schematic information to the target PCB.  

Before transferring the design from schematic to PCB, create and add the 
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PCB file to the .PrjPCB project. Required PCB footprints libraries must be 
available, install them via the Libraries panel. 

Netlists can be exported from Design » Netlist » Export Netlist From PCB

ECO Design Synchronization Keeping the schematic synchronized with the PCB is performed as a direct 
process in Altium Designer, there is no need to generate a netlist or ECO 
file. Design changes, such as annotation and component property updates 
are made in both directions using the Design » Update command. 

See Also: AR0106 Finding Differences and Synchronizing Designs

DRC DRC PCB Design Rule Checking can be performed on-line, or as a batch 
process. Found in the Tools menu.  

See Also: AR0111 Specifying the PCB Design Rules and Resolving 
Violations.

Drill Table .LEGEND Place » String command places a .LEGEND string that is converted into a 
symbol legend for mechanical drill plots at output time (Gerber or ODB++).  

Fixed Locked Each PCB object can be locked by right-clicking on it and selecting 
appropriate Locked command from the context menu.  

Edit; Rename Net Double-click, right-click 
Properties

Double-click on any object to edit its properties in the relevant properties 
dialog. Alternatively, right click on the object and select Properties from the 
context menu. Nets are edited via the PCB panel, or the Design » Netlist 
submenu. 

ERC Error Reporting Electrical Rules Checking is performed during compilation of a project 
according to the error check settings in Projects » Project Options » Error 
Reporting. Any violations detected will display in the Messages panel, 
double-click on an entry to trace an error. 
See Also:  AR0136 Verifying Your Design in Altium Designer

Export Save As As well as different file types, the Save As and Save Copy As command 
are used to export to other formats. Note that Save As will modify the 
project file to reference the new name given in the Save As dialog. To not 
affect the project use the Save Copy As command. 
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Field String Used to display a special string in the workspace (ahead of printout/output 
stage, consider using the Convert Special Strings option in Tools » 
Preferences » PCB Editor. Many display options can also be set from 
here. 

File Design document (sch, 
PCB, etc), Project, Design 
Workspace.

As well as individual schematic (*.SchDoc), PCB (*.PcbDoc) and other 
types of design files, Altium Designer also has the Project file (*.PrjPcb), 
which links together the entire set of files used create the PCB, and the 
Design Workspace (*.DsnWrk) which is a user-defined set of related 
Projects. 
See Also: AP0129 Project Essentials  

Find Errors Browse Violations PCB Rules can be browsed in the PCB panel, set to Rules mode. 
Violations are listed for each rule type, or select [All Rules] to list all 
violations. 
See Also: TR0104 Altium Designer Panels Reference

Force Update Update from Libraries 
(sch)

Used to update components in the schematic design. Full control over the 
level of updating, from full component refresh, to selective 
symbol/model/parameter updates. 
See Also: AP0144 Keeping Components Up-To-Date

Force Update Update from PCB Libraries Used to update all footprints on the board with information from 
corresponding footprints in PCB Footprint libraries (*.PcbLib). The update 
involves a detailed physical comparison library-to-board footprint primitives, 
and can be applied to all footprints on the board. 
See Also: AP0144 Keeping Components Up-To-Date

Hierarchy (Simple) Hierarchical Design Altium Designer supports true hierarchal design, of any complexity. Sub-
sheets are represented by sheet symbols (Modules in P-CAD), connectivity 
is established between sheet entries to ports on the sheet below.  
See Also: AR0123 Connectivity and Multi-Sheet Design

Hierarchy (Complex) Multi-channel Multi-channel design is the ability to reference a child sheet multiple times, 
either by  referencing the same sub-sheet from multiple sheet symbols, or 
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by placing a single sheet-symbol and using the Repeat statement to 
generate an array of sub-sheets.  

Multi-channel design, like complex hierarchy, is built on the architecture of 
multiple instances. The fundamental difference is that there is no need to 
‘flatten’ the design, Altium Designer’s expands the design during 
compilation, mapping the single logical symbol to the many physical PCB 
components.  
See Also: AR0112 Multi-Channel Design Concepts

Options Preferences Preferences In Altium Designer the term preferences is used to describe environment 
settings (as distinct from file settings), such as selection colors, mouse 
wheel behavior, and so on. Preference settings for all editor can be 
accessed via the DXP » Preferences menu, or Tools » Preferences. 

Preferences are Altium Design environment settings that are stored as part 
of the environment and used for all applicable documents being edited in 
that environment – settings persist from one design to the next. Example 
settings include menu customizations, the position of panels, mouse click 
behavior, and how project folders present when a project is opened. 
Found in both the DXP and the Tools menu. 

Options (Display, 
Grid, Board)

Options (Document / 
Project)

Options for documents are settings that are specific to and are stored with 
that document (file-specific settings). Changing a document option affects 
the current document only. Examples include settings for board layers and 
colors, grid settings and measurement units. Document options are found in 
the Design menu. 

Options for projects are settings that are specific to and are stored in only 
the project file. This includes error checking settings, design 
synchronization options, project parameters and print settings. Project 
options are found in the Project menu. 

Padstack / Pad Styles Pad Layer stackup (padstack) can be defined and edited only on a placed pad, 
padstacks cannot be predefined or stored. Padstyle definitions are limited to 
simple shapes – complex pad shapes can be created by placing other 
primitives in the footprint library that extend the pad shape as required. 
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Pattern Footprint They are the same – both define where the component sits on the board. 

Pattern Graphic Multiple Footprints Multiple footprints can be attached to the schematic component, switching 
from one to another can only be done on the schematic.  

Power Ports Power Ports Global net identifier that automatically connects all nets of the same name 
throughout the design. Bus Power Ports are available, these are used in 
FPGA designs. 

Reports (BOM) Reports » Bill of Materials 
or Simple BOM

Options exist for a simple ASCII BOM, or a customizeable BOM report, 
supporting various output formats, including Microsoft Excel using Excel 
templates. BOMs can also be generated from an Output Job file, which is 
added to the project like any other project document.  
See Also: TU0104 Generating a Custom Bill of Materials and TR0127 
OutputJob Editor Reference

Reports 
(Fabrication/Assembly 
only) 

File » Fabrication Outputs 
and Assembly Outputs

CAM outputs can be generated via the File » Assembly Outputs and File 
» Fabrication Outputs. CAM outputs can also be generated from an 
Output Job file, which is added to the project like any other project 
document. 
Details on each output type are available in the Knowledge Center panel, 
Documentation Library > Generating Manufacturing Outputs > Output 
Generation.  

Stack-up diagram Place Stackup Legend Found in the Design » Layer Stack Manager, command places a legend 
on the board. Right-clicking while in this dialog also copies the image to 
clipboard. 

Sub-object Primitive object The set of basic objects used to create group objects (such as 
components), or used in building up the design. 

Templates for designs Templates The templates used when a File » New command is selected are defined in 
the Tools » Preferences System » New Document Defaults. 
Alternatively, use any template by clicking on the New from Template 
options in the Files panel. 

A new Schematic template can be applied to an existing schematic using 
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the Design » Template submenu. 

PCB templates can only be used when creating a new PCB, they cannot be 
applied to an existing one.  

Tie Net Net Tie Component Type Different nets can be connected to each other via a special Net Tie 
component type (a setting in the Component properties dialog). A net tie 
footprint includes shorting-routing between the component pads, creating 
the connection between the nets. When placing components of this type, 
use the Verify Shorting Copper option in DRC to verify that the short 
exists. A net tie component is defined on both the schematic and PCB, and 
be excluded or included in the BOM. 

Trace Track They are the same – both define where the nets are physically laid or 
routed on the board. 

Trace Clean-up Clean All Nets 
 

Used to clean individually routed nets for undesired duplicate (stacked) 
track segments.  A selection of tools for reworking tracks can be found in 
Edit » Move. Found in the Design » Netlist. 

Undo Undo Undo last action. by default will undo groups of the last actions performed. 
Set the size of the undo stack in Tools » Preferences » PCB/SCH Editor » 
General. Can also control if undo actions apply to all in group (eg, all wires 
just placed), or each (the last wire only) using the Group Undo option. 

Variants Assembly Variants Assembly Variants allow alternate population options of the same board. 
Support is included for variant BOMs and pick and place files. Variants are 
defined in the Projects menu. 

See Also: AP0128 Managing Design Variation with Variants
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Revision History 

Date Version No. Revision

20-Jun-2006 1.0 New release 

31-Oct-2006 1.1 Updates made for additional terminology. 

Software, hardware, documentation and related materials:  

Copyright © 2006 Altium Limited. 

All rights reserved. You are permitted to print this document provided that (1) the use of such is for personal use only and will not be copied or posted on 
any network computer or broadcast in any media, and (2) no modifications of the document is made. Unauthorized duplication, in whole or part, of this 
document by any means, mechanical or electronic, including translation into another language, except for brief excerpts in published reviews, is prohibited 
without the express written permission of Altium Limited. Unauthorized duplication of this work may also be prohibited by local statute. Violators may be 
subject to both criminal and civil penalties, including fines and/or imprisonment. Altium, Altium Designer, Board Insight, CAMtastic, CircuitStudio, Design 
Explorer, DXP, LiveDesign, NanoBoard, NanoTalk, Nexar, nVisage, P-CAD, Protel, SimCode, Situs, TASKING, and Topological Autorouting and their 
respective logos are trademarks or registered trademarks of Altium Limited or its subsidiaries. All other registered or unregistered trademarks referenced 
herein are the property of their respective owners and no trademark rights to the same are claimed. 
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