
 

AP0101 (v2.0) December 13, 2004 1 

 

Polygons Pours & 
Copper Regions 

Summary  
Application Note  
AP0101 (v2.0) December 13, 2004   

This application note looks at using polygon pours to create 
regions of solid copper on a PCB. It covers such topics as 
placing and modifying polygon pours, setting properties, 
controlling the clearance using design rules and repouring. 

 

 

A copper pour on a signal layer is a common part of a PCB design. This may be a hatched ground pour 
on an analog design, a solid power supply pour for carrying heavy currents, or a solid ground pour for 
EMC shielding. Designers requiring large areas of solid copper in their PCB designs can use fills or 
copper regions, or polygon pours.  

Fills and Copper Regions 
Fills (Place » Fill) are limited to a rectangular shape and will not pour 
around other objects such as pads, vias, tracks, fills or text.  
A copper region (Place » Copper Region) is a multi-sided solid 
copper area, i.e. a fill with more sides, and will not pour around other 
objects. You can set the layer and net associated with the copper 
region through the Region dialog. If you select the Cutout option, a 
negative copper region is created which will create a cutout when 
placed over a solid polygon pour. 

Polygon Pours 
A Polygon Pour (Place » Polygon Pour) creates large areas of 
solid or hatch-filled copper and, since its outline is made up of a 
series of placed tracks and arcs, it can fill irregularly shaped areas. 
As they are poured, polygon pours allow for clearances around 
electrical objects of a different net or can connect to objects of the 
same net. Clearances can be set using the PCB Clearance design 
rules. 

When you place a polygon pour, you are defining the outline of a 
polygon object. There are two ways that the polygon object can 
filled – solid or hatched. 

Figure 2. A hatched polygon pour 
showing varying clearances 
around electrical objects. 

Figure 1. A selected copper region. 
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Solid pours 
If the polygon pour’s Fill Mode is set to Solid (Copper Regions) in the Polygon Pours dialog, the area 
inside the polygon boundary is filled with copper regions (complying with applicable design rules such 
as copper clearance). It places a copper region in each individual area that it finds within the boundary. 
These areas are created by existing objects such as tracks and pads. 

Hatched pours 
The copper pour for a polygon can be crosshatched at 90 or 45 degrees, or filled with horizontal or 
vertical lines. Thermal considerations may determine the style of hatching used in a design. If you have 
the polygon pour’s Fill Mode set to one of the hatched or line options in the Polygon Pours dialog, it 
first outlines all the objects that are within the boundary using tracks and arcs (routing tracks, pads, 
vias, etc) and then fills in each outlined area with tracks.  

Polygon Pour Cutouts  
Polygon Pour Cutouts are negative copper regions, i.e. they are used for the removal of copper 
definitions. They can only be used to cutout the copper from a solid fill polygon pour. 

  
Figure 3. Polygon Pour Cutout placed on a Solid fill polygon pour (left) and the polygon repoured (right). 

Placing polygons 
Polygons can be placed on any selected layer of a PCB. Select the Place » Polygon Pour command 
and the Polygon Pour dialog (Figure ) displays to allow you to set the fill and net connection options. 
See Setting Polygon Pour properties for more information. Click OK and the cursor changes to a 
crosshair, ready to draw the polygon outline.  

Drawing the outline of a polygon pour is similar to placing tracks during routing, i.e. click to place the 
polygon vertices and right-click (or press ESC) to fill the polygon and exit polygon placement mode. 
While defining the shape of the polygon pour, press the SPACEBAR to cycle through the four polygon 
corner styles of any angle line, 90-degree arc, 45-degree or 90-degree line, as shown below in Figure . 

 
Figure 4. Polygon Pour corner styles 
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Use BACKSPACE to delete the last placed track. There is no need to close the polygon, as DXP will 
automatically complete the shape by adding a track from the start point to the last point placed. This 
‘auto close’ track displays as a white, unfilled track as you place the polygon. 

 
Figure 5. Placing a Polygon Pour showing the auto close track 

Setting Polygon Pour properties 
The Polygon Pour dialog displays when you select the Place » Polygon Pour command from the 
menus or you can press TAB while in placement mode. Alternatively, double-click on a polygon pour, 
or right-click on a selected polygon pour and select Properties.  

 
Figure 6. The Polygon Pour dialog 
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Setting the Fill Mode 
To determine the appearance of the hatching fill used when copper is poured into the polygon pour 
outline, the Hatched (Tracks/Arcs) option is used with a combination of the Grid Size, Track Width 
and Hatch Mode options that become available when you select the Hatched option. The fill will be 
created out of tracks (and arcs) automatically placed according to these settings. The Grid Size 
determines the spacing between the centers of the 
tracks used for hatching. This grid ideally should be a 
fraction of the component pin pitch to allow efficient 
placement of the tracks. Next, set the width of tracks 
used to create the hatching when the polygon is poured.  
To create a solid copper pour, click on the Solid 
(Copper Regions) option and a region of copper will be 
created. You can use Polygon Pour Cutouts with a Solid 
filled polygon. In this mode, you can also Remove 
Islands less than an nominated area and Remove 
Necks when the copper width is less than the 
nominated width. The Arc Approximation option allows 
for a maximum deviation from the perfect arc used when 
the copper is poured around pads or vias (the lower the 
value, the smoother the arc). 
The Fill Mode option None (Outlines Only), i.e. no fill, can be useful during the design phase as it will 
not slow down system performance waiting for repours. Then, select the desired hatching style before 
generating output. 

When polygons are poured, they can contain many short pieces of tracks and arcs, placed to create 
smooth edges around the existing objects on the board. Set the Minimum primitive length as 
appropriate, considering that a larger value gives faster pour times, screen redraws and output 
generation but downgrades the smoothness of the polygon edges. Setting the Surround Pads With 
option to Octagons instead of Arcs has a similar effect on the repour times and smoothing. 
If you are changing a Hatched polygon pour to a Solid pour, use the Tools » Polygon Pours » 
Convert Hatched Polygons to Solid command to set the extents of the repoured polygon as well as 
remove islands and necks and set the arc approximation. 

Defining the net connection styles 
The polygon pour can be attached to a net. 
When a netlist exists in the PCB document, 
enable the Connect to Net option and select the 
required net from the drop-down list. The 
polygon will now connect to each pad on this net 
found within the outline of the polygon, in 
accordance with the Polygon Connect Style 
design rule (see Setting the Polygon Connect 
design rule for more information). 

 

Grid size: 30mil 

Track width: 10mil 

90 degree hatch 

 

Grid size: 20mil 

Track width: 10mil 

45 degree hatch 

Figure 7. Hatching style examples 

Connect to Net +12V. 
 

Connect to Net with Pour 
Over Same Net option on. 

Figure 8. Net Connection examples 
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Figure 9. Connect to Net +12V 
with Remove Dead Copper 
option enabled. 

Polygon pours will automatically pour around any existing electrical objects on a layer (pads, vias, 
tracks, etc). If you want the polygon to automatically connect to objects on the same net as the pour, 
check the Pour Over Same Net option in the Polygon Pour dialog. Any existing tracks within the 
polygon, which are part of the net being connected to, will be covered by the polygon. If this option is 
selected and the polygon is assigned to No Net, it will pour around all objects regardless of their 
assigned nets.  

Removing dead copper 
If the Remove Dead Copper option is enabled, any regions of ‘dead’ 
copper within the polygon will be deleted. Dead copper is created 
when an area of the polygon cannot be connected to the selected net 
and appears as unconnected ‘islands’ of copper within the polygon 
created when existing tracks, pads and vias prevent the polygon 
pouring as one continuous area.  

The entire polygon is removed if it does not enclose any pads on the 
selected net, as it is all viewed as dead copper.  

Controlling the clearance using design rules 
If a violation appears between the polygon and an object, e.g. a pad, you can repour the polygon by 
double-clicking on it and confirming the setup. This results in the polygon pouring around the violating 
object, taking into account clearance and polygon clearance design rules. These design rules may be 
set by using the Design » Rules command. 

Polygon Clearance rule 
Create a Polygon Clearance rule (under Electrical/Clearance in the PCB Rules & Constraints Editor) 
to control the distance between the polygon pour and any other objects, e.g. pads, tracks or fills. When 
creating Clearance rules for 
polygons, you must use the 
InPolygon (or InPoly) keyword, 
rather than IsPolygon (or 
IsPoly). This is because the 
clearance rules operate on the 
primitives (tracks and arcs) that 
make up (or are ‘in’) the polygon, 
rather than the polygon as a whole 
object. A valid clearance rule for 
polygons would be between 
"InPolygon" objects and all other 
objects.  

The Polygon Clearance rule must 
have a higher priority than any 
general clearance rule if it is to 
have any effect (1 is the highest 
priority). 

Figure 10. Polygon Clearance rule in PCB Rules & Constraints Editor 
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Online DRC (design rule check) will show violations but if there are any track width violations, for 
example, they are displayed only once. If you move a polygon or change the clearance, the online 
DRC will not display the violations again. This saves refresh time when large solid polygons are 
present. Run the DRC manually to check for any violations (Tools » Design Rule Check). 

Setting the Polygon Connect design rule 
To control how a polygon connects to pads when the Connect to Net option is used, set the Plane/ 
PolygonConnect design rule (Design » Rules). This rule specifies the style of the connection from a 
component pin to a polygon pour.  

Three connection options are available: direct (solid copper to the pin); thermal relief (the width, 
number and angle of connections can be set) or no connection. 

 
Figure 11. Polygon Connect rule in PCB Rules & Constraints Editor 

Removing copper islands and narrow necks 
If you have set the Fill Mode to Solid, you can enable options to remove islands of copper by 
determining the area threshold (Remove Islands by Area), or remove any copper that is under the 
Copper Width as defined by the Width Threshold (Remove Under Width Copper), such as narrow 
necks of copper. You can also set the Arc Resolution to determine how accurately the fill is drawn 
around other objects, e.g. pads, when the polygon is poured. 

Repouring polygons 
To repour a polygon, click to select and then move the polygon, or press TAB (or double-click) and 
change the settings. Alternatively, right-click on a selected polygon and choose from the Polygon 
Actions » Repour options. Confirm the repour by clicking Yes in the rebuild Confirm dialog. 
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Creating a polygon outline from a set of tracks  
You can create a polygon outline from a set of placed tracks using a process parameter attached to the 
process PCB:RunScissors. Select Customize from the right-click menu when over the menu toolbar, 
copy the Slice Polygon Pour command from the Place menu, rename the caption and change the 
process parameter to (mode=POLY_FROM_SEL_PRIMS). See the Customizing DXP Resources 
tutorial for more information. Then, select the joining tracks required to make the polygon and choose 
this new command. A new unfilled polygon is created on the same layer and with the same shape as 
the selected tracks. These tracks can be deleted if they are no longer required. 

Working with polygons 
Once you have defined the polygon pour, you can move, merge, copy and paste, slice or reshape it. 
Delete selected polygons by pressing the Delete key. 

Moving polygons 
Click and drag to move a polygon. Hold down Shift key to select multiple 
polygons to move. The rebuild Confirm dialog appears when you release 
the mouse button. Click Yes to repour the polygon(s) and refresh the 
screen. 

Merging polygons 
If you move a polygon toward another polygon and both polygons are attached to the same net, they 
will automatically merge. The new outline is visible while merging and you are prompted to pour only 
one. If two merged polygons leave a hole in the resultant polygon, a repour will create one solid 
polygon, as cutouts are not possible. Merged polygons cannot be unmerged back into their original 
outlines. 

Slicing polygons 
The Place » Slice Polygon Pour command is used to slice a single polygon pour into two or more 
separate polygon pours. You are now in slice mode (similar to line placement mode), so click (or press 
ENTER) to anchor a series of vertex points that define the shape of the slice. When defining the slice, 
press SHIFT+SPACEBAR to cycle through the placement modes. Press SPACEBAR to toggle 
between the Start and End modes. Use the BACKSPACE key to remove the last placed slice 
segment. When you have finished defining the slice, right-click (or press ESC). Continue defining more 
slices, or right-click (or press ESC) to exit polygon slice mode. 

A confirmation dialog appears stating how many new polygons will be created. Click Yes and confirm 
that you wish to rebuild the polygons.  

Reshaping polygons 
Selected polygons can be reshaped by clicking on the vertices or midpoints and dragging them to the 
required new location.  
You can also edit the shape by moving and inserting vertices. Right-click and select Polygon Actions 
» Move Vertices. Click and drag on a vertex handle to move the vertex. 

Figure 12. The Rebuild 
confirmation dialog 
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To insert a vertex, click-and-hold on the small midpoint cross in the 
line segment and drag it to where the new vertex is required. Right-
click and confirm to rebuild the new polygon shape. 

If you are having difficulties ‘picking up’ a vertex due to the hatching, 
click on the vertex, zoom out (Page Down) until you see the lines 
attached to the vertex move and then zoom back in (Page Up) to 
place the vertex. 

Shelving polygons 
You may find that some large hatched polygons can take a while to repour, so use the Tools » 
Polygon Pours » Shelve Polygons command to temporarily hide polygons in the design. Use the 
Tools » Polygon Pours » Restore Shelved Polygons to reinstate them. 

Using polygons on non-copper layers 
Polygons can be used on non-copper layers for purely display reasons, e.g. to define separate areas of 
the board. If a polygon is placed on a non-signal layer, it will not pour around existing objects because 
they are not assigned to a net.  

Managing polygons 
For more information about the polygons in your PCB, you can use the Board Information Report or list 
the properties of a polygon and its children. 

Using Reports – Board information 
The number of polygons detected on your PCB can be shown by selecting Reports » Board 
Information. For a detailed listing of the polygon properties, use the List panel. 

Using the List panel to view polygon properties 
Select the polygons that you wish to view in the List panel by using the filter IsPoly in the Filter panel 
(click on the Filter tab or select View » Workspace Panels » PCB » Filter) and click on Apply. 

 
Figure 14. The Filter panel showing the IsPoly query. 

Any polygons in the design will be selected. Open the List panel (select View » Workspace Panels » 
PCB » List) and a list of all polygons in the PCB will appear – both manually placed polygons and 

Figure 13. Moving polygon vertices 
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internal planes (which are system-created polygons). Details such as their location, layer, net and 
copper pour options are also displayed.  

 
Figure 15. The List panel showing the results of an IsPoly query. 

Parent-children attributes, such as the region(s) associated with a solid pour polygon, or the tracks and 
arcs that make up hatched polygons, can be listed by right-clicking on a polygon (Poly) in the Object 
Kind list of the List panel and selecting Show Polygon Children. 

 
Figure 16. The List panel showing the results of an IsPoly query with Show Polygon Children enabled. 

Other uses of polygons 
Polygons are also used by DXP to outline each region of split internal power planes. A split plane is 
therefore just an empty polygon. Split planes can be viewed in the Split Planes Editor in the PCB 
panel. Refer to the Internal Power & Split Planes article for more information. 



Polygon Pours & Copper Regions 

10 AP0101 (v2.0) December 13, 2004 

Revision History 
 

Date Version No. Revision 

9-Dec-2003 1.0 New product release 

13-Dec-2004 2.0 Updates for SP2. Formerly Polygon Planes and Copper Pours. 

Software, hardware, documentation and related materials:  

Copyright © 2004 Altium Limited. 

All rights reserved. You are permitted to print this document provided that (1) the use of such is for personal use 
only and will not be copied or posted on any network computer or broadcast in any media and (2) no modifications 
of the document is made. Unauthorized duplication, in whole or part, of this document by any means, mechanical or 
electronic, including translation into another language, except for brief excerpts in published reviews, is prohibited 
without the express written permission of Altium Limited. Unauthorized duplication of this work may also be 
prohibited by local statute. Violators may be subject to both criminal and civil penalties, including fines and/or 
imprisonment. Altium, CAMtastic, Design Explorer, DXP, LiveDesign, NanoBoard, Nexar, nVisage, P-CAD, Protel, 
Situs, TASKING and Topological Autorouting and their respective logos are trademarks or registered trademarks of 
Altium Limited or its subsidiaries. All other registered or unregistered trademarks referenced herein are the property 
of their respective owners and no trademark rights to the same are claimed. 


	Polygons Pours &�Copper Regions
	Fills and Copper Regions
	Polygon Pours
	Solid pours
	Hatched pours
	Polygon Pour Cutouts
	Placing polygons
	Setting Polygon Pour properties
	Setting the Fill Mode
	Defining the net connection styles
	Removing dead copper

	Controlling the clearance using design rules
	Polygon Clearance rule
	Setting the Polygon Connect design rule

	Removing copper islands and narrow necks
	Repouring polygons
	Creating a polygon outline from a set of tracks

	Working with polygons
	Moving polygons
	Merging polygons
	Slicing polygons
	Reshaping polygons
	Shelving polygons
	Using polygons on non-copper layers

	Managing polygons
	Using Reports – Board information
	Using the List panel to view polygon properties
	Other uses of polygons

	Revision History


