This reference manual describes the PCB Editor and PCB objects.

PCB Editor
Function
The PCB Editor allows you to create, edit and verify the PCB design, as well as generate the output files required to manufacture the printed circuit board.

Editor Environment
When the PCB Editor is active (i.e. a PCB document (*.PcbDoc) is open and active) the main application window will contain:
- a main design window in which to design
- editor-specific menus and toolbars
- workspace panels - both global and editor-specific.

Object placement, routing and graphical editing is carried out on the PCB document which, when opened, appears as a tabbed document view in the main design window.

The use of the main design window in terms of actual design (placement, editing, routing, design rule checking, etc) is outside the scope of this topic and information for such should be sought in the relevant documentation, links to which are provided in the Links section below. The following sections, however, offer useful hints and tips with respect to the main design workspace in general.

Specifying Document Options
Options specific to the active PCB document are defined in the Board Options dialog, which can be accessed by choosing Design » Board Options from the main menus.
This dialog provides controls for defining the various grid systems, specifying the units of measurement to be used and controlling the display and position of an associated (back) sheet on which the board is placed.

To define the layer stack for the active PCB document, choose Design » Layer Stack Manager from the main menus. The Layer Stack Manager dialog will appear.

Visible display of layers in the main design window, and the coloring of each, is defined and controlled from the Board Layers and Colors dialog. Access this dialog by choosing Design » Board Layers & Colors from the main menus.
In each case, use the dialog's ‘What's This Help’ feature to obtain detailed information about each of the options available. Simply click on the question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field or option.

Specifying Workspace Preferences

General workspace preferences - applicable to all PCB documents - are defined on the relevant pages contained within the Protel PCB section of the Preferences dialog. Choosing Tools » Preferences from the main menus will take you to the Protel PCB - General page of this dialog.
Again, use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available across the various pages.

**Right-Click Menus**

Right-clicking in the main design window will pop-up a menu providing commands to access commonly used features such as document options and workspace preferences, as well as commands that are in context with the object currently under the cursor.
Panning

Panning in the workspace can be carried out in the following ways:
- using the horizontal and vertical scroll bars
- using the keyboard arrow keys (holding Shift key for faster movement)
- using the mouse wheel (Roll Up - pan up; Roll Down - pan down; Shift+Roll Up - pan left; Shift+Roll Down - pan right)
- right-click & hold to access the panning hand.

Zooming

Zooming in the workspace can be achieved in the following ways:
- using the Page Up (zoom in) and Page Down (zoom out) keyboard shortcuts. (Hold down the Shift and Ctrl keys to provide finer and coarser zooming respectively)
- using the mouse wheel (Ctrl+Roll Up - zoom in; Ctrl+Roll Down - zoom out).

Changing the Current Layer

One workspace layer is 'current' at any given time. Some design objects, such as tracks, fills, text or single layer pads are placed on the current layer. Other design objects, such as components, multi-layer pads and vias, can be placed without regard to the current layer. Selection (for moving, deleting, etc) is layer-independent - you can perform these operations on any primitives without having to change the current layer.

At the bottom of the main design window there is a tab for each layer that is enabled with respect to its visibility in the workspace (from the Board Layers and Colors dialog).

A layer can be made current by clicking on its corresponding tab. Alternatively, use the + and - keys on the numeric keypad to cycle forward and backward through all enabled layers in the workspace.

Pressing the * key on the numeric keypad will cycle through enabled signal layers for the design.

Selection Memory

Click on the button at the bottom right of the main design window to access the Selection Memory dialog, from where you can control all aspects of the selection memory feature.
For detailed information with respect to the dialog's use, refer to the topic Show selection memory dialog, in the PCB Layout area of the Command Reference.

**Mask Level Controls**

Click on the mask level button at the bottom right of the main design window to access a pop-up containing controls for adjusting the masking level when the mask highlight method is employed as part of temporary or permanent filtering.

The **Mask** slider bar controls the extent of 'dimming' when masking is applied using a permanent filter - e.g. when applying a query from the Filter panel, when browsing design objects using the PCB panel, or when interactively routing.

The **Highlight** slider bar controls the extent of 'dimming' when masking is applied using a temporary filter.

In both cases, moving a slider downwards will result in a greater level of masking - with all design objects not falling under the scope of the applied filter becoming more "dimmed" in the workspace.
Clear Filtering
Click on the **Clear** button at the bottom right of the main design window in order to clear any existing filtering applied to the current PCB document. If the filtering is temporary in nature, you can simply click anywhere inside the main design window in order to clear the filtering. If the applied filtering is permanent in nature, you must use this button, or one of its counterparts which can be found in the respective dialog(s) from which the original filtering was initiated.

Associated Panels
The following workspace panels are specific to the PCB Editor.
Filter Panel
Inspector panel
List panel
PCB panel
Certain workspace panels, although not specific to the PCB Editor, will be used frequently as you design. These include the Projects panel and Messages panel. For a complete listing of all workspace panels, refer to the DXP Panels Reference, which can be found in the DXP Design Environment area of this Online Help System.

Associated Design Objects
For detailed information with respect to the various objects available for PCB design, refer to the PCB Design Objects section of this technical reference. Pressing F1 over a design object in the main design window will access the documentation for that object directly.

Notes
A key feature of the PCB Editor is the way logical and physical (or electrical) connections between the elements in a design are recognized and managed. At all times the PCB Editor monitors the state of the connectivity, adding and removing connection lines as you place and delete tracks.

Autorouting is performed using the Situs Autorouter, which itself is an integral part of the PCB Editor. Situs is a topological autorouter, which uses advanced topological mapping to first define the routing path, then calls on a variety of proven routing algorithms (passes) to convert this 'human-like' path to a high-quality route. The router closely follows PCB electrical and routing rule definitions.

Design Rules
The PCB Editor is a rules-driven environment. As you work in the editor and carry out design changes (such as placing tracks, moving components and autorouting) the editor constantly monitors each action and checks to see if the design still complies with defined design rules.
Design rules collectively form an instruction set for the PCB Editor to follow. Each rule represents a requirement of your design and many of the rules, for example clearance and width constraints, can be monitored as you work by the On-Line Design Rule Checker (DRC). Certain rules are monitored when using additional features of the software, for example routing-based rules when using the Situs
Autorouter to route a design, or signal integrity-based rules used by the Signal Integrity Analyzer when performing a detailed signal integrity analysis of a design.

The PCB Editor provides a powerful interface from where you can define the various design rules as required. The rules themselves are divided into the following ten categories: Electrical; Placement; Routing; Manufacturing; SMT; Plane; Mask; Test Point; High Speed and Signal Integrity. Choose Design » Rules from the main menus to access the PCB Rules and Constraints Editor dialog, from where you can specify rule constraints for your design as required.

Setting up the design rules before you start working on the board allows you to remain focused on the task of designing. With a well-defined set of design rules, you can successfully complete board designs with varying and often stringent design requirements. This is further enhanced by the fact that the PCB Editor allows you to export and import rule sets, enabling you to store and retrieve your favorite design rule configurations, depending on the job at hand.

For more detailed information with respect to the types of design rule available for use and how they can be defined, refer to the Design Rules Reference, located in the PCB Layout area of this Online Help System.
Re-entrant Editing

The PCB Editor includes a powerful feature which allows you to perform a second operation without having to quit from the operation you are currently carrying out. This facility is known as re-entrant editing.

Re-entrant editing allows you to work more flexibly and intuitively. For example, you start placing a track then realize that another track segment must be deleted. There is no need to drop out of Interactive Routing mode. Simply press the Edit Delete shortcut keys (E, D), delete the required track segment, press Esc to drop out of the Edit Delete process and continue interactively routing your design.

The second operation can only be accessed by using its shortcut keys.

A large number of processes can be completed within another process. The number of times another process can be launched before the current process is complete depends on the demands each of these incomplete processes is placing on the software.

Arrangement of panels and toolbars is totally configurable and, once you have set up the working environment to your liking, can be saved using the View » Desktop Layouts » Save Layout command.
PCB Design Objects

Arc

Description
An arc is essentially a circular track segment that can be placed on any layer. Arcs can have a variety of uses in PCB layout. For example, they can be used when defining component outlines on the overlay layers, or on a mechanical layer to indicate the board outline, cut outs, and so on. They can also be used to produce curved paths while interactively routing. Arcs can be open, or closed to create a circle (often referred to as a full circle arc).

Object Type
Primitive design object.

Availability
Arcs are available for placement in both PCB and PCB Library Editors. Four different methods of arc placement are supported, each accessed using separate placement commands:

Place arc by center
This method enables you to place an arc object using the arc center as the starting point. To access placement mode:

PCB Editor
- choose Place » Arc (Center) [P, A] from the PCB Editor main menus
- click the button on the Utility Tools drop-down of the Utilities toolbar

PCB Library Editor
- choose Place » Arc (Center) [P, A] from the PCB Library Editor main menus
- click the button on the PCB Lib Placement toolbar
- right-click in the workspace and choose Place » Arc (Center) from the pop-up menu that appears.

Place arc by edge
This method enables you to place an arc object using the edge of the arc as the starting point. The arc angle is initially fixed at 90°. To access placement mode:
PCB Editor

- choose Place » Arc (Edge) \([P, E]\) from the PCB Editor main menus
- click the button on the Wiring toolbar.

PCB Library Editor

- choose Place » Arc (Edge) \([P, E]\) from the PCB Library Editor main menus
- click the button on the PCB Lib Placement toolbar.

Place arc by edge (any angle)
This method enables you to place an arc object using the edge of the arc as the starting point. The angle of the arc can be any value. To access placement mode:

PCB Editor

- choose Place » Arc (Any Angle) \([P, N]\) from the PCB Editor main menus
- click the button on the Utility Tools drop-down of the Utilities toolbar

PCB Library Editor

- choose Place » Arc (Any Angle) \([P, N]\) from the PCB Library Editor main menus
- click the button on the PCB Lib Placement toolbar.

Place full circle arc
This method enables you to place a 360° (full circle) arc. To access placement mode:

PCB Editor

- choose Place » Full Circle \([P, U]\) from the PCB Editor main menus
- click the button on the Utility Tools drop-down of the Utilities toolbar

PCB Library Editor

- choose Place » Full Circle \([P, U]\) from the PCB Library Editor main menus
- click the button on the PCB Lib Placement toolbar.

Placement
The way in which an arc is placed depends on the particular method of placement that you have chosen to invoke:
Placing an arc starting at the center

After launching the command, the cursor will change to a cross-hair and you will enter arc placement mode. Placement is made by performing the following sequence of actions:

- click or press **Enter** to anchor the center point of the arc
- move the cursor to adjust the radius of the arc, then click or press **Enter** to set it
- move the cursor to adjust the start point for the arc, then click or press **Enter** to anchor it.
- move the cursor to change the position of the arc's end point, then click or press **Enter** to anchor it and complete placement of the arc.

Continue placing further arcs, or right-click or press **Esc** to exit placement mode.

Press the **Spacebar** before defining the arc's end point, to render the arc in the opposite direction.

Placing an arc starting at the edge

After launching the command, the cursor will change to a cross-hair and you will enter arc placement mode. Placement is made by performing the following sequence of actions:

- click or press **Enter** to anchor the start point for the arc
- move the cursor to change the position of the arc's end point, then click or press **Enter** to anchor it and complete placement of the arc.

Continue placing further arcs, or right-click or press **Esc** to exit placement mode.

Press the **Spacebar** before defining the arc's end point, to render the arc in the opposite direction.

Placing an arc starting at the edge (any angle)

After launching the command, the cursor will change to a cross-hair and you will enter arc placement mode. Placement is made by performing the following sequence of actions:

- click or press **Enter** to anchor the start point for the arc
- move the cursor to adjust the radius of the arc, then click or press **Enter** to anchor the center point
- move the cursor to change the position of the arc's end point, then click or press **Enter** to anchor it and complete placement of the arc.

Continue placing further arcs, or right-click or press **Esc** to exit placement mode.

Press the **Spacebar** before defining the arc's end point, to render the arc in the opposite direction.

Placing a full circle arc

After launching the command, the cursor will change to a cross-hair and you will enter arc placement mode. Placement is made by performing the following sequence of actions:

- click or press **Enter** to anchor the center point of the arc
- move the cursor to adjust the radius of the arc, then click or press **Enter** to set it and complete placement of the arc.

Continue placing further arcs, or right-click or press **Esc** to exit placement mode.
**Editing**

The properties of an arc object can be modified before, during and after placement. Editing itself falls into two categories - graphical and non-graphical.

**Non-Graphical editing**

The following three methods of non-graphical editing are available:

**Editing via an associated properties dialog**

This method of editing uses the following dialog to modify the properties of an arc object:

![Arc Properties Dialog](image)

Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Simply click on the question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field or option.

The Arc dialog can be accessed prior to entering placement mode, from the Protel PCB - Defaults page of the Preferences dialog (Tools » Preferences). This allows you to change the default properties for the arc object, which will be applied when placing subsequent arcs.

During placement, the Arc dialog can be accessed by pressing the Tab key.

After placement, the Arc dialog can be accessed in one of the following ways:

- double-clicking on the placed arc object
- selecting the arc object and choosing Properties from the right-click pop-up menu
- choosing the Change command from the Edit menu and then clicking once over the placed arc object.

**Editing via the Inspector panel**

The Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same kind, from one convenient location.
For more detailed information with respect to the content and use of the panel, refer to the Inspector panel topic, in the Protel PCB panels section of the DXP Panels Reference. This technical reference can be found in the DXP Design Environment area of the Online Help System.

**Editing via the List panel**

The List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly inspect and modify object attributes. When used in conjunction with the Filter panel, it enables you to display just those objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy and efficiency.

For more detailed information with respect to the content and use of these panels, refer to the List panel and Filter panel topics, in the Protel PCB panels section of the DXP Panels Reference. This technical reference can be found in the DXP Design Environment area of the Online Help System.

**Graphical editing**

This method of editing allows you to select a placed arc object directly in the workspace and change its size, shape or location, graphically.

When an arc object is selected, the following editing handles are available:

1. **Arc placed by center or edge**
   - Click & drag A to adjust the radius.
   - Click & drag B to adjust the end points.
   - Click anywhere on the arc - away from editing handles - and drag to reposition it. The arc can be rotated or flipped while dragging:
     - press the Spacebar to rotate the arc anti-clockwise or Shift + Spacebar for clockwise rotation. Rotation is in accordance with the value for the Rotation Step, defined on the Protel PCB - General page of the Preferences dialog (Tools » Preferences)
     - press the X or Y keys to flip the arc along the X-axis or Y-axis respectively.

**Notes**

If you attempt to graphically modify an arc object that has its Locked property enabled, a dialog will appear asking for confirmation to proceed with the edit.
Arrows can be placed as layer-specific keepout objects to act, for example, as routing barriers. A keepout arc is simply an arc object with its **Keepout** property enabled. You can therefore either place a standard arc and then enable this property, or use the predefined keepout arc placement commands, available from the **Place » Keepout** sub-menu.

---

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless the **Permanent** option - on the **Protel PCB - Defaults** page of the **Preferences** dialog - is enabled. When this option is enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement session.
**Board Shape**

**Description**
The board shape, also referred to as the board outline, is a closed polygonal shape that defines the boundary, or extents, of the PCB. The board shape is used to determine the extents of the power planes when calculating plane edge pull back, used when defining split planes on internal plane layers and also for calculating the board edge when exporting design data to other tools, such as the 3D viewer.

**Availability & Placement**
The board shape object is only available in the PCB Editor and is automatically placed when you create a new PCB document. As such, it is not an object that can be placed in the traditional sense. You can however, redefine the board shape - in effect discarding the existing shape and placing a new one. You can also redefine the board shape based on selected line and arc objects in the workspace.

**Redefining the board shape**
This feature is accessed by choosing the Design » Board Shape » Redefine Board Shape command from the main menus.

After launching the command, the existing board shape will be displayed green on a black background and the cursor will change to a cross-hair, ready to define the outline of the new board shape.

Placement of the new outline is made by performing the following sequence of actions:
• position the cursor and click to anchor the starting point for the shape
• position the cursor and click to anchor a series of vertex points that define the polygonal outline of the board shape
• after placing the final vertex point, right-click or press Esc to complete placement of the board shape. There is no need to “close” the polygon as the software will automatically complete the shape by connecting the start point to the final point placed.

Upon closing the polygon, the existing board shape will, in effect, be discarded.

Redefining the board shape using selected objects
This method of redefining the board shape allows you to define the required outline for the board using standard track and arc objects. The track and arc segments must be placed to form a closed boundary.

Once the outline is the required shape, simply select all objects defining it and launch the Design » Board Shape » Define from selected objects command from the main menus. The existing board shape will be modified to fill the area defined by your selected boundary.

Editing
The board shape object can not be edited in the usual manner. Non-graphical editing does not apply as it does not have an associated properties dialog. Although it can be selected, it does not appear as an object in either the List or Inspector panels. When selected, the editing handles that appear cannot be used to graphically modify its shape. Modification is possible however, with respect to location, orientation and shape, using available commands from the Design » Board Shape sub-menu, which are detailed in the following sections.

Moving the existing board shape
The existing board shape can be moved within the workspace by choosing the Design » Board Shape » Move Board Shape command from the main menus. After launching the command, the cursor will change to a cross-hair and the board shape will appear floating on the cursor.
Simply move the shape to the required position within the workspace and click or press Enter to effect placement. The display will update accordingly.

The board shape can be rotated or flipped while being moved:

- press the **Spacebar** to rotate the board shape anti-clockwise or **Shift + Spacebar** for clockwise rotation. Rotation is in accordance with the value for the Rotation Step, defined on the Protel PCB - General page of the Preferences dialog (Tools » Preferences)
- press the **X** or **Y** keys to flip the board shape along the X-axis or Y-axis respectively.

**Changing the outline of the existing board shape**

The existing board shape can be edited with respect to its shape, without having to totally redefine it anew, by using the Design » Board Shape » Move Board Vertices command from the main menus. After launching the command, the cursor will change to a cross-hair and the board shape will be displayed with various editing handles, as shown in the example image below:

![Board Shape Editor](image)

Click & drag A to reposition an existing vertex.

Click & drag B to add a new vertex point and reposition as required.

After modifying the board shape as required, right-click or press **Esc** to exit.

**Notes**

While defining the board shape, use the **Spacebar** to cycle through various corner modes. Modes available are: 90 Degrees, 45 Degrees, Arc and Any Angle.

The visible grid will be drawn to fill the area defined by the bounding rectangle of the board shape. This is illustrated in the following image, where the board shape has been rotated to emphasize the area that is occupied by the visible grid.
If you need to move the board shape and all objects currently placed within its bounds, simply select all objects - including the board shape - and then click on any design object and drag the whole to a new location. Again, the entire selection can be rotated and/or flipped while dragging. By pressing the L key, you can flip the design objects contained within the board shape, to the opposite side of the board (e.g. Top layer to Bottom layer).
Component

Description
A component footprint is the representation of a physical device on a PCB. A footprint may include such items as pads for connecting to the pins of a device, a physical outline of the package and device mounting features.

Object Type
Group design object.

Availability
Component footprints are available for placement in the PCB Editor only. Use one of the following methods to place a component footprint:

- choose **Place » Component [P, C]** from the main menus
- click the **button on the Wiring toolbar**
- place a specific component footprint directly from the **Libraries** panel
- place a specific component footprint from within the PCB Library Editor.

Placement
The way in which a component footprint is placed within a PCB design depends on how, and from where, placement mode is invoked.

Placement using menu or toolbar command
After launching the command, the **Place Component** dialog will appear.
Use the dialog to choose the component footprint you wish to place. You can type the name of the footprint directly into the **Footprint** field. In this case, the first matching footprint found in the Available Libraries will be used.

If you are unsure of the name of the footprint, or wish to control from which library the footprint is placed, press the ... button to the right of the field. The **Browse Libraries** dialog will appear, from where you can browse through the currently Available Libraries for the active project. The Available Libraries consist of project libraries, installed libraries and libraries found along search paths defined in the **Search Paths** tab of the **Options for Project** dialog (Project » Project Options).

Clicking the ... button in the **Browse Libraries** dialog will give access to the **Available Libraries** dialog, from where you can add/remove additional libraries to/from the overall list of those available to the project.

The dialog also provides a search facility - accessed by clicking the **Find** button - allowing you to search for a specific component footprint across the Available Libraries or in any library along an external search path.
Once the required footprint has been chosen, set the appropriate designator and any comment text, then click **OK** to close the dialog. You will return to the PCB document and an outline of the component footprint will appear floating on the cursor. Position the footprint at the location required and click or press **Enter** to effect placement.

Continue placing further instances of the same component footprint or right-click or press **Esc** to exit. The **Place Component** dialog will reappear. Either browse for a different component footprint to place or click **Cancel** to exit placement mode.

The component footprint can be rotated or flipped while in placement mode:
- press the **Spacebar** to rotate the footprint anti-clockwise or **Shift + Spacebar** for clockwise rotation. Rotation is in accordance with the value for the **Rotation Step**, defined on the **Protel PCB - General** page of the **Preferences** dialog (**Tools » Preferences**)
- press the **X** or **Y** keys to flip the footprint along the X-axis or Y-axis respectively
- press the **L** key to flip the footprint to the other side of the board.

**Placement from Libraries panel**

Component footprints can be placed onto the active PCB document directly from the **Libraries** panel. With respect to model linking and library management, component footprints to be placed on a Protel PCB document are referred to as ‘Protel Footprints’.

Protel Footprints can be placed from the panel when a Protel PCB document is active in the main design window and the library being browsed is one of the following:
- a Protel Footprint library (**.PcbLib**)
- an integrated library (**.IntLib**) with the suffix `[Protel Footprint]`
- a schematic components library (**.SchLib**) or an integrated library with the suffix `[Components]` and the selected component in the main list has a linked Protel Footprint model that exists in a Protel Footprint library in the Available Libraries list.
When a selected component footprint can be validly placed onto the active document, the **Place** button at the top-right of the panel will become available and its text will change to incorporate the name of that footprint, as illustrated below:

To place a selected component footprint, either:

- click on the **Place** button,
- double-click on the component footprint entry, or
- click on the component footprint entry and drag it into the PCB design workspace.

When placing a Protel Footprint on a Protel PCB document using the first two methods, the **Place Component** dialog will appear, with the selected footprint loaded ready for placement.
Set the appropriate designator and any comment text, then click **OK** to close the dialog. The footprint will appear floating on the cursor. Simply position the footprint as required and click to effect placement.

The component footprint can be rotated or flipped while in placement mode:

- press the **Spacebar** to rotate the footprint anti-clockwise or **Shift + Spacebar** for clockwise rotation. Rotation is in accordance with the value for the **Rotation Step**, defined on the **Protel PCB - General** page of the **Preferences** dialog (Tools » Preferences)
- press the **X** or **Y** keys to flip the footprint along the X-axis or Y-axis respectively
- press the **L** key to flip the footprint to the other side of the board.

Continue placing further instances of the same component footprint or right-click or press **Esc** to exit. The **Place Component** dialog will reappear, set ready for placing another instance of this footprint type, with the designator already incremented. Continue placing instances of the same footprint or other footprints, or press **Cancel** to exit.

When using the click-and-drag placement method, only a single instance of the component footprint is placed. You do not remain in placement mode and the footprint cannot be rotated or flipped.

**Placement from within PCB Library Editor**

Component footprints can be placed onto a PCB document directly from the active PCB Library document. Placement is carried out in one of two ways:

- from the **PCB Library** panel - allows you to place the focused component footprint (which need not necessarily be the active component footprint currently displayed in the main design window)
Simply click (or right-click) on the component footprint you wish to place and choose the Place command from the subsequent pop-up menu that appears.

- by choosing the Tools » Place Component command from the PCB Library Editor main menus.

This command places the active component footprint only.

After launching either command, the last PCB document to have been active (irrespective of the project it belongs to) will be made the active document in the main design window and the Place Component dialog will appear with the chosen component footprint already loaded. Use this dialog to define footprint designator and comment as required and click OK.

The footprint will appear floating on the cursor. Simply position the footprint as required and click to effect placement.

The component footprint can be rotated or flipped while in placement mode:

- press the Spacebar to rotate the footprint anti-clockwise or Shift + Spacebar for clockwise rotation. Rotation is in accordance with the value for the Rotation Step, defined on the Protel PCB - General page of the Preferences dialog (Tools » Preferences)
- press the X or Y keys to flip the footprint along the X-axis or Y-axis respectively
- press the L key to flip the footprint to the other side of the board.

Continue placing further instances of the same component footprint or right-click or press Esc to exit. The Place Component dialog will reappear, set ready for placing another instance of this footprint type, with the designator already incremented. Continue placing instances of the same footprint or other footprints, or press Cancel to exit.

**Editing**

The properties of a component footprint object can be modified before, during and after placement. Editing itself falls into two categories - graphical and non-graphical.

**Non-Graphical editing**

The following three methods of non-graphical editing are available:

**Editing via an associated properties dialog**

This method of editing uses the following dialog to modify the properties of a component footprint object. The header of the dialog reflects which component footprint is currently being edited (in the example image below, U6 is being edited):
Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Simply click on the question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field or option.

The following sections provide an overview of each of the specific regions of the dialog:

**Component Properties**

Use this region of the dialog to define properties for the component, including its location and rotation, the layer it is currently placed on and its type.

Enable the **Lock Prims** option to lock the position of all primitives that make up the component relative to one another. If this option is disabled, you can change the shape of the component on the board.

If the placement of the component is critical, then it can be locked in place to prevent accidental movement or repositioning by the Autoplacer, by enabling the **Locked** option.

**Designator & Comment**

The options in the **Designator** and **Comment** regions are used to change the way the component designator and comment text are displayed on the PCB document, and in relation to the associated component footprint.

**Footprint**

This section of the dialog contains the name of the current footprint model used for the component. The current component footprint model can be changed to any other footprint model available. Use the ... button to the right of this field to open the **Browse Libraries** dialog. From here, you can browse through the currently Available Libraries (project libraries, installed libraries and libraries found along search paths defined in the **Search Paths** tab of the **Options for Project** dialog).
The **Browse Libraries** dialog also provides a search facility - allowing you to search for a specific component footprint model across all Available Libraries or in any library along an external search path. After choosing the required model, you will return to the **Component** dialog. The **Name**, **Library** and **Description** fields of the region will be filled with information associated to the chosen footprint model.

**Schematic Reference Information**

This region of the dialog contains valuable information with respect to the schematic component that the PCB footprint model is linked to.

The **Unique ID** field is used to link the PCB component footprint to the schematic component - particularly useful when synchronizing the PCB document with the source schematic documents after re-annotation. The easiest way to link components is from the PCB, using the **Edit Component Links between Flattened Project and PCB** dialog (Project » Component Links).

The unique ID entry consists of the unique ID of the source schematic component (given at the time of its placement onto the schematic document), prefixed with the unique IDs of any connected sheet symbols that exist in the path to the schematic component's document.

The schematic component's designator and hierarchical document path are also shown, along with any information pertaining to the source schematic library that the schematic component is placed from.

**Dialog Access**

The **Component** dialog can be accessed prior to entering placement mode, from the **Protel PCB - Defaults** page of the **Preferences** dialog (Tools » Preferences). This allows you to change the default properties for the component footprint object, which will be applied when placing subsequent component footprints.

During placement, the **Component** dialog can be accessed by pressing the **Tab** key.

After placement, the **Component** dialog can be accessed in one of the following ways:

- double-clicking on the placed component footprint object
- selecting the component footprint object and choosing **Properties** from the right-click pop-up menu
- choosing the **Change** command from the **Edit** menu and then clicking once over the placed component footprint object.

**Designator and Comment**

The component footprint's Designator and Comment text fields can be formatted independently of the footprint itself. The corresponding properties dialogs for each - the **Designator** and **Comment** dialogs respectively - can be accessed using the three methods described above (replacing component footprint with the relevant object whose properties you wish to view/modify).
Constituent Primitives

If the Lock Prims option in the Component Properties region of the Component dialog is disabled, you will be able to edit the properties of the primitive objects constituting the component footprint, individually and independently. Editing is carried out using the associated properties dialog for a track, arc, pad, etc.

Editing via the Inspector panel

The Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same kind, from one convenient location.

For more detailed information with respect to the content and use of the panel, refer to the Inspector panel topic, in the Protel PCB panels section of the DXP Panels Reference. This technical reference can be found in the DXP Design Environment area of the Online Help System.

Editing via the List panel

The List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly inspect and modify object attributes. When used in conjunction with the Filter panel, it enables you to display just those objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy and efficiency.

For more detailed information with respect to the content and use of these panels, refer to the List panel and Filter panel topics, in the Protel PCB panels section of the DXP Panels Reference. This technical reference can be found in the DXP Design Environment area of the Online Help System.

Graphical editing

This method of editing allows you to select a placed component footprint object directly in the workspace and change its size, shape, location or orientation, graphically.

Changing location or orientation
With the **Lock Prims** option enabled in the **Component Properties** region of the **Component** dialog, the component footprint can only be changed graphically with respect to its location and orientation. As such, no editing handles appear when the object is selected:

Click anywhere on the main body of the footprint and drag to reposition it. The footprint can be rotated or flipped as it is being dragged:

- press the **Spacebar** to rotate the footprint anti-clockwise or **Shift + Spacebar** for clockwise rotation. Rotation is in accordance with the value for the **Rotation Step**, defined on the **Protel PCB - General** page of the **Preferences** dialog (Tools » Preferences)
- press the **X** or **Y** keys to flip the footprint along the X-axis or Y-axis respectively
- press the **L** key to flip the footprint to the other side of the board.

**Changing size and shape**

Component primitives can be added, modified and deleted from a component footprint directly in the PCB workspace. To modify component primitives on the board - graphically - you must first unlock them. This is achieved by disabling the **Lock Prims** option, in the **Component Properties** region of the **Component** dialog. The existing primitives can be modified or deleted as required and then the **Lock Prims** option re-enabled. Refer to the Graphical Editing sections of the corresponding topics for the various applicable primitives, for further information.

You can also add new primitives to a component footprint - again, ensure that the **Lock Prims** option is first disabled. Simply place the new primitives as required, select them and then choose the **Tools » Convert » Add Selected Primitives to Component** command from the main menus.

You will be prompted to choose the component footprint to which you wish to add the primitives to. Click on the footprint - the primitives will be added. After all required primitives are added, re-enable the **Lock Prims** option.

**Graphically changing Designator and Comment fields**

The component footprint's Designator and Comment text fields can be graphically edited separately and independently of the main footprint itself. They are essentially string objects and when selected, a single editing handle becomes available:
Click & drag B to rotate the string about point A.

Click anywhere on the string - away from the editing handle - and drag to reposition it. The string will be held by point A and can be rotated or flipped while dragging:

- press the Spacebar to rotate the string anti-clockwise or Shift + Spacebar for clockwise rotation. Rotation is in accordance with the value for the Rotation Step, defined on the Protel PCB - General page of the Preferences dialog (Tools » Preferences)
- press the X or Y keys to flip the string along the X-axis or Y-axis respectively
- press the L key to flip the string to the other side of the board.

**Notes**

Component footprints can be changed freely. However, if there are netlist connections to the pads the new footprint must have the same used pin numbers available as the previous one. If it does not the warning message "cannot match pads with new footprint" will be displayed and the substitution will be aborted. For example, changing a DIP16 to an SMD16A is a legitimate change as the pin numbers match. Changing a DIP16 to a TO-3 would generate a warning and the change would be aborted. If the change is successful the connection lines will also be updated to remain connected to the appropriate pads.

The unique ID can be reset for a schematic component. The corresponding PCB footprint will still carry the previous ID entry. In this case, you must re-link the two components in the Edit Component Links between Flattened Project and PCB dialog and push the change through to the PCB component footprint.

It is important to note that graphical changes to a component footprint directly on the PCB, through modification of its primitives, affect only that instance of the component footprint. The changes do not affect the component footprint in the source PCB Library document. In general, modifications to component footprints should be carried out within the source footprint library (*.PcbLib) and then the changes pushed through to all instances of those footprints that have been placed on the PCB document, using the applicable Update command available from the PCB Library Editor's main Tools menu or the PCB Library panel.

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless the Permanent option - on the Protel PCB - Defaults page of the Preferences dialog - is enabled. When this option is enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement session.
Component Designators

Component designators will auto-increment by 1 during placement if the initial component has a designator ending with a numeric character. Change the designator of the first component, prior to placement, from the Place Component dialog (accessed upon entering placement mode, or during placement by pressing the Tab key).

To achieve alpha or numeric designator increments other than 1, use the Paste Array feature. Controls for this feature are provided in the Setup Paste Array dialog, accessed by pressing the Paste Array button in the Paste Special dialog (Edit » Paste Special).

By setting the designator of the component prior to copying it to the clipboard and setting the Text Increment field in the Setup Paste Array dialog, the following types of component designator sequences can be placed:

- numeric (e.g. 1, 3, 5)
- alphabetic (e.g. A, B, C)
- alphanumeric (e.g. A1, A2; 1A, 1B; A1, B1; 1A, 2A, etc)

To increment numerically set the Text Increment field to the amount you wish to increment by. For example, if the initial component had a designator of U1 and the Text Increment field was set to 2, the component footprints placed would have the designators U1, U3, U5 and so on.

To increment alphabetically, set the Text Increment field to the letter in the alphabet that represents the number of letters you wish to skip. For example, if the initial component had a designator of 1A and the Text Increment field was set to C, the component footprints placed would have the designators 1A, 1D, 1G and so on.
Connection

Description

Connection lines are the visual representation of the logical connectivity between net objects. Each of these lines, connecting one pin in a net to another pin in the net, is called a From To. The entire set of connections (From Tos) for a design is often referred to as the 'ratsnest'.

The connection lines are subsequently used when interactively routing (or Autorouting) in order to achieve the physical, routed links between the logically connected objects in each net.

Availability & Placement

Default connections (From Tos) are automatically generated and placed by the PCB's Connectivity Analyzer when nets are loaded into the PCB design document (i.e. when importing the design or design changes from the schematic). As such, a connection is not a design object that can be accessed and placed by the user.

Editing

A connection object cannot be edited with respect to properties in the usual manner - it cannot be selected in the workspace, has no corresponding properties dialog and cannot be edited graphically.

The layer upon which connection lines are displayed can be enabled/disabled with respect to its visibility using the corresponding Show option for Connections and From Tos, in the System Colors region of the Board Layers and Colors dialog (Design » Board Layers & Colors).

Define the display color by clicking on the color swatch to bring up the Choose Color dialog, from where you can choose from a range of predefined colors, or create your own custom color.

You can control which connection lines in the entire ratsnest of connections are shown and which are hidden. Use the available commands on the View » Connections sub-menu to:

- show or hide all connection lines for the design
- show or hide all connection lines associated with a chosen net
- show or hide the connection lines for all nets associated with chosen component.
Notes

When the components and connective (net) information is loaded into a PCB design, the pin-to-pin connections are displayed for each net. These connection lines are in fact system-generated From Tos, added and arranged by the PCB Editor to give the shortest overall connection length in each case - a net topology referred to as Shortest.

The topology of part or all of a net can be changed by adding specific, user-defined From Tos. User-defined From Tos are added using the PCB panel configured in From-To Editor mode. For more detailed information, refer to the ‘Using the panel From-To Editor’ section of the PCB panel topic, which can be found in the Protel PCB panels section of the DXP Panels Reference. This technical reference can be found in the DXP Design Environment area of the Online Help System.

A system-generated From To does not appear in the workspace as a separate entity - only the associated pin-to-pin connection line for the From To is displayed, which is used for interactive routing/Autorouting guidance.

A user-defined From To appears in the workspace as a dotted line, separate and distinct from the pin-to-pin connection line that is also displayed when the From To is added. The user-defined From To line controls where the associated pin-to-pin connection line starts and finishes.

If you specify user-defined From Tos for only part of a net, the PCB Editor will set the remaining pin-to-pin connections (system-generated From Tos) to the Shortest topology.

The type of From To determines how the Connectivity Analyzer treats the pin-to-pin connection line when, for example, a net object is moved or part of a net is manually routed:

- **System-generated From To** - the connection line can be moved as required as part of the Connectivity Analyzer's re-optimization to keep the default topology of the net (i.e. Shortest)
- **User-defined From To** - if the From To is not the result of selecting a predefined topology, the connection line is not considered as part of the Connectivity Analyzer's re-optimization process. If the From To is part of a predefined net topology (other than Shortest), the Connectivity Analyzer can include it in re-optimization, so long as the chosen topology is kept.

During component moves all connection lines are automatically hidden, except those that go from a moving component to a non-moving component. If currently hidden, the connection lines that are part of the move are automatically displayed.
Connectivity during Interactive Routing

The PCB Editor is a connectivity-aware design environment. At all stages of routing your design, the software monitors and manages the netlist connectivity. Because the PCB's Connectivity Analyzer automatically monitors the completion status of the net you are routing, you can route without regard to the arrangement of the pin-to-pin connections. Once you complete a connection, the entire net is reanalyzed and connection lines are added and re-optimized as necessary.

There are two distinct advantages to this methodology. The first is that you can route a track to any primitive on the net, you do not have to route between the two points connected by the connection lines. The Connectivity Analyzer monitors your progress and adds and removes the connection lines automatically. The second is that the net connectivity is "unbreakable", you cannot accidentally break it into two unconnected parts. If you delete a track segment, the software detects the break and immediately adds a connection line to restore the net connectivity.

When a net is analyzed and a connection line added, the software automatically adds it based on the topology of the net. By default, all nets have their topology set to shortest. For these nets a from-to is added where the two sub-nets are closest.

If the net has a user-defined topology applied, the connection line is added to maintain the topology and is shown as a dotted line (called a Broken Net Marker), indicating that the net should be routed between these two points to maintain the topology.

If the Smart Track Ends option is enabled on the Protel PCB - General page of the Preferences dialog (Tools » Preferences), the connectivity Analyzer will attempt to keep connection lines attached to the ends of the tracks. For example, if you start routing from a pad, and then stop the routing (leaving the track end in free space), the Analyzer will attach the connection line to the track end.
Coordinate

9790,7760 (mil)

Description
A coordinate is used to mark the horizontal (X) and vertical (Y) distance of a point in the design workspace with respect to the current origin. Coordinates can be placed on any layer.

Object Type
Group design object.

Availability
Coordinates are available for placement in both PCB and PCB Library Editors:

PCB Editor
- choose Place » Coordinate [P, O] from the PCB Editor main menus
- click the button on the Utility Tools drop-down of the Utilities toolbar.

PCB Library Editor
- click the button on the PCB Lib Placement toolbar
- right-click in the workspace and choose Place » Coordinate from the pop-up menu that appears.

Placement
After launching the command, the cursor will change to a cross-hair and you will enter coordinate placement mode. Simply position the cursor and click or press Enter to place a coordinate. Continue placing further coordinates, or right-click or press Esc to exit placement mode.

Editing
The properties of a coordinate object can be modified before, during and after placement. Editing itself falls into two categories - graphical and non-graphical.

Non-Graphical editing
The following three methods of non-graphical editing are available:

Editing via an associated properties dialog
This method of editing uses the following dialog to modify the properties of a coordinate object:
Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Simply click on the question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field or option.

The Coordinate dialog can be accessed prior to entering placement mode, from the Protel PCB - Defaults page of the Preferences dialog (Tools » Preferences). This allows you to change the default properties for the coordinate object, which will be applied when placing subsequent coordinates.

During placement, the Coordinate dialog can be accessed by pressing the Tab key.

After placement, the Coordinate dialog can be accessed in one of the following ways:
- double-clicking on the placed coordinate object
- selecting the coordinate object and choosing Properties from the right-click pop-up menu
- choosing the Change command from the Edit menu and then clicking once over the placed coordinate object.

**Editing via the Inspector panel**

The Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same kind, from one convenient location.

For more detailed information with respect to the content and use of the panel, refer to the Inspector panel topic, in the Protel PCB panels section of the DXP Panels Reference. This technical reference can be found in the DXP Design Environment area of the Online Help System.

**Editing via the List panel**

The List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly inspect and modify object attributes. When used in conjunction with the Filter panel, it enables you to display just those objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy and efficiency.
For more detailed information with respect to the content and use of these panels, refer to the List panel and Filter panel topics, in the Protel PCB panels section of the DXP Panels Reference. This technical reference can be found in the DXP Design Environment area of the Online Help System.

**Graphical editing**

This method of editing allows you to select a placed coordinate object directly in the workspace and change its location graphically. The size and shape of a coordinate object cannot be changed graphically. As such, editing handles are not available when the coordinate object is selected:

Click anywhere on the coordinate and drag to reposition it. The position values are automatically updated as the coordinate is moved.

**Notes**

If you attempt to graphically modify a coordinate object that has its **Locked** property enabled, a dialog will appear asking for confirmation to proceed with the edit.

The coordinate group object is comprised of a string specifying the actual X,Y position and a point marker (small cross of two tracks). In the PCB Editor, coordinate objects can be converted to their set of primitive objects by choosing **Tools » Convert » Explode Coordinate to Free Primitives** from the main menus. Explode a coordinate when you need to reposition the position string without changing the location of the marker. Once exploded, a coordinate object can no longer be manipulated as a group object.

Coordinate units, imperial (mils) or metric (mm), are determined by the **Measurement Unit** setting in the **Board Options** dialog (Design » Board Options).

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless the **Permanent** option - on the **Protel PCB - Defaults** page of the Preferences dialog - is enabled. When this option is enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement session.
Dimension

The PCB dimensioning facility consists of various dimension object types. Click on a particular dimension object within the diagram below, or use the links thereafter, to access more detailed information about each of the types available.

Available Dimensioning Objects

Linear dimension
Angular dimension
Radial dimension
Leader dimension
Datum dimension
Baseline dimension
Center dimension
Linear Diameter dimension
Radial diameter dimension
Standard dimension
Linear Dimension

The linear dimension object places dimensioning information on the current PCB layer, with respect to a linear distance. The dimension value is the distance between the start and end markers (reference points selected by the user) measured in the default units. The references may be objects (tracks, arcs, pads, vias, text, fills, polygons or components) or points in free space.

Object Type
Group design object.

Availability
Linear dimension objects are available for placement in both PCB and PCB Library Editors:

PCB Editor
- choose Place » Dimension » Linear [P, D, L] from the PCB Editor main menus
- click the button on the Place Dimension drop-down of the Utilities toolbar.

PCB Library Editor
Right-click in the workspace and choose Place » Dimension » Linear from the pop-up menu that appears.

Placement
After launching the command, the cursor will change to a cross-hair and you will enter dimension placement mode. Placement is made by performing the following sequence of actions:
- position the cursor and click or press Enter to anchor the dimension start point (this is the first reference point)
- move the cursor and click or press Enter to anchor the dimension end point (this is the second reference point)
- the text can now be initially positioned. Simply move the cursor and click or press Enter when the text is in the desired position, to complete dimension placement.
Continue placing further linear dimensions, or right-click or press Esc to exit placement mode.

The linear dimension object can be rotated during placement. Press the Spacebar to rotate the dimension anti-clockwise or Shift + Spacebar for clockwise rotation. Rotation is in accordance with the value for the Rotation Step, defined on the Protel PCB - General page of the Preferences dialog (Tools » Preferences).
Editing
The properties of a linear dimension object can be modified before, during and after placement. Editing itself falls into two categories - graphical and non-graphical.

Non-Graphical editing
The following three methods of non-graphical editing are available:

Editing via an associated properties dialog
This method of editing uses the following dialog to modify the properties of a linear dimension object:

![Linear Dimension Dialog](image)

Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Simply click on the question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field or option. The Linear Dimension dialog can be accessed prior to entering placement mode, from the Protel PCB - Defaults page of the Preferences dialog (Tools » Preferences). This allows you to change the default properties for the linear dimension object, which will be applied when placing subsequent linear dimensions.

During placement, the Linear Dimension dialog can be accessed by pressing the Tab key.
After placement, the Linear Dimension dialog can be accessed in one of the following ways:
- double-clicking on the placed linear dimension object
- selecting the linear dimension object and choosing Properties from the right-click pop-up menu
• choosing the **Change** command from the **Edit** menu and then clicking once over the placed linear dimension object.

**Editing via the Inspector panel**

The **Inspector** panel enables you to interrogate and edit the properties of one or more design objects in the active document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same kind, from one convenient location.

For more detailed information with respect to the content and use of the panel, refer to the **Inspector** panel topic, in the Protel PCB panels section of the DXP Panels Reference. This technical reference can be found in the DXP Design Environment area of the Online Help System.

**Editing via the List panel**

The **List** panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly inspect and modify object attributes. When used in conjunction with the **Filter** panel, it enables you to display just those objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy and efficiency.

For more detailed information with respect to the content and use of these panels, refer to the List panel and Filter panel topics, in the Protel PCB panels section of the DXP Panels Reference. This technical reference can be found in the DXP Design Environment area of the Online Help System.

**Graphical editing**

This method of editing allows you to select a placed linear dimension object directly in the workspace and change properties such as the position of its text and its reference points, graphically.

When a linear dimension object is selected, the following editing handles are available:

![Graphical Editing Handles](image)

Click & drag **A** or **B** to adjust the dimension text position parallel to the extensions.

Click & drag **C** to move the start point of the dimension.

Click & drag **D** to move the end point of the dimension.

Handles **C** and **D** allow for redefinable references - once the dimension is detached from a reference object it becomes non-referenced and can be moved for attachment to a different reference point or object.

As you drag any of the editing handles, the dimension may be rotated.

If the linear dimension object is totally non-referenced (i.e. it is not attached to any reference design objects) click anywhere on it - away from editing handles - and drag to reposition it. The dimension can be rotated or flipped while dragging. The latter is performed by pressing the **X** or **Y** keys to flip the dimension along the X-axis or Y-axis respectively.
Notes

When dimensioning an object, anchor points become available to you, highlighting where the dimension can be attached. Depending on the location of the cursor in relation to the object, one of the anchor points will highlight in a different color, specifying where the dimension will attach if you proceed to click or press Enter.

You do not have to be exactly on the point for the anchor to highlight.

A linear dimension object can be moved in one of the following three ways:

- selecting both the dimension object and the object that is being dimensioned. The whole can be dragged to a new location as required
- selecting the object that is being dimensioned only. The dimension text will follow the object in its alignment plane only. The dimension extensions will expand/contract to keep the relationship between dimension and object being dimensioned
- selecting the dimension object only. It is important to note that the dimension cannot be moved on its own if it is referenced by a design object. To move the dimension only, it must first be detached from the object(s) it is dimensioning.

If you attempt to graphically modify a linear dimension object that has its **Locked** property enabled, a dialog will appear asking for confirmation to proceed with the edit.

The dimension value automatically updates as you move the start or end points. Likewise, if the position of the object that either reference point of the dimension is anchored to is changed, the dimension will update and expand/contract to reflect this.

When the reference or references to which a dimension object is attached are deleted, a dialog will appear, asking whether the dimension should also be deleted. If the dimension is not deleted, it remains on the PCB sheet, but non-referenced.

Linear dimensions are group objects consisting of text and track segments. They can be converted to their set of primitive objects by choosing **Tools » Convert » Explode Dimension to Free Primitives** from the main menus. Once exploded, a dimension object can no longer be manipulated as a group object.
Any changes made to object properties during placement will cause the default properties for the object to be updated, unless the **Permanent** option - on the **Protel PCB - Defaults** page of the **Preferences** dialog - is enabled. When this option is enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement session.
Angular Dimension

Description
The angular dimension object allows for the dimensioning of angular distances.

Object Type
Group design object.

Availability
Angular dimension objects are available for placement in both PCB and PCB Library Editors:

PCB Editor
- choose **Place » Dimension » Angular** [P, D, A] from the PCB Editor main menus
- click the button on the **Place Dimension** drop-down of the Utilities toolbar.

PCB Library Editor
Right-click in the workspace and choose **Place » Dimension » Angular** from the pop-up menu that appears.

Placement
After launching the command, the cursor will change to a cross-hair and you will enter dimension placement mode. Placement is made by performing the following sequence of actions:
- position the cursor over the first reference object and click or press **Enter** to anchor the first dimension reference (the inside reference)
- move the cursor to the next required position associated with the first object being dimensioned and click or press **Enter** to anchor the second dimension reference (the outside reference)
- position the cursor over the second reference object and click or press **Enter** to anchor the third dimension reference (the inside reference)
- move the cursor to the next required position associated with the second object being dimensioned and click or press **Enter** to anchor the fourth dimension reference (the outside reference)
- place the dimension text as desired for the angle being considered and then click or press **Enter** to complete placement.
Continue placing further angular dimensions, or right-click or press Esc to exit placement mode.

**Editing**

The properties of an angular dimension object can be modified before, during and after placement. Editing itself falls into two categories - graphical and non-graphical.

**Non-Graphical editing**

The following three methods of non-graphical editing are available:

**Editing via an associated properties dialog**

This method of editing uses the following dialog to modify the properties of an angular dimension object:

![Angular Dimension Dialog](image)

Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Simply click on the question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field or option.

The **Angular Dimension** dialog can be accessed prior to entering placement mode, from the Protel PCB - Defaults page of the Preferences dialog (Tools » Preferences). This allows you to change the default properties for the angular dimension object, which will be applied when placing subsequent angular dimensions.

During placement, the **Angular Dimension** dialog can be accessed by pressing the Tab key.

After placement, the **Angular Dimension** dialog can be accessed in one of the following ways:

- double-clicking on the placed angular dimension object
- selecting the angular dimension object and choosing Properties from the right-click pop-up menu
• choosing the Change command from the Edit menu and then clicking once over the placed angular dimension object.

**Editing via the Inspector panel**

The Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same kind, from one convenient location.

For more detailed information with respect to the content and use of the panel, refer to the Inspector panel topic, in the Protel PCB panels section of the DXP Panels Reference. This technical reference can be found in the DXP Design Environment area of the Online Help System.

**Editing via the List panel**

The List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly inspect and modify object attributes. When used in conjunction with the Filter panel, it enables you to display just those objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy and efficiency.

For more detailed information with respect to the content and use of these panels, refer to the List panel and Filter panel topics, in the Protel PCB panels section of the DXP Panels Reference. This technical reference can be found in the DXP Design Environment area of the Online Help System.

**Graphical editing**

This method of editing allows you to select a placed angular dimension object directly in the workspace and change properties such as the position of its text and its reference points, graphically.

When an angular dimension object is selected, the following editing handles are available:

Click & drag A and B to change the position of the dimension text, along the path of the dimension extensions.

Click & drag C and E to detach the dimension from the first reference object.

Click & drag D and F to detach the dimension from the second reference object.

Handles C & E and D & F allow for redefinable references - once the dimension is detached from a reference object it becomes non-referenced and can be moved for attachment to a different reference point or object.
If the angular dimension object is totally non-referenced (i.e. it is not attached to any reference design objects) click anywhere on it - away from editing handles - and drag to reposition it. The angular dimension can be rotated or flipped while dragging:

- press the **Spacebar** to rotate the angular dimension anti-clockwise or **Shift + Spacebar** for clockwise rotation. Rotation is in accordance with the value for the **Rotation Step**, defined on the **Protel PCB - General** page of the **Preferences** dialog (Tools » Preferences)
- press the **X** or **Y** keys to flip the angular dimension along the X-axis or Y-axis respectively.

**Notes**

When dimensioning an object, anchor points become available to you, highlighting where the dimension can be attached. Depending on the location of the cursor in relation to the object, one of the anchor points will highlight in a different color, specifying where the dimension will attach if you proceed to click or press **Enter**.

You do not have to be exactly on the point for the anchor to highlight.

An angular dimension object can be moved in one of the following three ways:

- selecting both the dimension object and the object that is being dimensioned. The whole can be dragged to a new location as required
- selecting the object that is being dimensioned only. The dimension text will follow the object in its alignment plane only. The dimension extensions will expand/contract to keep the relationship between dimension and object being dimensioned
- selecting the dimension object only. It is important to note that the dimension cannot be moved on its own if it is referenced by a design object. To move the dimension only, it must first be detached from the object it is dimensioning.

If you attempt to graphically modify an angular dimension object that has its **Locked** property enabled, a dialog will appear asking for confirmation to proceed with the edit.

The dimension value automatically updates as you move the start or end points. Likewise, if the position of the object that either reference point of the dimension is anchored to is changed, the dimension will update and expand/contract to reflect this.
When the reference or references to which a dimension object is attached are deleted, a dialog will appear, asking whether the dimension should also be deleted. If the dimension is not deleted, it remains on the PCB sheet, but non-referenced.

Angular dimensions are group objects consisting of text and track segments. They can be converted to their set of primitive objects by choosing Tools » Convert » Explode Dimension to Free Primitives from the main menus. Once exploded, a dimension object can no longer be manipulated as a group object.

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless the Permanent option - on the Protel PCB - Defaults page of the Preferences dialog - is enabled. When this option is enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement session.
Radial Dimension

Description
The radial dimension object allows for the dimensioning of a radius with respect to an arc or circle. The dimension can be placed either internally or externally.

Object Type
Group design object.

Availability
Radial dimension objects are available for placement in both PCB and PCB Library Editors:

PCB Editor
- choose Place » Dimension » Radial [P, D, R] from the PCB Editor main menus
- click the button on the Place Dimension drop-down of the Utilities toolbar.

PCB Library Editor
Right-click in the workspace and choose Place » Dimension » Radial from the pop-up menu that appears.

Placement
After launching the command, the cursor will change to a cross-hair and you will enter dimension placement mode. Placement is made by performing the following sequence of actions:
- position the cursor and click or press Enter to anchor the dimension to the desired arc or circle
- move the dimension's arrow pointer to the desired location around the arc or circle. The arrow can be placed either inside or outside and movement is in accordance with the Angular Step value in the Radial Dimension dialog. When the required position has been attained, click or press Enter to lock the arrow in place
- the text can now be initially positioned in relation to the tail of the arrow pointer. Simply move the text into the required position and click or press Enter to complete placement.

Continue placing further radial dimensions, or right-click or press Esc to exit dimension placement mode.
Editing
The properties of a radial dimension object can be modified before, during and after placement. Editing itself falls into two categories - graphical and non-graphical.

Non-Graphical editing
The following three methods of non-graphical editing are available:

Editing via an associated properties dialog
This method of editing uses the following dialog to modify the properties of a radial dimension object:

Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Simply click on the question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field or option.

The Radial Dimension dialog can be accessed prior to entering placement mode, from the Protel PCB - Defaults page of the Preferences dialog (Tools » Preferences). This allows you to change the default properties for the radial dimension object, which will be applied when placing subsequent radial dimensions.

During placement, the Radial Dimension dialog can be accessed by pressing the Tab key.

After placement, the Radial Dimension dialog can be accessed in one of the following ways:

- double-clicking on the placed radial dimension object
- selecting the radial dimension object and choosing Properties from the right-click pop-up menu
- choosing the Change command from the Edit menu and then clicking once over the placed radial dimension object.
Editing via the Inspector panel

The Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same kind, from one convenient location.

For more detailed information with respect to the content and use of the panel, refer to the Inspector panel topic, in the Protel PCB panels section of the DXP Panels Reference. This technical reference can be found in the DXP Design Environment area of the Online Help System.

Editing via the List panel

The List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly inspect and modify object attributes. When used in conjunction with the Filter panel, it enables you to display just those objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy and efficiency.

For more detailed information with respect to the content and use of these panels, refer to the List panel and Filter panel topics, in the Protel PCB panels section of the DXP Panels Reference. This technical reference can be found in the DXP Design Environment area of the Online Help System.

Graphical editing

• This method of editing allows you to select a placed radial dimension object directly in the workspace and change properties such as the position of its text, the location of its arrow pointer and its reference point, graphically.

When an radial dimension object is selected, the following editing handles are available:

Click & drag A to adjust the dimension text position, relative to the ‘tail’ of the arrow pointer.
Click & drag B to adjust the position of the arrow pointer around the circumference of the circle or arc.
Click & drag C to move the start point of the dimension. This handle allows you to redefine the reference - once the dimension is detached from a reference object it becomes non-referenced and can be moved for attachment to a different reference point or object.

If the dimension text is placed within the circumference of the arc or circle, only two of the three editing handles will be available for use - A and C. Editing handle A will assume the additional role of editing handle B.

If the radial dimension object is totally non-referenced (i.e. it is not attached to any reference design objects) click anywhere on it - away from editing handles - and drag to reposition it. The dimension can be rotated or flipped while dragging:
• press the **Spacebar** to rotate the radial dimension anti-clockwise or **Shift + Spacebar** for clockwise rotation. Rotation is in accordance with the value for the **Rotation Step**, defined on the **Protel PCB - General** page of the **Preferences** dialog (**Tools » Preferences**)
• press the **X** or **Y** keys to flip the radial dimension along the X-axis or Y-axis respectively.

**Notes**

A radial dimension object can be moved in one of the following three ways:

• selecting both the dimension object and the object that is being dimensioned. The whole can be dragged to a new location as required
• selecting the object that is being dimensioned only. The dimension text will follow the object in its alignment plane only. The dimension pointer and tail will expand/contract to keep the relationship between dimension and object being dimensioned
• selecting the dimension object only. It is important to note that the dimension cannot be moved on its own if it is referenced by a design object. To move the dimension only, it must first be detached from the object it is dimensioning.

If you attempt to graphically modify a radial dimension object that has its **Locked** property enabled, a dialog will appear asking for confirmation to proceed with the edit.

The dimension value automatically updates as the radius of the arc or circle changes.

When the reference arc or circle to which a radial dimension object is attached is deleted, a dialog will appear, asking whether the dimension should also be deleted. If the dimension is not deleted, it remains on the PCB sheet, but non-referenced.

Radial dimensions are group objects consisting of text and track segments. They can be converted to their set of primitive objects by choosing **Tools » Convert » Explode Dimension to Free Primitives** from the main menus. Once exploded, a dimension object can no longer be manipulated as a group object.

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless the **Permanent** option - on the **Protel PCB - Defaults** page of the **Preferences** dialog - is enabled. When this option is enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement session.
Leader Dimension

Description
The leader dimension object allows for the labeling of an object, point or area. There are three types of leader available: Standard, Round and Square, which reflect the label text either being encapsulated in a circle or square or not at all. The pointer can be an arrow or a dot.

Object Type
Group design object.

Availability
Leader dimension objects are available for placement in both PCB and PCB Library Editors:

PCB Editor
- choose Place » Dimension » Leader [P, D, E] from the PCB Editor main menus
- click the button on the Place Dimension drop-down of the Utilities toolbar.

PCB Library Editor
Right-click in the workspace and choose Place » Dimension » Leader from the pop-up menu that appears.

Placement
After launching the command, the cursor will change to a cross-hair and you will enter dimension placement mode. Placement is made by performing the following sequence of actions:
- position the cursor and click or press Enter to anchor the dimension start point (this is the location of the arrowhead or dot)
- move the cursor and click or press Enter to anchor a series of vertex points that define the shape of the leader
- after placing the final required vertex point, right-click or press Esc to effect placement of the text label and exit placement mode.

Editing
The properties of a leader dimension object can be modified before, during and after placement. Editing itself falls into two categories - graphical and non-graphical.
Non-Graphical editing

The following three methods of non-graphical editing are available:

**Editing via an associated properties dialog**

This method of editing uses the following dialog to modify the properties of a leader dimension object:

![Leader Dimension dialog](image)

Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Simply click on the question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field or option.

The **Leader Dimension** dialog can be accessed prior to entering placement mode, from the **Protel PCB - Defaults** page of the **Preferences** dialog (Tools » Preferences). This allows you to change the default properties for the angular dimension object, which will be applied when placing subsequent angular dimensions.

During placement, the **Leader Dimension** dialog can be accessed by pressing the **Tab** key.

After placement, the **Leader Dimension** dialog can be accessed in one of the following ways:

- double-clicking on the placed leader dimension object
- selecting the leader dimension object and choosing **Properties** from the right-click pop-up menu
- choosing the **Change** command from the **Edit** menu and then clicking once over the placed leader dimension object.

**Editing via the Inspector panel**

The **Inspector** panel enables you to interrogate and edit the properties of one or more design objects in the active document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same kind, from one convenient location.
For more detailed information with respect to the content and use of the panel, refer to the Inspector panel topic, in the Protel PCB panels section of the DXP Panels Reference. This technical reference can be found in the DXP Design Environment area of the Online Help System.

**Editing via the List panel**

The List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly inspect and modify object attributes. When used in conjunction with the Filter panel, it enables you to display just those objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy and efficiency.

For more detailed information with respect to the content and use of these panels, refer to the List panel and Filter panel topics, in the Protel PCB panels section of the DXP Panels Reference. This technical reference can be found in the DXP Design Environment area of the Online Help System.

**Graphical editing**

This method of editing allows you to select a placed leader dimension object directly in the workspace and change properties such as the position of its text, its shape and its reference point, graphically. When a leader dimension object is selected, the following editing handles are available:

Click & drag A to move the start point of the dimension (i.e. the position of the arrowhead). This handle allows you to redefine the reference - once the dimension is detached from a reference object it becomes non-referenced and can be moved for attachment to a different reference point or object.

Click & drag B to move the end point of the dimension (i.e. the position of the text label).

Click & drag intermediate handles to change the shape of the leader.

If the leader dimension object is totally non-referenced (i.e. it is not attached to any reference design objects) click anywhere on it - away from editing handles - and drag to reposition it. The dimension can be rotated or flipped while dragging:

- press the Spacebar to rotate the leader dimension anti-clockwise or Shift + Spacebar for clockwise rotation. Rotation is in accordance with the value for the Rotation Step, defined on the Protel PCB - General page of the Preferences dialog (Tools » Preferences)
- press the X or Y keys to flip the leader dimension along the X-axis or Y-axis respectively.

**Notes**

When dimensioning an object, anchor points become available to you, highlighting where the dimension can be attached. Depending on the location of the cursor in relation to the object, one of the anchor points will highlight in a different color, specifying where the dimension will attach if you proceed to click or press Enter.
You do not have to be exactly on the point for the anchor to highlight.

A leader dimension object can be moved in one of the following three ways:
- selecting both the dimension object and the object that is being dimensioned. The whole can be dragged to a new location as required
- selecting the object that is being dimensioned only. The dimension will follow the object. The segment of the leader dimension - between the arrow/dot and the first defined elbow - will expand/contract to keep the relationship between dimension and object being dimensioned
- selecting the dimension object only. It is important to note that the dimension cannot be moved on its own if it is referenced by a design object. To move the dimension only, it must first be detached from the object it is dimensioning.

If you attempt to graphically modify a leader dimension object that has its **Locked** property enabled, a dialog will appear asking for confirmation to proceed with the edit.

When the reference to which a leader dimension object is attached is deleted, a dialog will appear, asking whether the dimension should also be deleted. If the dimension is not deleted, it remains on the PCB sheet, but non-referenced.

Leader dimensions are group objects consisting of text and track segments. They can be converted to their set of primitive objects by choosing **Tools » Convert » Explode Dimension to Free Primitives** from the main menus. Once exploded, a dimension object can no longer be manipulated as a group object.

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless the **Permanent** option - on the **Protel PCB - Defaults** page of the **Preferences** dialog - is enabled. When this option is enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement session.
**Datum Dimension**

Description
The datum dimension object allows for the dimensioning of a linear distance of a collection of objects, relative to a single reference object. The first object chosen is the 'base'. All subsequent objects are relative to this first object. The dimension value in each case is therefore the distance between each reference object and the 'base', measured in the default units. The references may be tracks, arcs, pads, vias, text, fills, polygons or components.

Object Type
Group design object.

Availability
Datum dimension objects are available for placement in both PCB and PCB Library Editors:

PCB Editor
- choose **Place » Dimension » Datum [P, D, T]** from the PCB Editor main menus
- click the [button on the **Place Dimension** drop-down of the **Utilities** toolbar.

PCB Library Editor
Right-click in the workspace and choose **Place » Dimension » Datum** from the pop-up menu that appears.

Placement
After launching the command, the cursor will change to a cross-hair and you will enter dimension placement mode. Placement is made by performing the following sequence of actions:

- position the cursor and click or press **Enter** to anchor the dimension start point (this is the first reference object or 'base')
- move the cursor to the next required object and click or press **Enter** to anchor the dimension end point (this is the second reference object)
- move the cursor to subsequent reference objects and click or press **Enter**. When all desired objects have been selected, right-click or press **Esc**
• the text can now be initially positioned. Click or press Enter when the text is in the desired position to complete placement and exit placement mode.

The datum dimension object can be rotated during placement. Press the Spacebar to rotate the dimension anti-clockwise or Shift + Spacebar for clockwise rotation. Rotation is in accordance with the value for the Rotation Step, defined on the Protel PCB - General page of the Preferences dialog (Tools » Preferences).

Editing

The properties of a datum dimension object can be modified before, during and after placement. Editing itself falls into two categories - graphical and non-graphical.

Non-Graphical editing

The following three methods of non-graphical editing are available:

Editing via an associated properties dialog

This method of editing uses the following dialog to modify the properties of a datum dimension object:

![Datum Dimension Dialog]

Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Simply click on the question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field or option.

The Datum Dimension dialog can be accessed prior to entering placement mode, from the Protel PCB - Defaults page of the Preferences dialog (Tools » Preferences). This allows you to change the default properties for the datum dimension object, which will be applied when placing subsequent datum dimensions.
During placement, the **Datum Dimension** dialog can be accessed by pressing the **Tab** key.

After placement, the **Datum Dimension** dialog can be accessed in one of the following ways:

- double-clicking on the placed datum dimension object
- selecting the datum dimension object and choosing **Properties** from the right-click pop-up menu
- choosing the **Change** command from the **Edit** menu and then clicking once over the placed datum dimension object.

**Editing via the Inspector panel**

The **Inspector** panel enables you to interrogate and edit the properties of one or more design objects in the active document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same kind, from one convenient location.

For more detailed information with respect to the content and use of the panel, refer to the **Inspector** panel topic, in the Protel PCB panels section of the DXP Panels Reference. This technical reference can be found in the DXP Design Environment area of the Online Help System.

**Editing via the List panel**

The **List** panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly inspect and modify object attributes. When used in conjunction with the **Filter** panel, it enables you to display just those objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy and efficiency.

For more detailed information with respect to the content and use of these panels, refer to the List panel and Filter panel topics, in the Protel PCB panels section of the DXP Panels Reference. This technical reference can be found in the DXP Design Environment area of the Online Help System.

**Graphical editing**

This method of editing allows you to select a placed datum dimension object directly in the workspace and change properties such as the position of its text and its reference points, graphically.

When a datum dimension object is selected, the following editing handles are available:

- Click & drag any of the handles at the text end of the extensions to adjust the dimension text position for all cases simultaneously.
- Click & drag **A** to move the base point of the dimension.
- Click & drag subsequent handles to move each reference individually, with respect to the base.
All handles nearest to the object(s) being dimensioned allow for redefinable references - once the dimension is detached from a reference object it becomes non-referenced and can be moved for attachment to a different reference point or object.

As you drag any of the editing handles, the dimension may be rotated.

If the datum dimension object is totally non-referenced (i.e. it is not attached to any reference design objects) click anywhere on it - away from editing handles - and drag to reposition it. The dimension can be rotated or flipped while dragging. The latter is performed by pressing the X or Y keys to flip the dimension along the X-axis or Y-axis respectively.

**Notes**

When dimensioning an object, anchor points become available to you, highlighting where the dimension can be attached. Depending on the location of the cursor in relation to the object, one of the anchor points will highlight in a different color, specifying where the dimension will attach if you proceed to click or press **Enter**.

![Anchor Points]

You do not have to be exactly on the point for the anchor to highlight.

A datum dimension object can be moved in one of the following three ways:

- selecting both the dimension object and the object(s) being dimensioned. The whole can be dragged to a new location as required
- selecting an object that is being dimensioned only. The dimension text will follow the object in its alignment plane only. The dimension extensions will expand/contract to keep the relationship between dimension and object being dimensioned
- selecting the dimension object only. It is important to note that the dimension cannot be moved on its own if it is referenced by a design object. To move the dimension only, it must first be detached from the object it is dimensioning.

If you attempt to graphically modify a datum dimension object that has its **Locked** property enabled, a dialog will appear asking for confirmation to proceed with the edit.

The dimension value automatically updates as you move the start or end points. Likewise, if the position of the object that either reference point of the dimension is anchored to is changed, the dimension will update and expand/contract to reflect this.
When the reference or references to which a dimension object is attached are deleted, a dialog will appear, asking whether the dimension should also be deleted. If the dimension is not deleted, it remains on the PCB sheet, but non-referenced.

Datum dimensions are group objects consisting of text and track segments. They can be converted to their set of primitive objects by choosing **Tools » Convert » Explode Dimension to Free Primitives** from the main menus. Once exploded, a dimension object can no longer be manipulated as a group object.

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless the **Permanent** option - on the **Protel PCB - Defaults** page of the **Preferences** dialog - is enabled. When this option is enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement session.
Baseline Dimension

Description
The baseline dimension object allows for the dimensioning of a linear distance of a collection of references, relative to a single base reference. The first point chosen is the ‘base’. All subsequent points are relative to this first point. The dimension value in each case is therefore the distance between each reference point and the ‘base’, measured in the default units. The references may be objects (tracks, arcs, pads, vias, text, fills, polygons or components) or points in free space.

Object Type
Group design object.

Availability
Baseline dimension objects are available for placement in both PCB and PCB Library Editors:

PCB Editor
- choose Place » Dimension » Baseline [P, D, B] from the PCB Editor main menus
- click the button on the Place Dimension drop-down of the Utilities toolbar.

PCB Library Editor
Right-click in the workspace and choose Place » Dimension » Baseline from the pop-up menu that appears.

Placement
After launching the command, the cursor will change to a cross-hair and you will enter dimension placement mode. Placement is made by performing the following sequence of actions:
• position the cursor and click or press **Enter** to anchor the dimension start point (this is the first reference point or ‘base’)
• move the cursor to the required end point and click or press **Enter** to anchor the dimension end point (this is the second reference point)
• the text can now be initially positioned. Click or press **Enter** when the text is in the desired position to effect placement
• move the cursor to subsequent reference points and click or press **Enter** twice to effect placement (first click to anchor to a reference and second click after positioning the text)
• when all required references in the baseline dimension have been covered, right-click or press **Esc** to exit placement mode.

The baseline dimension object can be rotated during placement. Press the **Spacebar** to rotate the dimension anti-clockwise or **Shift + Spacebar** for clockwise rotation. Rotation is in accordance with the value for the Rotation Step, defined on the Protel PCB - General page of the Preferences dialog (Tools » Preferences).

**Editing**

The properties of a baseline dimension object can be modified before, during and after placement. Editing itself falls into two categories - graphical and non-graphical.

**Non-Graphical editing**

The following three methods of non-graphical editing are available:

**Editing via an associated properties dialog**

This method of editing uses the following dialog to modify the properties of a baseline dimension object:
Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Simply click on the question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field or option.

The **Baseline Dimension** dialog can be accessed prior to entering placement mode, from the **Protel PCB - Defaults** page of the **Preferences** dialog (Tools » Preferences). This allows you to change the default properties for the baseline dimension object, which will be applied when placing subsequent baseline dimensions.

During placement, the **Baseline Dimension** dialog can be accessed by pressing the **Tab** key.

After placement, the **Baseline Dimension** dialog can be accessed in one of the following ways:

- double-clicking on the placed baseline dimension object
- selecting the baseline dimension object and choosing **Properties** from the right-click pop-up menu
- choosing the **Change** command from the **Edit** menu and then clicking once over the placed baseline dimension object.

**Editing via the Inspector panel**

The **Inspector** panel enables you to interrogate and edit the properties of one or more design objects in the active document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same kind, from one convenient location.

For more detailed information with respect to the content and use of the panel, refer to the **Inspector** panel topic, in the Protel PCB panels section of the DXP Panels Reference. This technical reference can be found in the DXP Design Environment area of the Online Help System.

**Editing via the List panel**

The **List** panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly inspect and modify object attributes. When used in conjunction with the **Filter** panel, it enables you to display just those objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy and efficiency.

For more detailed information with respect to the content and use of these panels, refer to the List panel and Filter panel topics, in the Protel PCB panels section of the DXP Panels Reference. This technical reference can be found in the DXP Design Environment area of the Online Help System.

**Graphical editing**

This method of editing allows you to select a placed baseline dimension object directly in the workspace and change properties such as the position of its text and its reference points, graphically.

When a baseline dimension object is selected, the following editing handles are available:
Click & drag the handles at arrows to adjust the dimension text position parallel to the extensions. Click & drag A to move the base point of the dimension. Click & drag subsequent handles to move each reference individually, with respect to the base.

All handles nearest to the object(s) being dimensioned allow for redefinable references - once the dimension is detached from a reference object it becomes non-referenced and can be moved for attachment to a different reference point or object.

As you drag any of the editing handles, the dimension may be rotated.

If the baseline dimension object is totally non-referenced (i.e. it is not attached to any reference design objects) click anywhere on it - away from editing handles - and drag to reposition it. The dimension can be rotated or flipped while dragging. The latter is performed by pressing the X or Y keys to flip the dimension along the X-axis or Y-axis respectively.

**Notes**

When dimensioning an object, anchor points become available to you, highlighting where the dimension can be attached. Depending on the location of the cursor in relation to the object, one of the anchor points will highlight in a different color, specifying where the dimension will attach if you proceed to click or press Enter.

You do not have to be exactly on the point for the anchor to highlight.

A baseline dimension object can be moved in one of the following three ways:

- selecting both the dimension object and the object that is being dimensioned. The whole can be dragged to a new location as required
• selecting an object that is being dimensioned only. The dimension text will follow the object in its alignment plane only. The dimension extensions will expand/contract to keep the relationship between dimension and object being dimensioned

• selecting the dimension object only. It is important to note that the dimension cannot be moved on its own if it is referenced by a design object. To move the dimension only, it must first be detached from the object it is dimensioning.

If you attempt to graphically modify a baseline dimension object that has its Locked property enabled, a dialog will appear asking for confirmation to proceed with the edit.

The dimension value automatically updates as you move the start or end points. Likewise, if the position of the object that either reference point of the dimension is anchored to is changed, the dimension will update and expand/contract to reflect this.

When the reference or references to which a dimension object is attached are deleted, a dialog will appear, asking whether the dimension should also be deleted. If the dimension is not deleted, it remains on the PCB sheet, but non-referenced.

Baseline dimensions are group objects consisting of text and track segments. They can be converted to their set of primitive objects by choosing Tools » Convert » Explode Dimension to Free Primitives from the main menus. Once exploded, a dimension object can no longer be manipulated as a group object.

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless the Permanent option - on the Protel PCB - Defaults page of the Preferences dialog - is enabled. When this option is enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement session.
Center Dimension

Description
The center dimension object allows for the center of an arc or circle to be marked.

Object Type
Group design object.

Availability
Center dimension objects are available for placement in both PCB and PCB Library Editors:

PCB Editor
- choose Place » Dimension » Center [P, D, C] from the PCB Editor main menus
- click the button on the Place Dimension drop-down of the Utilities toolbar.

PCB Library Editor
Right-click in the workspace and choose Place » Dimension » Center from the pop-up menu that appears.

Placement
After launching the command, the cursor will change to a cross-hair and you will enter dimension placement mode. Placement is made by performing the following sequence of actions:
- position the cursor and click or press Enter to anchor the dimension to the desired arc or circle
- move the dimension until the desired sizing is achieved then click or press Enter to complete placement.
Continue placing further center dimensions, or right-click or press Esc to exit placement mode.
The center dimension object can be rotated during placement. Press the Spacebar to rotate the dimension anti-clockwise or Shift + Spacebar for clockwise rotation. Rotation is in accordance with the value for the Rotation Step, defined on the Protel PCB - General page of the Preferences dialog (Tools » Preferences).

Editing
The properties of a center dimension object can be modified before, during and after placement. Editing itself falls into two categories - graphical and non-graphical.
Non-Graphical editing

The following three methods of non-graphical editing are available:

**Editing via an associated properties dialog**

This method of editing uses the following dialog to modify the properties of a center dimension object:

![Center Dimension dialog](image)

Use the dialog’s 'What’s This Help' feature to obtain detailed information about each of the options available. Simply click on the question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field or option.

The Center Dimension dialog can be accessed prior to entering placement mode, from the Protel PCB - Defaults page of the Preferences dialog (Tools » Preferences). This allows you to change the default properties for the center dimension object, which will be applied when placing subsequent center dimensions.

During placement, the Center Dimension dialog can be accessed by pressing the Tab key.

After placement, the Center Dimension dialog can be accessed in one of the following ways:

- double-clicking on the placed center dimension object
- selecting the center dimension object and choosing Properties from the right-click pop-up menu
- choosing the Change command from the Edit menu and then clicking once over the placed center dimension object.

**Editing via the Inspector panel**
The **Inspector** panel enables you to interrogate and edit the properties of one or more design objects in the active document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same kind, from one convenient location.

For more detailed information with respect to the content and use of the panel, refer to the **Inspector** panel topic, in the Protel PCB panels section of the DXP Panels Reference. This technical reference can be found in the DXP Design Environment area of the Online Help System.

**Editing via the List panel**

The **List** panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly inspect and modify object attributes. When used in conjunction with the **Filter** panel, it enables you to display just those objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy and efficiency.

For more detailed information with respect to the content and use of these panels, refer to the **List** panel and **Filter** panel topics, in the Protel PCB panels section of the DXP Panels Reference. This technical reference can be found in the DXP Design Environment area of the Online Help System.

**Graphical editing**

This method of editing allows you to select a placed center dimension object directly in the workspace and change its size and orientation, graphically.

When an center dimension object is selected, the following editing handles are available:

![Center Dimension Editing Handles]

Click & drag A to change the size of the dimension. As you drag a handle, the dimension may be rotated.

Click & drag B to detach the dimension from the reference object. This handle allows for redefinable references - once the dimension is detached from a reference object it becomes non-referenced and can be moved for attachment to a different reference point or object.

If the center dimension object is totally non-referenced (i.e. it is not attached to a reference design object) click anywhere on it - away from its perimeter editing handles - and drag to reposition it. The dimension can be rotated or flipped while dragging. The latter is performed by pressing the X or Y keys to flip the dimension along the X-axis or Y-axis respectively.

**Notes**

A center dimension object can be moved in one of the following three ways:

- selecting both the dimension object and the circle/arc that is being dimensioned. The whole can be dragged to a new location as required
- selecting the circle/arc that is being dimensioned only. The dimension will move with the object
selecting the dimension object only. It is important to note that the dimension cannot be moved on its own if it is referenced by a design object. To move the dimension only, it must first be detached from the object it is dimensioning.

If you attempt to graphically modify a center dimension object that has its **Locked** property enabled, a dialog will appear asking for confirmation to proceed with the edit.

When the reference arc or circle to which a center dimension object is attached is deleted, a dialog will appear, asking whether the dimension should also be deleted. If the dimension is not deleted, it remains on the PCB sheet, but non-referenced.

Center dimensions are group objects consisting of track segments. They can be converted to their set of primitive objects by choosing **Tools » Convert » Explode Dimension to Free Primitives** from the main menus. Once exploded, a dimension object can no longer be manipulated as a group object.

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless the **Permanent** option - on the **Protel PCB - Defaults** page of the **Preferences** dialog - is enabled. When this option is enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement session.
Linear Diameter Dimension

Description
The linear diameter dimension object allows for the dimensioning of an arc or circle with respect to the diameter, rather than the radius. The dimension can be placed either internally or externally.

Object Type
Group design object.

Availability
Linear diameter dimension objects are available for placement in both PCB and PCB Library Editors:

PCB Editor
- choose Place » Dimension » Linear Diameter [P, D, I] from the PCB Editor main menus
- click the \[P, D, I\] button on the Place Dimension drop-down of the Utilities toolbar.

PCB Library Editor
Right-click in the workspace and choose Place » Dimension » Linear Diameter from the pop-up menu that appears.

Placement
After launching the command, the cursor will change to a cross-hair and you will enter dimension placement mode. Placement is made by performing the following sequence of actions:
- position the cursor and click or press Enter to anchor the dimension to the desired arc or circle. The position of the dimension is determined by the alignment angle for the dimension
- move the dimension text to the desired position (either internal or external) and click or press Enter to complete placement.

Continue placing further linear diameter dimensions, or right-click or press Esc to exit placement mode.

The linear diameter dimension object can be rotated during placement. Press the Spacebar to rotate the dimension anti-clockwise or Shift + Spacebar for clockwise rotation. Rotation is in accordance with the value for the Rotation Step, defined on the Protel PCB - General page of the Preferences dialog (Tools » Preferences).
**Editing**

The properties of a linear diameter dimension object can be modified before, during and after placement. Editing itself falls into two categories - graphical and non-graphical.

**Non-Graphical editing**

The following three methods of non-graphical editing are available:

**Editing via an associated properties dialog**

This method of editing uses the following dialog to modify the properties of a linear diameter dimension object:

![Linear Diameter Dimension dialog](image)

Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Simply click on the question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field or option.

The Linear Diameter Dimension dialog can be accessed prior to entering placement mode, from the Protel PCB - Defaults page of the Preferences dialog (Tools » Preferences). This allows you to change the default properties for the linear diameter dimension object, which will be applied when placing subsequent linear diameter dimensions.

During placement, the Linear Diameter Dimension dialog can be accessed by pressing the Tab key. After placement, the Linear Diameter Dimension dialog can be accessed in one of the following ways:

- double-clicking on the placed linear diameter dimension object
• selecting the linear diameter dimension object and choosing Properties from the right-click pop-up menu
• choosing the Change command from the Edit menu and then clicking once over the placed linear diameter dimension object.

Editing via the Inspector panel

The Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same kind, from one convenient location.

For more detailed information with respect to the content and use of the panel, refer to the Inspector panel topic, in the Protel PCB panels section of the DXP Panels Reference. This technical reference can be found in the DXP Design Environment area of the Online Help System.

Editing via the List panel

The List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly inspect and modify object attributes. When used in conjunction with the Filter panel, it enables you to display just those objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy and efficiency.

For more detailed information with respect to the content and use of these panels, refer to the List panel and Filter panel topics, in the Protel PCB panels section of the DXP Panels Reference. This technical reference can be found in the DXP Design Environment area of the Online Help System.

Graphical editing

This method of editing allows you to select a placed linear diameter dimension object directly in the workspace and change properties such as the position of its text and its reference points, graphically.

When a linear diameter dimension object is selected, the following editing handles are available:

Click & drag A or B to adjust the dimension text position parallel to the extensions.
Click & drag C to move the start point of the dimension.
Click & drag D to move the end point of the dimension.

Handles C & D allow for redefinable references - once the dimension is detached from a reference object it becomes non-referenced and can be moved for attachment to a different reference point or object.
If the linear diameter dimension object is totally non-referenced (i.e. it is not attached to any reference design objects) click anywhere on it - away from editing handles - and drag to reposition it. The dimension can be rotated while dragging.

**Notes**

A linear diameter dimension object can be moved in one of the following three ways:

- selecting both the dimension object and the object that is being dimensioned. The whole can be dragged to a new location as required
- selecting the object that is being dimensioned only. The dimension text will follow the object in its alignment plane only. The dimension extensions will expand/contract to keep the relationship between dimension and object being dimensioned
- selecting the dimension object only. It is important to note that the dimension cannot be moved on its own if it is referenced by a design object. To move the dimension only, it must first be detached from the object it is dimensioning.

If you attempt to graphically modify a linear diameter dimension object that has its **Locked** property enabled, a dialog will appear asking for confirmation to proceed with the edit.

The dimension value automatically updates as the diameter of the reference arc or circle changes.

When the reference arc or circle to which a linear diameter dimension object is attached is deleted, a dialog will appear, asking whether the dimension should also be deleted. If the dimension is not deleted, it remains on the PCB sheet, but non-referenced.

Linear diameter dimensions are group objects consisting of text and track segments. They can be converted to their set of primitive objects by choosing **Tools » Convert » Explode Dimension to Free Primitives** from the main menus. Once exploded, a dimension object can no longer be manipulated as a group object.

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless the **Permanent** option - on the **Protel PCB - Defaults** page of the **Preferences** dialog - is enabled. When this option is enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement session.
Radial Diameter Dimension

Description
The radial diameter dimension object allows for the dimensioning of an arc or circle with respect to the diameter, rather than the radius. The dimension can be placed either internally or externally.

Object Type
Group design object.

Availability
Radial diameter dimension objects are available for placement in both PCB and PCB Library Editors:

PCB Editor
- choose Place » Dimension » Radial Diameter [P, D, M] from the PCB Editor main menus
- click the button on the Place Dimension drop-down of the Utilities toolbar.

PCB Library Editor
Right-click in the workspace and choose Place » Dimension » Radial Diameter from the pop-up menu that appears.

Placement
After launching the command, the cursor will change to a cross-hair and you will enter dimension placement mode. Placement is made by performing the following sequence of actions:
- position the cursor and click or press Enter to anchor the dimension to the desired arc or circle
- move the dimension's arrow pointer to the desired location around the arc or circle. The arrow can be placed either inside or outside and movement is in accordance with the Angular Step value in the Radial Diameter Dimension dialog. When the required position has been attained, click or press Enter to lock the arrow in place
- the text can now be initially positioned in relation to the tail of the arrow pointer. Simply move the text into the required position and click or press Enter to complete placement.

Continue placing further radial diameter dimensions, or right-click or press Esc to exit placement mode.

TR0112 (v1.0) December 01, 2004
Editing
The properties of a radial diameter dimension object can be modified before, during and after placement. Editing itself falls into two categories - graphical and non-graphical.

Non-Graphical editing
The following three methods of non-graphical editing are available:

Editing via an associated properties dialog
This method of editing uses the following dialog to modify the properties of a radial diameter dimension object:

![Radial Diameter Dimension dialog](image)

Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Simply click on the question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field or option.

The Radial Diameter Dimension dialog can be accessed prior to entering placement mode, from the Protel PCB - Defaults page of the Preferences dialog (Tools » Preferences). This allows you to change the default properties for the radial diameter dimension object, which will be applied when placing subsequent radial diameter dimensions.

During placement, the Radial Diameter Dimension dialog can be accessed by pressing the Tab key.

After placement, the Radial Diameter Dimension dialog can be accessed in one of the following ways:
- double-clicking on the placed radial diameter dimension object
- selecting the radial diameter dimension object and choosing Properties from the right-click pop-up menu
choosing the Change command from the Edit menu and then clicking once over the placed radial diameter dimension object.

**Editing via the Inspector panel**

The Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same kind, from one convenient location.

For more detailed information with respect to the content and use of the panel, refer to the Inspector panel topic, in the Protel PCB panels section of the DXP Panels Reference. This technical reference can be found in the DXP Design Environment area of the Online Help System.

**Editing via the List panel**

The List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly inspect and modify object attributes. When used in conjunction with the Filter panel, it enables you to display just those objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy and efficiency.

For more detailed information with respect to the content and use of these panels, refer to the List panel and Filter panel topics, in the Protel PCB panels section of the DXP Panels Reference. This technical reference can be found in the DXP Design Environment area of the Online Help System.

**Graphical editing**

This method of editing allows you to select a placed radial diameter dimension object directly in the workspace and change properties such as the position of its text and its reference point, graphically.

When an radial diameter dimension object is selected, the following editing handles are available:

Click & drag A to adjust the dimension text position, relative to the 'tail' of the arrow pointer.  
Click & drag B to adjust the position of the arrow pointer around the circumference of the circle or arc.  
Click & drag C to move the start point of the dimension. This handle allows you to redefine the reference - once the dimension is detached from a reference object it becomes non-referenced and can be moved for attachment to a different reference point or object.

If the dimension text is placed within the circumference of the arc or circle, only two of the three editing handles will be available for use - A and C. Editing handle A will assume the additional role of editing handle B.
If the radial diameter dimension object is totally non-referenced (i.e. it is not attached to any reference design objects) click anywhere on it - away from editing handles - and drag to reposition it. The dimension can be rotated or flipped while dragging:

- press the **Spacebar** to rotate the radial diameter dimension anti-clockwise or **Shift + Spacebar** for clockwise rotation. Rotation is in accordance with the value for the **Rotation Step**, defined on the **Protel PCB - General** page of the **Preferences** dialog (**Tools » Preferences**)
- press the **X** or **Y** keys to flip the radial diameter dimension along the X-axis or Y-axis respectively.

**Notes**

A radial diameter dimension object can be moved in one of the following three ways:

- selecting both the dimension object and the object that is being dimensioned. The whole can be dragged to a new location as required
- selecting the object that is being dimensioned only. The dimension text will follow the object in its alignment plane only. The dimension pointer and tail will expand/contract to keep the relationship between dimension and object being dimensioned
- selecting the dimension object only. It is important to note that the dimension cannot be moved on its own if it is referenced by a design object. To move the dimension only, it must first be detached from the object it is dimensioning.

If you attempt to graphically modify a radial diameter dimension object that has its **Locked** property enabled, a dialog will appear asking for confirmation to proceed with the edit.

The dimension value automatically updates as the radius of the arc or circle changes.

When the reference arc or circle to which a radial diameter dimension object is attached is deleted, a dialog will appear, asking whether the dimension should also be deleted. If the dimension is not deleted, it remains on the PCB sheet, but non-referenced.

Radial diameter dimensions are group objects consisting of text and track segments. They can be converted to their set of primitive objects by choosing **Tools » Convert » Explode Dimension to Free Primitives** from the main menus. Once exploded, a dimension object can no longer be manipulated as a group object.

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless the **Permanent** option - on the **Protel PCB - Defaults** page of the **Preferences** dialog - is enabled. When this option is enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement session.
Standard Dimension

Description
The standard dimension object places dimensioning information on the current PCB layer. The dimension value is the distance between the start and end markers, measured in the default units.

Object Type
Group design object.

Availability
Standard dimension objects are available for placement in both PCB and PCB Library Editors:

PCB Editor
- choose Place » Dimension » Dimension [P, D, D] from the PCB Editor main menus
- click the button on the Place Dimension drop-down of the Utilities toolbar.

PCB Library Editor
- click the button on the PCB Lib Placement toolbar.
- right-click in the workspace and choose Place » Dimension » Dimension from the pop-up menu that appears.

Placement
After launching the command, the cursor will change to a cross-hair and you will enter dimension placement mode. Placement is made by performing the following sequence of actions:
- position the cursor and click or press Enter to anchor the dimension start point
- move the cursor to the required end point, then click or press Enter to anchor this point and complete placement.

Continue placing further standard dimensions, or right-click or press Esc to exit placement mode.

Editing
The properties of a standard dimension object can be modified before, during and after placement. Editing itself falls into two categories - graphical and non-graphical.

Non-Graphical editing
The following three methods of non-graphical editing are available:

Editing via an associated properties dialog
This method of editing uses the following dialog to modify the properties of a standard dimension object:
Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Simply click on the question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field or option.

The **Dimension** dialog can be accessed prior to entering placement mode, from the **Protel PCB - Defaults** page of the **Preferences** dialog (**Tools » Preferences**). This allows you to change the default properties for the standard dimension object, which will be applied when placing subsequent standard dimensions.

During placement, the **Dimension** dialog can be accessed by pressing the **Tab** key.

After placement, the **Dimension** dialog can be accessed in one of the following ways:

- double-clicking on the placed standard dimension object
- selecting the standard dimension object and choosing **Properties** from the right-click pop-up menu
- choosing the **Change** command from the **Edit** menu and then clicking once over the placed standard dimension object.

**Editing via the Inspector panel**

The **Inspector** panel enables you to interrogate and edit the properties of one or more design objects in the active document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same kind, from one convenient location.

For more detailed information with respect to the content and use of the panel, refer to the **Inspector** panel topic, in the Protel PCB panels section of the DXP Panels Reference. This technical reference can be found in the DXP Design Environment area of the Online Help System.

**Editing via the List panel**

The **List** panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly inspect and modify object attributes. When used in conjunction with the **Filter**
panel, it enables you to display just those objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy and efficiency.

For more detailed information with respect to the content and use of these panels, refer to the List panel and Filter panel topics, in the Protel PCB panels section of the DXP Panels Reference. This technical reference can be found in the DXP Design Environment area of the Online Help System.

**Graphical editing**

This method of editing allows you to select a placed standard dimension object directly in the workspace and change its location, orientation and position of its start and end points, graphically.

When a standard dimension object is selected, the following editing handles are available:

Click & drag A to move the start point of the dimension.
Click & drag B to move the end point of the dimension.
Click anywhere on the standard dimension object - away from editing handles - and drag to reposition it. The dimension can be rotated or flipped while dragging:

- press the **Spacebar** to rotate the standard dimension anti-clockwise or **Shift + Spacebar** for clockwise rotation. Rotation is in accordance with the value for the **Rotation Step**, defined on the **Protel PCB - General** page of the **Preferences** dialog (**Tools » Preferences**)
- press the **X** or **Y** keys to flip the standard dimension along the X-axis or Y-axis respectively.

**Notes**

If you attempt to graphically modify a standard dimension object that has its **Locked** property enabled, a dialog will appear asking for confirmation to proceed with the edit.

The dimension value automatically updates as you move the start or end points.

Standard dimensions are group objects consisting of text and track segments. They can be converted to their set of primitive objects by choosing **Tools » Convert » Explode Dimension to Free Primitives** from the main menus. Once exploded, a dimension object can no longer be manipulated as a group object.

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless the **Permanent** option - on the **Protel PCB - Defaults** page of the **Preferences** dialog - is enabled. When this option is enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement session.
**Fill**

**Description**
A fill is a rectangular object that can be placed on any layer. When placed on a signal layer, a fill becomes an area of solid copper that can be used to provide shielding or to carry large currents. Fills of varying size can be combined to cover irregularly shaped areas and can also be combined with track or arc segments and be connected to a net.

Fills can also be placed on non-electrical layers. For example, place a fill on the Keep-Out layer to designate a ‘no-go’ area for both autorouting and autoplacement. Place a fill on a Power Plane, Solder Mask, or Paste Mask layer, to create a void on that layer.

In the PCB Library Editor, fills can be used to define component footprints.

**Object Type**
Primitive design object.

**Availability**
Fills are available for placement in both PCB and PCB Library Editors:

**PCB Editor**
- choose Place » Fill [P, F] from the PCB Editor main menus
- click the button on the Wiring toolbar.

**PCB Library Editor**
- choose Place » Fill [P, F] from the PCB Library Editor main menus
- click the button on the PCB Lib Placement toolbar
- right-click in the workspace and choose Place » Fill from the pop-up menu that appears.

**Placement**
After launching the command, the cursor will change to a cross-hair and you will enter fill placement mode. Placement is made by performing the following sequence of actions:

- click or press Enter to anchor the first corner of the fill
- move the cursor to adjust the size of the fill, then click or press Enter to anchor the diagonally-opposite corner and thereby complete placement of the fill.

Continue placing further fills, or right-click or press Esc to exit placement mode.
Editing
The properties of a fill object can be modified before, during and after placement. Editing itself falls into two categories - graphical and non-graphical.

Non-Graphical editing
The following three methods of non-graphical editing are available:

Editing via an associated properties dialog
This method of editing uses the following dialog to modify the properties of a fill object:

![Fill dialog](image)

Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Simply click on the question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field or option.

The Fill dialog can be accessed prior to entering placement mode, from the Protel PCB - Defaults page of the Preferences dialog (Tools » Preferences). This allows you to change the default properties for the fill object, which will be applied when placing subsequent fills.

During placement, the Fill dialog can be accessed by pressing the Tab key.

After placement, the Fill dialog can be accessed in one of the following ways:
- double-clicking on the placed fill object
- selecting the fill object and choosing Properties from the right-click pop-up menu
- choosing the Change command from the Edit menu and then clicking once over the placed fill object.
Editing via the Inspector panel

The Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same kind, from one convenient location.

For more detailed information with respect to the content and use of the panel, refer to the Inspector panel topic, in the Protel PCB panels section of the DXP Panels Reference. This technical reference can be found in the DXP Design Environment area of the Online Help System.

Editing via the List panel

The List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly inspect and modify object attributes. When used in conjunction with the Filter panel, it enables you to display just those objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy and efficiency.

For more detailed information with respect to the content and use of these panels, refer to the List panel and Filter panel topics, in the Protel PCB panels section of the DXP Panels Reference. This technical reference can be found in the DXP Design Environment area of the Online Help System.

Graphical editing

This method of editing allows you to select a placed fill object directly in the workspace and change its size, shape or location, graphically.

When a fill object is selected, the following editing handles are available:

- Click & drag A to resize the fill in the vertical and horizontal directions separately.
- Click & drag B to resize the fill in the vertical and horizontal directions simultaneously.
- Click & drag C to rotate the fill about its center point.
- Click anywhere on the fill - away from editing handles - and drag to reposition it. The fill can be rotated or flipped while dragging:
  - press the Spacebar to rotate the fill anti-clockwise or Shift + Spacebar for clockwise rotation.
    Rotation is in accordance with the value for the Rotation Step, defined on the Protel PCB - General page of the Preferences dialog (Tools » Preferences)
  - press the X or Y keys to flip the fill along the X-axis or Y-axis respectively.

Notes

A fill will 'adopt' a net name if the first corner is placed on an object which has a net name.
If you attempt to graphically modify a fill object that has its **Locked** property enabled, a dialog will appear asking for confirmation to proceed with the edit.

Fills can be placed as layer-specific keepout objects to act, for example, as routing barriers. A keepout fill is simply a fill object with its **Keepout** property enabled. You can therefore either place a standard fill and then enable this property, or use the predefined keepout fill placement command, available from the **Place » Keepout** sub-menu.

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless the **Permanent** option - on the **Protel PCB - Defaults** page of the **Preferences** dialog - is enabled. When this option is enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement session.
User-defined From To

Description
User-defined From Tos allow you to create specific net topologies within a design, giving you total control over the arrangement, or pattern, of pin-to-pin connections in a net. They are different to system-generated From Tos, added and arranged by the PCB Editor to give the shortest overall connection length in each case - a net topology referred to as Shortest. Displayed in the workspace as pin-to-pin connection lines, From Tos are collectively referred to as the 'ratsnest'.

Availability & Placement
User-defined From Tos can be added for part or all of a net using the From-To Editor, available from the PCB panel.

For more detailed information, refer to the 'Using the panel From-To Editor' section of the PCB panel topic, which can be found in the Protel PCB panels section of the DXP Panels Reference. This technical reference can be found in the DXP Design Environment area of the Online Help System.
Editing

A user-defined From To object cannot be edited with respect to properties in the usual manner - it cannot be selected in the workspace, has no corresponding properties dialog and cannot be edited graphically.

The layer upon which user-defined From To lines are displayed can be enabled/disabled with respect to its visibility using the corresponding Show option for Connections and From Tos, in the System Colors region of the Board Layers and Colors dialog (Design » Board Layers & Colors).

<table>
<thead>
<tr>
<th>System Colors (Y)</th>
<th>Color</th>
<th>Show</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connections and From Tos</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Define the display color by clicking on the color swatch to bring up the Choose Color dialog, from where you can choose from a range of predefined colors, or create your own custom color.

The display of user-defined From Tos is controlled from the From To Display Settings dialog, accessed by clicking the Settings button in the From Tos region, on the Protel PCB - Show/Hide page of the Preferences dialog (Tools » Preferences).

By default, display of user-defined From Tos is set to Automatic. In this mode, the From Tos can only be viewed when the PCB panel is configured in From-To Editor mode. To be able to see user-defined From Tos when browsing nets or components in the design (PCB panel in Nets or Components modes), set the display mode to Always.
Notes
A system-generated From To does not appear in the workspace as a separate entity - only the associated pin-to-pin connection line for the From To is displayed, which is used for interactive routing/Autorouting guidance.

A user-defined From To appears in the workspace as a dotted line, separate and distinct from the pin-to-pin connection line that is also displayed when the From To is added. The user-defined From To line controls where the associated pin-to-pin connection line starts and finishes. This is best demonstrated by example. Consider a user-defined From To added between the logically connected pins of two components. A connection line is also added and displayed (PCB panel configured in Nets mode; From To display set to Always):

The pin-to-pin connection line - used for routing purposes - conceals the presence of the distinctly separate user-defined From To line. However, as you start to route the connection, you can see the distinct and separate nature of the two lines:

If the routing is now suspended, the Connectivity Analyzer adds a connection line so as to maintain the required topology which is shown as a dotted line (called a Broken Net Marker), indicating that the net should be routed between these two points to maintain the topology determined by the user through the addition of the user-defined From To:

If you specify user-defined From Tos for only part of a net, the PCB Editor will set the remaining pin-to-pin connections (system-generated From Tos) to the Shortest topology.

The type of From To determines how the Connectivity Analyzer treats the connection line in the workspace when, for example, a net object is moved or part of a net is manually routed:
• **System-generated From To** - the connection line can be moved as required as part of the Connectivity Analyzer's re-optimization to keep the default topology of the net (i.e. Shortest)

• **User-defined From To** - if the From To is not the result of selecting a predefined topology, the connection line is not considered as part of the Connectivity Analyzer's re-optimization process. If the From To is part of a predefined net topology (other than Shortest), the Connectivity Analyzer can include it in re-optimization, so long as the chosen topology is kept.
Pad

Description
A pad is a design object that is used to create an interconnection point from a component pin to the routing on the board. Pads can be used individually as free pads in a design or, more typically, they are used in the PCB Library Editor, where they are incorporated with other primitives into component footprints.

Object Type
Primitive design object.

Availability
Pads are available for placement in both PCB and PCB Library Editors:

PCB Editor
- choose Place » Pad [P, P] from the PCB Editor main menus
- click the button on the Wiring toolbar.

PCB Library Editor
- choose Place » Pad [P, P] from the PCB Library Editor main menus
- click the button on the PCB Lib Placement toolbar
- right-click in the workspace and choose Place » Pad from the pop-up menu that appears.

Placement
After launching the command, the cursor will change to a cross-hair and you will enter pad placement mode. Simply position the cursor and click or press Enter to place a pad. Continue placing further pads, or right-click or press Esc to exit placement mode.
When placing SMD or single layer pads, use the * key (on the numeric keypad) to toggle enabled signal layers. Use the + or - keys (on the numeric keypad) to toggle up and down through all enabled layers.

Editing
The properties of a pad object can be modified before, during and after placement. Editing itself falls into two categories - graphical and non-graphical.

Non-Graphical editing
The following three methods of non-graphical editing are available:
Editing via an associated properties dialog

This method of editing uses the following dialog to modify the properties of a pad object:

Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Simply click on the question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field or option.

When editing pad size and shape, three levels of editing are available:

- **Simple** - specify a size and shape which is used for the pad on each affected layer in the pad stack
- **Top-Middle-Bottom** - specify a different size and shape for the pad on the top, mid and bottom layers of the pad stack respectively
- **Full Stack** - allows you to define the pad size and shape for each of the affected layers in the pad stack, on a layer-by-layer basis. Editing of the full pad stack is carried out in the Pad Layer Editor dialog, accessed by clicking the Edit Full Pad Layer Definition button:

Dialog Access

The *Pad* dialog can be accessed prior to entering placement mode, from the *Protel PCB - Defaults* page of the *Preferences* dialog (*Tools » Preferences*). This allows you to change the default properties for the pad object, which will be applied when placing subsequent pads.

During placement, the *Pad* dialog can be accessed by pressing the *Tab* key.
After placement, the **Pad** dialog can be accessed in one of the following ways:

- double-clicking on the placed pad object
- selecting the pad object and choosing **Properties** from the right-click pop-up menu
- choosing the **Change** command from the **Edit** menu and then clicking once over the placed pad object.

**Editing via the Inspector panel**

The **Inspector** panel enables you to interrogate and edit the properties of one or more design objects in the active document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same kind, from one convenient location.

For more detailed information with respect to the content and use of the panel, refer to the **Inspector** panel topic, in the Protel PCB panels section of the DXP Panels Reference. This technical reference can be found in the DXP Design Environment area of the Online Help System.

**Editing via the List panel**

The **List** panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly inspect and modify object attributes. When used in conjunction with the **Filter** panel, it enables you to display just those objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy and efficiency.

For more detailed information with respect to the content and use of these panels, refer to the List panel and Filter panel topics, in the Protel PCB panels section of the DXP Panels Reference. This technical reference can be found in the DXP Design Environment area of the Online Help System.

**Graphical editing**

This method of editing allows you to select a placed pad object directly in the workspace and change its location graphically. The size and shape of a pad object cannot be changed graphically. As such, editing handles are not available when the pad object is selected:

1. Click anywhere on the pad and drag to reposition it. The pad can be rotated or flipped while dragging:
   - press the **Spacebar** to rotate the pad anti-clockwise or **Shift + Spacebar** for clockwise rotation. Rotation is in accordance with the value for the **Rotation Step**, defined on the **Protel PCB - General** page of the Preferences dialog (Tools » Preferences)
   - press the **X** or **Y** keys to flip the pad along the X-axis or Y-axis respectively.

**Notes**

- Pads can be multi-layer (appearing on all signal and plane layers), or single layer and can also be connected to a net. Multi-layer pads can have a different shape defined on each layer and require a drill hole to connect the various layers. Single layer pads should not include a drill hole.
Pad shapes can be circular, rectangular, rounded rectangular (i.e. circular with different X and Y sizes), or octagonal.

Pads automatically connect to an internal power plane layer that is assigned the same net name. The pad will connect in accordance with the applicable Power Plane Connect Style design rule. If you do not want pads to connect to power planes, add another Power Plane Connect Style design rule targeting the specific pads required and with a connection style of No Connect.

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless the Permanent option - on the Protel PCB - Defaults page of the Preferences dialog - is enabled. When this option is enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement session.

**Tenting**

Partial and complete tenting of pads can be achieved by defining an appropriate value for Solder Mask Expansion. This expansion constraint can either be defined on a pad-by-pad basis, in the associated Pad dialog, or by defining appropriate Solder Mask Expansion design rules:

- to partially tent a pad - covering the land area only - set the Expansion to a negative value that will close the mask right up to the pad hole
- to completely tent a pad - covering the land and hole - set the Expansion to a negative value equal to or greater than the pad radius
- to tent all pads on a single layer, set the appropriate Expansion value and ensure that the scope (Full Query) of a Solder Mask Expansion rule targets all pads on the required layer
- to completely tent all pads in a design, in which varying pad sizes are defined, set the Expansion to a negative value equal to or greater than the largest pad radius.

When tenting an individual pad, options are available to follow the expansion defined in the applicable design rule, or to override the rule and apply a specified expansion directly to the individual pad in question.

**Pad Designators**

Pads can be labelled with a designator (usually representing a component pin number) of up to 20 alphanumeric characters in length. Pad designators will auto-increment by 1 during placement if the initial pad has a designator ending with a numeric character. Change the designator of the first pad, prior to placement, from the Pad dialog (accessed during placement by pressing the Tab key).

To achieve alpha or numeric designator increments other than 1, use the Paste Array feature. Controls for this feature are provided in the Setup Paste Array dialog, accessed by pressing the Paste Array button in the Paste Special dialog (Edit » Paste Special).
By setting the designator of the pad prior to copying it to the clipboard and setting the Text Increment field in the Setup Paste Array dialog, the following types of pad designator sequences can be placed:

- numeric (e.g. 1, 3, 5)
- alphabetic (e.g. A, B, C)
- alphanumeric (e.g. A1, A2; 1A, 1B; A1, B1; 1A, 2A, etc)

To increment numerically set the Text Increment field to the amount you wish to increment by. To increment alphabetically, set the Text Increment field to the letter in the alphabet that represents the number of letters you wish to skip. For example, if the initial pad had a designator of 1A and the Text Increment field was set to C, the pads placed would have the designators 1A, 1D, 1G and so on.
Polygon Plane

Description
A polygon plane object creates a solid or hatch-filled (lattice) area on the selected PCB layer. Polygon planes (or copper pours) are similar to area fills, except that they can fill irregularly shaped areas of a board and can connect to a specified net as they are poured.

Object Type
Group design object.

Availability
Polygon Planes are available for placement in the PCB Editor only. Use one of the following methods to access the placement command:

- choose Place » Polygon Plane [P, G] from the main menus
- click the button on the Wiring toolbar.

Placement
After launching the command, the Polygon Plane dialog will open:
Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Simply click on the question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field or option.

After defining the options as required, click **OK**. The cursor will change to a cross-hair and you will enter polygon plane placement mode. Placement is made by performing the following sequence of actions:

- position the cursor and click to anchor the starting point for the polygon plane
- position the cursor and click to anchor a series of vertex points that define the polygonal shape of the plane
- after placing the final vertex point, right-click or press **Esc** to complete placement of the polygon plane. There is no need to "close" the polygon as the software will automatically complete the shape by connecting the start point to the final point placed.

**Editing**

The properties of a polygon plane object can be modified before, during and after placement. Editing itself falls into two categories - graphical and non-graphical.

**Non-Graphical editing**

The following three methods of non-graphical editing are available:

**Editing via an associated properties dialog**

This method of editing uses the following dialog to modify the properties of a polygon plane object:
Use the dialog’s ‘What’s This Help’ feature to obtain detailed information about each of the options available. Simply click on the question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field or option.

The **Polygon Plane** dialog can be accessed prior to entering placement mode, from the **Protel PCB - Defaults** page of the **Preferences** dialog (Tools » Preferences). This allows you to change the default properties for the polygon plane object, which will be applied when placing subsequent polygon planes. During placement, the **Polygon Plane** dialog can be accessed by pressing the Tab key.

After placement, the **Polygon Plane** dialog can be accessed in one of the following ways:

- double-clicking on the placed polygon plane object
- selecting the polygon plane object and choosing **Properties** from the right-click pop-up menu
- choosing the **Change** command from the **Edit** menu and then clicking once over the placed polygon plane object.

**Editing via the Inspector panel**

The **Inspector** panel enables you to interrogate and edit the properties of one or more design objects in the active document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same kind, from one convenient location.

For more detailed information with respect to the content and use of the panel, refer to the **Inspector** panel topic, in the Protel PCB panels section of the DXP Panels Reference. This technical reference can be found in the DXP Design Environment area of the Online Help System.

**Editing via the List panel**

The **List** panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly inspect and modify object attributes. When used in conjunction with the **Filter**
panel, it enables you to display just those objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy and efficiency.

For more detailed information with respect to the content and use of these panels, refer to the List panel and Filter panel topics, in the Protel PCB panels section of the DXP Panels Reference. This technical reference can be found in the DXP Design Environment area of the Online Help System.

**Graphical editing**

This method of editing allows you to select a placed polygon plane object directly in the workspace and change its size, shape or location, graphically.

When a polygon plane object is selected, the following editing handles are available:

Click & drag **A** to resize the polygon plane in the vertical and horizontal directions separately.

Click & drag **B** to resize the polygon plane in the vertical and horizontal directions simultaneously.

Click anywhere on the polygon plane - away from editing handles - and drag to reposition it. The polygon plane can be rotated or flipped while dragging:

- press the **Spacebar** to rotate the polygon plane anti-clockwise or **Shift + Spacebar** for clockwise rotation. Rotation is in accordance with the value for the **Rotation Step**, defined on the **Protel PCB - General** page of the **Preferences** dialog (**Tools » Preferences**)
- press the **X** or **Y** keys to flip the polygon plane along the X-axis or Y-axis respectively.

After resizing, moving, rotating or flipping, a confirmation dialog will appear asking if you want to rebuild the polygon - essentially repouring it within the newly-sized/repositioned boundary. Clicking **Yes** will effect the modification.

To graphically modify the boundary shape of a polygon plane, you will need to launch the **Edit » Move » Polygon Vertices** command. After launching the command, simply click inside the polygon plane to be modified. Filtering will be applied to the document, resulting in the chosen polygon plane object remaining visible and all other objects becoming dimmed.

The boundary track editing handles for the polygon plane will be displayed:
Click on a corner editing handle (A) to move the handle and modify the polygon boundary. Click on the center handle in a track segment (B) to break the track and add a new vertex.

Continue modifying the shape of the polygon as required or right-click or press Esc to stop. A confirmation dialog will appear asking if you want to rebuild the polygon - essentially repouring it within the new boundary. Click Yes to effect the changes you have made.

**Notes**

Polygons can be poured on any layer:

- when placed in occupied board space on a signal layer, polygon planes will automatically pour copper around any existing electrical objects (tracks, pads, vias, fills, etc) while maintaining the clearances specified in the design rules. If you want a plane to automatically connect to objects on the same net as the plane, enable the Pour Over Same Net option in the Polygon Plane dialog. If this option is selected and the plane is assigned to No Net, it will pour around all objects regardless of their net assignments
- if a polygon is placed on a non-signal layer it will not be poured around existing objects, as these objects are not assigned to a net and therefore do not belong to anything.

To create a solid-filled polygon plane, make the Track Width slightly larger than the Grid Size in the Polygon Plane dialog. This will cause adjacent tracks that make up the polygon hatching to overlap, creating a solid fill.

If you want to place a polygon plane but do not want it to slow system performance, set the Hatching Style to None. This will place the polygon with outline tracks only - inside tracks will not be placed. You can then repour the polygon at a later stage with the desired hatching.

When a polygon plane is poured around component pads, you can choose whether such pads are surrounded by arcs or octagons (from the Polygon Plane dialog):

Octagons give smaller Gerber files and faster photoplotting.
To control how a polygon plane connects to pads when the **Connect to Net** option is used, include a Polygon Connect Style design rule.

Polygon planes are group objects made up of a series of tracks and arcs. They can be converted to their set of primitive objects by choosing **Tools » Convert » Explode Polygon to Free Primitives** from the main menus. Once exploded, a polygon plane object can no longer be manipulated as a group object.

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless the **Permanent** option - on the **Protel PCB - Defaults** page of the **Preferences** dialog - is enabled. When this option is enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement session.
### Room

![RoomDefinition](image)

**Description**
Rooms are regions that assist in the placement of components. Rectangular or polygonal shaped rooms can be placed on either the top or bottom layer of the board and can either be placed empty - associating components at a later stage - or placed around components in the design, automatically associating them to the room. Alternatively, orthogonal, non-orthogonal and rectangular shaped rooms may be created automatically based on selected components in the workspace.

**Object Type**
Primitive design object.

**Availability**
Rooms are available for placement/creation in the PCB Editor only. Use one of the following methods to place/create a room:

- choose Design » Rooms » Place Rectangular Room [D, M, R] from the main menus
  (click the button on the Place Room drop-down of the Utilities toolbar)
- choose Design » Rooms » Place Polygonal Room [D, M, M] from the main menus
  (click the button on the Place Room drop-down of the Utilities toolbar)
- choose Design » Rooms » Create Non-Orthogonal Room from selected components [D, M, N]
  from the main menus
  (click the button on the Place Room drop-down of the Utilities toolbar)
- choose Design » Rooms » Create Orthogonal Room from selected components [D, M, O]
  from the main menus
  (click the button on the Place Room drop-down of the Utilities toolbar)
- choose Design » Rooms » Create Rectangle Room from selected components [D, M, T]
  from the main menus
  (click the button on the Place Room drop-down of the Utilities toolbar)
- add a new Room Definition design rule.

**Placement**
The procedure involved to obtain a room on the PCB document depends on whether you are placing or creating the room and which particular method of placement/creation you have chosen to use.
Placement using menu or toolbar command

Rectangular or polygonal shaped rooms can be placed on the top or bottom layer of the design.

Rectangular Room

After launching the command, the cursor will change to a cross-hair and you will enter room placement mode. Placement is made by performing the following sequence of actions:

- click or press **Enter** to anchor the first corner of the room
- move the cursor to adjust the size of the room, then click or press **Enter** to anchor the diagonally-opposite corner and thereby complete placement of the room.

Continue placing further rooms, or right-click or press **Esc** to exit placement mode.

Polygonal Room

After launching the command, the cursor will change to a cross-hair and you will enter room placement mode. Placement is made by performing the following sequence of actions:

- position the cursor and click to anchor the starting point for the room
- position the cursor and click to anchor a series of vertex points that define the polygonal shape of the room
- after placing the final vertex point, right-click or press **Esc** to complete placement of the room.

There is no need to “close” the polygon as the software will automatically complete the shape by connecting the start point to the final point placed.

Continue placing further polygonal rooms, or right-click or press **Esc** to exit placement mode.

While defining the shape of the room, use the **Spacebar** to cycle through various corner modes. Modes available are: 90 Degrees, 45 Degrees and Any Angle.

Auto-Component Association

By placing a room - rectangular or polygonal - around one or more components, so that they fall completely within its boundaries, the components will automatically be associated to the room. The scope or query created for the room’s definition rule depends on whether all components are part of an existing component class or not. If they are, then this component class will be used. If not, a new component class is created, with these components as its members. It is therefore possible to have
multiple rooms, each with a scope that targets a particular component class, and have one or more mutual component members between those classes.

**Manual Component Association**

When an empty room is placed in the design, components required to be placed in the room should be grouped together by the use of a specific component class. A Room Definition rule will automatically be created and assigned to the room, with an initial scope (Full Query) of All. Edit this query to target the specific component class previously defined. The components can then be moved to the room by the use of the Tools » Interactive Placement » Arrange Within Room command.

**Creation using menu or toolbar command**

Non-orthogonal, orthogonal and rectangular shaped rooms can be created automatically based on selected components in the workspace. In each case, the method of creation is the same:

- first, ensure that all components that you wish to create the room for, are selected in the main design window
- launch the relevant creation command
- a component class is automatically defined to include the selection
- the chosen room type is then created, the definition of which is defined to associate the created component class
- the room will be sized accordingly, in order to fit all components in the selection, as defined by the limits of their bounding rectangles.

The following sections illustrate, by example, each of the three room types created from the three selected components in the image below.

![Room Types Example](image)

In each case, there are two images - the first showing the result of running the associated room creation command and the second showing just the created room, which has been filtered in the workspace for clarity.
Non-orthogonal Room

Orthogonal Room
Rectangular Room

Creation by adding a Room Definition design rule

For each room that is placed or created an associated Room Definition design rule is also created. Conversely, you may add a new rule of this type and a corresponding room object will appear in the design workspace.

Add a new Room Definition rule by right-clicking on the Room Definition entry, which can be found under the Placement category in the PCB Rules and Constraints Editor dialog, and choose New Rule from the subsequent pop-up menu that appears. The new rule will be added to the folder-tree on the left hand side of the dialog and will appear in the summary list for that rule type, in the main editing window of the dialog.
Clicking on the entry for the newly-created rule in the folder-tree pane (or, alternatively, double-clicking on the rule entry in the summary list) will allow you to edit/define the scope and constraint attributes for the rule.

Use the Define button to access the workspace and determine the location, shape and size of the required room - either polygonal or rectangular. After defining the boundaries of the room you will return to the dialog.

After defining all constraints for the rule as required, click OK to exit the dialog. The corresponding room object will appear in the design workspace, in accordance with the definition of the rule.

**Editing**

The properties of a room object can be modified during and after placement. Editing itself falls into two categories - graphical and non-graphical.

**Non-Graphical editing**

This method of editing targets the associated Room Definition rule for a room object, allowing you to change the room's scope and related constraints such as upon which layer the room is placed and whether it exists to keep objects inside or outside its boundaries. The following three methods of non-graphical editing are available:

**Editing via an associated properties dialog**

This method of editing uses the following dialog to modify the constraints of a room's associated Room Definition rule:
Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Simply click on the question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field or option.

During placement, the **Edit Room Definition** dialog can be accessed by pressing the **Tab** key.

After placement, the **Edit Room Definition** dialog can be accessed in one of the following ways:
- double-clicking on the placed room object
- selecting the room object and choosing **Properties** from the right-click pop-up menu
- choosing the **Change** command from the **Edit** menu and then clicking once over the placed room object.

The constraints for a Room Definition rule can also be edited directly in the **PCB Rules and Constraints Editor** dialog (**Design » Rules**).

**Editing via the Inspector panel**

The **Inspector** panel enables you to interrogate and edit the properties of one or more design objects in the active document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same kind, from one convenient location.

For more detailed information with respect to the content and use of the panel, refer to the **Inspector** panel topic, in the Protel PCB panels section of the DXP Panels Reference. This technical reference can be found in the DXP Design Environment area of the Online Help System.

**Editing via the List panel**

The **List** panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly inspect and modify object attributes. When used in conjunction with the **Filter** panel, it enables you to display just those objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy and efficiency.
For more detailed information with respect to the content and use of these panels, refer to the List panel and Filter panel topics, in the Protel PCB panels section of the DXP Panels Reference. This technical reference can be found in the DXP Design Environment area of the Online Help System.

**Graphical editing**

This method of editing allows you to select a placed room object directly in the workspace and change its size, shape, location or orientation, graphically.

**Changing room size and location**

When a room object is selected the following editing handles are available, irrespective of whether it is was originally placed as a rectangular or polygonal room:

Click & drag A to resize the room in the vertical and horizontal directions simultaneously.

Click & drag B to resize the room in the vertical and horizontal directions separately.

Click anywhere on the room - away from editing handles - and drag to reposition it. The room can be rotated or flipped while dragging:

- press the Spacebar to rotate the room anti-clockwise or Shift + Spacebar for clockwise rotation. Rotation is in accordance with the value for the Rotation Step, defined on the Protel PCB - General page of the Preferences dialog (Tools » Preferences)
- press the X or Y keys to flip the room along the X-axis or Y-axis respectively.

A room object can also be moved using the Design » Rooms » Move Room command.

**Changing room shape**

To graphically modify the boundary shape of a room, you will need to launch the Design » Rooms » Edit Polygonal Room Vertices command. Although the command name suggests it is for use with polygonal rooms only, it is in fact for use with all rooms, since a rectangular room is itself polygonal in shape.
After launching the command, simply click inside the room to be modified. The boundary track editing handles for the room’s polygonal boundary shape will be displayed:

Click on a corner editing handle (A) to move the handle and modify the polygon boundary. Click on the center handle in a track segment (B) to break the track and add a new vertex.

Continue modifying the shape of the room as required or right-click or press **Esc** to stop. The display of the room will update in accordance with the new boundary shape.

**Slicing a room**

Commands are available that allow you to graphically ‘slice’ a placed room object into two or more separate rooms. These commands offer two levels of ‘slice’, which can be summarized as follows:

**Standard Slice**

Allows you to slice an existing room object into multiple rooms. If the original room was associated to and contained components that were members of a component class, a newly generated room that inherits one or more of these components will not have a new component class created and assigned to it. Therefore, the components in the new room will still be members of the original component class.

The corresponding command for this level of slice is available by:

- choosing **Design » Rooms » Slice Room** from the PCB Editor main menus
- clicking the button on the **Place Room** drop-down of the **Utilities** toolbar
- right-clicking over a room object and choosing **Room Actions » Slice Room** from the subsequent pop-up menu that appears.

**Smart Slice**

Also allows you to slice an existing room object into multiple rooms. If the members of the original room were part of a component class and slicing results in members residing in the newly-generated rooms, then each new room will have a component class created and associated to it. The component class membership will be updated accordingly, so that each component in a new room will be added to the class for that room and removed from the original room class.

Any room that is created that does not inherit a member component of the original room will have no component class created and assigned to it.

The corresponding command for this level of slice is available by right-clicking over a room object and choosing **Room Actions » Slice and Create Classes** from the subsequent pop-up menu that appears.
After launching either command, filtering will be applied to the document, resulting in all room objects remaining visible and all other objects becoming dimmed. The cursor will change to a cross-hair and you will be prompted to choose a start point for the slice. Simply move the cursor to the required point with respect to the room you wish to slice and click or press Enter.

You are now in slice mode (which is essentially line placement mode). Simply move the cursor and click or press Enter to anchor a series of vertex points that define the shape of the slice.

When you have finished defining the slice, right-click or press Esc. Continue defining further slices, or right-click or press Esc to exit slice mode. A confirmation dialog will appear, which states how many rooms the original room will be turned into. Click Yes to commit the slice(s) you have made or No to discard. The resulting new room object(s) will be updated accordingly and the relevant Room Definition rule created and associated.

Use the Backspace key while in slice mode to remove the last placed slice segment.

**Room Wrapping**

The following three commands are available that allow you to quickly change the shape of existing room objects within a design:
• Wrap Non-Orthogonal Room Around Components
• Wrap Orthogonal Room Around Components
• Wrap Rectangular Room Around Components

Each of the commands can be accessed from either the main Design » Rooms submenu or from the Room Actions sub-menu, when right-clicking over a room in the workspace.

In each case, after launching the command the cursor will change to a cross-hair and you will be prompted to choose a room to modify. Simply position the cursor over the required room and click or press Enter. The room will change to the required shape (if not already) and will resize in order to fit its member components, as defined by the limits of their bounding rectangles.

Continue modifying further rooms or right-click or press Esc to exit.

Notes

Once component(s) have been assigned to a room they move when the room is moved. To move a room without moving the components, temporarily disable the associated Room Definition rule - either in the PCB Rules and Constraints Editor dialog or in the Inspector panel (with the room in question selected in the workspace).

A room can be locked to prevent accidentally moving it. To lock a room, simply double-click on it and enable the Room Locked option in the Edit Room Definition dialog.

When using any of the Wrap-based commands, if the current room is already the shape that you are trying to change it to and was created based on its member components, it will already be optimally sized (wrapped) around the components and using the command will have no effect.
When using either the Inspector or List panels to edit the properties of a room’s associated Room Definition rule, the selected room object will appear as the Object Kind: Confinement Constraint Rule.

As well as being a design rule in its own right (Room Definition), a room can also be used as an object when defining the scope of another rule, such as Clearance or Height. As the room is to be used as an object rather than a rule, you can simply disable the rule. The following two queries can be used when using a room object in another rules’ scope definition:

- `TouchesRoom(RoomName)` - use to find objects that are completely or partially within the room
- `WithinRoom(RoomName)` - use to find objects that are completely within the room.

The context-sensitive right-click menu - accessed when the cursor is over a room object - also provides commands for selecting the connections in the room, routing the connections in the room using the Situs Autorouter and unrouting the room. For more information, refer to the corresponding topics in the Command Reference, links to which are provided in the Links section below.

The Design » Rooms » Copy Room Formats command is used to copy the formatting of a selected source room to destination rooms that contain an identical set of components. The command is particularly useful when you need to copy the placement and routing of a particular channel, to all other channels in a multi-channel design. Follow the link below to the corresponding topic in the Command Reference.
String

Description
The string object places text on the selected layer. As well as user-defined text, special strings can be used to place board or system information on the PCB, such as the layer name or a board legend, by setting the string text to be one of the special string names.

Object Type
Primitive design object.

Availability
Strings are available for placement in both PCB and PCB Library Editors:

PCB Editor
- choose Place » String [P, S] from the PCB Editor main menus
- click the button on the Wiring toolbar.

PCB Library Editor
- choose Place » String [P, S] from the PCB Library Editor main menus
- click the button on the PCB Lib Placement toolbar
- right-click in the workspace and choose Place » String from the pop-up menu that appears.

Placement
After launching the command, the cursor will change to a cross-hair and you will enter string placement mode. Simply position the cursor and click or press Enter to place a string.
Continue placing further strings, or right-click or press Esc to exit placement mode.
The string object can be rotated or mirrored while in placement mode:
- press the Spacebar to rotate the string anti-clockwise or Shift + Spacebar for clockwise rotation.
  Rotation is in accordance with the value for the Rotation Step, defined on the Protel PCB - General page of the Preferences dialog (Tools » Preferences)
- press the X or Y keys to mirror the string along the X-axis or Y-axis respectively.

Editing
The properties of a string object can be modified before, during and after placement. Editing itself falls into two categories - graphical and non-graphical.
Non-Graphical editing

The following three methods of non-graphical editing are available:

**Editing via an associated properties dialog**

This method of editing uses the following dialog to modify the properties of a string object:

![String Properties Dialog](image)

Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Simply click on the question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field or option.

The **Text** field allows you to define the textual content of the string. Type the required text directly into the field. If you want to place a special string, simply choose the required entry from the field's associated drop-down.

**Special Strings**

A defined set of special strings are available that act as placeholders for board or system information. Special strings show default text during board editing, but are converted during printing or plotting to include the appropriate system information.

To use a special string on a PCB, simply place a string object and set its text to be one of the special string names. Special string names begin with the dot `.` character.

The following lists the defined set of special PCB strings:

- **.Arc_Count** - the number of arcs on the PCB
- **.Component** - the comment string for a component (used in designing component footprints)
- **.Component_Count** - the number of components on the PCB
- **.Designator** - the designator string for a component (used in designing component footprints)
- **.Fill_Count** - the number of fills on the PCB
- **.Hole_Count** - the number of drill holes on the PCB
PCB Layout Document Editor and Object Reference

- **.Layer_Name** - the name of the layer the string is placed on
- **.Legend** - a symbol legend for mechanical drill plots
- **.Net_Count** - the total number of different nets on the PCB
- **.Net_Names_On_Layer** - the names of all nets on the specific layer
- **.Pad_Count** - the number of pads on the PCB
- **.Pcb_File_Name** - the path and file name of the PCB document
- **.Pcb_File_Name_No_Path** - the file name of PCB document
- **.Plot_File_Name** - the file name of the Gerber plot file
- **.Print_Date** - the date of printing/plotting
- **.Print_Scale** - the printing/plot scale factor
- **.Print_Time** - the time of printing/plotting
- **.Printout_Name** - the name of the printout
- **.String_Count** - the number of strings on the PCB
- **.Track_Count** - the number of tracks on the PCB
- **.Via_Count** - the number of vias on the PCB

### Dialog Access

The **String** dialog can be accessed prior to entering placement mode, from the Protel PCB - Defaults page of the Preferences dialog (Tools » Preferences). This allows you to change the default properties for the string object, which will be applied when placing subsequent strings.

During placement, the **String** dialog can be accessed by pressing the **Tab** key.

After placement, the **String** dialog can be accessed in one of the following ways:

- double-clicking on the placed string object
- selecting the string object and choosing Properties from the right-click pop-up menu
- choosing the Change command from the Edit menu and then clicking once over the placed string object.

#### Editing via the Inspector panel

The **Inspector** panel enables you to interrogate and edit the properties of one or more design objects in the active document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same kind, from one convenient location.

For more detailed information with respect to the content and use of the panel, refer to the **Inspector** panel topic, in the Protel PCB panels section of the DXP Panels Reference. This technical reference can be found in the DXP Design Environment area of the Online Help System.

#### Editing via the List panel

The **List** panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly inspect and modify object attributes. When used in conjunction with the **Filter**
panel, it enables you to display just those objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy and efficiency.

For more detailed information with respect to the content and use of these panels, refer to the List panel and Filter panel topics, in the Protel PCB panels section of the DXP Panels Reference. This technical reference can be found in the DXP Design Environment area of the Online Help System.

**Graphical editing**

This method of editing allows you to select a placed string object directly in the workspace and change its location or orientation, graphically.

When a string object is selected, the following editing handle is available:

![Graphical Editing Handle](image)

Click & drag B to rotate the string about point A.

Click anywhere on the string - away from the editing handle - and drag to reposition it. The string will be held by point A and can be rotated or mirrored while dragging.

**Notes**

Text is rendered using one of three special fonts. The Default style is a simple vector font which supports pen plotting and vector photoplotting. The Sans Serif and Serif fonts are more complex and will slow down vector output generation, such as Gerber. These fonts are built into the software and cannot be changed. All fonts have the full IBM extended ASCII character set that supports English and other European languages.

The .Designator and .Comment special strings are added to the component in the library. Use these if you need to control the location of these attributes on a component. They can be placed on any layer. The standard designator and comment can be hidden if desired.

Use the .Legend string on the Drill Drawing layer. It will be replaced by a drill table when the output is generated.

While most special strings are only converted during printing or plotting, the following can be viewed on-screen:

- .Layer_Name
- .Pcb_File_Name
- .Pcb_File_Name_No_Path
- .Print_Date
- .Print_Time

To see the values of these special strings, enable the Convert Special Strings option on the Protel PCB - Display page of the Preferences dialog (Tools » Preferences).
Any changes made to object properties during placement will cause the default properties for the object to be updated, unless the **Permanent** option - on the **Protel PCB - Defaults** page of the **Preferences** dialog - is enabled. When this option is enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement session.
Track

Description
A track is a straight solid-filled line with a defined width. Use tracks wherever you need to define a straight line in the PCB workspace.

Tracks are generally placed on a signal layer, while using the Interactive Routing tool, to form the electrical interconnection between component pads on a PCB.

On non-electrical layers, tracks are used as general-purpose line drawing elements to create board outlines, component outlines, polygon planes, keepout boundaries, etc.

Object Type
Primitive design object.

Availability
Tracks are available for placement in both PCB and PCB Library Editors.

PCB Editor
In the PCB Editor, there are different commands available for placing tracks, depending on whether you wish to route connections manually on a signal layer using the Interactive Routing tool, or place straight lines on a non-electrical layer.

Lines are the same track object that is placed during interactive routing, the difference is that lines are not "net-aware". Lines do not adopt a net name if you click on a pad or existing routing when you commence placing a line and their placement is not regulated by design rules.

To place track objects using the Interactive Routing tool:
- choose **Place » Interactive Routing [P, T]** from the main menus
- click the button on the **Wiring** toolbar
- right-click in the PCB design workspace and choose **Interactive Routing** from the subsequent pop-up menu that appears.

To place line objects (track that is net-unaware):
- choose **Place » Line [P, L]** from the main menus
- click the button on the **Utility Tools** drop-down of the **Utilities** toolbar

PCB Library Editor
To place line objects (track that is net-unaware):
- choose **Place » Line [P, L]** from the main menus
- click the button on the **PCB Lib Placement** toolbar
• right-click in the workspace and choose **Place » Line** from the pop-up menu that appears.

**Placement**

Irrespective of the command used, the basic procedure for track placement is the same. After launching the command, the cursor will change to a cross-hair and you will enter track placement mode. Placement is made by performing the following sequence of actions:

- click or press **Enter** to anchor the starting point for the first track segment
- move the cursor to size the track and click or press **Enter** to anchor the end point for this first segment, which is also the start point for the next connected segment
- position the cursor and click or press **Enter** to anchor a series of vertex points that define the series of connected track segments
- right-click or press **Esc** to end the current series of connected track segments.

Continue placing further tracks, or right-click or press **Esc** to exit placement mode.

Use the **Backspace** key while in placement mode, to remove the last placed track segment.

The active layer can be changed while placing track:

- press the * key (the asterisk key on the numeric keypad) to cycle through the available signal layers
- press the + and - keys (on the numeric keypad) to cycle forward and backward through all visible layers in the design respectively.

In each case, the active layer will have its layer tab highlighted and the color of the current track segment will be drawn in the current layer color.

**Editing**

The properties of a track object can be modified during and after placement. Editing itself falls into two categories - graphical and non-graphical.

**Non-Graphical editing**

The following three methods of non-graphical editing are available:

**Editing via an associated properties dialog**

The specific controls available for editing a track object depends on the command used to place the track and whether you are editing during or after placement.

**Editing during track placement using the Place » Interactive Routing command**

While interactively routing, the track width and routing via parameters can be changed on-the-fly by pressing the **Tab** key. This pops up the **Interactive Routing** dialog, where you can change the trace width, layer, the via diameter and the via hole size.
If the values are changed to be outside the current maximum and minimum settings of the applicable rule - as summarized in the **Design Rule Constraints** region of the dialog - they are automatically clipped.

When performing impedance-controlled routing, that is, when the associated Routing Width design rule is configured in the **Characteristic Impedance Driven Width** mode, the **Interactive Routing** dialog appears as follows:
In this mode, the routing width required on each layer is calculated based on the specified impedance, using the appropriate equation (microstrip or stripline) and the physical parameters of the layer stack.

The impedance equations used for calculating the impedance and trace width are accessed from the Layer Stack Manager dialog, by pressing the Impedance Calculation button. The subsequent dialog that appears - the Impedance Formula Editor dialog - contains impedance calculators for both microstrip and stripline impedance calculations.

Default equations are in place to calculate the impedance and the required track width in order to satisfy that impedance when routing. Clicking the Helper button associated with an equation will open the Query Helper dialog, from where you can edit the equation if required.

**Editing during track placement using the Place » Line command**

While placing net-unaware track using the Place » Line command, the track width and current layer can be changed on-the-fly using the Line Constraints dialog, accessed by pressing the Tab key.

**Post-placement editing**

After placement, track properties are edited using the Track dialog:
Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Simply click on the question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field or option.

The Track dialog can be accessed in one of the following ways:

- double-clicking on the placed track object
- selecting the track object and choosing Properties from the right-click pop-up menu
- choosing the Change command from the Edit menu and then clicking once over the placed track object.

The Track dialog can also be accessed prior to entering placement mode, from the Protel PCB - Defaults page of the Preferences dialog (Tools » Preferences). This allows you to change the default properties for the track object, which will be applied when placing subsequent tracks using the Place » Line command.

Editing via the Inspector panel

The Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same kind, from one convenient location.

For more detailed information with respect to the content and use of the panel, refer to the Inspector panel topic, in the Protel PCB panels section of the DXP Panels Reference. This technical reference can be found in the DXP Design Environment area of the Online Help System.

Editing via the List panel

The List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly inspect and modify object attributes. When used in conjunction with the Filter panel, it enables you to display just those objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy and efficiency.
For more detailed information with respect to the content and use of these panels, refer to the List panel and Filter panel topics, in the Protel PCB panels section of the DXP Panels Reference. This technical reference can be found in the DXP Design Environment area of the Online Help System.

**Graphical editing**

This method of editing allows you to select a placed track object directly in the workspace and change its size, shape, location or orientation, graphically.

When a track object is selected, the following editing handles are available:

![Editing handles](image)

Click & drag A to move the end points of the track.

Click & drag B to "break" the track into two segments, effectively adding a new vertex. The original track end points will stay anchored at their original positions

Click anywhere on the track - away from editing handles - and drag to reposition it. The track can be rotated or flipped while dragging:

- press the Spacebar to rotate the track anti-clockwise or Shift + Spacebar for clockwise rotation. Rotation is in accordance with the value for the Rotation Step, defined on the Protel PCB - General page of the Preferences dialog (Tools » Preferences)
- press the X or Y keys to flip the track along the X-axis or Y-axis respectively
- press the L key to flip the track to the other side of the board.

**Notes**

When placing a track on a PCB, various placement modes are available:

- Any Angle
- 90 Degree
- 90 Degree with Arc
- 45 Degree
- 45 Degree with Arc.

The mode specifies how corners are created when placing tracks and the angles at which track segments can be placed. Each placement mode, except Any Angle, has a Start and an End mode.

When placing a track, press Shift + Spacebar to cycle through the placement modes. Press Spacebar to toggle between the Start and End modes, where applicable.

The PCB and PCB Library Editors incorporate a sophisticated "look-ahead" feature that operates as you place tracks (applicable in all modes except Any Angle). The track segment that is connected to the cursor is called a look-ahead segment and is shown in outline/draft mode as you move the cursor. The segment between this look-ahead segment and the last-placed segment is the current track that you are placing (shown in final mode).
Use the look-ahead segment to work out where you intend to place the next segment and to determine where you wish to terminate the current segment. When you click to place the current segment, its end point will be positioned exactly where you need to commence the next segment. This feature allows you to quickly and accurately place tracks around existing objects and plan where the next track segment can be placed.

If you require greater control over how a track segment is broken into two individually connected segments - rather than using the central editing handle to break the track in the center - use the Edit » Move » Break Track command. This allows you to 'break' the track segment anywhere along its length.

Any changes made to track properties during placement using the Place » Line command will cause the default properties for the track object to be updated, unless the Permanent option - on the Protel PCB - Defaults page of the Preferences dialog - is enabled. When this option is enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement session.

For more detailed information with respect to manually routing your design using the Interactive Routing tool, refer to the Command Reference topic 'Interactively Route Connections', a link to which is available in the Links section below.
Via

Description
A via is a design object that is used to form an electrical connection between two signal layers of a PCB. Vias are like round pads, which are drilled and usually through-plated when the board is fabricated.

Object Type
Primitive design object.

Availability
Vias are available for placement in both PCB and PCB Library Editors:

PCB Editor
- choose Place » Via \([P, V]\) from the PCB Editor main menus
- click the button on the Wiring toolbar.

PCB Library Editor
- choose Place » Via \([P, V]\) from the PCB Library Editor main menus
- click the button on the PCB Lib Placement toolbar
- right-click in the workspace and choose Place » Via from the pop-up menu that appears.

Placement
After launching the command, the cursor will change to a cross-hair and you will enter via placement mode. Simply position the cursor and click or press Enter to place a via.
Continue placing further vias, or right-click or press Esc to exit placement mode.
When placing free vias, use the * key (on the numeric keypad) to toggle enabled signal layers. Use the + or - keys (on the numeric keypad) to toggle up and down through all enabled layers.

Editing
The properties of a via object can be modified before, during and after placement. Editing itself falls into two categories - graphical and non-graphical.

Non-Graphical editing
The following three methods of non-graphical editing are available:
Editing via an associated properties dialog

This method of editing uses the following dialog to modify the properties of a via object:

![Via dialog](image)

Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Simply click on the question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field or option.

The Via dialog can be accessed prior to entering placement mode, from the Protel PCB - Defaults page of the Preferences dialog (Tools » Preferences). This allows you to change the default properties for the via object, which will be applied when placing subsequent vias.

During placement, the Via dialog can be accessed by pressing the Tab key.

After placement, the Via dialog can be accessed in one of the following ways:

- double-clicking on the placed via object
- selecting the via object and choosing Properties from the right-click pop-up menu
- choosing the Change command from the Edit menu and then clicking once over the placed via object.

Editing via the Inspector panel

The Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same kind, from one convenient location.

For more detailed information with respect to the content and use of the panel, refer to the Inspector panel topic, in the Protel PCB panels section of the DXP Panels Reference. This technical reference can be found in the DXP Design Environment area of the Online Help System.
Editing via the List panel

The **List** panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly inspect and modify object attributes. When used in conjunction with the **Filter** panel, it enables you to display just those objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy and efficiency.

For more detailed information with respect to the content and use of these panels, refer to the List panel and Filter panel topics, in the Protel PCB panels section of the DXP Panels Reference. This technical reference can be found in the DXP Design Environment area of the Online Help System.

**Graphical editing**

This method of editing allows you to select a placed via object directly in the workspace and change its location graphically. The size of a via object cannot be changed graphically. As such, editing handles are not available when the via object is selected:

Click anywhere on the via and drag to reposition it.

**Notes**

Use the Paste Array feature to paste an array of free vias. Controls for this feature are provided in the **Setup Paste Array** dialog, accessed by pressing the **Paste Array** button in the **Paste Special** dialog (Edit » Paste Special).

Vias can be one of the following three types:

- **multi-layer (Thru-Hole)** - this type of via passes from the Top layer to the Bottom layer and allows connections to all internal signal layers
- **blind** - this type of via connects from the surface of the board to an internal signal layer
- **buried** - this type of via connects from one internal signal layer to another internal signal layer.

Vias use layer colors to indicate which layers are connecting.

When you change layers while interactively routing, using the * key, a via is automatically inserted to preserve the electrical conductivity. The via will be placed in accordance with the applicable Routing Via Style design rule and the drill pair definitions.

When routing the design using the Situs Autorouter, vias will be placed as necessary and in accordance with the defined (and applicable) Routing Via Style design rules.
Vias automatically connect to an internal power plane layer that is assigned the same net name. The via will connect in accordance with the applicable Power Plane Connect Style design rule. If you do not want vias to connect to power planes, add another Power Plane Connect Style design rule targeting the specific vias required and with a connection style of No Connect.

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless the Permanent option - on the Protel PCB - Defaults page of the Preferences dialog - is enabled. When this option is enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement session.

**Tenting**

Partial and complete tenting of vias can be achieved by defining an appropriate value for Solder Mask Expansion. This expansion constraint can either be defined on a via-by-via basis, in the associated Via dialog, or by defining appropriate Solder Mask Expansion design rules:

- to partially tent a via - covering the land area only - set the Expansion to a negative value that will close the mask right up to the via hole
- to completely tent a via - covering the land and hole - set the Expansion to a negative value equal to or greater than the via radius
- to tent all vias on a single layer, set the appropriate Expansion value and ensure that the scope (Full Query) of a Solder Mask Expansion rule targets all vias on the required layer
- to completely tent all vias in a design, in which varying via sizes are defined, set the Expansion to a negative value equal to or greater than the largest via radius.

When tenting an individual via, options are available to follow the expansion defined in the applicable design rule, or to override the rule and apply a specified expansion directly to the individual via in question.

**Blind and Buried Vias**

Before using blind or buried vias it is important to establish the level of support provided by the manufacturer. Most manufacturers support blind and buried vias between what are termed 'layer pairs'. Using this technology, a multi-layer board is fabricated as a set of thin double-sided boards which are then 'sandwiched' together. This allows blind and buried vias to connect between the surfaces of these thin double-sided boards, which become the layer pairs.

The layer pairs are defined by the layer stack you configure in the Layer Stack Manager dialog (Design » Layer Stack Manager).
It is important to note that the layer pairs are dependent on the layer stack-up style. Make sure you contact your manufacturer to ensure you select the correct stack-up style before you start designing with blind and buried vias.

Once you have established the correct stack-up style, you should define the valid drill pairs. Drill pairs are set up in the **Drill-Pair Manager** dialog, accessed by clicking on the **Configure Drill Pairs** button in the **Layer Stack Manager** dialog.

If you define a drill pair for each layer pair in your design, the PCB Editor will automatically insert the correct via type (thru-hole, blind or buried) as you toggle layers while interactively routing.

In order to control the size of blind and buried vias when interactively routing or using the Situs Autorouter, individual Routing Via Style design rules can be set up targeting the different layer pairs.
For example, to control the via size for blind vias between the top layer and mid layer 1, the following scope (Full Query) can be used:

\[(\text{StartLayer} = '\text{TopLayer}') \text{ and } (\text{StopLayer} = '\text{MidLayer1}')\]

to control the via size for buried vias between mid layer 2 and mid layer 3, the following scope would be used:

\[(\text{StartLayer} = '\text{MidLayer2}') \text{ and } (\text{StopLayer} = '\text{MidLayer3}')\]

Alternatively, instead of creating individual rules, you can simply expand the one rule query using ORs:

\[((\text{StartLayer} = '\text{TopLayer}') \text{ and } (\text{StopLayer} = '\text{MidLayer1}')) \text{ or } ((\text{StartLayer} = '\text{MidLayer2}') \text{ and } (\text{StopLayer} = '\text{MidLayer3}'))\]
Violation

Description
A violation object marks an instance in the design where a particular design rule is currently being violated by one or more design objects. The violation itself is highlighted in the workspace through the use of a DRC Error Marker.

Availability & Placement
This type of object is placed automatically by the Design Rule Checking features - both Online and Batch. As such, it is not a design object that can be accessed and placed by the user.

Editing
A violation object cannot be edited with respect to properties in the usual manner - it cannot be selected in the workspace, has no corresponding properties dialog and cannot be edited graphically.

The layer upon which the associated DRC Error Markers are displayed can be enabled/disabled with respect to its visibility using the corresponding Show option for DRC Error Markers, in the System Colors region of the Board Layers and Colors dialog (Design » Board Layers & Colors).

<table>
<thead>
<tr>
<th>System Colors (Y)</th>
<th>Color</th>
<th>Show</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connectors and From To</td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>DRC Error Markers</td>
<td></td>
<td>✓</td>
</tr>
</tbody>
</table>

Define the display color by clicking on the color swatch to bring up the Choose Color dialog, from where you can choose from a range of predefined colors, or create your own custom color.

DRC Error Markers currently displayed in the workspace can be cleared using the Tools » Reset Error Markers command. Running the command will also clear the violation objects from the workspace and their corresponding listings in the PCB panel.

Violation objects can be shown or hidden in the workspace by enabling/disabling the corresponding design rules respectively. This can be done either from the PCB Rules and Constraints Editor dialog (Design » Rules) using the Enabled option for a rule, or by using the On field for a rule, in the Rules region of the PCB panel, when configured in Rules mode:

Disabling a rule takes it out of testing with respect to DRC and therefore no violations of it will be listed in the panel or added to the workspace.
Notes

All current violations in the PCB document can also be seen and navigated in the PCB panel - with the mode of the panel set to Rules:

Details of a violation object can be accessed either by double-clicking on the relevant violation entry in the PCB panel, or by right-clicking on an error marker in the workspace and choosing a command from the Violations sub-menu. In either case, the Violation Details dialog will appear, providing details about the particular design rule that is being violated and the offending object(s).

From this dialog you can highlight the offending object (causing it to flash in the workspace) and jump to it, effectively providing zoom and center.
Using the Reset Error Markers command just clears the error markers and the presence of violation objects in the workspace and on the PCB panel, it does not fix the violations. If you run a batch mode Design Rule Check (DRC) again, all violation objects will reappear on the PCB panel and in the workspace, along with the error markers.

Clearing the error markers clears the violations reported in the PCB panel only. The violation messages that appear in the Messages panel after running a batch mode DRC, will remain.
Index

Protel PCB Design Objects .11, 17, 21, 33, 36, 39, 40, 45, 50, 54, 58, 63, 68, 72, 76, 80, 83, 87, 91, 96, 102, 114, 119, 126, 132

Revision History

<table>
<thead>
<tr>
<th>Date</th>
<th>Version No.</th>
<th>Revision</th>
</tr>
</thead>
<tbody>
<tr>
<td>01-Dec-2004</td>
<td>1.0</td>
<td>New product release</td>
</tr>
</tbody>
</table>

Software, hardware, documentation and related materials:

Copyright © 2004 Altium Limited.

All rights reserved. You are permitted to print this document provided that (1) the use of such is for personal use only and will not be copied or posted on any network computer or broadcast in any media and (2) no modifications of the document is made. Unauthorized duplication, in whole or part, of this document by any means, mechanical or electronic, including translation into another language, except for brief excerpts in published reviews, is prohibited without the express written permission of Altium Limited. Unauthorized duplication of this work may also be prohibited by local statute. Violators may be subject to both criminal and civil penalties, including fines and/or imprisonment. Altium, CAMtastic, Design Explorer, DXP, LiveDesign, NanoBoard, Nexar, nVisage, P-CAD, Protel, Situs, TASKING and Topological Autorouting and their respective logos are trademarks or registered trademarks of Altium Limited or its subsidiaries. All other registered or unregistered trademarks referenced herein are the property of their respective owners and no trademark rights to the same are claimed.