
Welcome to Altium Designer and LiveDesign!

The Altium Designer LiveDesign Evaluation Kit lets you experience first-hand the power that real-time communication

with your design during development brings to the design process. Altium Designer is the industry’s first system to unify

the complete electronic product development process and allow you to harness the full potential of today’s high-capacity

programmable devices at both the logical and physical design level.

You'll be able to probe, analyze and debug your circuit just like an actual prototype. And because the implementation is

performed on an FPGA, you can update your design quickly and many times over without incurring cost or time penalties.

Altium Designer and LiveDesign will have a profound impact on the way your future products are designed, providing

you with benefits to the speed, design flow, quality and final product cost for the design phase.

Start today – experience the benefits of Altium Designer and LiveDesign!

The following steps are outlined in this Quickstart Guide to start you on your evaluation of LiveDesign:

What's in the box

System requirements

Requirements for FPGA design

Installing your software

Activating your license

Connecting your board

Creating a constraint file for your board

Online third-party board support

More information

Your Development Board

LiveDesign Evaluation Kit
QUICKSTART GUIDE
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Your Altium Designer LiveDesign Evaluation Kit includes the following components to get you started on your evaluation:

A Altium Designer Software Installation CDs

B Universal JTAG Interface

C Parallel cable (26 way IDC – DB25)

D JTAG ribbon cable (short 10 way IDC – 10 way IDC)

E JTAG ribbon cable (long 10 way IDC – 10 way IDC)

F JTAG flying lead cable (10 way IDC – 10 flying leads)

Please follow standard antistatic procedures during installation.

What's in the box

For optimum performance of Altium Designer software please refer to the recommended system requirements provided below.

Recommended system for optimal performance.Windows XP (Professional or Home).3 GHz Pentium 4 processor or equivalent.1 GByte RAM.2 GByte hard disk space (Install + User Files).Dual monitors with 1280x1024 screen resolution.32-bit color, 64 MB graphics card

Minimum system for acceptable performance.Windows 2000 Professional SP2.1.8 GHz processor .1 GByte RAM .2 GByte hard disk space (Install + User Files) .Main monitor 1280x1024 screen resolution 

Strongly recommended: Second monitor with 

minimum 1024x768 screen resolution .32-bit color, 32 MB graphics card

If any of these components are missing or appear damaged, please contact your nearest Altium Sales and Support

Center or Reseller.

System requirements
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Altium uses a licensing system that makes the management of the licensing options within Altium Designer easy to

administer and manage. Under this system, Altium collects hardware data from each machine with an Altium node-

locked license installed. Depending on individual situations, up to ten pieces of hardware information may be collected

and used for licensing management. The hardware information collected is not shared with any external third party or

used by Altium for any reason other than license management.

Step 1

Requirements for FPGA design

Installing your software

To begin the install process, simply insert the Altium Designer Software Installation CD

(Disc 1) into your computer's CD ROM drive. The Installation Wizard will automatically

start and guide you through the installation process. If the Installation Wizard does not

start automatically, run Setup.exe located in the Setup directory on the program CD.

Note: If you have a previous version of Altium Designer installed on your computer, you may be

prompted to uninstall it prior to continuing with the installation. If you are required to do this, use

Add and Remove Programs in the Windows Control Panel. We recommend you backup any important

information in the Altium Designer installation directory prior to uninstalling.

To complete the device-specific processing of a design for implementation in an FPGA, Altium Designer transparently

interfaces with third-party software tools supplied by the various FPGA vendors. You will require the appropriate FPGA

vendor software installed and correctly licensed before you can process your design for a specific target device.

Altium Designer supports the following FPGA vendor software:

For up-to-date information on supported versions, visit www.altium.com/vendortools

Designer LiberoTM Quartus®II ispLever® ISE

www.altium.com/vendortools
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A 'License Agreement' screen will

now appear (not illustrated).

You must accept the license

agreement in order to proceed.

Once you have accepted, you will

be asked to enter your full name

and organization name in order to

personalize your installation.

Step 2

The following screen will appear

when Altium Designer has been

successfully installed.

Steps 5-9 will guide you through

the license activation process.

Select the folder where you wish to

install the files for Altium Designer.

Click Next and the 'Ready to Install

the Application' screen will appear

(not illustrated). Click Next again

and the installation will begin.

During the installation you will be

prompted to insert Disc 2. Insert

and click OK to continue.

Note: The default Destination Folder
will vary according to the release that
you are installing.

Step 4

Step 3
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To launch the Activation Wizard, start the

Altium Designer software from the Start

menu. You will then be taken to the

'Licensing' screen. If this page does not

appear, click on DXP » Licensing.

From the Available Licenses menu, select

your preferred activation method,

nominating either internet or email

activation. This will then lead you to the

Activation Wizard Step 1 of 3 screens.

The quickest and simplest way to activate your license is by the use of the internet. The email activation

option is recommended where access to the Internet is limited.

Activating your license

You will now be asked to enter your

Customer Number and product

Activation Code. You will find these

details in the documents received

with the LiveDesign Evaluation Kit. 

You will then be asked if you wish

to identify a primary point of

contact for the license. If you select

No, you will still need to provide a

valid email address to receive the

license file.

Step 5

Step 6
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The next step of the activation

process requires you to verify

the licensee details. Check the

information displayed and

update if necessary.

Click on the Finish button in 

order to activate your license. 

Your details will be sent to Altium.

The licensee details are then

verified and the license file will 

be emailed to you.

You will receive an email from

Altium containing your license file.

Follow the instructions in this

email to add your license file and

finalize your activation, giving you

30 days to evaluate the full

features of Altium Designer. 

You are now ready to use 

Altium Designer.

Step 8

Step 7

Step 9
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Connecting your board

The Universal JTAG Interface  

A = Parallel header socket
B = Interface header socket

B

A

Hard and soft JTAG chains
connected to a target board

1 Connect the Universal JTAG Interface to your PC using the parallel cable supplied, via the parallel header socket (A).

2 Connect the flying lead cable to the 10 pin JTAG interface header socket (B). Note: A 10 way – 10 way ribbon cable

is supplied for third-party boards with a 10 pin compatible header interface.

3 Referring to the third-party development board's silkscreen or technical documentation, locate and connect the five

flying leads marked GND, HARD_TDI, HARD_TDO, HARD_TCK and HARD_TMS to the corresponding JTAG header

pins on the target board.

4 Connect the four flying leads marked SOFT_TDI, SOFT_TDO, SOFT_TCK and SOFT_TMS to any free I/O pins of the

FPGA on the target board. The flying lead marked CONNECT is floating and can remain unconnected.
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Creating a constraint file for your board

This section will take you through the steps of creating the constraint file for your target board and adding it to an

FPGA project. 

A constraint file is a text file containing a list of statements or lines known as constraint groups, each of which targets

one or more objects and contains one or more constraints. 

1 Creating the file 

Start the Altium Designer software from the Start menu. Once the software has loaded, select 

File » New » Other » Constraint File from the menus. 

Constraints can be defined by typing them in directly, or by using the Design » Add/Modify Constraint

menu options.

2 Defining the target board 

Within the constraint file editor, type in the following constraint group:

Record=Constraint | TargetKind=PCB | TargetId=My Third Party Development Board    

The TargetId specifies the name of the PCB you are targeting. This can be any text string to identify your board.

3 Defining the target device  

Within the constraint file editor, either type in the following constraint group or select 

Design » Add/Modify Constraint » Part… menu command and choose the device from the 

'Choose Physical Device' dialog.  

Record=Constraint | TargetKind=Part | TargetId=EP1C12Q240C6    

The TargetId above is specifying an Altera Cyclone device. Substitute this with the actual device on your board.

Note that this device must be supported by the system. To check that your device is supported, select 

View » Devices View. Then select Tools » Browse Physical Devices and click on the vendor's name in the

Vendors list to display supported devices.

4 Defining the Nexus JTAG soft chain 

Within the constraint file editor, either type in the following constraint groups or choose 

Design » Add/Modify Constraint » Port… menu command for each new pin.  

Record=Constraint | TargetKind=Port | TargetId=JTAG_NEXUS_TDI | FPGA_PINNUM=P108

Record=Constraint | TargetKind=Port | TargetId=JTAG_NEXUS_TDO | FPGA_PINNUM=P109

Record=Constraint | TargetKind=Port | TargetId=JTAG_NEXUS_TCK | FPGA_PINNUM=P45

Record=Constraint | TargetKind=Port | TargetId=JTAG_NEXUS_TMS | FPGA_PINNUM=P115

The FPGA_PINNUM field indicates the pin number of I/O pins on the FPGA that are connected to the 

SOFT_TDI, SOFT_TDO, SOFT_TCK and SOFT_TMS flying leads. 
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5 Defining the other FPGA pins 

Within the constraint file editor, create new constraint

groups specifying all the remaining connected FPGA pins

on the board. The pins may be grouped together to

target a particular peripheral or feature of the board.

Record=Constraint | TargetKind=Port | TargetId=

[Port Name] | FPGA_PINNUM=[pin#]*

For example, a 4 pin DIP Switch could be defined 

as follows: 

Record=Constraint | TargetKind=Port | TargetId=SW[3..0]

| FPGA_PINNUM=P29,P28,P27,P26

The TargetId above is specifying the schematic port name

that will be used in the design to connect to the

specified pin.  

* Note that for QFP packaged FPGAs, valid pin numbers may begin with the letter P, immediately followed by the

pin number, i.e. P22 means Pin 22. For FPGAs in PGA or BGA packages, the pin number is a grid reference, 

i.e. A22 is the pin on Row A, Column 22, and P22 is Row P, Column 22.

6 Adding the constraint file to a project 

Once your constraint file is created and saved, you may add it to an existing FPGA project by right-clicking on the

FPGA Project in the Projects Panel, and then choosing the Add Existing To Project command.

For more information about creating and using constraint files refer to the documents below. These PDF files can be

opened from within the Altium Designer Documentation Library, accessed by pressing F1 within the application, and

browsing to the FPGA Hardware Design » Working with Constraints section. 

AR0124 Design Portability, Configurations and Constraints.pdf

AP0104 Re-targeting the design to the Production Board.pdf

TR0103 Constraint File Reference.pdf
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Online third-party board support

Altium's website contains a wealth of information on third-party development boards, with instructions on getting these

boards up and running with Altium Designer.

Visit www.altium.com/community and click through to Third-Party Development Board Support to obtain general

instructions on:

Connecting to boards

Building a constraint file

Building an example project

Altium also provides support for an

extensive range of third-party

development boards. This support can

include instructions for connecting the

board (including images), constraint files

and example projects that demonstrate

the use of processor cores and virtual

instruments. To assist in finding a

particular board, you can search by

details such as manufacturer, device or

board name.

This site is continuously being updated to

provide relevant and up-to-date

information on third-party development

boards available. If a specific board is not

listed, or level of support is limited, you

can submit a request for future support.

www.altium.com/community
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Congratulations on successfully installing your Altium Designer LiveDesign Evaluation Kit. Now that you are ready to

evaluate LiveDesign, we recommend you refer to the following information to gain maximum benefit.

The Altium Designer Documentation Library, accessed by pressing F1 within the application, provides an extensive 

range of documentation covering all areas of design. We recommend that once you have read the introductory

documents, which will show you how to get started with Altium Designer and give you a good understanding of the

software, that you also read the below documents which relate to FPGA design, processor cores and embedded

software development:

GU0101 FPGA Designers Quickstart Guide.pdf

TU0116 Getting Started with FPGA Design.pdf

TU0118 Implementing a Simple Processor-Based Design in an FPGA.pdf

AP0103 Processing the Captured FPGA Design.pdf

GU0107 Using the TSK51x TSK52x Embedded Tools.pdf 

GU0108 Using the TSK165x Embedded Tools.pdf 

GU0109 Using the TSK80x Embedded Tools.pdf 

GU0110 Using the PowerPC Embedded Tools.pdf 

GU0111 Using the TSK3000 Embedded Tools.pdf

TU0123 Creating a Core Component.pdf

Note: Although references in some of these documents relate to using and downloading designs to Altium's

NanoBoard-NB1 hardware development platform, the overall concepts and process flows can be applied to 

your third-party development board.

As well as the specific third-party development board resources and example projects provided on Altium's website, 

there are over 40 FPGA projects and reference designs included with this system. All example projects are available in

the \Examples folder found in the Altium Designer installation directory. Like the documents mentioned above, these

example projects have been configured to be used with the Nanoboard-NB1. Using the constraint file you created for

your board, you should be able to retarget and reuse various parts of the designs.

Further information, support resources and additional example projects can be found at www.altium.com/community

More information

For more information visit www.altium.com/livedesign
or contact your local Altium Sales and Support Center or Reseller.

www.altium.com/community
www.altium.com/livedesign
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