Altium Designer Documentation

System Requirements for Altium Infrastructure Server

Created: January 17, 2018 | Updated: July 13, 2020
All Contents

Parent page: Altium Infrastructure Server

Ensure that your computer/server meets the system requirements detailed below, prior to installing an Altium Infrastructure Server.

Operating System Support

The Altium Infrastructure Server can be installed on a PC running one of the following Operating Systems:

  • Windows 10 (32-bit or 64-bit)
  • Windows 8.1 (32-bit or 64-bit)
  • Windows 8 (32-bit or 64-bit)
  • Windows 7 (32-bit or 64-bit)
  • Windows Server 2016 Standard Edition
  • Windows Server 2008/2012 R2 (32-bit or 64-bit, where applicable)
The Altium Infrastructure Server cannot be installed on a PC running Windows XP. In addition, if your version of Windows Operating System does not support Windows Authentication (including: Core, Home, Starter, and Base editions), you will not be able to install the Altium Infrastructure Server.
The Altium Infrastructure Server relies on a number of Microsoft runtime components for successful operation and access, in some situations these may not be present on the target machine. If you receive an error message about a missing library (DLL) when you attempt to sign into an Altium Infrastructure Server, it indicates that there are missing Microsoft runtime components. To-date, this is only known to occur on Windows Server 2008 R2 x64 Datacenter. Use this link to download and install these missing components: http://www.microsoft.com/en-us/download/confirmation.aspx?id=29 

Recommended System Requirements

The following are the recommended system requirements to install and run an Altium Infrastructure Server. Note that these recommendations are for 10-30 concurrent users.

  • OS: Windows Server 2012 R2
  • RAM: 16GB+
  • Processor: Intel® Xeon® processor or equivalent (4 or more cores)
  • Disk space: 200GB (SSD)

Minimum System Requirements

The following are the minimum system requirements to install and run an Altium Infrastructure Server. Note that these recommendations are for 10-30 concurrent users.

  • OS: Windows 7
  • RAM: 8GB+
  • Processor: Intel Core i3/i5 processor or equivalent (2 or more cores)
  • Disk space: 200GB

Altium Designer Requirements

To fully access and appreciate the features and technologies associated to, and installed with, the Altium Infrastructure Server, requires Altium Designer 16.0 or later.

Installation & Other Software

Due to the observed unpredictable behavior of antivirus software, it is recommended to disable such software during the installation of the Altium Infrastructure Server.

If the computer is also running Microsoft Exchange Server, you might receive an HTTP Error 503 error when you first attempt to log in. The installation of the Exchange Server can change the Internet Information Services (IIS) configuration in a way that conflicts with the Infrastructure Server. To resolve this, the following changes must be made to the applicationHost.config file:

<handlers accessPolicy="Read, Script">
...

<add name="kerbauth" image="C:\Program Files\Microsoft\Exchange Server\V15\Bin\kerbauth.dll" preCondition="bitness64" />
<add name="WSMan" image="C:\Windows\system32\wsmsvc.dll" preCondition="bitness64" />
<add name="exppw" image="C:\Program Files\Microsoft\Exchange Server\V15\ClientAccess\Owa\auth\exppw.dll" preCondition="bitness64" />
<add name="cafe_exppw" image="C:\Program Files\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy\bin\exppw.dll"  preCondition="bitness64" />

...
</handlers>

For information about the ApplicationHost.config file, refer to this article. For information on editing the file, refer to this article.

Additional Software Installed or Configured

  • Internet Information Services (IIS). For correct operation, the Altium Infrastructure Server requires, at minimum, version 7.5 (IIS 7.5) to be installed. Installation of the Altium Infrastructure Server will simply install the version of IIS native to your operating system:
    • IIS 10.0 - Windows 10 and Windows Server 2016 Standard Edition
    • IIS 8.5 - Windows 8.1 and Windows Server 2012 R2
    • IIS 8.0 - Windows 8
    • IIS 7.5 - Windows 7 and Windows Server 2008 R2
  • Firebird 2.5 database engine.
  • .NET Framework 4.5.2
Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

联系我们

联系原厂或当地办公室

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: