Altium Designer Documentation

Creating & Managing Processes in Altium NEXUS Server

Created: December 19, 2019 | Updated: January 17, 2020

Parent page: Browser-based Access & Management

Altium NEXUS provides a powerful collaborative design environment. Part of that is the support for Workflows, that guide a company's designers through typical, everyday design processes such as:

  • Requesting new managed parts
  • Performing design reviews
  • Creation of new managed projects.

Each Workflow that is used to implement a particular design process is created as part of a Process Definition. It can therefore be referred to as that process's underlying Workflow, or simply a Process Workflow.

Processes, and their Workflows, are created and managed through the NEXUS Server's browser interface - by an Administrator of that server.

For the three design areas mentioned previously, predefined process workflows are included with your server installation. Some of these are activated for use out-of-the-box. Use these, modify them, or create your own as required, to suit the needs of your company. Others are samples - these cannot be activated and used as is. Each of these is therefore more like a 'template' - edit to suit your company's requirements, name, and save as a new process definition, which you can then activate and use, along with all other definitions.

A powerful Process Workflow Editor provides the flexibility for you to build processes with workflows that can be as simple, or as complex as needed, and in-line with your company's requirements.

Accessing Processes

All process management is performed from within the Processes area (Admin - Processes) of the NEXUS Server's browser interface.

You must be signed in as an Administrator for your NEXUS Server, in order to see the Processes area of the interface.

Accessing the Processes area of the NEXUS Server's browser interface - command central for working with processes and their associated workflows.Accessing the Processes area of the NEXUS Server's browser interface - command central for working with processes and their associated workflows.

The Processes interface is presented over the following four tabs:

  • Browser - providing a summary listing of all processes (active or closed). A centralized 'processes dashboard' if you will.
  • Part Requests - providing a dedicated area with which to manage the processes related to the theme of requesting parts.
  • Project Activities - providing a dedicated area with which to manage the processes related to the theme of working with managed projects, such as design reviews and publishing to a PLM system.
  • Project Creations - providing a dedicated area with which to manage the processes related to the theme of creating new managed design projects.
The last three tabs can be referred to as Process Themes. Process Themes allow the various processes to be grouped intuitively, by area of design. They also allow for the software to cater for new process creation, by supporting only those workflow elements that are needed for a particular area, and thereby streamlining the building of a required workflow. Moving forward, this approach provides a foundation for Altium by which to extend the interface through the addition of further themes, as and when required.

The following sections take a look at these various tabs in more detail.

Browser Tab

Use this tab to centrally browse all active or closed processes, across all process themes. By default, the tab presents all Active (running) processes. Switch to viewing all Closed processes (e.g. completed, rejected, or terminated) using the drop-down field above the list.

Browse all active processes from the one convenient location. Roll over the image to see an example of browsing all closed processes.Browse all active processes from the one convenient location. Roll over the image to see an example of browsing all closed processes.

For each entry, the following information is presented (where applicable):

  • Status - the state of the process. This can be one of the following:
    •  Active - the process is currently active, and its associated workflow is progressing.
    •  On hold - the process is currently active, but is awaiting initial input, such as assignee allocation, before its workflow can progress.
    •  Closed - the process is now closed, for example was either successfully completed, or rejected.
    •  Terminated - the process is now closed, and was terminated directly by a NEXUS Server Administrator.
  • Process Name - the name of the process definition.
  • Title - this field is used to distinguish between multiple instances of the same process. The title is the process name, with an instance suffix (#1, #2, and so on).
  • State - this is the state currently reached within the process's associated workflow.
  • Assignee (Active process only) - this is the user who now has a task to perform to move the process along from its current workflow state.
  • Started By - the user who initiated the process.
  • Started At - the date and time at which the process was started.
  • Ended At (Closed process only) - the date and time at which the process was closed.

For an active process, there is also a Terminate control (). Click this to force-end a process. The process will move to the Closed listing of processes.

Processes can be sorted by any column possessing the  control - click on the control, or the column name. Searching can also be conducted, using the Search field at the top of the list. Data in all fields except Status, Started At, Ended At and Terminate can be used to search.
  • You can also import a previously exported process definition from file, directly from within the Browser tab. To do so, click the  button. In the Open dialog that appears, navigate to, and open, the required Workflow file (*.aaw). The correct process theme will be detected, and the content of the file will be loaded into the Process Workflow Editor. For more information, see Importing/Exporting a Process Definition.
  • Use the  button to export a report of the currently listed activities (Process Workflows) as a detailed comma-delimited *.csv file – see example. Active or Closed activities can be exported, and the entries to be included filtered using the process name Search field. On the design side, the NEXUS Explorer panel includes an equivalent  button - under the Activites tab when browsing a project (using the default Project view) - for downloading the currently listed activities data that relate to that project.

Click on an entry for a process to view a diagram of its underlying workflow (on the Diagram tab below the list), showing what needs to happen for the process to be completed, and where that process is at, along its flow, in terms of who now has a task to perform to move the process along.

Click the  control at the bottom-right to highlight the current point reached in the workflow - the user(s) entry will flash momentarily.

Viewing the underlying workflow for a selected process on its Diagram tab. Each workflow is built diagrammatically allowing you to see at-a-glance where in the workflow a process currently sits, and who now has the next task in order to continue progress of that process.Viewing the underlying workflow for a selected process on its Diagram tab. Each workflow is built diagrammatically allowing you to see at-a-glance where in the workflow a process currently sits, and who now has the next task in order to continue progress of that process.

The following additional tabs are also available:

  • Data - showing all pertinent data for the process. For a design review process for example, this can include the project and its data set, the review type, people involved in the review, and any additional attachments. For a part request process,  this can include attached datasheets, parametric data, and any preliminary components.
Applicable entities, such as attachments, datasheets, project and project data set (Item-Revision) will appear as hyperlinks for quick navigation to, or opening of. You also have the ability to configure the parametric data that is visible to the standard user on this tab. When editing the workflow for a process, and with no element selected, the data that can be presented on the Data tab is listed in the right-hand pane. Click the Edit control to access its related form (<ProcessName> Data).
  • History - showing a history of actions taken along the process's workflow.

Use the Data and History tabs to browse more detail for the process, and a trail of its workflow activity, respectively.Use the Data and History tabs to browse more detail for the process, and a trail of its workflow activity, respectively.

Part Requests/Project Activities/Project Creations Tabs

Use these tabs - which gather together processes into specific themes - to view, create, and manage process workflows that are to be used when requesting a new managed part, performing design reviews or publishing to a PLM system, or creating new design projects, respectively.

By default, the upper region of a tab presents all of the Latest versions of defined processes within the theme. Switch to viewing All defined processes (i.e. all versions) using the drop-down field above the list.

Example of browsing the latest versions of defined processes for a particular theme (in this case, the Project Activities theme).Example of browsing the latest versions of defined processes for a particular theme (in this case, the Project Activities theme).

For each entry, the following information is presented:

  • Process Name : version - the name of the process definition, and its version. To ensure you are always viewing/working with the latest version, ensure that the version drop-down field above the list is set to Latest.
  • Instances (active / all) - the number of instances of this version of the process definition that are currently active, along with the total number of instances that have been started.
  • Created By - the user who has created this version of the process definition.
  • Created At - the date and time at which this version of the process definition was created (saved and deployed).
  • Start - as an administrator, you can start a new instance of this version of the process definition by clicking the  control. This is only available provided the process definition has been activated. If the process has been suspended, or it is a sample (template) definition, the control will appear as , and an instance cannot be started.
  • Active - shows whether this version of the process definition is active () and can therefore be used, or has been suspended (), or is a sample (template) definition (), and can therefore not be used. Only active process definitions will appear in the relevant area of the Altium NEXUS GUI, for use by designers. Click on the icon to toggle the active state, where applicable.
Only the latest version of a process definition can be used (made active and started). Previous versions can not be used, but they can be modified to produce a later version. In addition, sample process definitions (whose Active state is distinguished by ) cannot be used out-of-the-box. Each of these is more like a 'template' - edit to suit your company's requirements, name, and save as a new process definition, which you can then activate and use, along with all other definitions.
  • Edit - click the  control to modify the underlying workflow for the process definition. The workflow diagram for this version of the process definition will be presented in the Process Workflow Editor, as a starting point from which to work. Any Administrator can modify any user defined process definition, irrespective of who originally created that definition, and save and deploy it as the next version. For default process definitions supplied by Altium, you are able to create a new process definition based on editing one of these (in essence forking), but cannot modify a default itself. For more information on editing a process definition, see Editing an Existing Process Definition.
  • Remove - click the  control to remove (delete) this version of the process definition. Note that some of the default process definitions supplied by Altium cannot be removed (and therefore have no such control). If at least one instance of the process definition has been started, irrespective of whether it is still active or not, the definition cannot be removed (the delete control will be removed).
Process definitions can be sorted by any column possessing the  control - click on the control, or the column name. Searching can also be conducted, using the Search field at the top of the list. Data in the Process Name : version and Created By columns can be used to search.

Click on an entry for a process definition to view its diagrammatic workflow on the Diagram tab below the list. If there is a currently active instance of a process, the view will show where that process is at, along its flow, in terms of who now has a task to perform to move the process along.

If multiple instances of a process are active, the Diagram view will show a combined state. Click the  control at the bottom-right to highlight the current point reached in the workflow - the user(s) entry will flash momentarily.

Viewing the underlying workflow for a selected process on its Diagram tab.Viewing the underlying workflow for a selected process on its Diagram tab.

Default Process Definitions

A number of process definitions are provided by Altium - across the three process themes - as part of the NEXUS Server's installation. Some of these are activated for use out-of-the-box, and can be used as is, while others are samples - they cannot be activated and used directly. All can be used as a starting point from which to create your own process definitions as required. Use the following collapsible sections to access information on the process definitions provided.

  • New Part Request - activated by default, is removable, and the workflow diagram for which is shown below.

  • New Part Request Assign - sample definition, is removable, and the workflow diagram for which is shown below.

  • New Part Request Multiple Tasks - sample definition, is removable, and the workflow diagram for which is shown below.

  • New Part Request Notify 3rd Party - sample definition, providing the ability to trigger EDS notification with parameters from the workflow, and await a response from EDS. This can be used to integrate a 3rd party system into NEXUS Server processes (requires access to Altium NEXUS Server SDK), giving you the ability to further customize your workflows, and support influencing of decisions in the workflow for a process from an external source. It is removable, and the workflow diagram is shown below.

An example application - Process Listener - to receive and send notifications using the NEXUS Server EDS is available with the NEXUS Server SDK.
  • Part Request with PLM Part Create - sample definition, supporting the automatic creation of a Component in your PLM instance, and then propagation of the generated part number back to the component in NEXUS. It is removable, and the workflow diagram is shown below.

One important thing to note is that when you modify this sample definition to create your own, you must specify the PLM instance into which parts are to be created. Select the Create Part in PLM entity in the workflow diagram and choose the PLM instance from the drop-down menu associated with the PLM Instance field. This menu lists all currently defined PLM instances (as defined on the PLM Integration page of the interface).
  • Ad Hoc Review - activated by default, is removable, and the workflow diagram for which is shown below.

  • Handoff Review - activated by default, is removable, and the workflow diagram for which is shown below.

  • Milestone Review - activated by default, not removable, and the workflow diagram for which is shown below.

  • Project Releaser with Publish - sample definition, providing the ability to publish to an integrated PLM instance as an additional stage of the Project Releaser. It is removable, and the workflow diagram is shown below.

  • Publish to PLM (User selects) - sample definition, providing publish of released managed project outputs to an integrated PLM instance, but with the user able to select exactly which outputs get published. It is removable, and the workflow diagram is shown below.

  • Project - sample definition, is removable, and the workflow diagram for which is shown below.

  • Project (with parameters) - sample definition, is removable, and the workflow diagram for which is shown below.

  • Project with initialise in PLM - sample definition, supporting the automatic creation of part numbers in your PLM instance, and then propagation of these as Server Parameters of the NEXUS Managed Project. It is removable, and the workflow diagram is shown below.

The NEXUS Server installation also includes the LibSync process that synchronizes component data between the NEXUS Server and a target PLM instance. This is a 'built in' read-only process workflow and is therefore not editable, or included in the list of processes on the server's Processes page (Admin » Processes). See PLM Component Synchronization for more information.

Adding a New Process Definition

Related page: Defining a Process Workflow

New processes can be created using the dedicated Process Workflow Editor. To access the editor, make active the tab for the theme in which you want to create your new process, then click the  button at the top-right of the page.

It is important to make the theme active first, so that the process is created with the correct Type.

Accessing the Process Workflow Editor. Ensuring the desired process theme is made active before access will ensure the new process definition will be set to the right theme type.Accessing the Process Workflow Editor. Ensuring the desired process theme is made active before access will ensure the new process definition will be set to the right theme type.

Give your new process definition a meaningful name, then build the workflow graphically, and define the required aspects of each element in that flow. For user tasks, a User Form Editor is used to fashion the required form that will be presented to the user, to take their input when they are given a task at the relevant point along the workflow.

The powerful Process Workflow Editor provides the flexibility for you to build processes with workflows that can be as simple, or as complex as needed, and in line with your company's requirements.The powerful Process Workflow Editor provides the flexibility for you to build processes with workflows that can be as simple, or as complex as needed, and in line with your company's requirements.

Once a process has been defined as required, click the  button to have it added to the list of available processes for that process theme. The new process definition will be activated ready for use.

The Editor will flag any issues with your workflow diagram that are preventing it from being saved and deployed - for example a diagram must have a Start event, and at least one End event defined. And a User Task must have at least one Form field and an Assignee.

Editing an Existing Process Definition

Any Administrator can modify any user defined process definition, irrespective of who originally created that definition, and save and deploy it as the next version. To do so, click the  control for the process definition you wish to modify. The workflow diagram for this version of the process definition will be presented in the Process Workflow Editor, as a starting point from which to work.

For process definitions supplied by Altium, you are able to create a new process definition based on editing one of these (in essence forking), but cannot modify a default itself.

Example editing of an existing process definition - accessing the Process Workflow Editor, with which to perform required changes.Example editing of an existing process definition - accessing the Process Workflow Editor, with which to perform required changes.

Make changes to the diagrammatic workflow for the process as required, including any changes to the forms associated to user tasks thereof, then click the  button to effectively save the definition as the next version. In the example here, the original process definition Company Pre-release Review : 1 (version 1) is modified and saved to become Company Pre-release Review : 2 (version 2).

With modifications made, save and deploy as the next version of that process definition.With modifications made, save and deploy as the next version of that process definition.

By using the top-left drop-down field and setting the entry to All, you can see all versions of existing process definitions. In the image below, you can see both versions of the Company Pre-release Review process definition.

Showing all versions of the example process definition Company Pre-release Review. Note that only the latest version (version 2) can be activated and used.Showing all versions of the example process definition Company Pre-release Review. Note that only the latest version (version 2) can be activated and used.

Only the latest version of a process definition can be used (made active and started). Previous versions can however be used as a starting point with which to build a later version. If you were to delete the latest version of a process definition, then the next previous version will effectively become the latest, and can once again be made active and used (instances started).

Importing/Exporting a Process Definition

Process definitions can be exported and imported, allowing you to quickly reuse them across NEXUS Server instances - a real time saver where a process's underlying workflow might be particularly complex, and having to 'reinvent the wheel' as it were would be an otherwise daunting exercise.

To import:

  1. Access the theme tab (Part Requests, Project Activities, Project Creations) corresponding to the process definition you are wanting to import.
If you attempt to import a process definition into the wrong theme, the software will alert you to this and import will be prevented.
  1. Click the  button to create a new process definition, and access the Process Workflow Editor.
  2. Click the  button. In the Open dialog that appears, navigate to, and open, the required Workflow file (*.aaw). The content of the file will completely overwrite anything currently defined for the process definition (Name, diagram, etc).
You can also import a previously exported process definition from file, directly from within the Browser tab of the interface. To do so, click the  button. In the Open dialog that appears, navigate to, and open, the required Workflow file (*.aaw). The correct process theme will be detected, and the content of the file will be loaded into the Process Workflow Editor.

To export:

  1. Click the  control to access editing mode for the required version of process definition that you wish to export.
  2. In the Process Workflow Editor, click the  button. The process definition will be exported as a Workflow file (<ProcessDefinitionName>.aaw), to the default downloads folder defined for your Web Browser.
  3. Click on the Processes entry in the left-hand navigation tree for the NEXUS Server's browser interface to back out of the Process Workflow Editor without making any changes to the process definition.

Designer Access to Process Workflows

Related pages: Performing Design Reviews, Publishing to a PLM, Requesting a New Managed Part

Once the required set of process definitions for each available process theme are crafted as required for your company, those definitions that are activated will be available for use by all users once they are signed into the NEXUS Server. The following sections take a look at where a designer can access, and start these active processes - both through Altium NEXUS, as well as the NEXUS Server's browser interface.

Administrators for the NEXUS Server can, as mentioned previously, start a new instance of any activated process definition - directly from the corresponding process theme tab within the Processes area of the NEXUS Server's browser interface - by clicking the  control.

Part Requests

Related page: Requesting a New Managed Part

From within the Altium NEXUS design environment, activated process definitions that are part of the Part Requests theme can be accessed in the following places:

  • From the Components panel. Right-click within the main area of the panel - the active part request process definitions are available from the Operations » Submit Request sub-menu. Alternatively, click on the Submit request link under the Need more components? section.

If no active process definitions are available for the Part Requests process theme, the Submit Request sub-menu will be grayed out (not available). You may need to sign out of the server and back in again, or restart Altium NEXUS, to refresh.
  • From within the Manufacturer Part Search panel. If the currently selected search item has no  icon, the Information pane (accessed by clicking ) will present the  button. Click the drop-down part of the button to access a menu of the active part request process definitions. Clicking the main part of the button directly will launch the first process definition in the list.
Requesting a part through the Manufacturer Part Search panel provides the added benefit that it will auto-fill key information for you, including all data sheets and parametric information.

If no active process definitions are available for the Part Requests process theme, the  button will be grayed out (not available). You may need to sign out of the server and back in again, or restart Altium NEXUS, to refresh.

If the currently selected search item has an  icon, the active part request process definitions will be available from the menu associated with the  button (click on the drop-down part of the button).

The active part request process definitions can also be accessed from the right-click menu for the main area of the panel, from the Submit Request sub-menu.

If no active process definitions are available for the Part Requests process theme, the Submit Request sub-menu will be grayed out (not available). You may need to sign out of the server and back in again, or restart Altium NEXUS, to refresh.
  • From the Explorer panel, after having conducted a search. The  button will be available which, when pressed, will present the active part request process definitions available to choose from.

Note that if the Legacy Part Requests feature has been enabled, then the button will appear as . An additional entry relating to new part requests using that legacy functionality will also appear on the menu. This will have the suffix (Legacy). If no active process definitions are available for the Part Requests process theme, and the Legacy Part Requests feature is not enabled, the Submit Request button will not be shown. You may need to sign out of the server and back in again, or restart Altium NEXUS, to refresh.

From the NEXUS Server's browser interface, activated process definitions that are part of the Part Requests theme can be accessed from the Part Requests page, by clicking the  button at the top-right of the page.

Accessing activated Part Requests definitions from the Part Requests page of the NEXUS Server's browser interface.Accessing activated Part Requests definitions from the Part Requests page of the NEXUS Server's browser interface.

If no active process definitions are available for the Part Requests process theme, the  button will be unavailable. If only one process definition exists, the button will not appear with drop-down functionality, and will start that process immediately upon being clicked.

Project Activities

Related pages: Performing Design Reviews, Publishing to a PLM, PLM Integration.

Activated process definitions that are part of the Project Activities theme can be accessed in various places.

Design Review and Standard PLM Publishing

From within Altium NEXUS, activated design review and standard PLM publishing process definitions - that are part of the Project Activities theme - can be accessed from the Project » Project Activities sub-menu for the active project:

Also available from the Project Activities context sub-menu, accessed by right-clicking on the entry for the design project in the Projects panel.
If no active design review and standard PLM publishing process definitions are available for the Project Activities process theme, the menus will not be visible.

From the NEXUS Server's browser interface, activated design review and standard PLM publishing process definitions - that are part of the Project Activities theme - can be accessed from the Projects page of the interface. Select the required project, then click the  button.

Accessing activated Project Activities definitions (design review and standard PLM publishing) for a managed project, within the Projects area of the NEXUS Server's browser interface.Accessing activated Project Activities definitions (design review and standard PLM publishing) for a managed project, within the Projects area of the NEXUS Server's browser interface.

If no active design review and standard PLM publishing process definitions are available for the Project Activities process theme, the  button will not be shown.

PLM Publishing through the Project Releaser

From within Altium NEXUS, the process for publishing to a PLM instance as part of the Project Releaser can be accessed from the Project » Project Releaser sub-menu for the active project, or by right-clicking on the entry for the design project in the Projects panel and choosing the process from the Project Releaser context menu entry.

Project Creations

From within Altium NEXUS, activated process definitions that are part of the Project Creations theme can be accessed in three places:

  • From the main File » New » Project in <ServerName> sub-menu.

  • From the Convert to Managed Project context sub-menu, accessed by right-clicking on the entry for an unmanaged project in the Projects panel.

  • From the Clone context sub-menu, accessed by right-clicking on a project's entry in the Open Project dialog when the server location is selected.

Note that when at least one process definition for the Project Creations process theme is active, the ability to create a new managed project through the Create Project dialog (File » New » Project) is disabled – the connected server is not available as a target location. Regular (Local) and VCS type projects can be created as normal through this dialog.

If no active process definitions are available for the Project Creations process theme – which is the default case for a fresh installation of the Altium NEXUS Server – the process menus will not be visible, and you will be able to create a managed project through the Create Project dialog as usual.

Also note that in this default configuration the Convert to Managed Project command changes to Make Project Available on Server.

From the NEXUS Server's browser interface, activated process definitions that are part of the Project Creations theme can be accessed in the following places:

  • From the main Projects page of the interface, by clicking the  button.

Accessing activated Project Creations definitions from the main Projects area of the NEXUS Server's browser interface.Accessing activated Project Creations definitions from the main Projects area of the NEXUS Server's browser interface.

  • From the Projects page of the interface, when wanting to clone a particular project. Select the required project, then click the  button to access the processes on the menu.

Accessing activated Project Creations definitions when wanting to clone a managed project, within the Projects area of the NEXUS Server's browser interface.Accessing activated Project Creations definitions when wanting to clone a managed project, within the Projects area of the NEXUS Server's browser interface.

If no active process definitions are available for the Project Creations process theme – which is the default case for a fresh installation of the Altium NEXUS Server – the menu will offer the basic project cloning functionality (Clone). This is not related to the process workflow functionality.
Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

联系我们

联系原厂或当地办公室

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: