Altium Designer Documentation

Generating Production Data for a Multi-board Design in Altium Designer

Created: December 13, 2019 | Updated: December 17, 2019
您正在阅读的是20.0版本。 关于最新版本,请前往阅读21版本
All Contents

Parent page: Designing Systems with Multiple Boards

The primary aim of Multi-board design is to bring all elements of an electronic product together as a system that is ready for successful production. Fabrication and Assembly outputs from the sub projects within a Multi-board project cater for the production of those specific modules, but not for the overall system that will be assembled as a product. Along with the design definitions for the sub module PCBs and the required enclosures, hardware and wiring, a system design also should include key production data that relate to the complete product, such as singular definitions of its parts and assembly.

System level Bill of Materials

Critical to the notion of project production data is a valid record of the design's required component parts and their associated data, captured as a Bill Of Materials (BOM). Altium Designer provides the advanced ActiveBOM feature that also delivers real-time information on manufactured parts and supplier sources, component specifications, lifecycle status, availability and more, which is all collated and managed through a project's ActiveBOM document.

► See BOM Management With ActiveBOM for detailed information about working with BOM documents.

In system design, ActiveBOM documents can be created within the Multi-board project itself to provide a single source BOM definition for the complete Multi-board project, without the need to manually assemble that data from the individual sub project BOMs.

To create a system level BOM document, right click on the Multi-board project name in the Projects panel and choose the Add New to Project » ActiveBOM command from the context menu. The resulting <project name>.BomDoc file is added to the top level in the Multi-board project hierarchy.

The system level BOM sources component parameters from the Multi-board Assembly document, which is turn derives component information from the Multi-Board sub projects, as defined in the Multi-board Schematic. As such, it relies on the sub projects being up to date and their schematic and PCB synchronized – as is the case for the Multi-board Schematic and Assembly documents (Design » Update Assembly - <Assembly document> or Design » Import Changes From <Multi-board project>, respectively).

To ensure that the Multi-board Assembly holds the correct project component data, select the Edit » Update All Parts command from the main menu, or right click in the Assembly editor and choose the Update All Parts option.

A top-level Multi-board BOM also includes source project details for each listed item in the form of Module column information. The ModuleAssembly column is enabled by default, while the other Module reference columns can be made visible from the Columns tab in the Properties panel.

As an aggregate reference of part information for the overall product design – in practice a connected set of PCB project Modules – a system-level BOM will include component and supply chain data for all sub projects, plus collated information such total pricing for specific parts and the cost of all parts in the complete Multi-board design.

Note that data from BOM documents within sub projects are not used by a system-level BOM document. However, changes made to a sub project BomDoc, such as a modified component Designator or Part Choice are adopted by the project design itself, and these will be then reflected in the Multi-board BomDoc.

As outlined above, any component data changes in a sub project must be updated to the Multi-board Assembly document (Update All Parts) before those changes will be reflected in the system-level Multi-Board BomDoc.

Part Choices

A powerful advantage of the ActiveBOM feature is its ability to provide real-time supply chain information for project components, composed of manufacturer part data and validated supplier sources. Stored as Part Choices and implemented in a BomDoc as mapped Solutions, a system level BOM can include additional part data that relates to the overall product design such as mechanical/mechatronic parts, interconnecting cables, wiring harnesses and so on.

By way of example, Multi-board module interconnecting cables are expressed in terms of their terminating parts in a Multi-board Schematic. Those cable connector parts can be included in the system level BOM, along with their associated supply chain Solution or with a particular part/supply reference added as a Manual Solution.

► See Creating BOM Solutions for more information.

System level Output Data

Beyond the production output data generated for the fabrication and assembly of a Multi-board design's constituent sub projects, a system level design requires output data that applies to the production of the overall Multi-board assembly. Altium Designer offers this system level output data through generated reports and graphics documents.

BOM Report

A BOM Report output can be generated directly from the ActiveBOM document through the Report Manager dialog, opened from the Reports » Bill of Materials option in the main menu.

The Report Manager dialog (Bill of Materials for BOM Document <BomDoc>) allows you to configure and generate a BOM report for the system level design in a range of output formats, including csv, xml, pdf, etc. The report will include all ActiveBOM data, include a snapshot of each Item's Supply Chain data.

Draftsman BOM Table

A Draftsman BOM Table report added to a system level Draftsman document will draw its data from and reflect a Multi-board ActiveBOM document. To create a system level Draftsman document, right click on the Multi-board project name and select Add New to Project » Draftsman Document from the context menu (select any sub project as the source).

When a BOM Table is placed from this top level document (Place » Bill Of Materials) its content will include all part items from the overall Multi-board design. As with the ActiveBOM document, the additional Module reference parameter columns are available (Module Assembly, Designator, Source and Title). BOM Table columns are managed under the Columns tab in the Properties panel when the table is selected in the Draftsman editor.

Multi-board Assembly Export

Representations of the system level Multi-board assembly can be exported from the File » Export options available when a Multi-board Assembly is the active document. Export options include PARASOLID (*.x_t), STEP 3D (*.step) and PDF3D (*.pdf). An example of the interactive PDF 3D format is shown below.

Output Jobs

All of the above mentioned types of output data can be added to an Altium Designer Output Job to generate production data in container formats that target specific file formats, available printers, etc. The OutJob File is added to the Multi-board project and its generated outputs will therefore represent the system level design.

An Output Job is added to a Multi-board project by right-clicking on its name and selecting the Add New to Project » Output Job File option from the context menu. The Multi-board OutJob will offer output options that apply to the system level design only, such as the Documentation and Report outputs outlined above.

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

联系我们

联系原厂或当地办公室

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: