Altium NEXUS Documentation

Sharing a Design in Altium NEXUS

Created: July 19, 2021 | Updated: September 23, 2021

Parent page: Global Sharing

In support of Altium's Global Sharing paradigm, the Altium NEXUS design client supports the ability to share your design projects with others, anywhere around the world, directly from within the software. This complements the ability to share designs from within the connected Altium Workspace, such a Workspace provided by the Altium 365 platform or an Altium NEXUS Server. The following levels of sharing are supported from within Altium NEXUS:

  • Sharing of a live design – the work-in-progress (WIP) design itself, which can be shared:
    • With other members of your Workspace team – for editing and/or viewing. An invited team member can view the design through the Altium NEXUS design client or through the team's Workspace. Editing is performed only through the NEXUS design client. The invited team member must be registered with AltiumLive and have an active Altium NEXUS license subscription.
  • Note that sharing live WIP designs with those outside of your Workspace team is possible when connected to an Altium 365 Workspace, and not when using an Altium NEXUS Server Workspace. You can, however, share a design Snapshot for viewing and downloading with someone outside of your Workspace team (see below).
  • Sharing of a design 'snapshot' – a static snapshot of the design at a particular point in time and shared:
    • By link – available to anyone through a Web browser. Shared design access at this level requires neither active subscription for your Altium NEXUS licensing, nor registration with AltiumLive. A recipient of the shared link opens the Standalone Altium 365 Viewer to view (but not comment) on the design. Viewing requires no registration with AltiumLive and the link is available for 48 hours.
    • With specific people – available to specified people through email invite. Shared design access at this level requires registration with AltiumLive, but does not require active subscription for Altium NEXUS licensing. A recipient accesses the design snapshot through the Altium 365 Platform Workspace interface Web Viewer from their email invitation. Viewing requires registration with AltiumLive, but the snapshot is available permanently. Commenting on the design is also available.
  • Note that a design Snapshot shared in this way is essentially read-only. It can be downloaded or viewed in an Altium 365 Workspace, but unlike a shared WIP design, it cannot be opened for viewing/editing in Altium NEXUS.
  • If the recipient of a design (or design snapshot) shared with them through the Altium 365 platform does not have an AltiumLive account, they will need to register for one first – a link is provided on the Altium 365 Sign In page.
For more information on uploading a design snapshot from within the Altium 365 Platform Interface and then sharing with others, see Sharing Design Snapshots. For more information on sharing an actual live design with non-team members while viewing the design in your Web browser, see Sharing Live Designs outside of the Workspace.

Accessing Sharing Controls

Controls for sharing a design from within Altium NEXUS can be found in the Share dialog – accessed in the following ways:

  • For the active project – by clicking the button at the top-right of the main application window, or by choosing the Project » Share command from the main menus.
  • For the focused project in the Projects panel – by right-clicking on the entry for the project and then choosing the Share command from the context menu.
If there is no active project – i.e. no project document currently open – then the button will act on the currently focused project in the Projects panel.

Accessing the Share dialog – command central for sharing a design from within Altium NEXUS.Accessing the Share dialog – command central for sharing a design from within Altium NEXUS.

Sharing a Live Design

With a design project registered with (made available to) an Altium 365 Workspace, you have the ability to share that design with other people. This can be to other members of your Workspace team, or to people outside of the team. To share in this manner, click to select the entry, on the left side of the Share dialog.

Workspace team Administrators can always share a project with others for either editing or viewing. Non-administrative members of the Workspace team, or users with whom a project has been shared with outside of the Workspace team, can share a project with others for editing or viewing, depending on the level of access they themselves have. So if they have editing rights, they can share with others for either editing or viewing. If they only have viewing rights, then they can only share with other users for viewing and commenting.

Accessing the controls to share a live/WIP design with others. Note that the image shows the case for a project already available in a connected Workspace.Accessing the controls to share a live/WIP design with others. Note that the image shows the case for a project already available in a connected Workspace.

In order to be able to share a WIP design through an Altium NEXUS Server Workspace:

  • You must have active (valid) Altium NEXUS design client license.
  • You must be connected to your Altium Workspace.
  • The design project must be registered with (made available to) the Workspace.
In order to be able to share a design Snapshot through a Workspace:
  • You must be connected to your Altium Workspace.
  • The design project must be registered with (made available to) the Workspace.
  • A recipient of a shared Snapshot Link requires a standard web browser only.
  • A recipient a Snapshot specifically shared with their name needs to be:
    • registered with and signed in to AltiumLive.
    • connected to their Altium 365 Personal Space.

The Share dialog will present guidance in order to properly prepare you for sharing your chosen design project. The following are examples of this when sharing with an Altium 365 Workspace (a similar set of relevant advice dialogs are presented when working with an Altium NEXUS Server Workspace):

  • If not signed in to your Altium account, the dialog will present a link to do so (to access the Sign In dialog), or to register with AltiumLive, if you don't yet have credentials. You will typically connect to a Workspace (if you have one) once signed in to your account, and if that Workspace has been set as the default.

  • If you are signed in to your Altium account and are attempting to share an open project that is not registered with a Workspace (i.e. it is an unmanaged local or VCS project), and you don't have a Workspace available to you, the dialog will present a control to activate the Workspace for your company.
Only one Altium 365 Workspace can be activated per organization.

  • If you are signed in to your Altium account and are attempting to share an open project that is registered with a Workspace, and you are not currently connected to that Workspace, the dialog will present a control to connect to that specific Workspace, or switch to it if currently connected to a different Workspace.

  • If you are signed in to your Altium account and are attempting to share an open project that is not registered with a Workspace (i.e. it is an unmanaged local or VCS project), and you are not currently connected to a Workspace, the dialog will present a list of all Workspaces available to you, prompting you to select which Workspace to register the project with.

If you are already connected to a Workspace, then that will be used as the target in which to register the project. Note that the project will be made available in the target Workspace at the time the project is shared with nominated people.

Sharing with New People

With preparation complete, a project selected, and a target Workspace connected, you can proceed to specify which person (or people) the project is to be shared with. To check who already has access to the project, click on the Shared with control. The region will expand to show with whom the project is shared and whether they have editing rights (Can Edit), or can view and comment on the project only (Can View).

Check with whom the project is currently shared by clicking the Share with field. Hover over the image to see the result.Check with whom the project is currently shared by clicking the Share with field. Hover over the image to see the result.

You can share the project with anyone – other AltiumLive users from within your own organization, AltiumLive users from different organizations, and non-AltiumLive users (who will need to then register for AltiumLive accounts). Note that when connected to a Workspace provided by an on-site server, such Altium Concord Pro installed on your local network, you can share the WIP project with registered users of that Workspace only – for sharing externally, see Sharinga Design Snapshot or the sharing approach available in your Altium 365 Personal Space.

To add an entry, begin typing the desired name/email/role in the field so the matching user/role can be selected from the dynamic list – which will only contain filtered users in your Workspace team or within your organization, and existing roles defined for the Workspace. Multiple users/roles can be chosen. To remove an entered user/role, click the control associated with the entry.

To share with a person outside of your organization – irrespective of whether they have an AltiumLive account or not – you must enter their full email address and press Enter.

Set the sharing access permissions for the added people/roles from the associated drop-down menu by selecting Can View () or Can Edit (), where the latter option inherently includes viewing capability. The setting initially applies to all entries (people/roles) included in the field. Use the optional note field to include information that relates to the sharing arrangement for this project.

Workspace team Administrators can always share a project with others for either editing or viewing. Non-administrative members of the Workspace team can share a project with others for editing or viewing, depending on the level of access they themselves have.

Additional sharing permissions are available to administrators and the project owner in the Share dialog when connected to an Altium 365 Workspace. Use the Advanced Settings options to specify the re-sharing and download rights for users that the design is to be shared with.

The Share dialog's Advanced Settings option is not available when connected to a Workspace provided by an on-site server, such as Altium Concord Pro installed on your local network.

Only those shared users with Edit permissions applied can re-share a project with others. Additional control of this sharing is available from the Sharing Settings dialog's Who can share the project options:

  • Editors in the Workspace – allow Workspace team members that have Edit rights for the shared design to re-share it with others.
  • Editors outside the Workspace – allow non Workspace team members that have Edit rights for the shared design to re-share it with others.

All shared users with Edit rights can download the project's design files. For users with View (read-only) share permissions, the ability to download files is set by the dialog's Who can download files options:

  • Viewers in the Workspace – allow Workspace team members that have View rights for the shared design to download design files.
  • Viewers outside the Workspace – allow non Workspace team members that have View rights for the shared project to download design files.

With target recipient(s) defined and access rights specified, click the button to proceed with sharing the project.

Sharing with a non Team Member

When connected to a Workspace provided by an on-site server, such as Altium Concord Pro, a WIP design cannot be shared with those that are not registered users of that Workspace (non-team members). For sharing externally from an on-site server Workspace, see Sharing a Design Snapshot, or the Upload sharing approach available in your Altium 365 Personal Space.

If you attempt to share an Altium 365 Workspace project with a person outside of the team, the Sharing Outside of the Workspace dialog will appear, offering the following options:

  • Share for Viewing – click this option to proceed with sharing the project, but with view-only permissions.
  • Share for Editing – click this option to proceed with sharing the project, with editing rights.

You can share a project with anyone outside of the Workspace team, for editing or viewing.You can share a project with anyone outside of the Workspace team, for editing or viewing.

Sharing with a user outside of the Workspace team for editing is perfect for contractors – where you want them to actively work on the design, but without bringing them into your team.

Sharing an Unmanaged Project

If you are sharing an unmanaged, local project (not under external VCS), the project will be made available in the currently connected Workspace at the time the project is shared with the nominated people. What actually happens depends on whether you are sharing for viewing or editing:

  • When sharing for viewing only (and connected to an Altium 365 Workspace) – the project is made available through Simple Sync. Under this mode, the design project can be edited by a single person only (the owner of that project). The strength of Simple Sync comes when you do not want anyone else editing your design, but where you do want to take advantage of Altium 365's Global Sharing paradigm, and be able to share that design with multiple other people for viewing and commenting. For more information on this functionality, see Making an Existing UnManaged Project Available Online.
  • When sharing for editing – the project needs to be added to the Workspace's Versioned Storage Git design repository. Under this mode, multiple people can be shared the project for editing, as well as being able to utilize Altium 365's Global Sharing support for shared viewing and commenting. A dialog will be presented alerting you to this and giving you the option to do so.

When sharing an unmanaged project (not under VCS) with a person for editing, the project will need to be brought under version control by addition to the Workspace's Versioned Storage Git design repository.When sharing an unmanaged project (not under VCS) with a person for editing, the project will need to be brought under version control by addition to the Workspace's Versioned Storage Git design repository.

If the unmanaged project is already under version control (in an external design repository) it will remain under the external VCS design repository, and not be added to the Workspace's own built-in VCS (Git) design repository. In this case Simple Sync (mirroring) applies, but of course multiple collaborators can continue to work on/edit the design, since it is under VCS.

However, the full functionality delivered through the Altium 365 platform – or more specifically an Altium 365 Workspace – can only be experienced by having your project fully managed and stored under the Workspace's native VCS (within its Versioned Storage Git repository). What you can do is migrate your project from using the external VCS system to the Workspace's native VCS system Altium NEXUS's built in VCS repository migration feature.

► For information on this, see Moving from External VCS to Workspace Native VCS.

  • When connected to a Workspace provided by an on-site server, such as Altium Concord Pro installed on your local network, an unmanaged project to be shared with another Workspace user is automatically added to the Workspace's VCS. The now managed project will be shared with the specified Workspace user with View or Edit rights, as was selected in the Share dialog.
  • Note that an on-site server Workspace cannot share a WIP project with anyone who is outside of the Workspace team – who is not a registered User of the Workspace.

Sharing Result

What happens next depends on the type of user being invited:

  • A user that is already part of your Workspace Team will be added to the sharing access list for the project directly, and they will receive an email notifying them that the project has been shared with them. They can open the project in Altium NEXUS, or access it through the Workspace interface (from the Projects page).
  • When an existing Role for the Workspace is added it will appear on the access list for the project, and all members of the role will receive an email notifying them that the project has been shared with them. They can open the project in Altium NEXUS, or access it through the Workspace interface (from the Projects page).
  • When using an Altium 365 Workspace for sharing with a person outside of your Workspace team, they will be added to the sharing list and will receive an email notifying them that the project has been shared with them. They can open the project in Altium NEXUS from the Shared with Me option, or access it through their Altium 365 Platform Personal Space Interface (from the Shared with Me page). Their received email provides direct access to the design through Altium 365. Once they click the button in the email they will be taken to the Altium 365 Sign In page (unless already signed in to the platform, or their AltiumLive account). Upon signing in, they will be taken to the Web Viewer directly, with the shared design loaded.
  • You cannot share a WIP design outside of the team (external users) when connected to a Workspace provided by an on-site server, such as Altium Concord Pro. However:

If the person does not have an AltiumLive account, they will need to sign up for one first – a link is provided on the Altium 365 Sign In page.

Accessing a shared live design from the email invite received by the user that is not a member of the Workspace Team.Accessing a shared live design from the email invite received by the user that is not a member of the Workspace Team.

Modifying Access Rights for Existing People

At any time, an Administrator (or Workspace team member with editing rights) can modify the existing access permissions for a project. To access the list of existing shared people and roles for a project click the entry on the left side of the Share dialog, then expand the Shared with field on the right.

Accessing the list of people and roles who currently have shared access to the project.Accessing the list of people and roles who currently have shared access to the project.

Things to be aware of:

  • In terms of permissions, a person/role has full editing access to the project when the Can Edit option () is selected. Otherwise, they have View-only access ().
  • The Owner and the Administrators role always have full editing access (Can Edit).
  • With the exception of the Owner and Administrators role, permissions for all included people/roles may be individually set as Can View or Can Edit, or access rights completely removed. Click on the current permission state to access controls.

  • A project may be explicitly shared with specific people and/or roles, or simply shared with all members of the Workspace team. For the latter, set the required access for the Everyone in the team entry. To not share the project with the entire team, set this entry to None.

Make changes to access permissions as required. Each changed entity is highlighted in the list with a lighter background.

Example changes to the permissions for two existing people with which a project is currently shared.Example changes to the permissions for two existing people with which a project is currently shared.

To affect changes, click the button. The changes will be applied, with confirmation reflected through the dialog. To see the updated list of shared access, click the Who has access link.

After saving permission changes, you can view the updated result directly through the Share dialog.After saving permission changes, you can view the updated result directly through the Share dialog.

  • Note that the sharing of a project with another user can be revoked at any time by choosing the Remove option for that user in the Share dialog.
  • Also note that if you are changing permissions to Can Edit for someone outside of the Altium 365 Workspace team, you will be alerted – through the Sharing Outside of the Workspace dialog – to confirm whether to give them view-only rights, or editing rights.

Accessing a Shared Live Design

Access to a project shared with a user depends on whether that user is a member of the Workspace team, or is outside of the Workspace team.

Workspace Team Member

For a member of the Workspace team, they can access the shared project through Altium NEXUS, or through the Projects page of the Workspace's interface. Note that editing of the project – if they have editing rights – is only possible through Altium NEXUS.

Within Altium NEXUS, access the project using the File » Open Project command or the ellipsis button associated with the Workspace entry in the Projects panel. The Open Project dialog will appear, from where you can choose which managed project to open from your connected Workspace – when connected to a Workspace, that Workspace will appear in the Locations region of the dialog, distinguished by the icon, and appearing with the name given to the Workspace. Only those managed projects that have been shared with you (and you have permission to access) will be listed.

Once opened, the project will appear under an entry for the Workspace, in the Projects panel.

Choose which managed project to open from your connected Workspace, from within Altium NEXUS, from those currently shared with you.Choose which managed project to open from your connected Workspace, from within Altium NEXUS, from those currently shared with you.

You have the option to open the project to the default checkout path, or use the drop-down menu to specify a custom path. The default checkout path is taken from the Document Path field on the System – Default Locations page of the Preferences dialog.
When browsing the project through Altium NEXUS's Explorer panel – configured in its default Project View rather than Classic View – click the button, at the top-right of the panel, to open the project in Altium NEXUS (adding it to the Projects panel). Use the button to open the project for viewing the connected Workspaces web interface.

Invited Stakeholder Outside of the Workspace Team

For a person outside of the Altium 365 Workspace team with whom the project has been shared, they can access that project through Altium NEXUS or through the Altium 365 Workspace interface (from the Shared with Me page). Note that editing of the project – if they have editing rights – is only possible through Altium NEXUS.

A WIP Project design cannot be shared outside of the team (to external users) when using a Workspace provided by an on-site server, such as Altium Concord Pro installed on your local network.

However, if you are the recipient of a design that has been shared with you from a member of an Altium 365 Workspace, it will be available In Altium NEXUS from the Shared with Me location as described below – and also available for viewing in your Personal Space.

The shared project also can be accessed in the user's Personal Space interface on the Shared with Me page. To open the project, select the design's tile and click on the project name, or choose the Open option from the tile's ellipsis menu. Alternatively, double-click directly on the tile.

► See the Altium 365 Platform Shared with Me section for details on the types of entities that can be shared in the Workspace Shared with Me space.

Within Altium NEXUS, access the project using the File » Open Project command. The Open Project dialog will appear, from where you can choose which managed project to open from the Shared With Me location.

Once opened, the project will appear under the entry Shared with me, in the Projects panel. What you can do with the project depends on the access rights you have been given to it. If editing rights were assigned to you, you will be able to edit the design normally, which would typically be the case for an external contractor – since the design is shared from a Workspace, design changes are synchronized in both directions. If you are restricted to viewing rights, you still will be able to comment on the WIP design.

Choose which managed project to open, from within Altium NEXUS, from those currently shared with you as an external stakeholder. Note that access is made to such projects without having access to the Workspace.Choose which managed project to open, from within Altium NEXUS, from those currently shared with you as an external stakeholder. Note that access is made to such projects without having access to the Workspace.

You have the option to open the project to the default checkout path, or use the drop-down menu to specify a custom path. The default checkout path is taken from the Document Path field on the System – Default Locations page of the Preferences dialog.

Sharing a Design Snapshot

Creating a read-only snapshot of a design allows you to quickly share that design – at that specific point in time of the project's development – for wider collaboration with others through the Web. This can be useful for an on-the-fly design review, sharing a particular design milestone, or even to stimulate contextual discussion. To share in this manner, click to select the entry, on the left side of the Share dialog.

Accessing the controls to share a snapshot of a design.Accessing the controls to share a snapshot of a design.

Any user who is currently viewing a project within Altium NEXUS can share a snapshot of that design.

Sharing by Link

By default, the dialog is set to Share By Link, meaning that anyone who is given the link will have access to view the design snapshot through their Web browser for a time-limited period of 48 hours. Commenting on the design is not possible with this level of sharing.

This level of sharing does not require you to be signed in to your Altium account within Altium NEXUS.

Click the button to generate the link to the design snapshot. In the background, the project itself is packaged into a Zip archive using Altium NEXUS's Project Packager. Once the link is ready, click the button to copy it, and then share with the required people as needed.

Generating the time-limited link that can be shared with anyone, anywhere.Generating the time-limited link that can be shared with anyone, anywhere.

When the recipient of the link opens it in a web browser they will be taken to an instance of the Altium 365 Viewer – on the main altium.com site – with the design processed and loaded.

Using the shared link, a recipient can browse the design snapshot using Altium 365 Viewer, loaded on the main altium.com site. Shown here is a schematic – hover over the image to see the PCB.Using the shared link, a recipient can browse the design snapshot using Altium 365 Viewer, loaded on the main altium.com site. Shown here is a schematic – hover over the image to see the PCB.

When the design (in the Zip archive) is uploaded to the Altium 365 Viewer, it is removed as soon as it is processed. As a result, viewing of the design is time-limited – available for the duration of your browser session (and no longer available if you close your browser tab). Alternatively, use the link again, at any time during the permitted period of 48 hours.

Sharing with Specific People

Clicking the Share with specific people control will switch the sharing mode (for sharing a design snapshot) to allow you to share with one or more specific people – by email invitation. Recipients will have access to view, share or download the design snapshot through the Web-based Altium 365 Platform Interface. Such a design snapshot is available permanently through the platform and commenting on the design is possible with this level of sharing.

This level of sharing requires that you be signed in to your Altium account within Altium NEXUS (using your AltiumLive account credentials). If you are not currently signed in to your Altium account the dialog will present a link to do so (to access the Sign In dialog), or to register with AltiumLive, if you don't yet have credentials.

Switch mode to be able to share a design snapshot with specific people on a permanent basis.Switch mode to be able to share a design snapshot with specific people on a permanent basis.

Enter the full email of a person with whom you want to share the snapshot and press Enter. Multiple people can be specified in this way, as needed. You can also add an optional note – to let them know anything pertinent about this specific snapshot being shared.

Example sharing of a design snapshot with a specific person, by email.Example sharing of a design snapshot with a specific person, by email.

Use the Share dialog's Advanced Settings options to specify the permissions applied to the shared project Snapshot. Select Allow sharing to allow the project snapshot to be re-shared by the specified person, and the Allow downloading option to enable downloading of the (zipped) snapshot.

Once ready, click the button. The project itself is packaged into a Zip archive using Altium NEXUS's Project Packager, then uploaded to the Altium 365 platform. Confirmation of upload is provided once the process completes.

 

The shared snapshot is packaged and then uploaded to the Altium 365 platform, where it is available on a permanent basis.The shared snapshot is packaged and then uploaded to the Altium 365 platform, where it is available on a permanent basis.

The person with whom you shared the uploaded design snapshot will receive an email invite to access that snapshot through Altium 365. Once they click the button in the email they will be taken to the Altium 365 Sign In page (unless already signed in to the platform, or their AltiumLive account). Upon signing in, they will be taken to the Web Viewer, with the shared design snapshot loaded.

If the person does not have an AltiumLive account, they will need to register for one first – an account creation form is provided when the Altium 365 link is opened.

Accessing the design snapshot from the email invite received by the user with whom the snapshot was shared.Accessing the design snapshot from the email invite received by the user with whom the snapshot was shared.

Accessing a Shared Design Snapshot

In addition to following the link in their email invite, a person with whom a permanent design snapshot has been shared will be able to access (open, share and view) that snapshot at any time from the Shared with Me page of their Altium 365 Personal Space. A design snapshot is denoted by the icon within its tile.

To open in the integrated Viewer, select the design's tile and click on the project name, or choose the Open option from the tile's ellipsis menu. Alternatively, double-click directly on the tile. Note that a shared design snapshot is not able to be edited and is therefore not accessible to Altium NEXUS through the Shared With Me location in the Open Project dialog – it can, however, be downloaded if it has been shared with that permission enabled.

Accessing a design snapshot from the Shared with Me page of the Altium 365 Platform Interface. In this example a Comment has been placed in the shared design.Accessing a design snapshot from the Shared with Me page of the Altium 365 Platform Interface. In this example a Comment has been placed in the shared design.

The person who originally shared the design snapshot – uploading it permanently to the Altium 365 platform – will also be able to access that snapshot from the Files page of their Personal Space .

Disabling Sharing

To disable sharing completely, uncheck the Altium Cloud option, on the System – Network Activity page of the Preferences dialog. If you attempt to share a design through the Share dialog – either live, or as a snapshot – a Warning dialog will appear, alerting you to the fact this option has been disabled.

Disabling connectivity to the Altium Cloud will prevent sharing of design projects.Disabling connectivity to the Altium Cloud will prevent sharing of design projects.

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

联系我们

联系原厂或当地办公室

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: