Altium NEXUS Documentation

创建PCB封装

Modified by Jun Chu on Sep 12, 2018
无论是在数据保险库还是通过AltiumLive提供的多个集成/分立元器件库,Altium均拥有数量巨大的现成PCB元器件。尽管如此,即使具备这一丰富的资源,在工程师职业生涯的某些时刻,他们仍将可能创建定制的PCB元器件。采用PCB编辑器中可用的同一套基元对象在PBC元器件库编辑器中创建“PCB元器件封装”。除了封装外,还可以将公司徽标、制造定义以及电路板设计期间所需的其他对象保存为“PCB元器件”。
 

在原理图绘制期间,安装在电路板上的真实元器件表述为原理图符号,在电路板设计时则表示为PCB封装。Altium NEXUS元器件可以:

  • 在本地元器件库中创建并从中放置,或者
  • 从全球共享的元器件存储系统Altium数据保险库中直接放置,该数据保险库包含成千上万的元器件,各元器件具备一个符号、封装、元器件参数以及供应商链接。

手动创建封装

控制型元器件封装的2D及3D视图。3D图像显示了适用于元器件的导入STEP模型,请注意,可在下文STEP模型中观察到焊盘和元器件覆盖层。

手动创建元器件封装的常见顺序为:

  1. 应在PCB元器件库编辑器中心的工作区参考点附近创建封装。使用“J、R”快捷键来直接跳到参考点。如果在开始创建您的封装前您就忘了移动到参考点,您可以使用“Edit » Set Reference参考”子菜单命令来将参考焊盘引入您的封装。
  2. 根据元器件要求放置焊盘Place » Pad)。在运行放置焊盘命令后但在放置第一个焊盘之前,按“Tab”键,打开“焊盘”对话框,定义所有的焊盘属性,包括焊盘“标号”、“大小和形状”、“层”以及“孔洞大小”(适用于通孔焊盘)。对于后续焊盘放置而言,标号将自动增加。对于表面安装焊盘,将层设置到“顶层”。对于通孔焊盘而言,将层设置到“多层”。
在标明焊盘时应多加小心,这是因为Altium NEXUS正是采用该属性从“原理图符号”上的引脚编号进行映射。
  1. 为了确保正确地放置焊盘,考虑专门为任务设置一个网格。采用“Ctrl+G”快捷键,打开“网格编辑器”对话框,按“Q”键,将网格从“英制”更改为“公制”,反之亦然。
  2.  为了在使用鼠标移动焊盘的同时准确放置焊盘,使用键盘方向键,按照当前网格增量移动光标, 此外,按住“Shift”,以网格的10倍速率移动。当前X、Y位置显示在“状态”栏上以及“抬头”显示中。“抬头”显示包含位置以及上次点击位置到当前光标位置的增量。使用“Shift+H”快捷键,打开及关闭“抬头”显示器。或者,双击编辑已放置焊盘,在“焊盘”对话框中直接输入X和Y位置。
  3. 为了核实工作区两点之间的距离,使用Reports »Measure Distance命令,也可以采用Ctrl+M快捷键。遵循“状态”栏上的提示。
  4. 根据焊盘3D尺寸以及适用的掩膜设计规则自动计算焊盘特定属性(例如阻焊层和助焊层)。虽然可以针对各焊盘手动定义掩膜设置,但这样一来将难以在电路板设计流程后期更改该等设置,通常而言,只有无法通过设计规则来瞄准焊盘时才能这样做。请注意,在电路板设计期间,在PCB编辑器中定义规则。
  5. 使用走线、圆弧和其他基元对象,在“丝印层”上界定元器件轮廓。
  6. 在机械层上放置走线和其他基元对象,定义其他机械细节,例如放置区域。机械层为通用层,工程师应分配该等层的功能,并在其封装间一致地运用该等层。
  7. 放置“3D体对象”,确定封装上适合的元器件的3D形状。可以放置多个“3D体”对象,供造型,或者,可以将STEP格式3D元器件模型导入到“3D体”对象中。
  8. 在放置到主要PCB工作区期间,标号和注释字符串被自动添加到封装的“丝印层”。可以通过在机械层上放置“标号”和“注释”字符串来纳入其他“标号”和“注释”字符串。
    在放置标号和注释字符串时,工程师需要在PCB编辑器中定义一个“层对”。这确保了字符串将会被连接到元器件所在的电路板的一边,并且在翻转元器件时字符串将翻转到电路板的另一边。欲了解与此相关的更多信息,请参见下文“处理特殊层特定要求”一节。
  9. 通过双击PCB元器件库面板中的封装清单上的名称,打开PCB元器件库封装对话框,重新命名已完成封装。元器件名称可以高达255个字符。
For a standardized pad / via definition across all footprints, the PAD/Via library (*.PvLiB) can be used for Pad/Via placement.  

使用IPC兼容封装向导创建元器件

“IPC兼容封装向导”创建IPC兼容元器件封装。“IPC兼容封装向导”使用来自于元器件本身的尺寸信息,然后根据IPC发布的算法计算适宜的焊盘和其他封装属性,而非直接依据封装大小运作(正如“元器件向导”一样)。

DPAK封装(“晶体管外形”)是“IPC兼容封装向导”中一种全新的被支持封装。

  • 选择“Tools » IPC Compliant Footprint Wizard”命令,运行“IPC兼容封装向导”。
  • 该向导可以创建下列封装类型:BGA封装、BQFP、CAPAE、CFP封装、CHIP阵列、DFN、CHIP、CQFP封装、DPAK、LCC封装、LGA、MELF、MOLDED、PLCC、PQFP、PQFP、PSON、QFN、QFN-2ROW、SODFL、小外形集成电路封装、SON、SOJ封装、SOP/TSOP封装、SOT143/343封装、SOT223封装、SOT23封装、SOT89封装以及WIRE WOUND。
  • IPC兼容封装向导”根据IPC发布的标准采用来自于元器件本身的尺寸信息。

IPC兼容封装向导的部分功能包括:

  • 可以输入并立即查看整体封装尺寸、引脚信息、脚间距、焊盘以及公差。
  • 可以输入“元件外框”、“组装”和“元器件(3D)主体信息”等机械尺寸。
  • 向导可实时填入数据,允许轻松地查看并作出调整。在各阶段显示封装预览。
  • 可在任一阶段按完成建,以生成当前预览的封装。
如果您在完成这个向导前点击“完成”,将采用适用于您选定的元器件类型的系统默认值来创建封装。

使用IPC封装批量生成器创建元器件

可采用“IPC封装批量生成器”,可批量生成多个封装。生成器从Excel电子表格或者逗号分隔文件中读取电子元器件的尺寸数据,然后采用IPC方程式创建IPC合格封装。“IPC封装批量生成器”支持包括:

  • 在Altium NEXUS安装时,将封装型空白模板文件纳入\Templates文件夹。
  • Package input files can contain the information for one or more footprints of a single package type and can be either an Excel or comma-delimited (CSV) format file.


“IPC封装批量生成器”可选择在开放PCB封装库中创建所有的封装,或者根据输入文件或封装名称生成单一元器件库。

使用元器件向导创建元器件

PCB元器件库编辑器”包含一个“元器件向导”。该向导让您能够从多种封装类型中进行选择、填写适当的信息,然后,它将为您创建元器件封装。请注意,在“元器件向导”中,工程师输入焊盘和元器件层所需的尺寸。

要启动“元器件向导”,右键点击“PCB元器件库”面板的“元器件”部分,选择“元器件向导”,或者选择“Tools»Component Wizard”命令。

纳入元器件的3D模型

可将元器件的3D表示纳入封装中。 可在Altium NEXUS中使用下列3D模型格式:

  • Altium NEXUS“3D体对象”,放置它们,创建所需的元器件形状。
  • STEP 模型 - *.Stp and *.Step.
  • SolidWorks 部件 - *.SldPrt.
  • Parasolid 模型 - *.x_t and *.x_b.

通过放置众多Altium NEXUS“3D体”对象来构成形状,方式是放置一个“3D体”对象并将3D模型导入其中,或者两者结合采用。

  •  为“3D体”对象分配一个机械层,然后在放置期间确保在“3D体”对话框中选择该层。
The Properties panel can also be used to reference a 3D model stored in a server. 
  • 借助于2D模式显示,通常可以更加轻易地从“3D体”对象中创建元器件形状。“3D体”对象的可用形状包括挤压型、圆柱形或球形。
  • 要在2D显示模式和3D显示模式之间切换“PCB元器件库”编辑器,按“2”和“3”快捷键。
  • 可从元器件制造商网站或者www.3dContentCentral.com等共享资源网站下载3D元器件模型。
  • 在3D模式显示下,更易于放置3D模型。要放置“通用”3D模型,首先放置“3D体”对象,当“3D体”对话框打开时,将“3D模型类型”设置到“通用3D模型”,选择“嵌入”选项,然后点击“从文件加载”按钮,找到3D模型文件的位置。
  • 当点击并按住3D模型移动时,属于3D模型嵌入的“3D体”对象的最近顶点或3D模型上定义的捕捉点将获取到该模型。可在“3D体”对话框中或者通过“Tools » 3D Body Placement » Add Snap Points from Vertices”命令中的命令定义捕捉点。该命令为交互式的,欲了解提示,参见“状态”栏。请注意,该命令有2种模式,默认模式为在用户选定的“顶点”添加“捕捉点”。在启动命令后,按“空格键”,启用第二种模式,在该模式下,工程师经提示,点击2个点,然后,软件计算并定位到位于2次点击中点的“捕捉点”。
  • 当“PCB元器件库”为3D显示模式时,采用标准Windows快捷键来放大及平移。正如在2D模式下,点击并按住鼠标右键,平移或滑动文件。为了旋转视图,按住“Shift”键,然后点击并按住鼠标右键。或者,使用3D鼠标,例如Space Navigator™。
  • 清单面板适用于编辑“3D体”对象属性,例如尺寸、转动和颜色。这些面板让工程师能够轻易地编辑某一值,并立即看到效果——对于旋转3D模型这类任务而言,再理想不过。
  • 3D模型支持不局限于元器件,它还可用来导入支架或者成品外壳等机械细节。将外壳直接导入PCB编辑器,如果它经链接而非嵌入,那么,当更改已链接3D模型时,PCB编辑器将跳出一个警告对话框,供重新加载3D模型。

同一封装,在左边,从一套“3D体”对象中创建物理元器件,而在右边,则已导入一个STEP模型。

请注意,Altium NEXUS的3D视图模式需要通过Shader Model 3(或更优)支持Microsoft DirectX 9(或更优)的显卡。

创建形状不规则的封装

部分封装需要形状不规则的焊盘。这可以通过使用“PCB元器件库编辑器”中可用的任何设计对象来实现,然而,在这样做时,还须牢记一个重要因素。


通过放置多个对象来创建形状不规则的焊盘。

Altium NEXUS根据其形状自动将阻焊层和助焊层添加到焊盘对象。根据默认设计规则定义默认扩展量值,但还可以通过“优选设置”对话框中的“PCB Editor » Defaults”页面所含“焊盘基元”类型设置来规定扩展量值。在放置期间或者放置后,可通过“焊盘”对话框来禁用这些设置。

  欲了解与使用设计规则来定义默认扩展量值相关的更多信息,参见“设计规则参考”一节的“掩膜规则”。

创建定制焊盘形状

Main article: Working with Custom Pad Shapes

如果只采用焊盘对象来创建不规则形状,那么将正确地生成匹配的不规则形状。然而,如果是用其他对象(例如线条(走线)、填充物、区域、焊盘、过孔或圆弧)来创建不规则形状,将需要手动处理阻焊层和助焊层。

All object-kinds have a solder mask property, and fill and region objects also have a paste mask expansion property. If these objects have been placed on the top layer to create a pad shape, then the solder mask property of those objects can be enabled to either obey the applicable design rule, or use a manual expansion value. If fill and region objects have been used to build up a pad shape, then the paste mask can also be enabled as a property of the extra objects.

When the mask shape is not correctly created as an expansion (or contraction) of the set of objects used to create the custom pad shape, then manually defined solder and paste mask expansions can be also achieved by placing lines (tracks), fills, regions, or arc primitives directly on the corresponding solder or paste mask layer. The custom button footprint shown below is an example of this.

必须在其形状内使用焊盘,以便软件知道在哪里连接网络。

显示阻焊层/助焊层

为了核实已在“PCB元器件库编辑器”中正确定义阻焊层和/或助焊层,打开视图设置对话框,启用各掩膜层的“显示”选项 () 。

下文“具备连接到同一引脚的多个焊盘的封装”一节的图像展示了紫色(“顶层阻焊层”的颜色)边缘的PCB封装,它似乎出现在各焊盘的边缘。这代表按照焊盘下的扩展量突出的阻焊层形状的边缘。

要快速浏览各图层,请将单层模式(Shift + S)与Ctrl + Shift +滚轮组合使用。

管理具备布线基元的元器件

在转移设计时,从可用元器件库提取各元器件规定的封装并放置在电路板上。然后,封装中的每个焊盘都将其网络属性设置为连接到原理图中该元件引脚的网络名称。 所有与焊盘有接触的物体连接到与焊盘相同的网络。

“PCB编辑器”包括一个综合的网络管理工具。要启动它,从菜单中选择“Design»Net list»Configure Physical Nets”。点击选项菜单的“菜单”按钮,点击“新网络名称”区域,选择网络分配到未分配的基元。

具备连接到同一引脚的多个焊盘的封装

下文所示封装,即,SOT223晶体管,具备连接到同一逻辑原理图元器件引脚——引脚2——的多个焊盘。为了形成该连接,添加了具备同一标号“2”的两个焊盘。在“原理图编辑器”中使用“Design»Update PCB”命令将设计信息转移到PCB时,随之发生的同步将表明连接线接到PCB编辑器中的两个焊盘。


SOT223封装,显示了具备一个“2”标号的两个焊盘。

处理特殊阻焊层要求

下面所示的封装是直接安装在PCB表面铜层上的按钮开关触点组。


该按钮封装,通过放置焊盘、走线和圆弧来设计。
在PCB顶层放置一个橡胶开关焊盘层,以及一个小型附属碳按钮,当按下按钮以便形成电路连接时,该按钮将接触到封装中的两套引脚。为了做到这点,两套引脚均不得被阻焊层覆盖。

通过放置圆弧(该圆弧的宽度等于或超过圆弧半径)来取得圆形阻焊层开口,从而带来下文两套引脚所示的实心圆 (selected in the image to make them visible)。由圆弧、水平走线和焊盘决定各套铜引脚。焊盘须确定连接点。将元器件放置在电路板底部时,手动放置的阻焊层定义将被自动转移到底部阻焊层掩膜层。

标号与注释字符串

默认标号与注释字符串

在电路板上放置封装时,将根据从设计的“原理图”视图中提取的信息提供标号和注释。将封装放置到电路板上时,将自动添加适用于标号和注释字符串的占位符,因此,这些占位符无需手动定义。这些字符串的位置由元器件“属性”对话框中的标号和注释字符串“自动位置”选项决定。“标号和注释”字符串的默认位置和大小由“优选设置”对话框“PCB编辑器-默认值”页面中的“元器件基元”所含设置控制。

其他标号和注释字符串

还存在需要其他标号或注释字符串的情况——例如,装配厂可能想要在各元器件形状内列示了标号的详细组装图纸,而内部公司要求则规定将标号刚好放置在最终PCB元器件覆盖层上的元器件上方。通过在封装中包含.Designator特殊字符串可以实现对附加指示符的这一要求。 而 .Comment特殊字符串也可用于规定备用图层或位置上的注释字符串的位置。

为了满足装配厂的要求,在元器件库编辑器中将“标号”字符串放置在机械层上,那么,则可以生成包括该层的打印输出,作为设计组装说明的一部分。

处理特殊层特定要求

存在PCB元器件可以具备的众多特殊要求,例如,需要点胶点或者可剥离阻焊层定义。众多这些特殊要求将会被连接到元器件所在的电路板的一侧,并且在翻动元器件时字符串将翻转到电路板的另一边。

Altium NEXUS的PCB编辑器通过被称为“层对”的功能来支持该要求,而非纳入可能鲜少使用到的众多特殊目的层。层对只是被定义为一对的两个机械层。每当元器件从电路板的一侧翻转到另一侧时,配对机械层上的任何对象均翻转到该配对中的另一机械层上。

须在翻转元器件前定义“层配对”。如果在将元器件移动到底侧后定义配对,机械内容将翻转但仍停留在原始层上。如果您忘了在翻转前创建层对,您可以从元器件库中更新,更新放置在电路板上的元器件的情况。

The Names of Mechanical Layers can be edited directly from the View Configurations dialog by right-clicking then selecting Edit Layer.

添加PCB封装高度

在最简单的3D表示形式下,可向“PCB元器件”添加高度信息。为此,双击“PCB元器件库”面板中“丰庄”清单中的封装,显示“PCB元器件库元器件”对话框。在“高度”栏输入适用于元器件的建议高度。

在电路板设计期间,可以定义高度设计规则(在“PCB编辑器”中选择“Design » Rules”),通常在一个类别的元器件中或者room定义中针对最大元器件高度进行测试。

将3D体和/或STEP模型附加到“PCB元器件”上将是一个定义“高度”信息的更好方案。将在其他模型中讨论与此相关的细节。

从其它来源添加封装

可从其他“PCB元器件库”复制“PCB元器件”,然后在目的地元器件库中对此重新命名并修改,以便符合所需的规格。有许多方法可进行该等复制:

  • 在PCB文件中选择一个已放置封装,复制(Edit » Copy)并使用“Edit » Paste Component”将它们粘贴到打开的PCB元器件库。
  • 当拟复制的封装在“PCB元器件库编辑器”中可用时,选择Edit » Copy Component,更改到打开的PCB目的地元器件库,选择Edit » Paste Component
  • 使用标准“Shift+Click”或“Ctrl+Click”在面板的清单中选择一个或多个封装,右键点击并选择“复制”,转换为目标元器件库,右键点击封装名称清单,选择“粘贴”。

验证元器件封装

工程师可运行一系列的报告来核实是否正确创建了封装以及定义哪些元器件位于当前PCB元器件库中。

通过测试重复基元、漏掉的焊盘标号、浮空敷铜以及不适宜的元器件参照,“元器件规则检测”报告(报告»元器件规则检测)有助验证当前PCB元器件库中的所有元器件。

验证集成库内的PCB元器件库

将PCB元器件库纳入作为“集成库封装”的一部分提供了另一层验证,这是因为它让“设计编辑器”能够一同检查原理图和PCB模型。当然,这要求存在与“PCB元器件库”匹配的“原理图元件库”,假设情况是这样,则可能运用项目选项对话框错误报告进行一系列的其他检测。

更新PCB封装

可以以两种方式之一更新“PCB封装”: 通过从“PCB元器件库”中“推送”PCB,或者通过从“PCB编辑器”中提取更新。推送PCB封装更新从“PCB元器件库”中取得选定的封装,将其用来更新含该封装的所有打开的PCB文件。如果需要完全更换,第一种方法是最好的方法。第二种方法,即,提取,让工程师在执行更新前能够审查现有封装与元器件库封装之间的所有差异。同样的,工程师可以选择需要从元器件库中更新哪些对象。当您需要弄清楚电路板上的封装与元器件库封装之间究竟发生了哪些变化时,第二种方法是最佳的方法。

从PCB元器件库中进行封装更新

在“PCB元器件库编辑器”中,使用“Tools » Update PCB with Current Footprint”或“Tools » Update PCB With All Footprints”命令。在“PCB元器件库”面板中,“PCB元器件库”面板的“元器件”区域双击,选择“Update PCB with [Component]”或“Update PCB with All”。运行这些命令将打开“元器件更新选项”对话框,您可以从对话框中选择拟更新的基元/属性。

选定的更新被推送到所有打开的PCB文件中的相关封装。

从PCB编辑器中提取封装更新

在“PCB编辑器”中,使用“Tools » Update From PCB Libraries”命令,该命令依次打开“从PCB元器件库更新-选项”,点击OK打开“从PCB元器件库更新”对话框。

将已完成PCB封装发布到数据保险库

在完成“PCB封装”创建后,可将封装以及任何其他3D模型/主体信息(所有均共同创建元器件模型)发布到Altium数据保险库并存储在其中。在单一的实体中,基于数据保险库的元器件将所有设计领域之间代表该等元器件所需的所有信息整合到一起。因此,可以认为它是与此相关的容器。即,存储所有域模型和参数信息的“桶”。

就其在多个域的表示而言,基于数据保险库的元器件本身并不含域模型,但包含到该等模型的链接。作为源元器件定义的一部分,在设计侧对这些链接进行说明——已发布元器件条目来自于其中。同样的,在您能够深入研究基于数据保险库的元器件的定义与发布流程前,您须首先确保已创建并发布了所有域模型本身。

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

联系我们

联系原厂或当地办公室

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
You are reporting an issue with the following selected text
and/or image within the active document:
Altium Concord Pro 免费试用

请填写下方表格获取Altium Concord Pro 免费试用