Altium NEXUS Documentation

Working with a Board Region Object on a PCB in Altium NEXUS

Created: November 5, 2020 | Updated: October 13, 2021

Parent page: PCB Design Objects

The Board Region for a traditional rigid board, with two Board Cutouts.
The Board Region for a traditional rigid board, with two Board Cutouts.

Summary

A Board Region is a user-defined area of a PCB that can have a unique layer stack assigned to it. A PCB can have a single Board Region (for a traditional rigid PCB), or be made up of multiple Board Regions (for a rigid-flex PCB). The overall outer edge of the Board Region(s) defines the Board Shape.

Rigid-Flex is under active development. To switch to Rigid-Flex 2 mode, enable the following options in the Advanced Settings dialog:

  • PCB.RigidFlex2.0 - enables the Rigid-Flex 2 features in Board Planning Mode. Note that in previous releases of Altium NEXUS this option was called Legacy.PCB.RigidFlex. The behavior has changed along with the name change; enabling the old option restored the old mode (Rigid-Flex1.0), whereas enabling the new option enables the new mode (Rigid-Flex2.0).
  • PCB.RigidFlex.SubstackPlanning - enables the Board view in the Layer Stack Manager.

Learn more about Rigid-Flex Design

Availability

Board Regions are implemented in the PCB Editor with the View mode set to Board Planning Mode (View » Board Planning Mode, or press the 1 shortcut).

Placement


The video demonstrates creating the Board Shape from selected objects and then slicing the shape to create the three regions needed.
Then it shows an alternate approach, where the three Board Regions are defined from selected objects.

Board Regions are placed and modified in Board Planning Mode:

  1. Select View » Board Planning Mode (or press the 1 shortcut) to enter Board Planning Mode. The default existing Board Region will display as a green rectangle.
  2. Select Place » Board Region to place a new region (or click the button on the Active Bar).
  3. Position the cursor and click to anchor the starting vertex for the Board Region. The Board Region is a polygonal object, like a Region or Polygon, and has the same placement process.
  4. Move the cursor ready to place the second vertex. The default behavior is to place 2 edges with each click with a user-defined corner shape between them, press the Spacebar to toggle the corner direction. Refer to the Placement Modes section below for more details on changing corner modes.
  5. Continue to move the mouse and click to place vertices, creating the edges required to define the overall shape of the Board Region.
  6. After placing the final vertex, right-click or press Esc to close and complete the definition of the board shape. There is no need to manually close the board shape as the software will automatically complete the shape by connecting the last point placed back to the start point.
  7. Each Board Region is named to uniquely identify it. Enter a suitable name in the Name field in the Board Region mode of the Properties panel (the Board Region must be selected in the design space to display its properties in the panel).
  8. Each Board Region must have a layer stack assigned. When a new Board Region is created it will be assigned the default layer stack, named Board Layer Stack. Assign the required Layer stack in the Board Region mode of the Properties panel. Layer stacks are defined and named in the Layer Stack Manager.
  9. If the final PCB requires multiple Board Regions, continue to define additional regions.
  • Each region displays a label that shows the region name and the name of the layer stack assigned to it in the form Region Name - Layer Stack Name. The Board Region is named in the Board Region mode of the Properties panel, and the Layer Stack is named in the Layer Stack Manager.
  • Any number of Board Regions can be placed to build up the required Board Shape. Board Regions can overlap, note that this does not define the distance that one region intrudes into its neighbor region, that is defined as part of the layer stack configuration in the Layer Stack Manager.
  • To remove a Board Region, select it then press the Delete key on the keyboard. There must always be at least one Board Region, you will not be able to delete the last one.
  • As well as drawing the Board Region, they can also be created from primitives - learn more in the Converting between 2D Drawing Primitives and Board Definition Objects section of this page.
  • Board Regions can also be created from 3 Body objects by using the Create Board Region from 3D Body command while in 3D mode. 
  • During placement of a Board Region the cursor is constrained by the cursor snap settings, which includes: the current Snap Grid, the available Objects for Snapping, the presence of Workspace Guides, and the Axes Snapping settings - use these features to help achieve the required shape.

    Learn more about Understanding the Snap Behavior.

Additionally, you can press the Tab key to pause the placement and access the Board Region mode of the Properties panel from where its properties can be changed on the fly. Click the design space pause button overlay () to resume placement.

Placement Modes

When redefining the board shape there are five available corner modes, four of which also have corner direction sub-modes. During redefinition:

  • Press Shift+Spacebar to cycle through the five available corner modes.
  • Press Spacebar to toggle between the two corner direction sub-modes.
  • When in either of the arc corner modes, hold the  key to shrink or the key to grow the arc. Hold the Shift key as you press to accelerate arc resizing.
  • Press the 1 shortcut key to toggle between placing two edges per click, or one edge per click. In the second mode, the dashed edge is referred to as the look-ahead segment (as shown in the last image in the set below).
  • Press the Backspace key to remove the last vertex.

Press Shift+Spacebar to cycle through the five available corner modes, press the 1 shortcut to toggle placement between two edges or one edge. Press Shift+Spacebar to cycle through the five available corner modes, press the 1 shortcut to toggle placement between two edges or one edge.
Press Shift+Spacebar to cycle through the five available corner modes, press the 1 shortcut to toggle placement between two edges or one edge. Press Shift+Spacebar to cycle through the five available corner modes, press the 1 shortcut to toggle placement between two edges or one edge.
Press Shift+Spacebar to cycle through the five available corner modes, press the 1 shortcut to toggle placement between two edges or one edge. Press Shift+Spacebar to cycle through the five available corner modes, press the 1 shortcut to toggle placement between two edges or one edge.
Press Shift+Spacebar to cycle through the five available corner modes, press the 1 shortcut to toggle placement between two edges or one edge.

Creating a Board Cutout Region

To create an internal cutout in the board, place a Board Cutout Region (Place » Define Board Cutout, or click the button on the Active Bar). A Board Cutout is also a polygonal object, so has the same placement process as the Board Region itself. The images below show a Board Region with two Board Cutouts, these become holes in the board when it is fabricated.

A Board Cutout placed on a Board Region becomes a hole in the finished board. A Board Cutout placed on a Board Region becomes a hole in the finished board.A Board Cutout placed on a Board Region becomes a hole in the finished board.

Slicing a Board Region

An existing Board Region can be sliced into two separate Board Regions. To slice a region (in Board Planning Mode):

  • Select the Design » Slice Board Region command (or click the  button on the Active Bar).
  • Slicing behavior is the same as track (or polygon boundary) placement behavior, there are five corner modes. Press Shift+Spacebar to cycle through the corner modes and Spacebar to toggle the corner direction.
  • Slicing must start and end on an edge or outside of the Board Region.
  • When you right-click to end the slicing command the Confirm dialog will appear (as shown below), after clicking Yes the Board Region will be split into two Board Regions.
  • Move or reshape the Board Regions as required, and assign a suitable Name and Layer Stack in the Properties panel.

The video above demonstrates slicing the Board Shape to create three Board Regions needed in a rigid-flex design.

Converting between 2D Drawing Primitives and Board Definition Objects

A common approach to defining the Board Shape, and the Board Regions needed in that shape, is to import a drawing from a mechanical CAD package. For example, you might import mechanical detail in a DWG file, giving you a set of lines (tracks) on a mechanical layer that define: the board shape, the regions within the shape, and for a rigid-flex design, lines that define the location of bend lines in the flexible regions.

The software includes a number of commands to help create board definition objects (Region, Cutout, Bend Line) from 2D drawing primitives, and also partner commands to convert board definition objects back to drawing primitives.

Object From selected 2D Drawing Primitives From Board Design Objects
Board Region Create Board Region from Selected Objects
(Design » Board Shape submenu)
Explode Region to Free Primitives
Board Cutout Create Board Cutout from Selected Primitives Explode Board Cutout to Free Primitives
Bend Line Convert Selected Line to Bend Line Explode Bend Line

Notes:

  • Commands for both directions are available in the Tools » Convert submenu of the relevant View mode (apart from the Create Board Region from Selected Objects command, which is in the Design » Board Shape submenu).
  • To convert 2D drawing primitives to board definition objects, switch the view to 2D Layout Mode.
    • The primitive(s) must be selected before running the command.
    • The primitives must form a closed shape to create a Region or Cutout. Check the warning box below to learn more about the requirements of this shape.
  • To convert board definition objects to 2D drawing objects, switch the view to Board Planning Mode.
    • These commands do not require the object(s) to be pre-selected but will act on the selected object if one is already selected.
    • If there are multiple Board Regions present, the Region disappears when it is exploded to primitives. If there is only one Board Region present, the primitives will be created and the chosen Board Region will remain (there must always be one Board Region).
    • 2D drawing objects are created on the Board Shape layer. If a layer of this Layer Type does not exist in the board, a mechanical layer will be added with its Layer Type set to Board Shape. Learn more about Mechanical Layers and Layer Types.

Learn more about the Board Shape

All of the commands that create a polygonal shape based on an outline constructed from lines (tracks) and arcs, will attempt to find the shape by following the centerline of the selected objects. If the coordinates for the end of one track/arc segment do not exactly match the coordinates of the next track/arc segment then the boundary identification algorithm will fail and a message will be displayed showing the failure location. It will then offer to use a tracing algorithm instead. Note that the tracing algorithm follows the outer edge of the track/arc objects so the shape will be slightly different than the one created from the centerlines, only choose this option if your design can accept the impact of this difference.

Graphical Editing

Related article: Editing Polygonal Objects

Board Regions (and Board Cutouts) are polygonal objects, their shape can be modified in the same way as all other polygonal objects. Points to remember about editing a polygonal object:

  • When you click and drag on a vertex or polygon edge there are 3 reshaping modes available, sliding, breaking, and incurvating - press Shift+Spacebar to cycle through the modes as you are dragging. The current mode is displayed on the Status bar and in the Heads-Up display.
  • The cursor snapping behavior is controlled by the current cursor snap settings, which include the current Snap Grid, the available Objects for Snapping, the presence of Workspace Guides, and the Axes Snapping settings - use these features to help you achieve the required shape. Learn more about Understanding the Snap Behavior.
If attempting to graphically modify an object that has its Locked property enabled, a dialog will appear asking for confirmation to proceed with the edit. If the Protect Locked Objects option is enabled on the PCB Editor – General page of the Preferences dialog and the Locked option for that design object is enabled as well, that object cannot be graphically edited. Double-click the locked object to select it then disable the Locked property in the Properties or List panel or disable the Protect Locked Objects option to graphically edit the object.

Non-Graphical Editing

The following methods of non-graphical editing are available.

Editing via the Board Region Dialog or Properties Panel

Properties page: Board Region Properties

This method of editing uses the associated Board Region dialog and Properties panel mode to modify the properties of a Board Region object.

The Board Region dialog (the first image) and the Board Region mode of the Properties panel (the second image) The Board Region dialog (the first image) and the Board Region mode of the Properties panel (the second image)
The Board Region dialog (the first image) and the Board Region mode of the Properties panel (the second image)

During placement, the Board Region mode of the Properties panel can be accessed by pressing the Tab key. Once the Board Region is placed, all options appear.

After placement, the Board Region dialog can be accessed by:

  • Double-clicking on the placed Board Region object.
  • Placing the cursor over the Board Region object, right-clicking then choosing Properties from the context menu.

After placement, the Board Region mode of the Properties panel can be accessed in one of the following ways:

  • If the Properties panel is already active, select the Board Region object.
  • After selecting the Board Region object, select the Properties panel from the Panels button at the bottom right of the design space or select View » Panels » Properties from the main menus.
If the Double Click Runs Interactive Properties option is disabled (default) on the PCB Editor – General page of the Preferences dialog, when the primitive is double-clicked or you right-click on a selected primitive then choose Properties, the dialog will open. When the Double Click Runs Interactive Properties option is enabled, the Properties panel will open.
While the options are the same in the dialog and the panel, the order and placement of the options may differ slightly.
Press Ctrl+Q to toggle the units of measurement currently used in the dialog/panel between metric (mm) and imperial (mil). This only affects the display of measurements in the dialog/panel; it does not change the measurement unit specified for the board, which is configured in the Units setting in the Properties panel when there are no objects selected in the design space.

Editing Multiple Objects

The Properties panel supports editing multiple objects, where the property settings that are identical in all currently selected objects may be modified. When multiples of the same object type are selected manually or through a List panel, a Properties panel field entry can be edited for all selected objects. If values of a property are different for objects in the selection, the appropriate field will be shown as an asterisk (*) – a new property value will be applied to all selected objects.

Editing via a List Panel

Panel page: PCB List

A List panel allows you to display design objects from one or more documents in tabular format, enabling quick inspection and modification of object attributes.

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

联系我们

联系原厂或当地办公室

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: