Altium NEXUS Documentation

Connection

Modified by Tiffany Cullen on Jan 2, 2020

Parent page: PCB Objects

Unrouted connection lines between the
pads of two placed board components.

Summary

Connection lines are the visual representation of the logical connectivity between net objects. Each of these lines, connecting one pin in a net to another pin in the net, is called a From To. The entire set of connections (From Tos) for a design is often referred to as the 'rats nest'.

The connection lines are subsequently used when interactively routing (or Autorouting) in order to achieve the physical, routed links between the logically connected objects in each net.

Availability & Placement

Default connections (From Tos) are automatically generated and placed by the PCB's Connectivity Analyzer when nets are loaded into the PCB design document (i.e. when importing the design or design changes from the schematic). As such, a connection is not a design object that you can access or place.

When the components and connective (net) information are loaded into a PCB design, the pin-to-pin connections are displayed for each net. These connection lines are in fact system-generated From Tos, added and arranged by the PCB Editor to give the shortest overall connection length in each case - a net topology referred to as Shortest.

The topology of part or all of a net can be changed by adding specific User-defined From Tos. User-defined From Tos are added using the PCB panel configured in From-To Editor mode.

Non-Graphical Editing

A connection object cannot be edited with respect to properties in the usual manner; it cannot be selected in the workspace, has no corresponding Properties panel mode or dialog and cannot be edited graphically. The following sections define what can be done with connection lines through non-graphical editing.

Defining the Default Connection Line Color

The layer upon which connection lines are displayed can be enabled/disabled with respect to its visibility using the corresponding  for the Connection Lines entry in the System Colors region on the Layers & Colors tab of the View Configuration panel with the board in 2D Layout Mode).

The visibility and coloring for the connections (and from tos) can be controlled from the Layers & Colors tab of the View Configuration panel.

Define the display color by clicking on the color swatch to open a color chooser (which only allows changing the color for Connections and From Tos) from where you can choose from a range of predefined colors or create your own custom color. You can save any view configurations for use in other projects.

Changing the Connection Line Color

An easy way to make important nets stand out during the routing process is to change the color of their connection lines. To do this, double-click the net name in the Nets mode of the PCB panel to access the Edit Net dialog from where you can edit the connection line color.

Double-click in the PCB panel to edit a net's connection line color.

Displaying Connection Lines using Layer Colors

As well as setting the connection line color for individual nets, you also can display the connection lines using the colors of the start and end layers to which the connection line travels. These connection lines are displayed as dashed lines using the colors of both the start and end layers. This feature is ideal when you are routing a multi-layer board since you easily can see to which target layer the connection being routed must go.

Note that this dashed color override is only applied to nets that travel from one layer to another; if the connection starts and ends on the same layer, it retains its defined color.

To use the color-by-layer feature, enable the Use Layer Colors for Connection Drawing option in the Additional Options region of the View Options tab of the View Configuration panel. The images below show the same region of the board in single layer mode from the Top Layer, then from the Bottom Layer.

 An example of connection lines that connect between different layers in a multi-layer board in single layer mode.

Displaying Connection Lines in Single Layer Mode

A multi-layer board is visually dense, making it difficult to interpret what is occurring. To help with this, you easily can switch the layer display from the chosen Layers to Single Layer mode by pressing the Shift+S shortcut. Normally, when you do this, all connection lines that do not either start or end on the current layer are also hidden, since it is assumed they are not relevant. To always display the connection lines, enable the All Connections in Single Layer Mode option in the Additional Options region of the View Options tab of the View Configuration panel.

Controlling Connection Line Visibility

You can control which connection lines in the entire rats nest of connections are shown and which are hidden. Use the available commands on the View » Connections sub-menu (from the main menus) to:

  • Show or hide all connection lines for the design.
  • Show or hide all connection lines associated with a chosen net.
  • Show or hide the connection lines for all nets associated with a chosen component.

How From-To Objects Show in the Workspace

A system-generated From To does not appear in the workspace as a separate entity - only the associated pin-to-pin connection line for the From To is displayed, which is used for interactive routing/Autorouting guidance. A user-defined From To appears in the workspace as a dotted line, separate and distinct from the pin-to-pin connection line that is also displayed when the From To is added. The user-defined From To line controls where the associated pin-to-pin connection line starts and finishes.

If you specify user-defined From Tos for only part of a net, the PCB Editor will set the remaining pin-to-pin connections (system-generated From Tos) to the Shortest topology.

The type of From To determines how the Connectivity Analyzer treats the pin-to-pin connection line when, for example, a net object is moved or part of a net is manually routed:

  • System-generated From To - the connection line can be moved as required as part of the Connectivity Analyzer's re-optimization to keep the default topology of the net (i.e. Shortest).
  • User-defined From To - if the From To is not the result of selecting a predefined topology, the connection line is not considered as part of the Connectivity Analyzer's re-optimization process. If the From To is part of a predefined net topology (other than Shortest), the Connectivity Analyzer can include it in re-optimization as long as the chosen topology is kept.
During component moves, all connection lines are automatically hidden except those that go from a moving component to a non-moving component. If currently hidden, the connection lines that are part of the move are automatically displayed. To toggle the display of these connection lines while moving a component, press the N key while in movement mode. When pressing the N key in movement mode, the Heads Up display between Show to Hide, depending on whether the component is shown or hidden.
 
Many of the the settings, such as the current routing mode, width, gap and via size, are displayed on the Status bar or the Heads Up display (Shift+H to toggle it on/off).

Connectivity During Interactive Routing

The PCB Editor is a connectivity-aware design environment. At all stages of routing your design, the software monitors and manages the netlist connectivity. Because the PCB's Connectivity Analyzer automatically monitors the completion status of the net you are routing, you can route without regard to the arrangement of the pin-to-pin connections. Once you complete a connection, the entire net is reanalyzed and connection lines are added and re-optimized as necessary.

There are two distinct advantages to this methodology. The first is that you can route a track to any primitive on the net; you do not have to route between the two points connected by the connection lines. The Connectivity Analyzer monitors your progress and adds and removes the connection lines automatically. The second is that the net connectivity is "unbreakable"; you cannot accidentally break it into two unconnected parts. If you delete a track segment, the software detects the break and immediately adds a connection line to restore the net connectivity.

When a net is analyzed and a connection line added, the software automatically adds it based on the topology of the net. By default, all nets have their topology set to Shortest. For these nets, a from-to is added where the two sub-nets are closest. If the net has a user-defined topology applied, the connection line is added to maintain the topology and is shown as a dotted line (called a Broken Net Marker), indicating that the net should be routed between these two points to maintain the topology.

An example Broken Net Marker (top) - a system-generated from-to (connection line) advising how the
two points should be routed to satisfy topology.


If the Smart Track Ends option is enabled on the PCB Editor - General page of the Preferences dialog, the Connectivity Analyzer will attempt to keep connection lines attached to the ends of the tracks. For example, if you start routing from a pad then stop the routing (leaving the track end in free space), the Analyzer will attach the connection line to the track end.
Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

联系我们

联系原厂或当地办公室

You are reporting an issue with the following selected text
and/or image within the active document:
Altium Designer 免费试用
Altium Designer Free Trial
我们开始吧!首先,您或者您的公司已经在使用Altium Designer了吗?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

既然您在使用Altium Designer,为何仍需要试用?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

好的,实际上您无需下载一个试用版本。

点击下方按钮下载最新版本的Altium Designer安装包

下载Altium Designer 安装包

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

填写下方表格,获取Altium Designer最新报价。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

如果您是Altium维保期内客户,您不需要下载试用版本。

如果您不是Altium维保客户,请填写下方表格免费试用。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

您为何想要试用Altium Designer?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

那您来对地方了!请填写下方表格申请试用吧。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

好的,您可以下载免费的Altium Designer Viewer查看文档,有效期6个月。

请填写下方表格申请。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

好棒!创作是一件超酷的事情,我们可以为您提供完美的设计软件。

Upverter是一个社区导向的交流平台,专为您这样的创客量身定做。

点击这里看看吧!

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

好的,您可以下载免费的Altium Designer Viewer查看文档,有效期6个月。

请填写下方表格申请。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。