Altium NEXUS Documentation

PCB_Obj-CoordinateCoordinate_AD

Modified by Admin on Apr 11, 2017
All Contents

Parent page: PCB Objects

A placed Coordinate.

Summary

A coordinate is a group design object. It is used to mark the X (horizontal) and Y (vertical) distance of a point in the design workspace relative to the current origin. Coordinates can be placed on any layer.

Availability

Coordinates are available for placement in both PCB and PCB Library Editors:

  • PCB Editor - the following methods of access are available:
    • Choose Place » Coordinate from the main menus.
    • Click the  button on the Utility Tools drop-down () of the Utilities toolbar.
  • PCB Library Editor - the following methods of access are available:
    • Click the  button on the PCB Lib Placement toolbar.
    • Right-click in the workspace and select Place » Coordinate from the context menu.

Placement

After launching the command, the cursor will change to a cross-hair and you will enter coordinate placement mode. A coordinate will appear "floating" on the cursor:

  1. Position the cursor and click or press Enter to place a coordinate.
  2. Continue placing further coordinates, or right-click or press Esc to exit placement mode.

Additional actions that can be performed during placement are:

  • Press the L key to flip the coordinate to the other side of the board.
  • Press the + and - keys (on the numeric keypad) to cycle forward and backward through all visible layers in the design respectively – to change placement layer quickly.
  • Press the Tab key to access an associated properties dialog, from where properties for the coordinate can be changed on-the-fly.
While attributes can be modified during placement (Tab to bring up associated properties dialog), bear in mind that these will become the default settings for further placement unless the Permanent option on the PCB Editor – Defaults page of the Preferences dialog is enabled. When this option is enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement session.

Graphical Editing

This method of editing allows you to select a placed coordinate object directly in the workspace and change its location graphically. The size and shape of a coordinate object cannot be changed graphically. As such, editing handles are not available when the coordinate object is selected:

A selected Coordinate.

  • Click anywhere on the coordinate and drag to reposition it. The position values are automatically updated as the coordinate is moved.

If attempting to graphically modify an object that has its Locked property enabled, a dialog will appear asking for confirmation to proceed with the edit. If the Protect Locked Objects option is enabled on the PCB Editor – General page of the Preferences dialog, and the Locked option for that design object is enabled as well, then that object cannot be selected or graphically edited. Double click on the locked object directly and disable the Locked property or disable the Protect Locked Objects option, to graphically edit the object.

Non-Graphical Editing

The following methods of non-graphical editing are available:

Editing via an Associated Properties Dialog

Dialog page: Coordinate

This method of editing uses the following dialog to modify the properties of a coordinate object.

The Coordinate dialog.

The Coordinate dialog can be accessed prior to entering placement mode, from the PCB Editor – Defaults page of the Preferences dialog. This allows the default properties for the coordinate object to be changed, which will be applied when placing subsequent coordinates.

During placement, the dialog can be accessed by pressing the Tab key.

After placement, the dialog can be accessed in one of the following ways:

  • Double-clicking on a placed coordinate object.
  • Placing the cursor over a coordinate object, right-clicking and choosing Properties from the context menu.
  • Using the Edit » Change command and clicking once over a placed coordinate object.

Quickly change the units of measurement currently used in the dialog between metric (mm) and imperial (mil) using the Ctrl+Q shortcut. This affects the dialog only and does not change the actual measurement unit employed for the board, as determined by the Measurement Unit setting in the Board Options dialog (Design » Board Options).

Via an Inspector Panel

Panel page: PCB Inspector, PCB Filter, PCBLIB Inspector, PCBLIB Filter

An Inspector panel enables the designer to interrogate and edit the properties of one or more design objects in the active document. Used in conjunction with appropriate filtering - by using the applicable Filter panel, or the Find Similar Objects dialog - the panel can be used to make changes to multiple objects of the same kind, from one convenient location.

Via a List Panel

Panel page: PCB List, PCB Filter, PCBLIB List, PCBLIB Filter

A List panel allows the designer to display design objects from one or more documents in tabular format, enabling quick inspection and modification of object attributes. Used in conjunction with appropriate filtering - by using the applicable Filter panel, or the Find Similar Objects dialog - it enables the display of just those objects falling under the scope of the active filter – allowing the designer to target and edit multiple design objects with greater accuracy and efficiency.

Tips

  1. In the PCB Editor, the current origin can be set to be any point in the PCB workspace by selecting Edit » Origin » Set, and clicking on the location for the new origin. To set the current origin back to the absolute origin ((0,0) in the lower-left corner of the workspace), select Edit » Origin » Reset.
  2. The coordinate group object is comprised of a string specifying the actual X,Y position and a point marker (small cross of two tracks) . In the PCB Editor, a coordinate can be converted to its constituent primitive objects using the Tools » Convert » Explode Coordinate to Free Primitives command. Explode a coordinate to reposition the position string without changing the location of the marker.

 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

联系我们

联系原厂或当地办公室

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document:
Altium Designer 免费试用
Altium Designer Free Trial
我们开始吧!首先,您或者您的公司已经在使用Altium Designer了吗?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

既然您在使用Altium Designer,为何仍需要试用?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

好的,实际上您无需下载一个试用版本。

点击下方按钮下载最新版本的Altium Designer安装包

下载Altium Designer 安装包

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

填写下方表格,获取Altium Designer最新报价。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

如果您是Altium维保期内客户,您不需要下载试用版本。

如果您不是Altium维保客户,请填写下方表格免费试用。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

您为何想要试用Altium Designer?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

那您来对地方了!请填写下方表格申请试用吧。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

好的,您可以下载免费的Altium Designer Viewer查看文档,有效期6个月。

请填写下方表格申请。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

好棒!创作是一件超酷的事情,我们可以为您提供完美的设计软件。

Upverter是一个社区导向的交流平台,专为您这样的创客量身定做。

点击这里看看吧!

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

好的,您可以下载免费的Altium Designer Viewer查看文档,有效期6个月。

请填写下方表格申请。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。