Altium NEXUS Documentation

使用集成库_AD

Created: June 12, 2018 | Updated: June 13, 2018

主页面与元器件和元器件库相关的更多信息

集成库反映了Altium NEXUS“第二代”元器件管理方式—即:“集成元器件”模式。在该模式中,更高水平的元器件在“原理图”库文件中的原理图符号内建模。其他模型从符号进行链接并且元器件参数也可添加至符号。所有源库(符号和链接模型)在“集成库包”项目中定义,该项目随后编译成单一文件(“集成库”或“IntLib”)。

本文档概述了创建集成库的多种方式以及该元器件库的元件放置和修改。

集成库的优点

编译成为集成库的主要优点为:

  • 可以在单个便携式文件获取所有元器件信息—由于所有模型打包到集成库中,只有一个文件需要用于项目,或者在项目重新定位时移动。 如果您将工作分成不同的工作站,或者希望与其他人分享您的设计,这种便携性是宝贵的优点。
  • 如果一个元件被放置在集成库的设计原理图中,Altium NEXUS可以保证找到合适的模型,只要它能够简单地找到它所来自的集成库 - 不需要分离库和模型文件,模型链接可以证明 非常“脆弱”,很容易被日常管理任务破坏,比如重命名硬盘上的文件夹。
  • 从安全方面来看,集成库十分可靠—一旦生成后,不会发生改变。事实上,更新集成库实际上意味着完全替代它 - 您必须有目的地拉起原始库包,更新源文档,然后重新编译。
  • 这些库在编译时也会被检查完整性。 这意味着不仅检查可用性,而且检查引脚映射的正确性。 即使您希望保留离散库文件,建议在集成库包中编译原理图库,以确保源元件能够正确映射到目标模型。 一旦满意,您可以忽略您创建的集成库,并直接从原理图库中放置。

使用元器件库包创建集成库

集成库包(*.LibPkg)为一类Altium NEXUS项目,用于将生成集成库所需的一套设计文件集中在一起。从“原理图元器件库编辑器”提取“原理图”符号,并为每个符号定义模型参考/链接和参数信息。这些内容保存在一个或多个原理图元器件库文件中。参考模型可能包括PCB 2D/3D元器件模型、电路仿真模型和信号完整性模型。

必须添加至集成库包的唯一文件为原理图元器件库。包含PCB 2D/3D元器件模型和仿真模型/子电路的文件可以位于任何有效搜索位置— 项目内、“安装库”清单中的文件内或为包规定的搜索路径里。

元器件库包随后编译成单个“集成库”文件(*.IntLib)。

将模型库集中到项目中还是通过搜索路径定位模型库取决于您的工作风格。在准备集成库包时如果检查和编辑模型,您可能想要模型库就在您指尖并将它们添加至元件库包。如果持续向硬盘驱动器或网络上的特定文件夹添加模型库,那么最好使用搜索路径,让编译器自动检测新添加的元器件库。

总之,创建集成库基本包括以下四个步骤:

  1. 创建源库包。
  2. 创建并添加所需源原理图元器件库文件。
  3. 创建并添加(或指向)所需域模型文件。
  4. 编译元器件库包,以生成集成库文件。

创建源库包

从主菜单选择File » New » Project命令,创建新的集成库包。在出现的新项目对话框中,设置“集成库”的项目类型,规定针对项目的名称和位置及其类型(普通、VCS(版本控制)或管理(作为“Altium数据保险库安装的一部分))以及与类型相关的选项(若适用)。”

点击OK选项后,新的空壳元器件库包项目将添加至项目面板,最初不包含文件。

通过“新项目”对话框创建新的“集成库包”(*.LibPkg)。 通过“新项目”对话框创建新的“集成库包”(*.LibPkg)。

创建和添加源原理图元器件库

创建包含所需元器件的源原理图元器件库(*.SchLib)。对于各个元器件,添加所需模型链接和参数信息。具有两种创建源原理图元器件库的方式:

利用现有设计项目中布置的元器件制作原理图元器件库时,所有源原理图文件将自动打开。产生的元器件库将在项目后命名(<ProjectName>.SchLib)。

当源原理图元器件库准备好后,只需采用以下一种方法添加至元器件库包:

源原理图元器件库添加至元器件库包。源原理图元器件库添加至元器件库包。

创建和添加域模型文件

在相应文件中参考原理图元器件创建模型。从而分别在“PCB元器件库”(*.PcbLib)中获得PCB 2D/3D元器件模型,在“模型”(*.Mdl)和“子电路”(*.Ckt)文件中获得仿真模型和子电路文件。最重要的模型当然为PCB 2D/3D元器件模型,该模型可以与其对应的原理图元器件库一样通过两种方式创建:

当利用现有PCB文件制作PCB元器件库时,确保文档打开且为活动文档。产生的元器件库将在PCB文件名后命名(<PCBDocumentName>.PcbLib)。

规定在何处找到模型

随着模型文件的定义,现在需要将它们提供给库包,以便在需要时可以轻松定位它们 - 请记住,模型是由原理图元件引用(或链接到)的。 无论您是在构建集成库包还是在进行原理图设计,Altium NEXUS都有一个标准系统可用于制作模型。 有三种制作模型的方法:

  • 将元器件库/模型添加至项目。
  • 在“安装库”清单中安装元器件库/模型。从而,所有设计项目可用。
  • 确定至元器件库/模型的搜索路径。

每个方式都有优点,因此,选择最适合您工作实践的方法。不同模型也与不同方法更好地协作。例如,您可能不想看到当元器件库包打开时“项目”面板中列出大量仿真模型,但是可能想要看到PCB 2D/3D元器件模型库。在这种情况下, 定义存储仿真模型的文件夹的搜索路径,并将PCB库添加到库包中。

这三种模型可用性方法共同组成可用库(可用于项目),并且都可以在可用库对话框中定义 - 可通过单击库面板左上角的按钮进行访问。

通过可用库对话框确定模型可用性。 通过可用库对话框确定模型可用性。

如果元器件库包不是活动项目,请在访问可用库对话框之前确保其源原理图库之一处于活动状态 - 确保正在为其考虑可用库,而不是另一个打开的项目。

还可以使用Add Existing to Project命令将PCB元器件库(或其他模型文件)直接添加至元器件库包—该命令可以利用主项目菜单或与项目面板中的元器件库包条目相关的右击菜单获得。

“源PCB元器件库”添加至元器件库包。 “源PCB元器件库”添加至元器件库包。

利用可用库对话框搜索路径制表符确定至模型文件的搜索路径—只需访问集成库选项对话框搜索路径制表符(Project » Project Options)。根据要求只需添加一条或多条路径,注意:沿着这些路径以顶部至底部的顺序搜索模型。点击刷新清单按钮,确认正在查找所需模型文件并在必要时调整路径。

一个定义的搜索路径的实例,用来查找所需的PcbLib模型文件。 一个定义的搜索路径的实例,用来查找所需的PcbLib模型文件。

编译元器件库包

通过将源库添加到库包以及根据需要定义模型文件的任何路径,现在可以编译该包以最终生成集成库。 像任何其他项目一样,集成库包的编译器将生成一系列警告和/或错误消息 - 例如,警告任何未找到的模型。 另外,可以检查引脚映射错误,例如当实际封装包含焊盘A和K时,将指令映射到焊盘1和2!

即使您希望保留分立库文件,建议您在集成库包中编译原理图库,以确保源元件能够正确映射到目标模型。

在进行编译前,最好浏览并在集成库选项对话框错误报告制表符上正确设置错误报告条件。

在编译库包之前,根据需要设置错误报告选项和严重级别是一个好主意。 在编译库包之前,根据需要设置错误报告选项和严重级别是一个好主意。

要进行编译,采用编译集成库命令—该命令可以利用主项目菜单或与“项目”面板中的元器件库包条目相关的右击菜单获得。源库和模型文件编译成集成库,在源库包后命名(<LibraryPackageName>.IntLib)。编译器将检查违规情况,发现的任何错误或警告将列于信息面板。修复源库中的问题,随后重新编译。

集成库包编译完成后由“编译器”标记错误示例。一旦警告和错误解决后,

鼠标悬停在图像上,查看成功编译的结果。 集成库包编译完成后由“编译器”标记错误示例。一旦警告和错误解决后, 鼠标悬停在图像上,查看成功编译的结果。

集成库保存在输出文件夹内,输出文件夹在集成库选项对话框选项制表符上命名(默认情况下项目子文件夹的位置为:\Project Outputs for <ProjectName>)。自动添加至“安装库”清单(所有项目均可用),随后可以通过元器件库面板呈现。

编译的集成库添加至“安装库”清单,因此,可以通过“元器件库”面板可得。 编译的集成库添加至“安装库”清单,因此,可以通过“元器件库”面板可得。

元器件库面板提供了直接查看集成库文件的方式。这个面板的目的是在集成库的基础上构建,允许通过元件,封装或3D模型浏览集成库 - 单击当前库字段右侧的  按钮以进行控制。 当通过元器件浏览时,会显示元件到模型的关系。

利用项目文件创建集成库

还可以直接利用构成文件(源原理图和PCB文件)制作集成库。只需使用制作集成库命令,该命令可以利用“原理图”或“PCB编辑器”中的主设计菜单获得。

该过程主要涉及:

  1. 打开所有源原理图文件并制作原理图元器件库。
  2. 利用PCB文件制作PCB元器件库。
  3. 将这些元器件库编译成集成库,在项目后命名(<ProjectName>.IntLib)。

集成库添加至项目(在项目面板中的“Libraries\Compiled Libraries”下),添加至安装库,通过元器件库面板可用。

直接利用当前设计项目中的原理图和PCB文件进行集成库流程创建。 直接利用当前设计项目中的原理图和PCB文件进行集成库流程创建。

利用数据库元件库创建集成库

相关页面:使用数据库元件库

如果您希望Altium NEXUS元件与您的公司数据库紧密耦合,Altium NEXUS的数据库元件库是一个理想的选择。 如果设计需要离开公司站点,或者如果您希望让设计人员使用安全的集成库,这可以很容易实现。 Altium NEXUS提供了直接从数据库元件库(标准数据库元件库(DbLib)或版本控制的SVN数据库元件库(SVNDbLib))编译集成库的工具。 通过这种方式,您的CAD库管理员仍然可以使用数据库元件库,而您的设计人员则可以使用定期重新生成的集成库,并以“离线”方式进行工作。

使用“离线集成库向导”程序进行转换。该过程在每个数据库表的基础上进行,并完全控制数据库中的哪些表。 将为每个包含的表格生成一个单独的集成库。

使用离线集成库向导程序将数据库元件库(标准数据库元件库或版本控制SVN数据库元件库)转换为“离线”集成库。使用离线集成库向导程序将数据库元件库(标准数据库元件库或版本控制SVN数据库元件库)转换为“离线”集成库。

该过程涉及以下步骤:

  1. 利用打算作为活动文档转换为打开的“数据库元件库”文件(*.DbLib)或“SVN数据库元件库”文件(*.SVNDbLib),从主菜单选择Tools » Offline Integrated Library Maker命令,以访问离线集成库向导程序。
  2. 使用转换元器件库页面来规定待处理的标准数据库元件库或版本控制SVN数据库元件库。通过其访问向导程序的当前元器件库将被默认规定为转换元器件库。您可以自由浏览和选择不同的数据库元件库(若需要)。
  3. 使用选项页面来规定链接数据库中哪些表将纳入转换。所有数据库表均默认纳入转换。要排除一个表,只需确保其相关转换选项不可用。该向导程序页面还允许您指定输出目录,生成的集成库将保存在该目录下。直接进入该基本目录路径或点击字段右侧的图标  ,以访问文件夹浏览对话框,通过该对话框可以浏览和选择所需目录。每个纳入的数据库表的生成输出(集成库)将保存在规定输出目录内的自身子文件夹中,使用表名命名。
  4. 按照要求选择数据库元件库和设置相关转换选项后,点击下一步,开始转换。将显示进度条并显示正在转换的当前数据库表的信息。注意:转换过程针对您指定转换的所有数据库表。以下内容主要为该过程的分解:
    1. 集成库包(*.LibPkg)在项目面板内创建和打开。使用表名对该包命名。例如,对于名称为“Capacitor - Ceramic”的表,包名为Capacitor - Ceramic.LibPkg。
    2. 创建原理图元器件库文件并添加至集成库包。再一次使用表名来对原理图命名(如:Capacitor - Ceramic.SchLib)。
    3. 随后考虑表中的所有记录,构建合适的Altium NEXUS元器件。为此,从合适的源库检索参考原理图符号并将其作为元器件添加至新的原理图元器件库文件。记录中确定的参数和模型链接信息随后添加至该元器件。
    4. 检索记录的参考封装模型并添加至PCB元器件库文件。该文件再一次在表后命名(如:Capacitor - Ceramic.PcbLib)。PCB元器件库文件随后添加至集成库包。
    5. 如果源库为标准数据库元件库且PCB 3D和/或“仿真”模型链接已经在数据库记录中确定,参考PCB 3D库和“仿真”模型文件同样添加至集成库包。此等模型的位置保持不变。模型的完整路径规定为其相应模型链接的一部分。
    6. 随后编译集成库包,以形成集成库(如:Capacitor - Ceramic.IntLib),集成库随后添加至Altium NEXUS“安装库”。
可以通过可用库对话框安装制表符查看当前安装库,通过点击元器件库面板顶部的元器件库按钮可以快速访问。

转换过程的结果 - 包含组成符号和封装模型文档的库封装项目,以及编译后的IntLibs,它们也作为已安装的库添加,因此可用于Altium NEXUS中的所有PCB设计项目。 转换过程的结果 - 包含组成符号和封装模型文档的库封装项目,以及编译后的IntLibs,它们也作为已安装的库添加,因此可用于Altium NEXUS中的所有PCB设计项目。

通过数据保险库元器件获取创建集成库

相关页面:使用购物车

还可以从本地“Altium数据保险库”获取元器件并将其纳入“集成库”。当放置来自此等“集成库”的元器件时,实际链接将回到数据保险库中的“元器件条目”。这让您能够以离线方式高效利用公司的“数据保险库”元器件,确保设计仍然与源数据保险库中的元器件真实连接。还应确保为这些元器件确定的供应链信息通过使用“元件选择清单”继续得以使用。

将Vault内容获取到IntLib中的能力仅适用于您当地的Altium Vault。 您无法以这种方式从Altium Content Vault获取内容。

  Content Cart对话框中,获取到IntLib的过程如下:

  1. 点击选择目标数据保险库链接并从菜单选择集成库文件

将Content Cart的目标设置为IntLib文件。  Content Cart的目标设置为IntLib文件。

  1. 为生成的IntLib文件指定名称和位置。 默认情况下,该文件将以 Integrated_Library - <Date> - <Time>.IntLib格式命名,并在 \Users\Public\Documents\Altium\AD<Version>\Library\ExportCmpLib中生成。 按需要通过另存为对话框进行修改 - 通过单击更改链接进行访问。

接受默认目标文件夹或按要求更改。 接受默认目标文件夹或按要求更改。

  1. 如果需要将额外元器件纳入同一集成库,点击“添加更多条目”链接,随后使用选择条目对话框来选择这些元器件。
  2. 一旦准备就绪,点击传递购物车按钮,以进行集成库的生成。将创建临时“集成库包”(*.LibPkg),同时生成和添加源原理图元器件库(带符号、参数和模型链接)和PCB元器件库(带封装模型)文件。随后进行编译,以在规定文件夹中生成集成库文件。信息对话框将确认成功生成文件。

将购物车传递给目标文件夹,文件夹包含所需“集成库”文件。 将购物车传递给目标文件夹,文件夹包含所需“集成库”文件。

生成后,集成库添加至“安装库”清单(软件“可用库”的一部分)并可以通过元器件库面板可用。

生成的集成库提供来自公司数据保险库的元器件。 生成的集成库提供来自公司数据保险库的元器件。

集成库元器件的放置

通过元器件库面板进行集成库元器件的放置。可以在当前原理图表上(当以“元器件”视图浏览集成库时)或当前PCB文件上(当以“元器件”或“封装”视图浏览时)进行放置。可以利用以下方式进行放置:

  • 选择元器件条目、点击放置按钮、随后放置和点击,以放置到工作区。
  • 点击并把所需元器件拖至工作区。
通过使用放置按钮方法,可以放置多个元器件,这是由于该方法保持放置模式,直至右击或按下Esc。拖放法感觉更为直接,但是本质上为“单放”。

使用元器件库面板来放置集成库元器件。由于拖放法是直接的,其只能放置一个元器件。使用放置按钮

可保持放置模式。 使用元器件库面板来放置集成库元器件。由于拖放法是直接的,其只能放置一个元器件。使用放置按钮 可保持放置模式。

当原理图元器件库和集成库可能包含相同元器件(具有全部相同的模型链接)时,当它们的模型信息被检索后,所有这些元器件库的放置元器件将发挥不同作用。从集成库放置的元器件将寻找初始集成库,以获取模型。从原理图元器件库放置的元器件不能访问保存在集成库中的模型。

修改集成库

集成库用于放置元器件且不能直接编辑。要修改集成库,首先修改源库,随后重新编译元器件库包,从而形成包括这些变更的更新集成库。

要修改集成库:

  1. 打开所需集成库的源库包项目。
  2. 打开拟修改的源原理图或模型库。
  3. 按要求进行变更、保存并关闭修改的元器件库。
  4. 重新编译元器件库包。新生成的集成库将代替旧的现有版本。

反编译集成库

有时可能需要访问集成库中的源库进行修改,但无论出于何种原因,都无法访问原始源库包项目。 这是一个便携式集成库文件的另一个方面。 虽然集成库不能直接编辑,但可以将它们反编译回其组成源符号和模型库。

为实现上述目标,应进行以下操作:

  1. 打开包含待修改的源库的集成库。两种操作,任选其一:
    1. 选择File » Open命令,在选择打开文件对话框中浏览集成库,点击打开
    2. 将集成库文件从“Windows文件浏览器”拖放至Altium NEXUS窗口。
  2. 在出现的提取源或安装对话框中,点击提取源按钮。
确保点击“取源按钮。点击“安装元器件库”按钮仅仅将集成库添加至软件可用库的“安装库”清单。

源原理图和模型库被提取并保存在以集成库的文件名命名的新文件夹中 - 在原始集成库所在的文件夹中。
随后创建元器件库包(<IntegratedLibraryFileName>.LibPkg) ,源原理图元器件库和PCB元器件库添加至项目面板中呈现的项目中。仿真模型和子电路文件不会自动添加至项目。

从集成库提取源库—反编译,以产生元器件库包项目。 从集成库提取源库—反编译,以产生元器件库包项目。

包含源库和模型文件的文件夹的路径自动添加到集成库对话框的搜索路径选项卡上(项目»项目选项) - 确保任何模型(特别是.mdl和.ckt文件 )可以被找到。
元器件库包不会自动保存。确定项目保存的位置和名称 - 默认情况下,该文件将与提取的源文件保存在同一文件夹中。

 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

联系我们

联系原厂或当地办公室

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: