Component Editor - Single Component Editing Mode

Modified by Jason Howie on Sep 6, 2018

Parent page: Managed Components

A managed component is defined/edited using the Component Editor, which can operate in two modes - Single Component Editing and Batch Component Editing. The former provides a streamlined interface when defining/editing a single component. This is the default mode when creating a new Component Item, or editing a single revision of an existing Component Item. The latter provides the interface for defining/editing multiple components, but can be used to define/edit a single component, should you wish.

This document looks at working with the Component Editor in its Single Component Editing mode.

For more information on working with the Component Editor in its Batch Component Editing mode, see Component Editor - Batch Component Editing Mode.

Facilitating the Functionality

This Single Component Editing functionality is delivered through a purpose-made extension for the Component Editor - the Single Component Editor extension.

The Single Component Editor extension.

This feature is only made available, provided the Single Component Editor extension is installed as part of your Altium NEXUS installation. This extension is installed by default when installing the software, but in case of inadvertent uninstall, can be found back on the Purchased tab of the Extensions & Updates page (click on the  control at the top-right of the workspace and choose Extensions and Updates from the menu).

Interface Overview

In its Single Component Editing mode, the Component Editor interface is essentially divided into four main regions, illustrated in the following image and summarized thereafter.

The Component Editor, when operating in its Single Component Editing mode, can be divided into four key regions.

  1. Component - where you define key properties of the component, including its Name, Description, unique Id, Type, resident Folder, and reference to any Component Template as required.
  2. Models - where you add links to released domain models, for use by the component.
  3. Parameters - where you craft a set of parametric data that will be applied to the component. This can include parameters from a referenced Component Template, as well as additional user-defined parameters. Links to website URLs can also be added here, as well as datasheets.
  4. Part Choices - where you can search for, and add Part Choices for the component; the real world manufacturer parts that you want to be used for the design component when the board is manufactured and assembled.

Component

This region provides controls for defining the following component attributes:

  • Name - reflects the humanly-readable name given to the component. This system parameter is available and indexed when searching within the Server and will provide a good means to locate specific components beyond having to remember their Item ID!

As you start typing the name, a pop-up listing of available manufacturer parts - from the managed content server's Local Part Catalog - will appear. You can select an entry to quickly define your component, either fully (all information), with parameters only (parameters and part choices), or just use the name. This creation form part search facility is also available by pressing the  button at the far right side of the field. For more information, see Creating the Component from a Part Search.

The field will populate with any default value for the Name system parameter that has been defined in a referenced Component Template.
  • Description - reflects the description added to the component. This system parameter is available and indexed when searching within the Server.
The field will populate with any default value for the Description system parameter that has been defined in a referenced Component Template. Also, if the component is being created from a part search, and the Use all data option is chosen, the Description field will be populated with the description from that chosen part.

In addition, and by clicking the Advanced Settings control, you get access to the following:

  • Id - this field is used to determine the ID used for the released Component Item in the Server. For a new component created through the File » New » Component command, this field is populated in accordance with a default naming scheme, CMP-{00000}. For a new component created through the Explorer panel, this field is populated in accordance with the default naming scheme specified for that component's parent folder. If the parent folder has a component template attached, then defined Component Naming will be brought in from that template. The software will automatically assign the next available unique ID, based on that scheme, having scanned the entire Server and identifiers of existing Items.

Alternatively, you can override the auto-assigned ID for the component by entering the ID required directly in the Id field. You always have full control and final say over how the Items are identified!

This field will be read-only if the component has already been released.
  • Folder - use this field to release the component to a specific folder in the target Server. For a new component created through the File » New » Component command, this field is blank. For a new component created through the Explorer panel, this field is populated with that component's parent folder. You have full control over where in the target Server a component will be stored. To manually specify a target folder, click the  button to access the Choose Folder dialog. Browse to, and choose an existing folder, or create a new one on-the-fly.
Taking the time to carefully determine the folder path for your component ensures it is released into the correct destination folder from the outset. However, Items can be easily moved to any folder in the Server structure, post release, if need be.
This field will be read-only if the component has already been released.
  • Template - this field provides the ability to reference a defined Component Template. Click on the field to access a listing of all Component Template Items currently available in the active managed content server (to which you are signed in). Click on an entry to create a link to the indicated (latest) revision of that Component Template Item. Template information will be brought into the Component Editor (Name, Description, Id naming format, Folder, Type, Models, and Parameters). For more information, see Referencing a Component Template.
  • Type - this field supports the ability to define the type of component and is a key attribute used to facilitate targeted searching of Server components. Click on the field to access a listing of currently defined component types from which to choose.
It is also possible to change the component type for one or more components after release to a completely different type, on-the-fly. In the Explorer panel, select the component(s) that you want to change, then right click and choose the Operations » Change component type command from the context menu. The Component Type dialog will appear from which you can select the new component type.
The field will populate with any default value for the ComponentType parameter that has been defined in a referenced Component Template.

Models

This region of the editor is used to add links to released domain models, for use by the component.

At the most basic level, a component used in board design requires representation in the schematic and PCB editing domains. It therefore needs schematic symbol and PCB footprint models.

The Models region, providing the controls to define the models required to represent the component in the Schematic, PCB and Simulation domains.

Use the following collapsible sections to learn more about working with models.

The links to required models for the component can be defined in a variety of ways:

  • Selecting an existing model. Click the drop-down icon on the button below the model type, and choose Existing from the associated menu. Choose the model of the required type through the subsequent dialog. Note that the Revision State field, below the preview of the model, will reflect the current state of the chosen revision of the model Item, and whether it is the latest revision (Up to date) or not (Out of date).
Note that the button is dynamic and will reflect the last command (from its menu) that was used.

Dialog-based addition of an existing model.

Add one, or multiple models, through drag and drop from the Explorer panel.

  • Create a new model manually. Click the drop-down icon on the button below the model type, and choose New from the associated menu. The corresponding temporary editor for that model type will open, ready for you to define the model. Once defined, just save and close the editor - the model will appear linked back in the Models region. Note that the Revision State field, below the preview of the model, will show Not released. Upon release of the component, any newly defined model will automatically be released to the Server also, into the initial revision of a new Item.

Example manual creation of a new model for a component.

  • Create a new model using a Wizard (for symbol and footprint only). Click the drop-down icon on the button below the model type, and choose Wizard from the associated menu. The process is similar for these two model types, just using a different Wizard:
    1. For a symbol, the Symbol Wizard will appear. For a footprint, the IPC Compliant Footprint Wizard will appear. Use the respective wizard to define the model as required.
    2. After finishing in the wizard, the corresponding temporary editor for the model type will open, with the resulting model generated from the wizard loaded.
    3. Make any additional changes as required, then save and close the editor - the model will appear linked back in the Models region. Note that the Revision State field, below the preview of the model, will show Not released.
    4. Upon release of the component, any newly defined model will automatically be released to the Server also, into the initial revision of a new Item.

Example using the Symbol Wizard to create the required symbol for the component being created/edited. Hover over the image to see an example of using the IPC Compliant
Footprint Wizard
to create a footprint model for the component.

  • From a template. If the component references a component template, all model Items that are defined (as dedicated parameters) in that template (SCHLIB and PCBLIB(s) only), will be brought in to the Models region. For more information, see Referencing a Component Template.
  • From a Part Search. If the component is being created from a part search, and the Use all data option is chosen, models defined for that chosen part will be brought in. If no models are defined for that part, the current models will remain. For more information, see Creating the Component from a Part Search.

Storage of Newly-created Models

You can define default target folders in which newly-created models should be created, or override those to specify a different target folder, should you need - affording you greater control and flexibility over how your models are created and stored.

Defining Default Target Folders

Default release target folders for newly-created models are defined on the Admin - Settings - Vault - Components page of the NEXUS Server's browser interface.

Accessing the page on which to define default release target folders, when new model Items are created through the Component Editor (in its Single Component Editing mode).

The default folders (in a new installation) will create models in a single area of the Server folder structure, as seen in the image below:

The Server folder structure created for newly-created models, when using
the installation defaults.

To change a default folder, click the  button. The Vault Explorer window will appear with which to choose the desired new default target release folder for that model type. Once chosen, click OK to close the window and return to the Components page, with the applicable field updated with the new folder path.

An example of changing the default release target folder for symbol models.

If any changes to the default release target folders are made, ensure to click the  button at the top-right of the page.

Overriding the Default Target Folder

Newly-created models - when creating components through the Component Editor in its Single Component Editing mode - will be stored in the Server according to the defined default target release folders, as described previously. However, should you wish, you can override the default by nominating a specific folder in which to store the created model Item. To do so, click on the  control - at the top-right of the model's preview - and choose the Select Target Folder entry from the menu. The Choose Folder dialog will appear (essentially a trimmed incarnation of the Explorer panel). Use this to choose the required target folder and click OK.

Override the default release folder for a model type by choosing a different one.

While the component is still unreleased, the chosen target folder will be presented, textually, above the model's preview window - a useful reminder of where the new model will be found!

While the component remains unreleased, the chosen folder for the model is presented.

To modify a model that is currently being used (referenced) by the component, click the  control at the top-right of its preview. The corresponding temporary editor for that model type will open, ready for you to make changes to the model as required. Once ready, just save and close the editor - the modified model will appear linked back in the Models region. Upon release of the component, the modified model will automatically be released to the Server also, into the next revision of its parent Item.

If the model is referenced by multiple components, a dialog will appear alerting you to this, and offering you various choices. You can create a copy of the model (clone it) so that the change affects only the current component. Or you can continue with editing this shared model, and update the other components that reference it later. Or you can simply cancel out of the editing process.

An example of editing an existing model that is being referenced by the component.

To change a model, click on the  control - at the top-right of the model's preview - and choose the Select Model entry from the menu. Use the subsequent dialog that appears to browse for and choose, a different model Item, or a different revision of that same model Item.

An example of switching the symbol used to represent a component.

To clone an existing referenced domain model, click on the  control - at the top-right of the model's preview - and choose the Clone entry from the menu. The corresponding temporary editor for that model type will open, with the cloned model ready for you to make changes as required. Once ready, just save and close the editor - the cloned model will appear linked back in the Models region. Note that the Revision State field, below the preview of the model, will show Not released. Upon release of the component, the cloned model will automatically be released to the Server also, into the initial revision of a new Item.

Example of cloning an existing model - allowing you to quickly create a new model item on-the-fly, and have your component use it, whilst not having to reinvent the wheel to do so.

To quickly browse to the model in the Explorer panel, click on the  control - at the top-right of the model's preview - and choose the Show in Explorer entry from the menu. The panel will present (or be focused) with that model (and revision thereof) displayed.

Example browsing to the revision of the model Item in the Explorer panel.

When you attempt to commit/release a component back to the Server, the Component Editor runs a validation - a Component Rule Check. As part of this, if the Editor detects that a linked model is not the latest revision, this is flagged by a validation failure dialog, and the issue detailed in the Messages panel. Revision State information can now be found beneath the graphical preview of the referenced revision of a model Item. If there is a later revision of the Item available, the Revision State field will reflect this using the text Out of date, to the right of the current revision's lifecycle state. When the latest revision is being referenced, the text will be Up to date.

Detecting a model is out of date as part of the Component Editor's automatic component validation checks.

You have the option to cancel the release and fix the issue(s), or ignore any violation(s) and release regardless. To update the link to use the latest revision of the model, click on the  control - at the top-right of the model's preview - and choose the Update to Latest entry from the menu.

While validation of the component is automatically carried out at time of release, it can be performed at any time, manually, by running the Tools » Component Rule Check command. For more details on what checks are involved, and their configuration, see Running a Component Rule Check.

While a component can reference a single symbol, and single simulation model, provision is made for referencing any number of footprint models. This will be a welcome feature for those wishing to create components that reference 3 footprints, satisfying the IPC requirements for different density levels (L (least or minimum copper), M (most, or maximum copper), and N (nominal, or median copper)). To this end, once a footprint model has been linked, the Add Footprint control will still remain available. The default footprint is the first linked, and is distinguished by the  icon at the model's top left.

You can set another footprint model to be the default model by clicking the  control - at the top-right of the model's preview - and choosing the Set Default entry from the menu.

An example component defined in the Component Editor (Single Component Editing mode), using a referenced Component Template. The template has three
footprint models defined, which are brought into the Models region. The default footprint model (distinguished by an icon at its upper-left) corresponds to
the PCBLIB model entry in the template.

To remove a model, click on the  control - at the top-right of the model's preview - and choose the Remove entry from the menu.

Parameters

This region of the editor is used to add parametric data to the component. Three types of parameter can be manually added here:

  •  Parameter - a standard, user-defined parameter.
  •  Link - a URL link to the page of a web site, for example a manufacturer's website, or an online datasheet.
  •  Datasheet - providing a link to a datasheet (in any format) that is (has been) uploaded to the server and referenced by the component.

The Parameters region, providing the controls for adding parametric data to the component.

Any number of these parameter types may be added as required. To do so, click the drop-down part of the  button at the bottom of the region, then choose the relevant entry from the menu. A new parameter will be added to the list as follows:

  • Parameter - will be added below the currently selected entry in the list. The name will be in the default format Parameter n, click inside the Name field to change this as required. Click inside the Value field and type the value as required.
  • Link - will be added at the bottom of the list. Click inside the Name field and enter the required name. This will be presented on the right-click References sub-menu, when accessed for a placed instance of the component on a schematic sheet. Type (or paste) the URL for the target page into the Value field. This will become a hyperlink, with which to access the target.
  • Datasheet - a standard Windows Open dialog will appear, with which to browse to, and select, the required datasheet. Multiple datasheets can be added simultaneously through this dialog. Each datasheet will be added at the bottom of the list. The Name will initially be that of the file itself, and is presented in the Explorer panel, and also in the References sub-menu for a component, after it is placed on a schematic sheet. Change this to a more suitable caption as required. The Value will be the file, in terms of its name, format, and size on disk. This will be a hyperlink, with which to quickly access the datasheet.
Clicking the  button directly (not accessing its drop-down menu) will place a standard Parameter. To remove a parameter, select it in the list (multiple parameters can be selected for removal) and click the  button.
The Parameters region can also be populated with parametric data from a part found by conducting a Part Search. For more details, see Creating the Component from a Part Search.

Attaching Datasheets through Drag and Drop

In addition to the manual attachment through the Open dialog mentioned in the previous section, you can also attach one or more datasheets to the component in the following ways:

  • By dragging and dropping from Windows File Explorer to anywhere within the Parameters region.
  • By dragging and dropping a datasheet link from a web page in an external web browser, to anywhere within the Parameters region.


Example demonstrating attachment of datasheets from a local drive, and then editing the local caption for the main datasheet.

Template Parameters

In addition, if the component references a Component Template, then any parameters defined in that template will be brought in, and added to the Parameters region.

Example parameters from a referenced Component Template Item.

Things to note:

  • A standard template parameter (not marked as Read-only or Required) is distinguished in the Parameters region by use of the  icon.
  • A template parameter marked as Read-only is distinguished in the Parameters region by use of the  icon.
  • A template parameter marked as Required is distinguished in the Parameters region by use of the  icon.
  • An existing user-defined parameter that has the same name as a parameter in the linked Component Template Item, will be replaced with the template version. Any existing value for that parameter will be kept (and not overwritten with the value in the template).
  • The value fields for template-based parameters that have been marked as read-only, will be non-editable. For all other template-based parameters, that have not been marked as read-only, you are free to change the values as required.
  • If a template-based parameter has been marked as Required, but has not been given a value in the template, its value field will contain the  icon, alerting you to the fact that a value is required for this parameter. You will not be able to release a component until values are defined for all required parameters.
Template Parameters cannot be removed.

Support for Unit-aware Component Parameter Data Types

The Component Editor supports unit-aware component parameter data types that are defined within a referenced Component Template. You can enter a parameter's value directly into the applicable field using a range of formats - such as 2.2k, 2k2, 4M, 2.5GHz - with the managed content server engineered with the requisite smarts to recognize the numerical value behind those entries.

This feature of a component template facilitates targeted searching through the Server's Search facility - a facility that not only allows you to search by component type, but allows you to search smarter, with range searches. Using the power of unit-aware component parameters, you can quickly define a search, for example, to find all capacitors with a capacitance between 47uF and 220uF.

Unit-aware data types for component parameters can only be defined through a component template.

Component parameters from a referenced component template that have unit-aware data types.

When entering a value for a component parameter that uses a unit-aware data type, the following are things to consider:

  • You can enter the value in a range of different formats: 
    • Numerical value only (e.g., 10). Note that if the data type has a unit, this will be applied automatically. (In the Component Template, those types with units have the unit in brackets after their name).
    • Numerical value and units (e.g., 10F).
    • Numerical value with prefix (e.g., 10k). The appropriate unit will automatically be added (where applicable).
    • Numerical value with prefix and units (e.g., 10kF).
    • Numerical value with prefix in typical engineering format (e.g., 2k2, 2k2Ohm, 10r2, 10R2). The value will automatically be normalized accordingly (e.g., 2K2 will become 2.2k).
  • You can enter prefix and/or units with or without a space after the numerical value (e.g., 10uF, or 10 uF). The space will be automatically stripped.
Note that engineering abbreviations are case insensitive, so entering 2k2 is the same as entering 2K2, and entering 100R is the same as entering 100r. The only exception is M (Mega) and m (milli).

The following unit-aware data types are supported:

Most data types have a unit (shown in brackets in the Component Template). This will be applied if no unit is specified when entering a value for a parameter.
  • Voltage - Volt(V)
  • Current - Ampere(A)
  • Resistance - Ohm
  • Capacitance - Farad(F)
  • Inductance - Henry(H)
  • Power - Watts(W)
  • Frequency - Hertz(Hz)
  • Temperature - Celsius(C)
  • Decibels - Decibel(dB)
  • Percent - Percent(%)
  • Length - Metre(m)
  • Mass - Gram(g)
  • Time - Second(s)

The following table lists the prefixes that are supported when entering a value for a unit-aware parameter type.

Prefix Term Value (Scientific) Value (Normal)
T Tera 1 x 1012 1,000,000,000,000
G Giga 1 x 109 1,000,000,000
M Mega 1 x 106 1,000,000
k kilo 1 x 103 1,000
d deci 1 x 10-1 1 / 10
m milli 1 x 10-3 1 / 1,000
u micro 1 x 10-6 1 / 1,000,000
n nano 1 x 10-9 1 / 1,000,000,000
p pico 1 x 10-12 1 / 1,000,000,000,000
Note that the use of some, or all prefixes may not be applicable, depending on the parameter type. For example, no prefix is valid for a Percentage. The software will alert you to any invalid use of prefixes.

When a unit-aware data type is used for a component parameter, the entered value is validated against the specified data type. This ensures that the correct measurement unit for that data type is being used, where the unit is entered. For example, a parameter of type Celsius cannot have a value of 10V!

In the Component Editor, entering an invalid value for a parameter will cause a dialog to appear, alerting you to the fact that the entry is not a valid value. This is also the case when copying and pasting a value between cells. Clicking OK in the dialog will revert the value back to its previous entry.

Data validation - the Component Editor has the smarts to alert you to a mismatch between the value entered for a unit-aware parameter, and its data type.

Part Choices

This region of the editor is used to specify one or more Part Choices for the component - the 'allowed' manufacturer parts that can be used to implement the component on the assembled board. The actual supply chain intelligence - comprising Manufacturer (and part number), Supplier (and part number), Description, Pricing and Availability - is sourced from the managed content server's local Part Catalog and the relevant Part Source.

Each managed content server has its own dedicated Part Catalog. This is a managed local part catalog database, dedicated to the management and tracking of manufacturer parts and their associated supplier parts. The local Part Catalog stores items representative of actual Manufacturer Parts, along with one or more items representative of Supplier Parts - the incarnations of those Manufacturer Parts, as sold by the Suppliers/Vendors. Each Supplier Part is a reference to an item in a parts database - either the aggregate parts database of the Altium Parts Provider (the default Part Source which itself interfaces to, and gathers the parts from, enabled Suppliers), or a linked local parts database (a Part Source configured as a Custom Database Parts Provider). Enable required Suppliers and determine Location/Currency ranges for the Altium Parts Provider within the Part Providers area of the Server's browser interface. While you remain signed into your managed content server from Altium NEXUS, the Altium Parts Options region - on the Data Management - Parts Providers page of the Preferences dialog - becomes read-only and adopts those settings defined for the Server. For more information on managing the Altium Parts Provider part source for your Altium NEXUS Server, see Supply Chain Management.

Example Part Choices list for a component being defined, containing a single manufacturer part.

A manufacturer part can be added to the Part Choices list for the component in two ways:

To manually add a part choice, click the  button at the bottom of the region. The Add Part Choices dialog will appear - search for the required manufacturer part, select an entry for a supplier who vends that part, then click the OK button.

Search results in the dialog are grouped by manufacturer and manufacturer part number, with the sub-entries reflective of the vendors supplying that part. When you select a vendor of a part, it can be any vendor, it is the manufacturer part that is added to the Part Choices list. And by using the manufacturer part, and not a specific vendor/supplier, you get a single Part Choice that will bring with it all solutions based on the suppliers vending that part (and who are available for use through your managed content server).
If the component already has defined data, or if there are already part choices in the list, the Use component data dialog will appear. Use this to decide how you want to use the result, should you wish to replace any or all existing data or, to just have the part added as a part choice, click Skip.

Making a manual part choice - use the Add Part Choices dialog to search for the required manufacturer part, select a vendor (supplier)
entry and click OK.

To remove a part choice, select it in the list, then click the  button.

A Part Choice contains various pieces of information, as summarized in the following image, and detailed thereafter.

Supply Chain Data and User Ranking features are not available at this time.

The 'anatomy' of a Part Choice - the entry can be broken down into 7 key pieces of information.

  1. Part Image.
  2. Manufacturer Name and Manufacturer Part Number. This is a clickable link to the Octopart website, providing detailed information on that manufacturer part.
  3. Description.
  4. Stock. This entry displays the total sum of the stock available from the the suppliers enabled as part of the Altium Parts Provider source for your managed content server.
  5. Median unit price. This entry will be displayed in red text if there are no prices, or the price = 0.
  6. Manufacturer Lifecycle. This can appear in one of four states:
  • Gray = Default, unknown or no information
  • Green = New or Volume Production states
  • Orange = Not Recommended for New Design
  • Red = Obsolete or EOL
  1. Datasheet. Click the  button to open the manufacturer's datasheet for the part. All datasheets are hosted on the Ciiva website.
The lifecycle status is designed to be used as an indicator, for a number of reasons:
  1. Altium maintains a database of many millions of components, produced by thousands of component manufacturers. Since there is no single, consistent method used by those manufacturers to reflect a component's lifecycle state, the status is based on information aggregated from manufacturers, global distributors and global sales analysis.
  2. A part is only reported as EOL or Obsolete when there is at least one authorized distributor or manufacturer that has confirmed this status.
  3. Determining the Not Recommended for New Design status is more complex. Manufacturers sometimes just report if a part is active or not, and may not give advance warning that a part is to be discontinued or replaced. Therefore this lifecycle status does not always concur with the status provided by the manufacturer. The status algorithm uses various information, including real time and historical stock availability from all distributors, to try to determine the availability of the part. Parts which have consistently poor availability (when they have been generally available in the past), or cannot be sourced over a period of time after having previously having good availability, will eventually be flagged as Not Recommended for New Design (if they are not already EOL or Obsolete).
  4. The idea of the lifecycle status indicator is to provide simple-to-understand information that helps you to make more informed decisions about a part, by highlighting those parts which may be problematic. However, due to the sheer volume of data and number of components that are managed, there is always a chance that the Altium status lags behind the instantaneous manufacturer status, and is therefore not up-to-date. It is not possible for Altium to guarantee the accuracy of the lifecycle status, it is recommended that if there is any doubt that you double-check with the manufacturer for authorized lifecycle information.

Creating the Component from a Part Search

Providing a boost to creation of a managed component, Altium NEXUS supports the ability to search for a real-world part, courtesy of Part Search functionality, and then add that part (or a portion of its data) into the Component Editor. In this way, you can quickly define a new managed part for addition to your managed content server, without having to craft that component from scratch. There is no having to 'reinvent the wheel' as it were, since all data for that part - its name, description, parameters, datasheets, part choices and any defined models - can be brought in.

The feature itself can be accessed in a number of ways - click on a collapsible section to explore further.

As a general observation, if the component has no data yet defined, all data available for that part will be loaded when using this feature. If the component is partially defined, then you will be given the option of how to use the data from the chosen part - whether to use all its data (name, description, parameters, models and part choices), its parameters only (name, parameters and part choices, while leaving description, datasheets and models untouched), or just its name (leaving all other entities untouched).

The Name field gives two methods of access to the Part Search feature:

  • Typing Directly - as you start typing in the Name field, a pop-up listing of matching parts is presented. Select a part to use.

Start typing the name of the required manufacturer part - and select the relevant entry from the convenient pop-up listing. The image shows all data for that part being brought
into the Component Editor.

  • Using the Part Search dialog - click the  button at the far right of the field to access the Part Search dialog. Search for the required part, select an entry for a supplier who vends that part, then click the OK button.
Search results in the dialog are grouped by manufacturer and manufacturer part number, with the sub-entries reflective of the vendors supplying that part. When you select a vendor of a part, it can be any vendor, it is the manufacturer part that is used to create the new component. And in terms of Part Choice, by creating based on the manufacturer part, and not a specific vendor/supplier, you get a single Part Choice that will bring with it all solutions based on the suppliers vending that part (and who are available for use through your managed content server). Parameters are imported in accordance with defined Parameter Import Options - configured on the Data Management - Parts Providers page of the Preferences dialog.

Use the Part Search dialog to find the required manufacturer part - be sure to select one of its available vendors/suppliers before clicking OK. The image shows all data for that
part being brought into the Component Editor.

The Part Search feature can be accessed by choosing the Tools » Create from Part Search command, from the main menus. Alternatively, use the Shift+Ctrl+M keyboard shortcut. The Part Search dialog will appear. Search for the required part, select an entry for a supplier who vends that part, then click the OK button.

Search results in the dialog are grouped by manufacturer and manufacturer part number, with the sub-entries reflective of the vendors supplying that part. When you select a vendor of a part, it can be any vendor, it is the manufacturer part that is used to create the new component. And in terms of Part Choice, by creating based on the manufacturer part, and not a specific vendor/supplier, you get a single Part Choice that will bring with it all solutions based on the suppliers vending that part (and who are available for use through your managed content server). Parameters are imported in accordance with defined Parameter Import Options - configured on the Data Management - Parts Providers page of the Preferences dialog.

Use the Part Search dialog to find the required manufacturer part - be sure to select one of its available vendors/suppliers before clicking OK. The image shows all data for that
part being brought into the Component Editor.

A part can also effectively be chosen, and its data loaded, when manually adding a Part Choice. After clicking the  button at the bottom of the Part Choices region, the Add Part Choices dialog will appear. This is very similar to the Part Search dialog. Search for the required manufacturer part, select an entry for a supplier who vends that part, then click the OK button. For a new component, with no defined data, all data from the chosen part will be brought into the Component Editor.

Search for a Part Choice, and bring all the data associated with that part into the Component Editor, effectively defining the component.

If the component already has defined data, or if there are already part choices in the list, the Use component data dialog will appear. Use this to decide how you want to use the result, should you wish to replace any or all existing data or, to just have the part added as a part choice, click Skip.

Running a Component Rule Check

When you attempt to commit/release a component back to the Server, the Component Editor runs a validation - a Component Rule Check. This feature can also be run at any time, manually, by choosing the Tools » Component Rule Check command, from the main menus (be sure to have saved your component before you do).

The command is also available from the editor's main File menu.

Just as a board project has the Compiler to detect for any violations, the Component Editor has a Component Validator. Any violations that are found will be listed in the Messages panel.

Detecting issues with a component prior to releasing/committing to the server.

The Component Validator tests for an array of potential issues with the component and its defined models - both hardwired tests, as well as a range of violation types that can be user-defined at the global level.

Hardwired validation checks all carry a report mode of . Examples of these checks include:

  1. Component not referencing any models.
  2. A target folder not specified for the component in the target managed content server.
  3. Component not having a unique Id.

User-definable checks are configured on the Data Management - Component Rule Checks page of the Preferences dialog.

User-definable violation checks that can be configured as part of global preferences, for use with the Component Validator.

Any of the hardwired tests that fail, or user-defined checks at a level of Error or above, would prevent release of the component.

A Word About Linked Simulation Models

Related page: Managed Simulation Models

As with Symbol and Footprint Items, a component can also reference a revision of a Simulation Model Item. Adding a model link of this type is similar to adding a Symbol and Footprint, with the exception of there being no Wizard-based creation option, so refer back to the previous sections for information on that. Here, we look at including component-level simulation parameters, and also configuration of pin mapping.

Adding Component-Level Simulation Parameters

When using a simulation model for a component in a design, parameters specific to that model can be specified at two different levels:

  • Model-Level Parameter - specified as part of the simulation model definition itself (in the SimModel file), and released with that definition into a revision of the linked Simulation Model Item.
  • Component-Level Parameter - specified as part of the component definition (here in the Component Editor), and released with that definition into a revision of the linked Component Item.
Component-level parameters are used for parameters that are shared between multiple models or where the designer wants to make such a parameter visible/editable on the schematic (e.g. value, frequency etc).

Parameters are added at the component-level in the Parameters region of the Component Editor. It is important to note that the naming of parameters must be the same as those parameters defined at the model-level. To see the model-level parameters, and therefore which parameters can be added at the component-level (and their names!), click the View Parameters control, at the bottom of the Simulation model's preview window.

View the model-level parameters for a Simulation Model Item, to see which parameters can be added at the component-level - and how they are named!

Armed with the available model-level parameters, you can now proceed to add any of those same parameters at the component-level. To do so, click the  button at the bottom of the Parameters region. A new parameter entry will be added to the list. Change the name as required - remembering to match exactly the name of the corresponding model-level parameter.

Add sim-related parameters at the component-level. Notice that two parameters are already available - Area Factor and Temperature - courtesy of a referenced Component
Template.

When an instance of the released component is placed in a design, a simulation parameter can have a different value at the component-level, to that for the same parameter at the model-level. When the netlist is generated, the component-level parameter will have priority.
For some of the built-in SPICE3f5 models, entering a value for a parameter at the component-level will override a related parameter defined in a linked model file (*.mdl). For a semiconductor capacitor, for example, specifying a value for the component-level Width parameter will override any value specified for the DEFW parameter in the associated model file. If a parameter is specified at the component-level for a subcircuit model, that value will override the value defined for it in the linked subcircuit file (*.ckt). If a parameter is specified at the component-level for a digital device, that value will override the value specified for that parameter in the source SimCode definition (*.scb).

Pin Mapping

Once the link to the required SIM model has been chosen, you need to ensure that the pins of the component - when represented in the schematic domain - are correctly mapped to the pins of the simulation model.

This feature is not available while in Single Component Editing mode - you will need to switch to Batch Component Editing mode (Tools » Switch to Batch Editor).

Once you have switched the Component Editor to its Batch Component Editing mode, mapping is performed in the Pin Mapping dialog, accessed by right-clicking on the component definition's SIM model entry and choosing Operations » Edit Pin Mapping from the context menu. For each schematic pin, use the available drop-down to change the associated Model Pin entry accordingly. If the device is multi-part, be sure to check the mapping for each part. Once finished, you can switch back to Single Component Editing mode (Tools » Switch to Single Component Editor), or proceed to release from within the Batch Component Editing mode.

Ensuring correct schematic pin-to-model pin mapping.

For a multi-part component, the ability to exclude a part from simulation is also determined through the Pin Mapping dialog.
For the built-in SPICE3f5 and supported PSpice models, the function of each of the pins in a model can be found in the general form section for that model, in the SPICE 3f5 user manual. For subcircuit models, the manufacturer will typically insert comments for each pin of the model, describing that pin's function. If no commenting is evident, then the pinout of the model will typically be that of the physical device itself. Consult the datasheet for the device in this case. For Digital SimCode models, the mapping of the component pins to the INPUTS and OUTPUTS declared in the SimCode file will depend on the input and output node list entries in the netlist template.

Full Support for Digital SimCode Models

When using a managed component that references a Simulation Model Item featuring a SimCode definition (in a *.scb file), that scb file (released with the SimModel file to the Server) is used for subsequently run simulations. In the genera ted simulation netlist (*.nsx file), the model reference will contain the full path to the scb file, cached locally from the Server. For example:

.MODEL 74LS90 xsimcode(file="C:\ProgramData\Altium\Altium NEXUS {A586F887-1E00-4F36-9EC8-61C78B91FA73}\VaultsFileCache\0072B38F-E431-40BB-B462-FD262DB9CDAB\9A7AB3DA-D4A5-43B3-9C88-33A56E86A0BF\Released\LS.SCB" func=ls90)

An .scb file typically contains multiple scb models. When the simulation model definition is released, the .scb file - released and stored with the SimModel file in the Server - is stripped back to include only the single scb model referenced by the simulation model definition, and not the full listing of models.

 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

You are reporting an issue with the following selected text
and/or image within the active document:
ALTIUM DESIGNER FREE TRIAL
Altium Designer Free Trial
Let’s get started. First off, are you or your organization already using Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

In that case, why do you need an evaluation license?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You actually don’t need an evaluation license for that.

Click the button below to download the latest Altium Designer installer.

Download Altium Designer Installer

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Please fill out the form below to get a quote for a new seat of Altium Designer.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

If you are on Altium Subscription, you don’t need an evaluation license.

If you are not an active Altium Subscription member, please fill out the form below to get your free trial.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Why are you looking to evaluate Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

You came to the right place! Please fill out the form below to get your free trial started.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Sounds exciting! Did you know we offer special discounted student licenses? For more information, click here.

In the meantime, feel free to request a free trial by filling out the form below.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

That’s great! Making things is awesome. We have the perfect program for you.

Upverter is a free community-driven platform designed specifically to meet the needs of makers like you.

Click here to give it a try!

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.