Working with the Project Releaser

Modified by Jason Howie on Aug 29, 2018

Parent page: Board Design Release

Once a design is considered ready for flight into the wider world, it needs to be released - a process that can often be underestimated.

Altium NEXUS provides powerful, high-integrity board design release management, courtesy of its Project Releaser. With an intuitive user interface, you are able to generate all manufacturing data for your project simultaneously - fabrication data, assembly data, design source, etc. The releaser also provides the ability to generate the assembly data for multiple detected variants of your board design at the same time. You don't even have to worry if you haven't created Output Job files - it'll do that for you if you ask it to!

The Project Releaser caters for all types of PCB project - unmanaged/non-version-controlled, under external VCS control, or managed through a managed content server - by offering two modes of operation:

  • Managed (Online) Mode - releasing all generated data to revisions of Items in the managed content server to which you are actively signed in. You don't even have to remember to increment Item Revisions, it is all handled for you.
  • Unmanaged (Offline) Mode - releasing all generated data into a folder-based structure, which can be optionally wrapped up in a single Zip file.

With the Project Releaser, you'll be able to generate your manufacturing data with simplified ease, and with the highest integrity. And you'll also be able to survey the fruits of that generation before you commit to finalizing the release (viewing Gerbers/ODB++ data in the CAM Editor for example), ensuring that the data you have generated is exactly the data required to get your board manufactured on time, first time.

This document takes a look at the release process from the perspective of releasing to a target managed content server. If you are not using a managed content server, or are signed out from your Server, you will be using the Project Releaser in its unmanaged (Offline) mode, which is covered here.

Accessing the Project Releaser

The graphical interface to the Project Releaser is the Release view, which can be accessed by:

  • Choosing the Project » Project Releaser command from the main menus (with a source document for the required project open as the active document).
  • Right-clicking on the entry for the required project, in the Projects panel, and choosing the Project Releaser command from the context menu.

Accessing the Release view - the user interface to the Project Releaser.

Release Mode/Target

The Project Releaser attempts to detect which release mode to use - managed (Online) or unmanaged (Offline) - and the target of the release, automatically. Where a choice can exist, typically where the project has been released to one managed content server, and you are actively signed in to another, the system will provide the options available to you.

When releasing to a managed content server, the target Server is stored as an attribute in the PCB project file. So you can have a target Server stored with the project that can be different to the Server in which you are actively signed in.
If you have a regular project (not managed and not under VCS), and are only connected to the Altium Content Vault, then Offline mode of releasing will be entered automatically.

Detecting Output Job Files

If your project currently has no Output Job file(s) associated to it, the Project Releaser will detect this, and you will be asked if you wish to add default ones. If you opt to do so, the following will be created:

  • Fabrication.OutJob - with the following outputs defined:
    • Documentation Outputs: PCB Prints
    • Fabrication Outputs: Gerber Files, NC Drill Files, and IPC-2581
    • Validation Outputs: Design Rules Check, Footprint Comparison Report
    • Export Outputs: Save As/Export PCB (in ASCII format)
  • Assembly.OutJob - with the following outputs defined:
    • Documentation Outputs: PCB 3D Print, Schematic Prints
    • Assembly Outputs: Generates pick and place files, Assembly Drawings
    • Report Outputs: Bill of Materials
    • Export Outputs: Export STEP

These default Output Job files are sourced from the following default installation folder: \Users\Public\Documents\Altium\Nexus<Version>\OutputJobs.

You can run with the default files as they are, massage them to suit your needs, and even add additional Output Job files. Define the Outjobs as required within the default folder, or your own custom folder location. If using your own folder, specify that location using the OutputJob Path field, on the System - Default Locations page of the Preferences dialog. All Output Job files found in the specified location will be added to the project.
If you have at least one OutJob file defined for the project, this auto creation will not be offered.

Detecting Variants

A very powerful aspect of the Project Releaser, is that it will detect defined variants for your design and create Assembly Data sets for each, ready for release. Each Assembly Data set will appear with (default) target item naming in the form:

PCBA-[ProjectName]-[VariantName]

The Data set for the base (non-varied) design will be PCBA-[ProjectName]-[NO VARIATIONS].

The [VariantName] suffix ensures that the correct variant is being used when generating data from the assigned OutJob file(s).

Additional Assembly Data sets created based on detection of variants defined for the design.

Setting Server Item Naming Schemes

When releasing a project to the active managed content server for the first time, you can define how the target data items in that Server (whose revisions receive the generated data) are named. This is done on the Item Naming tab of the Project Release Options dialog, which is accessed by pressing the  button, at the bottom-left of the view (or by clicking on the Target Revision link for a data set to be released, and choosing Edit from the context menu). Use this tab to:

  • Define the name for the project. By default, this will be filled with the actual name of the project.
  • Define the top-level target folder (in the Server) in which the data will be released.
  • Define default naming schemes for the various data items that can be generated as part of the release.
The Project item is not an item created to receive release data, but rather an entity used as the anchor point for presenting the overall project view of the released data items, and how they are all connected, when viewing a managed project in the Explorer panel. For more information, see Viewing a Released Managed Project.

To change any of the naming schemes, click the Settings button to access the Naming Template Settings dialog.

Set the target folder and define the naming for generated data items in the target managed content server.

The following macro formats are supported for use in a naming template:

  • Parameter-based - supporting the use of parameters, enclosed in square braces (e.g. [ProjectName], [VariantName], [ProjectParameter]).
  • Numeric-based - supporting the use of numerical quantifiers, enclosed in curly braces (e.g. {0000}, {9000}).
From the Item Naming tab of the Project Release Options dialog, you can click on a naming scheme entry directly, and change the naming as desired. Alternatively, click the button at the right of the field to access the Choose Item dialog (an incarnation of the Explorer panel), which allows you to target an existing Item in the active managed content server.
Item naming can be changed at any time during the first stage of the Release view, when configuring the data that is to be released into the active managed content server. After data has been generated for a particular data set, and uploaded to the Server, the associated naming cannot be changed.

The Release Process

With Server data Item naming defined as required, you can now get started with the release process. This is a staged flow, with the entries on the left-hand side of the Release view showing you at-a-glance, which stage you are currently at.

Online Stage 1 - Configure Vault Release

This stage of the release process is where you specify the type(s) of data that you wish to generate. Data Items that can be released are:

  • Source Data - a snapshot of the source design.
  • Fabrication Data - the data required by a Fabrication House to create the bare board.
  • Assembly Data for the Base Design (no variations) - the data required by an Assembly House to fully populate the bare board in accordance with a Bill of Materials, and for the non-varied base design.
  • Assembly Data for Design Variant n - the data required by an Assembly House to populate the bare board in accordance with a Bill of Materials, and for Variant n of the base design.

The number of assembly data sets will correspond to the base (non-varied) design, and all detected variants defined for that design.

In addition, you can add and configure Custom Data sections - allowing you to create a customized set of release data. This is more for backward compatibility, or custom data flows. No references are created, except to the source data. Any number of custom data sets can be added and configured as part of the release (click the Add Section control beneath the list of currently defined data items).

Stage 1 of the project release process - configuring what is to be included in the release (what data to generate).

The Source Data item is always included for a release. The other data items can be optionally included.

For the Fabrication and Assembly data items to be included in a release requires at least one OutputJob file be assigned to them. If you have Output Job files with names that start with the sub-strings 'fab' and 'ass', those Out Jobs will be assigned automatically to the Fabrication Data and Assembly Data sections respectively, when the Release view is first accessed. If not, you will need to assign the applicable OutJobs in each case manually. T his can be done from the Release Options tab of the Project Release Options dialog (click the  button at the bottom-left of the view to access).

Assign OutJobs to the applicable data sets as required.

The Release Options tab of the Project Release Options dialog can also be used to change the release target - switching between managed (Online) and umanaged (Offline) modes of operation. Three options are available:

  • Unmanaged - Folder (Offline): set this option to release generated data to a local folder. The root folder path is specified on the Output Path tab of the dialog. By default this is set to [OutputPath] (using the path defined in the Output Path field, on the Options tab of the Project Options dialog).
  • Unmanaged - Zip (Offline): set this option to release generated data to a local folder. The data will be packed into a single Zip file. The Zip path/name is specified on the Output Path tab of the dialog. By default this is set to [OutputPath][ProjectName].zip (using the path defined in the Output Path field, on the Options tab of the Project Options dialog).
  • Managed - <ServerName> (Online): set this option to release to the managed content server (with ServerName) to which you are actively signed in.

Switch release target - where the generated data is to be sent - as part of the release options for the project.

Click on the link next to a Target Revision entry, back in the main view, to access a menu of commands, illustrated in the following image and described thereafter.

Accessing controls to specify the target revision for a data set that is to be generated as part of the release - hover over
the image to see.

  • Auto <RevisionID> - this entry lets the system handle the revisions, so that you don't need to create planned revisions where they do not currently exist. The RevisionID shows the next revision of the Item at the same level within the assigned revision naming scheme (e.g. if the current revision is A.1, this command would switch the target to be A.2).
  • Next <RevisionID> - use this entry to quickly increment the target revision at the next level within the assigned revision naming scheme. The RevisionID shows the next revision (e.g. if the current revision is A.1, this command would switch the target to be B.1).
  • Custom - use this entry to target a specific revision of a target item, by defining a custom Revision ID through the Custom Revision ID dialog.
  • Browse - use this entry to point to an existing target Item-Revision in which to release. The Choose Target Item dialog (an incarnation of the Explorer panel) will appear with which to do so.
  • Edit - use this entry to access the Item Naming tab of the Project Release Options dialog, from where you can change the name of the target Item (and initial revision) that will be created.
  • Navigate - use this entry to quickly navigate to the Item in the Explorer panel (where it has already been released, and the next revision exists in a planned state).

The entry at the top of the menu will reflect the current target revision chosen/defined.

Click on the Details control - at the far right of a data set's header - to access details of what exactly is going to be generated by that data set. Collapse this extended view for a set by clicking on the Hide Details control. With the exception of the Source Data set, the data generated will come from one or more assigned Output Job files. You can quickly access the source OutJob by clicking the Configure control.

Access the detailed view for a data set to see what data will be generated - hover over the image to see.

There are additional settings that can be defined, relating to project release, on the Data Management - Servers page of the Preferences dialog:

  • The folder used to temporarily store generated files prior to uploading to the active managed content server can be set to the automated location (\Users\<ProfileName>\AppData\Local\Temp for a default installation), or manually overridden with a folder of your choice.
  • Enable the Delete contents after exiting release mode option, to have the temporary storage folder effectively flushed after finishing the release process.
  • The name of each generated output can be optionally prefixed with the Item ID and Revision ID (e.g. [FAB-Bluetooth_Sentinel-A.1] Validation.PDF). To do so, enable the Prepend revision HRID to file names option.

Additional preferences relating to the project release process.

With the data items that are to be created as part of the release configured as required, click the  button at the bottom-right of the page to proceed.

The button has two states. Clicking it will launch the standard Prepare command. This will proceed with the release up to the Review Data stage - allowing you to essentially double-check that all is in order before commiting the release of the data. If you don't want to pause for review, use the drop-down menu associated to the button and choose the Prepare & Release command.

Several pre-release checks are performed as part of the preparation, including:

  • Making sure that the project and all files have been saved.
  • Making sure that the project and all relevant file(s) are committed to VCS if applicable.
  • Making sure that each enabled data item has been given a name.
  • Ensuring that the user has rights to create the target item (and revision).
  • Creating the required target Items (and planned revisions) in the managed content server, where they do not currently exist, and ensuring the next revision is used for those items that do.

If any issues are found, you will be offered solutions with which to resolve them (such as saving locally modified files, and committing to VCS).

The Source Data Item is generated at this time - with a snapshot of the source design project files released to the target item revision.

Online Stage 2 - Validate Project

After Stage 1 completes without issue, this next stage of the release process is run automatically when one or more Validation-type reports are detected in assigned OutJob file(s). All defined validation output generators, defined in an Output Job file assigned to the data item being released, are run. This includes running any of:

  • Differences Report - using the comparator to determine if the source and PCB design documents are correctly in-sync.
  • Electrical Rules Check - checking the electrical/drafting validity of the captured source design.
  • Design Rules Check - checking the validity of the PCB document in relation to specified board-level design constraints.
  • Footprint Comparison Report - comparing footprints on the board against their source library to ensure they are up-to-date, and matched.
  • Component State Checking - checking for components that are in restricted states. As part of configuration, you determine the action to be taken for each currently defined state, of each currently defined Lifecycle Definition in the target managed content server; no action, a warning, or generate an error. The latter will prevent release of the design. In addition, running the check will generate a handy HTML-based report, allowing you to see at-a-glance which design components are not in valid states.
  • Environment Configuration Compliance Check - checking that only data items permitted through the environment configuration available for use by your assigned role (if applicable), are being used. This check can also ensure that all design items are sourced from a managed content server.

If validation is successful, the  icon is presented, with the text Passed. If not, the  icon will be displayed, with the text Failed.

The release will fail if any validation checks are not passed successfully.
Clicking  at the bottom-right of the page will stop the release process.

Online Stage 3 - Generate Data

After Stage 2 completes without issue, this next stage of the release process is run automatically. This is where all other outputs - defined in the OutJob file(s) assigned to the included Data Items - are run, to generate the data to be released into the relevant target items in the Server.

As with the other stages, but more noticeable with this stage, since it takes longer to run, icons are used to present the progress of generation:

- not yet run/generated.

- being run/generated.

 - generated successfully.

 - generation failed.

Clicking  at the bottom-right of the page will stop the release process.

Online Stage 4 - Review Data

With all validation checks passed, and output data generated, this stage of the release process allows you to review the generated data.

If you chose to use the Prepare & Release command (from the menu associated to the  button), the Project Releaser will not pause at the Review Data stage.

Review generated data, checking that all is as it should be, prior to commiting to the release, and uploading the data to the managed content server.

The page defaults to present a simple (compact) view of the generated data. Switch to a more detailed view by clicking the Details control associated to a section of interest.

Click on a Details control to switch from simple to detailed view of the generated data for the associated section. Switch back again by clicking the Hide Details control.

The following table lists the possible output states, when data is being generated and observed from the detailed view:

State

Description

Output has not yet been generated/does not exist.

Output has been generated, but changes have since happened on the design side, making the validity of this data no longer current.

The output is currently in the process of being generated.

The output is validation-based and has generated a report free of any errors. For an ERC report, there are either no errors, or the level of those errors falls within the specified maximum tolerated error level for that report.

The output (excluding validation-based outputs) has generated successfully.

The output has not generated successfully. For a validation-based output this means errors exist within the source design documents that are causing certain check(s) to fail. For a standard output, the output could not be generated successfully. Perhaps Fatal Errors exist when performing a pre-generation compile, or something is amiss in the configuration of the associated output generator, in the Output Job file.

In the compact view of the generated data, click a View link to open the associated data file, or file set, either within the relevant editor within Altium NEXUS (e.g. the CAM editor), or within the relevant external application (e.g. Microsoft Excel). In the detailed view, double-click on an entry to view just that file.

In the Source Data section, in compact view, clicking the View link will open Windows File Explorer at the temporary folder in which the snapshot of the source files for the project have been saved. This functionality is also provided through the Explore link, at the right of the sections header. In fact, each section has such a control, to quickly jump to the parent folder for that data, within the temporary folder.
In the detailed view, commands on the right-click context menu provide the ability to open a document, and explore to where it has been generated (in the temporary folder). You can also add data columns for folder location and creation date - right-click on the heading area for a grid and choose the Select Columns command, giving access to a dialog with which to tailor the data presented.

If, after reviewing  the data, you find you need to make modifications, click the  button at the bottom-right of the page. A confirmation dialog will appear, alerting you to the fact that all generated data will be lost - clicking OK will cancel the release and you will be returned to Stage 1 of the process.

The system naturally prevents any modification of design files between preparing the release and releasing the data to the managed content server. If you do change design files in any way, the release process will terminate, and you will return to the initial stage, prior to release preparation.

If the generated data all looks good, proceed with the release by clicking the  button (also at the bottom-right of the page). The Confirm Release dialog will appear, summarizing the configurations of the project that will be released to the managed content server. You also have the opportunity here to add a Name (by default the entry here is [ProjectName]), Description, and to add any pertinent release notes.

Confirmation of what will be released, in terms of the Item-Revisions generated, and the ability to change Name/Description and add
release notes.

Online Stage 5 - Upload Data

After confirming the release in the previous stage, this next stage is automatically entered. It simply presents progress of data upload into the revisions of the relevant data Items in the managed content server.

This stage simply reflects progress of the upload of generated data to the linked Item-Revisions in the managed content server.

Online Stage 6 - Execution Report

This is the final stage of the process, providing a summary of the release.

The final report for the release.

Use the Navigation Links to quickly access the associated Item Revision, containing the released data (Fabrication Data, Assembly Data, and any Custom Data sets), in the Explorer panel - your portal to your managed content server.

Viewing the released data for the project, directly in the managed content server, courtesy of the Explorer panel.

If your design project is a Managed Project, then you have one extra piece of functionality available to you after the release is complete. By clicking on the Project Page link, the last of the Navigation Links at the top of the Execution Report page, you will open the Explorer panel, presenting the project in the Project View - only available for Managed Projects.

If you have previously viewed the project in Classic View, you may need to manually switch over to Project View - commands are available from the menu associated to the  button.

For a managed project, you can explore the project in the Explorer panel in more detail, courtesy of the Project View.

This view is the same as that when browsing the detailed view for a managed project, from the Projects page of the Server's browser-based interface. The following tabs are available within the view:

  • Stream - detailing recent activity for the project.
  • Parameters - provide a listing of parameters that have been defined at the project level, either within Altium Designer (through the Parameters tab of the Project Options dialog), or through the Server (not currently available).
  • Releases - presents every release of the project, with the latest release at the top of the list. Each entry on the left shows a snapshot of the date/time of release, along with what packages are included in the release. Use the Search field to quickly find a specific release (very useful if you have released the project many times). As you click on a release entry on the left, the following sub-tabs on the right populate with information for that release:
    • Details - a graphical representation of how the generated data links together, all under the umbrella of the parent design project. Click a link to access that Item-Revision within the NEXUS Server, on the Explorer page of the browser interface. Also included is the date and time of the release, by whom it was released, and the VCS revision.
    • Parameters - a listing of parameters that have been defined at the project level, either within Altium Designer (through the Parameters tab of the Project Options dialog), or through the Server (not currently available). In addition, system-generated parameters specific to that release.
    • Preview - an interactive preview of the released design source - zoom, explore, and double-click entities in the main preview window to navigate around the released design source.
    • Part List - a simple listing of all managed components in the released design, in terms of the following information:
      • Name
      • Item ID
      • Description
      • Designator
      • Quantity
      • Revision Status

Note that the list shows all parts used in the released design, irrespective of variant assembly packages generated. In other words, the list is not filtered by variant.

  • Working Files - the source design files, which can be downloaded in a single Zip file.

That's it - with your project released, you can simply close the Release view (using the  button at the bottom-right of the view). And when you need to re-release the same project in the future, the Project Releaser facilitates this quickly and easily, and increments the target Item-Revisions automatically.

Unmanaged (Offline) Release Mode

As well as the managed (Online) release mode described previously, the Project Releaser also caters for local, unmanaged (Offline) release. Typically, this mode of releasing would be used if you don't use a managed content server, or if you cannot be currently connected to your managed content server. And while the Project Releaser will automatically determine the mode where possible, or offer options where that is not so clear cut, you can always force the use of Offline mode. The latter is performed by setting the Release Target, on the Release Options tab of the Project Release Options dialog (click the  button, while at Stage 1 of the release process), to one of the following:

  • Unmanaged - Folder: set this option to release generated data to a local folder. The root folder path is specified on the Output Path tab of the dialog. By default this is set to [OutputPath] (using the path defined in the Output Path field, on the Options tab of the Project Options dialog).
  • Unmanaged - Zip: set this option to release generated data to a local folder. The data will be packed into a single Zip file. The Zip path/name is specified on the Output Path tab of the dialog. By default this is set to [OutputPath][ProjectName].zip (using the path defined in the Output Path field, on the Options tab of the Project Options dialog).
You can use [ProjectName], [<VariantParameterName>], [<ProjectParameterName>] entries when defining the output path required.

You can quickly tell if the Project Releaser is configured in its Offline mode, by:

  • The title of stage 1 reading Configure Local Release, instead of Configure Vault Release (when in Online mode).
  • The title of Stage 5 reading Pack Data, instead of Upload Data (when in Online mode).

The Project Releaser configured in a local, unmanaged (Offline) mode.

The release process is very similar to that described for the managed (Online) release mode, just targeting release of data to local folders instead. Rather than repeating the information described earlier, here we'll just outline the stages involved, and highlight any differences.

Offline Stage 1 - Configure Local Release

Here is where you configure the data that you want to be generated from your design project. Source data is always included as part of a release, with the option to include fabrication, assembly (base and/or variations), and any custom data, as required.

For each data set to be generated, you need to specify a target folder where that data will be stored. Default folder names are used as follows:

  • Source Data - will be generated in the Sources folder.
  • Fabrication Data - will be generated in the Fabrication folder.
  • Assembly Data for no variant - will be generated in the Assembly folder.
  • Assembly Data for <VariantName> - will be generated in the Assembly <VariantName> folder.
  • Custom Data <Custom - n> - will be generated in the <Custom - n> folder.

You can of course change this default naming to suit your requirements. To do so, click on a current Target Folder entry, enter the desired new name for the folder, and press Enter.

When releasing to a local folder, or packed Zip file, bear in mind that re-releasing with the same defined folder names will simply overwrite existing data files within those folders.

With the data sets to be created as part of the release configured as required, click the  button at the bottom-right of the page to proceed.

The button has two states. These differ slightly between the two unmanaged release options:
  • Unmanaged - Folder: clicking the button will launch the standard Prepare command. This will proceed with the release up to the Review Data stage - allowing you to essentially double-check that all is in order before releasing to the target folders. If you don't want to pause for review, use the drop-down menu associated to the button and choose the Prepare & Explore command.
  • Unmanaged - Zip: clicking the button will launch the standard Prepare command. This will proceed with the release up to the Review Data stage - allowing you to essentially double-check that all is in order before packing the data into the Zip file. If you don't want to pause for review, use the drop-down menu associated to the button and choose the Prepare & Pack command.

Several pre-release checks are now performed, including:

  • Making sure that the project and all files have been saved.
  • Making sure that the project and all relevant file(s) are committed to VCS if applicable.
  • Making sure that each enabled data item has been given a target folder.

If any issues are found, you will be offered solutions with which to resolve them (such as saving locally modified files, and committing to VCS).

The Source Data is generated at this stage - with a snapshot of the source design project files released to the target folder.

Offline Stage 2 - Validate Project

After Stage 1 completes without issue, this next stage of the release process is run automatically when one or more Validation-type reports are detected in assigned OutJob file(s). All defined validation output generators, defined in an Output Job file assigned to the data item being released, are run. This stage runs the same as it does when releasing in managed (Online) mode.

The release will fail if any validation checks are not passed successfully.
Clicking  at the bottom-right of the page will stop the release process.

Offline Stage 3 - Generate Data

After Stage 2 completes without issue, this next stage of the release process is run automatically. This is where all other outputs - defined in the OutJob file(s) assigned to the included Data Items - are run, to generate the data to be released into the relevant target folders. This stage runs the same as it does when releasing in managed (Online) mode.

Clicking  at the bottom-right of the page will stop the release process.

Offline Stage 4 - Review Data

With all validation checks passed, and output data generated, this stage of the release process allows you to review the generated data. This stage behaves in much the same way as when releasing in managed (Online) mode.

If you used the Prepare & Explore command (Unmanaged - Folder release target), or Prepare & Pack command (Unmanaged - Zip release target), this stage will not be available to you - in other words, there will be no pause for review, the data will be released straight away - to the target folders, or packed into the target Zip file, respectively.

Review generated data, checking that all is as it should be, prior to committing to the release, and sending the data to the targeted folder(s), or packing the
data into the localized zip file, in accordance with the unmanaged release option chosen.

In the compact view of the generated data, click a View link to open the associated data file, or file set, either within the relevant editor within Altium NEXUS (e.g. the CAM editor), or within the relevant external application (e.g. Microsoft Excel). In the detailed view, double-click on an entry to view just that file.

If, after reviewing the data, you find you need to make modifications, click the  button at the bottom-right of the page. A confirmation dialog will appear, alerting you to the fact that all generated data will be lost - clicking OK will cancel the release and you will be returned to Stage 1 of the process.

The system naturally prevents any modification of design files between preparing the release and releasing the data to the target folder(s). If you do change design files in any way, the release process will terminate, and you will return to the initial stage, prior to release preparation.

If the generated data all looks good, proceed with the release by clicking the  button (also at the bottom-right of the page). What happens next depends on the target release option you are using:

  • Unmanaged - Folder: the generated files will be released to the target folder(s) and the process will jump directly to the last stage, to view the Execution Report.
  • Unmanaged - Zip: the process will proceed to the next stage - Pack Data.

Offline Stage 5 - Pack Data

After confirming the release in the previous stage, this next stage is automatically entered, and involves the data being packed into a single, localized zip file. The Zip path/name is specified on the Output Path tab of the Project Release Options dialog. By default this is set to [OutputPath][ProjectName].zip (using the path defined in the Output Path field, on the Options tab of the Project Options dialog).

This stage is only applicable when you are using the Unmanaged - Zip target release option.

Offline Stage 6 - Execution Report

This is the final stage of the process, providing a summary of the release.

The final report for the release, as shown when using the Unmanaged - Folder release target. Hover over the image to see the equivalent with the
release target set to Unmanaged - Zip.

Use the Navigation Link provided to quickly explore (in Windows File Explorer) to the output folder, or packed zip file, respectively.

Quickly browse to the output folder of locally released data, directly from the Execution Report stage of the interface. Hover over the image to see an example of browsing to
the packaged zip file of locally released data.

 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

You are reporting an issue with the following selected text
and/or image within the active document:
ALTIUM DESIGNER FREE TRIAL
Altium Designer Free Trial
Let’s get started. First off, are you or your organization already using Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © Altium Limited

In that case, why do you need an evaluation license?

If would like to speak with a representative, please contact your local Altium office.
Copyright © Altium Limited

Got it. You actually don’t need an evaluation license for that.

Click the button below to download the latest Altium Designer installer.


Download Altium Designer Installer

If would like to speak with a representative, please contact your local Altium office.
Copyright © Altium Limited

Please fill out the form below to get a quote for a new seat of Altium Designer.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

If you are on Altium Subscription, you don’t need an evaluation license.

If you are not an active Altium Subscription member, please fill out the form below to get your free trial.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Why are you looking to evaluate Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © Altium Limited

You came to the right place! Please fill out the form below to get your free trial started.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Sounds exciting! Did you know we offer special discounted student licenses? For more information, click here.

In the meantime, feel free to request a free trial by filling out the form below.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

That’s great! Making things is awesome. We have the perfect program for you.

Upverter is a free community-driven platform designed specifically to meet the needs of makers like you.

Click here to give it a try!

If would like to speak with a representative, please contact your local Altium office.
Copyright © Altium Limited

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.