New Features and Updates Summary

Modified by Susan Riege on Aug 6, 2018

FPGA Pin Mapper

The FPGA Pin Mapper is currently a beta version.

The FPGA Pin Mapping feature has been developed to expedite the process of achieving the optimal topology for pin programmable devices in PCB layouts. It offers an interactive mechanism for exchanging pin/net definition data between the FPGA (or Microcontroller) and PCB domains via the common format of csv pin report/information files.

Included in Altium NEXUS as the Pin Mapper dialog, it allows a link to be specified between a schematic component and an external *.csv pin information file that has been generated by the FPGA tool. Altium NEXUS will detect any changes made to that file and offer a range of pin data synchronization choices, including the option to update the external file to match the net pin names in Altium NEXUS.

The pin data exchange between the domains is therefore bidirectional, which enables an iterative and cooperative approach to FPGA pin layout through pin swapping, while avoiding the errors of manually passing pin data between domains.

► See the FPGA Pin Mapper Quick Guide for an overview of using the Pin Mapping feature.

Updates

Create Differential Pair classes in the Schematic Editor

A dedicated Differential Pair Class can now be defined at the schematic level by adding the new Diff.PairNetClass class type to Differential Pair Directives through the Properties panel.

When passed to the PCB via an Engineering Change Order (ECO), the class becomes available as a Diff Pair Class to apply to PCB Differential Pair Routing Rules. Control over the handling of the Diff Pair Net classes can be specified in the Comparator and ECO tabs of the Options for PCB project dialog (Project » Project Options).

Improved Backdrilling support

Controlled Depth Drilling, or Back Drilling, in Altium NEXUS has been improved to support the PCB Via stub removal technique for any defined Back Drill Pairs. Along with allowing back drilling from the board surface to any internal layer, the process and its Design Rule now recognizes layer connections made to copper objects such as polygons, fills and regions.

Center Snapping for 3D models

To improve the convenience and accuracy of positioning 3D models in a PCB design, support has been added for a range of new snapping point placement options for 3D models. The enhanced snapping location options also improve the ability to measure critical span distances in 3D objects.

The additional snapping points include:

  • All hole centers.
  • The 90° locations (points crossing the orthogonal axes) around a hole circle.
  • The middle of a border line.
  • The center point in a line between two snap points (Spacebar mode).
  • The model’s body axis.

Export 3D board without Free Models

When exporting a 3D model of a board design to the MCAD domain it may be desirable to exclude freely placed 3D body models, such as an enclosure that has been previously imported from MCAD.

This choice is now included as a Skip Free 3D Bodies option in the Export Options dialog, which is opened from the File » Export » [format] command, where format is PARASOLID, STEP 3D or VRLM. The dialog option is also available when any of the 3D export formats have been added as an Export Output in an Output Job.

True generation of True Type Fonts in PDF Outputs

The documentation PDF generator has been updated to support vector rather than rasterized True Type fonts, which ensures clean font rendering in the PDF output and allows text to be searched and selected in the external PDF reader.

In Altium NEXUS, when configuring an OutJob to generate PDF documentation outputs containing True Type fonts, check the TT fonts printout option in the PCB Printout Properties dialog to enable full TTF support.

Note that Acrobat Reader will retain the results of previous searches, and may not deliver the expected search results when an existing PDF has been updated from Altium NEXUS. To correct this, flush the Acrobat Reader cache using the Purge Cache Contents button in the Search section of the reader’s Preferences dialog.

Light/Dark Theme choice

Altium NEXUS now includes the option to switch between its default 'dark' GUI theme and a new Altium Light Gray theme. The option is accessed from the UI Theme Current drop down menu in the System – View page of the Preferences dialog.

BOM Sets in ActiveBOM

A common requirement during BOM generation is the need to output the BOM in a number of different layouts – each displaying different data for various post-design processes, such as purchasing, board assembly preparation, and so on.

ActiveBOM now supports BOM Sets, each BOM Set captures the current layout and configuration of the BOM Items grid, saving it as a named Set. Any number of BOM Sets can be defined, click the  icon to apply that BOM Set.

BOM Sets are configured in the ActiveBOM Properties panel.

Support for selecting a BOM Set during BOM generation will be added in an upcoming release.

Improved BOM Aliases behavior in Draftsman

A Draftsman Bill of Materials (BOM) table allows the standard column header names to be substituted by user defined Alias names, which allow the table to be customized to suit personal/company BOM conventions. BOM Aliases can be defined in both a Draftsman BOM Table and a Project ActiveBOM document, where the latter settings will override the former.

The improved interaction between the two Alias definition locations is as follows:

  • Draftsman will source BOM information from an ActiveBOM document if one is available in the PCB Project, and the Data Source option in the BOM Properties panel is set to Project. A Draftsman BOM table will adopt any Aliases that have been defined in the source ActiveBOM document, and Draftsman's BOM Alias parameters are set to read-only.
  • When a BOM document is not available in the PCB Project, or Draftsman’s Data Source BOM property is set to Board, Aliases may be added and/or edited under the Columns tab of the Properties panel – available when a BOM Table is selected.

Note that Draftsman’s Tools » Update board command will detect the addition or removal of a project ActiveBOM document, or changes in an ActiveBOM document, and update the state of Draftsman BOM Table Aliases accordingly.

Formulas and Smart Edit in Properties panel

The ability to modify data strings using formulas and batch replacement has been added to the Properties panel in both the Schematic and PCB Editors. Formulas and expressions offer a convenient method of modifying attribute parameters of multiple selected objects to change their Location or string-based values such as the Designator and Comment.

► See information on Formulas and Batch Replacement (List panel documentation).

Some parameter string fields also provide access to the Smart Edit dialog when multiple objects are selected, which is opened from the associated ellipsis button ().

Global Component Display Properties for Draftsman Assembly View

When a placed Board Assembly View is selected in a Draftsman document, the Component Display Properties section in the Properties panel now offers property settings that apply to all components on the Assembly View. Changes to the display property options, such as the Component Body (formerly Geometry Source) or Designator visibility, are global to the currently selected Assembly View.

Conversely, when a component is selected in the Assembly View, the Component Display Properties settings apply to the selected component only (as in previous versions of Draftsman). Use the Component Display Properties dialog for making changes to a specific range of components.

Also included in the updated property options is the ability to specify the Designator color, via its associated button, for both the global and single component modes of the Component Display Properties.

Projects panel Document status indicators

Active file status icons have been added to the Projects panel as a visual aid to the state of documents in an open project.

When file locking is enabled (see Data Management – File Locking), the icons associated with documents in the panel indicate when a file is open (), modified (), open and locked by this instance of Altium NEXUS (), or open and locked by another instance of Altium software (). Regardless of file locking, a modified document is indicated by an asterisk (*) associated with its file name.

Selectable Subversion format for working copy

To improve the compatibility with existing, external Subversion systems, Altium NEXUS can now be configured to generate SVN working copy files in one of three common SVN version formats.

Where company standardization dictates the use of an earlier version of Subversion for example, such as version 1.7, Altium NEXUS can be set to that version in the Data Management – Version Control Preferences page. As a result, the working copy files created by a SVN repository Checkout will be in the version 1.7 format, which ensures compatibility with external Subversion clients and tools.

While a new set of working copy files will be created in the specified version, if an existing working copy is detected by Altium NEXUS, then the system will re-write the file set in the same version. By way of example, if the preferred SVN version is set to 1 .9 and the Checkout process encounters an existing working copy in version 1.8, then the Checkout copy will be created in version 1.8.

SVN version 1.9 is the default and recommended Subversion system in Altium NEXUS.

Special String identification labels

To assist in identifying Special Strings that are placed on a board layout or in a template legend, Altium Designer’s View Configuration panel now includes a Special Strings option. When the option is enabled, any placed Strings that are formed from converted Special Strings will be superimposed (labeled) with the unconverted Special String name.

Zoom in on a String to see its label overlay.

Arc Approximation Added to Region Objects

The Arc Approximation property for standalone regions has been added to Region objects in the Properties panel. This field is used to enter the maximum deviation from a perfect arc. 

Keepout Height support in IDF Import

The Altium NEXUS Intermediate Data Format (IDF) Importer has been improved to support Height constraints in IDF Keepouts.

In the IDF format, Keepout definitions can include an additional (maximum) Height attribute. When encountered by the Altium NEXUS importer, both a matching Room Definition and an associated Height constraint Rule are created for the imported board placement layout. The height constraint in the new Rule corresponds to the height attribute in the source IDF Keepout, therefore transferring its intended function to the Room definition in the imported board.

Drag and drop Models to the Component Editor

The Component Editor in Altium NEXUS will now accept component Models that are dragged and dropped directly from the Explorer panel.

Drag and drop a source Model on to the existing model to replace it (as is the case with Symbols), or drop the Model onto the area following existing models to add that Model to the component.

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

You are reporting an issue with the following selected text
and/or image within the active document:
ALTIUM DESIGNER FREE TRIAL
Altium Designer Free Trial
Let’s get started. First off, are you or your organization already using Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © Altium Limited

In that case, why do you need an evaluation license?

If would like to speak with a representative, please contact your local Altium office.
Copyright © Altium Limited

Got it. You actually don’t need an evaluation license for that.

Click the button below to download the latest Altium Designer installer.


Download Altium Designer Installer

If would like to speak with a representative, please contact your local Altium office.
Copyright © Altium Limited

Please fill out the form below to get a quote for a new seat of Altium Designer.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

If you are on Altium Subscription, you don’t need an evaluation license.

If you are not an active Altium Subscription member, please fill out the form below to get your free trial.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Why are you looking to evaluate Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © Altium Limited

You came to the right place! Please fill out the form below to get your free trial started.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Sounds exciting! Did you know we offer special discounted student licenses? For more information, click here.

In the meantime, feel free to request a free trial by filling out the form below.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

That’s great! Making things is awesome. We have the perfect program for you.

Upverter is a free community-driven platform designed specifically to meet the needs of makers like you.

Click here to give it a try!

If would like to speak with a representative, please contact your local Altium office.
Copyright © Altium Limited

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.