Altium Designer Documentation

Working Between the Schematic and the Board

Modified by Phil Loughhead on Aug 16, 2018

One of the great strengths of Altium Designer is how easily you can move between the various elements of your design. For example, a click in the Projects panel opens a schematic sheet, another click opens the PCB and another click opens the OutputJob file showing all the outputs you need to generate from the completed board.

However, design is much more than just having easy access to design files. As the designer, you need design-oriented tools that help to efficiently complete the many design tasks needed to get your product made. A key element to working efficiently is being able to move fluidly back and forth between the schematic and the board layout as you perform the various design tasks.

Perhaps you are preparing for placement, clustering related components around the periphery of the board as you examine your layout options. Or perhaps you are checking the connectivity, locating critical nets and examining where they have been routed.

For tasks such as these, you need to find objects in the target document based on objects you can see in the source document.

Cross probing, cross-selecting and the Navigator panel are some of the ways you can work between the schematic and PCB documents.

Cross probing, cross-selecting and the using the Navigator panel can all zoom the view, select the object, and dim other objects. Configure these behaviors in the System - Navigation page of the Preferences dialog.


The Unified Design Environment

Altium Designer uses the term unified to describe the way that the design sits - as a single entity, at the center of the design process. It is this unified, design-centric approach that makes it possible to work efficiently between the schematic and the board. The environment is also unified, with all of the editors and design technologies operating within the one software application.

Because Altium Designer is a unified design environment, the schematic and board can be opened side-by-side. Once the design has been compiled, you can:

  • Cross probe a component, net or pin between the schematic and the board.
  • Cross select components from one editor to the other.
  • Easily transfer design changes from one editor to the other in either direction.

Why Compile, and what is the Unified Data Model?

So what is compiling and why does the design need to be compiled?

When you compile your schematic project, the software creates the connectivity that you've defined by the pin to pin wiring placed in the design. The sequence is:

  • The pin-to-pin connectivity is created within each sheet.
  • The sheet-to-sheet connectivity is then created, based on the chosen Net Identifier Scope.
  • The enabled error checks are run.

The Unified Data Model

A fundamental element of the software is the Unified Data Model (UDM). When the project is compiled, a single, cohesive model is created, which sits central to the design process. Data within the model can then be accessed and manipulated using the various editors and services within the software. Rather than using a separate data store for each of the various design domains, the UDM is structured to accommodate all information from all aspects of the design, including the components and their connectivity.


Cross Probing

Cross probing is the name given to the ability to click (or double-click) on an object in one design interface and be presented with that object in another design interface. There are numerous places you can cross probe in Altium Designer.

For example, once you have launched the PCB editor's Tools » Cross Probe command, you can click on a component on the PCB to display the same component on the schematic. This command supports cross probing between components, buses, nets, and pins/pads. The default behavior is to remain in the source editor; use this when both the source and target documents are visible. Hold Ctrl as you click to jump to the target document.

Additionally, after compiling the schematic project, you can right-click then choose Cross Probe or double-click on an error message in the Messages panel to jump to that error condition on the schematic.


You can cross probe components, pins, nets, or buses.

There are a number of different ways you can cross probe within Altium Designer.

Learn more about Cross-Probing and Selecting


Cross Selection

Cross-selection is similar to cross probing; use it to select a component that you can currently see in another design interface. What cross selection offers is the ability to select multiple components. It works in both directions between the schematic and PCB and is an ideal tool for building a set of selected objects ready for a design action. For example, you might be looking at a number of components on the schematic and would like to locate them in the PCB editor workspace so you can position them on the board.

Once Cross Select Mode is enabled (Tools menu), each time you select a component in that editor, it is automatically selected in the other editor.


Use cross selection to quickly select PCB components directly from the schematic.

Learn more about Cross-Probing and Selecting


Applying Color to the Nets

As the design builds up it quickly becomes dense and detailed - the schematic busy with wiring and the board a maze of connection lines and routed nets. To help bring clarity and visibility, the designer can apply color to the schematic wiring, and also to the PCB connection lines and routing. 

This ability to selectively override the color of specific nets is known as Net Color Override. Color can be applied to schematic nets and those color settings transferred to the PCB, or color settings can be applied directly in the PCB editor.

Learn more about Applying Color to the Nets


Design Synchronization

The most common schematic-to-PCB design task is keeping the schematic and PCB matched or synchronized. Regardless of whether you are transferring a captured design to a new PCB for the first time or making changes to an existing design on either the schematic or PCB side, the same process is used.

The synchronization process detects and resolves the schematic and PCB differences.

Design synchronization is performed directly between the schematic and PCB editors; there is no intermediate, netlist-like document used. The software uses a comparator engine to compare all aspects of the design and a set of Engineering Change Orders (ECOs) is created to resolve any differences. When these are applied, the two sides of the design are back in sync.

Learn more about Design Synchronization


The Navigator Panel

If the design is large and spread over many sheets, it can become difficult to follow a net and verify the connectivity in the design by simply looking at the schematics. To help with this process, the Navigator panel is used. The panel gives a view of the entire, compiled design, so will be blank until the project is compiled (Project » Compile PCB Project). The Navigator panel can be opened by clicking the  button down the bottom right of the application.


Use the Navigator panel as your view into the entire, compiled design. Hold Alt as you click in the panel to locate that item on the PCB.

Learn more about the Navigator panel


Where to Next?

Like all of Altium Designer's design technologies, the Schematic and PCB editors are designed to be quick to learn and easy to work in. Context sensitive right-click menus are used extensively and context-sensitive help (F1) and in-command shortcut lists (Shift+F1) are available everywhere.

If you are new to Altium Designer's design software, you might want to start with the concept to completion tutorial. Based around a simple nine component circuit, you'll start with a blank schematic sheet and end up with the PCB along with the files needed to fabricate the board.

You also can learn more on the following pages:

Design Synchronization

The Navigator Panel

Cross-Probing and Selecting

Applying Color to the Nets

Pin and Part Swapping

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

You are reporting an issue with the following selected text
and/or image within the active document:
ALTIUM DESIGNER FREE TRIAL
Altium Designer Free Trial
Let’s get started. First off, are you or your organization already using Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

In that case, why do you need an evaluation license?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You actually don’t need an evaluation license for that.

Click the button below to download the latest Altium Designer installer.

Download Altium Designer Installer

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Please fill out the form below to get a quote for a new seat of Altium Designer.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

If you are on Altium Subscription, you don’t need an evaluation license.

If you are not an active Altium Subscription member, please fill out the form below to get your free trial.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Why are you looking to evaluate Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

You came to the right place! Please fill out the form below to get your free trial started.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Sounds exciting! Did you know we offer special discounted student licenses? For more information, click here.

In the meantime, feel free to request a free trial by filling out the form below.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

That’s great! Making things is awesome. We have the perfect program for you.

Upverter is a free community-driven platform designed specifically to meet the needs of makers like you.

Click here to give it a try!

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.