Altium Designer Documentation

Create Project (File Menu)

Modified by Rob Evans on Aug 26, 2019

Three variations of the Create Project dialog

Summary

The Create Project dialog is used to create a new project. Every design starts with a project file that stores project level settings, such as links to each of the design documents within that project. As well as creating the new project file on the hard drive, this dialog supports adding the new project to version control or creating it as a managed project.

The new project can be created:

  • As a Managed Project with a working copy in your preferred location. A Managed Project is one that is stored in a server.
  • In your version control system with a working copy in your preferred location.
  • In a folder on the hard drive.

Access

The dialog is accessed by choosing File » New » Project from the main menus.

Options/Controls

Locations

Select the target location of the project.

  • Server - choose to select a server as the target location. This will create a Managed Project.
    • Project Type - use to select the type and template of the project. All available templates are listed.
    • Project Name - a default name appears; enter a meaningful name for the project.
    • Description - enter a meaningful description of the project.
    • Repository - use the drop-down to display the connected repositories defined in the Data Management - Design Repositories page of the Preferences dialog. Click  to open the Preferences dialog from where you can connect to a repository.
    • Folder - enter a name for the folder of this project in the repository. Use  to open the Choose Item dialog in which you can can navigate to and select the desired folder within the repository.  
If you are not currently signed in to your server, you will be prompted to do so. In addition, if you have not defined a Design Repository for the environment, a default repository will be created for you with the name DefaultRepository.
  • Local Storage - use  to open a dialog in which you can browse to and select the desired local storage location.
  • Parameters - use this region to add custom Parameters to the project as the project is being created. Project Parameters for a managed project are read-only and can be accessed on the Server Parameters tab of the Project Options dialog (Project » Project Options).
    • Name - the name of the parameter.
    • Value - the parameter's value.
    • Add - click to add a parameter.
    •  - click to delete the selected parameter(s).
  • Version Control - choose to select a version-controlled repository as the target location. This will create a VCS project.
    • Project Name - a default name appears; enter a meaningful name for the project.
    • Repository - use the drop-down to display the connected repositories defined in the Data Management - Design Repositories page of the Preferences dialog. Click  to open the Preferences dialog from where you can connect to a repository.
    • Repository Folder - enter a name for the folder of this project in the repository. Use  to open the Choose Item dialog in which you can can navigate to and select the desired folder within the repository.  
    • Local Storage - use  to open a dialog in which you can browse to and select the desired local storage location.
    • Parameters - use this region to add custom Parameters to the project as the project is being created. Project Parameters for a version-controlled project can be accessed on the  Parameters tab of the Project Options dialog (Project » Project Options).
      • Name - the name of the parameter.
      • Value - the parameter's value.
      • Add - click to add a parameter.
      •  - click to delete the selected parameter(s).
  • Local Projects - choose to select a local folder as the target location. This will create a file project.

    • Project Name - a default name appears; enter a meaningful name for the project.
    • Folder - a default name appears; enter a meaningful name for the project. Use  to open a dialog in which you can browse to and select the desired local folder.
    • Parameters - use this region to add custom Parameters to the project as the project is being created. Project Parameters for a local project can be accessed on the Parameters tab of the Project Options dialog (Project » Project Options).
      • Name - the name of the parameter.
      • Value - the parameter's value.
      • Add - click to add a parameter.
      •  - click to delete the selected parameter(s).

Additional Controls

  • Create - click to create and save the project and associated files. The new project will be listed in the Projects panel.
When you click Create for a version-controlled or managed project, it will be added to the specified folder within the target repository then checked out to the local working folder defined in the Local Storage field. 
Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

You are reporting an issue with the following selected text
and/or image within the active document:
ALTIUM DESIGNER FREE TRIAL
Altium Designer Free Trial
Let’s get started. First off, are you or your organization already using Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

In that case, why do you need an evaluation license?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You actually don’t need an evaluation license for that.

Click the button below to download the latest Altium Designer installer.

Download Altium Designer Installer

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Please fill out the form below to get a quote for a new seat of Altium Designer.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

If you are on Altium Subscription, you don’t need an evaluation license.

If you are not an active Altium Subscription member, please fill out the form below to get your free trial.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Why are you looking to evaluate Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

You came to the right place! Please fill out the form below to get your free trial started.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Sounds exciting! Did you know we offer special discounted student licenses? For more information, click here.

In the meantime, feel free to request a free trial by filling out the form below.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

That’s great! Making things is awesome. We have the perfect program for you.

Upverter is a free community-driven platform designed specifically to meet the needs of makers like you.

Click here to give it a try!

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.