Altium Designer Documentation

Configuring PCB Printouts in Altium Designer

Created: October 1, 2021 | Updated: October 22, 2021

Parent page: Streamlining Generation of Manufacturing Data with Output Jobs

Print-based output for your PCB project in Altium Designer is available through creating an output job configuration file (*.OutJob). When you create a job output, there is a range of manufacturing documentation available for output including common two-dimensional PCB printouts, such as composite drawings and schematic drawings. 2D print output is configured in the Print dialog. 3D PCB printout (PCB 3D Prints) is configured in the PCB 3D Print Settings dialog.

To create an output job file, click File » New » Output Job File from the main menus. The new Output Job File will appear as a new file in the OutJob Editor window.

Output jobs are configured as an OutJob file, giving you full control over print-based output.
Output jobs are configured as an OutJob file, giving you full control over print-based output.

Configuring 2D Print-based Output

When you are ready to print documentation from your OutJob, access the Print dialog (right-click on the desired output then choose Configure). In the Print dialog that opens, you can define what is printed, view printouts, and edit their setup definitions.

The UI.Unification.PrintPreviewDialog option in the Advanced Settings dialog must be enabled to access the Print dialog.

The Print dialog when accessing it for a PCB 2D print output.
The Print dialog when accessing it for a PCB 2D print output.

The options and controls of the Print dialog are located on three tabs:

  • The General tab has options to configure page settings.
  • The Pages tab lists the currently defined printout pages, includes display options, options to manage layer settings, and allows you to add a new printout page.
  • The Advanced tab provides designator setting options as well as font and color options.

The preview region on the right-hand side of the dialog reflects changes in the settings. Refreshing (F5) is needed when settings change.

Configuring General Settings of the Printout

Basic settings of the printout are configured on the General tab of the Print dialog.

Basic settings of the printout are configured on the General tab of the Print dialog.
Basic settings of the printout are configured on the General tab of the Print dialog.

The settings on this tab include:

  • Printer and presets settings (note that when accessing the Print dialog from an OutJob file, the Printer field is not configurable as the printer settings are defined in the OutJob file itself).
  • Page settings, including the color set you want to use for the printed output (grayscale, monochrome, or color), page size and orientation.
  • Scale and position settings.
  • Area of the PCB document to print (entire sheet or a specific area that can be defined by typing in the coordinates of the area's opposite points or interactively in the PCB document).

Adding a New Page

A new printout page can be added to the current configuration by clicking the Add Page button under the listing of currently defined pages on the Pages tab of the dialog.

Adding a new page to the printout.
Adding a new page to the printout.

The page will be added beneath existing printouts and will be given a default name of New PrintOut. Use  buttons to move the selected page upward or downward in the list, which changes the page printing order.

Configuring a Page

A newly added printout page can be configured (and an existing page's configuration can be edited) through the associated Selected Page Settings region when the page is selected in the page list of the dialog's Pages tab.

Configure the selected page through the Selected Page Settings region of the dialog.
Configure the selected page through the Selected Page Settings region of the dialog.

The following options and controls are available when configuring the selected page:

  • The Page Name field allows you to change the name for the page as required to assign a more meaningful name that will readily identify the nature and purpose of the page.
  • The options below may be enabled to control which components are included in associated printouts (such as whether or not you choose to show surface-mountable components), as well as additional controls (such as showing mirror layers).
  • The Pad Display Options region provides options that allow you to control the display of pads on the printout, i.e. whether or not pad numbers and associated nets are shown.
  • The Pad Font Size option allows you to determine the size of the font used for pad numbers and net text.

Managing Page Layers

The 'heart' of page configuration is the layer management area of the Print dialog which provides the necessary controls to define the layer set of the page, order the layers that are to make up the page, and configure the settings of each layer. To access this area, select a page in the list on the dialog's Pages tab then click the Edit Layer button, or double-click the page directly in the list.

Configure layers of the selected page by accessing the appropriate area of the Print dialog.
Configure layers of the selected page by accessing the appropriate area of the Print dialog.

To return to the main Pages tab, select the Layer Name in the upper region (e.g. New PrintOut > Layers).

Click the Manage Page Layers button to access the area where you may view all layers and enable the layers intended to be printed using the checkbox or by using the Select All Layers and Select All Classes links. You may choose the layer you want to manage from the Print Layer Type drop-down in the Edit Layers area. Use the color swatch at the right of a layer entry to control the coloring that is used for that layer.

Manage the layer set of the page by accessing the appropriate area of the Print dialog.
Manage the layer set of the page by accessing the appropriate area of the Print dialog.

To return to the main Pages tab, select the Layer Name in the upper region (e.g. New PrintOut > Layers). To return to the Edit Layers region, select Layers in the upper region (e.g. New PrintOut > Layers > Manage).

In the Edit Layers region, use buttons to move the selected layer upward or downward in the list, which changes the print rendering order.

Configuring a Layer

A layer in the layer set of a printout page can be configured through the associated Selected Layer Settings region when the layer is selected in the layer list of the Edit Layers area.

Configure the selected layer through the Selected Layer Settings region of the dialog.
Configure the selected layer through the Selected Layer Settings region of the dialog.

The following options and controls are available when configuring the selected layer:

  • Print Layer Type – use this drop-down to choose/change the required layer. The drop-down presents all layers defined for the board.
  • Drill Layers – use this region when configuring a drill layer (Drill Drawing/Drill Guide).

    • First – use this drop-down to specify the starting layer for the required drill pair. The drop-down lists all available signal and internal plane layers defined in the board's layer stack.
    • Last – use this drop-down to specify the finishing layer for the required drill pair. The drop-down lists all available signal and internal plane layers defined in the board's layer stack.
  • Configure Drill Symbols – click this button to open the Drill Symbol dialog, where you may assign symbols/letters to each drill size.
  • Free Primitives – use the drop-downs to determine how the free primitives on a layer are displayed on the printout. For the following free primitive objects, use the associated drop-down field to choose whether to display the object fully (Full), in outline mode only (Draft), or hide the object (Hide).
  • Component Primitives – use the drop-downs to determine how the component primitives on a layer are displayed on the printout. For the following component primitive objects, use the associated drop-down field to choose whether to display the object fully (Full), in outline mode only (Draft), or hide the object (Hide).
  • Other – this region provides controls to determine how other objects on a layer are displayed on the printout. For the following objects, use the associated drop-down field to choose whether to display the object fully (Full), in outline mode only (Draft), or hide the object (Hide).

Consider, as an example, an assembly drawing that includes the following layers:

  • Component overlay
  • Top layer (for surface mount pads)
  • Multilayer (for through-hole pads)

The top layer would be configured to display the component primitives so the surface mount pads are visible and hide the free primitives so the routing is not visible. The multilayer would also be configured to display the component primitives so the through-hole component pads are visible and hide the free primitives so that the vias are not visible.

Configuring Advanced Settings of the Printout

Advanced settings of the printout are configured on the Advanced tab of the Print dialog.

Advanced settings of the printout are configured on the Advanced tab of the Print dialog.
Advanced settings of the printout are configured on the Advanced tab of the Print dialog.

The settings on this tab include:

  • Designator print settings – use the control in the Designator Print Settings region to specify the type of designator information to be included on the printouts. Choose from the drop-down to either Print Physical Designators or Print Logical Designators.
  • The Print Keepout Objects option gives you full control over whether keepout design objects are included on the printed document or not.
  • Font substitutions – each of the three standard fonts used in the PCB Editor (Default, Serif, and SansSerif) can be substituted for a different Windows font when the printout is generated. Use the options in the Replace Stroke fonts by TT fonts region to enable font substitution and substitution fonts.
  • Color settings – use controls in the Color Settings region to define global settings of coloring that will be used for the current printout. The options include using the net override color rather than the layer color (the Use Net override color option) and applying the colors configured for the PCB design in the PCB Editor (the Retrieve Layer Colors from PCB button). Controls for setting the current color configuration as the default one and resetting the current configuration to the default one are also provided.

Configuring 3D Print-based Output

The PCB 3D Print Settings dialog enables you to select or create 3D printouts of your PCB for inclusion in the job output file. Remember, you can have multiple instances of any printout (use the Add New Documentation Output control from the OutJob in the Output Containers region to do this), which is particularly useful for 3D since you can print out views of the board from differing perspectives if you wish.

The PCB 3D Print Settings dialog
The PCB 3D Print Settings dialog

The dialog is divided into four regions:

  • Render Resolution – includes options for the quality of the "picture" of the 3D model to be printed. The available resolutions are not printer-dependent.
  • View to Print – enables you to select from flat views of the board, that is, the camera perspective perpendicular to the board, either from above or from below, or a Custom view.
  • View Configuration – enables you to apply the current view configuration for surface colors, visibility, opacity, and board thickness.
  • Preview – shows you exactly what will be printed.

Creating Custom 3D Printouts

A custom view of your board can include it being rotated to an angle, zoomed, have various settings for surface colors, visibility, opacity, and board thickness. You can use these options to generate views that provide high levels of detail to highlight areas of your design or even create effects.

To create a custom 3D view of your board as a printout, perform the following steps:

  1. Go to the PCB Editor window and enter 3D mode (shortcut: 3).
  2. Use the 3D view controls to achieve the desired perspective.
  3. Return to the job output file and double-click anywhere on the PCB 3D Print row (or right-click on it and select Configure from the shortcut menu) to open the PCB 3D Print Settings dialog.
  4. Click the Custom option then press the Take Current Camera Position button. The Preview pane will update with the new perspective.
  5. Click OK to apply the custom setting to the current PCB 3D printout.

If you would like to apply custom surface colors, etc., perform the following steps:

  1. Go to the PCB Editor window and open the View Configuration panel (View » Panels » View Configuration from the main menus, or click the Panels button at the bottom right of the main editor and select View Configuration, or use the L shortcut.
  2. Set the options required. Note that you do not have to save the options to apply it to a PCB 3D printout.
  3. Return to the job output file, open the PCB 3D Print Settings dialog, enable the Custom option then press the Take Current View Configuration button. The Preview pane will update with the new view configuration settings. Once you apply the view configuration, it will apply to all of the View to Print options.
  4. Click OK to apply the view configuration to the current PCB 3D printout.
  5. Save the OutJob file to keep any new 3D printouts.

Tips

Print-based output can be generated in the following ways:

  • Using an appropriately configured output generator defined in an Output Job file (*.OutJob). The output will be generated upon running the configured output generator.
  • Directly from within the active PCB document using the File » Print menu command. The output will be generated for the currently enabled default print set.

    When generating output directly from the PCB Editor using the File » Print menu command, this facility is configured separately to configurations defined in an OutJob file. In this case, use the Default Prints tab of the Project Options dialog (Project » Project Options) to configure the default print configuration and page layout for each of the print-related outputs that can be generated.
    To access the Default Prints tab of the Project Options dialog, the Value field for the UI.ProjectOptions.DefaultPrints on the Advanced Settings dialog must be enabled.

    The Default Prints tab of the Project Options dialog
    The Default Prints tab of the Project Options dialog

Configuration options defined here are distinct and separate from those defined for the same output type in an Output Job file. In the case of the former, the settings are stored in the project file; for the latter, they are stored in the Output Job file.

Setup options accessed from the PCB Editor's File menu with respect to page and printer are also separate from those defined when accessed from within an Output Job file. Again, the former will be stored with the project file, the latter with the Output Job file.

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: