Altium Designer Documentation

Draftsman

Modified by Jason Howie on Apr 20, 2017
This documentation page references Altium Vault, which is no longer a supported product. Altium Vault and its component management features have migrated to Altium Concord Pro.

Draftsman is an alternate way to create the graphical documents for board design production. Based on a dedicated file format and set of drawing tools, the Draftsman drawing system provides an interactive approach to bringing together fabrication and assembly drawings with custom templates, annotations, dimensions, callouts, and notes.

The Draftsman PCB drawing capabilities are available through an Altium Designer Extension application, which is automatically installed with Altium Designer. The extension can be manually installed/removed or updated from Altium Designer's Extension & Updates page (DXP » Extensions and Updates). The Draftsman extension is located within the Installed tab and within the Updates tab when a software update is available.

Key Features

The Draftsman drawing application can act as an adjunct, or even an alternative, to the production of graphical-type PCB production documents using traditional outputs. It offers automated placement of assembly and fabrication drawings on demand, and includes a wide range of manual drawing tools that can be used to add important details and highlighting to its multi-page documents.

The tool's key features include:

  • Automated extraction of drawing data from the source PCB document.
  • Creation of multi-page documents.
  • The application of separate templates to each page of a document.
  • Automatic generation of drawings from customized templates.
  • Availability of common and additional drawing views (Assembly View, Fabrication View, Section View, or Drill Drawing View).
  • Assembly Views that include graphics generated from 3D Models (without the requirement for special PCB layers).
  • A customizable Layer Stack Legend with the option to add detailed layer information.
  • A BOM table that can show all board items or only those items for a selected Assembly View.
  • Placement of Callouts to indicate BOM item positions or items from a Notes list.
  • Support of assembly Variants.
  • User preference settings for drawing objects and functions (DXP » Preferences).
  • Print and Export to PDF outputs.
  • Inclusion in OutJobs, where a Draftsman PCB Drawing file can be added as a new Documentation Output.


Place drawing views, objects and automated annotations on single or multi-page Draftsman documents.

Working with Documents and Templates

The Altium Draftsman application creates and saves PCB drawing files (*.PCBDwf) and uses specific template formats for defining Sheet (page) properties (*.DwsDot) and Document content (*.DwfDot). The 'smart' document templates can be configured to automatically populate the document with nominated PCB drawing views and information text. When initially created, Document templates can use current Sheet templates to define the page properties (size, style, margins, etc.).

Create a New Document

A new Draftsman document is created in Altium Designer using the File » New » Draftsman Document command. The New Draftsman Document dialog opens.

The dialog allows for the selection of a predefined Document Template (three are provided with the installation) or a Default option that creates a blank A4 document – note that a Sheet Template can be applied once the new document has been created. The button opens the Draftsman - Templates page of the Preferences dialog, where the location of the templates directory is defined.

Create a blank or template-based Draftsman document from a specified project and PCB.

Along with the desired Draftsman template, a specific Project and board Source Document can be selected where multiple files are open in Altium Designer. The new document will be associated with, and therefore draw data from, the nominated project, which will become the active project. The newly created document will be added to the nominated project.

The dialog's Layers checkboxes determine which board layers (as defined by the Layer Stack) are used to generate Fabrication drawings in the document (at one per sheet), when a Fabrication document template is used.

Document Sheets

PCB Draftsman files are a multi-sheet format, which allows documents to contain individual pages (sheets) that are assigned to particular types of board project production information. Sheets can be added to and removed from the current document with the Tools » Add Sheet and Tools » Remove Sheet commands (the commands are also available on the right-click context menu).

The currently active sheet number and the total number of sheets in a document are shown in the Status bar at the bottom of the workspace.

Sheet Properties

The page properties of a Draftsman document can be defined from the Sheet Properties dialog dialog (Tools » Sheet Properties or choose Sheet Properties from the right click menu).

The settings in the Sheet Properties dialog determine the base structure (size, border, settings, etc.) of the current page or all pages in the document. Alternatively, the page format can be defined by loading a (custom) sheet template document.


Sheet stying properties can adopt standard or customized settings, or those from a sheet template.

Format and Size

Select the dialog's Format & Size tab to access manual or template-based settings for the document's page size/content. The options are:

  • Custom template – the page settings of a predefined sheet template are applied. The graphics defined in the template will be loaded into the page, along with template data including sheet sizes, settings, and zone and border margin definitions. The PCB Draftsman extension is supplied with a range of standard templates, while custom sheet templates can be created by saving an existing document in the *.DwsDot format.

    Use the button to directly open an alternative Sheet Template from another location.

  • Standard sheet size – selected a standard sheet size from the drop down list.
  • Custom size sheet – enter a custom sheet size.

Use the Apply to selection to change the sheet settings for the active page (Current Page) or all pages in the document (Entire Document).

Margins and Zones

Select the dialog's Margins & Zones tab to access settings for the page border and its graphical divisions. The options are:

  • Margins – use to define the distance from the edge of the page to each border line.
  • Zones – enter the number of horizontal and vertical reference divisions within the border.

Use the Apply to selection to change the sheet settings for the active page (Current Page), or all pages in the document (Entire Document).

Create Templates

An Altium Draftsman document can use templates to define its page properties (Sheet template), and for new documents, a range of predetermined content (Document template). Both types of templates can be created from the PCB drawing file (file extension PCBDwf) that is currently open in the editor by saving the document as one of the template types (DwsDot or DwfDot). A Template document may be reopened, edited and saved to modify its content and properties.

Sheet Template

Sheet (page) templates contain the graphics information for a page, including sheet sizes, parameters, and zones and border settings. Objects created with the editor's graphics tools (such as lines, rectangles, circles, and text) are also included – for example, a constructed Title block and content. A Sheet Template can be used to define the graphic format of a new or existing drawing document, and are also saved as part of a Document Template.

To save the current drawing document format as a Sheet Template, select the File » Save Copy As (or just Save As) command and choose Altium Draftsman Sheet Templates (*.DwsDot) from the save dialog's Save as type selection filter. Any elements that are incompatible with the Sheet Template format will be removed, such as placed drawings or additional pages. Before saving, an alert dialog will detail the pending action if incompatible elements exist.

As with other Altium Designer documents (Schematic, PCB, etc.), the Save As command will replace the existing source file in the project (in this case, a Draftsman drawing document) with the newly saved file (a Sheet Template document). The source document (*.PCBDwf) is not deleted from the project folder on disk.

A better approach is to use the Save Copy As option, which will save the new template to the nominated directory while leaving the source document (and project contents) intact.

Note that a saved Sheet Template can be applied to a Draftsman document page from its Sheet Properties dialog – select the dialog's button to locate and load a specific Sheet Template.

Document Template
Document Templates define a Draftsman document's content and (optionally) its style properties. The template supports multi-page documents, data for the main document attributes (tables and lists, drawing types, etc.), and elements created by the drawing Editor that do not depend on the PCB's design content.

To save the current drawing document format as a Document Template, select the File » Save Copy As (or just Save As) command and choose Altium Draftsman Document Templates (*.DwfDot) from the save dialog's Save as type selection filter. All of an existing drawing document's content and attributes, with the exception to those that relate to data extracted from the PCB design, will be saved as a Document Template. If the source drawing document has a specific page style (as might be applied by a Sheet Template) these graphical elements and attributes will be saved with the new Document Template.

Any elements that are incompatible with the Document Template format will be removed. Before saving, an alert dialog will detail the pending action if incompatible elements exist.

Only one type of board Fabrication View can be saved in a Document Template. This is because when the template is used to create a new Draftsman drawing document, the layer and content of each generated Fabrication drawing (at one per sheet) will depend on the specific PCB design.

A multi-page Draftsman document might typically contain assembly drawings, drill tables and drawings, layer stack and BOM tables, and fabrication drawings. When saved as a Document Template, the data from the current PCB is retained to define a drawing content 'shell'.

When subsequently used as a template for a new drawing document, the project's current PCB data is loaded into the shell in place of the template PCB data, therefore, recreating the document format and its type of content.

Edit a Template

Both Sheet and Document templates can be opened as free documents in Altium Designer and edited accordingly. Open a template by selecting File » Open and choose Altium Draftsman Sheet Templates (*.DwsDot) or Altium Draftsman Document Templates (*.DwfDot) from the browser filter options.

An open Document Template will include the PCB design data that applied when the template was created, and also the Sheet Template properties that were active when it was created. If a Sheet Template defined the page properties in that Document template, it will need to be reapplied if the Sheet Template has changed in the interim.

Document Options

The options settings for a PCB Draftsman document can be defined in the Draftsman Document Options dialog, which is accessed from the Tools » Document Options menu command. Note that the document options apply to the entire drawing document, however, the Sheet Properties settings apply to individual document sheets (pages). Both the Document Options and Sheet Properties are saved with the current Draftsman document.


The Draftsman Document properties apply to all pages of a drawing document.

The Draftsman Document Options dialog provides the following settings for the current Draftsman document:

  • General tab - General settings for:
    • Source – the PCB file source data to which the drawing is synchronized.
      • The PCB Document menu offers a choice of all boards that are available in the current project, where a new selection will redefine the link between the drawing document and PCB.
      • The Top/Bottom Assembly Layer menus allow the selection of any board Mechanical Layer as the source of component Geometry and RefDes positioning. This alternative component data applies when the AssemblyDrawing option is selected as a component’s Geometry Source or Location source in the Component Display Properties dialog.
    • Grids – the grid color and distance between grid divisions (Size), and how the divisions are grouped into fine and coarse lines (Multiplier).
    • Variants – how components that are not fitted in the currently selected board Variant are shown (hidden or as a definable mesh fill style). Select the board Variant option by choosing from the Variation menu (under View) in the Board Assembly View mode of the Draftsman Properties panel.
    • Zones – the positioning rules that apply to the alpha numeric indicators for the zone divisions in the document border.
    • Scale, etc – set the scale of newly placed document Views, the Font, and Sheet/border color properties for all sheets in the current document.
  • Parameters tab - view and add/remove Parameters. Smart Parameters can be used in the drawing document, such as in a title or table.
    • Add/Remove parameters – use the and buttons to create or delete Custom Parameters.
    • Parameter Filtering – check the System/Project/PCB Parameter options to filter the displayed list (Custom Parameters are always listed). Note that all except Custom Parameters are read-only, and marked with an asterisk suffix (*).
  • Snapping tab - the snap binding options, which can be globally switched off (Shift+E) or individually selected for:
    • Vertices – the corners of rectangles, ends of lines or sections, etc.
    • Line centers – the center point of lines.
    • Circle centers – the center point of defined circles.
    • Grid – the grid divisions, as defined by the Grids settings under the dialog's General tab.
    • Boundaries – the extended lines for edges or centers of objects.
    • Snapping Distance – defines a distance zone in which the snap binding operates.
  • Line Styles tab - define line thickness and dashing style for the available lines that can be placed on a document.
    • Dash Patterns – the line/spacing definitions for the dashed line options, in units of 0.02mm (when in metric mode). For example, a pattern Value of 20,10,20 defines a repeating 0.4mm, 0.2mm, and 0.4mm dash arrangement, with a cycle length of 1mm (50 units). A custom dashed line option can be created using the button.
    • Line Thickness – the weight or thickness of the available Line style options. Use the button to restore the default values.
  • Units tab - set the type of unit and numeric precision used for the document.
    • Measurement Unit – set the document measuring units to Imperial or Metric.
    • Precision – set the standard measurement precision accuracy and tolerance definitions (number of significant digits to the right of the decimal point, with the last digit rounded) for drawing documents. The tolerance display for a selected measurement can be enabled in the Draftsman Properties panel by choosing a Tolerance Type option in the panel's Tolerance section.

Working with Drawing Views

The Altium Draftsman application allows a range of automated production drawings to be placed directly onto a Draftsman drawing document. The type of drawing to be placed is selected from the editor's Drawing Views icon collection, or by selecting a drawing type from the main Place menu.

Draftsman Properties Panel

When placed in the document, drawings can be manipulated within the page and their properties edited from a dedicated Draftsman Properties panel. If not already open, the panel can be activated by double-clicking on a placed drawing view, by selecting the drawing view and choosing Properties from the right-click option menu, or by clicking on the button at the bottom of the work area.


The panel automatically changes its mode and content to match the selected drawing view or object.

The panel provides editing access to the detailed properties of objects that have been placed in the drawing document. Select an object or view to see its properties in the panel.

A number of the panel sections (groups of options) are common to most of its view modes, as instigated by selecting drawing object. These are:

  • Position – sets the object's rotational orientation to choices of 90º increments.
  • Scale – sets the visible size of the object to a choice of preset ratios (Scale menu), or to a specific figure relative to 1, where 0.9 would represent 90% (the Use Custom Scale option).
  • Title – sets a view's title name, its font/color and visibility settings. System or custom Parameters can be used in the title. The Use Document Font checkbox forces the placed view to adopt the font style defined in the global Draftsman Document Options dialog.

Assembly View

An Assembly view for the nominated project PCB is placed in a document with the Place » Board Assembly View command, or with the icon from the Drawing Views options.


A placed board Assembly View can be moved, scaled and viewed from different sides.

The view shows the board outline with cutouts, holes, and component graphics with additional notation. The component graphics are automatically generated and take data on a priority basis from several sources:

  1. The projection of a board component's three-dimensional model (3D model) – used by default.
  2. A component's silk screen graphic taken from Top/Bottom Overlay layer – used when a 3D model is not available.
  3. A graphic of the component's dimensions derived from its contact pads (its Bounding Box) – used when both a 3D models and screen overlay are not available.

A component's visibility, designator attributes and the geometry source (option 1, 2 or 3 above) used for forming its graphics can be changed in the Component Display Properties dialog, which is opened from the Draftsman Properties panel.

The automatic generation of the drawing view does not rely on the availability of an additional board layer (for example, Top/Bottom Assembly).

Assembly View Properties

The Board Assembly View mode in the Draftsman Properties panel offers the following settings (use the button to expand/collapse option groups):

  • Position – the Assembly view's orientation on the sheet.
  • Scale – drawing scale (zoom), set by preset ratio or a custom amount.
  • Title – the view's title name, its font/color and visibility settings.
  • Styles – set the color and line weight/style for the board and component outlines.
  • Font – the font settings for component designators, which also defines the minimum and maximum size for the automatic scaling to fit into component graphics. The font style for individual components can be overridden in the Component Display Properties dialog.
  • View – view settings, including;
    • View – direction of the view (top, below, from the side, etc).
    • Display holes – a filter for the display of holes, which can be set to show all holes (All), only construction holes (Pads Only), only large holes (Minimum diameter Only) or no holes (None).
    • Minimum Diameter – the size threshold setting for the Minimum Diameter hole visibility option (above).
    • Variation – where available, select a project PCB Variant to display – omitted variant components are not shown or indicated as a colored mesh, as determined by the related Document Options setting.
    • Component Caption – select the parameter source for the text captions associated with components (Designator or BOM Item reference).
    • Show SMD Pads – check to display surface mount component pads in the drawing. Use the associated drop down menu to select the rendering color.
    • Show Through-Hole Pads – check to display any Through Hole type pads that exist in the drawing. Use the associated drop down menu to select the rendering color.
    • Components button – opens the Component Display Properties dialog for setting component display options. Check Show Component Pads to render pad graphics on components.

Component Display Properties

How components are displayed in an Assembly view is configured in the Component Display Properties dialog, which is available from the button in the Board Assembly View of the Properties panel.

Using the Show menu, the Component Display Properties dialog can be selected to display the component properties in different formats, with grouping choices of components, classes, footprints, and by BOM entry (the Footprints grouping is shown selected in the image below). The dialog allows control of the visibility and graphics for individual components and includes the following options:

  • Visible – toggle the visibility of a component's graphics.
  • Geometry Source – the data source used for rendering the component's graphics:
    • Default – the component graphics will be taken, in order of priority, from the three options below (3D model, Silk Screen Overlay or Bounding Box).
    • Body projection – the component's 3D model, if available.
    • Silk screen – the Silk Screen printing layer.
    • Bounding box – dimensions derived from the component's contact pads.
    • AssemblyDrawing – the component graphic data contained on a Mechanical Layer, as nominated in the Document Options dialog.
  • Color – the color of the component graphics.
  • Reference marker display – enable/disable a component's visual reference marker (typically a dot indicating Pin 1 on a component).
  • Show Designator – toggle the visibility of a component's Designator notation.
  • Location – the position settings for a component designator.
    • CenterFit (default) – the designator is placed in the center of the component graphic and automatically scaled to fit.
    • Center, TopLeft, Left, Right, etc – the designator is placed close to the component outline, in the position described.
    • AssemblyDrawing – the designator, its position and size is defined by the properties of the component designator (generally derived from a .Designator special string) on a specified Mechanical Layer.
  • Font – the selected font for a component designator (not available for the Center/Fit option, which scales the font size). Note that when the Designator is derived from a board mechanical layer (the Assembly View Location option), the font style is determined by the Font option but the font size will reflect that defined by the designator on the board mechanical layer.
  • Hatching Pattern – the visual pattern and color used to render the component's profile, such as when it is displayed in a board Section View.


Configure the component graphics and annotations for the most suitable display of an Assembly view.

To ease the task of locating and changing options for multiple entries, the Component Display Properties dialog also provides smart filtering capabilities, which can be activated from the icon in each column header. Select the desired entry in the filter drop down list to constrain (filter) the dialog contents to components that match the selected attribute. Multiple filter options can be applied and then disabled or cleared using the filter entry checkboxes in the dialog's lower border.


Automated data filtering uses a specific text query to group component entries, or a full query approach for custom filtering (as shown below).

To create a more advanced or compound filter constraint, select the Custom option from the filter drop down list.

Fabrication View

A Fabrication view for the nominated project PCB is placed in a document with the Place » Board Fabrication View command, or with the icon from the Drawing Views options.


Draftsman Fabrication views can be displayed from either side (or flipped) and be rendered with solid or outlined copper fills.

Fabrication View Properties

With the placed fabrication graphic selected in the editor, the Board Fabrication View mode in the Properties panel offers the following settings:

  • Position – the Fabrication view's position and orientation on the sheet.
  • Scale – drawing scale (zoom).
  • Title – the view's title name, its font, and visibility settings. Note that system or custom parameters may be used in text properties fields, such as the Layer Name and Scale parameters (used for the Title shown in the image below).
  • View – view settings, including:
    • Layer – the board layer displayed in this view.
    • View – direction of the view (top or below).
    • Drawing Mode – how board conductors are displayed - solid and fully rendered (Full) or as lines (Simplified).
    • Polygon Fill Mode – how polygons are displayed - solid (Filled), hatching fill (Hatched), or by outline (Outline).
    • Board Line Style – the type, color, and weight options for the line that defines the board perimeter.

Drill Drawing View

The Drill Drawing view for the selected PCB is placed in a drawing document with the Place » Drill Drawing View command or with the icon from the Drawing Views options.


A placed Drill Drawing can be displayed from either show holes for specific drill pairs (if available) and rendered with defined hole group symbols.

Drill Drawing View Properties

With a placed Drill Drawing graphic selected in the editor, the Drill Drawing View mode in the Properties panel offers the standard drawing view settings, such as Position, Title and View. The panel mode's additional properties settings are:

  • Layer Pairs (under View) – select from the list of Drill Layer Pairs for the PCB (where available) for display in the drawing view.
  • Configurations (under Drill Symbols) – set the drill symbol graphic and its size for each hole style group using the Drill Symbol Configurations dialog.

Drill Symbol Configurations

The Drill Symbol Configurations dialog presents a tabular view of PCB hole data, with hole styles grouped on a selectable parameter (column data) basis and assigned standard symbols. The dialog is activated by the button in the Properties panel, when in Drill Drawing View mode (as above).


Set hole symbol graphics for specified groups of hole types based on their attributes.

The dialog's hole data table provides a flexible approach to assigning holes styles to Drill Drawing symbols, along with setting the symbol display graphics and sizes. By using the selectable hole parameters offered by the Grouping drop-down menu, the chosen criteria will group hole types under one symbol.

For example, in the above image the criteria is configured to group holes by Size, Plated status, and Tolerance, so all holes that have these parameter values in common are collected under the one drill symbol. By contrast, if the grouping criteria was set to 'Drill Layer Pair', all holes would be grouped under one symbol – since for this PCB, the parameter value applies to all holes (only one Drill Layer Pair is used in the PCB design).

The displayed Drill Symbol for a hole group, in both the Drill Drawing View and a placed Drill Table, is selected from the Symbol Graphics menu in the Drill Symbol Configurations dialog. The supported symbols include a range of graphic shapes and letter characters.

Detail View

The Draftsman document Detail View feature allows a defined area of a drawing to be brought out to a floating, magnified view of its detail. The magnification factor (scale), labeling and line attributes of the detailed view can be configured in the Board Detail View mode of the Properties panel.

To place a Detailed View, select the Place » Board Detail View command or click the icon from the Drawing Views tools options. The placement procedure is as follows:

  • Click a point on the drawing to specify the center of the target Detail View area.
  • Move the mouse and click to specify the radius of the view area (the Detail View source).
  • Click again to determine the position of the Detail View expansion.
  • Use the View and Style options in the Properties panel (in Board Detail View mode) to set how the Detailed View relates to the source area.

Detail Views may be added all graphical board views, including the Assembly View, Fabrication View, Section View, and Drill Drawing View.

Section View

A Section View provides a profile slice, or sectional, drawing taken from a nominated 'cut' point through a placed PCB Assembly View. The section view generator takes the available 3D data from the current PCB to create a standalone section drawing that is aligned to the nominated cut point. Any number of Section Views can be created from an Assembly View, and the section parameters may be modified after they are placed.

To begin the process of creating a Section View, use the Place » Board Sectional View command, or select the icon on the Drawing Views toolbar. The steps to create Section B-B shown in the following image would be:

  1. Position the cursor on the Assembly View, where a vertical cut line (initially A-A) will follow the cursor movement – use the Spacebar to toggle between vertical and horizontal cut lines.
  2. Click to set the position of the cut line.
  3. Move the cursor on either side of the line to set the view direction (as indicated by the cut line arrows) and click to confirm.
  4. Drag and place the new Section View in the desired location.

After a Section View has been placed, it can be dragged to a new location, or its associated cut line moved to a different position on the Assembly View. To do the latter, select the Section View and then drag its cut line to a new position on the Assembly View – the Section View graphics will update accordingly.

The Board Section View mode in the Properties panel provides additional options for a selected Section View, such as its scale, label, style, and orientation.

  • Use the Position and Scale options to define the size and rotation (in 90º increments) of an existing section view.
  • Use the View options to manipulate the cut and section display, where:
    • The Positional Mode changes the cut orientation between horizontal and vertical, and the Flip View Direction option changes the directional view of the selected section cut (the direction from where you are 'looking'). The cut line direction arrows will change accordingly.
    • The Slice Section option disables the visibility of the objects behind the cut line – it removes the 'background' objects from the section view.
    • The Board Cut Fill Style option sets the properties of the graphical pattern superimposed on cut objects, and therefore the appearance of the sliced object faces.
    • The Display Mode options sets the cut line end arrow style, while the Show Connector Line toggles the line drawn between the cut arrows.
  • Use the Styles options to determine the visual style of the cut line placed on the Assembly View, where:
    • The Cutting Line Style options define the line's weight, style and color, while the Connector Line Style sets the properties of the line drawn between the cut arrows.
    • The Arrow Style options set the shape and weight of the cut arrow heads.

Layer Stack Legend

A Draftsman document's Layer Stack Legend view provides a representation of the board's internal structure as an enlarged sectional view. It includes detailed descriptions and information for each layer in the stack, including the Gerber files associated with each layer.

By default, the information for each layer is derived from the corresponding attributes in the Board Layer Stack, as defined in the Layer Stack Manager dialog (Design » Layer Stack Manager in the board editor), however the layer description attributes may be edited and expanded through the Layer Stack Legend mode of the Properties panel.

To place a Layer Stack Legend view in a drawing document, use the Place » Layer Stack Legend command or select the Icon from the Drawing Views toolbar.


A placed Layer Stack Legend derives data from the Layer Stack for the nominated PCB, and can be displayed with relative layer thickness and drill pairs.

Layer Stack Legend Properties

To configure how data is displayed in a Layer Stack view, access the Properties panel's Layer Stack Legend mode by double clicking on the placed view or selecting Properties from its right click options. The panel mode provides a comprehensive range of grouped attribute settings that allow for detailed fine tuning of a placed Layer Stack Legend view. Use the button to expand/collapse panel option groups.

The more important settings in this panel mode are:

  • View Width and Layer Heights (under View Styles) – determine the dimensions of the Layer Stack graphic, where the Heights options offer a standard uni-dimensional view, a view where layer depth (height) is proportional to the real layer thickness, and a fixed layer height that is aligned to the table row contents.
  • Show Drill Pairs (under View Styles) – enables a graphic representation of drill holes between the board's assigned Drill Layer Pairs (as defined by the PCB design's Layer Stack).
  • Scale (under View Styles) – sets the scale of the stack layers relative to their actual thickness (the Layer Heights option must be in 'Real Width' mode). The min/max Layer Height setting determines the dimensional range of the layer height scaling.
  • Source (under Data) – the source of the data included in the view, which can be a choice of several stacks when dealing with board designs with different structural regions, such rigid-flex PCBs.
  • Configurations (under Settings) – the button opens the Layer Information dialog, which allows the layer table's data and information to be edited.
  • Most other options in the panel's group sections are self-evident, and can be explored by changing values and toggling options.

Layer Stack Legend Information

The Layer Information dialog allows a large degree of control over the layer information displayed in the Layer Stack Legend view table. To open the dialog click the button under Settings in the Properties panel's Layer Stack Legend mode.

The Layer Information dialog allows the following editing options:

  • Toggle the visibility of the outer layers (Paste and Solder Masks and Silkscreen overlays).
  • Define the display color for each layer.
  • Hide, move and rename columns in the table. Columns can also be added and removed, or new custom columns created.
  • Edit the content of individual table cells. The cells are initially populated from the board Layer Stack data, however, once a cell has been manually edited it will not be updated from the board data (Tools » Update Board).
  • Define the Total information data, data shown in the table footer. This displays the total board thickness by default, but can be renamed or set to a custom value – note that the footer visibility can be toggled with the Show Footer option under Table Styles in the Properties panel.

Note that the Layer Stack display and information options define the structure and content of the Layer Stack Legend view that has been placed on a drawing document and do not affect the Board Layer Stack configuration that is defined in the PCB Editor.

Annotation and Drawing Tools

Altium Draftsman provides a range of additional drawing and annotation tools designed to add important information to a Draftsman drawing document. These include both automated note and highlighting systems plus free-form drawing capabilities. The dimension tools apply to a placed Assembly Drawing view and are available under the main Place menu or from their respective icons on the Drawing Annotations toolbar.

Dimensions

Object dimension graphics may be placed on an Assembly Drawing view to indicate the lengths, sizes, and angles of the object outlines, or the distance between nominated objects – dimensions may also be added to a Section View of an Assembly Drawing. To place a dimension graphic, select the desired type from the Place menu or from the Dimension drop down menu () on the toolbar.

Linear Dimension

A linear dimension can be added to the object's outline edge or between two object points. To place the dimension:

  1. Select the Linear Dimension tool:
  2. To dimension an object edge, hover the cursor over the location until the desired edge is highlighted, and click to select. Position the dimension graphic, then click to lock it in place.
  3. To dimension between two points, hover the cursor over the first location until the point is highlighted (dot) and click to select. Repeat for the second point then position the dimension graphic and click to lock it in place.

A dimension graphic can be moved after it has been placed, but only within its angular plane (horizontal, vertical, etc.). Most aspects of a placed dimension are available for editing in the dimension mode of the Properties panel – select a placed dimension to enable its associated panel mode.

Notable options that are available in the panel's Dimension mode are:

  • Value – shows the measured dimension in the base document units (Value), but can be replaced with an alternative value using the Override Value With option.
  • Units – set the Units type for this object instance (see the Measurement units note below for more information).
  • Tolerance – change the dimension text to display nominated +/- tolerance values.
  • View – change the dimension text and arrow positions relative to the dimension indicator line.
  • Appearance – change the arrow graphic style and line width size, style and color.
  • Text prefix/suffix – add prefix and/or suffix text to the dimension text. For example ~ and nom, respectively, would create ~10.5nom where the dimension value is 10.5. Text will show the unit name suffix, eg; mm, when that option is enable in the panel's Units section.

Measurement units:

Note that the units system (Metric or Imperial) that applies to a Drafstman document is defined by the Measurement Unit setting in the Draftsman Document Options dialog dialog (Tools » Document Options). However, for individual objects such as Linear/Radial Dimensions, Drill/BOM Tables and the Layer Stack Legend, their default units may be preset to Imperial or Metric in the Draftsman – Primitive Defaults page of the Preferences dialog (DXP » Preferences). These settings will override the document's base Units setting when a new object of that type is placed.

In turn, the Units used by the placed object can be locally changed through the Units option in the Draftsman Properties panel.

Radial Dimension

A radial dimension can be added to a circular hole object on an Assembly Drawing. To place the dimension:

  1. Select the Radial Dimension tool:
  2. Hover the cursor over the location to highlight the desired hole, then click to select.
  3. Position the dimension graphic, then click to lock it in place.

The Radial dimension measurement graphic can be moved (select and drag) or edited in a similar way to the Linear Dimension graphic. Again, most aspects of the placed dimension are available for editing in the Radial Dimension mode of the Properties panel – select a placed radial dimension to enable its associated panel mode.

Note that Altium Designer will automatically detect (and convert if necessary) a dimension that has been manually entered with a specific Units suffix – mm or mil in this application. When a dimension is entered without a suitable suffix, the figure is assumed to be in the Units that are configured for the document or object.

Angular Dimension

An angular dimension can be added between two object edges on an Assembly Drawing. To place the dimension:

  1. Select the Angular Dimension tool:
  2. Hover the cursor over the first edge location until the line is highlighted then click to select. Repeat for the second line.
  3. Position the dimension graphic and click to lock it in place. Note that the graphic can be aligned inside or outside the intersection of the two edge lines.

The Angular dimension measurement graphic can be moved (select and drag) or edited in a similar way to the Linear Dimension graphic. Most aspects of the placed dimension are available for editing in the Angular Dimension mode of the Properties panel – select a placed angular dimension to enable its associated panel mode.

Callouts

Draftsman document Callouts can be placed on drawing views to provide further information on components and general objects, or on Assembly Drawing views, synchronized indicators for BOM entries and Note items. As such, the source text for a Callout can be a custom entry, a link to a specified Note entry, or an automated reference to a BOM item.

To place a Callout:

  1. Select the Callout tool:
  2. To place a Callout with custom text, select a point where a drawing element is not highlighted, click to place the Callout pointer and then position and place the Callout end. Edit the Callout text in the Properties panel. An existing Callout may be changed to the Custom Text type by selecting that option from the Source Type list in the panel's Source group.
  3. To place an automated BOM component link, select a highlighted outline edge of a component, then position the Callout end and click to place. If a BOM has been placed on the drawing, the Callout link will show the corresponding BOM entry number for that component.
  4. To create a reference to a Note entry, place a Callout at the desired point and then select Note Item as the Source Type in the Properties dialog's Source group. Select a note number from the Note Item drop down list – a Note list entry must already exist on the drawing.

Smart Callout text can be placed and configured to read the matching BOM entry for a component, refer to an existing Note Item entry, or just display custom text.

When placing a Callout, its type is automatically selected based on the selected source object, as follows:

  • Selecting a open (un-highlighted) area will instigate a Custom Text callout (see Step 2, above).
  • Selecting component outline will create a BOM Item callout (see Step 3, above).

To create a Note Item reference, or to change an existing Callout to another type, select the appropriate Source Type in the Source section of the Properties panel's Callout mode.

Notes

Draftsman document Note Item lists can be placed as free text entries in any location. The entries can be referenced by Callouts (see above) and both configured and edited in the Properties panel's Note mode.

To place a Note Item, select the Insert Note tool and then click to place the default Note entries in the drawing space. Select an entry in the list to edit its text content and number icon style in the Properties panel. Use the Add/Delete buttons to include and remove list entries, and configure the order of the text entries using the Up/Down buttons.


Select a single entry in a Note Item list to edit its content in the Properties dialog.

By way of example, to add a new Note entry that uses one of the preset document parameters:

  1. Select the Note Item on the document, then select the button in the Properties panel.
  2. Include suitable text, and then select the button to open the Document Parameters dialog.
  3. Select an existing (system) parameter or a custom parameter from the list. Note that custom parameters can be added under the Parameters tab of the Draftsman Document Options dialog (Tools » Document Options).
  4. Confirm the dialog action (OK) to add the parameter reference to the new Note entry (note 4, below).

BOM and Drill Tables

A PCB Draftsman document allows both Bill Of Materials (BOM) and Drill symbol/data tables to be placed on the drawing and subsequently configured in the Properties panel. The tabular data is directly derived from the project PCB files and provides a simple, visual way to convey crucial information for the PCB fabrication and assembly processes.

The BOM/Drill placement options are available under the main Place menu or from their respective icons on the Drawing Annotations toolbar.

BOM Table

To place a BOM table, select the BOM table placement tool and click to position the table on the drawing document.

Select the placed table to enable the Bill of Materials mode of the Properties dialog, which provides configuration options for most aspects of the BOM table, including its visual attributes and data content. The Data Filtering options allow the BOM content to reflect a selected board design Variant (Variations), and/or filter the content to that of any Assembly View that has been placed on the document (the default is 'All' content).

Note that the properties of a newly placed BOM table, including its included columns, is defined by the Draftsman's preferences (DXP » Preferences – Draftsman)

Use the panel's Columns section to manage the table's data columns, however, the grouping and content of the columns will depend on how the BOM itself is configured, as outlined below.


Manipulate the columns of a placed BOM Table in the Columns section of the Properties panel.

Setup the BOM table's available content and data grouping in the Bill Of Materials Configurations dialog, which is opened from the button in the Properties panel under the Configurations section. The dialog provides the following BOM configuration options:

  • Data Source – defines which PCB project data files are used to derive the BOM item list – by default, this the current Board design. The alternative Project option will extract BOM data from all design files in the nominated PCB project.
  • Grouping Key – defines which component attribute is used to group BOM items together (in a single row). This is typically set to Comment (and perhaps also Footprint) so that components of the same type are together.

Select the Project option from the Data Source menu to enable all project data, including custom component Parameters from the project schematic document(s).

The Properties panel's Columns section allows the column order to be rearranged using the Up/Down buttons, columns to be removed (visually disabled) or new columns added. Use the button to include a new data column in the table – the next available data column is added with each click of the Add button. Use the button to reset the list of data Columns.

Drill Table

To place a Drill table, select the Drill Table placement tool and click to position the table on the drawing document.

Select the placed table to enable the Drill Table mode of the Properties dialog, which provides configuration options for most aspects of the Drill Table, including its visual attributes and data content (through Data Filtering and Column selection). Note that the panel's Units section allows for dimension entries (such as those in the Hole Size column) to be set to one or both of the available units (mm or mils), which also have individual Precision settings.

Use the panel's Columns section to manage the table data sort order, and column visibility and position order. The sort order buttons () toggle between off, ascending, and descending modes, and sorting can be applied to multiple columns.


Set the visibility, order and sorting for Drill Table column data. Drill hole symbols are defined as described for a placed Drill Drawing View (Configuration button).

The Drill Table's symbol styles, and the grouping of drill hole types under those symbols, is determined by the settings in the Drill Symbol Configurations dialog opened from the panel's button (under Drill Symbols). This is the same dialog that is activated from the panel when in Drill Drawing View mode, but in this case, only those columns activated (made visible) for the Drill Table will be shown – note that the two Drill Symbol Configuration dialogs versions are from the same source and therefore interact.

Graphical Tools

Draftsman provides a range of graphical element tools that can be used to place basic, free-form drawing elements in a document. The tools are accessed from the main Place menu or from the Graphical Tools drop down menu () on the Drawing Annotations toolbar.

Place a graphic element by clicking to position its first node and then again to place its second node, therefore determining its size – that is, the length for a line, the radius for a circle, the distance between opposite vertices for a rectangle or text box, or the dimensions of a placed image graphic. The nodes will snap to the nodes or guidelines of other objects, and optionally, the document snap grid if enabled.

Placed graphical elements can be moved by selecting and dragging, or when multiple elements are selected (Ctrl-shift + click, or by lassoing). Individual nodes can also be selected and moved. For more options, select a placed graphical element to enable its associated mode in the Draftsman Properties panel – note that the Text Box content is defined in the panel, and this can include document parameters.

DXF Import

Draftsman provides further graphical options through the import of standard DXF files, which are loaded into the drawing space from the File » Import from DXF menu command. Use the Windows file browser to select a *.DXF or *.DWG file then configure the import options from the DXF Import Settings dialog that opens:

  • Units – select metric or imperial units to best match the source file.
  • Default Line Width – select a default line weight for all objects within the imported graphic file, where 0.2mm corresponds to Draftsman's 'normal' line weight setting.
  • Default Font Family – select a default font that will be used to represent any text in the source file.

Note that the DXF source graphic is interpreted using Draftsman’s standard graphical shape objects – lines, circles, rectangles, text – and each individual object is therefore editable in the Draftsman Properties panel.

Documentation Outputs

Draftsman documents may be printed or generated as output files in the same manner as Altium Designer's other graphics-based documents (Schematic, PCB, etc.). New Draftsman documents (once saved) are automatically added to the associated PCB project, and are therefore available to all normal document generation and printing processes.

Print or Export to PDF

To print the currently active drawing document, select File » Print from the main menu (or Ctrl+P) and select the print options in the normal way. For Draftsman documents, the print dialog includes a scalable print preview with page navigation selectors.

To export a drawing document to a single or multi=page PDF file (as determined by the document structure), select File » Export to PDF from the main menu.

Add to OutJob

A Draftsman drawing document is added to an OutJob by first opening an existing Output Job file or creating a new Output document (File » New » Output Job File).

To add a Draftsman document to the output job, select the Add New Documentation option under the Documentation Outputs section then select PCB Drawing. Assign the newly added output file (*.PCBDwF) to a PDF output by selecting that container option and then checking the enable option associated with the Drawing document.

Installation and Preferences

The Altium Draftsman PCB drawing capability is enabled in Altium Designer through the Draftsman software extension, which is automatically installed with Altium Designer – as is the case with other software extensions such as the Vault Explorer.

To manually install the extension, select the Purchased tab in the Extension Manager (DXP » Extensions and Updates) and locate the Draftsman extension. Click its download icon to download and install the extension then restart Altium Designer to enable the software's full functionality.


Once installed, the Draftsman icon will also appear in the Updates tab (under Extensions & Updates) when a new version is available for download.

Once installed and ready to use, the extension will appear under the Extension Manager’s Installed tab. The Draftsman drawing features, including the ability to create a new Draftsman document file, become available when a Schematic or PCB project document is open.

If you would prefer that the Draftsman extension is not automatically installed with Altium Designer updates, deselect the Draftsman extension option in the Extension Manager's Configure Platform page – DXP » Extension and Updates, Installed tab, Configure link. Click to confirm the change. Note that the configuration change will also uninstall the Draftsman extension.

Preferences

The extension's preferences are available in the Draftsman section of Altium Designer's Preferences dialog (DXP » Preferences).

The Draftsman - Primitives Defaults page of the Preferences dialog allows the default values and settings to be configured for drawing and objects placed in a Draftsman document. These default settings can be overridden in the Draftsman Properties panel once an object or view has been placed in a document.


The Draftsman preference settings define the default configuration for Views and objects placed on a PCB document – these are overruled by changes made in the Draftsman Properties panel.

The Draftsman - Templates page of the Preferences dialog is used to define the location of Draftsman Sheet and Document templates.

The Draftsman - Templates Preferences page is used to define the location of the Draftsman templates.

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

You are reporting an issue with the following selected text
and/or image within the active document:
ALTIUM DESIGNER FREE TRIAL
Altium Designer Free Trial
Let’s get started. First off, are you or your organization already using Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

In that case, why do you need an evaluation license?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You actually don’t need an evaluation license for that.

Click the button below to download the latest Altium Designer installer.

Download Altium Designer Installer

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Please fill out the form below to get a quote for a new seat of Altium Designer.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

If you are on Altium Subscription, you don’t need an evaluation license.

If you are not an active Altium Subscription member, please fill out the form below to get your free trial.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Why are you looking to evaluate Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

You came to the right place! Please fill out the form below to get your free trial started.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

That’s great! Making things is awesome. We have the perfect program for you.

Upverter is a free community-driven platform designed specifically to meet the needs of makers like you.

Click here to give it a try!

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.