Altium Designer Documentation

Generating Gerber X2 Fabrication Data from a PCB in Altium Designer

Created: July 11, 2017 | Updated: July 11, 2017
All Contents

Parent page: More about Outputs

As part of Altium Designer’s ability to export a wide range of PCB design fabrication and assembly file formats, the Gerber X2 format is available for both individual and output job file generation.

Gerber X2 is a direct, and much advanced, evolution of the existing Gerber RS-274X standard and adds a large range of additional data for PCB fabrication and assembly. Compared to the RS-274X standard, the new Gerber X2 format includes critical information such as:

  • Layer stack definitions
  • Pad and via attributes
  • Impedance controlled tracks
  • and more…

A prime advantage of the Gerber X2 format is backward compatibility with the old Gerber RS-274X standard. Being a multi-file standard, a target fab/assembly house that has not moved to the new standard can extract the traditional Gerber file elements as needed. This may be a significant advantage for those unwilling to tackle a major shift in fabrication file formats, or for fabrication houses with inflexible equipment and software.

The overall benefit of adopting the Gerber X2 format for transferring board design data to fabrication and assembly houses is the rich set of manufacturing data included in the file set, and the backward compatibility to the previous standard for a low risk upgrade path. With a full implementation at both ends of the CAD-CAM chain, the risks associated with data misinterpretation, file errors and variable data interpretation can be largely eliminated. In short, both the Gerber X2 and IPC-2581 formats represent a new generation of board design to manufacture data transfer.

Useful links:

Gerber X2 Direct Output

With a project PCB file loaded as the active document, the Gerber X2 file set can be generated by selecting File » Fabrication Outputs » Gerber X2 Files from the main menu. This opens an initial Gerber X2 Setup dialog to define the plot layers, drill options and general configuration applied during the export process.

The Gerber X2 output setup is similar to that of the standard Gerber output.The Gerber X2 output setup is similar to that of the standard Gerber output.

Output is generated to the location defined in the Output Path field, on the Options tab of the Project Options dialog. Generated file names will include the name of the PCB document.

Generated files will be added to the project, and appear in the Projects panel under the Generated\CAMtastic! Documents and Generated\Text Documents folders.

The generated Gerber output is also opened as a composite CAM document that can be edited and/or saved into the current project, and managed via the CAMtastic panel.

To specify if the generated CAM output is automatically opened in Altium Designer, enable the Open outputs after compile option in the Options tab of the Options For Project dialog (Project » Project Options).

Gerber X2 Output through an Output Job File

Related page: Preparing Multiple Outputs in an OutputJob

To include Gerber X2 file output in a project's Output Job Configuration file, click on [Add New Fabrication Output] under the Fabrication Outputs section, and select Gerber X2 Files from the menu, and the desired data source from the associated sub-menu.

Configure a Gerber X2 Files output as part of an Output Job file's Fabrication Outputs. Configure a Gerber X2 Files output as part of an Output Job file's Fabrication Outputs.

As with other Fabrication outputs, when the OutJob is run - either manually, or part of the project release system - the Gerber X2 file set will be generated in accordance with settings defined for the applicable Output Container.

Prepping a Gerber X2 output as part of a configured OutJob.Prepping a Gerber X2 output as part of a configured OutJob.

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: