Altium Designer Documentation

Working with an OLE Object on a PCB in Altium Designer

Created: November 6, 2015 | Updated: October 31, 2018
All Contents

Parent Page: PCB Objects

A placed sequence of OLE objects – image, spreadsheet cells and word document text (top to bottom).
A placed sequence of OLE objects – image, spreadsheet cells and word document text (top to bottom).

Summary

Object Linking and Embedding (OLE) technology in the PCB Editor  allows data supplied by Windows OLE applications to be embedded in a PCB design while actively linked back to the source application. In many cases, this allows the embedded PCB data to be edited from within the application that created it.

Typical OLE objects that might be placed in a PCB document include common Excel documents, Word documents or graphics objects from a suitable OLE image application. The supported file types include universal formats such as CSV and XLS format spreadsheets, DOC and RTF word documents, and BMP image files.

Availability and Placement

Use the Place » Object From File command to navigate to and place/embed an OLE object into a PCB from the Choose File dialog.Altium Designer’s Smart Paste capability also allows a selection in an OLE application to be copied and pasted (Edit » Paste) into the PCB document as an OLE object. The text paste option (Edit » Paste Text) can be used to strip the text elements from an OLE object if required. These will be placed as Altium Designer PCB text objects.

Graphical Editing

Once placed, embedded objects can be proportionally scaled by dragging on their selection handles. With text-based objects such as Word and Excel documents, the embedded text is automatically scaled in size and thickness to suit the new dimensions.

Non-Graphical Editing

Editing via an Associated Properties Dialog

Dialog page: OLE Object

The placed object’s angle and layer can be set from the object’s properties dialog, where its Rotation is defined in degrees (CCW) and its layer selected from the drop down Layers menu.

The OLE Object properties dialog. Note the Edit data button.
The OLE Object properties dialog. Note the Edit data button.

The OLE Object dialog can be accessed during placement by pressing the Tab key.

After placement, the dialog can be accessed in one of the following ways:

  • Double-clicking on the placed region object.
  • Placing the cursor over the region object, right-clicking and choosing Properties from the context menu.

Quickly change the units of measurement currently used in the dialog between metric (mm) and imperial (mil) using the Ctrl+Q shortcut. This affects the dialog only and does not change the actual measurement unit employed for the board, as determined by the Measurement Unit setting in the Board Options dialog (Design » Board Options).

Use the Edit data button to open the object for editing in its matching OLE application. When the file is saved in the application, the results will be reflected in the embedded PCB object.

When editing a embedded OLE spreadsheet object (CSV, XLS, etc) in its source application (Excel), note that while the cell contents can be successfully updated, a change in the number of cells will not transfer to the OLE object in Altium Designer.

Editing via an Inspector Panel

Panel pages: PCB Inspector, PCBLIB Inspector

An Inspector panel enables the designer to interrogate and edit the properties of one or more design objects in the active document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same kind, from one convenient location.

Editing via a List Panel

Panel pages: PCB List, PCBLIB List

List panel allows the designer to display design objects from one or more documents in tabular format, enabling quick inspection and modification of object attributes. Used in conjunction with appropriate filtering, it enables the display of just those objects falling under the scope of the active filter – allowing the designer to target and edit multiple design objects with greater accuracy and efficiency.

Notes

  • An OLE Object can also be converted to a collection of free primitive objects using the Tools » Convert » Explode OLE Object to Free Primitives command. This will break the object into appropriate Regions and/or Text objects.
  • A convert to free primitives option is also offered if the matching OLE application cannot be found when attempting to edit an OLE Object.

 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: