Altium Designer Documentation

Release Notes for Altium Designer

Modified by Maksim Feshchanka on Apr 18, 2019
All Contents

The following sections list the release notes for publically released versions of Altium Designer 19.0

For a summary of new features and enhancements in Altium Designer 19.0, see New in Altium Designer.

Version 19.0.15

Build: 446 Date: 18 April 2019 

28016 Fixed access violation error when attempting to combine two Properties panels - each in separate schematic windows.
31284 To improved search performance the Components Panel has been updated to apply search only when the Enter key is pressed. An advanced option has been added to enable dynamic in-grid searching.
31292 Fixed DBLib browsing issue with the Components Panel where in some situations the contents were not displayed.
31301 Fixed file loading error when trying to open a SCHLIB file and a specific part was unable to be read.
31394 Fixed exception error when attempting to modify a model (symbol or footprint) with the Component Editor
31440 Can now properly add (drag-n-drop) datasheet links to a component from the Manufacturer Part Search Panel.
31483 Fixed access violation error when using the Components Panel if the library is saved. Would only occur if the Properties Panel is docked above the Components Panel (BC:10756).
31688 Fixed compatibility issue where Draftsman tables with merged cells created in AD18 would collapse when opened in AD19.

 

Version 19.0.14

Build: 431 Date: 5 March 2019 

31334 Fixed access violation when using the Components Panel after saving a schematic library if it was already installed.

Version 19.0.13

Build: 425 Date: 28 February 2019 

Platform

30563 Fixed slow project loading when using library search paths with a large quantity of libraries (BC:10689).
30583 Altium Designer now keeps the Splash Screen visible until SVNDBLIB file-based libraries are loaded.
30586 Symbols with the special characters (%, @ etc) in the comment or name were not placed from the Component panel when working with managed server.
31065 Fixed component placement and stability errors when using DBLibs and the Components Panel (BC:10704).
31083 The Components Panel performance has been greatly improved.
31098 Fixed bug with DBLib search where results would not list components correctly.

Schematic

29796 Can now place specific NO ERC markers from the compiled messages panel. (BC:10488).
31099 Fix bug with Batch Edit where replaced text would not update correctly. (BC:10624).
31130 The Update From Libraries>>Choose Component dialog has been updated with new component selection dialog.

PCB

31060 The min and max gap values are now correctly updated when using Diff Pair Impedance Profiles.<
31088 Fixed performance issues when the Navigation Toolbar is enabled (BC:10506).
31100 Fixed bug where vias that belong to a footprint would incorrectly move (BC:10612).

Version 19.0.12

Build: 326 Date: 5 February 2019 

PCB

29378 Fixed bug where no warning dialog was presented when drag-moving a Component with locked pad/via/track items.
29408 Fixed regression bug that compromised the Inside Area selection tool performance when the View Configuration panel is open.
30036 Fixed issue when the defined Via structures in the Layer Stack were not available in the correct priority order as Via transition types in the PCB Editor.
30057 Fixed the via cycling when using the '4' hotkey and using the Template Preferred Via Routing style rule.
30206 Fixed regression bug that prevented a violation of the Net from Testpoint Rule being highlighted in the PCB when it is selected in the PCB Rules and Violations panel.
30289 xSignal Signal Length and Routed Length values are now updated correctly in PCB panel when Accordion objects are deleted.
30336 Fixed regression bug that caused incorrect flipping of the board view (Ctrl+F) when toggling the 2D/3D view option or changing the active layer.
30439 Fixed regression issue where the current active layer saved with a board Layer Set is not automatically restored when the Layer Set is subsequently reopened.
30498 Fixed regression bug that disabled the 'L' shortcut key (flip to other side of board) for the String object.
30535 Fixed regression bug that prevented access to the Layer Stack Manager when the system language is set to Turkish.
30538 Fixed regression bug in Layer Stack Manager that caused duplicate Top/Bottom Overlays to be shown in the list when the LSM is saved (BC:10483).
30565 Fixed regression bug that caused separate Mechanical Layers to be added in the View Configuration panel after they have been assigned to a Layer Pair (BC: 10550).
30578 Fixed issue where Mask During Interactive Editing option in Preferences did not apply to Drag Component feature.
30598 Resolved Layer Stack Manager impedance calculation issue caused by frequency data not being passed to the calculator.
30623 Resolved performance regression issues that caused delays when moving PCB components while the View Configuration panel is open.
30689 Fixed regression bug that prevented a checked Solder Mask Tented option from being transferred to the opposite layer when an placed SMD component is changed between the Top and Bottom layers.
30734 Fixed regression where round cutouts were created instead of Pad holes when defining the Board Shape from an imported 3D Body (BC:10435).
30783 Fixed issue where Fills and locked primitives were automatically added to the moving set during Component Drag.

Data Management

29632 Fixed regression issue where the Single Component Editor was misinterpreting parameter unit values.
30236 Fixed exception error bug in the Single Component Editor that occurs when attempting to edit a Symbol which is also used for a large number of other components.
30292 Fixed an issue where the 'Notifications are allowed on the main thread only' error message appeared while Preparing the Project Release where an ActiveBOM was presented.
30369 Fixed issue when attempting to replace an unmanaged (file-based) Component using the Design Item Id option in the Properties panel, where the Component Search dialog offered server-based managed components rather than the original source Library components.
30407 Fixed an issue where BOM Reports with the 'MS Excel File - Native' file format can't be generated via Folder Structure when there were special characters in path.
30489 Fixed regression bug that prevented formulas in a BOM report field being applied to values in all parameter fields.
30516 Fixed regression bug that caused delays and excessive RAM usage when the Components panel processes a Library Package that contains a large number of Footprint Libraries.
30521 Fixed regression bug in Components panel where component Value data were not able to be refreshed when the source database file of a DBLib is updated (BC:10449).
30562 Fixed an issue where an exception occurred during the project release of the project with default output jobs (OUT_BOM.dll).
30659 Fixed regression issue that created "Column Name Error" entries in a generated BOM Output file when the source ActiveBOM document has column name Aliases.
30685 Fixed regression issue where component and supplier data from the Manufacturer Part Search panel could not be imported into an open Database Library.
30728 Fixed regression for the Components panel where if a Supplier Links entry from a DBLib has incomplete supplier data, any entries that follow it will not be shown in the Part Choices List (BC:10505).
30779 Fixed bug when it was not possible to add 'Manufacturer' or 'Manufacturer Part Number' parameter to a part into a *.SchDoc via 'drag and drop'.
30805 Fixed issue where DBLib Components using particular part numbers could not be placed (BC:10564).

Other

30228 Multi-Board: Fixed access violation when creating mates and changing the visible/locked status of other items.
30519 SCH: Fixed bug where a DBLIb sourced component that is dragged from the Components panel to a schematic was placed without Models and Parameters (BC:10516).
30524 SCH: Fixed slow response time when using Cross Select feature where any hidden schematic documents will be opened in the background.
30724 SCH: Fixed exception error when opening a particular SCH document and using Japanese system language.
30819 Added option to enable\disable associated routing when a component is moved (Preferences>>PCB Editor>>Interactive Routing>>Move component with relevant routing).

Version 19.0.10

Build: 269 Date: 17 December 2018 

Platform

25312 Improved opening speed of panels such as the Properties and View Configuration panels.
26036 Revised the data column sorting in the Pin Mapper to match the net name and pin number order.
26554 Fixed issue where incorrect component parameters are shown in Explorer panel after sorting by component tolerance.
26927 Improved the UI action of scrollbars (within panels, grids, dialogs) making them easier to use.
27405 Fixed an issue where the 'Variant or safe array index out of bounds' error message appeared when accessing multi-dimensional arrays.
27113 Fixed issue where an exception is raised if attempting a Check Out when the VCS Provider - GIT service has been removed (BC:9551).
27906 Fixed an issue where modified field values in the Properties panel (when editing objects on a SCHDOC or SCHLIB) were not being applied, if the currently selected item was changed for another, or deselected (BC:9641).
27975 Improved move and locking behavior between board components and external parts in Multi Board Assembly.
28216 Fixed bug where the Clone Variant duplicated UniqueID in .PrjPCB file that led to infinite ECO loop of parameters for Alternate Parts with the Same footprint.
28304 Updated Sign In drop down menu UI to offer all available managed content servers.
28482 Reduced and optimized quantity of the queries to the system registry (BC:9106).
28582 Updated Open Project dialog from file browser to dialog for accessing all project sources, including Managed Projects.
28907 Added new Create Project dialog that simplifies selection of the project target location and applied template.
29828 Fixed invalid session ID bug that caused multiple reconnect attempts to the associated server.
29880 The name Design Workspace has been changed to Project Group, to avoid confusion with the new cloud Workspaces. The *.DsnWrk file extension has been retained for a saved Project Group.

 

Data Management

21617 Revised the Filter Editor dialog UI in ActiveBOM.
22430 Added ability to set manufacturer Part Choice ranking for Managed Components in Component Editor, Explorer and ActiveBOM.
22653 Changed the retrieval of Supplier Part Numbers and Manufacturer Part Numbers to batch mode to prevent the delays associated with sequential single data requests in BOM report, SchLib editor and OutJob with Active BOM.
22982 Fixed issue in Data Management - Servers page of Preferences which is flagged as modified when no changes have been made.
23120 Restored the 'Publish Documents To' function for publishing released documents from the Explorer panel.
23348 Implemented the BOM document filter options in the BOM Report.
23824 Manual Solution is now supported by Import Ranks feature. Import manual solution for the component from one Project-BOM to another.
23999 Fixed issue where variations to project properties were not being passed to BOM outputs (BC:9580 ; 7072).
24029 Added new 'Supplier Packaging' parameter to the cloud component data to provide a distinction to the manufacturer 'Packaging' parameter (BC:8063 ; BC:8986).
24443 Resolved issue where BOM filtering options change after an increase or decrease in the number of design items (BC:5572).
24619 Introduced support for ActiveBOM Filter options in BOM Report and BOM Sets.
24832 Fixed issue where the Part Suppliers in a BOM document are not dynamically updated when the Parts Providers locations have been changed in Preferences.
24844 Added ability to change Component sources (design Items) directly within ActiveBOM, as in the Item Manager.
24876 Added new Create/Edit Manufacturer Links feature for ActiveBOM Solutions (BC:9437).
25271 Added ability to export BOM in xls/xlsx format when MS Office is not installed (BC:4646).
25441 Fixed issue where the Print Preview for a PCB 3D Printout is blank.
25760 Paste functionality has been improved when working with an ActiveBOM document, and at least one target cell has been selected.
25801 Fixed issue where a design file could not be successfully renamed in the Storage panel (BC:8643).
26014 Fixed a SVN connection error issue where a created SVN v1.9 file repository could not be committed to after the software has been restarted.
26111 Resolved an issue where a large number of listed OutJobs could not be displayed in the Project Release Options dialog, when the PC screen scaling has been set to 125%.
26133 Restored Filters options for 'Resistor' part types when searching Managed Components in the Explorer panel.
26267 Resolved issues with designator parameter type priority in BOM Reports.
26496 Resolved exception error when attempting to edit a particular component footprint from the Single Component Editor.
26699 Resolved issue where existing Part requests in Vault 3.0 are not shown in the Explorer panel.
26967 Resolved an issue with Project Releaser where the release would generate 'same key' errors if the only difference between any parameters was the presence of special characters (_, &, \, etc).
27026 Fixed issue where case sensitivity between a component's symbol and footprint Pin names caused multiple errors when releasing the component to a server.
27048 Added Supplier Packaging data to Manufacturer Part Search UI as parameter entries in the Details section (BC:8986 ; BC:8063).
27064 Resolved issue where BomDoc line numbers were blank if Greek characters have been used in component Value parameters.
27268 Fixed Bug in Properties panel that caused the 'Could not find the component in available libraries' error for the NEXUS Server managed component which also has corrupted the reference.
27404 Fixed delay issues in ActiveBOM caused by excessive data requests when updating component data from server.
27535 Fixed issue where the order of Supplier Links for a component in a BOM Report does not match that component's actual order of Supplier Links parameters (BC:9691).
27714 Fixed BOM Report issue where the Include Parameters From Server function returned different suppliers to those specified in the component Properties.
27959 Fixed regression where the target SVNDbLib cache folder path was missing a '\' character causing a SVN process failure.
28081 Fixed an error "One or more errors occurred at 000000010DA15E92" in Project Releaser that was occurring during preparation of data.
28291 Option "Report BOM Violations in Messages Panel" has been added to BOM report preferences.
28443 Added "BOM Checks with the ActiveBOM Document" item to the "Validations Output" menu.
28448 Cache Folder option added to the Data Management - SVN Libraries page of the Preferences dialog (BC: 1195).
29089 The Altium Infrastructure Server Packager now correctly uses the updated Preferences for the deployment package.
29090 An Altium Infrastructure Server Deployment Package no longer requires an internet connection to be present during installation (BC:8488).
29809 Fixed Component panel bug where the selected component category could not be reopened after performing a File-based Library Search.

 

Importers/Exporters

17619 Fixed bug causing P-CAD Import-Export errors and PCAD16LD.DLL access violations.
24746 Fixed issue where buses are not correctly translated when importing a xDxDesigner project.
25221 Updated xDxDesigner importer with improvements in the interpretation of layers and connections, and the alignment of Net Labels.
25427 DXF Import now properly supports spline objects and creates corresponding polygon objects.
25959 Resolved issue where some components are not translated when importing an xDX Designer project.
27588 Fixed issue where an "Access Violation" occured during the import of a specific xDxDesigner design with multi-part components.
28014 Fixed a bug in the Expedition Importer where only Top and Bottom layers were imported for a specific project.
28735 P-CAD Importer now correctly imports connections and ports (BC:9577).
29014 Improved Eagle importer with numerous fixes covering; hierarchical blocks, board outlines, layer assignments and object shapes.
28067 Generating IPC-2581 output no longer causes an access violation when using multi-line text in a string object (BC:10407).
30293 New extension added - Ansys EDB Exporter. Once installed, access in PCB Editor using File>Export>Ansys EDB.

 

Draftsman

15059 Added new Board Region View object to show board stack-up regions in Draftsman documents.
16063 Added support for special strings in a Draftsman custom Table (BC:7698).
18439 Added board Realistic 3D View object to Draftsman (BC:6991).
18441 Added Draftsman Center Mark object that binds to circle and arc centers (BC:9029).
18756 Fixed issue where a Rigid Flex design displays incorrectly in the Isometric View and the Board Assembly View with True Geometry.
22669 Improved snapping behavior of Dimension object points.
24616 Fixed an issue where the 'Draftsman document is out of date' redundant warning message appeared after export (of a specific users' design) to PDF (BC:9184).
25766 Added the ability to choose the displayed layer overlay(s) in Draftsman Board Assembly and Fabrication views. (BC:6910 ; BC:7716).
25779 Added new Transmission Line Structures table object in Draftsman that is populated with impedance calculation data from the Layer Stack Manager.
25784 Added Draftsman drawing symbol objects for representing Soldering and Gluing points.
25785 Improved the process for adding text in Draftsman where a single mouse click will add the default text in a default text box.
25786 Added new type of Sheet Number parameter to Draftsman that allows GOST compliant sheet numeration.
26114 Fixed issue where a moved or resized Draftsman graphic object can collapse to a single line (BC:9471).
26164 Fixed issue where a change in 3D body position in the PCB, caused by a PCB library update, is not updated to the board view in Draftsman.
26266 Fixed issue where the Space Navigator cannot zoom in a Draftsman document when a table cell has been clicked.
26443 Fixed an issue where, after renaming the associated PCB document, Draftsman would crash.
26542 Fixed regression where the hatching was missing on the Assembly view for not fitted components with silkscreen graphics selected (BC:9416).
26867 Fixed regression where hatching was not displayed for a Not Fitted component with its 3D body missing.
26934 Resolved slow performance issue when generating PDF output from an OutJob.
27359 Fixed bug where some not-fitted components were displayed on assembly views for particular users designs (BC:9416).
27601 Fixed bug that caused a prolonged hang due to duplicate designators on PCB (BC:9203 ; BC:9632).
27694 Added ability to move the start (target) points of Draftsman Callouts and Dimensions after placement (BC:7740).
27699 Fixed issue where a Fill pattern in a Draftsman Layer Stack Legend would revert to its default settings when the document is reopened (BC:9756).
27854 Fixed Draftsman bug where Variants are not being applied to an Isometric View generated by an Output Job.
28416 Improved the display of the Draftsman Assembly View in situations where the 3D model has potential errors (BC:9944).
28803 Radial dimensions now copy/paste correctly in Draftsman (BC:9969).
29424 Fixed inconsistency in 3D camera capture positioning for Draftsman Realistic View and Outjob PCB 3D Print when using the Custom View option.
29443 Fixed bug where the Auto-save Backup crashes Draftsman while working in the PCB Editor (BC:9857).
29463 Added Draftsman support for showing the Flex region Topology in a Board Assembly View.
30087 Draftsman's 'Update Board' command has been changed to 'Import Changes from [PCB document]' to better describe its function.

 

Multiboard

21572 Fixed bug in a Space Navigator where 3D movements in MbaDoc were inconsistent with PcbDoc.
23734 Fixed 'Input string is not in correct format' error when splitting a signal Entry for Multi-Board Schematic (BC:9406).
24498 Fixed bug where a "Input string was not in a correct format" error is thrown when attempting to Split a Multi-board schematic module Entry (BC:9406).
28431 Added support for 3D mouse in Multi-board designs - zoom/pan/rotate.
28432 Added support for exporting Multi-board assembly in STEP and Parasolid X_T format.
28433 Multi-Board Assembly now supports and shows the final folded state of rigid-flex designs.

 

Schematic

23846 Fixed issue where cut/copy/paste could not be used in the Properties panel Parameters listing (BC:9153).
24226 Fixed issue where the Name/URL link for a Schematic Library component was not updated (unless using Enter or focus change) when pressing Update in the Properties panel (BC:9637).
25412 Fixed 'Access violation at address' error that occurred when closing a schematic document with a paused interactive process.
25459 Resolved very slow response when ECO performed after making parameter changes for a Schematic Library that has a large number of Supplier Links.
25864 Fixed an issue where the Name field in the Properties panel for a Port object did not provide a drop-down listing of all existing port names.
27672 Fixed an issue with the Schematic Text Frame object where, when editing through the Properties panel, Tabs were being replaced with spaces when pasting text from an external editor (BC:9663).
27900 Fixed an issue where placing a component on a schematic sheet became slow after compilation.
28442 Using the Properties panel to simultaneously edit multiple objects across multiple schematics now correctly marks all sheets as modified (BC:9236).
28446 Schematic component (designator or comment) values are no longer overridden when enabling the "Override Library Primitive" option in Schematic Preferences (Defaults) (BC:10072).
28539 The Component mode of the Properties panel now includes a Rules section on the Parameters tab, allowing component-type design rules to be specified on the schematic (BC:9445 ; BC:8903).
28565 The Parameter Table Editor now displays all data correctly when the Altium Light Gray UI theme is used (BC:9931).
28716 Reinstated the ability to add and edit Design Rules associated with a schematic Component or document via its properties. Accessed in the Rules section under the Parameters tab in the Properties panel.

 

PCB

16383 Fixed bug that caused ODB++ output based on an Embedded Board to fail.
24425 Gloss and Retrace are now able to operate on objects in unions.
24595 Various enhancements to the routing-friendly move component feature, including better support for when: component is fanned out; its pins are routed; the target area has routes in it (BC:1048 ; BC:2866).
24805 Continued development of Interactive Router Follow mode with various bug fixes and behavior improvements.
25517 Added HDI - microvia (uVia) support.
25634 Resolved an issue where snap points and measurement lines were not visible for a semi-transparent free 3D Body, at certain view angles.
25666 Fixed Regression when it was not possible to change 'Value/Type' column value in 'Model Assignment' dialog of Signal Integrity.
25671 Resolved an issue where the Interactive Differential Pair Length Tuning command would not obey the target length being set to match a routed Differential Pair.
25724 Fixed regression in an interactive multi-route process where a change to the bus spacing was not being applied through the Properties panel.
25809 Layer tabs no longer auto-scroll when a tab is clicked. This would occur whenever the left-most tab was not the first visible tab (BC:9927).
25853 The Target Length values are now sorted correctly in the Properties panel when using the From Diff. Pairs setting.
25951 Added preferences option to enable/disable the reconnect after Move Component feature.
25975 Fixed issue where there is a very long delay when starting the Interactive Router in particular board designs.
25982 Added and integrated new thermal relief options for pads and vias.
26034 Fixed bug in PCB List panel Smart Edit feature where the Batch Replace function was inoperative.
26128 Added the capability to define, use and output an unlimited number of mechanical layers (BC:8976).
26144 Fixed an 'Object accessed after being destroyed' error message in the View Configuration panel that occurred when selecting a Layer Set if the previous set was deleted.
26361 Addressed the regression in IPC Compliant Footprint Wizard where it was not possible to change (or insert) any parameters for LGA, BGA Package Layout Options when Full Matrix is not selected.
26459 Fixed Net Class sorting in the Properties panel to match the Net sorting used in other areas of the software, such as the PCB panel.
26610 Updated Layer Stack Manager with new document interface and UI enhancements for stackup definition, uVia support, materials library, impedance calculator and more.
26862 Resolved CAMtastic issue where Design Rule values were incorrectly rounded to one decimal place.
26953 Fixed bug where the ability to define new component layer pairs was incorrectly available in the PCB Library Editor (BC:9535).
26970 Resolved an issue where the Extract 3D Models function cannot create the 3D model file outputs from the source PCB Library (BC:9418).
27000 Fixed issue where a Project Parameter in a Special String would not update in response to a change in the parameter's Value.
27451 Fixed an issue where PCB panels that were created using embedded board arrays incorrectly output the board outline ("profile") layer to ODB++.
27575 Fixed an issue when DRC flagged a Minimum Annular Ring violation for the backdrilling Stop Layer.
27661 Added ability to directly select the preferred layer from the drop-down menu opened by the Ctrl+L hotkey during Interactive Routing.
27662 Added ability to select the desired layer with the Number pad keys during Interactive Routing.
27666 Added "Show Layer Numbers" option to enable layer numbers in PCB editor layer tabs.
27673 Fixed an issue where pasting a free pad or via on a polygon pour did not accept that polygon's net setting, resulting in short-circuit and clearance violations (BC:9229).
27689 Added Interactive Routing logic to prevent a sub-via being separated from its stacked via set axis during the push and hug process.
27708 Fixed an issue where the backdrills did not appear after opening the PCB document within a specific project.
27771 Added a fully labelled Via side view to Interactive Routing Properties panel.
27871 Implemented Arc Approximation property for standalone regions. This property is available for a selected region in the Properties panel, PCB List panel, and FSO dialog.
28086 Fixed issue where a false un-routed net violation is reported for hatched polygons on particular board designs.
28114 Fixed bug where some objects (such as Line and Arc) on Layer 17-32 were converted to Layer 16 by the Make PCB Library function (BC:9847).
28174 Added Thermal Relief connection style options to Properties panel for pads and vias, which override the style defined in the PolygonConnect rule.
28188 Gerber-X2 Exporter now generates the Profile layer correctly when using arcs\curves (BC:9868).
28275 Net inheritance is now handled correctly when placing a PCB object that could attach to multiple nets, a selection window is displayed listing all possible nets.
28427 Added ability to place dimensions in PCB lib, which do not appear in PCB layout (BC:903).
28428 Added ability to create 3D Bodies from selected tracks, arcs and solid regions. Use Tools>Convert>Create 3D Body From selected primitives (BC:1868).
28441 Pressing the L shortcut to flip a moving component to the other side of the board no longer causes incorrect pad violations to be displayed (BC:5427).
29176 During a layer transition while interactive routing the 6 shortcut key can be used to cycle available via options. This now includes all possible via combinations, for example uVia + blind via.
29179 Added possibility to move strings on overlay layers in 3D mode (BC: 584).
29262 Fixed regression in PCB 3D body snap points where an added custom snap point could not be selected when using the Position 3D Body tool.
29269 DRC no longer falsely detects Minimum Annular Ring errors after the Remove Unused Pad Shape tool has been used to remove unused pad/via donuts (BC:4701).
29698 Resolved outstanding situations where the Flipped On Layer setting was incorrectly being enabled for a component, including: flipping a component while moving then performing an Undo; using a Paste on Current Layer feature (Alt+Ins or Paste Special) to swap layers while pasting; or importing preferences from an older version that had that setting enabled (BC: 9238 ; BC:10235).
29727 Fixed regression where it was not possible to paste special characters into the Text property box of a text string (BC:10221).
29778 Resolved an issue where the PCB editor performance would degrade after using the RMB to drag the view multiple times.
29786 Zoom behavior in the PCB Rules and Violations panel improved - now zooms to the violation detail instead of the violating objects (BC:7987).
29887 Resolved an issue where transparent objects in a 3D model became visible during a 3D command, such as Create from 3D Body, Align Face with Board, or Measure 3D Objects (BC:8699).
29932 New query keywords added: IsBlindVia, IsBuriedVia, IsMicroVia and IsThruVia.
30270 Fixed an issue where highlighting did not work when dragging a PCB component designator while in 3D mode.
Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

You are reporting an issue with the following selected text
and/or image within the active document:
ALTIUM DESIGNER FREE TRIAL
Altium Designer Free Trial
Let’s get started. First off, are you or your organization already using Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

In that case, why do you need an evaluation license?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You actually don’t need an evaluation license for that.

Click the button below to download the latest Altium Designer installer.

Download Altium Designer Installer

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Please fill out the form below to get a quote for a new seat of Altium Designer.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

If you are on Altium Subscription, you don’t need an evaluation license.

If you are not an active Altium Subscription member, please fill out the form below to get your free trial.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Why are you looking to evaluate Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

You came to the right place! Please fill out the form below to get your free trial started.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Sounds exciting! Did you know we offer special discounted student licenses? For more information, click here.

In the meantime, feel free to request a free trial by filling out the form below.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

That’s great! Making things is awesome. We have the perfect program for you.

Upverter is a free community-driven platform designed specifically to meet the needs of makers like you.

Click here to give it a try!

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.