Altium Designer Documentation

Working with Components In Altium Designer

Created: January 27, 2021 | Updated: November 23, 2021
Abstract Image representing the Server

Altium Designer, with its unified design approach, has traditionally used a component model that extends across all aspects of the electronics design process. However, to seamlessly fit the process of electronics design into the encapsulating product development process as a whole, this model needed to evolve – extending to cover other aspects including other design processes (in particular MCAD and Industrial Design), as well as business processes (such as procurement and manufacturing) that intersect with the product development process. This evolved object model is known as the Unified Component Model.

This component model effectively maps the concept of a design component – in the traditional electronics design arena – to the component as seen by the rest of the organization in the bigger 'product arena'. A truly 'Unified Component' model that not only represents the component in the different design domains (Schematic Capture, PCB Layout, Simulation) but also facilitates choices of the desired physical components – real-world manufactured parts – at design-time, offering a significant improvement in terms of procurement cost and time, when manufacturing the assembled product.

Under this modeling paradigm, the design component, as seen by the designer, is separated from the Manufacturer and/or Vendor parts. This information is not defined as part of the component. Instead, Part Choices are used to map the design component to one or more Manufacturer Parts, listed in a Part Catalog, which in turn can be mapped to one or more Vendor parts, allowing the designer to state up-front, what real parts can be used for any given design component used in a design.

These components, along with their part choices, are stored in a connected Workspace – one centralized secure location for all your design data, accessible for your entire design team.

  • Single source of component data – with a Workspace accessible for the entire team, engineers can source up-to-date and standardized components from one secure location, get real-time supply chain data, and use parametric and faceted search to find the exact components they need.
  • Design-time choice of physical components – for any given component, you can choose which manufacturer parts can be used to implement that component when assembling the board.
  • Real-time supply-chain information – fed back from the aggregate parts database of the Altium Parts Provider (which itself interfaces to and gathers the parts from enabled Suppliers) to let the designer know the current costing and availability of the chosen parts, and from all vendors that sell those chosen parts (as defined in the Workspace's local Part Catalog). This information can be added to a component at any moment, including after save of this component – without directly editing it and hence without impacting designs where it is already used – and then be used as part of a Bill of Materials.
  • Concurrent editing of the library – as the Workspace library is essentially a set of Component Items hosted by this Workspace, multiple users can be editing or creating new components for the Workspace library independently, without having to wait when other users will finish the work on their side.
  • Component Models Reuse – a component can be thought as a 'bucket' into which all parametric information and domain models is stored, including schematic symbol, PCB footprints, and simulation models. A component doesn't contain the domain models themselves but rather links to the relevant model Items that are also in a Workspace, so a single domain model can be used by multiple components. If a model changes, you'll be suggested to update all components that use this model, and this ensures that no component will use an out-of-date model.
  • Direct Component Editing – if a component needs to be edited, you can open it for editing directly from within your Workspace. A temporary instance of the Component Editor allows you to edit all aspects of that component, including modifying its referenced domain models without a file-based document in sight.

And if you enjoy using Altium 365 Workspace with the Pro level of access, or an on-site Workspace, you’ll also benefit from extended functionality:

  • Use of Component Templates – apply parameter and component taxonomy-based templates, so each new component type automatically has the correct BOM-compliant parameter set in addition to automating the correct naming, revision, and lifecycle schemes.
  • Component Lifecycle Validation – if a component is in an "end of life", "obsolete", or "abandoned" state, you will be warned before trying to manufacture boards that use it.
  • Where-used Component Traceability – components can be traced all the way through usages: if a part goes obsolete, you can explore in which designs it was used to know which ones need to be updated. If a symbol or footprint has an error, you can see all the components that use that symbol and footprint so you can fix them.
  • Requests of new components – an engineer can submit requests for new (or missing) components to the dedicated librarians and get notified when this component becomes available for use in designs by the requestor and other engineers in the company.

Altium Designer can work with two types of Workspace:

With an Altium 365 Workspace, you'll benefit from a richer set of collaborative features, including Global Sharing. And because it is cloud-based, you get the latest version of the Workspace without having to worry about manual upgrades.

Read more about Designing with a connected Workspace.

When hosting your components in Altium 365 Workspace, you'll have access to view more detailed information regarding component health, through a dedicated Library Health dashboard. This provides greater detail on issues and enables you to quickly assess and fix components accordingly.

Migrating Existing Component Libraries

Main page: Migrating Existing Libraries to Your Connected Workspace

Altium Designer, in conjunction with your connected Workspace, provides a streamlined, simple process to quickly migrate your existing libraries to that Workspace. The GUI to this process – the Library Migrator – presents an intuitive flow that takes initial selected libraries, and migrates them to your Workspace. Catering for all types of libraries relating to older component management methodologies – SchLib, PcbLib, IntLib, DbLib, SVNDbLib – the Library Migrator is the perfect solution to quickly building your company's Workspace component library so you can benefit from their many advantages – high-integrity, centralized storage and management, ease of design reuse, real-time supply-chain information.

The Library Migrator offers a minimalist Simple interface mode where the selected database and file-based component libraries are migrated to Workspace components through a single step, while the migrator automatically takes care of type classification, the target source folder, parameter inclusion and value type, and the transfer of all relevant data. The interface is also available in an Advanced mode that provides a full preview of the proposed library migration, and access to its related data and settings. And while the migration is a single-click process by default, the migrator also offers advanced configuration options through the Properties panel for enhanced control over exactly how that migration is performed.

Access the Library Migrator from any editor by choosing the File » Library Migrator command from the main menus.

All information that is present in an original source library is migrated to the Workspace components, including all referenced domain models (schematic symbols, PCB footprints, Simulation Models), parametric information, assigned part choices, datasheet files, etc. Component Templates are also created where necessary, and may then be refined and used for subsequent library migrations. If your original components have multiple PCB footprints defined, the Library Migrator will bring those models across and keep the current default footprint. And if you only work with PCB libraries – your only concern is PCB layout – then the Library Migrator supports migration of just those libraries, or it can be switched to a models only migration mode where specified models types are migrated from integrated or database libraries. Libraries that include multiple component types (monolithic libraries) are automatically detected and processed as well.

The Library Migrator in its Advanced mode – the full user interface to the component migration process.
The Library Migrator in its Advanced mode – the full user interface to the component migration process.

While migration may seem daunting, the defaults have been defined to enable you to get your collection of Workspace components without having to change a thing – start the process and design with the fruits of the Migrator's labor. The system conducts and handles a number of validations, for example, to ensure no duplicate IDs for the resulting components, or to ensure no duplicate models or component templates are created, and that such entities are reused across (linked to) components where needed. And if issues do arise, the system flags them, with suggestions on how to resolve those issues, aiming to get the migration back on track as quickly, and as smoothly as possible.

The Component Editor

A component is defined/edited using the Component Editor. This editor provides two different modes of operation:

  • Single Component Editing mode – provides a streamlined interface when defining/editing a single component. This is the default mode when creating a new component, or editing a single revision of an existing component.
  • Batch Component Editing mode – provides the interface for defining/editing single/multiple components. You can access this mode by choosing the Tools » Switch to Batch Editor command, from the Component Editor's main menus. This mode is also accessed if you have selected multiple component revisions for editing, from the Explorer panel. Each component definition will have a common set of parameters and links to required domain models. Batch editing comes into its own where it makes sense to manage components as a set, such as a set of chip resistors for example.
A new component can be created – using the Component Editor in its Single Component Editing mode – by using the File » New » Component command, accessible from any editor or from within the Components panel, or Explorer panel.
Read about Components.

Domain Models

From a designer's perspective, a component gathers together all information needed to represent that component across all design domains, within a single entity. It could therefore be thought of as a container in this respect. A 'bucket' into which all domain models and parametric information is stored.

In terms of its representation in the various domains, a component doesn't contain the domain models themselves, but rather links to the relevant model Items that are also in a Workspace. These links – to symbol, footprints, and simulation models – are specified as part of the component.

Use the following links to take a look at the various domain models that can be stored and managed in your connected Workspace:

If you are creating single components using the Single Component Editor – then not only can you create the domain models at the same time, as part of component creation, you can also search for an existing real-world part and create a new component off that, in your Workspace, directly. For more information, see Components.
3D models can also be managed in your connected Workspace. A 3D Model Item is referenced through a 3D Body object placed as part of the definition of the 2D footprint. As such, it is not a model link specified as part of the component.
Read about Components.

Component Templates

When connected to an Altium 365 Workspace, note that Component Templates are not supported with the Standard Subscription Plan. As such, this functionality will not be available with this level of access to Altium 365.

Helping to streamline the creation of your components, Altium Designer, in conjunction with your connected Workspace, supports creating and defining Component Templates. Just as a schematic template can be used to predefine information on schematic sheets that reference it, a component template is referenced by a component and provides predefined settings for use when defining that component.

In particular, component templates have been developed with parametric information firmly in mind, allowing you to define, in a single location, a 'bucket set' of parameters that will be made available to the referencing component. Through the template, you can control which of those parameters are to be made visible, fill in default values, and even mark those parameters that are required as mandatory. In addition, you can also force the use of parameters, marking them as required. Validation checks are in-place at the time of component save, to ensure compliance.

Specified default values for many of the template settings can be locked down to be read-only or selectively made available for override by the designer when defining a component.

The Component Template Editor provides the ability to define explicit data types for component parameters defined within a component template (*.CMPT). In addition, these data types are unit-aware, with a range of popular unit prefixes supported. As such, you can enter a parameter's value using a range of formats – such as 2.2k, 2k2, 4M, 2.5GHz – with the Workspace engineered with the requisite smarts to recognize the numerical value behind those entries.

This feature of a component template facilitates targeted searching through the Workspace's Advanced Search facility – a facility that not only allows you to search by component type but allows you to search smarter, with range searches. Using the power of unit-aware component parameters, you can quickly define a search, for example, to find all capacitors with a capacitance between 47uF and 220uF.

The Component Template Editor also provides support for defining multiple PCB footprints as part of a component template. Any number of footprint model links may be specified, and this will be a welcome feature for those wishing to create components that reference 3 footprints, satisfying the IPC requirements for different density levels: L (least or minimum copper), M (most, or maximum copper), and N (nominal, or median copper).

Adding Datasheets

Altium Designer, in conjunction with your connected Workspace, caters for the ability to store component datasheets within that Workspace and, in doing so, link them to target components. This allows you to more fully describe and support a component, in a centralized fashion, while reducing the reliance on external storage mediums (shared network drives for example). Storing datasheets next to the very components that need to reference them also means you no longer need to have a live internet connection, to consult a reference document that can often, and frustratingly, disappear without warning at the whim of the hosting website!

One or more datasheets can be attached (uploaded) to a component – essentially creating a link between the component and the datasheet(s) – when creating/editing that component through the Component Editor.

For an existing component in your Workspace, one or more datasheets can be attached (uploaded) through the Explorer panel. While browsing the required component, switch to its Data Sheet aspect view.

By far the easiest method to attach a datasheet to a component is to select it within your Windows File Explorer, then drag and drop it onto the Parameters region (Component Editor), or the indicated area of the Data Sheet aspect view (Explorer panel). You can attach any number of datasheets to a component. Once dropped, the file(s) will be uploaded.

Part Choices

In the Supply Chain Area, a procurement specialist often does not know what a particular component in the design represents. What is required, is an indication of what needs to be procured – which physically manufactured components can be used to implement that design component. The best person to indicate which real-world components can be validly used to implement the design-level components would be the designer. As part of the Unified Component modeling paradigm, Altium Designer caters to exactly that through the concept of making Part Choices.

Part Choices essentially create the mapping from a component in your connected Workspace to nominated Manufacturer Parts in that Workspace's local Part Catalog. In other words, Part Choices specify the 'allowed' manufacturer parts that can be used to implement that component on the assembled board. The actual supply chain intelligence – comprising Manufacturer (and part number), Supplier (and part number), Description, Pricing, and Availability – is sourced from the Workspace's local Part Catalog and the relevant Part Source.

Part Choices can be made while defining the component in the Component Editor – either prior to its save to your Workspace or at any time after save when editing that component. For more information, refer to the relevant documentation when using the Component Editor in either its Single Component Editing mode or its Batch Component Editing mode.

The designer can feel truly empowered by being able to specify Manufacturer Parts that are truly interchangeable at manufacturing time in the context of any usage of that component in their design – the very essence of true part equivalency. And it is this intelligent mapping of a component, that turns the humble component into a truly Unified Component. The unified nature of a component, through the chosen part choices made for it, ultimately creates a link from that component, all the way through chosen Manufacturer Part(s), and on to the Vendor (Supplier) Parts that each itself references. From the designer's perspective, the component is hooked directly into the supply chain.

Each defined Part Choice uses the manufacturer part, and not a specific vendor/supplier, meaning you get a single Part Choice that will bring with it all solutions based on the suppliers vending that part (and who are defined for use through your connected Workspace).

Real-time data is made available – fed back from the relevant parts database – to let the designer know the current costing and availability of the chosen parts, and from all enabled Vendors that sell those chosen parts (as defined in the local Part Catalog). And the procurement specialist can also keep abreast of supply-chain information, as it is made available in the Workspace for each component therein.

A part is no longer available or has suddenly become cost-ineffective? No matter, provision is made for real-time updates to be sent back to the Design Area as soon as a change occurs. With this vital 'heads-up', the designer can take that choice of part out of the associated list of Part Choices for that component and essentially 'off the radar'. And at any time additional new, truly equivalent parts can be added to the list, should something more appropriate, available, and cost-effective come along.


Part Source Configuration

Each Workspace has its own dedicated Part Catalog. This is a part catalog database, dedicated to the management and tracking of manufacturer parts and their associated supplier parts. The catalog works only with the Workspace.

The Part Catalog stores items representative of actual Manufacturer Parts, along with one or more items representative of Supplier Parts – the incarnations of those Manufacturer Parts, as sold by the Suppliers/Vendors. Each Supplier Part is a reference to an item in a parts database – either the aggregate parts database of the Altium Parts Provider (which itself interfaces to, and gathers the parts from, enabled Suppliers) or a linked local parts database.

Which Suppliers are actually used – a list of Approved Suppliers – is managed by the Workspace, through the Part Providers page of its browser interface. This facilitates centralized supply chain management, with designers across the entire organization using the same approved list of Suppliers, with which to source supply chain intelligence for parts used in their designs.

For many organizations, component supplier data is (and must be) sourced from an internal company enterprise system that provides a proprietary set of parts supplier data – which might be based on a tightly approved range of vendors and/or special pricing structures. This situation is catered for by the alternative Altium Custom Parts Provider, which when configured for synchronization through Altium Designer allows the supplier data from a specified database source to be mapped to the Workspace supply chain data. For more details, see Supply Chain Database to Workspace Data Synchronization.
Read about Part Source Configuration (in an Altium 365 Workspace, or a Concord Pro Workspace).

Key Panels to be Aware of

As part of your day-to-day activities with components, you will come to use, and rely on, two particular panels within Altium Designer:

  • Components panel – provides a powerful interface with which to interact with all your components – both Workspace and local (database and file-based). And for your Workspace components, the panel provides a filter-based parametric (faceted) search capability, for specifying target component parameters. In addition, the panel also offers options to edit a component through the Component Editor (in its Single Component Editing mode), view the component in its source Workspace, and perform component management functions such as component creation and cloning, or editing the selected component's Part Choices and Type.

    The Components panel – the main interface to all your components for day-to-day design and basic component management tasks.
    The Components panel – the main interface to all your components for day-to-day design and basic component management tasks.

    When using the Components panel, the data for Workspace components are cached to the local machine from the Workspace. This provides an offline access mode for Workspace components when Altium Designer is not connected to the Workspace, and therefore allows normal component browsing and placement, etc. This condition is indicated by the Offline mode - cached data is being used warning text in the lower bar of the panel’s component list pane.

    To learn more about component data caching, see the Component Data Caching section of the Components panel page.

  • Manufacturer Part Search panel – provides the ability for you to search for real-world manufactured parts by offering a sophisticated search feature based on categories and parametric filtering. The panel harnesses the manufacturer and supplier data resources of the Altium Parts Provider service to source the most pertinent and up-to-date component data. A selected manufactured part can be acquired to a connected Workspace or downloaded as a library, or its parameters and datasheets added to an existing part in the design space. The preferred supplier(s) of that manufactured part may also be selected and added, as Supplier Link parameters, to an existing design part. Acquisition to your own connected Workspace involves creating a new component using the Component Editor in its Single Component Editing mode – pre-filled with information from the searched part – and saving to that Workspace.

    The Manufacturer Part Search panel provides access to real-world manufactured parts.
    The Manufacturer Part Search panel provides access to real-world manufactured parts.

While much of the functionality for working with components is available through the Components panel, you can also use the Explorer panel – essentially the former provides a subset of the functionality available through the latter, and focused with respect to component management. There will be some features relating to components themselves that can still only be performed through the Explorer panel (adding datasheets without editing, changing states, deletion of components and models en masse, etc), but these would be more for atypical, edge cases, or as part of administration/Workspace structuring activities. Remember that the component is just one content type – the Explorer panel comes into its own for the entire gamut of content types supported by a Workspace. For example, the creation and management of component templates – very much a relevant entity for components – can be carried out only from within the Explorer panel (unless templates are created at the time of library migration using the Library Migrator).

Re-use in a Design

Once saved and available in the Workspace, components can be re-used in any new design project. In addition, the concept of component certification is made possible as the components are formally revised and lifecycle-managed. This allows the organization to specify the state of its components and what they can be used for (design, prototype, production, etc). From a design perspective, this results in the creation of the Workspace library, containing a formal collection of components that have been company-approved for use in each new design project embarked upon within that company.

The beauty of using certified components in your designs is that when it comes time to change the lifecycle state of your board design, the integrity of the design becomes greater still, since a design can only be released to "Prototype" or "Production" provided the components it uses are also in a corresponding state. Put another way, you wouldn't start to produce that assembled board if the components are only at a "Design" stage!

And, if we take this to the finest level of granularity in the component management arena itself, the system will flag any attempt to promote the lifecycle state of a component in the Workspace if its referenced domain models are not in a corresponding correct state to be able to do so. In other words, a parent component cannot be further in its lifecycle than its child models.

When connected to an Altium 365 Workspace, note that lifecycle and revision naming management is not supported with the Standard Subscription Plan. As such, this functionality will not be available with this level of access to Altium 365.

Design using components that have been certified for use.
Design using components that have been certified for use.

Placement of components can be performed either from the Components panel, or the Explorer panel.

A component can be placed onto a schematic sheet, or a PCB document. The applicable model for the chosen domain will appear floating on the cursor accordingly.

Prior to Placement

Placing a component truly is simplicity itself. But before you do anything, first ensure that the schematic sheet (or PCB document) that is to receive the component is open in Altium Designer and is the active document. If documents are open across multiple windows, ensure also that the window containing that active schematic document has focus.

When working with Altium Designer across multiple windows, if the Components panel or Explorer panel are docked in any mode to a window without the target schematic in it, the Place command will remain grayed-out. This is because clicking within a docked panel focuses the window to which that panel is attached. With the panel floating however, the required Altium window can be focused (the one with the active target schematic), and that window will keep focus when working inside the panel.

Placement from the Components Panel

Altium Designer supports access to, and placement of components from, the Components panel. The panel sources components from the active connected Workspace (and also any available database and file-based libraries). The panel offers full details of the selected component (Parameters, Models, Datasheets, Part Choices, etc.), component comparison, and for Workspace components, a filter-based parametric search capability for specifying target component parameters.

The Components panel uses the basic search engine functionality and view that is applied in the Manufacturer Part Search panel. While the Manufacturer Part Search panel harnesses the Altium Parts Provider service and focuses on component manufacturer and supplier data searches, the Components panel is populated with ready-to-place components from your Workspace and database/file-based library sources.

The panel gives a reassuring sense of familiarity for those designers who have regularly used it to search for, browse, and place components from any other library format – such as model libraries, integrated libraries, and database libraries.

Only the latest revision of each component is presented in the panel.

Commands available to place a Workspace component from the panel depend on its mode:

  • Compact Mode – place in one of three ways:
    • Select a component and use the Place command from the right-click context menu.
    • Double-click on the entry for the required component.
    • Click on, drag, and drop the component directly onto the active schematic sheet (or PCB document).

    Placing a component from the Components panel in its compact mode.
    Placing a component from the Components panel in its compact mode.

  • Normal Mode – place in one of four ways:

    • Select a component and use the button at the top-right of the Details pane (accessed by clicking the button)
    • Select a component and use the Place command from the right-click context menu.
    • Double-click on the entry for the required component.
    • Click on, drag, and drop the component directly onto the active schematic sheet (or PCB document).

    Placing a component from the Components panel in its normal mode.
    Placing a component from the Components panel in its normal mode.

Drag & drop places a single instance of the component. If you need to place multiple instances, use the Place command/button, or double-click on the component entry.

Placement from the Explorer Panel

While your day-to-day workings with components will typically be through the Components panel, placement can also be performed from the Explorer panel:

  1. Browse or search for the component you wish to place.
  2. Right-click on the specific revision of the component required (typically the latest, in which case just right-click directly on the top-level component entry).
  3. Choose the Place command.

The component will float attached to the cursor – just pick a ball-park spot on the active schematic sheet (or PCB document) and click to effect placement. You can fine tune and nudge it into its final location at a later stage.

Place a component from the Explorer panel, using the dedicated Place command.
Place a component from the Explorer panel, using the dedicated Place command.

For more express placement of your components from the Explorer panel, Altium Designer provides the ability to drag & drop revisions of components directly onto the active schematic document (or PCB document). Browse your Workspace for the required component to be placed. Placement involves a specific revision of that component, so be sure to expand the main component entry to list all of its available revisions (click the button at the top-right of the panel and disable the Show only latest option to see all previous revisions). Then click on the required revision and drag an instance of it onto the schematic sheet (or PCB document).

Drag and drop the top-level entry for a component itself, to place an instance of the latest revision of that component.
Drag & Drop places a single instance of the component revision. If you need to place multiple instances, right-click on the required component revision (or top-level component entry for the latest revision) and use the Place command.

Library Health

When browsing the content of a connected Altium 365 Workspace, the Explorer panel provides access to the Library Health view from where you can run health checks and inspect component health issues. Select the Library Health entry in the Server Folder region of the panel to access this view in the panel.

The Library Health view accessed from the Explorer panel
The Library Health view accessed from the Explorer panel

The top region of the view provides a summary of the health of your components, since last running a health check. Below are the health check analyses that are supported, gathered into various Issue Themes. Clicking on a health check analysis tile will provide a more detailed description of the check with steps to resolve (where available), as well as a detailed listing of all components failing that health check.

The Library Health view shares the same interface and functionality as the detailed Library Health dashboard page accessed from Altium 365 Workspace browser interface. See Accessing the Main Library Health Dashboard for more information on this page.

Where-Used Capabilities

When connected to an Altium 365 Workspace, note that Where-Used capabilities are not supported with the Standard Subscription Plan. As such, this functionality will not be available with this level of access to Altium 365.

The highly relational structure of the data in a Workspace lends itself to powerful 'where used' capabilities. At any time, you are able to see where a particular child Item is used, in terms of parent Items in the Workspace. So for a given domain model, you can quickly identify which components reference it. For a given component, you can see which board designs it has been used in, which managed schematic sheets, and so on. Conversely, and from a parent Item's perspective, you are able to quickly browse its children.

The ability to traverse the content of a Workspace in this way can offer great benefit, not least of a time-saving nature. For example, if a component is deprecated or made obsolete for any reason, you can quickly identify and pull-up the schematic sheets and board-level designs in which it is placed, and update and re-save those content as new revisions using another equivalent and approved component.

And why re-invent that proverbial wheel, when you can find a component that you need to use and see which designs it has already been used in. If those designs are at a production state, that component has been proven already and is therefore good-to-go. It can be re-used in your next design with assured confidence.

Inspecting from the Components Panel

Select a Workspace component in the Components panel to view information about where the latest revision of it is currently used, in the Where Used section (if the panel is in its Normal mode, click the button to access the Details pane). The section provides quick-filter information for:

  • Projects – the Workspace projects in which the component has been used. Information is only presented once the project has been saved to the Workspace.
  • Managed Sheets – the managed schematic sheets on which the component has been used.

Inspecting where a component (latest revision) is used, through the Components panel.
Inspecting where a component (latest revision) is used, through the Components panel.

Inspecting from the Explorer Panel

The Explorer panel provides a richer experience with respect to the various parent-child relationships that can exist between data Items in the Workspace:

  • For a parent Item, use the Explorer panel's Children aspect view tab.
    For a component or managed sheet, children can also be viewed using the Explorer panel's Preview aspect view tab.

    Example exploring the children of a managed schematic sheet revision, using the Children aspect view tab (top). Notice the information is also available from the Preview aspect view tab (bottom).
    Example exploring the children of a managed schematic sheet revision, using the Children aspect view tab (top). Notice the information is also available from the Preview aspect view tab (bottom).

  • For a child Item, use the Explorer panel's Where-used aspect view tab.

    Example exploring where symbol (top) and component (bottom) revisions are used, using the Where-used aspect view tab.
    Example exploring where symbol (top) and component (bottom) revisions are used, using the Where-used aspect view tab.

Double-clicking on the entry for a child Item in the Preview aspect view tab, or on an Item entry in the Children or Where-used aspect view tabs, will take you to that Item within the applicable Workspace in which it resides.

Managing Components

Having initially placed components onto schematic sheets of a board design, there now needs to be some way of updating those component instances, with any changes to their linked source components in the applicable Workspace. In other words, a means by which to keep the design synchronized with the Workspace entities that it uses.

For example, a component may have been re-saved to the Workspace, perhaps reflecting a change to a child model. This results in a new revision of that component. The placed instance of that component is now using an older revision and you may want to update it to use the latest revision instead. Alternatively, you may have decided to use a different component altogether, and simply need to change the existing component in the design for an alternate one.

There are various methods available by which to manage the components after initial placement into a design.

Single Instance Component Change

Each placed component has a link back to the component revision in the Workspace. This information can be found on the Properties panel, when browsing the properties for the selected component.

Each placed instance of a component has a link back to the specific revision of that component in the Workspace.
Each placed instance of a component has a link back to the specific revision of that component in the Workspace.

If there is a later revision of the existing component available, the entry for the revision status (on the Properties panel) will reflect this using the text Out of date, to the right of the current revision's lifecycle state. Note that if the lifecycle state has been marked as not being allowed for design (Allowed to be used in designs option disabled for it in the State Properties dialog), then the entry will instead show as Inapplicable.
When connected to an Altium 365 Workspace, note that configuration and use of lifecycle definitions is not supported with the Standard Subscription Plan. As such, this functionality will not be available with this level of access to Altium 365.

At this lowest, individual component level, the placed instance can be:

  • Updated to the latest revision of the existing component, by clicking the Example of updating the same component to its latest revision – hover over the image to see the result. button.

    Example of updating the same component to its latest revision – hover over the image to see the result.
    Example of updating the same component to its latest revision – hover over the image to see the result.

  • Switched out for the latest revision of a different (a replacement) Component Item, by clicking the Example of replacing the existing component with a different one (an alternate). button, at the right of the Design Item ID field. The Replace Component dialog will appear, presenting all components in your active Workspace. The current component is shown at the top of the list. Search for the replacement component required, select it, then click OK.

    Example of replacing the existing component with a different one (an alternate).
    Example of replacing the existing component with a different one (an alternate).

Effecting Batch Component Changes – the Item Manager

Related page: Managing Content with the Item Manager

Individual component change is great, however it soon becomes tiresome when dealing with a more sizable number of components. For this, you need a single, centralized place from which to effect multiple changes in a batch-like manner. Enter the Item Manager (Tools » Item Manager).

The Item Manager is 'command-central' for synchronizing Workspace design entities – placed on schematic sheets – with the source content they are linked to in a Workspace. It automatically detects and lists all components, flagging if they are Workspace entities or not, and then compares the Item-Revision of each Workspace component on the schematics against the available revisions of that component in the Workspace. For each entity, information about the current linked Item is given, in terms of revision, lifecycle state, and the source Workspace in which it resides.

When connected to an Altium 365 Workspace, note that configuration and use of lifecycle definitions is not supported with the Standard Subscription Plan. As such, this functionality will not be available with this level of access to Altium 365.
The automated comparison of revisions for Workspace content flags any that is out of date. That can then be selected and prepared for update to the latest revision with minimal effort. For more detail, see Detecting when Updates are Required.

You have full control over which of these Workspace entities to update, and how. For example:

  • Select an individual entry and update it to use the latest revision of the linked Item, or choose to use the latest revision of a completely different Item.
  • Select a group of entries that utilize the same linked Item and either update them to the latest revision of that Item, or choose to use the latest revision of a completely different Item.

All proposed changes are reflected back in the manager.

Once changes have been set up as required, generate an Engineering Change Order (ECO) and browse the actions that will be taken to implement those changes. Disable any actions if required – you are always in the driving seat! When ready, execute the ECO and the changes will be effected. Fast and efficient, your placed Workspace content is managed with simplistic ease.

If you're confident in the changes you are making, you can use the Item Manager's Apply ECO feature – effecting the changes quietly, without popping the Engineering Change Order dialog.

The following examples illustrate use of the Item Manager:

  • To update multiple components to use the latest revision of the existing Workspace component.

    Update a group of out-of-date components to their latest revisions.
    Update a group of out-of-date components to their latest revisions.

  • To change a couple of components for the latest revision of a different Workspace component – chosen through the Replace Component dialog.

    Replace one or more components with a different Workspace component.
    Replace one or more components with a different Workspace component.

Not only can the Item Manager be used to keep your components in your designs in-sync with changes to the source content in the connected Workspace(s), it is also a powerful tool to aid in the migration of your existing board designs – from using local design items to using Workspace design content. Once you have migrated your design components to a Workspace, and any schematic sheets (device sheets), you use the Item Manager to 'replace' the existing components and sheet symbols with their newly migrated Workspace incarnations. In other words, the components remain the same, from the design perspective, but the source of those components changes.

Powerful auto-matching capabilities enable you to quickly match local components and sheet symbols to Items in the Workspace.

Changing a Component from a BomDoc

It's not uncommon to identify an issue with a component when the BomDoc is being checked and made ready for ordering the parts. For example, the designer may have forgotten to finalize the selection of a component, or a component has gone EOL and the designer wants to explore the price and availability of potential replacements. While you could resolve this by returning to the schematic and editing the component, selecting a suitable part, then refreshing the BomDoc, ActiveBOM supports performing this directly from within the BomDoc – then pushing that change back to the schematic via an Engineering Change Order.

From within the BomDoc, right-click on the selected component(s) and select the Operations » Change <ComponentName> command. The Replace Component dialog will open, from where the replacement component can be searched for. After finding the desired replacement component select it, then click OK. The Engineering Change Order dialog will open, detailing the changes needed to synchronize the schematic with the BomDoc.

Example of component replacement directly from within a BomDoc.
Example of component replacement directly from within a BomDoc.

  • The replace component feature searches for a new component in the currently active Workspace.
  • If the component change also affects the board design, an update to the PCB should also be performed from the schematic.
  • The Replace Component dialog has a similar layout and shares many of the features with the Components panel.
Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: