Altium Designer Documentation

Your View of the PCB in Altium Designer

Created: May 21, 2021 | Updated: May 22, 2021

Working in 2D and 3D Layout Mode

Historically, PCBs have been laid out in a two-dimensional design space that uses colors to represent the various layers of the PCB. However, the physical PCB is a three-dimensional object, which requires the PCB designer to take the multiple-layer, 2D representation on the screen and map that to a 3D representation in their mind.

The substantial improvements in 3D video cards and the supporting software technology have allowed Altium to develop a solution to this problem, which is true three-dimensional PCB editing. More than simple visualization, Altium Designer's 3D capabilities allow you to:

  • Perform 3D clearance checking; components can be critically aligned with each other and the enclosure as required.
  • Visually locate connectors and other components requiring access for servicing.
  • Manufacturing processes and the order of assembly can be better defined knowing that all mechanical constraints have been accounted for.
  • More detailed hand assembly instructions, user manuals and instructions can be generated using images that are much closer to the reality of what will be seen by a human.
  • Experiments with different colored solder masks can be made in order to create a more aesthetically pleasing product that works well with its enclosure and surroundings. 

2D and 3D views of the same region of a board.
2D and 3D views of the same region of a board.

Altium Designer Display Modes

Altium Designer supports displaying and editing the board in 2D or in 3D, these are referred to as display modes. Select the required mode in the View menu, or press the 12 or 3 shortcut to switch directly to that mode.

There are three display modes, each with distinct functions.

  • Board Planning Mode (shortcut key 1) - use to define the board shape and also to position and configure split lines and bending lines on a rigid-flex design. Split lines are used to divide the board into regions and each region can then be assigned a different layer stack. To learn more about board regions and split and bending lines, refer to Defining the Layer Stack.
  • 2D Layout Mode (shortcut key 2) - the traditional 2D, multiple-layered view of the PCB. Altium Designer incorporates a set of features to help you manage your view of the board called the Board Insight System (detailed below).
  • 3D Layout Mode (shortcut key 3) - the true, 3D design. Combine the 3D display mode with a 3D mouse to view and manipulate the loaded 3D board as if you were holding it in your hand.
The 3D Layout Mode requires a graphics card that supports DirectX 9 or later, with Shader Model 3 or later.

The same board is shown in Board Planning mode, 2D Layout mode, and 3D Layout mode. The same board is shown in Board Planning mode, 2D Layout mode, and 3D Layout mode.

Single-Layer Mode

Single-Layer 2D Display Mode

Integrated with Board Insight are the Single-Layer mode features, which are configured on the PCB Editor - Board Insight Display page of the Preferences dialog. Single Layer mode displays the contents of the current layer while hiding or dimming the contents of all other layers. As well as hiding all objects on all other layers to display only the contents of the current layer, Single-Layer mode has grayscale and monochrome display modes. Converting all other layer colors to grayscale or monochrome lets you retain the spatial relationship information about the location of other objects in the design, without distracting you from the layer of interest. To cycle between the full display and each of the enabled single-layer modes, press the Shift+S shortcut. With each press of Shift+S, the software moves to the next enabled mode, ultimately returning to the full display mode. Single-layer modes are enabled on the PCB Editor - Board Insight Display page of the Preferences dialog. Disable (uncheck) any modes you do not want to be included when you press Shift+S. These settings apply to all designs in this installation of Altium Designer.

 

The single-layer modes available are:

  • Hide Other Layers - all other layers are hidden; only the contents of the active (current) layer are shown.
  • Gray Scale Other Layers - all other layers are displayed in a shade of gray derived from their current layer color; the active layer is shown in its standard color.
  • Monochrome Other Layers - all other layers are displayed in the same shade of gray; the active layer is shown in its standard color.

The below images show the regular multi-layer display and the three single-layer display modes.

The currently chosen single-layer mode is displayed in the General Settings region on the View Options tab of the View Configuration panel

Single-Layer 3D Display Mode

Single-layer mode is also available when the board is displayed in 3D Layout Mode. Use this for tasks such as examining the quality of routing on a specific layer or the quality of a power plane layer. While in single-layer mode, use the Ctrl+Shift+Wheel Roll shortcut to step through the layers.

Working with the Board Insight System

Board Insight is a configurable system of features that gives you complete control over viewing and working with your PCB design. A complex multi-layer board makes for a visually dense and often difficult to interpret design space. Altium Designer's Board Insight system makes it easier to view and understand the objects in your design. It consists of an integrated set of features developed to meet your view management needs.

Integrated with Board Insight are enhanced Single Layer mode and 3D visualization features. In Single Layer mode you can see clearly what is on a given layer, but also have a perspective as to what is on other layers. 

To the casual observer, a PCB design is quite unintelligible and looks like a mass of lines, circles, arcs, and strings in different colors all jumbled on top of one another. Even with a highly-trained eye, it can be difficult to make sense of the vast amount of design detail. Altium Designer includes a number of features to help find, identify, and manage the display of design content. Collectively these features are known as the Board Insight system.

Board Insight Pop-up Mode

The Board Insight options are accessed by pressing F2 in the design space. This opens the Board Insight pop-up menu (also accessible by selecting View » Board Insight). Select the desired command from the menu. Shortcut keys you can use in the design space without accessing the pop-up are listed to the right.

The Board Insight pop-up mode is an excellent tool for viewing objects under the cursor. Press Shift+X to view detailed information about any components and nets located under the cursor, as well as objects that belong to them, for example, pads and tracks. Use Shift+V to view information about violations currently under the cursor. A graphic of the selected object or violation currently chosen in the pop-up is also displayed. You can view detailed information about, select, or zoom to the object/violation by clicking on the object/violation to open a pop-up menu or by using the icons on the right. The options available are:

  • Properties or  - opens the Properties panel for that object or the Violation Details dialog for the violation.
  • Select or  - selects the object or violation in the design space.
  • Zoom or  - zooms in to the object/violation.

Heads Up Display

The Heads Up Display gives you real-time feedback about objects currently under the cursor in the PCB design space. The Heads Up Display is configurable and can include cursor location, delta information (distance from the last mouse click), current layer, and current-snap grid. As well as the information content, the display font and colors can also be configured. The Heads Up Display can be parked anywhere on the screen or you can have it follow the cursor.

If you pause for a moment as you are moving the cursor, the Heads Up Display will switch to Hover mode. Extra information is displayed in this mode, which can include a summary, available shortcuts, rule violations, net, component, and primitive details.

You can configure the Heads Up Display on the PCB Editor - Board Insight Modes page of the Preferences dialog.

In the Heads Up column of the grid, enable the property option(s) you want to be displayed in the Heads Up display. Font settings for those options can also be configured in the grid.

The following shortcut keys can be used to configure the Heads Up Display: 

  • Shift+H - toggles the Heads Up Display on or off. 
  • Shift+G - toggles the location of the Heads Up Display to be at a fixed position on the board or allows it to be moved with the cursor. 
  • Shift+D - toggles the display of the Delta Origin coordinates. The delta coordinates display the distance horizontally (dx) and vertically (dy) from the Delta origin coordinates. Use the Delta coordinates to gauge distance relative to a position on your board.
  • Insert - resets the Delta Origin to the current mouse coordinates. The distance horizontally and vertically the mouse is moved from the Delta Origin can be displayed in the Heads Up Display. This setting can be configured in the PCB Editor - Board Insight Modes page of the Preferences dialog.

Live Highlighting

Making sense of a complex PCB design is not easy with dense component placements, tight routing, and multiple signal layers. Altium Designer includes a number of net highlighting features to help you examine the routing.

Use the Live Highlighting region of the PCB Editor - Board Insight Display page of the Preferences dialog to configure this feature. 

Use Ctrl+Click to highlight any net on the board. Everything in the design that is not part of that net is dimmed, making the routing stand out on all signal layers, as shown in the image below. To highlight multiple nets, hold the Shift key as you Ctrl+Click on each net. Ctrl+Click in any free space to restore the display.

Net highlighting can also be used dynamically, meaning that as you move the cursor over a net, it will be highlighted. This method uses an outline highlight, which is configurable and does not affect the display of the remainder of the PCB. The image below shows a net highlighted using live highlighting.

The image below is an example of a net being highlighted using Ctrl+Click

Visual Pick List Pop-up

The Visual Pick List pop-up makes it easy to choose the correct object in a crowded design space. A multi-layer PCB design makes for a dense and visually crowded design space with many objects on top of one another. The Visual Pick List pop-up makes object selection simple. Double-click when there are multiple objects under the cursor to display the Visual Pick List pop-up. As you move the mouse through the list, the current object will be displayed in the pop-up, allowing easy identification. The objects in the Visual Pick List pop-up are sorted by layer.

Active Layer Control

The PCB editor is a multi-layer environment with only one layer being currently active. There are a few ways to change which layer is currently the active layer. Note that the current layer selection applies only to the 2D viewing mode.

  • Click on the Layer tab at the bottom of the design space.
  • Use the Active Layer drop-down in the Layers region on the Layers & Colors tab of the View Configuration panel.
  • Move through the layers using the following shortcuts.
    • Ctrl+Shift+Mouse wheel - next layer/previous layer
    • + (numeric keypad) - next layer
    • - (numeric keypad) - previous layer
    • * (numeric keypad) - next signal layer

Net Name Displayed on Tracks

Another handy feature to help you work more efficiently is the ability to display net names on the tracks (configured on the View Options tab in the Additional Options region of the View Configuration panel). To use this feature, enable the Repeated Net Names on Tracks option in the Additional Options region. Wherever you are working on the board, you can instantly be sure if the routing you are looking at is the net in which you are interested. 

Displaying net names on the tracks makes it easy to Displaying net names on the tracks makes it easy to "read" the routing.

Pad and Via Detail Display Options

You can control the display of pad and via details using the Pad and Via Display Options region of the PCB Editor - Board Insight Display page of the Preferences dialog. You can configure the color, background and font for pad and via information. Strings are automatically presented as right-reading, and aligned in the direction that maximizes the area available to display them. The Use Smart Display Color option automatically selects a font color that renders good contrast so that the text can be easily read.

Depending on the display mode (DirectX or GDI), not all pad and via detail features will be visible.

Locked Objects Display Options

You can control how locked objects are displayed in the design space, making them easier to identify visually. Use the controls in the Show Locked Texture on Objects region on the PCB Editor - Board Insight Display page of the Preferences dialog.

Show Locked Texture on Objects is available in DirectX mode only. 

Example of the Only When Live Highlighting option enabled. Example of the Only When Live Highlighting option enabled.

3D Board Insight

3D Board Insight includes projection modes, which display the board either in Perspective or Orthographic projection. Use the Projection region when in 3D viewing mode on the View Options tab of the View Configuration panel to select the desired display mode.

Select Orthographic to see the exact position of objects and text on the PCB without being obscured by surrounding objects. Choose Perspective to see a more realistic 3D view of the PCB.

PCB Object and Layer Transparency

The Object Visibility region of the View Configuration panel can be used to set the transparency of each PCB object. Use the Transparency slide bar to set the percentage or enter the desired percentage directly in the percentage field.

Altium Designer also provides support for setting the transparency of each object type individually and on a per-layer basis for each layer that can be used in board design. This gives you increased control over the display of objects within the design space. The Object Visibility dialog is used to configure, experiment with, and fine-tune transparency-level settings to suit your needs. The Object Visibility dialog is accessed by clicking the Advanced button at the bottom of the Object Visibility region on the View Options tab of the View Configuration panel.

Although the transparency settings can be defined for any 2D view configuration, Altium Designer features a dedicated default 2D view configuration for this very purpose named Altium Transparent 2D. It is identical in all other aspects to the Altium Standard 2D view configuration. Use the Configuration drop-down in the General Settings region on the View Options tab of the View Configuration panel to set the view configuration. The view configurations can be found in the \Templates folder of your installation.

For the Altium Standard 2D view configuration (\Templates\Altium Standard 2D.config_2dsimple), each object type has a default transparency setting of 0% across each layer with the exception of Rooms, which have a default setting of 60%.

Layers and Objects 

The grid of the Object Visibility dialog presents rows that represent each layer and columns that represent each object type. Not only does this allow a unique setting to be defined for a particular object across different layers, but it also allows different objects to have different visibility on a specific layer.

By default, only layers in the current board's layer stack will be shown. To show all layers supported for board design in Altium Designer, disable the Only show used layers option.

The layers themselves are grouped by their functional types:

  • Signal Layers 
  • Internal Planes 
  • Other Layers 
  • Silkscreen Layers 
  • Mask Layers 
  • Mechanical Layers

Layers that are currently not used in the design have their names and transparency values displayed in gray text. You can still configure the transparencies as required for any unused layers.

When you want to set up a global configuration for transparencies that can be used for any board design, it is a good idea to disable the Only show used layers option then configure the settings for each and every layer. In this way, if additional layers are added to a particular board design, the visibility settings will already be defined and ready for use.

Defining Transparency

To set a value for an object's transparency on a single layer, select the intersecting cell for the required object and layer, then use the Transparency for selected slide bar or enter the desired percentage.

Transparency is set on a percentage scale in 1% increments. 0% is fully visible (solid) and 100% is fully transparent (invisible).

Use the following multi-select controls to select multiple objects then set a common transparency for the selected objects.

  • Ctrl+click to select all cells within the same column.
  • Shift+click (or Shift+Arrow) to select contiguous cells across multiple columns and/or rows.
  • Click&drag to select multiple contiguous cells within the same, single row.

To quickly set the transparency for all object types on a specific layer, click on the layer name to select the entire row then set the desired transparency.

To quickly set the transparency for all objects across multiple contiguous layers, use multi-select controls to first select the required layer cells then set the transparency.

To quickly set the transparency for a specific object type across all layers, click on the object name cell to select the entire column then set the transparency.

Transparency in Action

The following image shows an example of transparency settings. As you can see, in Altium Standard 2D, the polygon pours on the top layer pretty much prevent anything from being seen.

The image below shows the result of setting up some transparency settings for various objects on different layers as part of the Altium Transparent 2D view configuration. By switching to this view in the design space, the 70% transparency set for polygon pours across layers kicks in, which allows other objects directly beneath to be viewed, almost like viewing an X-ray. By tweaking transparency settings, the resulting view of objects could undoubtedly be made more desirable still. The point is, with fully configurable transparency settings, you have the ability to get your transparent view of the board just the way you like it.

To get a true view of the mask layers without Multi-Layer objects such as pads and vias getting in the way, increase the transparency of those objects or make them fully (100%) transparent. This can prove very useful if you have undersized your mask openings!

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: