Altium NEXUS Documentation

Sharing a Design from within Altium NEXUS

Modified by Jason Howie on Jul 23, 2020

Parent page: Global Sharing

In support of Altium 365's Global Sharing paradigm, Altium NEXUS supports the ability to share your design projects with others, anywhere around the world, directly from within the software. This complements the ability to share designs from within the browser-based Altium 365 platform itself. The following levels of sharing are supported from within Altium NEXUS:

  • Sharing of an actual design - the live (or WIP) design itself, which can be shared:
    • With other members of your Workspace team - for editing and/or viewing. Sharing at this level requires both registration with AltiumLive and active subscription for your Altium NEXUS licensing. You also need to be connected to your Altium 365 Workspace. An invited team member can view the design through Altium NEXUS, or through the Altium 365 Platform Interface. Editing is performed only through Altium NEXUS.
    • With people outside of your Workspace team - for viewing or editing, through email invite. Sharing at this level requires both registration with AltiumLive and active subscription for your Altium NEXUS licensing. You also need to be connected to your Altium 365 Workspace. This allows invited stakeholders to view/edit (as applicable) a live, work-in-progress design project, without gaining access to your full server of design data.

If granted viewing access only, the invited stakeholder can view and comment on the design from within Altium NEXUS, or through the Altium 365 Platform Interface. As the relevant members of your Workspace team make changes to the design and commit them, those changes can be viewed 'live' by those external people. To view the shared design through the web interface, from anywhere, all that's needed is registration with AltiumLive to gain access.

If the invited stakeholder has been granted editing rights to the design, then they can open and edit from within Altium NEXUS - perfect for external contractors.

  • Sharing of a design 'snapshot' - a static snapshot of the design at a particular point in time and shared:
    • By link - available to anyone through a Web browser. Sharing at this level requires neither active subscription for your Altium NEXUS licensing, nor registration with AltiumLive. A recipient of the shared link uses Altium 365 Viewer to view (but not comment) on the design. Viewing requires no registration with AltiumLive and the link is available for 48 hours.
    • With specific people - available to specified people through email invite. Sharing at this level requires registration with AltiumLive, but does not require active subscription for your Altium NEXUS licensing. A recipient accesses the design snapshot through the Altium 365 Platform Interface from their email invitation. Viewing requires registration with AltiumLive, but the snapshot is available permanently. Commenting of the design is also available.
If the recipient of a design (or design snapshot) shared with them does not have an AltiumLive account, they will need to register for one first - a link is provided on the Altium 365 Sign In page.
For more information on uploading a design snapshot from within the Altium 365 Platform Interface and then sharing with others, see Sharing Design Snapshots. For more information on sharing an actual live design with non-team members while viewing the design in your Web browser, see Sharing Live Designs outside of the Workspace.

Accessing Sharing Controls

Controls for sharing a design from within Altium NEXUS can be found in the Share dialog - accessed in the following ways:

  • For the active project - by clicking the  button at the top-right of the main application window, or by choosing the Project » Share command from the main menus.
  • For the focused project in the Projects panel - by right-clicking on the entry for the project and then choosing the Share command from the context menu.
If there is no active project - i.e. no project document currently open - then the  button will act on the currently focused project in the Projects panel.

Accessing the Share dialog - command central for sharing a design from within Altium NEXUS.

Sharing a Live Design

With a design project registered with (made available to) an Altium 365 Workspace, you have the ability to share that design with other people. This can be to other members of your Workspace team, or to people outside of the team. To share in this manner, click to select the  entry, on the left side of the Share dialog.

Workspace team Administrators can always share a project with others for either editing or viewing. Non-administrative members of the Workspace team, or users with whom a project has been shared with outside of the Workspace team, can share a project with others for editing or viewing, depending on the level of access they themselves have. So if they have editing rights, they can share with others for either editing or viewing. If they only have viewing rights, then they can only share with other users for viewing and commenting.

Accessing the controls to share a live/WIP design with others. Note that the image shows the case for a project already available in a connected Workspace.

In order to be able to share a design:

  • You must be signed in to your Altium account (using your AltiumLive credentials).
  • You must have active (valid) Altium Subscription for your Altium NEXUS licensing.
  • You must be connected to your Altium 365 Workspace.
  • The design project must be registered with (made available to) the Workspace.

The Share dialog will present guidance in order to properly prepare you for sharing your chosen design project. The following are examples of this:

  • If not signed in to your Altium account, the dialog will present a link to do so (to access the Sign In dialog), or to register with AltiumLive, if you don't yet have credentials. You will typically connect to a Workspace (if you have one) once signed in to your account, and if that Workspace has been set as the default.

  • If you are signed into your Altium account and are attempting to share an open project that is not registered with a Workspace (i.e. it is an unmanaged local or VCS project), and you don't have a Workspace available to you, the dialog will present a control to activate the Workspace for your company.
Only one Altium 365 Workspace can be activated per organization.

  • If you are signed into your Altium account and are attempting to share an open project that is registered with a Workspace, and you are not currently connected to that Workspace, the dialog will present a control to connect to that specific Workspace, or switch to it if currently connected to a different Workspace.

  • If you are signed into your Altium account and are attempting to share an open project that is not registered with a Workspace (i.e. it is an unmanaged local or VCS project), and you are not currently connected to a Workspace, the dialog will present a list of all Workspaces available to you, prompting you to select which Workspace to register the project with.

If you are already connected to a Workspace, then that will be used as the target in which to register the project. Note that the project will be made available in the target Workspace at the time the project is shared with nominated people.

Sharing with New People

With preparation complete, project selected and target Workspace connected, you can proceed to specify which person (or people) the project is to be shared with. To check who already has access to the project, click on the control to the far right of the Shared with field. The region will expand to show with whom the project is shared and whether they have editing rights (Can Edit), or can view and comment on the project only (Can View).

Check with whom the project is currently shared by clicking the control at the far right of the Share with field. Hover over the image to see the result.

You can share the project with anyone - other AltiumLive users from within your own organization, AltiumLive users from different organizations, and non-AltiumLive users (who will need to then register for AltiumLive accounts). To add an entry, begin typing the desired name/email/role in the field so the matching user/role can be selected from the dynamic list - which will only contain filtered users in your Workspace team or within your organization, and existing roles defined for the Workspace. Multiple users/roles can be chosen. To remove an entered user/role, click the  control associated with the entry.

To share with a person outside of your organization - irrespective of whether they have an AltiumLive account or not - you must enter their full email address and press Enter.

Set the sharing access permissions for the added people/roles from the associated drop-down menu by selecting Can View () or Can Edit (), where the latter option inherently includes viewing capability. The setting initially applies to all entries (people/roles) included in the field. Use the optional note field to include information that relates to the sharing arrangement for this project.

Workspace team Administrators can always share a project with others for either editing or viewing. Non-administrative members of the Workspace team, or users with whom a project has been shared with outside of the Workspace team, can share a project with others for editing or viewing, depending on the level of access they themselves have. So if they have editing rights, they can share with others for either editing or viewing. If they only have viewing rights, then they can only share with other users for viewing and commenting.

With target recipient(s) defined and access rights specified, click the  button to proceed with sharing the project.

If you attempt to share a project with a person outside of the team, the Sharing Outside of the Workspace dialog will appear, offering the following options:

  • Share for Viewing - click this option to proceed with sharing the project, but with view-only permissions.
  • Share for Editing - click this option to proceed with sharing the project, with editing rights.

You can share a project with anyone outside of the Workspace team, for editing or viewing.

Sharing with a user outside of the Workspace team for editing is perfect for contractors - where you want them to actively work on the design, but without bringing them in to your team.

If you are sharing an unmanaged, local project (not under external VCS), the project will be made available in the currently connected Workspace at the time the project is shared with the nominated people. What actually happens depends on whether you are sharing for viewing or editing:

  • When sharing for viewing only -  the project is made available through Simple Sync. Under this mode, the design project can be edited by a single person only (the owner of that project). The strength of Simple Sync comes when you do not want anyone else editing your design, but where you do want to take advantage of Altium 365's Global Sharing paradigm, and be able to share that design with multiple other people for viewing and commenting. For more information on this functionality, see Making an Existing UnManaged Project Available Online.
  • When sharing for editing - the project needs to be added to the Workspace's Versioned Storage Git design repository. Under this mode, multiple people can be shared the project for editing, as well as being able to utilize Altium 365's Global Sharing support for shared viewing and commenting. A dialog will be presented alerting you to this and giving you the option to do so.

When sharing an unmanaged project (not under VCS) with a person for editing, the project will need to be brought under version control by addition to the Workspace's Versioned Storage Git design repository.

If the unmanaged project is already under version control (in an external design repository) it will remain under the external VCS design repository, and not be added to the Workspace's own built-in VCS (Git) design repository. Simple Sync applies, but of course multiple collaborators can continue to work on/edit the design, since it is under VCS. In some cases, functionality delivered through the Altium 365 platform - or more specifically an Altium 365 Workspace - can only be experienced by having your project fully managed and stored under the Workspace's native VCS (within its Versioned Storage Git repository). What you can do is create a snapshot of your project, disconnecting it from external VCS and from the Workspace (if already made available there), and then make it available to the Workspace again, but under the Workspace's VCS - starting afresh as it were. For information on how to do this, see Moving from External VCS to Workspace Native VCS.

What happens next depends on the type of user being invited:

  • A user that is already part of your Workspace Team will be added to the access list for the project directly. They will receive an email notifying them that the project has been shared with them (and what access rights they have to it). They can open the project in Altium NEXUS, or access it through the Altium 365 Platform Interface (from the Projects page).
  • An existing role for the Workspace will be added to the access list for the project directly. All members of the role will receive an email notifying them that the project has been shared with them (and what access rights they have to it). They can open the project in Altium NEXUS, or access it through the Altium 365 Platform Interface (from the Projects page).
  • For a person outside of your Workspace team, the project will be shared with them and they will receive an email notifying them that the project has been shared with them. They can open the project in Altium NEXUS, or access it through the Altium 365 Platform Interface (from the Shared with Me page). The email provides direct access to the design through Altium 365. Once they click the  button in the email they will be taken to the Altium 365 Sign In page (unless already signed in to the platform, or their AltiumLive account). Upon signing in, they will be taken to the Viewer, with the shared design loaded.
If the person does not have an AltiumLive account, they will need to sign up for one first - a link is provided on the Altium 365 Sign In page.

Accessing a live design from the email invite received by the user with whom the design was shared.

Modifying Access Rights for Existing People

At any time, an Administrator (or Workspace team member with editing rights) can modify the existing access permissions for a project. To access the list of existing shared people and roles for a project click the  entry on the left side of the Share dialog, then expand the Shared with field on the right.

Accessing the list of people and roles who currently have shared access to the project.

Things to be aware of:

  • In terms of permissions, a person/role has full editing access to the project when the Can Edit option () is selected. Otherwise, they have View-only access ().
  • The Owner and the Administrators role always have full editing access (Can Edit).
  • With the exception of the Owner and Administrators role, permissions for all included people/roles may be individually set as Can View or Can Edit, or access rights completely removed. Click on the current permission state to access controls.

  • A project may be explicitly shared with specific people and/or roles, or simply shared with all members of the Workspace team. For the latter, set the required access for the Everyone in the team entry. To not share the project with the entire team, set this entry to None.

Make changes to access permissions as required. Each changed entity is highlighted in the list with a lighter background.

Example changes to the permissions for two existing people with which a project is currently shared.

To affect changes, click the  button. The changes will be applied, with confirmation reflected through the dialog. To see the updated list of shared access, click the Who has access link.

After saving permission changes, you can view the updated result directly through the Share dialog.

Remember that if you are changing permissions to Can Edit for someone outside of the Workspace team, you will be alerted - through the Sharing Outside of the Workspace dialog - to confirm whether to give them view-only rights, or editing rights.

Accessing a Shared Live Design at any Stage

Access to the project depends on whether you are a member of the Workspace team, or have been shared a project outside of the Workspace team.

Workspace Team Member

For a member of the Workspace team, they can access the shared project through Altium NEXUS, or through the Altium 365 Platform Interface (from the Projects page of the Workspace's interface). Note that editing of the project - if they have editing rights - is only possible through Altium NEXUS.

Within Altium NEXUS, access the project using the File » Open Project command. The Open Project dialog will appear, from where you can choose which managed project to open from your connected Workspace (when connected to a Workspace, that Workspace will appear in the Locations region of the dialog, distinguished by the  icon, and appearing with the name given to the Workspace). Only those managed projects that have been shared with you (you have permission to access) will be listed.

Once opened, the project will appear under an entry for the Workspace, in the Projects panel.

Choose which managed project to open from your connected Workspace, from within Altium NEXUS, from those currently shared with you.

You have the option to open the project to the default checkout path, or use the  drop-down menu to specify a custom path. The default checkout path is taken from the Document Path field on the System - Default Locations page of the Preferences dialog.
When browsing the project through Altium NEXUS's Explorer panel - configured in its default Project View rather than Classic View - click the  button, at the top-right of the panel, to open the project in Altium NEXUS (adding it to the Projects panel).

Invited Stakeholder Outside of the Workspace Team

For a person outside of the Workspace team with whom the project has been shared, they can access that project through Altium NEXUS, or through the Altium 365 Platform Interface (from the Shared with Me page of the interface). Note that editing of the project - if they have editing rights - is only possible through Altium NEXUS.

On the Shared with Me page of the interface, a live design is denoted by the  icon within its tile. To open in the integrated Viewer, select the design of interest, click the  button within its tile, then choose the Open command from the associated menu. Alternatively, double-click directly on the tile.

Within Altium NEXUS, access the project using the File » Open Project command. The Open Project dialog will appear, from where you can choose which managed project to open from the Shared With Me location.

Once opened, the project will appear under the entry Shared with me, in the Projects panel. What you can do with the project depends on the access rights you have been given to it. If editing rights were assigned to you, you will be able to edit the design normally, which would typically be the case for an external contractor. If you have viewing rights only, you will be able to comment on the WIP design.

Choose which managed project to open, from within Altium NEXUS, from those currently shared with you as an external stakeholder. Note that access is made to such projects without having access to the Workspace.

You have the option to open the project to the default checkout path, or use the  drop-down menu to specify a custom path. The default checkout path is taken from the Document Path field on the System - Default Locations page of the Preferences dialog.

Sharing a Design Snapshot

Creating a snapshot of a design allows you to quickly share that design - at that specific point in time - for wider collaboration with others through the Web. This can be useful for an on-the-fly design review, sharing a particular design milestone, or even to stimulate contextual discussion. To share in this manner, click to select the  entry, on the left side of the Share dialog.

Accessing the controls to share a snapshot of a design.

Any user who is currently viewing a project within Altium NEXUS can share a snapshot of that design.

By default, the dialog is set to Share By Link, meaning that anyone who is given the link will have access to view the design snapshot through their Web browser for a time-limited period of 48 hours. Commenting on the design is not possible with this level of sharing.

This level of sharing does not require you to be signed in to your Altium account within Altium NEXUS.

Click the  button to generate the link to the design snapshot. In the background, the project itself is packaged into a Zip archive using Altium NEXUS's Project Packager. Once the link is ready, click the  button to copy it, and share with the required people as needed.

Generating the time-limited link that can be shared with anyone, anywhere.

On using the link, a recipient will be taken to an instance of Altium 365 Viewer - on the main altium.com site - with the design processed and loaded.

Using the shared link, a recipient can browse the design snapshot using Altium 365 Viewer, loaded on the main altium.com site. Shown here is a schematic - hover over the image to see the PCB.

When the design (in the Zip archive) is uploaded to Altium 365 Viewer, it is removed as soon as it is processed. As a result, viewing of the design is time-limited - available for the duration of your browser session (and no longer available if you close your browser tab). Alternatively, use the link again, at any time during the permitted period of 48 hours.

Sharing with Specific People

Clicking the Share with specific people control will switch the sharing mode (for sharing a design snapshot) to allow you to share with one or more specific people - by email invitation. Recipients will have access to view the design snapshot through the Web-based Altium 365 Platform Interface. Such a design snapshot is available permanently through the platform and commenting on the design is possible with this level of sharing.

This level of sharing requires that you be signed in to your Altium account within Altium NEXUS (using your AltiumLive account credentials). If you are not currently signed in to your Altium account the dialog will present a link to do so (to access the Sign In dialog), or to register with AltiumLive, if you don't yet have credentials.

Switch mode to be able to share a design snapshot with specific people on a permanent basis.

Enter the full email of a person with whom you want to share the snapshot and press Enter. Multiple people can be specified in this way, as needed. You can also add an optional note - to let them know anything pertinent about this specific snapshot being shared.

Example sharing of a design snapshot with a specific person, by email.

Once ready, click the  button. The project itself is packaged into a Zip archive using Altium NEXUS's Project Packager, then uploaded to the Altium 365 platform. Confirmation of upload is provided once the process completes.

The shared snapshot is packaged and then uploaded to the Altium 365 platform, where it is available on a permanent basis.

The person with whom you shared the uploaded design snapshot will receive an email invite to access that snapshot through Altium 365. Once they click the  button in the email they will be taken to the Altium 365 Sign In page (unless already signed in to the platform, or their AltiumLive account). Upon signing in, they will be taken to the Viewer, with the shared design snapshot loaded.

If the person does not have an AltiumLive account, they will need to register for one first - a link is provided on the Altium 365 Sign In page.

Accessing the design snapshot from the email invite received by the user with whom the snapshot was shared.

Accessing a Shared Design Snapshot at any Stage

In addition to following the link in their email invite, a person with whom a permanent design snapshot has been shared will be able to access that snapshot at any time from the Shared with Me page of the Altium 365 Platform Interface. A design snapshot is denoted by the  icon within its tile. To open in the integrated Viewer, select the design snapshot of interest, click the  button within its tile, then choose the Open command from the associated menu. Alternatively, double-click directly on the tile.

Accessing a design snapshot from the Shared with Me page of the Altium 365 Platform Interface.

The person who originally shared the design snapshot - uploading it permanently to the Altium 365 platform - will also be able to access that snapshot from the Uploads page of the interface.

Disabling Sharing

To disable sharing completely, uncheck the Altium Cloud option, on the System - Network Activity page of the Preferences dialog. If you attempt to share a design through the Share dialog - either live, or as a snapshot - a Warning dialog will appear, alerting you to the fact this option has been disabled.

Disabling connectivity to the Altium Cloud will prevent sharing of design projects.

 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

You are reporting an issue with the following selected text
and/or image within the active document:
ALTIUM DESIGNER FREE TRIAL
Altium Designer Free Trial
Let’s get started. First off, are you or your organization already using Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

In that case, why do you need an evaluation license?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You actually don’t need an evaluation license for that.

Click the button below to download the latest Altium Designer installer.

Download Altium Designer Installer

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Please fill out the form below to get a quote for a new seat of Altium Designer.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

If you are on Altium Subscription, you don’t need an evaluation license.

If you are not an active Altium Subscription member, please fill out the form below to get your free trial.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Why are you looking to evaluate Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

You came to the right place! Please fill out the form below to get your free trial started.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

That’s great! Making things is awesome. We have the perfect program for you.

Upverter is a free community-driven platform designed specifically to meet the needs of makers like you.

Click here to give it a try!

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.