Altium NEXUS Documentation

Managed Components

Modified by Jason Howie on Oct 10, 2019

Parent page: Working with Managed Components

Once all prerequisite domain models have been created and released into your managed content server, a design component can be defined and released into that server for reuse in design projects. Revision-controlled and lifecycle-managed, a company can authorize a set of such Component Items - or Managed Components - that can be formally used by their designers.

This document focuses on bringing the required pieces together to define and release a component into a managed content server.

The required domain models - typically schematic symbol and PCB footprint - can also be created on-the-fly at the time the component itself is being defined. This can be performed using the controls available in the Models region of the Component Editor, when using it in its Single Component Editing mode.
A component can be extended to include real-world physical component information, creating a component that spans, or rather unifies, the Design and Supply Chain arenas - a truly Unified Component. To do so requires that Part Choices be made for that component. This is the process of nominating which 'real-world' part(s) can be used for the design component when the product is physically assembled. Part choices can be made while defining the component, prior to its release to the server, and can be modified at any time thereafter by editing that managed component. Part choices can also be made outside of editing the component itself. For more information, see Adding Supply Chain Information to a Managed Component.

Component Items are created directly from within the server. Once a Component Item has been created (and data released into a revision of it), and its lifecycle state set to a level that the organization views as ready for use at the design level, it can be reused in the creation of one or more designs.

Folder Type

When creating the folder in which to store Component Items, you can specify the folder's type. This has no bearing on the content of the folder - releasing a component will always result in a corresponding Component Item. It simply provides a visual 'clue' as to what is stored in a folder and can be beneficial when browsing a server for particular content. To nominate a folder's use as a container for Component Items, set its Folder Type as Components, when defining the folder properties in the Edit Folder dialog.


Specifying the folder type - its intended use - gives a visual indication of the content of that folder when browsing the server.

Another important aspect of the parent folder is the Item Naming Scheme employed for it. This defines the format of the unique ID for each Item created in that particular folder. Several default example schemes are available, utilizing the short-form code for either the folder type (CMPL - Component Library) or the content type (CMP - Component):

  • $CONTENT_TYPE_CODE-001-{0000} - for example, CMP-001-0001.
  • $CONTENT_TYPE_CODE-001-{A00} - for example, CMP-001-A01.
  • $FOLDER_TYPE_CODE-001-{0000} - for example, CMPL-001-0001.
  • $FOLDER_TYPE_CODE-001-{A000} - for example, CMPL-001-A001.

Using a default naming scheme, the software will automatically assign the next available unique ID, based on that scheme, having scanned the entire server and identifiers of existing Items. This can be a great time-saver when manually creating Component Items.

A custom scheme can also be defined for a folder, simply by typing it within the field, ensuring that the variable portion is enclosed in curly braces (e.g. DES-CMP-{0000}).


The Item Naming Scheme of the parent folder is applied to the Unique ID for each Item created within that folder.

The Item Naming Scheme employed for the parent folder can be changed at any time. The modified scheme will then be applied to any subsequent newly-created Items within that folder.

Item Type

When creating a target Component Item in which to store your component, ensure that its Content Type is set to Component, in the Create New Item dialog. If you are creating the Item in a Components type folder, this Item type will be available from the right-click context menu when creating the Item.

A managed content server supports item-less component creation. Using the Create Item » Component command from the menus will enter this mode directly. To get the Create New Item dialog first, you need to use the Create Item » Other Item Type command. For more information about the former, see Item-less Component Creation.


Creating a Component Item within a Components folder - while the correct Content Type is available on the context menu (Component command), using this will take you into item-less component creation mode. To create a traditional Item using the Create New Item dialog, choose the Other Item Type command from the menu instead.

To see your newly created Component Item, which has yet to be defined and released, either disable the Show only latest option (available from the menu accessed by clicking the  button at the top of the Explorer panel), or switch the view for the folder from Components View to Classic View (available from the same menu).

When defining a Component Item, be sure to specify the type of lifecycle management to be used for the Item, and the naming scheme employed for its revisions, respectively.

Control over which Item types can use a particular lifecycle definition or revision naming scheme, can be defined and enabled at a global level from within the Content Types dialog, when defining each schema. The default schemes assigned for use by a Component Item are: Component Lifecycle and 1-Level Revision Scheme, respectively.

Once a component definition has been released into the initial revision of a Component Item, these schemes cannot be changed for that particular Item.

Specify the required schemes in the Create New Item dialog, using the Lifecycle Definition and Revision Naming Scheme fields respectively.

If the option to control use of lifecycle definitions and revision naming schemes per content type is enabled for any definitions/schemes, and the Component Item type is not set to use a particular definition/scheme, then that definition/scheme will not be available in the applicable drop-down list.


Selecting the Lifecycle Definition and Revision Naming schemes for a manually created Item.

Observing standard revision naming schemes and lifecycle definitions, across the various types of design item in a managed content server ensures smooth, consistent management of those items.
It is a good idea to add a Name and Description as part of the Item's definition. This information is used when searching the server and enables quick identification of what a Component Item offers.

Releasing a Component Definition

So far, we've discussed the support for a Component Item in the server, in terms of related folder and item types. Releasing an actual defined component into a revision of such an item can be performed in a streamlined way.

A component can be edited and released into the initial revision of a newly-created Component Item, courtesy of the server's support for direct editing. Direct editing frees you from the shackles of separate version-controlled source data. You can simply edit a supported Item type using a temporary editor loaded with the latest source direct from the server itself. And once editing is complete, the entity is released (or re-released) into a subsequent planned revision of its parent Item, and the temporary editor closed. There are no files on your hard drive, no questioning whether you are working with the correct or latest source, and no having to maintain separate version control software. The managed content server handles it all, with great integrity, and in a manner that greatly expedites changes to your data.

When you create a Component Item, you have the option to edit and release a component into the initial revision of that item, after creation. To do so, enable the option Open for editing after creation, at the bottom of the Create New Item dialog (which is enabled by default). The Item will be created and the temporary Component Editor will open, in its Single Component Editing mode, with the controls to define the component presented in the main design window. The document tab for the view will reflect the Name you have assigned to the component.


Example of editing the initial revision of a Component Item, directly from the managed content server - the temporary Component Editor provides the controls with which to define your component (shown in its default Single Component Editing mode).

Use the Component Editor to define the component as required. The Editor supports two modes of operation - Single Component Editing mode (the default), and Batch Component Editing mode. For more information see Defining the Component.

There are three relevant controls when direct editing, readily available from the Quick Access Bar (at the top-left of the main application window), or from the Component Library Standard toolbar:

  •  - Save Active Document. Use this button to save any changes made to the component. This allows you to save current changes, should you wish to come back at a later stage to make further changes before ultimately releasing to the managed content server.
  •  - Release Document. Use this button to release (effectively save and release) the defined component to the managed content server, storing it within the initial (planned) revision of the target Component Item. The Edit Revision dialog will appear, in which you can change Name, Description, and add release notes as required. The editor will close after the release. The source component definition will be stored in the revision of the Item.
  •  - Cancel Editing. Use this button if you wish to cancel editing. The editor will close, and nothing will be released to the target Component Item.

These controls are also available as commands - Save (Shortcut: Ctrl+S), Release to Server (Shortcut: Alt+Ctrl+S), and Cancel Edit - from the main File menu.

The released data stored in the server consists of the source component definition. In the Explorer panel, switch to the Preview aspect view tab to see full definition data, including referenced models, component template (if used) and parametric information.

Browse the released revision of the Component Item, back in the Explorer panel. Switch to the Preview aspect view tab to see information including referenced models, component template (if used) and parametric information.

Item-less Component Creation

The use of Component Templates provides an efficient means for creating components using ratified templates, however there is a drawback. Since the item is created first, the information in the template (i.e. naming scheme, revision scheme and lifecycle definition) are not assigned since the component item is already created. In order to alleviate this, the managed content server, in conjunction with Altium NEXUS, supports item-less component creation. This does not mean an item is not created, but rather an instance of the Component Editor is accessed directly, which allows the template details to be applied prior to adding and releasing the required component. The actual component item (and planned revision) is created as part of release preparation.

From the Explorer panel, Item-less component creation is available from within an existing folder for Component Items (folder type must be Components). There are two ways to enter item-less component creation mode:

  • By using the Create Item » Component command from the Item region's right-click menu.
  • By clicking the  button, located at the top-right of the panel.
A new component can also be created in this manner by using the File » New » Component command, accessible from any editor, or by using the Operations » Create command, located on the right-click context menu when browsing managed components through the Components panel. In both cases, you will be able to choose from available component templates that are currently defined for the various component types, where available - having the template information applied as you enter the temporay instance of the Component Editor, in its Single Component Editing mode.

Accessing Item-less component creation mode from within the Explorer panel. The current folder must be of type Components.

On entering this mode, a temporary (direct editing) instance of the Component Editor (in its default Single Component Editing mode) will be opened, ready to define the component. The default presentation and information loaded depends on whether a component template is involved.

  • If the mode is accessed from a folder of components and that folder has a component template attached, then model and parametric data, as well as defined Lifecycle Definition, Revision Naming, and Component Naming, will be brought in from that template. The Default Folder will be the folder from which the mode was launched. If a default Name has been specified in the template, this will be used to name the component, and also appear in the tab for the Component Editor's document view. If no default name has been specified, the tab will display New Component, and the component's Name will be blank.
  • If the mode is accessed from a folder of components and that folder has no component template attached, then a default component with default settings will be presented. If the source folder has a defined Item Naming Scheme, then this will be used to create the component's unique ID. The Default Folder will be the folder from which the mode was launched. All other definition information (models, parameters, component type) must be manually specified. The tab for the Component Editor's document view will display New Component, and the component's Name will be blank.

By way of example we'll just consider the first scenario. After all, getting the component template used is why this mode was created. Just remember, that while the process will be very similar for the other scenario, you will just need to do more manual work if not using a template.

Example component created after launching the item-less component creation mode from a folder (Schottky) that has a component template assigned to it. The component is defined with the information from the template. Roll over the image to see the referenced Component Template.

Make any adjustments to the component as required, including the addition of Part Choices.

If you are creating multiple components, using the Component Editor's Batch Component Editing mode, any additional component definition that you add will be created in accordance with the associated component template.

With the component defined, click the  button (on the Quick Access Bar) to release the component to the server. The Edit Revision dialog will appear, in which you can change Name, Description, and add release notes as required. The editor will close after the release.

If you are using the Component Editor in Batch Component Editing mode, the Release Manager dialog will appear with the component already prepared. As part of this automatic preparation, the Component Item itself is created, with a planned revision to accommodate the released definition. Click the Release Items button, and confirm the release when prompted. The editor will close after the release.

Your new component will be available to view in the Explorer panel, and also to browse for and work with, through the Components panel.

Defining the Component

Main pages: Component Editor - Single Component Editing Mode, Component Editor - Batch Component Editing Mode

A component is defined/edited using the Component Editor. This editor provides two different modes of operation:

  • Single Component Editing mode - provides a streamlined interface when defining/editing a single component. This is the default mode when creating a new Component Item, or editing a single revision of an existing Component Item.

Example showing definition of a component, with the Component Editor in its Single Component Editing mode.

A new component can be created, using the Component Editor in its Single Component Editing mode, by using the File » New » Component command, accessible from any editor, or by using the Operations » Create command, located on the right-click context menu when browsing managed components through the Components panel.
  • Batch Component Editing mode - provides the interface for defining/editing multiple components. You can access this mode by choosing the Tools » Switch to Batch Editor command, from the Component Editor's main menus. This mode is also accessed if you have selected multiple Component Item revisions for editing, from the Explorer panel. Each component definition will have a common set of parameters and links to required domain models. Batch editing comes into its own where it makes sense to manage components as a set, such as a set of chip resistors for example.
You can use the Batch Component Editing mode to define/edit a single component, should you wish.

Example showing definition of a component, with the Component Editor in its Batch Component Editing mode. While you can use this mode to edit a single component (as shown), its power really comes when editing multiple components that share the same parameters and models.

Referencing a Component Template

Related page: Managed Component Templates

Helping to streamline the creation of your managed components, Altium NEXUS, in conjunction with your managed content server, supports the use of Component Templates. Just as a schematic template can be used to predefine information on schematic sheets that reference it, a component template is referenced by a managed component, and provides predefined settings for use when defining that component.

Using a revision of a Component Template Item - or rather referencing one from the revision of a Component Item you are currently editing - can be performed in the following ways.

A component can only reference one component template at a time.

Manually from within the Component Editor

Reusing a revision of a Component Template Item from the Component Editor, depends on the operating mode of the Editor.

In Single Component Editing Mode

When editing a single component in this mode of the Component Editor, choose the required Component Template from the drop-down menju associated to the Template field - part of the Advanced Settings grouping, in the Component region of the Editor. All Component Template Items currently available in the same managed content server in which the Component Item itself resides are listed - by name - with their latest revisions indicated in brackets. Choose the required template to have it applied.

Quickly linking a Component Template Item from a menu of all available templates, when editing the revision of a Component Item using the Component Editor in its Single Component Editing mode.

In Batch Component Editing Mode

There are two ways of 'hooking up' a revision of a Component Template Item, to the Component Item Revision currently being edited:

  • From the Template tab of the Document Options dialog (Edit » Document Options). Click the Choose button to the right of the Item Revision field. This gives access to the Choose Item dialog (an incarnation of the Explorer panel). Use this dialog to browse to, and select the revision of the required Component Template Item. After clicking OK, a link will be created between the revision of the Component Item and the target revision of the Component Template Item. Evidence of this link can be seen back on the Template tab of the Document Options dialog.

Manually linking a component to a revision of a Component Template Item, in the target Server.

The Component Template Item being used can be changed at any time - click Choose and select a revision of a different Component Template Item.
The status of the linked Component Template Item Revision is reflected on the Template tab of the Document Options dialog. If a newer revision of the linked Item is available, click the  button, to use that latest revision.
  • From the Add menu associated with the Required Models/Parameters region of the Component Editor. The Templates sub-menu lists all Component Template Items - by name - currently available in the same managed content server in which the Component Item itself resides, with their latest revisions indicated in brackets. Click on an entry to create a link to the latest revision of that Component Template Item. Once again, verification of the link can be seen on the Templates tab of the Document Options dialog.

Quickly linking a Component Template Item from a menu of all available templates.

Inherited from the Components Server Folder

You can specify a Component Template Item to be automatically used for all Component Items (and revisions thereof) stored within a Components folder within the Server.

A default Component Template Item can only be defined for a folder of type Components.

Specify the required template using the Component Template field, when defining the folder's properties, in the Edit Folder dialog. The field's associated drop-down lists all Component Template Items - by name - currently available in the same managed content server in which the Components folder itself resides, with their latest revisions indicated in brackets. Choose an entry to create a link to the latest revision of that Component Template Item, for each subsequent Component Item created within that folder.

Specify a default Component Template Item, to be applied to all Component Items created within the parent Components folder.

To not use this feature, leave/set the Component Template field to None.

If a Component Template is chosen at the folder level, that same template will be used, by default, when Component Items are created in child sub-folders below. This facilitates quick template inheritance to all Items in child folders.

When a revision of a Component Item is released, it will essentially lock-in the specific revision of the Component Template used - creating a strong link to that revision, unless changed manually.

Impact on Component Models and Parameters when using a Component Template

When editing a revision of a Component Item, and a revision of a Component Template Item is linked to/referenced, the following happens within the Component Editor, with respect to models and parameters:

  • The models defined within the referenced template are added to the Models region (Single Component Editing mode) and Model Links region (Batch Component Editing mode).
  • An existing referenced model will be kept, and the component will remain using that model, unless purposefully changed manually.
  • The parameters defined within the referenced template are added to the Parameters region (Single Component Editing mode) and Required Models/Parameters region (Batch Component Editing mode).

Example of parameters after linking to a revision of a Component Template Item, when using the Component Editor in Single Component Editing mode (left) and Batch Component Editing mode (right).

All parameters originating from the referenced Component Template Item are distinguished by use of the  icon (Single Component Editing mode) and  icon (Batch Component Editing mode). In addition, and for Batch Component Editing mode only, the Show option for each template-based parameter follows the state of the corresponding Visible option in the template.
Template-based parameters cannot be removed.
You are free to add additional user-parameters as required.
  • An existing user-defined parameter that has the same name as a parameter in the linked Component Template Item, will be replaced with the template version. Any existing value for that parameter will be kept (and not overwritten with the value in the template).
  • In Batch Component Editing mode only, template-based parameters that are set to be shown are grouped together in the component definitions area of the editor, with Template Parameters used as the header text.

Appearance of example template-based parameters in the area where the component definitions themselves are defined, when using the Component Editor in its Batch Component Editing mode.

  • The value fields for template-based parameters that have been marked as read-only, will be non-editable. For all other template-based parameters, that have not been marked as read-only, you are free to change the values as required.
With the Component Editor in Single Component Editing mode, a Read-only template parameter is distinguished in the Parameters region by use of the  icon.
  • If a template-based parameter has been marked as required, but has not been given a value in the template, its value field will appear with a red border (in Batch Component Editing mode) or containing the  icon (in Single Component Editing mode), alerting you to the fact that a value is required for this parameter. You will not be able to release a component until values are defined for all required parameters.
With the Component Editor in Single Component Editing mode, a required template parameter is distinguished in the Parameters region by use of the  icon.

Parameter List Templates

If you are not using Component Template Items, you can still create predefined listings of parameters through the Component Editor's support for customizable Parameter List Templates. These simple, humanly-readable files can be built with a list of required parameters, that can then be loaded into the editor with a single click.

Parameter List Templates are only supported for use with the Component Editor in its Batch Component Editing mode.
Component Templates offer a far more powerful approach to organizing not only a set of parameters, but also required models and the ability to define component types. In addition, it is only through Component Templates that you can define unit-aware parameters for your components, which are needed for the advanced component searching functionality. To this end, if you have at least one Component Template Item present in your managed content server, the parameter list templates functionality will be disabled, and you will not be able to see and load these templates into the Component Editor.

Parameter list templates can be found in the Templates sub-menu - accessed by clicking the Add control at the bottom of the Required Models/Parameters region. A number of predefined templates are available, covering parameter sets associated with capacitors (Capacitor), resistors (Resistor), diodes (Diode) and transistors (Transistor).

Access parameter templates from the menu associated to the region's Add control.

Click on the template you wish to use - the parameters defined within that template will be added to the region.

Adding a set of parameters for use by your component(s) is expedited through the use of parameter templates.

Template Definition

A parameter template is defined in a Component Library Template file (*.cmplib_template). To be recognized by the system, and therefore appear in the Templates sub-menu within the Component Editor, these files must reside in the Templates folder of your Altium NEXUS installation (\Users\Public\Documents\Altium\AD<VersionNumber>\Templates for a default installation).

The template definition is straightforward, consisting of the name for the template (as it is to appear in the sub-menu) enclosed in square brackets, followed by a listing of the required parameters, in the format <ParameterName>=. By way of example, the predefined template for resistors - resistor.cmplib_template - has the following definition:

[Resistor]
Category=
Manufacturer=
Manufacturer Part Number=1
Mounting Type=
Temperature=
Package Type=
Package Reference=
RoHS=
Temperature Coefficient=
Tolerance=
Weight=
Height=
Value=
Power=
Resistance=
Composition=

The '=' sign is required to have the parameter added to the list of Required Models/Parameters when the template is used. If it is removed in the template file, leaving just the parameter name, it will be excluded when the parameters are added.
Any number of parameter templates may be defined within a single template file. This can be seen in the file group.cmplib_template, which contains the templates for capacitors and diodes.
If the same template ([<TemplateName>]) is defined more than once in the same .cmplib_template file, only the first instance will be used. The software also ensures that there is no duplication of parameters, where parameters from more than one templates are added. If a parameter to be added is already existing with exact matching name, it is ignored when that template is loaded.

Re-releasing a Component Item

At any stage, you can come back to any revision of a Component Item in the server, and edit it directly:

  • From the Components panel - right-click on the entry for a managed component and choose the Edit command from the context menu.
  • From the Explorer panel - right-click on the revision and choose the Edit command from the context menu.

Once again, the temporary Component Editor will open - in its Single Component Editing mode - with the component definition contained in the revision opened for editing. Make changes as required, then commit the release of the component into the next revision of the item.

Right-clicking on the top-level entry for an Item itself, in the Explorer panel, will edit the latest revision of that Item.

Accessing the command to launch direct editing of an existing revision of a Component Item - either from the Components panel, or the Explorer panel.

If you have selected multiple components to edit in the Components panel, then a separate temporary Component Editor instance will open for each, and in Single Component Editing mode. If you have selected multiple revisions of Component Items to edit in the Explorer panel, the temporary Component Editor will open in its Batch Component Editing mode.

Downloading Component Source

You also have the ability to download one or more components from your managed content server, into a Zip archive file containing source symbol and model libraries, and a source Integrated Library Package (*.LibPkg). This could be used to quickly generate an integrated library containing your chosen component(s). And when placing components from such an Integrated Library, the actual links are back to the Component Items in the server. This gives you the ability to effectively use your company's managed components in an offline fashion, while ensuring the design still maintains a true connection to those components in the source managed content server.

To be able to use this functionality in Altium NEXUS, you will need to enable the use of legacy, unmanaged component management methodologies. Use of unmanaged content is disabled by default in Altium NEXUS, as it is not recommended. You can restore this functionality by enabling the Legacy.UnManagedLibraries option in the Advanced Settings dialog - accessed by clicking the  button, on the System - General page of the Preferences dialog. You will need to restart Altium NEXUS for the change to this setting to take effect.

From the Components panel, the process to download into a Zip file is as follows:

  1. Browse to/filter your managed components using the panel's various features (Categories, faceted parametric filtering, etc).
  2. Select the managed component(s) you want to inlcude in the download. You can include as many different managed components in the download as required.
  3. Right-click on an entry in the selection and choose the Operations » Download command from the context menu.
  4. In the Save As dialog, specify the name, and location, for the generated Zip file. By default, the file will be named in the format Components - <Date> - <Time>.zip.
  5. Once ready, click the Save button to proceed with the download, and generation of the Zip file. An Integrated Library Package (*.LibPkg) will be created, with source SchLib (with symbols, parameters and model links) and PcbLib (with footprint models) files generated and added. This is then compressed into the Zip file, which is generated in the specified folder. An information dialog will confirm successful generation of the file.

From the Explorer panel, the process to download into a Zip file is as follows:

  1. Browse to the folder containing the component(s) you want to download.
  2. Select the revision of the Component Item(s) you want to inlcude in the download. You can only choose one revision of a particular Component Item (typically the latest revision), but can include as many different Component Items in the download as required.
  3. Right-click on an entry in the selection and choose the Operations » Download command from the context menu (if downloading multiple components, the command will appear as Operations » Download selected component to zip).
  4. In the Save As dialog, specify the name, and location, for the generated Zip file. By default, the file will be named in the format Components - <Date> - <Time>.zip.
  5. Once ready, click the Save button to proceed with the download, and generation of the Zip file. An Integrated Library Package (*.LibPkg) will be created, with source SchLib (with symbols, parameters and model links) and PcbLib (with footprint models) files generated and added. This is then compressed into the Zip file, which is generated in the specified folder. An information dialog will confirm successful generation of the file.

Example download (albeit a single component!) into a Zip file, in this case from the Components panel.

Migrating Existing Model Libraries

Main page: Streamlined Migration of Existing Libraries to Your Managed Content Server

Altium NEXUS, in conjunction with your managed content server, provides a streamlined, simple process to quickly migrate your existing libraries to that server. The GUI to this process - the Library Migrator view - presents an intuitive flow that takes initial selected libraries, and migrates them to a target managed content server. Catering for all types of libraries relating to older component management methodologies - SCHLIB, PCBLIB, INTLIB, DBLIB, SVNDBLIB - the Library Migrator is the perfect solution to quickly building your company's set of server-based managed components, and the many benefits that such components enjoy (high-integrity, lifecycle management, centralized storage and management, where-used functionality, ease of design resuse). And while the migration process can be configured - giving you enhanced control over how that migration is performed - at its most simplistic, you can accept the default settings and set the migration in motion within a matter of clicks.

Access the Library Migrator from any editor by choosing the File » Library Migrator command from the main menus.
While access to the Library Migrator is available in Altium NEXUS, should you wish to access an unmanaged library to make pre-migration tweaks, or access the Available Libraries list, you will need to enable the use of legacy, unmanaged component management methodologies. Use of unmanaged content is disabled by default in Altium NEXUS, as it is not recommended. You can restore this functionality by enabling the following option in the Advanced Settings dialog - accessed by clicking the  button, on the System - General page of the Preferences dialog:
  • Legacy.UnManagedLibraries

You will need to restart Altium NEXUS for the change to this setting to take effect.

All information that is present in an original source library is migrated, in order to arrive at a folder of unified components (managed components that have assigned part choices), with all referenced domain models (schematic symbols, PCB footprints, Simulation Models), and parametric information. Component templates can even be created, and used to create those managed components. And if your original components have multiple PCB footprints defined, you can rest assured that the Library Migrator will bring those models across, and keep the current default footprint too.


The Library Migrator view - the user interface to the component migration process.

While migration may seem daunting, the defaults have been defined to enable you to get your collection of managed components without having to change a thing - start the process and design with the fruits of the Migrator's labor. The system conducts and handles a number of validations, for example to ensure no duplicate IDs for the resulting managed components, or to ensure no duplicate models or component templates are created, and that such entities are reused across (linked to) components where needed. And if issues do arise, the system flags them, with suggestions on how to resolve those issues, aiming to get the migration back on track as quickly, and as smoothly as possible.
Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

You are reporting an issue with the following selected text
and/or image within the active document:
Altium Concord Pro Free Trial

Please Complete the form below to get Free Trial of Altium Concord Pro