Altium NEXUS Documentation

Board Region

Modified by Susan Riege on Apr 10, 2021

Parent page: PCB Objects

The Board Region for a traditional rigid board, with two Board Cutouts.

Summary

A Board Region is a user-defined area of a PCB that can have a unique layer stack assigned to it. A PCB can have a single Board Region (for a traditional rigid PCB), or be made up of multiple Board Regions (for a rigid-flex PCB). The overall outer edge of the Board Region(s) defines the Board Shape.

Availability

Board Regions are implemented in the PCB Editor with the View mode set to Board Planning Mode (View » Board Planning Mode, or press the 1 shortcut).

Placement

The video demonstrates creating the Board Shape from selected objects and then slicing the shape to create the three regions needed.
Then it shows an alternate approach, where the three Board Regions are defined from selected objects.

Board Regions are placed and modified in Board Planning Mode:

  1. Select View » Board Planning Mode (or press the 1 shortcut) to enter Board Planning Mode. The default existing Board Region will display as a green rectangle.
  2. Select Place » Board Region to place a new region (or click the  button on the Active Bar).
  3. Position the cursor and click to anchor the starting vertex for the Board Region. The Board Region is a polygonal object, like a Region or Polygon, and has the same placement process.
  4. Move the cursor ready to place the second vertex. The default behavior is to place 2 edges with each click with a user-defined corner shape between them, press the Spacebar to toggle the corner direction. Refer to the Placement Modes section below for more details on changing corner modes.
  5. Continue to move the mouse and click to place vertices, creating the edges required to define the overall shape of the Board Region.
  6. After placing the final vertex, right-click or press Esc to close and complete the definition of the board shape. There is no need to manually close the board shape as the software will automatically complete the shape by connecting the last point placed back to the start point.
  7. Each Board Region is named to uniquely identify it. Enter a suitable name in the Name field in the Board Region mode of the Properties panel (the Board Region must be selected in the design space to display its properties in the panel).
  8. Each Board Region must have a layer stack assigned. When a new Board Region is created it will be assigned the default layer stack, named Board Layer Stack. Assign the required Layer stack in the Board Region mode of the Properties panel. Layer stacks are defined and named in the Layer Stack Manager.
  9. If the final PCB requires multiple Board Regions, continue to define additional regions.
  • Each region displays a label that shows the region name and the name of the layer stack assigned to it in the form Region Name - Layer Stack Name. The Board Region is named in the Board Region mode of the Properties panel, and the Layer Stack is named in the Layer Stack Manager.
  • Any number of Board Regions can be placed to build up the required Board Shape. Board Regions can overlap, note that this does not define the distance that one region intrudes into its neighbor region, that is defined as part of the layer stack configuration in the Layer Stack Manager.
  • To remove a Board Region, select it then press the Delete key on the keyboard. There must always be at least one Board Region, you will not be able to delete the last one.
  • As well as drawing the Board Region, they can also be created from primitives - learn more in the Converting between 2D Drawing Primitives and Board Definition Objects section of this page.
  • Board Regions can also be created from 3 Body objects by using the Create Board Region from 3D Body command while in 3D mode. 
  • During placement of a Board Region the cursor is constrained by the cursor snap settings, which includes: the current Snap Grid, the available Objects for Snapping, the presence of Workspace Guides, and the Axes Snapping settings - use these features to help achieve the required shape.

Learn more about Understanding the Snap Behavior.

Placement Modes

When redefining the board shape there are five available corner modes, four of which also have corner direction sub-modes. During redefinition:

  • Press Shift+Spacebar to cycle through the five available corner modes.
  • Press Spacebar to toggle between the two corner direction sub-modes.
  • When in either of the arc corner modes, hold the  key to shrink or the key to grow the arc. Hold the Shift key as you press to accelerate arc resizing.
  • Press the 1 shortcut key to toggle between placing two edges per click, or one edge per click. In the second mode, the dashed edge is referred to as the look-ahead segment (as shown in the last image in the set below).
  • Press the Backspace key to remove the last vertex.

Press Shift+Spacebar to cycle through the five available corner modes, press the 1 shortcut to toggle placement between two edges or one edge.

Creating a Board Cutout Region

To create an internal cutout in the board, place a Board Cutout Region (Place » Define Board Cutout, or click the  button on the Active Bar). A Board Cutout is also a polygonal object, so has the same placement process as the Board Region itself. The images below show a Board Region with two Board Cutouts, these become holes in the board when it is fabricated.

A Board Cutout placed on a Board Region becomes a hole in the finished board.

Slicing a Board Region

An existing Board Region can be sliced into two separate Board Regions. To slice a region (in Board Planning Mode):

  • Select the Design » Slice Board Region command (or click the  button on the Active Bar).
  • Slicing behavior is the same as track (or polygon boundary) placement behavior, there are five corner modes. Press Shift+Spacebar to cycle through the corner modes and Spacebar to toggle the corner direction.
  • Slicing must start and end on an edge or outside of the Board Region.
  • When you right-click to end the slicing command the Confirm dialog will appear (as shown below), after clicking Yes the Board Region will be split into two Board Regions.
  • Move or reshape the Board Regions as required, and assign a suitable Name and Layer Stack in the Properties panel.

The video above demonstrates slicing the Board Shape to create three Board Regions needed in a rigid-flex design.

Converting between 2D Drawing Primitives and Board Definition Objects

A common approach to defining the Board Shape, and the Board Regions needed in that shape, is to import a drawing from a mechanical CAD package. For example, you might import mechanical detail in a DWG file, giving you a set of lines (tracks) on a mechanical layer that define: the board shape, the regions within the shape, and for a rigid-flex design, lines that define the location of bend lines in the flexible regions.

The software includes a number of commands to help create board definition objects (Region, Cutout, Bend Line) from 2D drawing primitives, and also partner commands to convert board definition objects back to drawing primitives.

Object From selected 2D Drawing Primitives From Board Design Objects
Board Region Create Board Region from Selected Objects
( Design » Board Shape submenu)
Explode Region to Free Primitives
Board Cutout Create Board Cutout from Selected Primitives Explode Board Cutout to Free Primitives
Bend Line Convert Selected Line to Bend Line Explode Bend Line

Notes:

  • Commands for both directions are available in the Tools » Convert submenu of the relevant View mode (apart from the Create Board Region from Selected Objects command, which is in the Design » Board Shape submenu).
  • To convert 2D drawing primitives to board definition objects, switch the view to 2D Layout Mode.
    • The primitive(s) must be selected before running the command.
    • The primitives must form a closed shape to create a Region or Cutout. Check the warning box below to learn more about the requirements of this shape.
  • To convert board definition objects to 2D drawing objects, switch the view to Board Planning Mode.
    • These commands do not require the object(s) to be pre-selected but will act on the selected object if one is already selected.
    • If there are multiple Board Regions present, the Region disappears when it is exploded to primitives. If there is only one Board Region present, the primitives will be created and the chosen Board Region will remain (there must always be one Board Region).
    • 2D drawing objects are created on the Board Shape layer. If a layer of this Layer Type does not exist in the board, a mechanical layer will be added with its Layer Type set to Board Shape. Learn more about Mechanical Layers and Layer Types.

Learn more about the Board Shape

All of the commands that create a polygonal shape based on an outline constructed from lines (tracks) and arcs, will attempt to find the shape by following the centerline of the selected objects. If the coordinates for the end of one track/arc segment do not exactly match the coordinates of the next track/arc segment then the boundary identification algorithm will fail and a message will be displayed showing the failure location. It will then offer to use a tracing algorithm instead. Note that the tracing algorithm follows the outer edge of the track/arc objects so the shape will be slightly different than the one created from the centerlines, only choose this option if your design can accept the impact of this difference.

Graphical Editing

Related article: Editing Polygonal Objects

Board Regions (and Board Cutouts) are polygonal objects, their shape can be modified in the same way as all other polygonal objects. Points to remember about editing a polygonal object:

  • When you click and drag on a vertex or polygon edge there are 3 reshaping modes available, sliding, breaking, and incurvating - press Shift+Spacebar to cycle through the modes as you are dragging. The current mode is displayed on the Status bar and in the Heads-Up display.
  • The cursor snapping behavior is controlled by the current cursor snap settings, which include the current Snap Grid, the available Objects for Snapping, the presence of Workspace Guides, and the Axes Snapping settings - use these features to help you achieve the required shape. Learn more about Understanding the Snap Behavior.

Non-Graphical Editing

The following methods of non-graphical editing are available:

Editing Via the Properties Panel

Properties page: Board Region Properties

This method of editing uses the associated Board Region dialog and Properties panel to modify the properties of a Board Region object.

The Board Region dialog on the left and the Board Region mode of the Properties panel on the right.

During placement, the Board Region mode of the Properties panel can be accessed by pressing the Tab key. Once the Board Region has been placed, all options appear.

After placement, the Board Region dialog can be accessed by:

  • Double-clicking on the placed Board Region object.
  • Placing the cursor over the Board Region object, right-clicking then choosing Properties from the context menu.

After placement, the Board Region mode of the Properties panel can be accessed in one of the following ways:

  • If the Properties panel is already active, by selecting the Board Region object.
  • After selecting the Board Region object, select the Properties panel from the Panels button in the bottom right section of the design space, or by selecting View » Panels » Properties from the main menu.

If the Double Click Runs Interactive Properties option is disabled (default) on the PCB Editor - General page of the Preferences dialog, when the primitive is double-clicked or you right-click on a selected primitive then choose Properties, the dialog will open. When the Double Click Runs Interactive Properties option is enabled, the Properties panel will open.

While the options are the same in the dialog and the panel, the order and placement of the options may differ slightly.

Press Ctrl+Q to toggle the units of measurement currently used in the panel between metric (mm) and imperial (mil). This only affects the display of measurements in the panel, it does not change the measurement unit specified for the board - this is configured in the Units setting in the Properties panel when there are no objects selected in the editing design space.

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
You are reporting an issue with the following selected text
and/or image within the active document:
ALTIUM DESIGNER FREE TRIAL
Altium Designer Free Trial
Let’s get started. First off, are you or your organization already using Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

In that case, why do you need an evaluation license?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You actually don’t need an evaluation license for that.

Click the button below to download the latest Altium Designer installer.

Download Altium Designer Installer

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Please fill out the form below to get a quote for a new seat of Altium Designer.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

If you are on Altium Subscription, you don’t need an evaluation license.

If you are not an active Altium Subscription member, please fill out the form below to get your free trial.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Why are you looking to evaluate Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

You came to the right place! Please fill out the form below to get your free trial started.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

That’s great! Making things is awesome. We have the perfect program for you.

Upverter is a free community-driven platform designed specifically to meet the needs of makers like you.

Click here to give it a try!

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.