Altium NEXUS Documentation

Coordinate

Modified by Admin on Apr 11, 2017
All Contents

Parent page: PCB Objects

A placed Coordinate.

Summary

A coordinate is a group design object. It is used to mark the X (horizontal) and Y (vertical) distance of a point in the design workspace relative to the current origin. Coordinates can be placed on any layer.

Availability

Coordinates are available for placement in both PCB and PCB Library Editors:

  • PCB Editor - the following methods of access are available:
    • Choose Place » Coordinate from the main menus.
    • Click the  button on the Utility Tools drop-down () of the Utilities toolbar.
  • PCB Library Editor - the following methods of access are available:
    • Click the  button on the PCB Lib Placement toolbar.
    • Right-click in the workspace and select Place » Coordinate from the context menu.

Placement

After launching the command, the cursor will change to a cross-hair and you will enter coordinate placement mode. A coordinate will appear "floating" on the cursor:

  1. Position the cursor and click or press Enter to place a coordinate.
  2. Continue placing further coordinates, or right-click or press Esc to exit placement mode.

Additional actions that can be performed during placement are:

  • Press the L key to flip the coordinate to the other side of the board.
  • Press the + and - keys (on the numeric keypad) to cycle forward and backward through all visible layers in the design respectively – to change placement layer quickly.
  • Press the Tab key to access an associated properties dialog, from where properties for the coordinate can be changed on-the-fly.
While attributes can be modified during placement (Tab to bring up associated properties dialog), bear in mind that these will become the default settings for further placement unless the Permanent option on the PCB Editor – Defaults page of the Preferences dialog is enabled. When this option is enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement session.

Graphical Editing

This method of editing allows you to select a placed coordinate object directly in the workspace and change its location graphically. The size and shape of a coordinate object cannot be changed graphically. As such, editing handles are not available when the coordinate object is selected:

A selected Coordinate.

  • Click anywhere on the coordinate and drag to reposition it. The position values are automatically updated as the coordinate is moved.

If attempting to graphically modify an object that has its Locked property enabled, a dialog will appear asking for confirmation to proceed with the edit. If the Protect Locked Objects option is enabled on the PCB Editor – General page of the Preferences dialog, and the Locked option for that design object is enabled as well, then that object cannot be selected or graphically edited. Double click on the locked object directly and disable the Locked property or disable the Protect Locked Objects option, to graphically edit the object.

Non-Graphical Editing

The following methods of non-graphical editing are available:

Editing via an Associated Properties Dialog

Dialog page: Coordinate

This method of editing uses the following dialog to modify the properties of a coordinate object.

The Coordinate dialog.

The Coordinate dialog can be accessed prior to entering placement mode, from the PCB Editor – Defaults page of the Preferences dialog. This allows the default properties for the coordinate object to be changed, which will be applied when placing subsequent coordinates.

During placement, the dialog can be accessed by pressing the Tab key.

After placement, the dialog can be accessed in one of the following ways:

  • Double-clicking on a placed coordinate object.
  • Placing the cursor over a coordinate object, right-clicking and choosing Properties from the context menu.
  • Using the Edit » Change command and clicking once over a placed coordinate object.

Quickly change the units of measurement currently used in the dialog between metric (mm) and imperial (mil) using the Ctrl+Q shortcut. This affects the dialog only and does not change the actual measurement unit employed for the board, as determined by the Measurement Unit setting in the Board Options dialog (Design » Board Options).

Via an Inspector Panel

Panel page: PCB Inspector, PCB Filter, PCBLIB Inspector, PCBLIB Filter

An Inspector panel enables the designer to interrogate and edit the properties of one or more design objects in the active document. Used in conjunction with appropriate filtering - by using the applicable Filter panel, or the Find Similar Objects dialog - the panel can be used to make changes to multiple objects of the same kind, from one convenient location.

Via a List Panel

Panel page: PCB List, PCB Filter, PCBLIB List, PCBLIB Filter

A List panel allows the designer to display design objects from one or more documents in tabular format, enabling quick inspection and modification of object attributes. Used in conjunction with appropriate filtering - by using the applicable Filter panel, or the Find Similar Objects dialog - it enables the display of just those objects falling under the scope of the active filter – allowing the designer to target and edit multiple design objects with greater accuracy and efficiency.

Tips

  1. In the PCB Editor, the current origin can be set to be any point in the PCB workspace by selecting Edit » Origin » Set, and clicking on the location for the new origin. To set the current origin back to the absolute origin ((0,0) in the lower-left corner of the workspace), select Edit » Origin » Reset.
  2. The coordinate group object is comprised of a string specifying the actual X,Y position and a point marker (small cross of two tracks) . In the PCB Editor, a coordinate can be converted to its constituent primitive objects using the Tools » Convert » Explode Coordinate to Free Primitives command. Explode a coordinate to reposition the position string without changing the location of the marker.

 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
You are reporting an issue with the following selected text
and/or image within the active document:
ALTIUM DESIGNER FREE TRIAL
Altium Designer Free Trial
Let’s get started. First off, are you or your organization already using Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

In that case, why do you need an evaluation license?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You actually don’t need an evaluation license for that.

Click the button below to download the latest Altium Designer installer.

Download Altium Designer Installer

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Please fill out the form below to get a quote for a new seat of Altium Designer.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

If you are on Altium Subscription, you don’t need an evaluation license.

If you are not an active Altium Subscription member, please fill out the form below to get your free trial.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Why are you looking to evaluate Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

You came to the right place! Please fill out the form below to get your free trial started.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

That’s great! Making things is awesome. We have the perfect program for you.

Upverter is a free community-driven platform designed specifically to meet the needs of makers like you.

Click here to give it a try!

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.