Altium NEXUS Documentation

PDF3D Exporter

Modified by Jason Howie on Mar 29, 2018
All Contents

Altium NEXUS users have long enjoyed the ability to interactively view PCB designs in fully rendered 3D, which provides a unique insight into the real structure of the board design, its components and associated mechanical parts.

There are significant advantages in being able to bring this 3D capability to those outside the immediate design team, such as fabrication and assembly houses, and not in the least, customers. This is made possible through the use of Altium NEXUS's PDF 3D export capability. This interactive 3D format is accessible for everyone with a recent version of the ubiquitous Adobe® Acrobat® Reader.


Interactively view an exported 3D design in Adobe Reader – zoom, rotate and select what design elements you'd like to see.

3D in Acrobat Reader

Interactive 3D viewing became possible for PDF files with the introduction of advanced 3D view capabilities in Acrobat Reader, starting with Version 7. Progressively enhanced through subsequent versions of the Acrobat Reader, the high-level detail and configuration options produced by Altium NEXUS’s PDF 3D export is compatible with versions 9 and above.

The foundation of this new 3D capability is the industry-developed Universal 3D (U3D) format for computer graphic files, which has been standardized by the European Computer Manufacturers Association (ECMA) as Standard ECMA-363 - Universal 3D File Format. U3D is natively supported by the PDF format and can be simply embedded (and compressed) in a PDF file for interactive 3D viewing in Acrobat Reader.

The result is a modestly sized, cross-platform 3D file format that does not require specialized 3D viewing software. In the case of PDF 3D files exported from Altium NEXUS, the embedded content includes the majority of the data viewable in Altium NEXUS’s own 3D view – including all tracks, pads, vias, polygons etc, all components, and the full set of board layers.

Export 3D Extension

The PDF 3D export capability is enabled in Altium NEXUS with the installation of the PDF3D Exporter extension.

This extension is installed by default when installing the software, but in case of inadvertent uninstall, can be found back on the Purchased tab of the Extensions & Updates page (click on the  control at the top-right of the workspace and choose Extensions and Updates from the menu). Click  to download the extension, and then restart Altium NEXUS when prompted. Once installed and ready to use, the extension will appear on the Installed tab of the Extensions & Updates page.

Generating a PDF

To export a PDF 3D file, open the desired PCB design document in the workspace and choose the File » Export » PDF3D command from the main menus.

As distinct from a fixed view of a board 3D design, from a particular angular perspective, the new PDF 3D export is notionally equivalent to Altium NEXUS’s own interactive 3D view. 

As such, the resulting PDF 3D export offers the same rotate, zoom and pan capabilities and can adopt any of the color schemes defined by the active View Configuration. To examine or edit the current configuration, and therefore the available rendering colors for the exported PDF, switch to viewing the board in 3D (keyboard shortcut: 3) and open the View Configuration panel. The rendering colors can be viewed in the 3D Settings section, on the panel's View Options tab.

The View Options tab of the View Configuration panel can be quickly accessed using the Ctrl+D keyboard shortcut.

A PDF 3D file will be created in 3D format, regardless of current PCB editor view mode (2D or 3D).

Export Options

Once the PDF 3D export has been instigated (File » Export » PDF3D) and a target file name/location nominated in the standard Windows-based Export File dialog, the Export 3D dialog opens to allow the rendering, behaviour and included design content to be defined for the PDF.


The Export 3D dialog allows you to configure how the exported PDF will look and behave.

Use the Export 3D dialog to configure export options as required, then click the Export button to generate the 3D PDF file.

3D files can be large, even with the format’s inherent data compression, so consider what level of design content is important for the target user. For example, the content of the copper layers (tracks, pads, etc) may not be required by someone looking at the mechanical aspects of a board design.

Note that Acrobat Reader allows users to toggle the display of model elements (in groups, or individually) to suit their own needs – see below.

When making the choice of included 3D content, it is also worth considering the 3D rendering capabilities of the viewer's PC. While the resulting PDF 3D file size might be reasonable, the target machine's CPU and graphics system may struggle to fluidly render a complex multi-layer design.

The above options define the initial settings when the PDF is opened in Acrobat Reader, and can be easily altered to taste from the reader’s 3D toolbar. Note that if the toolbar is disabled in the PDF 3D export options, the user will not be able to change the view.

Viewing a 3D PDF

As you would imagine, viewing a 3D PDF in Acrobat Reader is quite straightforward, with commands and menus that are logical extensions of the familiar 2D functions.

The 3D objects can be panned, zoomed and rotated using simple mouse drag and scroll-wheel operations, with functions selected from the floating 3D toolbar.


Acrobat's 3D toolbar provides controls for 3D navigation and lighting/view settings.

A feature of particular value in the reader is the Model Tree navigation pane, which can opened (if not already) with the button. This allows the user to navigate through all objects in the 3D PDF, select and highlight those of interest while toggling their visibility.


The Model Tree navigation panel is particularly useful
for controlling the display of specific components and nets.

The Model Tree navigation pane offers a powerful way to examine all aspects of a 3D design to a high degree of detail. Whether it’s a close examination of the component positioning and layout, or a detailed inspection of the internal board structure, the navigation tree can be used to find and display the appropriate objects.


The design displayed with components and board overlays deselected, illustrating the degree of 3D control available in Acrobat Reader.

When selected in the Model Tree pane, individual objects are highlighted in the view window with the color defined at the top of the pane (red in this case). This makes locating a particular component or net simple, and avoids the need to toggle an object's visibility to find its location. Similarly, selecting an object in the 3D view window highlights its entry in the Model Tree pane.

For more information on using the various controls, functions and settings in Acrobat Reader see the relevant Adobe help content: Displaying 3D Models in PDFs.

Basic design metadata from Altium NEXUS is also included in an exported PDF 3D document. The data includes the design source file, its author, the Altium NEXUS version, creation/modification dates, etc. The information can be viewed in Adobe Reader under the Description tab in the Document Properties dialog – File » Properties.

PDF 3D OutJob export

To include a PDF 3D file export in a project OutJob, click Add New Documentation Output under the Documentation Outputs entry, select PDF3D and then the desired document source - either a specific PCB document to export (or [PCB Document] to keep the OutJob generically reusable).

Adding a PDF3D output generator to an Output Job Configuration file.

The PDF 3D generation settings can be pre-configured by selecting the entry for the output generator, right-clicking and choosing Configure from the context menu. This opens the Export 3D configuration dialog (as outlined previously).

When the Output Job is run or manually instigated, the PDF 3D file will be exported as defined in the OutJob's Output Containers section. This is to the configured managed content server and path, or the local/remote publishing target defined on the Data Management – Publishing Destinations page of the Preferences dialog.


Generating a 3D PDF file to a defined PDF output container, from within a configured OutJob.

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

You are reporting an issue with the following selected text
and/or image within the active document:
ALTIUM DESIGNER FREE TRIAL
Altium Designer Free Trial
Let’s get started. First off, are you or your organization already using Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

In that case, why do you need an evaluation license?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You actually don’t need an evaluation license for that.

Click the button below to download the latest Altium Designer installer.

Download Altium Designer Installer

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Please fill out the form below to get a quote for a new seat of Altium Designer.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

If you are on Altium Subscription, you don’t need an evaluation license.

If you are not an active Altium Subscription member, please fill out the form below to get your free trial.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Why are you looking to evaluate Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

You came to the right place! Please fill out the form below to get your free trial started.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

That’s great! Making things is awesome. We have the perfect program for you.

Upverter is a free community-driven platform designed specifically to meet the needs of makers like you.

Click here to give it a try!

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.