全新功能及更新概览

Modified by Jun Chu on May 8, 2018

FPGA Pin Mapper

当前的FPGA Pin Mapper为测试版本。

开发FPGA引脚映射功能的目的在于加速实现PCB布局中引脚可编程器件最佳拓扑结构的过程。此功能提供了一种通过csv引脚报告/信息文件的通用格式在FPGA(或微控制器)与PCB域之间交换引脚/网络定义数据的交互式机制。

此功能在Altium NEXUS作为Pin Mapper对话框提供,允许在原理图元件与FPGA工具生成的外部*.csv引脚信息文件之间指定链接。Altium NEXUS将检测对该文件所做的任何更改并提供一系列引脚数据同步选项,包括更新外部文件以匹配Altium NEXUS中网络引脚名称的选项。

因此,域之间的引脚数据交换是双向的,提供了一种通过引脚交换实现FPGA引脚布局的迭代协作方法,同时避免了在域之间人工传递引脚数据的错误。

►有关使用引脚映射功能的概述,请参阅FPGA Pin Mapper快速指南

更新

在原理图编辑器中创建差分对组

目前,通过在属性面板中将新的Diff.PairNetClass组类添加到差分对指令中可在原理图层定义专用的差分对组

当通过工程变更指令(ECO)传递到PCB时,该组可用作差分对组,以适用于PCB差分对布线规则。 在Options for PCB project对话框(Project » Project Options)的ComparatorECO选项卡中可指定对差分对网络组的处理控制。

改进了背钻孔支持

Altium NEXUS中受控深钻孔或背钻孔已改进为支持任何指定背钻孔对的PCB过孔短截线清除技术。随着允许从板表面背钻孔至任何内层,目前此过程及其“设计规则”可识别与多边形、填充和区域等敷铜对象之间的层连接。

3D模型的中心捕捉

为了提高PCB设计中定位3D模型的方便性和准确性,新增了对一系列3D模型新捕捉点放置选项的支持。增强版的捕捉位置选项还改进了测量3D对象中临界跨距的功能。

其他捕捉点包括:

  • 所有孔中心。
  • 围绕孔圆的90°位置(与正交轴的交叉点)。
  • 边界线的中点。
  • 两个捕捉点间连线的中心点(空格键模式)。
  • 模型的本体轴线。

导出无自由模型的3D板

在将板设计的3D模型导出至MCAD域时,可能需要排除自由放置的3D主体模型,如先前从MCAD中导入的外壳。

目前,本选项作为Export Options对话框中的Skip Free 3D Bodies选项提供,可通过File » Export » [format]命令打开对话框,其中格式为PARASOLID、STEP 3D或VRLM。同时,当任何3D导出格式已添加为输出作业中的导出输出时,该对话框选项可用。

PDF输出中True Type字体的真正生成

文件PDF生成器已更新为支持矢量而非栅格化True Type字体,确保PDF输出中清晰的字体渲染并允许在外部PDF阅读器中搜索和选择文本。

Altium NEXUS中,在配置OutJob以生成包含True Type字体的PDF文件输出时,检查PCB Printout Properties对话框中的TT字体打印输出选项,从而启用完整的TTF支持。

请注意,Acrobat Reader将保留以前的搜索结果且在从Altium NEXUS更新现有的PDF时可能无法提供预期的搜索结果。若要解决此问题,使用阅读器优选设置对话框中搜索部分的清除缓存内容按钮清空Acrobat Reader缓存。

浅色/深色主题选项

目前,Altium NEXUS支持在默认的“深色”图形用户界面主题与新的Altium Light Gray主题之间进行切换的选项。本选项位于优选设置对话框System – View页面中UI Theme Current下拉菜单中。

ActiveBOM中材料清单集

材料清单生成过程中的常见要求是需要以多种不同的布局输出材料清单——每种布局均显示各后期设计过程中所用的不同数据,如采购、板组装准备等等。

ActiveBOM现在支持材料清单集,各材料清单集捕获材料清单项目栅格的当前布局和配置并将其保存为命名的集合。可规定材料清单集的数量,点击  图标可采用该材料清单集。

ActiveBOM Properties面板中配置材料清单集。

在即将发布的版本中将新增对材料清单生成期间选择材料清单集的支持。

改进了Draftsman中材料清单别名操作

Draftsman材料清单(BOM)表格中,可将标准列的标题名称替换为用户定义的别名,从而可将表格自定义为适应个人/公司的材料清单约定。可在Draftsman材料清单表格和Project ActiveBOM文件中指定材料清单别名,其中后者的设置将覆盖前者。

两个别名定义位置之间经改进的交互如下:

  • 若可用于PCB Project,Draftsman将从ActiveBOM文件中获取材料清单信息,且BOM Properties面板中Data Source选项将设置为Project。Draftsman材料清单表格将采用任何已在源ActiveBOM文件中定义的别名,且Draftsman的材料清单别名参数将设置为只读。
  • 若材料清单文件不适用于PCB Project或者Draftsman的数据源材料清单属性设置为Board,则在已选中材料清单表格的情况下,可从属性面板的选项卡中添加和/或编辑别名。

请注意Draftsman的Tools » Update板命令将检测项目ActiveBOM文件的添加或删除或者ActiveBOM文件中的任何更改,并相应地更新Draftsman材料清单表格别名的状态。

属性面板中的公式与智能编辑

在原理图编辑器和PCB编辑器的属性面板中新增了通过公式和批量替换修改数据字符串的功能。公式与表达式提供了一种修改多个选中对象的属性参数以更改其位置值或基于字符串的值(如标号和注释)的便捷方法。

► 了解有关“公式和批量替换”的信息(List面板文件)。

在选中多个对象时,一些参数字符串字段还提供了对智能编辑对话框的访问,可从相关省略号按钮()打开该对话框。

Draftsman组装视图的全局元件显示属性

当选中了Draftsman文档中放置的板组件视图时,属性面板中元件显示属性部分此时将提供适用于该组装视图上所有元件的属性设置。元件主体(以前称为几何源)或标号可见性等显示属性选项的更改对当前选定的组装视图具有全局性。

反之,若在组装视图中选中了元件,那么元件显示属性设置仅适用于选中的元件(与先前版本的Draftsman相同)。通过元件显示属性对话框更改元件的具体范围。

这些更新的属性选项中还包括通过相关按钮 指定元件显示属性的全局元件模式和单一元件模式的标号颜色。

项目面板文件状态指示器

项目面板中新增了活动文件状态图标,作为打开项目中文件状态的视觉辅助工具。

启用文件锁定(参阅数据管理—文件锁定)时,面板上与文件关联的图标指示文件的打开时间 (), 修改时间 (), 由Altium NEXUS本实例打开和锁定的时间 (), 或者由Altium软件另一个实例打开和锁定的时间 ()。无论文件是否锁定,与文件名称关联的星号(*)表示修改后的文件。

工作副本的可选Subversion格式

为了提高与现有外部Subversion系统的兼容性,目前可将Altium NEXUS配置为以三种通用SVN版本格式之一生成SVN工作副本文件。

例如,在公司标准规定使用Subversion早期版本(如,1.7版)的情况下,可在数据管理—版本控制优选设置页面中将Altium NEXUS设置为该版本。总之,通过SVN中央存储库“检出”创建的工作副本文件将为1.7版的格式,确保与外部Subversion客户端与工具的兼容性。

以指定版本创建一组新的工作副本文件时,若Altium NEXUS检测到现有的工作副本,则系统将重新写入相同版本的文件集。举例来说,如果将首选的SVN版本设置为1.9而“检出”过程中检测到现有的工作副本为1.8版,那么“检出”副本将为1.8版。

Altium NEXUS中,SVN 1.9版为默认和推荐的Subversion系统。

特殊字符串识别标签

为了辅助识别放置在板布局上或模板图例中的特殊字符串,当前Altium Designer的视图配置面板中包括特殊字符串选项。在启用该选项时,任何由已转换的特殊字符串形成的已放置的字符串将与未转换的特殊字符串名称叠加。

放大字符串可查看其标签叠加情况。

IDF导入中的Keepout高度支持

Altium NEXUS中间数据格式(IDF)导入器已改进为支持IDF Keepouts的高度约束。

IDF格式中,Keepout定义可包括其他(最大)高度属性。在使用Altium NEXUS导入器时,针对导入的板放置布局创建了匹配的Room定义和相关的高度约束规则。新规则中高度约束与源IDF Keepout中高度属性对应,因此将其预期功能转移至导入板中的Room定义。

Drag and drop Models to the Component Editor

The Component Editor in Altium NEXUS will now accept component Models that are dragged and dropped directly from the Explorer panel.

Drag and drop a source Model on to the existing model to replace it (as is the case with Symbols), or drop the Model onto the area following existing models to add that Model to the component.

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

联系我们

联系原厂或当地办公室

You are reporting an issue with the following selected text
and/or image within the active document:
Altium Designer 免费试用
Altium Designer Free Trial
我们开始吧!首先,您或者您的公司已经在使用Altium Designer了吗?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

既然您在使用Altium Designer,为何仍需要试用?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

好的,实际上您无需下载一个试用版本。

点击下方按钮下载最新版本的Altium Designer安装包

下载Altium Designer 安装包

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

填写下方表格,获取Altium Designer最新报价。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

如果您是Altium维保期内客户,您不需要下载试用版本。

如果您不是Altium维保客户,请填写下方表格免费试用。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

您为何想要试用Altium Designer?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

那您来对地方了!请填写下方表格申请试用吧。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

听上去很棒!您知道我们为学生提供了特殊折扣么?欲知详情,请点击这里。.

同时,请填写下方表格申请免费试用吧。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

好的,您可以下载免费的Altium Designer Viewer查看文档,有效期6个月。

请填写下方表格申请。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

好棒!创作是一件超酷的事情,我们可以为您提供完美的设计软件。

Upverter是一个社区导向的交流平台,专为您这样的创客量身定做。

点击这里看看吧!

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

好的,您可以下载免费的Altium Designer Viewer查看文档,有效期6个月。

请填写下方表格申请。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。