Altium Designer Documentation

Managed Schematic Templates in an Altium Vault

Modified by Jason Howie on May 19, 2017

Parent page: Vault Items

Altium Designer, in conjunction with Altium Vault, caters for the ability to create and manage Schematic Template Items in an Altium Vault. Such Items are created directly from within the target vault. Once a Schematic Template Item has been created (and data released into a revision of it), and its lifecycle state set to a level that the organization views as ready for use at the design level, it can be reused in future board-level design projects.

Folder Type

When creating the folder in which to store Schematic Template Items, you can specify the folder's type. This has no bearing on the content of the folder - releasing a schematic template will always result in a corresponding Schematic Template Item. It simply provides a visual 'clue' as to what is stored in a folder and can be beneficial when browsing a vault for particular content. To nominate a folder's use as a container for Schematic Template Items, set its Folder Type as Schematic Templates, when defining the folder properties in the Edit Folder dialog.


Specifying the folder type - its intended use - gives a visual indication of the content of that folder when browsing the vault!

Another important aspect of the parent folder is the Item Naming Scheme employed for it. This defines the format of the unique ID for each Item created in that particular folder. Several default example schemes are available, utilizing the short-form code for either the folder type (STC - Schematic Template Collection) or the content type (SCHDOT - Schematic Document Template):

  • $CONTENT_TYPE_CODE-001-{0000} - for example, SCHDOT-001-0001.
  • $CONTENT_TYPE_CODE-001-{A00} - for example, SCHDOT-001-A01.
  • $FOLDER_TYPE_CODE-001-{0000} - for example, STC-001-0001.
  • $FOLDER_TYPE_CODE-001-{A000} - for example, STC-001-A001.

Using a default naming scheme, the software will automatically assign the next available unique ID, based on that scheme, having scanned the entire vault and identifiers of existing Items. This can be a great time-saver when manually creating Schematic Template Items prior to release.

A custom scheme can also be defined for a folder, simply by typing it within the field, ensuring that the variable portion is enclosed in curly braces (e.g. SCH-TMP-{0000}).


The Item Naming Scheme of the parent folder is applied to the Unique ID for each Item
created within that folder.

The Item Naming Scheme employed for the parent folder can be changed at any time. The modified scheme will then be applied to any subsequent newly-created Items within that folder.

Item Type

When creating a target Schematic Template Item in which to store your schematic template, ensure that its Content Type is set to Schematic Template, in the Item Properties dialog. If you are creating the Item in a Schematic Templates type folder, this Item type will be available from the right-click context menu when creating the Item.


Creating a Schematic Template Item within a Schematic Templates folder - the correct Content Type is available on the context menu.

When defining a Schematic Template Item, be sure to specify the type of lifecycle management to be used for the Item, and the naming scheme employed for its revisions, respectively.

Control over which Item types can use a particular lifecycle definition or revision naming scheme, can be defined and enabled at a global level from within the Content Types dialog, when defining each schema. For a newly-installed vault, the default schemes assigned for use by a Schematic Template Item are: Simple Lifecycle and 1-Level Revision Scheme, respectively.

Once a template definition has been released into the initial revision of a Schematic Template Item, these schemes cannot be changed for that particular Item.

Specify the required schemes in the Item Properties dialog, using the Lifecycle Definition and Revision Naming Scheme fields respectively.

If the option to control use of lifecycle definitions and revision naming schemes per content type is enabled for any definitions/schemes, and the Schematic Template Item type is not set to use a particular definition/scheme, then that definition/scheme will not be available in the applicable drop-down list.


Selecting the Lifecycle Definition and Revision Naming schemes for a manually created Item.

Observing standard revision naming schemes and lifecycle definitions, across the various types of design item in a vault ensures smooth, consistent management of those items.
It is a good idea to add a comment and description as part of the Item's definition. This information is used when searching the vault and enables quick identification of what a Schematic Template Item offers.

Releasing a Schematic Template

So far, we've discussed the support for a Schematic Template Item in the vault, in terms of related folder and item types. Releasing an actual defined schematic template into a revision of such an item can be performed in a single streamlined way.

A schematic template can be edited and released into the initial revision of a newly-created Schematic Template Item, courtesy of the vault's support for direct editing. Direct editing frees you from the shackles of separate version-controlled source data. You can simply edit a supported Item type using a temporary editor loaded with the latest source direct from the vault itself. And once editing is complete, the entity is released (or re-released) into a subsequent planned revision of its parent Item, and the temporary editor closed. There are no files on your hard drive, no questioning whether you are working with the correct or latest source, and no having to maintain separate version control software. The Altium Vault handles it all, with the same great integrity you've come to expect, and in a manner that greatly expedites changes to your data.

When you create a Schematic Template Item, you have the option to edit and release a schematic template into the initial revision of that item, after creation. To do so, simply enable the option Open for editing after creation, at the bottom of the Create Item dialog (which is enabled by default). The Item will be created and the temporary Schematic Editor will open, presenting a .SchDot document as the active document in the main design window. This document will be named according to the Item-Revision, in the format: <Item><Revision>.SchDot (e.g. SCHDOT-001-0001-1.SchDot).


Example of editing the initial revision of a Schematic Template Item, directly from the vault - the temporary Schematic Editor provides the document with which to
define your schematic template.

Use the document to define the schematic template as required. For more information on doing this, see Creating and Working with Templates.

The Schematic Standard toolbar provides three relevant controls when direct editing:

  •  - Save Active Document. Use this button to save the changes made to the document. This is required before you can release the document back to the vault.
  •  - Release Document. Use this button to release the defined schematic template to the vault, storing it within the initial (planned) revision of the target Schematic Template Item. The Create Revision dialog will appear, in which you can change Comment, Description, and add release notes as required. The document and editor will close after the release. The document containing the source schematic template, *.SchDot, will be stored in the revision of the Item.
  •  - Cancel Editing. Use this button if you wish to cancel editing. The document and editor will close, and nothing will be released to the target Schematic Template Item.

The released data stored in the vault consists of the source schematic template, defined in the Schematic Template file (<Item><Revision>.SchDot). In the Vaults panel, switch to the Preview aspect view to see the template graphics.


Browse the released revision of the Schematic Template Item, back in the Vaults panel. Switch to the Preview aspect view to see the template graphics.

Reusing a Managed Schematic Template Item

Related pages: Managed Schematic Sheets in an Altium Vault , Controlling Access to Vault Content

Once a schematic template has been released to an Altium Vault, and its lifecycle state set to a level that the organization views as ready for use at the design level, that template can be reused in future board-level design projects.

When you are signed in to your Altium Vault, use of available Schematic Template Items is automatic. If there are released revisions of Schematic Template Items, then only those available templates - shared with you - will be presented in the applicable areas of the software where a schematic template can be chosen. If there are no released revisions of Schematic Template Items in the vault, or if you sign out of your vault, then you will be able to use local, file-based templates.

If you do not sign in to your Altium Vault you can still work with Altium Designer (under your valid Altium Designer License), but you will not be able to access your organization's Altium Vault, or any other services provided through its installation. You will therefore not be able to reuse any vault-based Schematic Template Items. You will only be able to use file-based templates defined locally.
A released schematic template can also be used as a configuration data item in one or more defined Environment Configurations. An environment configuration is used to constrain a designer's Altium Designer working environment to only use company-ratified design elements. Environment configurations are defined and stored within the Team Configuration Center - a service provided through the Altium Vault installation. Once you have signed in to the Altium Vault, and chosen (if applicable) from the selection of environment configurations available to you, Altium Designer will be configured, with respect to use of Schematic Templates. If the chosen environment configuration has one or more defined Schematic Template Items, then only those defined templates can be used. If the chosen environment configuration applicable to you does not have any Schematic Template Items specified/added, then these will remain manually definable. In other words, you are free to use local templates, or manually reuse a vault-based Schematic Template. For more information, see Environment Configuration Management.

Manual Reuse

When signed in to an Altium Vault and using an environment configuration that does not control the use of schematic templates, or working as an administrator, you are free to manually choose a revision of a Schematic Template Item. Choose a managed template to use from the Template tab of the Document Options dialog. Enable the Use Vault Template option then, in the Template from Vault region of the tab, simply click the Choose button and use the subsequent Choose Item dialog to browse to, and select, the required template in the connected Altium Vault. The region will populate with details for the chosen Item Revision:

  • Item Revision ID
  • The source Altium Vault
  • The Item Revision's comment and description.
  • The current state of that revision (both its current lifecycle state, and whether the revision is out of date or up to date).
The Revision State field reflects whether the revision of the template currently being used is the latest (Up to date) or has since been superseded (Out of date). If the latter, simply click the Update From Latest Revision button. The later revision will be used - as reflected in the Item Revision field, and the Revision State changing to Up to date once again - and applied to the active schematic sheet.
To remove use of the vault-based template, either click the Clear Template button, or disable the Use Vault Template option.


Manually choosing a revision of a vault-based Schematic Template Item from within the Document Options dialog.

To change templates, simply choose a different Schematic Template Item. Alternatively, use the Design » Templates » Set Template from Vault command. This presents the Choose Template dialog, from where you can browse to, and select the required Item Revision in the vault.


Use the Set Template from Vault command to quickly switch between vault-based Schematic Templates.

You are also free to use local, unmanaged Schematic Templates in addition to using those from a vault, should this be required.

Automatic Reuse

When under automatic control, or control of an environment configuration, Altium Designer will be configured, with respect to use of Schematic Templates, in the following areas:

When creating a new schematic document, either using the File » New » Schematic command, or right-clicking on a project's entry in the Projects panel and choosing Add New to Project » Schematic, the Select configuration item (Schematic Templates) dialog will appear. Use this dialog to choose which template to use for the new sheet, from the list of templates shared with you in the vault.

The latest revision of each available item will be used.


Choose from the latest revisions of Schematic Template Items, shared with you, when creating a new Schematic document.

The Template tab of the Document Options dialog will reflect the revision of the Schematic Template Item chosen - either at the time of document creation, or when applied at a later stage - in terms of:

  • Item Revision ID
  • The source Altium Vault
  • The Item Revision's comment and description.
  • The current state of that revision (both its current lifecycle state, and whether the revision is out of date or up to date).


The chosen revision of a Schematic Template Item is reflected on the Template tab of the Document Options dialog.

The Choose button will be disabled - you cannot freely traverse the vault to manually select a Schematic Template Item. The Show in Explorer button will still be available though, allowing you to quickly navigate to the Schematic Template Item Revision in its source Altium Vault.
To apply a different template, choose from the templates available to you on the Design » Templates » Configuration Templates sub-menu.

On the Schematic Editor's main Design » Templates sub-menu, the ability to freely select a different file-based Project or General template will be disabled. Instead, the Configuration Templates sub-menu will present all Schematic Template Item Revisions (latest) shared with you for use.


Only the latest revisions of those Schematic Templates shared with you, will be made available for use.

Re-Releasing a Schematic Template Item

At any stage, you can come back to any revision of a Schematic Template Item in the vault, and edit it directly. Simply right-click on the revision and choose the Edit command from the context menu. Once again, the temporary editor will open, with the template contained in the revision opened for editing. Make changes as required, then commit the release of the document into the next revision of the item.

Right-clicking on the top-level entry for an Item itself, will edit the latest revision of that Item.


Accessing the command to launch direct editing of an existing revision of a Schematic Template Item.

Downloading Released Data

Download the data stored in a revision of a Schematic Template Item by right-clicking on that revision and choosing the Operations » Download command from the context menu. The schematic template file will be downloaded into a sub-folder under the chosen directory, named using the Item Revision name. The file can be found in the Released folder therein.

Access the Download command from the top-level entry for a Schematic Template Item itself, to download the schematic template file stored in the latest revision of that Item.
Click the Explore button in the Download from Vault dialog, to quickly explore to the download folder.

Batch Releasing File-based Schematic Templates

If you have a set of file-based schematic templates (*.SchDot) that you need to release to a target Altium Vault quickly, and simultaneously, then you can use Altium Designer's Release Manager. Use it to batch-release templates stored across multiple source documents, in a nominated source folder location.

The Release Manager is considered to be a legacy tool.

Accessed the Release Manager dialog by running the File » Release Manager command.


Release schematic templates, stored in one or more source documents, using the Release Manager.

Setting up for release couldn't be simpler:

  • Set the Document Type to SCHDOT.
  • Point to a top-level folder containing the schematic template files you want to release. Files can be stored in sub-folders within this folder.
  • Choose the target vault.
  • Choose to create a top-level folder in the vault based on the nominated top-level Windows folder, or choose an existing vault folder. You can optionally create sub-folders in the nominated vault folder, for each Windows sub-folder. Additionally, you can opt to create a vault folder for each source schematic template file.
  • Use the Default Options for New Released Schematic Templates region of the Release Manager to control how required new Items are created as part of the release process - in terms of Lifecycle Definition, Item Naming (default is SCHDOT-{00000}) and Item Revision Naming schemes, and starting index.
  • Hit the Analyze Folders button.

Analysis of source folders and target vault folders (and Items) based on your chosen options will be performed and the source schematic template files detected will be listed. For each entry, the target Item will be displayed, its current and/or next revision (as applicable) and the action that will be performed by the release process.

Enable the schematic templates that you want to release and then click the Prepare Items and Documents button to effectively commit the link information to the source schematic template files involved in the release. Once saved, proceed with the release by clicking the Release Items button.

 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

联系我们

联系原厂或当地办公室

You are reporting an issue with the following selected text
and/or image within the active document:
Altium Designer 免费试用
Altium Designer Free Trial
我们开始吧!首先,您或者您的公司已经在使用Altium Designer了吗?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

既然您在使用Altium Designer,为何仍需要试用?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

好的,实际上您无需下载一个试用版本。

点击下方按钮下载最新版本的Altium Designer安装包

下载Altium Designer 安装包

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

填写下方表格,获取Altium Designer最新报价。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

如果您是Altium维保期内客户,您不需要下载试用版本。

如果您不是Altium维保客户,请填写下方表格免费试用。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

您为何想要试用Altium Designer?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

那您来对地方了!请填写下方表格申请试用吧。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

听上去很棒!您知道我们为学生提供了特殊折扣么?欲知详情,请点击这里。.

同时,请填写下方表格申请免费试用吧。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

好的,您可以下载免费的Altium Designer Viewer查看文档,有效期6个月。

请填写下方表格申请。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

好棒!创作是一件超酷的事情,我们可以为您提供完美的设计软件。

Upverter是一个社区导向的交流平台,专为您这样的创客量身定做。

点击这里看看吧!

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

好的,您可以下载免费的Altium Designer Viewer查看文档,有效期6个月。

请填写下方表格申请。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。