Altium Designer Documentation

Gerber X2 Support

Modified by Jason Howie on Jul 10, 2017
All Contents

Parent page: More about Outputs

As part of Altium Designer’s ability to export a wide range of PCB design fabrication and assembly file formats, the Gerber X2 format is available for both individual and output job file generation.

Gerber X2 is a direct, and much advanced, evolution of the existing Gerber RS-274X standard and adds a large range of additional data for PCB fabrication and assembly. Compared to the RS-274X standard, the new Gerber X2 format includes critical information such as:

  • Layer stack definitions
  • Pad and via attributes
  • Impedance controlled tracks
  • and more…

A prime advantage of the Gerber X2 format is backward compatibility with the old Gerber RS-274X standard. Being a multi-file standard, a target fab/assembly house that has not moved to the new standard can extract the traditional Gerber file elements as needed. This may be a significant advantage for those unwilling to tackle a major shift in fabrication file formats, or for fabrication houses with inflexible equipment and software.

The overall benefit of adopting the Gerber X2 format for transferring board design data to fabrication and assembly houses is the rich set of manufacturing data included in the file set, and the backward compatibility to the previous standard for a low risk upgrade path. With a full implementation at both ends of the CAD-CAM chain, the risks associated with data misinterpretation, file errors and variable data interpretation can be largely eliminated. In short, both the Gerber X2 and IPC-2581 formats represent a new generation of board design to manufacture data transfer.

Useful links:

Gerber X2 Direct Output

With a project PCB file loaded as the active document, the Gerber X2 file set can be generated by selecting File » Fabrication Outputs » Gerber X2 Files from the main menu. This opens an initial Gerber X2 Setup dialog to define the plot layers, drill options and general configuration applied during the export process.

The Gerber X2 output setup is similar to that of the standard Gerber output.

Output is generated to the location defined in the Output Path field, on the Options tab of the Project Options dialog. Generated file names will include the name of the PCB document.

Generated files will be added to the project, and appear in the Projects panel under the Generated\CAMtastic! Documents and Generated\Text Documents folders.

The generated Gerber output is also opened as a composite CAM document that can be edited and/or saved into the current project, and managed via the CAMtastic panel.

To specify if the generated CAM output is automatically opened in Altium Designer, enable the Open outputs after compile option in the Options tab of the Options For Project dialog (Project » Project Options).

Gerber X2 Output through an Output Job File

Related page: Preparing Multiple Outputs in an OutputJob

To include Gerber X2 file output in a project's Output Job Configuration file, click on [Add New Fabrication Output] under the Fabrication Outputs section, and select Gerber X2 Files from the menu, and the desired data source from the associated sub-menu.

Configure a Gerber X2 Files output as part of an Output Job file's Fabrication Outputs.

As with other Fabrication outputs, when the OutJob is run - either manually, or part of the project release system - the Gerber X2 file set will be generated in accordance with settings defined for the applicable Output Container.

Prepping a Gerber X2 output as part of a configured OutJob.

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

联系我们

联系原厂或当地办公室

You are reporting an issue with the following selected text
and/or image within the active document:
Altium Designer 免费试用
Altium Designer Free Trial
我们开始吧!首先,您或者您的公司已经在使用Altium Designer了吗?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

既然您在使用Altium Designer,为何仍需要试用?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

好的,实际上您无需下载一个试用版本。

点击下方按钮下载最新版本的Altium Designer安装包

下载Altium Designer 安装包

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

填写下方表格,获取Altium Designer最新报价。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

如果您是Altium维保期内客户,您不需要下载试用版本。

如果您不是Altium维保客户,请填写下方表格免费试用。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

您为何想要试用Altium Designer?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

那您来对地方了!请填写下方表格申请试用吧。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

听上去很棒!您知道我们为学生提供了特殊折扣么?欲知详情,请点击这里。.

同时,请填写下方表格申请免费试用吧。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

好的,您可以下载免费的Altium Designer Viewer查看文档,有效期6个月。

请填写下方表格申请。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

好棒!创作是一件超酷的事情,我们可以为您提供完美的设计软件。

Upverter是一个社区导向的交流平台,专为您这样的创客量身定做。

点击这里看看吧!

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

好的,您可以下载免费的Altium Designer Viewer查看文档,有效期6个月。

请填写下方表格申请。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。