Altium Designer Documentation

原理图放置以及编辑技巧

Modified by Jun Chu on Aug 17, 2018

电子设计是在原理图中捕获逻辑设计,然后将该设计表示为PCB工作区中的一组对象的过程。 即使是小型电路,原理图也会包含许多元件,每个元件都有众多的模型和参数。 PCB工作区还可以包含构成电路板的大量设计对象。 在设计过程中,需要根据您的工作进度改变这些对象的位置和属性,以便平衡各种设计要求。

对象放置基础

栅格和光标

将对象放置在原理图编辑器中之前设置栅格,以便于放置对象。Altium提供三种栅格:用于导航的可视栅格、用于对象放置的捕捉栅格和辅助创建连接的电气栅格。栅格为文档选项,即栅格随单独文件一起保存,因此不同设计文档的栅格设置各异。首先,在Properties面板Document Options模式的General区域中设置栅格。

当缩放比例允许充分间隔时,就会出现可见栅格,显示为线条或点。捕捉栅格为放置或移动原理图设计对象时光标所锁定的栅格。电气栅格覆盖捕捉栅格,电气栅格中可以连接不在格点位置的元件。在工作区中移动电气对象时,如果该对象位于另一个可以连接的电气对象的电气栅格范围内,该对象将捕捉到该固定对象并将出现热点(红叉)。电气栅格应设置为略低于目前的捕捉栅格,否则很难将电气对象定位在捕捉栅格上。

通过键盘或鼠标快捷键可以快速修改栅格或启用/禁用栅格,例如,按G键可切换1、5和10捕捉栅格设置。您还可以使用View » Grids子菜单。通过Preferences对话框中的Schematic-Grids页面,设置英制公制栅格格式

同时,您可以根据需要在Preferences对话框Schematic-Graphical Editing页面中的"光标"部分修改光标类型。例如,在放置和对齐设计对象时,延伸到设计窗口边缘的90度大十字(Large Cursor 90选项)将很有用。

放置设计对象

有关放置原理图设计对象的基础步骤如下。

  1. 选择需要放置的对象类型。您可以通过在Place菜单中选择对象类型(如Place"Wire),或者直接点击放置工具栏中的图标。还可以通过放置快捷键(如点击P、W可放置导线)。若要放置元器件(部件),您可以在Libraries面板中点击Place按钮,或者在Libraries面板中从相应的元器件库中选择元器件并将其拖到文件中。
  2. 在选择放置的对象时,光标将变为十字光标,表示正处于编辑模式,并且相应地,对象将在光标下的显示为悬浮状态。
  3. 在放置对象前,按Tab键可编辑对象属性。此键将打开特定对象的属性对话框,从而可以修改各种选项。一旦完成属性设置,点击  返回放置模式。在放置时编辑的优势在于有标号等数字标识符的对象将自动增加。
  4. 定位光标并单击鼠标左键,或者按Enter键放置对象。对于导线或多边形等复杂对象,您必须通过继续定位并点击程序放置对象的所有顶点。
注:通过Preferences对话框中Schematic - AutoFocus页面的AutoFocus选项可以控制原理图显示的状态。例如,可将原理图配置为在放置或编辑连接对象时自动放大或者调暗与当前放置导线无关的所有布线。通过快捷键或鼠标滚轮可实现其它缩放和平移选项。在放置对象时,通过Ctrl键或滚动鼠标滚轮进行放大和缩小,按下滚轮按钮并向上移动鼠标可放大,向下移动鼠标可缩小。可以在Preferences对话框中System - Mouse Wheel Configuration页面设置鼠标。
  1. 在完成对象放置后,您将仍处于放置模式(显示十字光标),因此您可以直接放置同类型的其它对象。若要退出放置模式,则右击鼠标或按Esc键。某些情况下(如放置多边形时),您可能需要右键双击或按两次Esc键:一次结束对象放置,一次退出放置模式。在退出放置模式时,光标将恢复其默认形状。

可重入编辑

原理图编辑器包含一项称为可重入编辑的强大功能,利用此功能,您可以通过键盘快捷键进行再次操作,而无需退出当前正在进行的操作。例如,在放置元件时,按Spacebar键可旋转该对象但不会中断放置过程。一旦您完成此元件的放置,另一个元件将出现在光标旁,且该元件处于已旋转状态。

若您在尚未放置端口时开始放置需要连接该端口的导线,您将发现可重入编辑非常有用。无需退出Place Wire模式;只要按下Place Por快捷键(P、R),放置端口,按Esc键退出放置端口模式,将导线连接到该端口即可。

测量原理图文档上的距离

原理图编辑器的Reports菜单(Reports » Measure Distance或者Ctrl+M快捷键)中有一个测距工具。您可以使用此工具测量原理图文档中两点之间的距离。启动该命令后,系统将提示您点击原理图文件上的两个点。在您选中两点后,将出现Information对话框并显示总距离值,其中X距离值Y距离值精确到小数点后两位。

测量单位与原理图文件中选定的System Units保持一致(Design - Document Options)。您可以通过更改系统单位(View » Toggle Units)切换为英制单位或公制单位。

以图形方式编辑放置的对象

以图形方式编辑工作区中对象的外观通常更容易。为此,必须首先选择对象。

在选中对象后,您可以移动该对象或编辑对象的图形特征。点击对象可以选中该对象并显示其"句柄"或顶点。若要以图形方式修改选中的对象,点击并按住一个编辑句柄。然后对象的此点将与光标连接,只需移动鼠标至新位置并放开即可调整大小。点击选中对象的任意位置可移动该对象,按Delete键可删除该对象。

使用复制和粘贴

在原理图编辑器中,您可以复制和粘贴在原理图文件内或不同原理图文件之间的对象,例如,可将一份原理图中的元器件复制到另一份原理图文件中。您可以将对象复制在Windows剪贴板中并将其粘贴到其他文件中。您还可以直接从Microsoft Excel等其他应用程序或Altium Designer中任何栅格样式控件中复制/粘贴表格类型选择。

通过Smart Paste功能可进行更高级的复制/粘贴操作。

选中您想复制的对象,选择Edit » Copy (Ctrl+C)并点击,可在对象上设置将在粘贴时用于精确定位对象的复制基准点。若Preferences对话框Schematic - Graphical Editing页面中的Clipboard Reference选项已启用,则系统将仅提示您点击设置基准点。

选择多个对象

有多种选择对象的方法,例如可使用Windows标准鼠标点击快捷键。在需要选择的对象数量较小或者需要同时编辑不同类型的对象时,此方法最理想。

若要选择多份原理图图纸中的多个对象,您可以使用Find Similar Objects对话框。右键单击其中一个需要编辑的对象并在上下文菜单中选择Find Similar Objects可打开该对话框。

让我们通过示例来演示此过程。假设我们需要将原理图中电源网络的名称从VCC改为3V3。该电源网络的名称是由电源端口的Net属性确定的。若要修改名称,则需要修改所有原理图图纸中所有VCC电源端口的Net属性。首先,在原理图中找到一个VCC电源端口,右击该端口并在上下文菜单中选择Find Similar Objects

上图显示了右击原理图电源端口后出现的Find Similar Objects对话框。需要注意的是对话框中列出了所点击的对象的属性,因此如果您点击其它对象,则该对话框的内容将有差异。您可以看到该对话框有两列:左列显示所点击的对象的当前属性--在底部您可以看到当前的网络名称Text为VCC。

您可以在第二列配置该对象与其他对象的匹配方式。您希望目标对象的属性与此匹配时,可以设置属性值为“相同”;在目标属性值不匹配时设置为“不同”;或者在您不希望通过属性匹配时将该属性设置为"任意"。

注:如上图所示,当Object Kind为相同且网络名称Text相同时,将发生匹配。换一种说法,即当另一个对象为Power Object且其网络名称为VCC时,将发生匹配。

其次,设置查找操作的范围,将其设置为仅查找Current Document 或查找所有Open Documents或Project Documents。例如,我们将其范围设置为查找Open Documents。

若要将此操作应用于项目中的所有图表,必须先打开项目中的所有图表。

最后,如果您已经查找了所有Open Documents中所有网络名称文本为VCCPower Object。下图显示了需要为此编辑操作进行的设置。

需要设置的关键选项有:

  • 选择匹配——选择所有网络名称文本为VCC的Power Object。
  • 打开Properties——打开Properties面板。

单击确定按钮以选择匹配的电源端口。 这将选择匹配的电源端口,并在Power Port的多对象模式下打开属性面板。

移动选定的对象:

  • 在按住Ctrl键的同时按下箭头键,可以根据当前的捕捉栅格值"微调"选定的原理图对象或PCB对象。
  • 在按住Ctrl+Shift键的同时按下箭头键,可以根据捕捉栅格值x10"微调"选定的对象。
  • 原理图对象的当前捕捉栅格显示在状态栏。可用的捕捉栅格可在Preferences对话框 Schematic - Grids 页面中设置,在工作时按G键可切换可用的栅格值。
  • 对于PCB对象,当前的捕捉删格显示在状态栏上,并在栅格编辑对话框中定义。 按下Ctrl + G可打开对话框并输入一个新值。
  • 您可以使用Reposition Selected Components命令(Tools » Component Placement » Reposition Selected Components或快捷键T、O、C)选择多个PCB元器件并分别对其重新定位(按照选择这些元器件的顺序)。通过PCB面板直接在PCB上选择元器件,或在启用了Cross Select ModeTools菜单)的情况下在原理图编辑器中选择这些元器件。

查看对象属性

原理图编辑器和PCB编辑器中均有Properties面板的多个对象模式。基本操作是列出所有当前选定对象的属性。上图显示了十个电源端口的属性。

若所有选定对象的属性相同,则显示属性值,例如两个电源端口的“旋转”、“名称”、“样式”、“字体”和“颜色”相同。

若电源端口属性的值不同,则显示*,例如X/Y位置。这表示并非所有对象均具有相同的X/Y值,而这也在情理之中,因为这些对象位置各不相同。

编辑对象

截至目前,您已经选定了需要编辑的Power Objects并在Properties面板中检查了这些对象的属性。现在准备编辑。

点击Name字段,再输入新值即可。若要进行上述编辑,我们需要替换所有文本,因此我们只需将单元格内的所有内容替换为新文本3V3。

只要在键盘上按Enter键,您对文本值的修改将应用于所有选定的对象。

如果在编辑过程中您改变主意,在键盘上按Esc键即可退出编辑。若要Undo已应用的编辑,则在菜单中选择Edit » Undo。若编辑已应用于多张原理图图表,您需要在每张图表中进行Undo操作。

您可以使用此方法将编辑全局应用于原理图编辑器或PCB编辑器中任何类型的对象。

编辑组对象

我们刚才执行的编辑是针对原始对象,即原理图编辑器中所用的基础对象之一。元器件等更复杂的对象被称为组对象;组对象本质上是原始对象的集合。例如,原理图上的元器件是绘图对象、字符串、参数、引脚和参考模型的集合。属于组对象的原始对象有时被称为子对象,而组对象则是其父对象。

让我们以一个典型的组对象编辑为例。您的设计包含多个电容器。当前,电压被指定为元器件注释字符串的一部分。您需要修改此设置、将电压指定为元器件参数并使参数在原理图上可见。

我们需要执行的步骤如下所示(详细描述如下所示) :

  1. 选择值为100uF 16V的电容器。
  2. 将其注释修改为100uF(删除文本16V)。
  3. 为这些元器件添加新参数,参数名称为Voltage,值为16V
  4. 修改此参数的可见性,使其显示在原理图上。

虽然这看起来是一组很复杂的编辑过程,但实际上非常简单明了。

第1步.选择Capacitor

若要选择所有100uF 16V电容器,可右击其中一个电容器的元器件符号并在上下文菜单中选择Find Similar Objects。

我们将使用前面示例中介绍的方法,只是这次您需要匹配的元器件应具有相同的CommentCurrent Footprint,如上图所示。

请注意,通过将元器件标号值修改为C*,我们可以匹配标号以字母C开头的元器件。单击OK选择匹配电容器。

第2步.修改Comment String

单击OK后,将打开Propertie面板(如果启用了Find Similar Objects对话框中的Open Properties选项)。后面将是显示在该表上选择的匹配对象的原理图。如果启用缩放匹配遮蔽匹配选项,视图将缩放,所有不匹配的对象都淡出或被遮蔽。

您可以检查SCH Inspector面板底部的状态行来查看其他图表中是否存在相同电容器。

若要修改注释字符串,删除字符串中的16V并按Enter键应用修改即可。

步骤3.为元器件添加新参数

我们需要做的下一个更改是添加一个新的参数。要执行此操作,请在Component模式下单击Propertie面板中Parameters选项卡上的Add。输入新的参数名称。您可以使用此方法添加任意数量的参数。

点击 ,以删除选取的参数。

第4步.将电压参数设置为可见

此步骤是使新的电压参数可见。单击图标  使参数可见(显示为 )。

此时,我们已经更新了所有100uF电容器的注释字符串。我们还添加了名为Voltage的新参数,并将其值设为16V,同时使该参数可见。

锁定设计对象

通过启用Locked属性可以锁定设计对象,使其无法在原理图文件中移动或编辑。例如,若特定对象的位置或尺寸很重要,那么锁定这些对象。可以在SCH List面板中启用锁定属性。

锁定原理图图纸上的设计对象

若要锁定一组原理图对象,您可以使用SCH List面板切换Locked选项,如下图所示。

如果您尝试移动或旋转一个已启用锁定属性的设计对象,将出现对话框,要求您确认是否继续编辑。

如果Preferences对话框中Schematic – Graphical Editing页面的Protect Locked Objects选项已启用且设计对象已处于锁定状态,则不可选中该对象或对其进行图形化编辑。禁用Protect Locked Objects选项,从而以图形方式编辑此对象。

如果您尝试同时选中锁定对象和其他对象,在启用Protect Locked Objects选项的情况下,您只能选中并移动那些未锁定的对象。

管理整个设计的封装

Altium Designer的原理图编辑器中具有一个功能强大的Footprint Manager。您可以从原理图编辑器工具菜单(Tools » Footprint Manager)中启动Footprint Manager,并利用其查看整个项目中与各元器件相关的所有封装。Footprint Manager的多选支持功能使其可以轻松编辑多个元器件的封装分配,更改封装的链接方式或更改已分配多个封装的元器件的当前封装分配。通过Altium Designer的标准ECO系统进行设计变更,并根据要求更新原理图和PCB。

使用查询功能查找和编辑多个对象

Altium Designer内置了强大的查询引擎,可用于精确定位设计对象。本质上,查询是对您希望在设计数据中找到的内容的描述。

过滤查找对象

您可以通过多种不同的方式查询设计数据。方法之一是在Filter面板中输入查询。在采用此查询时,您将筛选设计数据库。系统将检查每个对象查看其是否符合查询要求,如果是,则将该对象添加到结果集中。

下图显示了原理图库SCHLIB Filter面板,其中输入了IsPin查询。在采用此查询时,系统将检查库中每个对象(因为启用了Whole Library选项),任何作为引脚的对象均符合要求并被添加到结果集中。过滤所有其他对象。

如何呈现结果取决于右侧的选项。从上图中可以看出通过过滤器的对象(此例中为引脚)将被选中和缩放。所有未通过过滤器的其它对象将被取消选中并屏蔽(淡出且不可编辑)。

这些引脚还将显示在SCH List面板中,该面板以表格形式呈现设计数据,可以同时轻松比较和编辑一个或多个对象。

编辑原理图库列表面板中的设计对象

SCHLIB FilterSCHLIB List面板都有范围控制; 这是因为您可以单独控制结果的显示。 您可以使用它来执行某些操作,例如查找当前库中的所有引脚,然后在查看所有引脚或仅查看当前组件中的引脚之间切换。

SCHLIB List面板的表格栅格非常适用于查看和编辑对象。在您已将SCHLIB List面板设置为Edit模式(见下文)后,您可以通过键盘上的按键"走查"并编辑设置。例如,使用箭头键在栅格中移动对象、F2键或Spacebar键可编辑选中的单元格、Enter键可应用更改、Spacebar键可在单元格处于活动状态时勾选或取消复选框等等。

SCHLIB List面板具有完全可配置性。若要添加/删除列或修改列的顺序,右击列标题并在上下文菜单中选择Choose Columns

使用电子表格程序编辑设计数据

您不但可以直接在SCHLIB List面板中编辑数据,还可以选择多个单元格块并将其从SCHLIB List面板复制到您首选的电子表格程序中,或将其从电子表格复制到SCHLIB List面板中。例如,您正在创建新元器件并已经将制造商数据表中的所有引脚数据复制到电子表格中。

您需要将SCHLIB List面板设置为Edit模式,之后才能在面板中编辑和粘贴数据。

您无需逐一将每个引脚数据输入原理图库编辑器,而是:

  1. 将一个引脚放置在新原理图元器件中并复制,接着使用Paste Array命令输出您需要的引脚总数。
  2. Filter面板中使用IsPin查询以将这些引脚加载到List面板中。
  3. 设置相关的引脚数据列,使其与电子表格程序中列的排列相对应。
  4. 切换至电子表格程序,选择所需引脚数据块并复制。
  5. 回到SCHLIB List面板,选择相同单元格块,右击并在上下文菜单中选择Paste

您可能需要首先将数据块从面板复制到电子表格中,从而查看数据在电子表格中的呈现方式。使用此方法,您可以在新元器件中快速配置大量元器件引脚。

从电子表格或表格中粘贴时创建和编辑数据

您还可以使用Smart Grid Paste工具快速更新设计对象的属性或快速轻松地创建一组基元。通过在原理图或PCB编辑器的面板中右击菜单可启用这些工具。

有关使用Smart Grid Paste工具的更多信息,请参见Sch List 页面

过滤设计工作区的对象--它是如何工作的?

您可以通过在Filter面板中编写"查询",在Find Similar Objects对话框中配置选项(实际上在后台使用查询)或者通过在Navigator面板中选择对象来控制过滤过程。高亮显示引擎确定过滤数据的呈现方式。

作为用户,您可以在List面板的主图形编辑窗口中访问过滤后的显示数据。

编写查询技巧

  • 使用Query Helper熟悉可用的查询关键词。在Filter面板中点击Helper按钮可显示查询助手。有关更多查询信息,请参见Query Language Reference 部分。
  • 在键盘上按F1键显示该查询关键词的在线帮助。
  • 使用Query Helper对话框底部的Mask字段搜索可能的关键词。如果在要查找的字符串的开始添加"*"通配符,则将在关键词及描述中找到对该文本字符串的所有引用。
  • 在关闭Query Helper对话框前点击Check Syntax按钮。
  • 变量应加上引号,如"DIP14"。
  • 在处理查询时存在优先顺序,因此可使用括号确保按照正确的顺序处理查询。
Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

联系我们

联系原厂或当地办公室

You are reporting an issue with the following selected text
and/or image within the active document:
Altium Designer 免费试用
Altium Designer Free Trial
我们开始吧!首先,您或者您的公司已经在使用Altium Designer了吗?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

既然您在使用Altium Designer,为何仍需要试用?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

好的,实际上您无需下载一个试用版本。

点击下方按钮下载最新版本的Altium Designer安装包

下载Altium Designer 安装包

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

填写下方表格,获取Altium Designer最新报价。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

如果您是Altium维保期内客户,您不需要下载试用版本。

如果您不是Altium维保客户,请填写下方表格免费试用。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

您为何想要试用Altium Designer?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

那您来对地方了!请填写下方表格申请试用吧。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

听上去很棒!您知道我们为学生提供了特殊折扣么?欲知详情,请点击这里。.

同时,请填写下方表格申请免费试用吧。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

好的,您可以下载免费的Altium Designer Viewer查看文档,有效期6个月。

请填写下方表格申请。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

好棒!创作是一件超酷的事情,我们可以为您提供完美的设计软件。

Upverter是一个社区导向的交流平台,专为您这样的创客量身定做。

点击这里看看吧!

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

好的,您可以下载免费的Altium Designer Viewer查看文档,有效期6个月。

请填写下方表格申请。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。