Altium Designer Documentation

Status message

Altium Designer 17.0版本现已翻译至中文 跳转至中文界面

Altium Designer 全新功能

Created: December 22, 2022 | Updated: January 30, 2023

本页详细介绍了Altium Designer 23初始版本中的改进内容,以及后续更新中添加的改进内容。除了提供一系列有助于推动现有技术的发展和成熟的改进内容外,每次更新也根据客户通过AltiumLive社区的BugCrunch 系统提出的反馈,在整个软件中整合大量修复和强化功能,以帮助您继续创造前沿电子技术。

您可以选择继续使用当前版本、更新您的当前版本或同时安装Altium Designer 23 与当前版本以访问最新功能。您当前的版本可以在软件里的“扩展和更新”视图中进行更新。如果您选择同时安装Altium Designer 22 与当前版本,请访问“Altium下载”页面下载安装程序,然后在安装程序的“安装模式”页面选择“全新安装”

免费试用!

如果您喜欢我们的产品但还不是我们的客户,何不选择试用Altium Designer?只需填写一张简单的表格即可免费试用Altium Designer,并可在15天内访问完整软件。没错,您可以不受技术限制,完整地体验Altium Designer,自由访问世界上最好的PCB设计产品。单击下方链接,填写表格,亲自体会为什么相较于其他可用产品更多的工程师和设计师会选择 Altium!

Altium Designer 23 免费试用

Altium Designer 23.1

发布时间:2023年1月17日——版本23.1.1(build 15)

Altium Designer23.1版发布说明


原理图输入改进

电源端口编译名称

此时,Preferences对话框Schematic - Compiler页面Compiled Names Expansion区域中的Net Labels选项,可在原理图文档的已编译(物理)选项卡上决定Power Port对象的名称。

严格层次式多通道设计原理图示例,包括网络标签和电源端口。请注意,在查看原理图的已编译选项卡时,电源端口以与网络标签相同的方式显示物理名称。

Print对话框中的Net Labels选项(从Outjob文件访问原理图图纸输出时,将[Project Physical Documents]选项选为输出的数据源)和Smart PDF Wizard的Structure Settings页面上的Net Labels选项还定义了电源端口在原理图输出中的显示方式。

如需了解更多信息,请参阅Creating a Multi-channel DesignPreparing Printed Data 页面。

PCB设计改进

加载存储视图配置文件

添加了从View Configuration面板的View Options选项卡,加载存储视图配置文件的功能。使用Configuration下拉列表中的Load View Configuration选项,浏览并选中所需视图配置文件。

如需了解更多信息,请参阅Colors & Visibility Control页面。

Gerber Board Outline文件的重命名

现在,您可以在Gerber Setup和Gerber X2 Setup对话框中,将Gerber Board Outline类型文件重命名。

如需了解更多信息,请参阅Preparing Fabrication Data页面。

平台改进

改进了调用堆栈崩溃报告内容

此功能使用改进方法,收集调用堆栈崩溃报告。

数据管理改进

将图像附在评论后面的功能

此更新添加了将图像附在评论后面的功能。如前所述,一张图片胜过千言万语,因此附加图像将有助于向同事解释您的想法或高亮显示问题所在位置。您可以首先通过右键单击图像,以将图像复制到剪贴板,从而在Explorer窗口或网络浏览器页面中复制图像。要附加图像,请在评论中右键单击Paste(或使用快捷键Ctrl+V)(在载明"Add others with @ or paste images"的字段中)。

每张图像的最大尺寸为2MB。将其粘贴到评论中后,单击图像以显示完整图像,如右图所示。

如需了解更多信息,请参阅Document Commenting页面。

从Reports菜单导出Project History

添加了将Project History从Reports菜单导出为PDF的功能。从主菜单中选择Reports » Project History后,将打开Project History Report Configuration对话框,您可以在其中设置导出报告的Period:整个项目历史或从/到特定(或最新)项目版本。单击Export,然后在打开的Explorer窗口中输入导出的PDF的名称,然后单击Save。PDF报告将在网络浏览器中打开。

请注意,Altium Designer Standard Subscription不支持项目历史报告导出功能。
如需了解更多信息,请参阅Project HistoryPrint Preview对话框页面。

线束设计改进

Wiring Diagram中的压接

在当前版本中,压接在Wiring Diagram(*.WirDoc)中的使用方式,与其之前在Layout Drawing中的使用方式相同。Properties面板Harness Component模式的Crimps选项卡,可用于使用该图标添加和编辑压接。压接在设计空间中用a表示,如下图所示。

如需了解详细信息,请参阅Defining the Harness Wiring Diagram - Crimps页面。

Twist和Shield参数

参数已添加到Wiring Diagram文档 (*.WirDoc)中的Twist和Shield对象。在放置Twist或Shield期间或之后,单击Properties面板Add下拉列表中的Parameter,然后更新所需可见性、参数名称和值。下图所示为Twist对象示例。

如需了解详细信息,请参阅Defining the Harness Wiring Diagram - Wire Twisting and Shielding页面。

快速添加连接点对象

增加了将连接点对象添加到Layout Drawing(*.LdrDoc)的功能。您可以使用此功能,通过一次操作将多个对象添加到连接点。在Properties面板的Connection Point模式下,单击Connectors区域中的Add以打开Add Connectors对话框。在该对话框中,启用连接点的连接器。为了启用列表中的所有内容,请启用Connector旁边的复选框。

其他物理视图

在此版本中,您可以在Harness Layout Drawing(*.LdrDoc)文档中,为一个连接器添加多个3D物理模型视图。在Properties面板Harness Component模式的Physical Model区域中,选中Physical Model,然后单击Add View。将添加物理视图。您可以通过单击相应的图标,查看和更新视图参数。

如需了解详细信息,请参阅Creating the Harness Layout Drawing - Harness Component Properties页面。

将Download Sources添加到Project History

现在,您可以使用Download Sources命令下载并打开特定项目版本(在Projects面板中)。在Project History文件(<ProjectName> History)中单击,然后选中Download Sources。下载版本将在Projects面板中打开。请注意,此版本为只读版本,即您可以查看但不能以任何方式对其进行编辑。

如需了解更多信息,请参阅Project History页面。 

另存为ASCII功能

您现在可以将Harness Design Wiring Diagram(*.WirDoc)和Layout Drawing(*.LdrDoc)文档,另存为ASCII格式,此功能在共享时非常有用。使用File » Save As命令,并在打开的Save As对话框中Save as type下拉列表中选中Harness Wiring ascii(*.WirDoc)或Harness Layout ascii(*.LdrDoc)。

使用File » Save命令,保存ASCII Wiring Diagram或Layout Drawing文档时,将打开File Format对话框,以提醒您使用ASCII格式。在该对话框中选择ASCII Version(在下图中高亮显示)以继续使用此格式。

添加了Autosize和Justification属性

在Harness Project Draftsman文档Wiring Diagram 视图和Layout Drawing视图对象的Properties面板中,添加了Auto Size和Justification属性(*.HarDwf)。

启用Auto Size后,Wiring Diagram 视图将自动调整其大小以删除边框处的空白区域。通过单击与所需Justification对应的箭头或居中圆圈选中Justification。Justification的选定选项将定义在更新视图尺寸时改变其位置的相对点。

Example of a Wiring Diagram View with the Auto Size option enabled and Justification set to bottom-left. Hover the cursor over the image to see the view with the Auto Size option disabled - note that the location of the view is changed relative to its bottom-left corner.

已启用Auto Size选项且Justification设置为左下角的Wiring Diagram 视图示例。将光标悬停在图像上,以查看禁用Auto Size选项的视图——请注意,视图位置将相对于其左下角发生更改。

如需了解更多信息,请参阅Creating a Manufacturing Drawing for a Harness Design页面。 

多板改进

允许引脚连接到多个引脚

在Multi-board原理图文件(*.MbsDoc)上配置Harness类型的连接时,现在可以将一个PCB连接器上的一个引脚连接到同一目标PCB连接器上的多个引脚。

An example of the connection configuration of a harness connection in a Multi-board schematic. Note that the same pin of the source connector (H_1-Entry_1[1]) is connected to multiple pins of the same target connector.
Multi-board原理图中线束连接的连接配置示例。请注意,源连接器(H_1-Entry_1[1])的同一引脚连接到同一目标连接器的多个引脚。

如需了解更多信息,请参阅Working with Connections页面。

电路仿真增强功能

惯性延迟

对所有PSpice数字门(DLYLINE除外)实现了惯性延迟处理。

添加了PSpice基元

添加了对以下PSpice数字模型基元的支持:

  • DLTCH
  • SRFF

Altimade增强功能

放宽了Min Trace Width和Min Hole Size的限制

Min Trace Width和Min Hole Size的限制放宽后,分别为3密尔和4密尔。

如需了解更多信息,请参阅Single Click Ordering with Altimade页面。 

 

Altium Designer 23.0

发布时间:2022年12月15日——23.0.1版(build 38)

Altium Designer 23.0发布说明


PCB设计改进

丝印制备

为了帮助解决常见Design for Manufacture(DFM)问题,即外露铜皮、孔和板形状丝印重叠,本次发布中增加了为电路板制备丝印的专用功能。这些问题现在可以通过以下方式得到有效解决:

  • 丝印线和圆弧自动裁剪
  • 填充和区域的自动裁剪或移动
  • 丝印文本和元件位号自动移动。

可使用主菜单中的Tools » Silkscreen Preparation命令访问Silkscreen Preparation对话框,以在PCB封装编辑器(用于活动封装)和PCB编辑器(跨越一个或两个覆盖层上的所有或选定对象)中使用该功能。

此功能目前处于Open Beta阶段,且仅在Advanced Settings对话框中启用PCB.SilkScreenPreparation选项时可用。

增强版网络信息用户界面

Properties面板的Net Information区域此时将显示所选基元的所有网络、差分对和xSignals。您可以展开这些部分,以查看所有列出的信息。

如需了解更多信息,请参阅PCB Placement and Editing Techniques页面。

数据管理改进

丢失文件管理

以前,丢失文件可在Messages面板中通过相应通知删除,且在Projects面板中将项目标记为已修改。本次发布中引入一种强化方法,可用于对在项目文件中定义但在项目文件夹中找不到的文件进行管理。这些文件现在被标记为‘丢失’,而不是简单地将对此类文件的引用删除并将项目标记为已修改。它们仍然在项目文件中进行定义,并且仍显示在Projects面板的项目结构中,但其以灰色显示且具有区分图标。

可以使用关联命令,以确保对丢失文档的处理进行全面掌控。使用Projects面板中丢失文件的右键单击菜单,从项目中删除选中文件或所有丢失文件,或者对文件路径进行更新(即用选中文件替换丢失文件)。对于受版本控制的项目,您还可以恢复本地修改以从项目VCS存储库中恢复丢失文件。

使用项目入口处右键单击菜单中的Add Existing to Project命令,将现有文件添加到项目时,拟添加文件的名称和路径与丢失文件的名称和路径相同(例如,当在Altium Designer中打开项目后,将丢失文件添加到项目文件夹中时可能发生),将打开一个确认对话框,以询问您是否想要用选中文件替换丢失文件。

如需了解更多信息,请参阅Working with Documents页面。
此功能目前处于Open Beta阶段,且仅在Advanced Settings对话框中启用WSM.ManageMissingFiles选项时可用。

创建项目历史报告

此时可以为Workspace项目,创建Project History PDF报告。在OutputJob文件(*.OutJob),右键单击与Report Outputs入口关联的[Add New Report Output],然后选择项目Project History。

然后,可以将新建Project History输出报告连接到PDF输出容器。

右键单击创建的输出,然后选中Configure以访问Project History Report Configuration对话框,并在该对话框中对应导出报告的Period进行设置:整个项目历史或从/到特定的(或最新的)项目发布。

添加报告、链接到所需PDF输出容器并根据需要进行配置后,单击Generate内容或作为项目发布过程的一部分生成输出以导出项目历史。

项目历史报告示例 项目历史报告示例

请注意,Altium Designer标准订阅不支持项目历史报告导出功能。
如需了解更多信息,请参阅Project History页面Preparing Reports页面

特定层注释

添加了对PCB上2D特定层注释的支持。聚焦注释将自动切换至评审者拥有的相同视图(可见层、活动层、顶层/底层视图)。

聚焦注释时的视图配置切换示例。此处所示为聚焦注释前的视图配置:所有层均已启用,Top为活动层,且电路板从底层显示。将光标悬停在图像上,以查看聚焦注释后的电路板(应用与添加注释时相同的视图):Bottom为唯一启用的信号层,Bottom为活动层,且电路板从顶层显示。 聚焦注释时的视图配置切换示例。此处所示为聚焦注释前的视图配置:所有层均已启用,Top为活动层,且电路板从底层显示。将光标悬停在图像上,以查看聚焦注释后的电路板(应用与添加注释时相同的视图):Bottom为唯一启用的信号层,Bottom为活动层,且电路板从顶层显示。

如需了解更多信息,请参阅Document Commenting页面。

工作区存储库删除功能

如果存储库未对Workspace项目进行引用,则将由外部VCS托管的项目迁移至Altium 365 Workspace VCS后,可将Preferences对话框Data Management - Design Repositories页面中显示的Workspace存储库删除。

在将项目从外部VCS成功迁移至Workspace VCS后,将自动从Workspace中删除存储库。

说明:

  • 仅Workspace管理员拥有删除存储库的权限。
  • 如果项目已被软删除(移至Trash),则必须将其永久删除,以确保可删除引用它的存储库。
  • 无法删除Workspace的Versioned Storage存储库。
如需了解更多信息,请参阅 Making an Existing Project Available in the Workspace页面。

线束设计

本次发布首次实现了Harness Design功能。各类新入行工程师(参与产品设计过程)可使用该新工具,在Altium Designer中工作。其将全面线束设计支持引入与PCB和系统设计相同的环境中,从而消除了以前对第三方软件的严重依赖。

您可以使用Harness Design工具,创建从引脚间连接到制造文档的完整线束设计。线束设计既可作为独立项目,亦可作为Multi-board项目的一部分创建。在后一种情况下,Multi-board项目中PCB之间的逻辑连接用于定义线束内的连接。

本次发布引入了一个与新的多板演示项目(Harness_Demo_MB.PrjMbd)相关的示例线束设计项目(Harness_Demo_Prj.PrjHar),以确保可直接使用线束进行试车。

需了解更多信息,请参阅Harness Design页面。
此功能目前处于Open Beta阶段,且仅在Advanced Settings对话框中启用System.HarnessDesignAvailable选项时可用。请注意,Altium Designer Standard Subscription不支持Harness Design功能。

ActiveBOM增强功能

本次发布引入一些在ActiveBOM中使用替代元件时的增强功能。

在Add Alternative Item对话框中保留过滤器和值

当对相同类型不同元件的对话框进行访问时,可通过右键单击Workspace元件并选中上下文菜单中的Operations » Add Alternative Item命令进行访问的Add Alternative Item对话框,将记住所用过滤器和值。

防止使用已用元件替换替代元件

当尝试将替代元件替换为已用作替代元件的元件时,将弹出一个警告对话框以发出提醒。

 

确认删除具有替代元件的替代组

当尝试删除一组替代元件而该组中的元件已分配替代元件时,将显示一个警告对话框以提醒并要求您确认删除该组。

如需了解更多信息,请参阅Managing Your ActiveBOM Solutions页面。

电路仿真改进

高阻抗状态

添加了在SimData编辑器中,查看数字波形高阻抗状态的功能。

PSpice增强功能

本次发布中添加了对以下PSpice基元的支持:

  • LOGICEXP
  • Digital delay line
  • Digital Pullup and Pulldown
  • DFF
  • JKFF
  • DFFDE
  • JKFFDE

此外,以下PSpice基元的元件已添加到Simulation Generic Components库中:

  • 标准门
  • 三态门
  • 数字激励

Altium Designer 23.0版中完全公开的功能

以下功能已通过Open Beta阶段,并在本次发布中过渡为Public:

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

联系我们

联系原厂或当地办公室

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: