Altium Designer Documentation

EAGLE Import

Modified by Olesia Diachenko on Oct 1, 2018

他の形式や他のツールのデザインファイルで作業する要求に対応するため、Altium Designerは、CadSoft® EAGLE™(Easily Applicable Graphical Layout Editor)のデザインファイル、およびライブラリ(*.sch*.brd*.lbr)用インポーターを用意しています。

バージョンの対応

Altium DesignerのEAGLEインポーターは、EAGLEバージョン6.4.0(または、それ以降)で保存されたEAGLEデザインファイルをインポートすることができます。これらは、実際はXML形式です。EAGLEのバイナリ―形式のデザインファイルは、EAGLEインポーターを使って直接、インポートすることはできません。これらの古いバイナリ―バージョンのデザインファイルの場合は、Altium Designerにインポートする前に、EAGLEソフトウェアを使って新しいXML形式で保存してください。

EAGLEインポーターのインストール

EAGLEインポーターは、Altium Designerの初期インストール時に、その他の全てのインポーター、およびエクスポーターとともにインストールできます。Altium Designerインストーラー[Select Design Functionality] ページで、[EAGLE] オプション([Importers\Exporters] 機能セットの一部)を有効にするだけです。

[Importers\Exporters] 機能領域で、インストール対象としてEAGLEインポーターが選択されています。

この拡張機能が、ソフトウェアの初期インストール中に追加されていない場合は、[Extensions & Updates] 画面(ワークスペースの右上の コントロールをクリックしてメニューから [Extensions and Updates] を選択)でインストールの拡張機能と更新を管理する際に、[Configure Platform] ページから追加できます。

  1. 表示された [Installed] ページで、右上の [Configure] ボタンをクリックして [Configure Platform] ページを表示します。


最初に、[Extensions & Updates] 画面の [Configure Platform] ページを表示します。

  1. ページを下にスクロールして、[Importers\Exporters] 領域の [EAGLE] を選択します。

次に、[Importers\Exporters] の [EAGLE] オプションを選択します。

  1. ページの右上に戻って [Apply] ボタンをクリックします。変更内容を有効にするため、Altium Designerを再起動する必要があるので、ダイアログのプロンプトで [Yes] をクリックします。

EAGLEインポーターへのアクセスと実行

インポートは、インポートウィザード[File] » [Import Wizard])を使用して行います。EAGLEインポートウィザードにアクセスできるよう [EAGLE Projects and Designs] の項目を選択して、[Next] をクリックします。

EAGLEインポートウィザードは、Altium Designerの包括的なインポートウィザードからアクセスします。

EAGLEインポートウィザードは、次の操作を含め、それらのファイルのインポートに関連する方法を案内します。

  • プロセスに含めるEAGLEデザイン アーカイブ(BRD、および/またはSCH)を指定する
  • プロセスに含めるEAGLEライブラリファイル(LBR)を指定する
  • 一般的なログのレポート作成オプションを設定する
  • 回路図、およびライブラリのインポートに関連するオプションを設定する
回路図の階層は、対応しています。

インポートするEAGLEデザインファイル、および/またはライブラリと、必要に応じて、その他のオプションを指定します。

ユーザーは、出力ディレクトリーを指定することで、生成されたAltium Designerプロジェクトと関連ドキュメントの保存場所を完全に管理することができます。

デフォルトでは、出力ディレクトリーは、元のソースEAGLE設計/ライブラリファイルの場所です。

出力ファイル構成も提示されるので、作成物を正確に確認できます。全て必要な場合は、[Next] をクリックしてインポートを進めます。変更する必要がある場合は、[Back] ボタンをクリックします。インポートをキャンセルする場合は、[Cancel] をクリックします。

インポートプロセスを進める前に、出力ディレクトリーとファイル構成案を確認します。

インポートプロセスが完了したら、[Finish] をクリックしてウィザードを閉じます。インポート結果は、Projectsパネルに表示され、次のようにまとめられます。

  • Altium Designer PCBプロジェクト(*.PrjPcb)は、インポートされるEAGLEの.sch.pcb、および.lbrの各ファイルごとに作成されます。
  • EAGLE回路図アーカイブ(*.sch)は、Altium Designerの回路図ドキュメント(*.SchDoc)にインポートされます。
  • EAGLE PCBデザイン アーカイブ(*.brd)は、Altium DesignerのPCBドキュメント(*.PcbDoc)にインポートされます。
  • EAGLEライブラリ(*.lbr)は、Altium Designerの回路図ライブラリ(*.SchLib)、およびPCBライブラリ(*.PcbLib)ドキュメントにインポートされます。さらに、統合ライブラリ(*.IntLib)が、これらのソースライブラリに基づいてコンパイルされます。
  • インポートファイルごとにログファイル(*.log)が生成されます。このファイルには、元のEAGLEファイルの解析結果と、エラー、および警告(記録するよう設定されている場合)が保存されます。

EAGLE .pcb、および.schデザインファイルをインポートした後に作成されたAltium Designer PCBプロジェクトと、回路図、およびPCBドキュメント

インポート後の注意事項

EAGLEデザインファイルをインポートした後は、いくつかの点について確認し、場合によっては微調整することはごく一般的です。インポート後、次のような作業を行うことができます。これは、決して手間のかかる作業ではありませんし、もちろん必須作業でもありませんが、インポート後に考えられる検討事項においては、むしろ示唆に富む有効な作業です。

  • 回路図、およびPCBファイルが存在し、別々のプロジェクトにインポートされている場合、インポートされたデザインファイルを単一のAltium Designer PCBプロジェクトに移動(またはコピー)します。
  • コンポーネントリンク(回路図のソースとPCB基板がインポートされた場所)を確認します。そのデザインに関してインポートされたPCBから、[Project] » [Component Links] コマンドを使用します。続いて、[Edit Component Links] ダイアログを使用して、回路図とPCBコンポーネントをマッチング(リンク)させます。
  • [PCB Rules and Constraints Editor] ダイアログ[Design] » [Rules])を使用してデザインルールを確認し、インポートされたオブジェクトを対象にしていないルールを修正し、可能な場合は簡素化します(特に [Clearance]、および [Width] ルール)。
  • インポートにPCBライブラリがない場合は、PCBデザインからPCBライブラリを作成([Design] » [Make PCB Library])し、社内の必要な基準に応じて部品を修正し、3Dモデルも追加します。
  • 更新されたPCBライブラリに基づいてPCBデザインを更新します(適用可能な場合)。
  • [Design Rule Checker] ダイアログを使ってDRCを実行([Tools] » [Design Rule Check])し、エラーを修正します。
  • 関連するルールを使って、インポートされたポリゴンをより大きいポリゴンにクリーンアップします。
  • 基板にキープアウト外形を追加します。

 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

お問合せ

お近くの営業所にお問合せください。

You are reporting an issue with the following selected text
and/or image within the active document:
Altium Designer 無償評価版
Altium Designer 無償評価版
Altium Designerを使用していますか?

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

評価版ライセンスが必要な理由を下記から選択してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

その場合、評価版ライセンスは不要です。

ボタンをクリックして、最新のAltium Designerインストーラをダウンロードしてください。

Altium Designerインストーラをダウンロードする

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

Altium Designerの新規ライセンスのお見積もりをご希望の場合、下記のフォームに入力してください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Altium Designerサブスクリプションをご利用中の場合、評価版ライセンスは不要です。

お客様がAltium Designerサブスクリプションの有効なメンバーではない場合、下記のフォームに入力して無償評価版をダウンロードしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Altium Designerを評価する理由を下記から選択してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

無償評価版を使用するには、下記のフォームに入力してください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

アルティウムでは、学生の方や教育機関を対象とした特別価格ライセンスを提供しています。アカデミックライセンスの詳細については、こちらをクリック してください。.

また、下記のフォームに入力して無償評価版をリクエストしていただくことも可能です。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

その場合、Altium Designerビューワーの無償ライセンス(有効期間6か月)をダウンロードできます。

下記のフォームに入力してライセンスをリクエストしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

素晴らしいですね。アルティウムではモノづくりに最適なプログラムを提供しています。

Upverterは、コミュニティ主導型の無償プラットフォームで、お客様のような作り手の要求に合わせて設計されています。

試してみる場合、こちらをクリック してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

その場合、Altium Designerビューワーの無償ライセンス(有効期間6か月)をダウンロードできます。

下記のフォームに入力してライセンスをリクエストしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。