Knowledge Base

Created: November 19, 2020 | Updated: October 4, 2021

Contents

All Contents
Sort by:
Our Knowledge Base is developed from our users questions. Find answers and step-by-step instructions. Chances are we’ve seen your question before.

 

Title Views Votes

SOLIDWORKS CoDesigner panel error: There is no document opened…

I get this message in the SOLIDWORKS CoDesigner panel, "There is no document opened or the active document is not linked with PCB design." (for PCBs pushed from Altium using MCAD CoDesigner to SOLIDWORKS) after creating a "SpeedPak" configuration in SOLIDWORKS, which prevents most parts from loading to improve performance.

Read More
0
0
2 views
20

"The Internal ID Does Not Match" issue with SOLIDWORKS MCAD

This happens when several boards with the same set of components are used in a device assembly AND IF there is no common component folder set up in CoDesigner’s settings.

Read More
0
0
7 views
70

Graphics Support in Altium 365’s Web Viewer Interface

This knowledge article details the limited support of graphics in Altium 365's web-browser interface.

Read More
0
0
5 views
50

Server License Not Set or All CALs in use

If you didn't get a chance to refresh the license for your on-site managed content server before it expired, you may see this error message when trying to sign in from a remote web browser. You can also use the method described in this article to log into your server when all the Client Access Licenses (CALs) are already in use.

Read More
0
0
8 views
80

MCAD collaboration in NEXUS

I can't find the CoDesigner panel in NEXUS.

Read More
0
0
11 views
110

How can other Mechanical Engineers see my MCAD CoDesigner changes?

CoDesigner is not a storage system for synchronizing changes among Mechanical Engineers (MEs)

Read More
0
0
4 views
40

Can I increase the quality of the decals in SOLIDWORKS MCAD?

This article has some options that can affect the quality of decals.

Read More
0
0
2 views
20

SOLIDWORKS MCAD is used with SW PDM (Product Data Management)

This article has some guidance for when SOLIDWORKS is used with SOLIDWORKS Product Data Management

Read More
0
0
2 views
20

MCAD Autodesk Vault is used with Autodesk Inventor

This article describes a short procedure to better enable this functionality

Read More
0
0
4 views
40

Changing Owner of an Altium 365 Workspace

This knowledge article provides the necessary details to change the owner of your company's active workspace.

Read More
2
1
54 views
54-1

MCAD CoDesigner panel is not visible in Creo

There are different resolutions based on whether the add-in is loaded, failed to initialize, or is hidden in the User Interface.

Read More
0
0
7 views
70

MCAD SOLIDWORKS: Low performance with building a board

Move the toolbox to a local drive.

Read More
0
0
2 views
20

MCAD Fusion 360 Personal: Components are not shown

This version of Fusion 360 is for non-commercial use.

Read More
0
0
3 views
30

MCAD Fusion 360: Bad performance with the boards with 500+ components

This is a known issue with Fusion (reported for all big assemblies, not only with the ones built by CoDesigner.)

Read More
0
0
3 views
30

MCAD Fusion 360: The visibility of Copper and Soldermask

They are hidden by default.

Read More
0
0
2 views
20

Changing the board origin in MCAD

We can't rely on the relative ECAD origin because it can be easily changed in ECAD, and it's not realistic to synchronize the changes with MCAD in that case.

Read More
0
0
2 views
20

How to change the Port Cross Reference Display?

I'd like to add port references to my schematic, but I don't want to include the zone or grid references in order to save space.

Read More
0
1
29 views
291

Release not available

"Release not available: Project is not registerd [sic] in PLM" may show up when using Project Releaser, if you have a PLM extension installed.

Read More
0
0
2 views
20

Can't export DXF or DWG files - Class not registered error

When I try to export a PCB as a DXF or DWG, I get an error with the following details: Class not registered at ###... SaveDxf.dll, Base Address: ###...

Read More
0
0
8 views
80

Yellow line thru entire PCB window

If you have a yellow line through your PCB, it is probably a guide line (Snap Guide.) The color can be changed.

Read More
0
0
6 views
60

How do I use PerfView to collect additional data?

This article details the steps and settings to collect additional data for your support issue using Microsoft's PerfView tool.

Read More
0
2
19 views
192

Enabling VCS of an Uploaded A365 Project

A previously released project may not have utilized the built-in VCS of Altium 365. This article discusses how to add the project to the built-in VCS of Altium 365 after it has been released.

Read More
0
0
61 views
610

Re-adding a project to the A365 workspace

How to re-add a project to the A365 workspace. If the project has been already deleted from the workspace but you want to re-release the project back to the workspace, we need to remove the links from the previous release to the workspace to allow for the re-release to be available.

Read More
0
0
94 views
940

Which subscription plan do I have currently?

This article describes how you can determine your current subscription plan level

Read More
1
1
22 views
220

PCB Why do I see Designator overlaid on my extra designators?

Special Strings Display - You toggle the display of the Special Strings overlay within the View Configuration panel, go to the View Options Tab and toggle the visibility of Special Strings.

Read More
0
1
91 views
911

3D Model Placement in Footprint Library

How to place a 3D Model precisely in your footprint in a PCB library

Read More
0
5
123 views
1235

Variant Printing in Schematic from Output Job

Variants Not showing on the schematic prints when generated through output job.

Read More
4
3
29 views
29-1

Sending an enclosure from MCAD to ECAD

This article has links to learn how to send an enclosure from MCAD to ECAD

Read More
0
0
5 views
50

Slowness at startup

Here are some things that can cause a slow startup.

Read More
1
0
18 views
18-1

Map MCAD Models to ECAD Components

This article covers how to make models placed on the MCAD side be recognizable on the ECAD side when using a Pro subscription plan.

Read More
0
0
18 views
180

MCAD CoDesigner Keepout transfer

Is it possible to transfer keepout areas using MCAD CoDesigner? CoDesigner 2.1.0 and newer has an updated MCAD CoDesigner panel that now has a PCB Definition tab which displays Board Area definitions that exist on the board.

Read More
1
1
28 views
280

ECAD-MCAD model not properly imported warning

Transfering to MCAD domain, a message indicating there is a problem with 3D model and it will be substitute with simple geometry.

Read More
0
0
30 views
300

Viewing Copper in SOLIDWORKS

I can only see the bare board and components. How can I see the copper traces in SOLIDWORKS MCAD?

Read More
0
0
32 views
320

ECAD to MCAD transfer redraws board

This article describes why a transfer from ECAD to MCAD redraws board shape and loses board constraints.

Read More
0
0
36 views
360

Silkscreen not displaying in SOLIDWORKS

ECAD / MCAD CoDesigner transfer is not showing silkscreen in SOLIDWORKS. Sometimes the decals that represent copper and silkscreen and solder mask are not shown in SW 2019+ because of problems with the rendering on some video cards. The solution can be to change this flag in SOLIDWORKS preferences.

Read More
2
0
19 views
19-2

Altium Academy videos for ECAD-MCAD CoDesigner

Here is a link to a collection of videos from Altium Academy that may improve your experience with ECAD-MCAD CoDesigner

Read More
0
0
21 views
210

Importing a logo into a PCB document

This article describes how to import your company logo or other bitmap file (*.bmp) into your PCB document.

Read More
3
0
16 views
16-3

Placing a logo into a PCB document

How to place your company logo or any Graphic object ( a non-electrical primitive that can be placed on a PCB and PCB Library document and populated with a standard image file (*.png, *.jpg, *.bmp, *.svg.).) into your PCB document.

Read More
10
8
139 views
139-2

How to import Allegro files to Altium

This document describes different approaches for getting Allegro files into Altium Designer.

Read More
2
10
212 views
2128

You must have Microsoft(R) Excel installed on your machine

I can no longer generate any outputs that require MS-Excel since there seems to be an issue with Altium's ability to open the program. MS-Excel is working just fine for me and no other applications I use have issue with it, but I get this error, "You must have Microsoft® Excel installed on your machine to be able to generate a Board Stack Report."

Read More
14
0
65 views
65-14

Alternative Parts with Active BOM

I am trying to add an alternative part to an item on the active BoM for a non managed component, but when I right click on my item I do not get the option to add an alternative as expected according to documentation.

Read More
1
0
44 views
44-1

PCB Select and Dimming

This article discusses the ways you can affect Dimming, Masking, Zooming, and whether objects get selected in the document workspace when they are selected in the PCB panel lists.

Read More
2
0
17 views
17-2

Startup issue - Failure to Launch (or install)

This article has a long list of things to try when Altium won't start. Some of these also apply if Altium won't install.

Read More
2
0
40 views
40-2

Altium 365 Workspace error - You do not have a valid subscription for Altium Designer

I'm getting this error message: You do not have a valid subscription for Altium Designer (Expired at 1-Jan-2000). Subscription is required for Altium Designer to work with an Altium 365 Workspace."

Read More
0
1
163 views
1631

Student License

This article has information that will be helpful for students that want to start using Altium Designer.

Read More
1
4
11 views
113

PCB Panel Selection and Highlight Controls

When objects are selected in the Primitives list in the PCB panel, the behavior in the editor may not be as expected. This article reviews settings that can change behavior such as Dim / Normal / Mask, Clear Existing, and Zoom etc. and whether objects get selected in the document design editor workspace window when they are selected in the PCB panel lists.

Read More
1
0
23 views
23-1

How to install Software Extensions in an offline environment

I run Altium on an offline computer. It is not possible to attach to the Internet or any other network. How do I install Software Extensions & modify the Core Feature Set in this environment.

Read More
0
0
21 views
210

Connection lines & move component

Why do the connection lines not move the same when I use the Edit ► Move ► Component as they do if I would use dragging of the component in PCB Editor

Read More
0
0
16 views
160

Connection lines disappear when moving component

On a component with n-number pads the connections disappear when moving the component

Read More
4
1
169 views
169-3

Can Only Move Parts So Close To Each Other

How to change the mode of moving Components on a PCB

Read More
2
2
18 views
180

Can you set Electrical Clearance in the Design Rules for the Route Tool Path

Route Tool Path is defined on Mechanical layer, how can I define clearance to this path?

Read More
0
0
107 views
1070

Can't add bending line/Split line cannot be moved after placing/Board region cannot be selected

How do I add and modify a bending line to my Rigid Flex design?

Read More
7
2
25 views
25-5

Can't connect to Altium Infrastructure Server (AIS) after installation

If you just installed the Altium Infrastructure Server (AIS), the most common reason connection fails is because the licenses that came with the installation package were not installed.

Read More
1
0
74 views
74-1

Cannot delete Layer from Layerstack

This article describes a couple of scenarios in a Pcb document that can prevent layer deletion in the Layer Stack Manager.

Read More
6
0
127 views
127-6

Cannot select an Object that somehow is very far from PCB boundary

There appears to be objects outside of my workspace area, I am not able to find nor select them. How can I select them to delete. No matter what I do, it will not be selected.

Read More
9
1
19 views
19-8

Clearance Constrain between polyregion on multilayer and pad on top layer

I have an error stating "Clearance Constrain between polyregion on multilayer and pad on top layer" on my PCB layout. Every pad is having this error, as well as a through hole component. When I click to "jump to" the violation... It goes to the corner of the board and just says there is a clearance violation.

Read More
20
6
26 views
26-14

Combine OrCAD Schematic Import and PADS Allegro PCB import into single Project

Create a single project linking imported OrCAD Schematic Project and imported PADS/Allegro PCB Project

Read More
0
2
70 views
702

Command line installation parameters

This article covers the command line installation parameters that are available for Altium Designer.

Read More
1
4
36 views
363

Compile Error: Duplicate Net Names(Multi-Channel, Bus)

[Error] TopSheet.SchDoc Compiler Duplicate Net Names Bus Slice - I am receiving this error on the buses from my multi-channel sheet, and my buses do not look like they are properly connecting in the netlist. The buses look to be properly formed. How do I fix this Duplicate Net Name on Multichannel design error?

Read More
47
2
163 views
163-45

Component not created in Vault after running the batch file

We are tying to add components in Altium Vault/Concord Pro through .csv files. This method is working for some categories, but not for all.

Read More
0
0
27 views
270

Component placement for ODB++ files

I am importing ODB++ files into a fabrication house software MacroFab. Every time the component placement file comes in, it's position is offset from the actual board origin in the Gerber files. How do I make the component placement files match the PCB 0,0 origin when importing into MacroFab software.

Read More
0
0
9 views
90

Components Panel Filter not Correctly Filtering on Database 'value' Parameter

Using a Database Library with Microsoft Excel, formatting in the Excel file can cause the filter to not work correctly when read by Altium Designer. For example, setting the filter to "greater than or equal to #" does not filter correctly. We will look at how to format the column in the Excel database so it can be processed correctly.

Read More
0
0
39 views
390

Configure and Animate the bending of a PCB that is entirely Flex

Configuring and Animating the bending of a PCB that is entirely Flex

Read More
0
0
84 views
840

Convert a Fill or Region into a Polygon

When I try to create a polygon from the outline of overlapping shapes using Fills and Regions it does not work.  When I try to run the command it tells me it cannot find an enclosed shape (Tracks, Arcs, Full Circle) and when I click YES nothing happens.  How can I get this to work?

Read More
9
4
94 views
94-5

Convert Plated via Backdrills to Non_Plated in ODB++ output

Exporting ODB++, as of AD20.1.7, the exported backdrills are incorrectly set as VIAs which are plated. This shows how to modify the output to set the vias as NON_PLATED

Read More
0
1
33 views
331

Copying Circuit Selection From One Project to Another

What is the best method if I want to transfer a section of a schematic circuit and the associated layout from an existing project to another project?

Read More
1
7
37 views
376

Copying from Footprint (unlocked primitive) to PCB does not work

I can't select primitives of mechanical layers on a footprint and copy them to a mechanical layer on the PCB. I can only bring over the primitives to the PCB by changing the layer assignment in the properties panel. However, the primitives are still tide to the component footprint. How do I copy primitives from the footprint to the PCB?

Read More
1
1
15 views
150

Copying Multiline text to a string

When copying multiple lines of text from a PDF document to paste into a single string, only the first line will paste.

Read More
0
0
14 views
140

Delete a line from BOM

Is there a way to delete a line in the draftsman Bill Of Materials table? I have a test point that showed up there, and I am looking for a way to remove it.

Read More
1
0
10 views
10-1

Design Item IDs are reset and lost on update or placement from Schematic Library

Every time I update the schematic symbols, the Design Item IDs of some schematic symbols are reset. The same happens when I place these components from the components panel for components of Schematic (*.SchLib) and Integrated Libraries (*.IntLib).

Read More
1
1
58 views
580

Draftsman Drill Table Plated Column is in Russian

It appears that the Plating column data in Draftsman Drill Table objects only displays in Russian - I cannot find a language setting somewhere to modify the language of the information in this column.

Read More
0
1
26 views
261

DRC doesnt catch unconnected nets

I have a PCB design in which the DRC doesn't catch unconnected nets, although the check is enabled in the design rules.

Read More
1
3
32 views
322

Error - Microsoft Visual C++ runtime library

Altium crashes with the error: Microsoft Visual C++ runtime library.

Read More
4
0
27 views
27-4

Error code 68

I'm getting one of these errors when starting Altium Designer: Exception loading Wpf UI Error initializing licensing service Error code 68

Read More
0
1
25 views
251

Failed to create Key

Reported Error message "Failed to create Key" while trying to install Altium Designer even as an offline installation.

Read More
0
0
35 views
350

Feature request

Something is not working the way I expect or want it to work. I would like to see an enhancement.

Read More
0
0
24 views
240

General Slowness

Here is a long list of things that may help you track down an underlying cause.

Read More
10
0
93 views
93-10

Generating IPC-D-356A document and compare to extracted netlist

I am trying to export an IPC-356 file from the Altium CAM editor. I am receiving the following error Cannot Open File for Netlist Output!

Read More
3
1
68 views
68-2

Hide old expired licenses

Our organization has a bunch of expired licenses. Is there some way to remove them from the list in the Altium Designer license management page so it will look less cluttered and be less confusing to our users trying to pick a valid license that is under subscription?

Read More
0
0
13 views
130

How can I change the grid from mil to mm or set my designator to Visible in a Schematic Library

How can I change the grid from mil to mm or set my designator to visible in a Schematic Library

Read More
33
5
15 views
15-28

How can I copy everything to a new PCB

I suspect some sort of corruption with my PCB. I want to try copying as much as I can from my current PCB to a new "clean" one. I read that this might resolve my issue with "undo not working" in one particular PCB.

Read More
0
1
16 views
161

How do I reset the Altium Designer configuration to the installation defaults?

Reset the configuration of Altium Designer.

Read More
4
6
605 views
6052

How do I reset Unique IDs in version 21 and newer?

For AD20 and older, I used to follow this documentation: https://www.altium.com/documentation/altium-designer/sch-dlg-resetpartsheetsymboluniqueidsreset-part-and-sheet-symbol-unique-ids-ad?version=20.2 Now the option is gone.

Read More
0
4
37 views
374

How to access the Content Vault in the Explorer panel?

In Altium Designer 20 the Content Vault is not accessible via the Explorer panel per default. This article describes how you can make the Content Vault accessible via the Explorer panel again.

Read More
5
1
40 views
40-4

How to activate the Mixed Simulation tool in Altium Designer

How to activate the Mixed Simulation tool in Altium Designer

Read More
0
2
27 views
272

How to control the Designator location in Schematic Library

Component designator and comment can be made visible in the documents options of a schematic library.

Read More
4
19
36 views
3615

How to determine with which version a file was authored

Is there a way to determine which version of Altium Designer was used to create a project or design?

Read More
2
0
16 views
16-2

How to edit board shape

How to edit the board shape.

Read More
5
6
10 views
101

How to import CircuitMaker files into Altium

How to import CircuitMaker / CircuitStudio files into Altium

Read More
5
2
56 views
56-3

How to perform a thorough uninstall

Sometimes the operating system doesn't fully uninstall a software program. This document explains what you can do.

Read More
0
2
48 views
482

How to roam (Check Out) a license for offline use

When roaming, a seat of a license is acquired for a specified time. You do not need to remain signed-in to your account to use the license in this mode. You can sign out and work offline, in essence roaming freely with your license seat. This can be done with an On-Demand or Private Server licenses (not available if you are using the legacy Private License Server (PLS)

Read More
1
0
9 views
9-1

How to select multiple Designators

This article describes different methods to select multiple Designators in a PCB.

Read More
2
0
10 views
10-2

How to short two different Nets - create a Net Tie

This article covers the basics for the creation of a Net Tie

Read More
0
5
58 views
585

How to update Variant Parts with library?

After updating my schematic library the part does not get updated in the project when I run the BOM tool. On close inspection I can go into the Variants and the part to be varied is not showing the correct Part Number or Manufacturer fields. Going into the select alternative part I can confirm that the part in the Library is correct but there is no way to update the Variant listing. If I deselect it as fitted and then re-choose as a variant the data is corrected.

Read More
4
0
28 views
28-4

How to use a license

I have purchased a license, and I've downloaded and installed the software for Altium Designer. What do I have to do to get the software licensed so I can use it?

Read More
0
0
41 views
410

I am getting a Validation Error on my Project Schematics what does this mean

When validating schematics in a Project, various messages can be generated by the compiler. Please review the list of messages provided here for more information

Read More
1
1
243 views
2430

Import or Export Design Rules

How to import and/or export design rules?

Read More
9
13
12 views
124

Importer for KiCAD

We see that Altium supports importing of files from Kicad to Altium but we do not see how to add that importer. Do we need a later version of Altium to see this?

Read More
14
3
14 views
14-11

Importing a Mechanical Outline to PCB

Our mechanical engineer has created a PCB board outline complete with hole sizes & dimensions, and has sent it in 3D step file format. How to create a board shape from this file and other mechanical file types.

Read More
0
0
66 views
660

Board Cutout not in Gerber output

Board cutouts are not exported in Gerber file export. This article shows how to generate outlines for the cutouts onto a mechanical layer for documentation and inclusion in the fabrication output files.

Read More
3
22
40 views
4019

Background Turns Dark when Placing Track

Pressing P, T to place track. Once a net is clicked on to route, the background turns dark. This is a problem because I am now routing my board blind. Can't find the setting to fix this

Read More
0
1
15 views
151

Avoid adjacent layer parallel track routing

How to set a rule to avoid adjacent layer parallel track routing

Read More
0
0
15 views
150

Altium.PCB.DataModel.dll Crash on PCBDoc

Altium crashes with a Altium.PCB.DataModel.dll error message when I try to route or when repouring polygons on the PCBDoc.

Read More
3
2
27 views
27-1

Altium does not start per click (nview)

If I try to start Altium Designer by clicking from the start menu or from the task bar it usually takes a lot of tries to do this.

Read More
3
1
10 views
10-2

Altium Designer is not informing me of updates or allowing me to install them

When installing with the Offline Installer, online activity is disabled and 'greyed out'. Including the ability to check for and install updates. This is how you turn it back on.

Read More
0
0
155 views
1550

Altium Designer is crashing when trying to Open any project

Getting this error: HRESULT: [0x88990012], Module: [SharpDX.Direct2D1], ApiCode: [D2DERR_WRONG_FACTORY / WrongFactory], Message: The objects used together must be created with the same factory instance at ###... AdvSch.dll, Base Address: ###... Error when starting AD and eventually when I click on SCH sheet or a BomDoc file. Sometimes these error messages continue to pop up over and over again until I close AD from Task Manager.

Read More
41
2
100 views
100-39

Installing multiple instances of AD versions

Can I install more than one version at a time? Do I have to remove older versions first? Do I have to use the same version to edit as was used to create the project?

Read More
1
1
21 views
210

Is 3D view of a Cavity in PCB possible?

I would like to display my component in 3D while it is placed within a cavity, is this possible?

Read More
0
0
95 views
950

Layer Stack PDF Export Missing Bottom Surface Finish

You may come across some issue when placing, say, Layer Stack Table, in your *.PcbDoc for your documentation purpose, as it may not support all newly added elements, such as Surface Finish layer. Altium considers the legacy method to be somewhat obsolete and instead would like to direct you to Draftsman for this purpose.

Read More
0
0
22 views
220

Manufacturer Part Search (MPS) panel issues

How to resolve most Manufacturer Part Search (MPS) panel issues

Read More
17
0
64 views
64-17

Method to remove Managed Servers from Altium

How to remove previously connected managed servers from Altium? Even when signed out, the managed servers that were previously connected to would appear in the account drop down menu.

Read More
0
1
50 views
501

My Update button is greyed out - Trying to update Altium Designer

There is an update Available for Altium Designer, but my update button is greyed out. How can I update?

Read More
0
1
102 views
1021

New to Altium Designer or resume work with AD after break or major update

For all those who are new to Altium, starting to use it now more frequently or have updated from a really old version. This article covers how to contact Support, finding Learning Materials, Tutorials, and other useful information for getting (re) started.

Read More
0
0
80 views
800

Nothing happens when trying to use a license

I can't use a license. I click on a license, then click the use control below, or right-click on the license and choose "use" but nothing happens.

Read More
6
1
35 views
35-5

Numbering Sheets in Multi-channel

What are the steps and requirements to number my sheets in a multi-channel design?

Read More
2
1
58 views
58-1

Off Sheet Schematic Component Removal

Somehow I got a component outside of my sheet area and I cannot select or delete it. How to remove the component or get it back onto the sheet?

Read More
14
8
41 views
41-6

Active Bar how to disable or customize

Active Bar can only be disabled, not customized

Read More
1
5
34 views
344

Offline installer

This article explains how to get an offline installer package and related information.

Read More
0
0
32 views
320

Options for getting an AltiumLive password reset

Here are some ways a password can be reset.

Read More
1
0
20 views
20-1

PDF output - An error exists on this page

After creating a PDF via Output Job or Smart PDF creation, the Adobe Acrobat Reader throws the following error while opening the file: "An error exists on this page. Acrobat may not display the page correctly. Please contact the person who created the pdf to correct the problem" German version: Fehler auf dieser Seite. Die Seite wird unter Umständen nicht richtig in Acrobat angezeigt. Wenden Sie sich and den Ersteller des PDF-Dokuments, um das Problem zu beheben.

Read More
5
4
49 views
49-1

Plane Clearance

Where can I find the plane to edge clearance?

Read More
2
4
14 views
142

Port and URL information for when firewall or VPN is blocking access

I can't get the system running while connected to VPN. As soon as I disconnect form VPN, Altium starts running.

Read More
0
1
138 views
1381

Ports and IP Addresses for Altium Designer

We have strict firewall rules, is there any documentation available which states what IP addresses, ports are required to use this feature?

Read More
1
0
111 views
111-1

Power Port reduced to Local level warning

I get a warning when I compile my project schematics: "Global Power-Object ... has been reduced to local level by presence of port at ..." It is a Warning in the Message panel after validating the project.

Read More
10
1
19 views
19-9

Provider Cannot Be Found Error when Translating .IntLib to .DBLib

Trying to convert an .IntLib into a .DBLib using the menu option Tools ► Import from Integrated Libraries when the .DBLib is active in the workspace brings up this Error: "An error was encountered exporting. Provider cannot be found. It may not be properly installed. The export has been aborted."

Read More
0
0
25 views
250

Remove Solder Mask and Paste Mask from PCB Pads

How to remove the Solder Mask / Paste Mask from a Pad

Read More
4
2
62 views
62-2

Reverse Engineering from Gerber to PCB

I want to create a PCB from a Gerber file

Read More
2
13
49 views
4911

Rollback entire SVN Repository

When there is an issue with the current revision of the repository, there is a method on how to rollback to a previous revision.

Read More
2
0
62 views
62-2

Scroll bars are missing from PCB and Schematic editor windows

I thought there were scroll bars when zoomed in sufficiently in the PCB and Schematic editors. I don't have them anymore. How do I get them back?

Read More
3
3
20 views
200

Search Paths tab missing in Project Options

If you are used to using the Search Paths tab from previous versions, this article explains how you can bring it back.

Read More
1
1
20 views
200

Signing into a managed content server from within Altium Designer

Signing into and Connecting to a managed content server (such as Altium 365 workspace) from within Altium Designer

Read More
0
0
133 views
1330

Size Limits of PCB workspace

Move components left or down not working? Probably because you have reached the absolute zero coordinate. From there the workspace extends to the top and to the right, but you cannot reach any points below absolute zero. It would be best to move the whole board.

Read More
3
3
31 views
310

Slowness in specific areas

Sometimes there are settings or things about your documents that can cause unusual slowness. Here are some things to look for.

Read More
5
2
57 views
57-3

Status Bar is missing at bottom edge

I regularly rely on the XY location shown in the bottom left corner of the window frame as well as the hints and other messages that appear along the bottom of the window frame. For some reason, these are missing now. How do I get them back?

Read More
1
1
13 views
130

Subscription Expired on License

Receiving a Subscription Expired message, but I am sure it was renewed. How do I check and fix this?

Read More
5
1
101 views
101-4

SVN Error Commit failed, or Working Copy locked, or is already locked

I appear to have a lock on my SVN files. Or, when I try to commit that file I get an error - Commit failed - Previous operation has not finished; run 'cleanup' if it was interrupted.

Read More
0
0
69 views
690

Thermal Relief Connections for Custom Pads

How to create Thermal Relief Connections between Polygons and Custom pads.

Read More
1
1
78 views
780

Unable to move component even with Online clearance rule disabled

It is not possible to place a component on the PCB near to another components. Something seems to block the component from the placing. The reason is the different mode of moving objects.

Read More
10
1
51 views
51-9

Unable to open *.DRL file in Altium

*.DRL generated by the CAM Editor is in ASCII Format and readable. The best practice is to always provide your Fabricator with the .TXT generated from the PCB Editor, and ignore the *.DRL generated by the PCB Editor.

Read More
0
1
43 views
431

Unable to select and Delete Text

There are text on the PCB that the user is unable to select and due to this, they are unable to move / delete them.

Read More
11
2
30 views
30-9

Unable to select objects

If you are unable to select objects, make sure to check your configuration in Selection Filter under Properties panel https://www.altium.com/documentation/altium-designer/interactiveproperties-pnl-propertiesproperties-ad#!pcb-support

Read More
54
6
20 views
20-48

Uninstall Windows Updates

I suspect a recent Windows update is responsible for a new issue I am experiencing with Altium. How do I uninstall specific Windows Updates

Read More
0
0
9 views
90

Unknown Server - Can't make project available online

When it is opened, the project is shown in the projects panel under 'Unknown Server'. Even though I am logged into a workspace, I am not presented with the option to 'make project available online' when I right click on the project name in the projects panel. If I try to share the project, I am presented with a 'please switch to workspace to share this project' message.

Read More
1
0
13 views
13-1

Update gives error: This application requires Windows hotfix KB3140245

I can load up to 20.1.12, anything newer than that gives me the error. I ran the hotfix but I still get the error message. The error message opens up a Microsoft window that runs through the fix but after doing that it still doesn't work. When I try to install it manually, I'm getting: The update is not applicable to your computer" I am running Widows 7 professional 64bit

Read More
17
2
22 views
22-15

Updating schematic component footprints from the PCB Document.

For designs where the footprints in the PCB do not match the footprint configured in the schematic component, this will show you how to get them in sync.

Read More
13
3
152 views
152-10

User's email address already exists in another organization

This article discusses the issue of getting a message that the "User's email address already exists in another organization" or "Failed to create user account: Username: xxxx@yyyy.com already in use", or "Cannot add user: user with this email is already registered in other organisation" when you try to add them from your dashboard.

Read More
2
1
37 views
37-1

Using Local File Based Excel BOM templates

When signed into a managed server, why am I unable to use local file based Excel BOM templates.

Read More
1
0
38 views
38-1

Variant - Schematic - Project level parameters

Note of project priority when used in conjunction with special strings at various levels of your project files. How are same named parameters resolved?

Read More
3
1
68 views
68-2

Version not supported despite valid subscription - Refresh PLS license

We updated Altium Designer to a newer version, but now the client says our licenses do not support it. Our subscription for our private server license is current and the future date is displayed on the license management page subscription status column.

Read More
0
0
69 views
690

Version not supported with private license server - Refresh PLS & AIS

This article covers what to do when you get "Version Not Supported" error when using a private license server. It also has a comparison of the legacy Private License Server (PLS) and our current license server, Altium Infrastructure Server (AIS.)

Read More
0
1
206 views
2061

Viewer

If you have engineers that sometimes need only to view a project and therefore don't need a full license, they can leave the full licenses available in your organization's pool by using a viewer license. This article reviews some options based on your circumstance.

Read More
2
0
16 views
16-2

Warning: License Renewal Failed

This article has steps that should stop the pop-up message: Warning: License Renewal Failed The License Manager was not able to renew your license. Altium Designer will retry periodically.

Read More
19
5
50 views
50-14

What determines whether Altium will update to the next version rather than separate install?

Sometimes Altium Designer lets me update the software to the next version and sometime it has to be a new install into a new folder. What's that about?

Read More
0
0
13 views
130

What Does the White Arrow on Some Documents Mean?

In the Project Panel, why do some document icons have a small arrow in a white box on them?

Read More
1
0
14 views
14-1

When things don't display or print properly

Here are some things to try when a panel doesn't open after selection or doesn't display properly, or when things don't display or print properly in general

Read More
6
1
35 views
35-5

Why am I seeing different designators in my schematic?

This article summarizes how to remove board annotation if it was accidentally added to your project, or if it is no longer wanted.

Read More
4
1
213 views
213-3

Why are PCB 3D Models not Displaying in the 3D View?

The display of 3D body models in the PCB 3D view is controlled by a setting in the View Configuration Panel. We will take a look at how to ensure this option is enabled.

Read More
23
2
62 views
62-21

Why is my text upside down?

Text on my schematic is displaying upside-down

Read More
1
0
19 views
19-1

Why is there a [1] in front of my schematic sheet name?

There is a [1] in front of my schematic sheet name in the Projects panel. How do I get the normal filename back?

Read More
0
11
22 views
2211

Working with 32-bit and 64-bit software compatibility

This article covers how to use Database Libraries with 32-bit and 64-bit Altium Designer Software on the same computer and how to use a 64-bit version of Altium Designer when you are using a 32-bit version of Office. This article should help you out if you get the message: "The operating system is not presently configured to run this application." as described in this forum post: https://forum.live.altium.com/#posts/238667/731116. Or if you get this message: "An error occurred while establishing a connection to the database. Altium Designer requires that the 64-bit Microsoft Access Database Engine be installed. For more information and application solutions, click here."

Read More
1
0
78 views
78-1

Panels get rearranged i.e. stacked

Sometimes, the panels in Altium Designer get stacked on top of each other. This article describes the process on how to prevent them from showing in fractal mode in future.

Read More
0
3
21 views
213

How to group panels in tabbed mode when they are in fractal mode?

I want a panel to be tabbed with other panels that appear just above it. No amount of dragging will group it in tabbed mode. Why doesn't it stay where I put it?

Read More
0
3
47 views
473

How to add line number to a BOM template

How to format BOM template column to include line # (line number). Unable to add Line # using the Column=Line Number Format in a BOM Template

Read More
6
0
50 views
50-6

Connection Lines on PCB - Rats nest display

How do I control the display of Rats nest on my PCB, I want to show or hide them

Read More
10
7
163 views
163-3

Owning More Than One Workspace

An organization can only have one workspace.

Read More
0
2
26 views
262

Multiple Server CAL checkout

Signing into Concord Pro or NEXUS Server, duplicate checkouts per user are happening.

Read More
0
0
34 views
340

Managed Content Server upgrade

This document covers a best practice quick review of the steps to follow when upgrading your current on-site managed content server to our current version. As when you have been using Vault and want to upgrade to Concord Pro.

Read More
0
0
17 views
170

LDAP syncing

We are having issues with LDAP syncing with our Altium Server. It was working prior and we are now receiving: "There was no endpoint listening at http://localhost:9791/LdapSyncStatus that could accept the message. This is often caused by an incorrect address or SOAP action. See InnerException, if present, for more details."

Read More
0
0
21 views
210

How do I log in as administrator to release seats when none are available

How is it possible to login as an Administrator to a locally managed content server (Vault/NEXUS/Concord Pro) web interface to release seats?

Read More
0
0
8 views
80

Design repositories SVN not available after update from Nexus server

How to enable SVN repository support for NEXUS or Concord Pro managed content servers

Read More
0
0
52 views
520

Library Migrator to Altium 365

Migrating File-Based libraries to Altium 365 workspaces

Read More
2
0
77 views
77-2

How to rename a Managed Project and what happens to the local copy that was checked out previously?

This knowledge article describes how a project owner can rename an existing managed project, and how to propagate the same project name when opening the project again in Altium Designer.

Read More
0
2
18 views
182

How does Altium's Library Migrator handle components in an integrated library with different components using same symbols?

This article describes how the Library Migrator, used to convert local libraries to managed components in an Altium 365 workspace or a managed server (Concord Pro or Nexus), handles duplicate symbols being used across multiple components with different parameters.

Read More
0
0
100 views
1000

How To Control Lifecycle Transition Permissions in Altium 365?

This knowledge article discusses the different levels of support for controlled lifecycle transitions and lifecycle transitions through approval requests in Altium 365, and how to configure lifecycle definitions for the Altium 365 workspace in a supported web browser and Altium Designer client.

Read More
0
0
21 views
210

Managed Project Organization in Altium 365 Pro

With the latest release of Altium 365, projects can now be categorized by Folder Type.

Read More
1
0
18 views
18-1

Is it possible in A365 to remove a release and redo the process so we can keep the same revision number?

This knowledge article explains reverting manufacture server items to a previous revision.

Read More
7
0
38 views
38-7

Soft Delete Items from an Altium 365 Workspace

The purpose of this documentation is to provide information on how to delete items permanently from the Altium 365 workspace.

Read More
0
0
21 views
210

Concord Pro issues after migration - Re-index

After updating Concord Pro you may experience some of these issues: The "500 Internal Server Error" error message. Component cannot be released. Health monitor may show index errors. Re-indexing likely will resolve these issues. This article tells you how.

Read More
1
0
47 views
47-1

Can't delete empty folder

Can't delete empty folder from managed content server

Read More
0
1
35 views
351

FIPS and Backups

We're trying to migrate our Concord Pro server installation to a new server, and that new server has a FIPS mode requirement. I cannot perform nightly backups or do any restores on this server with FIPS mode enabled, and I can't disable it. Running the backup results in "This implementation is not part of the Windows Platform FIPS validated cryptographic algorithms."

Read More
0
0
22 views
220

Working with managed templates on A365 vs file-based in private server

Do I need to add my templates to the managed content server, if so how, or is there a way to make the BOM exporter point to my templates on our company server?

Read More
1
0
84 views
84-1

Share project via workspaces

Is share project via workspaces an included feature for the AD20 subscription?

Read More
0
0
13 views
130

How to set permissions on change-of-state in Concord Pro?

Right now, all of our users are able to change the lifecycle state of components (i.e. draft, released, etc.) but we want to give only certain people permission. Is there a way to limit which users can change to which state?

Read More
0
0
70 views
700

Altium 365 Data Cleanup

How to remove all objects related to components, projects, templates, etc.

Read More
0
1
40 views
401

Sharing Projects to Members Outside of the Organization Without Invitation to Workspace

Managed Projects to be edited by outside users needed to be invited to workspace, but not with the new update.

Read More
0
0
20 views
200

Accessing A365 Managed Project GIT Repository Outside of Altium Designer

Is it possible to access the A365 git repository through a commandline without opening Altium?

Read More
1
0
88 views
88-1

Edit Components in Altium 365

Working with and editing managed components with Altium 365

Read More
1
0
73 views
73-1

Connection to Altium 365 is Lost While Working

It is possible that connection may be lost to the Altium 365 platform while working due to a number of reasons; ie. service provider outage, server outage, temporary disconnects. This Article discusses how this is handled from the server perspective.

Read More
4
0
57 views
57-4
Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: