デザイン移行のためのボード準備

Modified by by Admin on May 10, 2019

このチュートリアル では、回路図エディタからデザイン情報を転送する前の準備として必要に応じて行う、ボードシェープの定義や作画シートの設定、レイヤの設定、キープアウトの設定方法などを紹介します。

このチュートリアルでは、PCB 設計を開始する際に必要な項目である、ボードシェープの作成や修正、シートテンプレートの設定やキープアウトの設定方法を紹介します。また、コンポーネントの配置や配線を行う前に必要な PCB のワークスペースでのグリッドやレイヤスタック、デザインルールの設定を簡単に紹介します。

ボードシェープの作成と修正

ボードシェープは、PCB エディタにおいて境界や範囲を指定します。ボードシェープは、基板外形とも呼ばれ、基本的には閉じた多角形です。新規 PCB ドキュメントを作成すると、デフォルトでは、グリッドが表示された黒いエリアとして表示されます。Altium Designer では、スプリットパワープレーンを使用する際、基板端のプルバック(外形からの逃げ)の範囲を決定するため、およびデザインデータを他のツールへ出力する際に基板のサイズを計算するために使用されます。
メニューから File » New » PCB を選択し、新規 PCB ファイルを作成すると、ボードシェープはデフォルトで6000 x 4000 mil のサイズになります。シェープは、Design » Board Shape のメニューにあるコマンドを使用してサイズや形状の変更が可能です。PCB テンプレートや PCB Board Wizard を使用して PCB ドキュメントを作成すると、ボードシェープは適切なサイズで作成されます。

ボードシェープのインポート

また、PCB エディタのメカニカルレイヤに設定したオブジェクトと同じ形状をボードシェープに設定することができます。この機能と機構系 CAD からの DWG や DXF データをインポートする機能を組み合わせ、機構系 CAD から Altium Designer へ必要なボードシェープを転送することができます。
新規に作成した PCB に DXF/DWG ファイルをインポートするには:
1. File » New » PCB を選択します。
2. 新規 PCB ファイルが開きます。シート上の黒い領域がボードシェープを表しています。ここでは、AutoCAD で .DXF(または .DWG)で作成した機構系ファイルをボードシェープとして再定義します。AutoCAD の 2.5 から 14 までのすべてのバージョンをサポートしています。インポートする形状は閉じた形で、内部のカットアウトはサポートしていないので注意してください。
3. File » Import を選択します。Import File ダイアログが表示されます。
4. ファイルフォーマットを選択し、ファイルタイプのオプションを AutoCAD (*.DXF,*DWG) に変更します。
5. インポートしたいファイルがあるフォルダへ移動し、ファイルを選択し、Open(開く)をクリックします。
6. Import from AutoCAD ダイアログが表示され、AutoCAD のレイヤを Altium Designer のどのレイヤにインポートするか指定することができます。例えば、(左側の)AutoCAD の '0' レイヤを(ドロップダウンリストから選択し)Altium Designer の Mechanical layer 4 に割り当てることができます。
7. その他のインポートオプションが正しく設定されていることを確認し、OK ボタンをクリックします。ボード外形を構成するトラックセグメントが所定のレイヤに表示されます。例えば、メカニカルレイヤ4です。インポートされたデータが現在の PCB ワークスペースよりも大きい場合は、自動的に縮小されます。
これで閉じた領域がメカニカルレイヤに読み込まれ、これらのオブジェクトがボードシェープを定義するために使用できます。

選択したオブジェクトからボードシェープを定義

先に記載したように、ラインやアークを使用して閉じた領域をメカニカルレイヤ(あるいは、他のレイヤ)に設定することでボードシェープを定義することができます。
選択済みのオブジェクトからボードシェープを定義するには:
1. ボードシェープとして定義したい閉じた形状をメカニカルレイヤ上に作成します。形状を作成するには、Place » Line や Place » Arc などの配置コマンドを使用します。
2. 新しいボードシェープの形状だけを選択します。カレントレイヤの全てのオブジェクトを選択するには、Edit » Select » All on Layer コマンド [ショートカット: S, Y] を実行します。
3. Design » Board Shape » Define from Selected Objects を実行すると、ボードシェープが選択している領域に適した形で再表示されます。

ボードシェープの修正

ボードシェープは、再定義(再描画)や頂点を移動することで変更することが可能です。ボードシェープは、その周囲に配置されているオブジェクトと一緒にあるいは、それとは別に移動することができます。
ボードシェープの色は、Design » Board Layers & Colors [ショートカット: L] を実行し、View Configurations ダイアログの System Colors にある Board Area Color で新しい色を選択することで変更できます。

ボードシェープの再定義

既存のボードシェープとは関係無く、何も無いのと同じ状態からボードシェープを再定義することができます。ボードシェープ全体を変更する場合は、次の手順を実行してください。
1. Design » Board Shape » Redefine Board Shapeを実行します。カーソルが十字に変化し、バックグランドが黒に、元のボードシェープが緑色で表示されます。
2. 頂点でクリックし(あるいは、ENTERキーを押し)、新しいボードシェープを作成します。ボードシェープの定義中に SPACEBAR を押すと、コーナースタイルが変化します。デザインウィンドウ下部のステータスバーでコーナーを配置する際、座標値を確認することができます。
3. ボードシェープを定義したら、終了するために右クリックか、ESC キーを押します。Altium Designerでは、最初に配置したポイントから最後に配置したポイントを自動的に結び、形を作成するので、完全に閉じた形状を作成する必要はありません。
新たに作成された基板外形の内側にはグリッドが表示されます。

座標指定による形状の定義

正確な寸法に基づく形を定義するには、マウスの代わりに Jump Location のショートカットキーを使用することができます。これを行うには:
1. 原点を PCB の左下側に設定(Edit » Origin » Set)します。
2. Design » Board Shape » Redefine Board Shape を実行し、マウスを放します。
3. J キーを押し、Jump サブメニューを表示します。O キーを押し、先程設定した原点へジャンプします。ENTER キーを押し、新しいボードシェープの最初の頂点を定義します。
4. J, L キーを押し、Jump to Location ダイアログを表示します。X-Location の欄がアクティブになっていますので、次の頂点を設定する X 座標の値を入力します(この時、マウスには触れないでください)。
5. TAB キーを押し、Jump to Location ダイアログの Y-Location 欄に移動し、Y 座標の値を入力します。
6. 値を入力したら ENTER キーを押し、ダイアログを閉じます。カーソルは、入力した位置に移動します。マウスには触れず再度 ENTER キーを押し、この頂点を確定します。
7. 再度、J, L キーを押し、Jump to Location ダイアログを表示します。次の頂点の X 座標を入力し、TAB キーを押し、Y 座標を入力し、ENTER キーを押します。この頂点を定義するため ENTER キーを押します。
8. 全ての頂点が定義され、座標値が原点(0, 0)に戻るまで、このプロセスを繰り返し行います。このときマウスには触れずに ENTER キーを押すようにしてください。

3D 外形を使用してボード外形を再定義

この機能は、インポートされた 3D STEP モデルの表面データを使用して、ボードの外形を再定義します。複雑なボード形状も素早く作成することができ、電子系と機械系の設計エリアの統合を助長します。これを行うには:
1. *Place » 3D Body* [ショートカット: P , B ] を選択して、STEP モデル (*.step、または *.stp) をインポートします。
2. Design » Board Shape » Define from 3D body [shortcut: D , S , S ] を選択します。このコマンドを使用する前に、ワークスペース内に 3D 外形を配置しておく必要があります。そして、3D モード [ショートカット: 3 ] にしておく必要があります。
3. 3D 外形をクリックして選択すると、カーソルが十字形に変わります。求める表面データを選択してください。
4. STEP モデルの平坦な表面データをクリックすると、それが新しいボードの外形になります。モデルの周りにカーソルを動かし、表面データに行き当たると、残りのモデルが透明になって、そのモデルを浮かび上がらせます。
注記 : X-Y プレーンにそろえられた表面データだけが、ボード外形に使用できます。X-Y プレーンへの調整が必要なモデル表面のデータを選択すると、Confirmation ダイアログを通して、作業の続行前に表面データをそろえるように求められます。このダイアログでは、選択した表面データを使用して、ボードのトップ、またはボトムの表面に関するモデルを配置することもできます。これが意味するのは、モデルの垂直な位置を同時に設定できると言うことです。モデルをそろえた後、再び、*Design » Board Shape » Define from 3D Body* を選択する必要があります。ボード外形を再定義したら、3D 外形を非表示にするオプションを利用できます。

ボードシェープの頂点移動

サイズ変更等でボードシェープを修正する場合、ボード全体を定義し直すより、頂点を移動すると作業が簡単に行える場合があります。
1. Design » Board Shape » Move Board Vertices を実行します。カーソルが大きな十字に変更し、ボード外形に編集用ハンドルが表示され、頂点の選択と移動が行えます。
2. 移動したい頂点でクリックし、新しい位置へ移動します。
3. ラインセグメント上の小さな十字のハンドルを移動することで、新たな頂点が追加できます。
4. 右クリックか ESC キーを押し、ボード外形を終了します。

ボードシェープの移動

Move Board Shape コマンドを使用して、ボードシェープだけを移動することができます。既に配置されているコンポーネントや接続は影響を受けません。
デザインシートと関連してボードシェープの位置を変更する必要がある場合、Board Options ダイアログ(Design » Board Options)の Display Sheet オプションを有効にして、シートを表示するようにしてください。Altium Designer でのシートの使用方法に関する詳細は、このチュートリアルの PCB シートの使用法 を参照してください。
ボードシェープだけを移動するには:
1. Design » Board Shape » Move Board Shape を実行すると、ボード外形がカーソルのところにフローティングの状態で表示されます。
2. ボードシェープを移動し、新しい位置でクリックし、配置します。
ボードシェープを既に配置されている全てのコンポーネントや接続と共に移動するには:
1. すべてを選択(Ctrl + A)するか、あるいは移動したいオブジェクトを、ボードシェープを含めてセレクトします。
2. 選択したオブジェクト上で直接クリックすると、カーソルが大きな十字に変化します。選択した領域がボックス表示されますので、シート上の新しい位置へドラッグします。
あるいは適切なオブジェクトを選択し、Edit » Move » Move Selection を実行します。移動の際の基準点を設定するためにクリックし、セレクションを移動し、配置するところでクリックします。

PCB シートの使用法

PCB エディタでのシートは、印刷用ページを表現するための特別な作画機能で、Board Options ダイアログを使用してコントロールします。新規 PCB ファイルを作成すると、デフォルトのシートがサイズ 10000 x 8000mil で自動的に作成されます。最初は表示されていませんが、表示すると、ボード外形のバックに白色で表示されます。
Altium Designer で用意されている PCB のサンプルファイル(Altium Designer がインストールされている Examples フォルダ)のほとんどは、ボーダー、グリッドリファレンス、タイトルブロックがメカニカルレイヤの Mechanical16 に作画された白いシートの上にボードが表示されます。

メカニカルレイヤにオブジェクトを配置し、これらのレイヤをシートにリンクすることで、独自のテンプレートが作成でき、表示・非表示が切り替えられます。既存の PCB テンプレート(Altium Designer がインストールされている Templates フォルダ)からコピーすることで、ボーダー、グリッド、タイトルブロックを含んだシートを PCB ファイルに追加できます。
シートのサイズと位置は Board Options ダイアログの Size 及び Location で、手動で変更できます。また、シートは、リンクしているメカニカルレイヤに配置されているオブジェクトに合わせ、自動的にサイズが変更されます。リンクしているメカニカルレイヤの内容が変化した場合は、View » Fit Sheet コマンドか、Design » Board Shape » Auto-Position Sheet コマンドを実行すると再計算が行われます。

シートを表示
PCBエディタでシートを表示するには:
1. Design » Board Options を実行し、Board Options ダイアログの Sheet Position セクションにある Display Sheet オプションを有効にします。
この Display Sheet オプションを無効にすると、シートはいつでも非表示にすることができます。リンクしている全てのメカニカルレイヤも非表示になります。OK をクリックします。
2. シートを表示するには、View » Fit Sheet を選択 [ショートカット: V, H (シートを表示)、または Z, S (シートをズーム)] します。ボードシェープの周囲に、デフォルトではサイズ 10000 x 8000mil の白いスペースが表示されます。

3. シートの色は、Design » Board Layers & Colors [ショートカット: L] を実行し、View Configurations ダイアログの System Colors にある Sheet Area Color および Sheet Line Color で新しい色を選択することで変更できます。作成したカスタムビューをビュー設定として保存し、繰り返し再利用することができます。
4. タイトルブロックやボーダー、グリッドなどの図面用テンプレートがある場合は、メカニカルレイヤにインポートし、View Configurations ダイアログで、これらのレイヤをシートにリンクします。それから Design » Board Shape » Auto-Position Sheet を実行すると、シートサイズが自動的にメカニカルレイヤに配置されているオブジェクトを囲んだ大きさになります。

既存の PCB テンプレートからシートを定義

ボーダー、グリッド、タイトルブロックを含んだシートは Altium Designer で用意されている PCB テンプレートドキュメントからコピーし、作成した PCB ドキュメントに貼り付けることで、いつでも定義することができます。Altium Designer の Templates フォルダには、定義済みの PCB テンプレートがあります。シートサイズのテンプレートは、A.pcbdoc から A0.pcbdoc まであります。
1. 新たにシートサイズを追加したい PCB ドキュメントを開きます。既存のデフォルト・シートサイズを表示し、新しいシートを配置し易くするため、V, H (シートを表示) あるいは、Z, S (シートをズーム) を実行します。
2. 既存の PCB テンプレートから PCB 上の全てのオブジェクトが収まるようなシートサイズを持ったもの(例えば A2.pcbdoc)を開きます。これを行うには、Files パネルの New from Template 領域から PCB Templates をクリックします。このオプションが表示されていない場合は、その他のオプションを折りたたむために Files パネルの各セクションの右側にある上向きの矢印をクリックします。PCB Templates をクリックすると Choose existing Document ダイアログが表示されます。
PCB の Templates フォルダに移動し、(例えば)A2.pcbdoc を選択し、Open をクリックします。テンプレートが新しいデザインウィンドウに新規 PCB デザインドキュメント、「PCB1.PcbDoc」として開きます。
3. テンプレートファイルの全ての内容をセレクト (Ctrl + A) し、クリップボードにコピー (Ctrl + C) します。もう一度クリックして、コピーの参照ポイントを設定します。保存しないで、「Pcb1.pcbdoc」を閉じます
4. デザインウィンドウ上側のタブをクリックし、元の PCB ドキュメントに切り換えます。CTRL + Vで、新規のシートを既存の PCB にペーストします。テンプレートの内容が Mechanical16 レイヤにペーストされます。
5. 次に Mechanical16 レイヤを表示し、シートとリンクします。Design » Board Layers & Colors を選択して View Configurations ダイアログを表示します。Mechanical16 用に Show, Enable, Linked to Sheet の各オプションを有効にします。

6. Single Layer Mode にチェックを入れると View Configurations ダイアログの View Options タブのシングルレイヤ・モードが有効な場合でも常にシートが表示されます。OK ボタンをクリックし、ダイアログを閉じます。
7. 最後にシートボーダーを含む、シートのサイズを変更することができます。V, H (シートを表示) あるいは、Z, S (シートをズーム)を実行します。シートにリンクしたレイヤのオブジェクトの範囲にシートが設定されます。この場合、Mechanical16 レイヤに定義されているシートボーダーを含んだ領域になります。
8. Mechanical16 に切り換え、必要なオブジェクトを追加したり、不要なものを削除することで、例えばタイトルブロックの編集が可能です。シートは、もう一度 V, H あるいは、Z, S を実行すると、全てのオブジェクトを含んだサイズに変更されます。作成したカスタムビューをビュー設定として保存し、繰り返し再利用することができます。

キープアウト
ボードシェープと同様に、基板の周囲に配置用・配線用に境界を定義する必要があります。これはKeepout レイヤにオブジェクトを配置することで行います。このレイヤに配置したオブジェクトは、コンポーネントと配線がここから外側へ行かないように定義するものです。通常、基板端に近いところにコンポーネントや配線が行われない様、キープアウトはボードシェープの少し内側に定義します。また、取り付けネジなどの機構的なオブジェクトや実装で要求される条件を満たすため、配線やコンポーネント用のキープアウトを定義することができます。
キープアウトの境界は、ライン、アーク、フィル等のオブジェクトで定義できます。
新規 PCB を作成する際に、PCB 製造メーカーの AT や Eurocard 等のテンプレートを使用した場合、キープアウトが自動的に含まれます。A2.pcbdoc 等のシートサイズのテンプレートにはキープアウトは含まれていません。

全レイヤに対するキープアウト定義

新規 PCB を次の方法で作成した場合は、自身でキープアウトを作成する必要があります:

•メニューから File » New » PCB を実行するか、あるいは Files パネルの New セクションからPCB File をクリックした場合
•Files パネルの New from Template セクションから PCB Templates をクリックし、PCB シートサイズテンプレート(例えば、A2.pcbdoc)を選んだ場合
これらのコマンドでは、デフォルトのボードシェープが作成されるだけなので、ボードシェープを定義した後、キープアウトを追加する必要があります。
すべての信号層に対して適用されるキープアウトを定義するには:
1. Keep-Out レイヤタブでクリックします。このレイヤだけにトラックを配置します。
2. Place » Line を実行します。キープアウトの頂点でクリックし、閉じた形状を定義します。
3. キープアウトトラックの配置が終了すれば、右クリックか ESC キーを押し、ラインの配置モードを終了します。

レイヤ別のキープアウト定義

各信号層別にキープアウトを定義することができます。これを行うには:
1. 必要なレイヤのレイヤタブをクリックします。
2. (Place » Keepout のサブメニューを使用して)レイヤ別のキープアウトオブジェクトを配置し、境界、あるいはキープアウトの領域を定義します。レイヤ別のキープアウトは、標準的なオブジェクトにキープアウト属性を有効にしたものです。これらのオブジェクトは、そのレイヤと同じ色で表示され、周囲はキープアウトの色で表示されます。レイヤ別のキープアウトは、ガーバーや ODB++ 出力ファイルには含まれません。

PCB ワークスペースの設定

これでボードシェープ、シート、キープアウト領域が作成されました。次にグリッド、レイヤ、PCBエディタのデザインルールの設定を簡単に紹介します。これで基板設計の準備が整います。

グリッド

基板上でコンポーネントの配置する前に、適切な配置グリッドが設定されているか確認する必要があります。PCB エディタのワークスペース上のコンポーネント以外の全てのオブジェクトは Snap Grid(スナップグリッド)に従って配置されます。このグリッドは、使用する配線テクノロジに適した値にする必要があります。

グリッドを設定するには:
1. Design » Board Options [ショートカット: D, O] を選択して Board Options ダイアログを開いてください。
2. リストを使用するか、値を直接入力し、Snap Grid と Component Grid の値を設定します。スナップグリッドの値は、通常、コンポーネントのピン間隔の倍数か約数に設定します。 例えば、ピン間が 100mil のコンポーネントの間を配線する場合は、25mil のスナップグリッドが使用されます。コンポーネントグリッドは、コンポーネントの配置だけに適用されます。
3. 注記 :このダイアログでは、Electrical Grid の設定も行うことができます。エレクトリカルグリッドは、電気的なオブジェクトを配置する際に適用され、設定したグリッドの範囲内にカーソルが近づくとスナップグリッドを無視し、電気的なオブジェクトに引き込まれます。
4. また、2つの異なる表示用グリッドも設定できます。これらは表示用だけに使用されます。OK ボタンをクリックし、ダイアログを閉じます。
5. グリッドを変更したり、無効にしたりするには、ショートカットキーを使用できます。G でスナップグリッドのメニューが現れ、SHIFT + Eで、エレクトリカルグリッドのオンオフが切り替わります。

ビュー設定におけるレイヤスタックとその他の非信号層の定義

PCB エディタは、View Configurations ダイアログで使用可能なビュー設定と呼ばれるレイヤ、サーフェス、色、表示およびその他の項目の定義と共に、PCB のデザインを 2D モードまたは 3D モードで表示することができます。2D または 3D のビュー設定を、繰り返し使用するために保存することができます。メインメニューから Design » Board Layers & Colors [ショートカット: L] を選択して、View Configurations ダイアログを開いてください。
2D モードは、マルチレイヤ環境であり、コンポーネントの配置、配線、接続等、通常の PCB デザイン作業に適しています。3D モードは、デザインを内部および外部からフル 3D モデルとして調べ、部品の干渉や製造前の外観をチェックするのに便利です(3D モードでは、2D モードで利用できる全ての機能は利用できません)。2D モードと 3D モードを切り換えるには、*File » Switch To 3D* または *File » Switch To 2D* [ショートカット: 2 (2D), 3 (3D)] を選択します。PCB エディタのワークスペースの下部には一連のレイヤタブがあります。編集作業のほとんどは特定のレイヤに対して実行されます。
PCBエディタには、3種類のレイヤがあります:

  • エレクトリカルレイヤ - ここには32の信号層と16のプレーン層が含まれます。デザインのエレクトリカルレイヤは、Layer Stack Manager ダイアログ(Design » Layer Stack Manager)で追加・削除が行えます。詳細は、次のセクション レイヤスタックマネージャの使用法 を参照してください。
  • メカニカルレイヤ
    - 基板外形の定義や寸法線、組立て図の作成等、デザインの必要に応じて、汎用のレイヤとして32のメカニカルレイヤが用意されています。これらのレイヤは、印刷やガーバー出力生成時に含めることができます。View Configurations ダイアログで、メカニカルレイヤの追加、削除、名称の設定を行うことができます。作成したカスタムビューをビュー設定として保存し、繰り返し再利用することができます。Only show enabled mechanical layers オプションを有効にすると、有効なレイヤだけがリストに表示されます。
    メカニカルレイヤを使用できるようにするには、有効にする必要があります。Enable 欄のオプションを有効にすることで、そのメカニカルレイヤが PCB ファイルのデータベースの一部になります。有効なメカニカルレイヤだけがデータベースの一部になることができます。デザインオブジェクトがあるメカニカルレイヤを無効にすることはできません。メカニカルレイヤ名を編集するには、レイヤ名をクリックし、F2を押します。
    Show オプションでメカニカルレイヤの表示をコントロールできます。Display In Single Layer Mode オプションをオンにすると、シングルレイヤモードが使用された(SHIFT + S)時にそのレイヤが表示されます。
    Linked To Sheet オプションを有効にするとそのメカニカルレイヤを PCB のシートに関連付けすることができます。リンクされたメカニカルレイヤは、(Board Optionsダイアログの)Display Sheet オプションで非表示にすることができます。これらはまた、Board Shape サブメニューのAuto-position sheet オプションが選択された場合、シートの範囲を自動的に決定するのに使用されます。
  • 特別レイヤ - ここにはトップ、ボトムのシルクスクリーンレイヤ、ソルダ及び、ペーストマスクレイヤ、ドリルレイヤ、キープアウトレイヤ(電気的な境界を定義するのに使用)、マルチレイヤ(マルチレイヤパッドやビアに使用)、コネクションレイヤ、DRC エラーレイヤ、グリッドレイヤ、ホールレイヤが含まれます。

レイヤスタックマネージャの使用法

簡単なデザインは、片面や両面基板で配線が行えます。より複雑なデザインの場合は、Layer Stack Manager ダイアログを使用してレイヤを追加することができます。信号層、インターナルプレーン層、絶縁(サブストレート)層の3種類がレイヤスタックに追加できます。伝送線路解析を実行する場合、これらは適切な値を設定する必要があります。
1. Design » Layer Stack Manager [ショートカット: D, K] を選択し、Layer Stack Manager ダイアログを表示します。

2. 必要に応じ、既存のレイヤをクリックして選択し、Add Layer か Add Plane ボタンをクリックすることで、信号層、プレーン層をデザインに追加することができます。新しいレイヤやプレーンは、現在選択しているレイヤの下に追加されます。必要なレイヤを追加すれば、Move Up 及び Move Down ボタンで、レイヤスタックを設定することができます。
3. レイヤの属性を編集するには、レイヤ名の上でダブルクリックを行います。(あるいは、レイヤをセレクトし、Properties ボタンを押します。)レイヤの属性、銅箔の厚みや絶縁体の属性等は、シグナルインティグリティ解析で使用されます。
4. スタックアップスタイルでは、レイヤスタックでの絶縁レイヤの順序を参照します。デフォルトでは、Layer Pairs、Internal Layer Pairs、Build-Up の3つのスタックアップスタイルがサポートされています。スタックアップスタイルを変更することで、レイヤスタックにおけるコアとプリプレグの構成が変更されます。ダイアログ右上にあるドロップダウンリストから適切なスタックアップスタイルを選択してください。ブラインドビアやベリードビアを使用する場合やシグナルインティグリティ解析を行う場合、スタックアップスタイルの定義は重要です。ブラインドビアやベリードビアを使用する場合は、Configure Drill Pairs ボタンで、ドリルペアを定義する必要があります。
5. OK ボタンをクリックし、ダイアログを閉じます。

デザインルールの設定

これでデザインルールを設定する準備ができました。PCB エディタでデザインルールを設定するには、PCB Rules and Constraints Editor ダイアログ(Design » Rules)を使用します。

あるいは、Design Rule Wizard(Design » Rule Wizard)を使用して始めることができます。この段階で、完璧なデザインルールを作成するのは、エラーが発生した時にオンライン DRC(Design Rules Check)で、すぐにエラー箇所を見つけるためだけではなく、最初に配置を行う際にエラーの発生を防ぐためです。オートルーターも、その実行中に設定したデザインルールを参照します。

一度ルールを作成すれば、配線幅やコンポーンネント間の最小クリアランス等のルールは、類似のプロジェクトで再利用することができます。個別のデザインルールをインポート・エクスポートするには、PCB Rules and Constraints Editor ダイアログの Design Rule ツリー上で右クリックします。
詳細は、以下を参照してください。

回路図デザインを PCB へ転送

回路図ドキュメントから回路情報を新規 PCB に転送する前に、次のことを確認してください:

  • PCB ファイルが回路図と同じ .PrjPCBプロジェクトファイルに属している
  • 回路図エディタでプロジェクトをコンパイル(Project » Compile Project)し、エラーの修正を行い、Design » Update PCB Documentコマンドを使用して ECO を生成し、対象となる PCB に回路の情報を転送します。PCB の更新に関する詳細は、

    を参照してください。

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

You are reporting an issue with the following selected text
and/or image within the active document:
ALTIUM DESIGNER FREE TRIAL
Altium Designer Free Trial
Let’s get started. First off, are you or your organization already using Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

In that case, why do you need an evaluation license?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You actually don’t need an evaluation license for that.

Click the button below to download the latest Altium Designer installer.

Download Altium Designer Installer

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Please fill out the form below to get a quote for a new seat of Altium Designer.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

If you are on Altium Subscription, you don’t need an evaluation license.

If you are not an active Altium Subscription member, please fill out the form below to get your free trial.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Why are you looking to evaluate Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

You came to the right place! Please fill out the form below to get your free trial started.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Sounds exciting! Did you know we offer special discounted student licenses? For more information, click here.

In the meantime, feel free to request a free trial by filling out the form below.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

That’s great! Making things is awesome. We have the perfect program for you.

Upverter is a free community-driven platform designed specifically to meet the needs of makers like you.

Click here to give it a try!

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.