ライブラリコンポーネントの作成

Modified by by Admin on May 10, 2019

 

 

このチュートリアルは、Altium Designer 10 以前のバージョンのために作成されました。パス情報、フットプリント、モデルは Altium Designer 10 に含まれないかもしれません。Wiki から以前のバージョンの Examples と Reference Designs のダウンロード や ライブラリのダウンロード が可能です。  

Contents

All Contents

このチュートリアルでは、Altium Designer の回路図と PCB のライブラリ・エディタを使用して、回路図コンポーネントと 3D 外形オブジェクトを含む PCB フットプリントを作成する方法を説明します。このチュートリアルで使用されている用語の説明が用語集として最後にまとめられています。

このチュートリアルでは以下の内容を説明します:

  • ライブラリの新規作成
  • シングル、または複合の parts がある回路図コンポーネントの作成
  • 回路図ライブラリ・エディタのレポートを使用したコンポーネントのチェック
  • マニュアル、または PCB Component Wizard を利用した PCB コンポーネントフットプリントの作成
  • 異型パッド形状を含む、その他の特別なフットプリントの作成
  • 3 次元コンポーネントの詳細(3D 外形)
  • PCB ライブラリ・エディタのレポートを使用したコンポーネント・フットプリントをチェック
  • 新しいコンポーネントとモデルを使用した統合ライブラリの作成

このチュートリアルは、回路図と PCB エディタの操作環境について理解していて、またコンポーネントの配置や編集について慣れている方を対象としています。このチュートリアルで使用したコンポーネントやライブラリは、Altium Designer がインストールされているフォルダ内の Creating Components フォルダに収められています。

回路図ライブラリ、モデルと統合ライブラリ

回路図コンポーネントシンボルは、回路図ライブラリ (*.SchLib) で作成します。これらのライブラリのコンポーネントは、個別のフットプリント・ライブラリやモデル・ファイルで定義されたフットプリントやその他のモデルを参照します。これらの個別のコンポーネント・ライブラリからコンポーネントを配置できます。または、シンボル・ライブラリ、フットプリント・ライブラリ、モデル・ファイルを統合ライブラリ (*.IntLib) へコンパイルできます。

統合ライブラリの長所は、移動し易さ(1 つのファイルにまとめられています)と、内部のコンポーネントやモデルを編集できないようになっている点です。Altium Designer のコンポーネントの多くは(ISO に対応した約 70,000 のコンポーネント)統合ライブラリとなっており、Altium Designer がインストールされているフォルダの Library フォルダに保存されています。統合ライブラリからは、ソース・ライブラリを抽出することができます。これを行うには、統合ライブラリを開いて Extract Sources を選択してソースライブラリを抽出します。編集可能なコンポーネントとして開きます。詳細については、Building an Integrated Library のチュートリアルを参照してください。
更に、Design » Make Project Library コマンドを使用して、アクティブなプロジェクトの回路図ドキュメントに配置されている全てのコンポーネントの回路図ライブラリを作成できます。

回路図コンポーネントの作成

回路図ライブラリ・エディタは、回路図コンポーネントを作成、修正し、コンポーネント・ライブラリを管理するために使用します。これは、回路図エディタに似ており、ピン・ツールが付加された同じグラフィック・デザイン・オブジェクトを共有します。
コンポーネントは、回路図ライブラリ・エディタ内のデザイン・オブジェクトを使用して作成します。または、ある回路図ライブラリから他の回路図ライブラリへ、あるいは回路図エディタから回路図ライブラリ・エディタへコピー、ペーストできます。

新規のライブラリ・パッケージと回路図ライブラリの作成

コンポーネントを作成する前に、それらを保存する新規回路図ライブラリを作成しておくことが必要です。このライブラリは、個別のファイルでモデルを参照して独立したライブラリとして作成することができます。コンポーネントを作成するには、回路図ライブラリと参照したモデルを統合ライブラリ・パッケージでコンパイルすることです。これはライブラリを作成する前に、新規のライブラリ・パッケージを作成する必要があることを意味します。ライブラリ・パッケージ (.LibPkg) は、統合ライブラリの基本で、コンパイルして個々の回路図ライブラリ、フットプリント・ライブラリ、モデル・ファイルを 1 つの統合ライブラリ・ファイルに結び付けます。

図 1. 新規のライブラリ(デフォルトの Component_1 と言う名称で作成されます)。

新規の統合ライブラリ・パッケージと空の回路図ライブラリを作成するには、次のステップを実行してください。
1. File » New » Project » Integrated Library を選択します。新しいライブラリ・パッケージ、Integrated_Library1.LibPkg が作成されます。これは、Projects パネルに表示されます。
2. Projects パネル内のライブラリ・パッケージ名を右クリックし、表示されるメニューから Save Project As を選択します。New Library.LibPkg を入力し、適切な場所を指定して Save ボタンをクリックします。拡張子を入力しない場合、拡張子は自動で追加されることに注意してください。
3. File » New » Library » Schematic Library を選択し、空の回路図ライブラリを追加します。Schlib1.SchLib と言う名称で新規のライブラリが作成され、デザイン・ウィンドウに Component_1 と言う空のコンポーネント・シートが表示されます。
4. File » Save As を選択し、Schematic Components.SchLib と言う名称でライブラリを保存します。
5. SCH Library タブをクリックし、SCH Library パネルを開きます。

新規の回路図コンポーネントの作成

既存のライブラリで新規の回路図コンポーネントを作成するには、通常、Tools » New Component を選択します。しかし、新規のライブラリは常に空のコンポーネントシートが含まれるため、Component_1 と言う名称を変更して最初のコンポーネント(NPN トランジスタ)を作成します。

図 2. NPN トランジスタのシンボル。

1. SCH Library パネルの Components リストから Component_1 を選択し、Tools » Rename Component を選択します。Rename Component ダイアログで新しいコンポーネント名(例えば、NPN)を入力し、OK をクリックします。
2. 必要ならば、Edit » Jump » Origin [ショートカットJ, O] を選択して、デザイン・ウィンドウの中央(シートの原点)にシートの原点を移動します。原点にカーソルが移動しているかどうかは、画面の左下のステータスを確認してください。Altium で用意されているコンポーネントは、シートの中央にある縦と横の線が交差する位置を原点として作成されています。常に、この原点の近くでコンポーネントを作成する必要があります。回路図上にコンポーネントを配置する時、この原点に一番近い電気的なホットスポット(ピンの端)でコンポーネントを、'つかみ' ます。 

図 3. Library Editor Workspace ダイアログで単位やその他のシート属性を設定。

3. 単位やスナップ、表示グリッドは、Library Editor Workspace ダイアログ(Tools » Document Options, [ショートカット T , D] )で設定できます。
Always Show Comment/Designator オプションを Library Editor Workspace ダイアログから有効にして、ライブラリドキュメント内の現在のコンポーネント用にComment/Designator のストリングを表示させることができます。
グリッドを変更する必要がある時は、Library Editor Workspace ダイアログを開かなくても、キーボードの G を押して、簡単にスナップグリッドを 1, 5, 10 と切り換えることができます。

グリッドを変更する必要がある時は、Library Editor Workspace ダイアログを開かなくても、キーボードの G を押して、簡単にスナップグリッドを 1, 5, 10 と切り換えることができます。これらの 3 つの設定は、Preferences ダイアログの Schematic - Grids ページで設定できます。

Always Show Comment/Designator オプションを Library Editor Workspace ダイアログから有効にして、ライブラリドキュメント内の現在のコンポーネント用にComment/Designator のストリングを表示させることができます。

これらの 3 つの設定は、Preferences ダイアログの Schematic - Grids ページで設定できます。
図 3 に従って、Library Editor Workspace オプションを設定します。それから、Units タブをクリックし Imperial Units を有効にして単位として DXP Defaults を指定します。OK ボタンをクリックし、ダイアログを閉じます。もし、ダイアログを閉じた時に回路図ライブラリ・エディタの表示グリッドが見えない場合、表示するまで Page Up キーで拡大します。ズームは、カーソルの周りで動作するので、原点の近くにカーソルを置いておくことに注意してください。

図 4. NPN のボディ

4. NPN トランジスタを作成するため、初めにコンポーネントのボディを定義します。Place » Line [ショートカット P, L] を選択します。または、Place Line ツールバーボタン(Utilities ツールバー)をクリックします。
必要ならば、TAB キーを押して、PolyLine ダイアログでラインの属性を設定します。図 4 をガイドにして (グリッドラインを使用すると簡単に配置できます)、垂直にラインを配置します。
一度クリックして最初のラインの最初の端を決め、もう一方の端までマウスを移動してクリックし、確定させます。右クリックか ESC を押してラインの配置を終了します。カーソルに十字マークが表示されている場合は、まだラインの配置モードになっていることに注意してください。
5. その他の 2 つのラインを作成します。このトランジスタでは、不規則な角度にラインを配置します。ラインを配置する時、水平/垂直、または 45 度に限定されることに気づくでしょう。配置モードを切り換えるには、ラインを配置中に Shift + Spacebar を押します。モードの 1 つにフリーの角度の配置モードがあります。これらの 2 つのラインを定義した後、ESC を押して配置モードを解除します。
グラフィカルなラインの正確な位置は、重要ではありません。コンポーネントデザインで重要なことは、ピンの場所か、ピンのホットエンドと呼ばれる特別な場所です。これは、電気的な接続を構築する場所で、ピンは常に配線に適するグリッドで配置すべきです。
6. 矢印の先は、閉じたポリゴンで作成します。Place » Polygon [ショートカット P, Y] を選択します。または、Place Polygon ツールバー ボタン (Utilities ツールバー) をクリックします。ポリゴンを配置する前に、TAB キーを押して Polygon ダイアログでポリゴン属性を設定します。Border Width Smallest に設定し、Draw Solid を有効にします。そして、fill と border 色を同じ色(基準色 229)に設定して OK をクリックしダイアログを閉じます。三角形の各頂点を定義し、右クリックして終了します。右クリックか、ESC を押してポリゴンの配置モードを終了します。図 5 は、ポリゴンの頂点の座標を示します。


Utilities ツールバー

 


グラフィカルラインの正確な場所は重要ではありません。コンポーネントデザインで重要なものはピンの場所、または特にピンのホットエンドと呼ばれるものです。これは、電気的な接続を作成する場所です。そのため、ピンは適切なグリッドへ配置する必要があります。 

 

図 5. 矢印の先端の座標が正しいか確認するには、座標情報を使用してください。

7. コンポーネントを保存します [ショートカット: Ctrl + S]。

回路図コンポーネントにピンを追加

コンポーネントのピンは、コンポーネントに電気的な属性を割り当てて、接続箇所を定義します。また、グラフィカルな属性も割り当てられます。
コンポーネントにピンを配置するには:
1. Place » Pin [ショートカット: P, P] を選択するか、ツールバーボタンをクリックします。ピンがカーソルに表示されます。カーソル側が電気的にホットな端子になり、コンポーネントのボディ側と逆の位置に配置します。
2. ピンを配置する前に、TAB キーを押してピンの属性を編集します。Pin Properties ダイアログ (図 8) が表示されます。ピンを配置する前にピン属性を定義した場合、定義した設定がデフォルトになります。そして、ピン番号と数値のピン名称は配置するごとに自動的にインクリメントされます。
3. Pin Properties ダイアログで、Display Name 欄にピン名称 (最初の NPN のピン番号である 1) を、Designator 欄にピン番号 (同じく 1) を入力します。もし、回路図シート上にコンポーネントを配置した時にピン名称と番号を表示したい場合は、Visible のチェックボックスにチェックを入れます。
4. ドロップダウン・リストからピンの Electrical Type を設定します。このタイプは、回路図シートの電気的な接続エラーを検知するために、プロジェクトをコンパイルする時、または回路図ドキュメントを分析する時に使用します。このコンポーネントの例では、全てのピンの Electrical Type Passive で設定されています。
5. このピンの長さを設定し、OK をクリックします(このコンポーネントの全てのピンを 20 に設定します)。
6. カーソルにピンが表示されている時に SPACEBAR を押すと、ピンを 90º ごとに回転できます。ピンの一端だけが電気的な接続ポイント(ホットスポット)であり、この端子は、コンポーネントのボディ側と逆側に配置する必要があることを覚えておいてください。ピンの非電気的な接続ポイントの先に、ピン名称があります。  

図 6. ピン名称と番号が表示された NPN シンボル。

7. コンポーネントを完成させるのに必要なピンを更に追加し、ピン名称、番号、シンボル、電気的なタイプが図 6 のような NPN シンボルと同様になっているか確認します。

図 7. 3 つ全てのピンのピン名称と番号の表示を編集。

ピン名称、または番号とコンポーネントのボディ間の距離を (1 インチの100 分の 1 の単位で) 変更したい場合は、Tools » Schematic Preferences を選択し、Schematic — General ページの Pin Margin オプションを変更します。

図 8. ピンを配置する前にピン属性を設定。

ピン名称、または番号とコンポーネントのボディ間の距離を (1 インチの 100 分の 1 の単位で) 変更したい場合は、Tools » Schematic Preferences を選択し、Schematic — General ページの Pin Margin オプションを変更します。

8. もし、ピン名称と番号を全て表示して配置した場合、容易に 1 回の操作で全ての表示状態を変更できます。これを実行するには、3 つのピンだけを選択(Shift + クリックで各ピンを選択)し、F11 を押して Inspector パネルを表示させます。そして、図 7 のように Show Name Show Designator のオプションを無効にします。
9. これでコンポーネントの作画は終了しました。File » Save を選択してファイルを保存します。

ピン追加時の注意点

  • ピン配置後にピン属性をセットするには、そのピンをダブルクリックするか、SCH Library パネルの Pins リストをダブルクリックし Pin Properties ダイアログを開きます。あるいは、上記のように Inspector で複数のピンを編集します。
  • ピンの名前の上にバーを表示したい場合は、その文字の後ろに ** (バックスラッシュ) を使用します。例えば、M\C\L\R\/VPP と記入すれば表示は となります。
  • 電源や GND ピンなど回路図では表示させない(ヒドゥン)ピンは、Hide オプションを有効にします。ヒドゥン・ピンは Connect To フィールドに記入されている電源や GND ネットに接続されます。例えば、VCC 用のピンは、コンポーネントの配置時、自動的に VCC ネットに接続されます。
  • ヒドゥン・ピン、またはヒドゥン・ピンのピン名称/番号を表示させるには、View » Show Hidden Pins を選択します。
  • Component Pin Editor ダイアログを使用すると、ピン属性をピン個別の Pin Properties ダイアログを経由しないで直接編集できます。Library Component Properties ダイアログ (このダイアログを開くには、SCH Library パネルのコンポーネント名をダブルクリック) で Edit Pins をクリックして、Component Pin Editor ダイアログを表示します (図 9)。

図 9. Component Pin Editor ダイアログで全てのピンの表示、編集が可能。
  • 複数のパートがあるコンポーネントでは、選択されたパートに関連したピンが Component Pin Editor ダイアログで白地のバックグランドにハイライト表示されます。その他の選択されていないパートのピンはグレーです。選択されていないパートでも、同様にピンの編集を行うことはできます。Pin Properties ダイアログを表示するには、ピンを選択して Edit ボタンをクリックします。 

回路図コンポーネントの属性設定

各コンポーネントには、default designator、PCB フットプリント、その他のモデル、コンポーネントに定義されているパラメータ等の属性があります。コンポーネントの属性を設定するには:
1. SCH Library パネルの Components リストからコンポーネントを選択し、Edit ボタンをクリックするかコンポーネント名をダブルクリックします。Library Component Properties ダイアログ (図 10) が表示されます。 


 

図 10. 基本的なコンポーネント属性は、Library Component ダイアログで定義します。

2. Default Designator (例えば、Q?)を入力します。? マークを入力すると、コンポーネントの配置時に、デジグネータ名が自動的にインクリメント(この場合では Q1, Q2)されるようになります。コンポーネントの配置前にデジグネータを定義しておくこと(配置前にオブジェクトを編集するには、配置中に TAB を押します。 )が必要です。
3. Comment を入力すると、コンポーネントの配置時に表示させることができます(例えば、NPN)。Designator Comment フィールドの Visible オプションが有効であることを確認します。Comment フィールドがブランクのままの場合、コンポーネントを配置する時に自動で Library Reference の名称が割り当てられます。
4. Description フィールドにトランジスタの詳細な説明(例えば、Transistor, NPN Generic)を入力します。ここで入力した文字はライブラリ検索で検索され、Libraries パネルに表示されます。
5.その他の欄はデフォルト値のままにし、必要に応じてモデルやパラメータを追加してください。

回路図コンポーネントにモデルを追加

図 11. Sch Library パネルを利用してモデルを追加。

回路シミュレーションやシグナルインティグリティ解析に使用するモデル・ファイルと同様、回路図コンポーネントに関連した PCB フットプリントのモデルも複数登録しておくことができます。コンポーネントに複数のモデル(例えば、複数のフットプリント)が割り当てられている場合、回路図にコンポーネントを配置する時、Component Properties ダイアログで適切なモデルを選択できます。
モデルの調達は、既存の Altium ライブラリからモデルを使用するか、Web からベンダのモデル・ファイルをダウンロードするかして、自分自身で作成することができます。
PCB フットプリント・モデルは、C:\Program Files\Altium Designer\Library\Pcb フォルダに、PCB libraries (.PcbLib) と言う形で提供されています。PCB ライブラリには、多くの PCB フットプリントを含めることが可能です。
回路シミュレーションに使用する SPICE モデル(.ckt や .mdl ファイル)は、Altium Designer がインストールされたフォルダの Library 内にある統合ライブラリに保存されます。新規のコンポーネントを作成する場合、デバイス・ベンダのウェブサイトから Spice モデルを入手するのが一般的です。また、XSpice Model Wizard(Tools » XSpice Model Wizard) を使用して、Spice モデルタイプを作成してコンポーネントに追加することができます。
回路図ライブラリ・エディタの Model Manager ダイアログでは、コンポーネントモデルの概要を確認でき編集することができます。例えば、同じモデルを、複数の選択したコンポーネントに追加することができます。Model Manager ダイアログを実行するには、Tools » Model Manager を選択します。
あるいは、図 11 のように、SCH Library パネルの Model リストの下にある Add ボタンをクリックするか、回路図ライブラリ・エディタ・ワークスペースの Models 領域を使用して、モデルを既存のコンポーネントに追加することもできます。図 12 のように Models 画面を表示するには、ワークスペースの右下にある矢印をクリックします。

図 12. Models 画面を表示するには、ワークスペース下部の矢印をクリックします。それから、Add ボタンを使用してモデルの種類を選択し、新規モデルを追加します。

1. 図 12 のように上下の矢印シンボルをクリックして、回路図ライブラリ・エディタ・ワークスペースで Models 画面を表示させます。

モデル・ファイルの保存場所を検索

回路図ライブラリ・エディタでコンポーネントにモデルを追加した時、モデルはリンクされますが、モデル・データは回路図コンポーネントにコピー、保存されません。これは、ライブラリ作成中や、コンポーネントを回路図シートに配置する時に、リンクしたモデルを利用できる必要があることを意味します。
ライブラリ・エディタで作業している時、コンポーネントからモデル情報へのリンクは、以下の検索場所を使用して決められます:
1. 最初に既存のライブラリ・パッケージ・プロジェクトに含まれるライブラリが検索されます。
2. 次に、Installed Libraries リストに登録されている PCB libraries (統合ライブラリではありません)が検索されます。: ライブラリのリストが指定できます。
3. 最後に、Project 検索パスに表示されているモデル・ライブラリが検索されます。検索パスは、Options for Project ダイアログ (Project » Project Options) で定義します。 : 検索パスにあるライブラリ内にモデルは表示できませんが、コンパイラは検索時にモデルが含まれています。

このチュートリアルでは、コンポーネントやそのモデル・ファイルをリンクするために、別の方法を使用します。ライブラリ・パッケージをコンパイルして統合ライブラリを作成する際は、様々なモデルが保存されている場所から統合ライブラリにコピーされます。

回路図コンポーネントへのフットプリント・モデルの追加

最初に PCB エディタでのコンポーネントを表すフットプリント(他のデザインツールでは、"パターン"、または "デカル" として知られています)のモデルを追加します。回路図コンポーネントに必要なフットプリントは、BCY-W3 と言うフットプリントです。

: 回路図ライブラリ・エディタの回路図コンポーネントに PCB フットプリント・モデルをリンクする時、モデルは統合ライブラリでは無く、PCB ライブラリに存在する必要があります。
1. Library Component Properties ダイアログの Models の項目で Add ボタンの右側にある小さい矢印をクリックします。そして、図 13 の様にリストから Footprint を選択します。

図 13. フットプリント・モデルをコンポーネントに追加。

2. PCB Model ダイアログが表示されます(図 14)。

図 14. PCB モデルを回路図コンポーネントへ割り当て。

3. Browse ボタンをクリックし、Browse Libraries ダイアログを開きます。このダイアログでは、ライブラリ・プロジェクト、または installed libraries リストに追加されているフットプリント・ライブラリを検索することができます。
4. 既存のライブラリで目的のフットプリントが無い場合、ライブラリを検索する必要があります。これを実行するには、Browse Libraries ダイアログで Find ボタンをクリックします。図 15 のように Libraries Search ダイアログが表示されます。

図 15. フットプリント・ライブラリの検索。

図 16. BCY-W3 のフットプリントの検索結果。

5. Scope を Libraries on Path に、Path を Altium Designer がインストールされているフォルダの Library\Pcb フォルダに設定します。Include Subdirectories オプションが有効になっていることを確認します。
6. ダイアログの上部のクエリ欄に BCY-W3 と入力し、Search をクリックします。
7. 図 15 のように、Browse Libraries ダイアログに、PCB ライブラリ(Cylinder with Flat Index.PcbLib)に保存されているフットプリントがリスト表示されます。このライブラリから BCY-W3 を選択し、OK をクリックして PCB Model ダイアログに戻ります。
8. このライブラリを使用するのは初めてなので、このライブラリを登録するかの確認のダイアログが表示されます。Confirm ダイアログの Yes をクリックします。フットプリント・モデル情報が更新され、PCB Model ダイアログにそのライブラリが追加されます。
9. OK をクリックしてモデルを追加します。図 17 のように、ワークスペース下部に Model 画面が表示されます
10. モデルを追加した後、PIN - PAD マッピングを確認することは良い考えです。PCB Model 属性を確認するにはモデルの属性を開きます(図 14)。Window Model Map を開くには Pin Map ボタンを押します(図 17a)。Pin - Pad ペアのマッピングを確認し、必要に応じて修正してください。 

図 17. コンポーネントに追加されたフットプリントモデル。

図 17a. モデルの Pin - Pad マッピング。

回路シミュレーションモデルの追加

SPICE モデルは、回路シミュレーション (.ckt や .mdl ファイル) で使用します。一般的にデバイス・ベンダのウェブサイトから供給されています。使用しようとしているデバイスが既存のライブラリで利用できる場合、それには Spice モデルが含まれています。このチュートリアルの手順を実行するために、C:\Program Files\Altium Designer\Examples\Tutorials\Creating Components フォルダで適切な一般的な NPN モデルを検索し、ライブラリを保存したフォルダにこのモデルをコピーします。
1. Spice モデルがどのように参照されているかは、プロジェクトによります(モデルはリンクされることを思い出してください)。その他のソース・ファイルとしてそれをプロジェクトに追加できます (Projects パネルでプロジェクト・ファイル名を右クリックして、Add Existing to Project を選択します)。しかし、もし、簡単に編集できない参照するソース・ファイルとしてモデル・ファイルを表示する場合、普通のプロジェクト・ファイルとしてそれを含めません。この場合、それを参照する最も適切な方法は、シミュレーション・モデル・ファイルを含むフォルダに Search Path を定義することになります。これを実行するには、メニューから Project » Project Options を選択し、Search Paths タブをクリックします。
2. Add ボタンをクリックして新規の検索パスを定義します。Edit Search Path ダイアログが表示されます。
3. 特に必要でない限り Include sub-folders in search オプションは、常に無効にしてください。検索プロセスが非常に遅くなります。
4. デフォルトの検索パスは、現在のフォルダです。作業フォルダにモデルをコピーしてから OK をクリックします。モデルが検索されたか確認するには、Options ダイアログの Refresh List ボタンをクリックします(図 19)。検索パスが定義され、作業フォルダに保存されたモデルが自動で検索されます。

図 18. 現在の作業フォルダでの検索パス。

5. モデルは、作成しているプロジェクト (ライブラリ・パッケージ New Library.LibPkg) で利用できます。これで、NPN コンポーネントにシミュレーション・モデルを追加できるようになります。これを実行するには、フットプリント・モデルを追加する方法と同じ方法を実行します(Simulation モデルを選択する方法を除く)。SIM Model - General / Generic Editor ダイアログが表示されます(図 19)。

図 19. Spice モデルの種類の設定は Sim Model ダイアログで行います。

 

6.NPN はトランジスタですので、Model Kind のドロップダウン・リストから Transistor を選択します。ダイアログは、Sim Model - Transistor/BJT ダイアログになります(図 20)。

図 20. NPN モデルの設定。

7. BJT Model Sub-Kind として選択されていることを確認します。 

Model Name は、SIM モデルファイルへリンクさせるのに重要ですので、適切なモデルファイル名 (拡張子なし) であるか確認してください。

注記: ダイアログの Found In region - 正しいモデルが見つかるとリスト表示されます。

8. このチュートリアルでは、Model Name の欄に NPN (モデル・ファイル NPN.mdl 用) と言うモデル・ファイルの名称を入力します。名称を入力するとすぐにモデルが検知されます。モデルが見つかった場合、ダイアログにパス/名称が、そして Found In と表示されます。
Model Name は、SIM モデルファイルへリンクさせるのに重要ですので、適切なモデルファイル名(拡張子なし)であるか確認してください。
注記: 正しいモデルが見つかると、ダイアログの Found In の項目にリスト表示されます。

9. 適切な Description (例えば、Generic NPN)を入力します。
モデル・ファイル (.mdl) が無い場合、Create ボタンをクリックして、簡単にシミュレーション・モデル・ファイルを作成してコンポーネントに割り当てることができる Spice Model Wizard を実行します。
10. 図 21 のように、OK をクリックして、モデル NPN が Models リストに追加された Library Component Properties ダイアログに戻ります。

図 21. Models 画面にリストされた NPN のフットプリントとシミュレーション・モデル。

シグナルインテグリティ・モデルの追加

シグナル・インテグリティ・シミュレータは、コンポーネントモデルではなく、ピンモデルを使用します。シグナル・インテグリティ・シミュレーションのコンポーネントを設定するには、Type と Technology オプション(デフォルトで用意されているピン・モデルを使用する)を設定するか、IBIS モデル(基本的に一組のピンモデル)をインポートします。
1. シグナル・インテグリティ・モデルを追加するには、Signal Integrity を選択し、それ以外はフットプリントを追加した方法と同じ作業を実行します。Signal Integrity Model ダイアログが表示されます。
2. IBIS ファイルをインポートしたい場合、Import IBIS ボタンをクリックして必要な .ibs ファイルを指定します。このチュートリアルでは、デフォルトで用意されたピン・モデルを使用します。図 22 のように、TypeBJT に設定し、適切な Model NameDescription を入力します (例えば、 NPN)。

図 22. NPN トランジスタについて設定したシグナル・インテグリティ・モデル・エディタ。

3. OK をクリックして、モデルが Models リストに追加された Library Component Properties ダイアログに戻ります(図 23)。

図 23. シミュレーションとシグナル・インテグリティ・モデルが、トランジスタに追加されます。

シグナル・インテグリティ・モデルの追加、編集についての詳細は、Performing Signal Integrity Analyses のチュートリアルを参照してください。
ライブラリ内の全コンポーネントのパラメータを編集したり管理するには、パラメータマネージャ (Tools メニュー) を使用します。

コンポーネントパラメータの追加

ライブラリ内の全コンポーネントのパラメータを編集したり管理するには、パラメータマネージャ (Tools メニュー) を使用します。

コンポーネント・パラメータでは、コンポーネントについての追加情報を定義することができます。これは、BOM、製造データ、コンポーネント・データシートへの参照、デザインルール、または PCB クラスへの割り当ての様な設計指示情報、Spice シミュレーション・パラメータ等で必要なデータを含みます。パラメータには、コンポーネントに必要な情報を追加することができます。

図 24. パラメータは、Parameter Properties ダイアログで設定します。

回路図コンポーネントにパラメータを追加するには:
1. パラメータは、Library Component Properties ダイアログでコンポーネントに追加します。ダイアログを開くには、Sch Library パネルのリストでコンポーネント名をダブルクリックします。
2. 新規のパラメータを追加するには、Library Component Properties ダイアログの Parameters for... セクション内の Add ボタンをクリックし Parameter Properties ダイアログを表示させます(図 24)。
3. パラメータの名称と値を入力します。テキスト・ストリングが必要な場合は、String がパラメータ Type として選択されていることを確認してください。また、コンポーネントを回路図シートに配置した時に値を表示したい場合は、値の Visible オプションが有効になっていることを確認してください。OK をクリックします。パラメータは、Library Component Properties ダイアログの Parameters リストに追加されます。

コンポーネントからデータシートへのリンク用パラメータ

パラメータは、コンポーネントからデータシートの様な参考資料へリンクさせることができます。リンクは、特定のコンポーネント・パラメータを追加することにより構築されます。参照ドキュメントにアクセスするには F1 ボタンを使用します。複数のドキュメントを参照するには、右クリック・メニューを使用します。

HelpURL

コンポーネントに予約されたパラメータ名(HelpURL)が含まれている場合、カーソルがコンポーネント上にある時に F1 ボタンを押すと、URL が表示されます。URL には実際のウェブアドレス、テキストファイル、PDF ファイルが指定できます。

コンポーネントリンク

2 つ目の手法は、複数のリンク、各リンクの名称をサポートしています。ここでは、パラメータ(リンクされたドキュメント、または URL を示すもの)を追加し、次に、このリンクのラベル(または、内容説明)を定義します。パラメータは、次のように定義します

 

パラメータ名

パラメータ値の例

1番目のパラメータ

ComponentLink1URL

C:_ _My Datasheets\XYZDatasheet.pdf

2番目のパラメータ

ComponentLink1Description

Datasheet for XYZ

1番目のパラメータ

ComponentLink2URL

C:_ _My Datasheets_ _Alternate XYZDatasheet.pdf

2番目のパラメータ

ComponentLink2Description

Datasheet for Alternate XYZ

 

同じパラメータのペアを使用して、リンクはいくつでも定義できます。ただし、インクリメンタルな指定はできません。データシートリンクを使用したコンポーネント上で右クリックすると、Context メニューの中に、Reference メニューのエントリが表示されます。メニューから各コンポーネントリンク用のエントリを見つけてください(図 25)。

図 25. 右クリックしてデータシート・リンクを実行。

Libraries パネルでコンポーネントを閲覧する時にも、コンポーネントとデータシートのリンクが使用できます。F1 キー、またはパネルのコンポーネント名の上で右クリックすると、リンク先ドキュメント/URL にアクセスします。

間接的に参照する文字

後で何らかの文字を入力するため、場所を確保しておく定義が必要になることがあります。例えば、回路図のテンプレートで、DesignedBy と言うパラメータを使用したいとします。この場合、その値はテンプレートを適用した新規回路図において定義します。Altium Designer では、間接的に文字を参照する手法で、この要求をサポートします。回路図シートレベルで、ドキュメント・パラメータとして、例えば DesignedBy と言うパラメータを追加し、その値をブランクにします。実際のドキュメントには通常の文字として、=DesignedBy を配置します。= は、間接参照を行っている文字であることを示し、文字を表示する代わりに、ドキュメント・パラメータ DesignedBy の現在の値を表示します。: デフォルトでは、間接的な文字は解析されず、最終的な値が表示されます。これを有効にするには、Preferences ダイアログの Schematic - Graphical Editing ページで、Convert Special Strings オプションを有効にします。パラメータの Value がブランクの場合、何も表示されません。Convert Special Strings オプションがデフォルトで無効になっているからです。
間接的に参照する文字は、コンポーネントにも使用できます。Visible オプションを有効にしてコンポーネントに追加されているパラメータを表示するのと同様に、コンポーネントの Comment フィールドの文字を間接的に表示することもできます。
間接的に参照する文字が役に立つ状況は、コンポーネントを PCB デザインや回路シミュレーションの双方で使用している場合です。回路図から PCB デザインへデータを移行する際、回路図の Comment 欄が PCB コンポーネントの Comment 欄にマップされます。しかし、回路シミュレーションでは Comment 欄は使用されません。シミュレータは、コンポーネントの多くの属性を必要とするからです。例えば、BJT には 5 つのシミュレーション属性があります。これらの 5 つの属性は、パラメータとして定義されます。この場合、回路シミュレーション・パラメータは、パラメータの名称を = 記号の後に入力することにより、間接的に参照する文字を使用して Comment 欄にマップできます。例えば、抵抗には 1 つのシミュレーション・パラメータ(Value)が割り当てられています。もし、抵抗の Comment 欄が =Value に設定されていれば、Value パラメータの内容が Comment として表示されます。もし、シミュレーション中に抵抗値を調整している場合、PCB レイアウトにデザインを移行する時に正しい抵抗値が使用されます。

シミュレーションパラメータ

上記に記載した様に、間接的に参照する文字の機能は、コンポーネントの Comment 欄にパラメータをマップするのに使用できます。 : シミュレーション・パラメータは、シミュレーション・モデルに構築され、手動でコンポーネントにそれらを追加する必要が無いことに注意してください。作成しているトランジスタのシミュレーション・モデルを編集する場合、BJT モデルが 5 つのシミュレーション・パラメータを持っていることがわかるでしょう(図 26)。

図 26. シミュレーション・パラメータは、Sim Model ダイアログで定義します。

シミュレーション・パラメータに簡単にアクセスしたい、または回路図にそれらを表示したい、または出力ドキュメントにそれらを含めたい場合、各パラメータの隣の Component parameter のチェックボックスを有効にして、コンポーネント・パラメータにすることができます

 

コンポーネントをチェックし、レポートを作成

新規のコンポーネントが正しく作成されているか確認するには、3 つのレポートを作成します。レポートを作成する前にライブラリ・ファイルが保存されているか確認してください。レポート・ファイルを閉じて、回路図ライブラリ・エディタに戻ります。

コンポーネント・ピンからモデルへのリンクは、コンポーネント・ルール・チェッカでチェックされません。
このリンクのレベルは、統合ライブラリにライブラリ・パッケージをコンパイルする時にチェックされます。コンパイルされた統合ライブラリを使用するつもりでなくても、ライブラリ・パッケージを使用してライブラリを作成し管理する際には便利になります。コンパイルすることで、より包括的なコンポーネントの検証ができます。

コンポーネント・ルール・チェッカ

コンポーネント・ルール・チェッカでは、ピンのダブリやミスなどのエラーをチェックします。
1. Reports » Component Rule Check [ショートカット: R, R] を選択します。Library Component Rule Check ダイアログが表示されます(図 27)。

図 27. 既存のコンポーネントをテストするために Component Rule Check ダイアログを設定。

2. 確認したい属性を設定します。 OK をクリックします。libraryname.err と言う名のレポートが、テキストエディタに表れ、ルール・チェックに違反したコンポーネントがリスト表示されます。
3. 必要な修正をライブラリに行い、ルールチェックを再度、実行します。
4. 回路図ライブラリを保存します。

コンポーネント・レポート

アクティブなコンポーネントの全ての情報をリスト表示するレポートを作成するには:
1. Reports » Component [ショートカット: R, C] を選択します。
2. 'libraryname.cmp' と言う名のレポートがテキストエディタに表れ、コンポーネントの各パートの数やピン情報が表示されます。 

ライブラリレポート

ライブラリの各コンポーネントのレポートを作成するには:
1. Reports » Library Report [ショートカット: R, L] を選択します。
2. Library Report Settings ダイアログで必要なレポートを設定します。
レポートは、選択した形式により Microsoft Word、またはウェブブラウザで開きます。

コンポーネントをその他のライブラリからコピー

その他の開いている回路図ライブラリからも回路図ライブラリへコンポーネントをコピーし、必要な属性を編集することができます。コンポーネントが統合ライブラリの一部である場合、.IntLib ファイルを開き(File » Open)、Yes を選択してソースライブラリを抽出する必要があります。生成されたソースライブラリ (.SchLib) は、Projects パネルから開きます。
1. SCH Library パネルの Components リストで、コピーしたいコンポーネントを選択すると、そのコンポーネントがデザインウィンドウに表示されます。
2. Tools » Copy Component を選択して、既存のライブラリ・コンポーネントからその他の開いているライブラリ・ドキュメントへコンポーネントをコピーします。Destination Library ダイアログが表示され、開いている全ての回路図ライブラリ・ドキュメントがリスト表示されます。
3. コンポーネントをコピーしたいドキュメントを選択します。OK をクリックすると、コピーしたコンポーネントが目的のライブラリに追加され、必要なら編集もできます。

複数のコンポーネントのコピー

SCH Library パネルを利用して 1 つ、または複数のコンポーネントもコピーできます。コンポーネントをパネルの名称リストから選択します。標準的な CTRL + クリック、や SHIFT + クリック機能を使用できます。次に、選択したコンポーネント上で右クリックして、Copy をポップアップメニューから選択します。図 28 を参照してください。

図 28. 既存のライブラリから選択したコンポーネントをコピー。

Components リストで右クリックすると:

  • 同じライブラリにコンポーネントを貼り付けることができます。
  • その他の開いているライブラリにコンポーネントを貼り付けることができます。
  • 同じ手法を使用して、回路図のコンポーネントを開いているライブラリへコピー、貼り付けができます。

複数のパートを持つ新規の回路図コンポーネントの作成

作成したトランジスタのシンボルは、コンポーネント全体(デバイス・メーカーによって供給された物理的なパッケージを表す 1 つのシンボル)を表します。
1 つの物理的なコンポーネントは、パートの集まりとして表される場合があります。例えば、8 つの抵抗を含む抵抗アレイがあります。各抵抗は、その他の抵抗と独立して使用できます。その他の例では、2 入力 AND ゲートの 74F08 があります(このデバイスには、4 つの独立した 2 入力 AND ゲートがあります)。コンポーネントは、各 4 つのゲートを 1 つのシンボルとして描画でき、もし、回路図で、各ゲートを 4 つの分割したゲートとして描画する場合、役に立ちます。このような 1 組の分割したパートとして配置するコンポーネントを、マルチ・パート・コンポーネントと呼びます。

図 29. 新規コンポーネントの名称を入力。

チュートリアルのこの項では、74F08SJX Quad 2-IN AND ゲートを作成する方法を説明します。また、交互に別の形状のモデルを表示できるコンポーネント(デバイスの IEEE 規格を表現)を作成します。
1. 回路図ライブラリ・エディタで、Tools » New Component [ショートカット T, C] を選択します。New Component Name ダイアログが表示されます (図 29)。
2. 新規コンポーネントの名称を入力し(例えば、74F08SJX)、OK をクリックします。新規コンポーネントの名称が SCH Library パネルの Components リストに表示され、シートの中央に十字の線(原点)のある空のコンポーネントシートが、表示されます。
3. これで、新規コンポーネントの最初のピンを作成できるようになります。上図のように、ピンが含まれています。詳細は、以下のセクションで説明します。最初のパートは、その他のパートの基準として使用されます。ピン番号だけは、各パートで変更する必要があります。

コンポーネントのボディを作成

このコンポーネントのボディは、複数のセグメントと円弧で構成されています。コンポーネント・シートの原点がワークスペースの中央にあることを確認してください。Edit » Jump » Origin [ショートカット: J, O] を選択します。グリッドについても表示されていることを確認してください [ショートカット: Page Up]。

図 30. 最初のパートのボディを定義するために Polyline を配置します。

ラインの配置

1. 現在のグリッド設定が Altium Designer のステータスバー(左下)に表示されることに注意してください。いつでも 3 種のグリッド設定を切り換えることができます。G キーを押してください。ここでは、グリッドを 5 に設定しています。
2. Place » Line [ショートカット: P, L] を選択するか、ツールバーボタンをクリックします。カーソルが、十字に変わり、複数セグメントのラインを配置するモードになります。
3. TAB キーを押して、ラインの属性を設定します。Polyline ダイアログで、線幅を Small に設定します。
4. ステータスバーの左端に表示される X, Y 座標を参照し、25, -5 になるところへカーソルを移動します。クリックするか ENTER を押し、線を引き始めます。マウスを移動し、ラインのセグメントを定義する頂点(0,-5; 0,-35; 25,-35)で左クリックします。
5. ラインの配置が完了したら、右クリック、または ESC を押します。
6. 完成したポリラインは、図 30 のようになります。コンポーネントを保存します

図 31. アークの属性は、ダイアログ、またはマウスを使用して定義できます。

アークの配置

アークは、アークの中心点、半径、開始点、終了点の 4 ステップで配置します。: アークの配置では、クリックの代わりに Enter を押すことができます。
1. Place » Arc (Center) [ショートカット P, A] を選択します。アークがカーソルの上に現れ、アークの配置モードになります。
2. TAB キーを押して、アークの属性を設定します。Arc ダイアログが表示されます。半径を 15、開始点を 270、終了点を 90、ライン幅を Small に設定します(図 31)。
3. アークの中心点を決めるため、25, -20 の位置にカーソルを移動して Enter を押すか左クリックします。マウスを移動する必要はありません。カーソルは、Arc ダイアログで設定した様に 15 の半径を定義する正確な位置にジャンプします。Enter を押します。
4. それから、カーソルはダイアログで設定した様にアークの開始点にジャンプします。マウスを移動しないで Enter を押し、開始点を受け入れます。カーソルが終了点までジャンプするので、そこで再び、Enter を押します。
5. 右クリックするか、ESC を押して、アークの配置モードを終了します。

信号ピンの追加

最初のパートにピンを追加します。このチュートリアルの最初の方にある Adding pins to a schematic component の項目で説明したのと同じ手法を使用します。1、2 番ピンに Input、3 番ピンに Output の電気的属性を割り当てます。ピンの長さを 20 に設定します。完成したパートは、図 34 のようになります。

図 32. コンポーネント 74F08SJX のパート A。input/output を示す三角形は表示上の機能です。Preferences ダイアログの Schematic - General ページの Pin Direction オプションで設定します。

図 33. Part B が追加されます。

図 34. 74F08SJX の Part B。 

パート 2、3、4 の作成

1. Edit » Select » All [ショートカット: Ctrl + A] を使用してコンポーネントを選択します。
2. Edit » Copy [ショートカット: Ctrl + C] を選択し、このパートをクリップボードにコピーします。
3. Tools » New Part を選択します。空白のコンポーネントシートが表示されます。SCH Library パネル内のパートカウンタが更新され、Part A と Part B が含められます。SCH Library パネル内の Components のリストでコンポーネント名の左にある + をクリックすると、図 34 の様になります。
4. Edit » Paste [ショートカット: Ctrl + V] を選択します。コンポーネントパートの外形がカーソルの上に現れるので、シートの原点に対して相対的に同様な場所に、Part A として配置します (シートの中央の黒い十字の部分が原点です)。必要ならば、元のパートと同じ位置になるまでコピーしたパートを選択し移動します。
5. 新しいパート、Part B のピン情報を更新します。各ピンをダブルクリックして、Pin Properties ダイアログでピン名称、番号を変更します。完成すると、Part B は 図 34 のようになります。
6. 上記の 3 から 5 のステップを繰り返し、 図 35 のように、残りの 2 つのパート、Part C と Part D を作成します。ライブラリを保存します

図 35. 74F08SJX の Part C と Part D。

パワーピンの追加

パワー・ピンを定義するには、2 つの方法があります。5 番目のパートをコンポーネントに作成することができ、そのパートに VCC や GND ピンを配置します。この方法を使用する場合、再アノテーション中にどのゲートもスワップされないようにするには、Component Properties ダイアログの Locked オプションを有効にする必要があります。
2 つ目の方法は、パワー・ピンを Hidden ピン として定義することです。この場合、それらは特別なネットに自動的に接続されます。
Hidden パワーピンは、マルチパート・コンポーネントの特定のパートに属さず、全てのパートに属します (どのパートが配置されているかに関らず、回路図に存在するそのコンポーネントのパート全て)。この要件を満たすには、ピンを Part 0 に割り当てます。つまり、コンポーネントの各パートに追加したいピンを保存するために使用する特別なパートです。
1. コンポーネントに GND (ピン番号 7) と VCC (ピン番号 14) のピンを追加します。Part Number 属性を 0 に、Electrical Type を Power に、Hide ステータス Hidden に、Connect to のネット属性を GND と VCC にそれぞれ設定します。

2. Hidden オブジェクトを表示するには、メニューから View » Show Hidden Pins を選択します。完成したパートは、 図 36 のように表示されます。パワーピンが各パートに現れることを確認します。

コンポーネントの属性設定

1. コンポーネントが Components リストで選択されている時に、SCH Library パネルの Edit ボタンをクリックして、コンポーネント属性を設定します。Library Component Properties ダイアログを設定します。Default Designator で U? を指定し、Description を Quad 2-Input AND Gate に指定、フットプリント名 DIP14 を Models リストに追加します。このチュートリアルの後半では、PCB Component Wizard を使用して DIP14 のフットプリントを作成します。
2. File » Save を選択して、ライブラリのコンポーネントを保存します。

図 36. hidden パワーピンと一緒に表示された Part A。

パートにおける Alternate 表示モードの作成

255 種類の Alternate 表示モードをコンポーネントパートに追加できます。これらの表示モードは、DeMorgan、または IEEE の表現のように、異なる形状のコンポーネントを作成することができます。IEEE シンボルの選択は、Sch Lib IEEE ツールバー(View » Toolbars » Utilities)、または Place » IEEE Symbols から有効にすることができます。各 Alternate 表示モードは、ノーマルモードと同じピンのセットを持つ必要があります。
パートの Alternate 表示を追加している場合、図 37 のように Mode ツールバーの Mode ツールから Alternate モードを選択すると、そのモードが Schematic Library エディタに表示され編集することができます。
Schematic Library エディタのデザインウィンドウに表示されるコンポーネント・パートに Alternate 表示モードを追加するには:
1. Tools » Mode » Add を選択するか、 ボタンをクリックします。Alternate 1 のブランクシートが表示されます。
2. 一般的には、Normal モードで作成されたパートをコピーし、新規の Alternate モードにそれを貼り付けします。この方法で正しいピンのセットが作成され、必要ならば形状やピンの位置を修正できます。
3. ライブラリを保存します。
一度、コンポーネントを回路図シートに配置したら、表示モードは Component Properties ダイアログの Graphical の項目の Mode リストから選択することができます。

図 37. AND ゲートの IEEE を表すために使用した表示モード Alternate 1。 

PCB コンポーネントのフットプリントの作成

フットプリントは、それらを配置した基板の最終的な面に関係なく、常にトップ面から作成します。レイヤに独特の属性、例えば、表面実装のパッドやソルダマスクの定義等は、コンポーネントの配置中にフットプリントを基板の反対側に反転させた時、自動的に適切な下層レイヤに移行されます。

チュートリアルのこの項目では、次の内容について説明します:

  • 新規 PCB ライブラリの作成
  • PCB Component Wizard を使用した、回路図コンポーネントに関するフットプリントの作成
  • 手動によるフットプリントの作成
  • 異型パッド形状を含む、特別なフットプリントの条件
  • 3 次元コンポーネントボディについての詳細(3D 外形)

フットプリントは、PCB エディタから PCB ライブラリへコピーしたり、PCB ライブラリ間でコピーできます。または、PCB ライブラリエディタの PCB Component Wizard、または描画ツールを使用してゼロから作成できます。PCB デザインに全てのフットプリントを配置している場合、PCB エディタで Design » Make PCB Library コマンドを使用して、それらのフットプリントだけが含まれた PCB ライブラリを作成することができます。
Altium Designer には、定義済みのスルーホールや SMD コンポーネントフットプリント等、PCB デザインで使用するための包括的なライブラリが含まれています。フットプリント・ライブラリ (.PcbLib files) は、Altium Designer がインストールされたディレクトリの Library\Pcb フォルダに保存されています。
チュートリアルのこの部分では、手動で作成するフットプリントは必要な手順を説明するだけで寸法は正確ではありません。新規のフットプリントを作成する場合、メーカーのデータシートに対して一致しているか、常に確認してください。

新規 PCB ライブラリの作成

新規の PCB ライブラリを作成するには:
1. File » New » Library » PCB Library を選択します。新規の PCB ライブラリドキュメント、PcbLib1.PcbLib が作成され、空のコンポーネントシート、PCBComponent_1 が表示されます。
2. 新規の PCB ライブラリ・ドキュメントの名称を、例えば、PCB Footprints.PcbLib に変更します。File » Save As を選択してください。新規の PCB フットプリントライブラリは、ライブラリパッケージ内に入れる必要があります(図 38)。

図 38. フットプリントライブラリ追加後のライブラリパッケージ。

3. PCB Library タブをクリックして、PCB Library パネルを開きます。
4. PCB Library Editor ワークスペースのグレー領域をクリックして、 図 39 のようなグリッドが表示されるまで PageUp キーを数回押します。
PCB Library Editor コマンドを使用して、新規の PCB ライブラリのフットプリントコンポーネントを追加、削除、編集する準備ができました。

図 39. フットプリントを作成する準備ができた新規の PCB ライブラリ。

PCB コンポーネントウィザードの使用

PCB ライブラリエディタには PCB Component Wizard が含まれていて、ユーザのリクエストに応じたコンポーネントフットプリントが作成できます。DIP14 のフットプリントを作成するために、ウィザードを使用します。

図 40. PCB Component Wizard を利用して、DIP14 のフットプリントを作成。

図 41. DIP14 のフットプリントを作成するウィザードの作業。

Component Wizard を使用して、新規のコンポーネントフットプリント(DIP14)を作成するには:
1. Tools » Component Wizard [ショートカット: T, C] を選択します。PCB Component Wizard が自動的に立ち上がります。Next > をクリックしてウィザードを進めます。
2. 目的のオプションを選択してウィザードを進めます。DIP14 を作成するには、Dual in-line Package (DIP) を Pattern として選択し、単位を Imperial 、ラウンドパッド 60mil、穴サイズを 32mil (寸法線の値を選択、入力)、パッド間の距離を 300mil(水平方向)、100mil(垂直方向)に設定、パッド数を設定する画面まではデフォルト設定を適用します。パッド数を設定する画面では、14 と入力します。
3. ウィザードの最後のページまで Next > をクリックし、最後のページで Finish をクリックします。新規のフットプリントのファイル名、DIP14 が PCB Library パネルのComponents リストに表示され、その新規のフットプリントがデザインウィンドウに表示されます(図 40)。必要なら更にコンポーネントを編集できます。
4. File » Save [ショートカット: Ctrl + S] を選択して、その新規のフットプリント・コンポーネントがあるライブラリを保存します。

IPC® フットプリントウィザードの使用

PCB Component Wizard と同様に、IPC® Compliant Footprint Wizard でコンポーネントフットプリントを作成できます。フットプリントを定義するパッドやトラックの属性を入力するように求めるのではなく、IPC® Compliant Footprint Wizard は実際のコンポーネントの大きさを入力として採用します。IPC-7351 標準用に開発された方式に基づいて、ウィザードはフットプリントを生成します。パッドやトラック等、Altium Designer の標準オブジェクトが使用されます。ウィザードは PCB Library Editor の Tools メニューから起動できます。

図 42. IPC® Compliant Footprint Wizard は、コンポーネントの大きさに基づいて、フットプリントを作成します。

手動によるフットプリントの作成

フットプリントは、PCB ライブラリエディタ内で作成、修正します。PCB エディタで利用できるツールとデザインオブジェクトを使用します。どんなものでも、PCB フットプリントとして保存できます。コーナーマーカー、フォトツールのターゲット、機構的な定義が含まれます。: 一度、フットプリントを PCB に配置すると、形状や機構の要求に応じて、Type 属性を設定できます。これらの設定の詳細な情報を確認するには、Component ダイアログの What's This help を使用してください。

図 43. Board Options ダイアログで単位とグリッドを設定。

コンポーネント・フットプリントは、コンポーネント・ピンの接続を構成するためのパッドを配置し、トラックやアークで外形を定義して作成します。デザインオブジェクトは、どんなレイヤにも配置できます。しかし、通常、外形はTop Overlay(シルク・スクリーン)レイヤに、パッドはマルチレイヤ(スルーホール・コンポーネント・ピン用)、または部品面の信号レイヤ(表面実装コンポーネント・ピン用)に作成します。PCB ドキュメントにフットプリントを配置する時、フットプリントを構成する全てのオブジェクトは定義されたレイヤに割り当てられます。
NPN トランジスタのフットプリントをマニュアルで作成するには:
1. フットプリントを作成する前に、単位とグリッドが適切であることを確認してください。Tools » Library Options [ショートカット: D, O] を選択して、Board Options ダイアログを表示します。UnitsImperialSnap Grid が X、Y 方向に 10mil であることを確認します。作成するフットプリントのパッド間隔を目的の間隔にするため、Grid を設定する必要があります。Visible Grid 1 を 10mil に、Visible Grid 2 を 100mil に設定します。
2. Tools » New Blank Component [ショートカット: T, W] を選択すると、空のコンポーネント・フットプリントのワークスペースが作成されます。ここで、新規のライブラリに空のフットプリントが作成されるのでそれを使用します。

作業中にスナップグリッドを変更するには、Ctrl + G を押します。
Visible グリッドを表示、または非表示にするには、L キーを押して View Configurations ダイアログを表示します。
原点マーカーが表示されない場合は、View Configurations ダイアログを開き、View Configurations ページの Origin Marker オプションを有効にします。

3. デフォルトの空のフットプリントの名称を変更するには、PCB Library パネルのリストでその名称(例えば、PCBComponent_1)をダブルクリックします。ここでは、チュートリアルの最初の方で使用した名称、BCY-W3 を入力しましょう。新しいフットプリント名を PCB Library Component ダイアログに入力します。
4. 原点マーカーで表示されたワークスペースの参照ポイント(0, 0)の周りにフットプリントを作成することをお薦めします。作業中に原点にカーソルをジャンプさせるには、[ショートカット J , R] を使用します。
参照ポイントとは、コンポーネントを配置する時に、コンポーネントを 'つかんだ' カーソルの位置のことです。一般的に、参照ポイントはコンポーネントのパッド 1 の中心、または幾何学的なオブジェクトの中心になります。参照ポイントは、いつでもこれらのどちらかに設定できます。Edit » Set Reference のサブメニューのオプションを使用してください。

新規のフットプリントにパッドを配置

Pad 属性ダイアログにはビューアがあり、定義されているレイヤ上のパッド形状を検討することができます。パッド用の通常の円形、楕円形(スロット)、四角形のホールを定義して、それらの plated 属性(plated(スルーホール)、または unplated(ノンスルーホール))を切り替えることができます。また、サーマルレリーフの生成、クリアランス計算、ガーバー出力、ODB++、NC ドリル等をサポートするのに必要な全ての作業を自動的に扱うことができます。NC ドリル出力(NC Drill Excellon フォーマット 2)では、3 種の異なるホールの種類とスルーホール、またはノンスルーホールにするかによって、6 個の異なる NC ファイルが生成されます。
新規のコンポーネント・フットプリントを作成するのに最も重要な手順の 1 つは、コンポーネントを PCB に半田付けするために使用するパッドを配置することです。これらは、物理的なデバイス上のピンに対して、正しい位置に正確に配置する必要があります。

パッドを配置するには:
1. Place » Pad [ショートカット: P, P] を選択するか、ツールバーボタンをクリックします。パッドがカーソル上に表示されます。最初のパッドを配置する前に、TAB キーを押してパッド属性を定義します。Pad ダイアログが表示されます(図 45)。
2. ダイアログの各領域を編集します(図 45)。これで、伸びた丸型のパッドが作成されました。
3. ステータス・バーに表示される座標を目安にして、最初のパッドを X:0, Y:-50 に位置決めし、クリック(または、ENTER を押)します。
4. 最初のパッドを配置後、カーソル上に次のパッドが表示されます。カーソルを X:0, Y:0 に合わせてクリックし、2 番目のパッドを配置します。: パッドの部品番号は自動的にインクリメントされます。
5. X:0, Y:50 にカーソルを移動し、クリックして 3 つ目のパッドを配置します。
6. 右クリックするか、ESC を押して、パッドの配置モードを終了します。3 つのパッドは 図 44 のように配置されます。
7. フットプリントを保存します。File » Save [ショートカット: CTRL + S] を選択してください。

図 44. 段階1, パッドを配置。

表面実装用のパッドは、Layer 属性を Top Layer に設定します。

各レイヤで異なったサイズが必要なスルーホールパッドについては、Size and Shape 属性を使用します。

図 45. 最初のパッドを配置する前にパッド属性を設定。

カーソル上にあるパッドをマウスを使用しないで配置するには、J, L ショートカットを使用して、Jump to Location ダイアログを表示させます。TAB を押して、X と Y の欄に希望の座標を入力し ENTER を押します。ENTER をもう一度押すと、パッドがワークスペースに配置されます。

パッドのデジグネータ(部品番号)

パッドにはデジグネータ(通常、コンポーネントのピン番号)でラベルをつけることができます。20 までの英数字が使用できます。デジグネータは、必要ならブランクのままにすることができます。
数字で始まる、または数字で終わるデジグネータを繰り返し配置すると、番号が自動的にインクリメントされます。アルファベットでインクリメント(例えば、1A, 1B)、または 1 以外の数字のインクリメントを使用する場合は Paste Array 機能を使用します。

ペースト・アレイ機能

パッドをクリップボードにコピーする前にパッドのデジグネータを設定することで、ペーストアレイ機能を使用した自動的な配置シーケンスをパッドのデジグネータに適用できます。Paste Array ダイアログの Text Increment の項目を設定すると、以下のようなパッドのデジグネータシーケンスで配置できます:

  • 数字 (1, 3, 5)。
  • アルファベット (A, B, C)。
  • アルファベットと数字の組み合わせ (A1 A2、または 1A 1B、または A1 B1、または 1A 2A 等)。

図 46. 複数のパッドを一度にペースト。
  • 数字順にインクリメントさせるには、Text Increment の項目をインクリメントしたい値に設定します。
  • アルファベット順にインクリメントするには、Text Increment の項目をスキップしたいアルファベットに設定します。例えば、もし最初のパッドのデジグネータが 1A の場合、その項目を A(アルファベットの最初の文字)に設定すると 1 つづつインクリメントされます。項目を C(アルファベットの 3 番目の文字)に設定すると、デジグネータは 1A, 1D(A の 3 つ後の文字), 1G 等になります。

ペーストアレイの機能を利用するには:

  • 最初のパッドを作成し必要なデジグネータを設定します (例えば、1A)。Edit » Copy [ショートカット: Ctrl + C] を使用して、クリップボードにこのパッドをコピーします。参照ポイントのコピーを定義するには、パッドの中央をクリックします。
  • Edit » Paste Special [ショートカット: E, A] を選択します。Paste Special ダイアログが表示されます(図 46)。
  • Paste Array ボタンをクリックし Setup Paste Array ダイアログを表示させます。必要に応じて各項目を設定します。

PCB シルク層(コンポーネントオーバーレイ)に外形を描画

インチ (mil) からミリ (mm) に座標単位を切り換えるには、Q を押します。

PCB シルク層に表示される外形は、Top Overlay レイヤに定義します。配置中にコンポーネントをボードの下層に反転させた場合、シルク層は自動的に Bottom Overlay レイヤに変更されます。
1. アーク、またはライン(トラック)等のシルクのオブジェクトを配置する前に、メイン編集ウィンドウの下の Top Overlay レイヤタブをクリックします。
2. 最初に、図 47 のようにアークを配置します。アークを配置するには、メニューから Place » Arc (Center) を選択します。カーソルを X:0, Y:0 に移動してクリックし、アークの中心を定義します。アークの半径や開始、終了角度がわかっている場合は、対話的な定義による設定を経ることなく、ずっと簡単にアークを配置することができます。配置したアークは Arc ダイアログで編集します。
3. アークの半径を定義するためにどこかをクリックし、再度クリックしてアークの開始角度を定義します。必要なら、Spacebar を押して、終了角度を定義する前にアークの方向を切り換えることができます。図 47 のように方向を設定し、再度クリックしてアークの終了角度を定義します。右クリックしアークの配置モードを終了します。 

ラインの配置中に間違えた場合は、BACKSPACE で最後に配置したトラックを消してください。

配置したアークをダブルクリックし、Arc ダイアログを表示させます。次のように属性を設定します: Width=6mil、Radius=105mil、Start Angle=55、 End Angle=305。
4. 次に、ラインを配置します。Place » Line [ショートカット P, L] を選択するか、 ボタンをクリックします。アークの端の近くにカーソルを移動し、図 47 のように PageUp を押してズームインします。アークの端にカーソルを近づけると、カーソルがアークの中心に引き込まれます。これは、オブジェクトの端にカーソルを引き込む電気的なグリッドを表します。クリックしてラインセグメントを配置します。
5. TAB を押して、線幅(6mil)を設定し、Line Constraints ダイアログでレイヤを確認します。
6. アークのもう一方の端へマウスを移動し、クリックしてラインを配置します。: ラインを配置中、Shift + Spacebar キーを押すと、配置角度の切り換えができます。
7. ラインの配置モードを終了するには、右クリック、または ESC を押します。

図 47. 配置されたアーク。ライン配置の開始時に電気的なグリッドを使用してアークにカーソルを引き込み、完成したシルク。

異型パッド形状のフットプリントを作成

異型形状のパッドを持つフットプリントを作成する必要がある場合があります。この場合、PCB ライブラリエディタで利用できるデザインオブジェクトを使用して作成しますが、覚えておく必要がある重要な要素があります。

図 48. 複数のオブジェクトを配置して不規則な形状のパッドを作成。

ソフトウェアでは、パッド形状に基づいてソルダ、ペーストマスクが自動で作成されます。もし、不規則な形状を構築するためにパッドを使用すれば、そのパッドと一致する不規則なマスクが正しく作成されますが、ライン(トラック)、フィル、リジョン、またはアーク等、その他のオブジェクトから異型の形状を作成する場合、ソルダマスクとペーストマスクのレイヤに適切な大きさのオブジェクトを配置してソルダ、またはペーストマスクを定義する必要があります。

図 48 は、異なる設計者がそれぞれ作成した SOT-89 のフットプリントです。左の図は、中央に大きな異型形状のパッドを配置して 2 つのパッドを使用しています。右の図は、パッドとライン (トラック) を使用しています。後者では、手動でソルダとペーストマスクを作成する必要があります。

その他のサンプルは、Wiki のアーティクル Creating a Custom Pad Shape にあります。

フットプリントに配線プリミティブを含むコンポーネントの管理

デザインを移行する時、各コンポーネントで指定したフットプリントがライブラリから抽出されボードに配置されます。フットプリント内の各パッドには、回路図のコンポーネントのピンに接続されたネット名と同じネット属性が割り当てられます。もし、フットプリントのパッドが銅箔のプリミティブに接触している場合、これらのプリミティブには自動でネット名が割り当てられず、デザインルール違反になります。この場合、ネット名を割り当てる更新プロセスを実行する必要があります。
PCB エディタには、広範囲のネット管理ツールが含まれています。これを実行するには、メニューから Design » Netlist » Configure Physical Nets を選択します。図 49 は、Configure Physical Nets ダイアログです。図 51 に示すスイッチのフットプリントで見つかった特別なプリミティブを更新するのに使用します。Menu ボタンをクリックしてオプションのメニューを表示します。そして、New Net Name 領域をクリックしてネットを選択します。割り当てのないプリミティブへネットを割り当てます。

図 49. Configure Physical Nets ダイアログで、ネットが無いフットプリントのプリミティブにネット名を更新。

複数のパッドが同じピンに接続されたフットプリント

図 50 に示すフットプリント(TO-3 のトランジスタ)には、そのフットプリントに相当する回路図コンポーネントのピンにリンクされた複数のパッドがあります。このコンポーネントについては、2 つの実装穴のパッド共、同じ '3' のデジグネータが割り当てられています。
回路図エディタで Design » Update PCB コマンドを使用して、PCB へデザイン情報を移行すると、PCB エディタで両方のパッドに接続線が表示されます(それらは、図 50 のように同じネット上にあります)。これらの両方共、配線できます。

図 50. 2 つのパッドに、同じネットの 3 のデジグネータが割り当てられた TO-3 のフットプリント。

特別なソルダマスクの取り扱いで必要なこと

図 51 に示すフットプリントは、PCB の表面レイヤの銅箔に直接、接触させる押しボタンスイッチの接触箇所です。

図 51. パッド、ライン、アークを配置して作成された押しボタンのフットプリント。

導電性があるゴムのスイッチパッドを PCB の Top 面に配置し、ボタンを押すと、フットプリントの両方の指状パターンと接触し、導通が生まれます。
導通させるには、両方のパターンがソルダマスクで覆われている必要はありません。円状のソルダマスクの開口は、アークの幅が半径と同じ、または半径より大きいアークを配置することにより作成できます。これは、2 つの指状パターンのところに円で作成されます。
指状のパターンは、アーク、水平のライン、パッドで定義されています。パッドは、接続箇所の定義に必要です。
: ボードの半田面にコンポーネントを配置する時、手動で配置したソルダマスクは自動で半田面に移動します

その他のフットプリント属性

ソルダ、ペーストマスク

ソルダ、ペーストマスクは、Solder Mask と Paste Mask レイヤそれぞれの各パッドの箇所に自動で作成されます。Mask レイヤの形状は、PCB エディタで設定されたソルダマスクとペーストマスクのデザインルール、または Pad ダイアログで指定したパッドの端からの拡張、または縮小されたパッド形状になります。

図 52. ソルダマスクが表示されたパッド。

パッド属性には、ソルダマスク、ペーストマスクのエクスパンション(開口サイズ)の設定があります。ここでは、部分的にパッドのエクスパンションを設定できますが、通常、これを行う必要はありません。一般的には、PCB エディタのペーストマスクとソルダマスクのデザインルールで適切なエクスパンションを設定します。1 つのルールを定義すれば、ボード上の全てのコンポーネントのエクスパンションを設定できます。もし必要ならば、ボード上の特定のフットプリント、または特定のコンポーネントの特定のパッド等のような特定の条件を割り当てたその他のルールを追加することができます。

マスクの表示

PCB ライブラリ・エディタで、自動で定義されているソルダマスク/ペーストマスクを確認するには、Mask レイヤを表示します。
1. マスクレイヤを表示させるには、View Configurations ダイアログ(Tools » Board Layers & Colors [ショートカット: L])を開いて、Show オプションを各マスクレイヤについて有効にし、OK をクリックします。
2. デザインウィンドウ下部のレイヤタブ(例えば、Top Solder)をクリックして、ソルダマスクを表示します(図 52)。 : 各パッドの端の周りに、Top Solder Mask レイヤの色で表示されるリングは、ソルダマスクの拡張の度合いにより、マルチレイヤパッドから突き出したソルダマスク形状の端を表します。これは、multilayer が描画順序のトップのレイヤだからです。レイヤの描画順序は、Preferences ダイアログの PCB Editor - Display ページで設定します。

マスクのエクスパンションをデザインルールで設定

デザインルールでマスクのエクスパンションを設定するには:
1. Expansion value from rules オプションが、Pad ダイアログの Paste Mask Expansion、または、Solder Mask Expansion のセクションで有効になっていることを確認します。
2. PCB ファイルを開いて(PCB ファイルが開いてなくても、簡単に仮の新規 PCB を作成できます)、PCB エディタのメニューから Design » Rules を選択し、Mask カテゴリのデザインルールを PCB Rules and Constraints Editor ダイアログで確認します。これらのルールは、フットプリントを PCB に配置した時に反映されます。: ルールシステムは階層構造になっており、必要ならば、ボード全体に適用させる通常のルールを無視して、より高い優先度を持つルールを定義できます。

マスクのエクスパンションを手動で指定

デザインルールのエクスパンションを無効にするには、パッド属性のマスクエクスパンションを指定します:
1. Pad ダイアログの Paste Mask Expansion または Solder Mask Expansion セクションの Specify expansion value を選択します。
2. 値を入力し OK をクリックします。フットプリントを保存します。

デジグネータとコメント文字

デフォルトのデジグネータとコメント文字

今、ライブラリで作成しているのはフットプリントです。基板にフットプリントを配置すると、デジグネータとコメントが割り当てられます。これを、コンポーネントと呼びます。フットプリントを作成する時、デジグネータとコメント文字を手動で定義する必要はありません。これらは、フットプリントを基板に配置する時、自動で追加されます。これらの文字の位置は、Component ダイアログのデジグネータとコメント文字の Autoposition オプションで決まります。Preferences ダイアログの PCB Editor - Defaults ページで文字の位置(サイズ)を事前に定義できます。

デジグネータとコメント文字の追加

デジグネータ、またはコメント文字を追加したい状況があるかもしれません。例えば、設計者はレイヤ別に出力する図面でコンポーネントを配置する位置にデジグネータのシルクが必要である一方、基板製造業者はデジグネータを含む各コンポーネントの詳細な製造図面が必要です。このようなデジグネータを追加したい場合、フットプリントに .Designator のスペシャル・ストリング(.Comment のスペシャル・ストリングもあります)を含めることで対応できます。基板製造業者に渡す図面を作成するには、ライブラリ・エディタでメカニカルレイヤに .Designator のスペシャル・ストリングを配置します。それから、このレイヤの図面を印刷します。
この機能が必要な場合、以下の方法を実行します:
1. 必要なメカニカルレイヤを表示します。各メカニカルレイヤの ShowEnable オプションを、View Configurations ダイアログ(Tools » Layers & Colors)で有効にします。
2. このレイヤをアクティブにするには、デザイン・ウィンドウの下部の Mechanical レイヤタブをクリックします。タブがハイライト表示され、全ての新しいテキストはこのレイヤに配置されます。
3. Place » String [ショートカット: P, S] を選択するか、Place String ボタンをクリックします。
4. テキストストリングを入力しその属性(例えば、フォント、サイズ、レイヤ等)を定義するには、テキストを配置する前に TAB キーを押します。String ダイアログが表示されます。Text のドロップダウン・リストから .Designator を選択します。テキストの Height(高さ)を 40mil に、Width(幅)を 6mil に設定して OK を押します。デジグネータの左下には、.Designator のストリングのドットがあります。
5. これでテキスト・ストリングを配置できます。テキストストリングを回転させるには Spacebar を押します。必要な場所に移動し、クリックして配置します。右クリック、または ESC を押して、ストリング配置モードを終了します。
6. 必要であれば、同じ手順を実行して .Comment のスペシャル・ストリングを配置します。
7. 特別なストリングをテストするには、PCB にフットプリントを配置します。PCB Library パネルでフットプリント名を右クリックし Place を選択して、フットプリントを配置できます(PCB ファイルが開いている時)。フットプリントを PCB ドキュメントに配置してもデジグネータが表示されない場合は、PCB エディタの View Configurations ダイアログの View Options ページで、Convert Special Strings オプションが選択されているか確認してください。

特別なレイヤ指定要求の取り扱い

グルードット、または peelable ソルダマスクのような PCB コンポーネントに割り当てる特別な必要条件があります。これらの特別な必要条件の多くは、コンポーネントを実装する配置面に関連しており、コンポーネントを反転する時、コンポーネントに関連するオブジェクトもボードの反対面に反転する必要があります。
Altium Designer の PCB エディタでは、滅多に使用しない特別な目的のレイヤを含めるのではなく、"レイヤペア" と言う機能を利用してこの要求をサポートします。レイヤペアとは、ペアとして定義された 2 つのメカニカルレイヤです。コンポーネントをボードのある面から反対面に反転する時はいつでも、ペアとなったメカニカルレイヤのオブジェクトは、そのペアの反対面のメカニカルレイヤに反転します。

図 53. PCB エディタでのレイヤペア定義

この方法を使用して、グルードット(または、その他の特別な条件)を含めるのに適切なメカニカルレイヤを選択します。そして、オブジェクトを使用してその形状を定義します。ボードにフットプリントを配置する時、レイヤペアを設定する必要があります。これにより、このコンポーネントをボードの反対側に反転する時にそのオブジェクトを移行するレイヤが指定されます。: レイヤペアは PCB ライブラリエディタでは定義できません。PCB エディタで定義します。

3 次元コンポーネントの詳細機能 

今日のエレクトロニクス製品はより精密で複雑になっており、PCB 設計者はコンポーネントの水平方向のクリアランスの条件以上のことを考慮する必要があります。また、高さ制限やコンポーネントの下にコンポーネントを配置するオプションを考慮する必要があります。更に、最終的な PCB ファイルを機構 CAD ツールへ移行し、開発中の製品を仮想的に組み立て、パッケージの完成度を確認する必要があります。Altium Designer には、これらの異なる状況に対応する機能が多数、搭載されており、もちろん、その中には 3D ビジュアライゼーションが含まれています。

PCB フットプリントへ高さ情報を追加

フットプリントに高さ属性を追加できます。これを実行するには、PCB Library パネルの Components リストのフットプリント名をダブルクリックし、PCB Library Components ダイアログを表示させます。そして、Height の項目にコンポーネントの高さを入力します。
Height デザインルールは、ボード設計中に定義できます(PCB エディタで Design » Rules を選択します)。一般的には、コンポーネントのクラス、またはルームを定義して最大のコンポーネントの高さについてテストします。

フットプリントに 3D 外形を追加

よりリアルなコンポーネントレンダリングのため、3D ビューモード [ショートカット: 2 (2D), 3 (3D)] が PCB ライブラリエディタに用意されています。3D 外形のオブジェクトはフットプリントに追加できます。3D 外形は有効なメカニカルレイヤ上でのみ、フットプリントに追加できます。押出成型のようなシンプルな 3D 外形は、2D ポリゴンタイプのオブジェクトです。表面カラーと高さの属性を持っており、3D のレンダリング時には、引っ張ったような、あるいは型で押し出したような形をしています。3D 外形は球体や円筒形も作成できます。
1 つ、または複数の 3D 外形は、コンポーネントの物理的なサイズと形状を全方向にわたって定義するために結合させることができ、Component Clearance のデザインルールで使用されます。高精度の 3D モデルはコンポーネントクリアランスのチェックの精度を向上させ、視覚的に完成した PCB アセンブリのリアリティを向上させます。
Altium Designer は、PCB フットプリントへ直接、3D STEP モデル(*.step or *.stp files)をインポートし、3D モデルをレンダリングする機能をサポートしています。この機能的な拡張は、STEP モデルを Altium Designer のドキュメントに組込むか、リンクすることができるようにします。ただし、リンクされた STEP モデルは、PCB ライブラリエディタでは扱えません。
: コンポーネントを反転させると、3D 外形もボードの反対側に反転します。3D 外形データ(メカニカルレイヤ内)を別のメカニカルレイヤに反転させたい場合は、PCB ドキュメントにレイヤペアを定義する必要があります。詳細は、Handling special layer-specific requirements such as glue dots の項をご覧ください。

図 54. DIP-14 コンポーネントの詳細
3D 外形を手動で配置

3D 外形は、手動で PCB ライブラリエディタ内に配置することができます(Place » 3D Body)。それらは、PCB ライブラリエディタのフットプリント(および、PCB エディタに配置されたフットプリント)にも自動的に追加されます。3D Body Manager ダイアログ (Tools » Manage 3D Bodies for Library/Current Component) を使用してください。
: 3D 外形は、2D モデル、3D モデルの両方に配置できます。

図 55. 3D 外形を含む DIP-14 のフットプリント。

ここで、このチュートリアルで以前に作成したフットプリント DIP14 に 3D 外形を追加してみましょう。PCB ライブラリエディタで 3D 外形を手動で配置するには:
1. PCB Library パネルで、DIP-14 をダブルクリックすると、PCB Library Component ダイアログが開きます(図 54)。名称、高さ、記述がわかります。コンポーネントの高さが、ここでは重要です。実際に高さのある 3D 外形を作る必要があるからです。
: コンポーネントについて製造元のデータが利用できる場合は、それをお使いください。

図 56. 3D Body ダイアログで 3D 外形属性を定義。

2. Place » 3D Body を選択します。コマンドの起動後、3D Body ダイアログが表示されます (図 56)。Extruded オプションを 3D Model Type 領域から選択します。
3. Properties 領域で、3D 外形オブジェクトに特定の名前 (Identifier) を付けます。Body Side (基板のどちらの側で 3D 外形を垂直に突き出すか) は、Top Side のままにしておいてください。
: コンポーネントには、ピンのように、PCB から突き出しているネガティブスタンドオフの高さを入力できます。スタンドオフの高さはデザインルールチェッカではチェックされません。
4. Overall Height を 200mil に、Standoff Height(ボードから 3D 外形下部までの距離)を 0mil に設定。3D Color の色を適当に設定します。
5. OK をクリックして、3D Body ダイアログを閉じます。配置モードになります。2D では十字形、3D では青色の円錐にカーソルが変化します。
6. カーソルを移動させ、クリックして、ボディの開始点を固定します。続いて、一連の頂点ポイントを固定して、ボディのポリゴン形状を定義します。
7. 最後の頂点ポイントを配置した後、右クリック、または ESC を押してボディの配置を完成させます。Altium Designer では、最初に配置したポイントから最後に配置したポイントを自動的に結び、形を作成するので、完全に "閉じた" ポリゴンを作成する必要はありません。
形状の定義中に SHIFT + SPACEBAR を使用して、いくつかのコーナーモードを切り替えることができます。切り替え可能なモードは次のとおり: 自由アングル、45°、アークつき 45°、90°、アークつき 90°。アークの半径は自由に増減できます。SHIFT + . (ピリオド)、または、SHIFT + , (コンマ)をそれぞれ使用します。SPACEBAR で、コーナーの向きを切り替えることができます。
押出 3D 外形オブジェクトが選択されている時は、編集ハンドルが各頂点に表示されます。 カーソルが変化して、 ハンドルを捉えたら、クリック & ドラッグで頂点を動かすことができます。このカーソルが縁の中間に表示されたら、クリック & ドラッグで頂点をその縁に追加し、動かすことができます。
カーソルが変化して、 オブジェクトの縁を捉えたら、クリック & ドラッグで縁を動かすことができます。
カーソルが変化して、 オブジェクトを捉えたら、クリック & ドラッグで 3D 外形を動かすことができます。3D 外形はドラッグして、回転させたり、反転させたりできます。編集コントロールを使用して、3D 外形の形状を調整してください。

図 57. DIP14 の 3D の例。このモデルには 16 の 3D 外形 - メインボディ、足、円筒によるピン 1 参照マーカーが使用されています。

配置モードの時に BACKSPACE キーを使用すると、最後に配置した頂点を削除できます。キーを繰り返し使用するとポリゴンの外形を '崩す' ことができ、最初に始めたところに戻ることができます。
この形状は、Component Clearance デザインルールに適合しています。しかし、3D ビジュアライゼーション用としては、不十分かもしれません。更に 3D 外形を設計して、コンポーネントの詳細を追加することもできます。
3D 外形を完成させると、3D Body ダイアログが表示されます。3D 外形の配置を続けるか、Cancel をクリック、または ESC を押してダイアログを閉じます。図 57 は Altium Designer で作成された DIP14 3D です。
3D 外形を 3D で見たい時は、3 を押して 3D ビューモードに入ります。3D モデルモードの時、3D 外形が見れないときは L を押して、View Configurations ダイアログを開きます。Physical Materials ページの Show Simple 3D Bodies オプションを有効にするか、あるいは 3D Bodeis Display Options コントロールを PCB パネル上で使用してください。2D モードに戻るには、を押します。
PCB ライブラリを保存します。

3D 外形をインタラクティブに作成

3D 外形オブジェクトをフットプリントから対話的に作成するのは、手動の方法とよく似ています。基本的な違いは、フットプリントの詳細を含む既存のオブジェクトから、3D 外形として "押し出す" ことのできる閉じた形状を検出することです。これは、3D Body Manager ダイアログで行います。
"閉じている" ポリゴンだけが 3D 外形オブジェクトを作成できます。
3D Body Manager ダイアログを使用して、トランジスタパッケージ用の3D 外形、TO-39 を定義しましょう。パッケージ外形のカーブ形状や方向タブにより、この方法は形状を手動で定義しようとするよりも簡単です:

図 58. 3D 外形が追加された TO-39 2D フットプリント。

1. ライブラリで、TO-39 フットプリントをアクティブにします。
2. Tools » Manage 3D Bodies for Current Component を選択します。3D Body Manager ダイアログが表示されます。

図 59. TO-39 3D モデル。

図 60. 3D Body Manager ダイアログを使用して、既存のプリミティブから 3D 外形オブジェクトを素早く作成。

3. コンポーネントのシルク外形に基づいた形状を作成するには、リストに表示される 2 番目のオプション、Polygonal shape created from primitives on TopOverlay を使用します。ダイアログのこの行で、Action 行の Add to (component_name) をクリックし、外形オブジェクトを配置するメカニカルレイヤに Registration Layer を設定します(この場合は Mechanical1)。Overall Height に適当な値、例えば 180mil を設定します。Body 3D Color は適当な色に設定します。図60 をご覧ください。リストをスクロールして、コンポーネントモデルを定義するのに使用したい、閉じたポリゴンを選択します。
4. Close をクリックすると、3D 外形の形状は図 58 のようにコンポーネント上に表示されます。ライブラリを保存します。
図 59 は、TO-39 用に完成された 3D モデルです。このモデルは、5 つの 3D 外形オブジェクトから構成されています:

  • 1 つは、フットプリント外形(全体の高さ 50mil、スタンドオフの高さ 0mil、外形 3D の色は灰色)から作成されるベースです。

図 61. 3D 外形の詳細が表示された PCBLib List パネル。
  • 1 つは、ケーシングの外形で、配置された円形から作成され、閉じたポリゴンをそこから選び出します。その際、3D Body Manager ダイアログで検出され、次のような属性 - 全体の高さは 180mil、スタンドオフの高さは 0mil、色は灰色 - が反映されます。
  • 1 つはピンで、これも配置された円形 (全体の高さ 0mil、スタンドオフの高さ -450mil、色は金色)から作成されます。これはコピー、ペーストされ、残りのピンを作成するのに、2 回、位置決めされています。**注意: 3D 外形のコピーやペーストは、2D モードで行います。3D モードのコピーコマンドはクリップボード用でスナップショットになります。   

3D 外形を編集するには、右クリックしポップアップメニューから Properties を選択して、3D Body ダイアログを開きます(図 56)。PCBLib List パネル(図 61)を使用して、3D 外形をリスト表示し、直接、編集することもできます。
3D 外形の詳細については、PCB Editor and Object Reference の 3D Body の項目を参照してください。

3D 外形として STEP モデルをインポート

多くのコンポーネントベンダが詳細な 3D モデルを提供して、一般的なメカニカル CAD パッケージで使用されています。Altium Designer は 3D STEP モデル(.step or .stp)を直接、コンポーネントフットプリントにインポートすることができます。モデルを自作するより、時間が節約され、さらに洗練されたモデルにすることもできます。
STEP ファイルでは、AP214、AP203 フォーマットがサポートされています。AP203 フォーマットでは彩色がサポートされていません。インポートされたモデルは、グレースケールで表示されます。

リンクされた STEP モデル

リンクされた STEP モデルは、PCB ライブラリエディタではサポートされていません。組込み STEP モデルはサポートされていません。 

STEP モデルのインポート

STEP モデルのインポート手順は、以下の通りです:
1. Place » 3D Body [ショートカット: PB] を選択します。3D Body ダイアログが表示されます。
2. Generic STEP Model オプションを 3D Model Type 領域で選択します。
3. Embed STEP Model ボタンをクリックします。Choose Model ダイアログが表示されます。そこで *.step や *.stp ファイルを確認することができます。 
4. 目的の STEP ファイルを選択し、Open ボタンをクリックして Choose Model ダイアログを閉じます。
5. 3D Body ダイアログに戻り、OK をクリックして閉じます。3D 外形がカーソルの上に表示されます。
6. ワークスペース内でクリックして、ロードされた選択モデルと共に、3D 外形オブジェクトを配置します。

STEP モデルの位置決めと向き

STEP モデルをインポートすると、3D 外形がモデルを収納するためにリサイズされます。生成したアプリケーション内で使用されている原点のせいで、PCB ドキュメントの座標軸に対して、STEP モデルを正確に方向付けるのは難しいかもしれません。STEP モデルのグラフィカルな位置決めを行うには、いくつかの方法があります。モデルを扱うために配置されている参照ポイント(snap points でわかります)を使用するか、ボードに対するモデルの表面または表層を使用します。非グラフィカルな位置決めは、3D Body ダイアログの Generic STEP Model 領域の設定で実行できます。

その他のソースからフットプリントを追加

PCB ライブラリに既存のフットプリントをコピーできます。コピーしたフットプリントは、必要に応じて仕様に合うように名称を変更したり編集を行うことができます。
もし、既存のフットプリントを PCB ライブラリにコピーしたい場合、以下のことができます:

  • PCB ドキュメントで配置したフットプリントを選択し、コピーして(Edit » Copy)、開いている PCB ライブラリに Edit » Paste Component を使用してペーストします。
  • Edit » Copy Component を選択して、PCB ライブラリエディタにコピーするフットプリントをアクティブにします。コピー先の PCB ライブラリを開き、Edit » Paste Component を選択します。 
  • 1 つ、または複数のフットプリントを PCB ライブラリパネルのリストで選択します。標準的な操作、SHIFT + クリック、または CTRL + クリックしたまま、右クリックで、Copy を選択します。コピー先のライブラリに切り替えて、フットプリント名のリストで右クリックし Paste を選択します。 

コンポーネントのフットプリントの確認

回路図ライブラリエディタには一連のレポート機能があり、フットプリントが正しく作成されているか確認し、どのコンポーネントが既存の PCB ライブラリにあるか特定できます。既存の PCB ライブラリの全てのコンポーネントを確認するには、Component Rule Check のレポート機能を実行します。Component Rule Checker は、複数のプリミティブ、パッドのデジグネータの誤り、未接続の銅箔、不適当なコンポーネントについてチェックします。
1. レポートを実行する前にライブラリ・ファイルを保存します。
2. Reports » Component Rule Check [ショートカット: RR] を選択して、Component Rule Check ダイアログを表示させます。 
3. 全てのチェックボックスを有効にして、OK をクリックします。PCBlibraryfilename.err と言うレポートが作成され、テキストエディタに表示されます。どんなエラーもチェックされます。
4. レポートを閉じて PCB ライブラリ・エディタに戻ります。

図 62. デザインで使用する前に、ライブラリ内のフットプリントを検証。

統合ライブラリの作成

ここまでで、以下のような操作を行ってきました:

  • 統合されたライブラリパッケージ(コンパイルされた統合ライブラリのソースプロジェクト)を作成しました。
  • 新規の回路図ライブラリをライブラリパッケージに追加し、回路図コンポーネントを作成しました。
  • コンポーネントをその他の領域で使用する際のモデルを特定しました。ボードデザイン、または回路シミュレーション等です。
  • 新規の PCB フットプリントライブラリをライブラリパッケージに追加し、フットプリント、3D モデルを作成しました。
  • 特別なフットプリントを扱う方法について説明しました。

このチュートリアルの最後の手順では、ライブラリパッケージをコンパイルして統合ライブラリを作成し、コンポーネントや全ての参照モデルを含む 1 つのファイルを作成します。統合ライブラリを使用しないでソースライブラリとモデルファイルから直接、作業する方法を希望しても、ライブラリパッケージをコンパイルする強力な動機があります。これにより、広範囲なコンポーネントやコンポーネントに関連するモデルをチェックすることができます(図 63)。

図 63. コンパイル時にエラーチェックが実行されます。

ライブラリパッケージをコンパイルするには:
1. Project » Compile Integrated Library を選択して、統合ライブラリのライブラリパッケージ内のソースライブラリやモデルファイルをコンパイルします。コンパイル中に見つかったエラー、またはワーニングは、Messages パネル(View » Workspace Panels » System » Messages)に表示されます。Messages パネルでエラーをダブルクリックすると、詳細情報を表示してコンポーネントにジャンプします。この方法でソースライブラリのエラー箇所を修正し、統合ライブラリを再コンパイルします。
2. 新規の Integrated Libraryname.INTLIB が作成され、Project Options ダイアログの Options タブで指定した出力フォルダに保存されます。新規の統合ライブラリは自動で Installed Libraries のリストに追加され、Libraries パネルに表示されます。
 

Design » Make Integrated Library コマンドを使用して完成したプロジェクトから統合ライブラリを作成できることに注意してください(これは、最初にソースライブラリを作成し、それから統合ライブラリを作成します)。 

用語

以下の用語がこのチュートリアルで使用されています。

コンポーネント

コンポーネントは、ボードに配置する物理的なデバイスです。集積回路、抵抗等。これらのコンポーネントには、1 つのパート、または複数のパートで構成されているものがあります。

3D 外形

3D 外形はポリゴンで形成されたオブジェクトで、有効なメカニカルレイヤ上のフットプリントに追加できます。水平方向、垂直方向の平面で、コンポーネントの物理的なサイズと形状を定義するために使用できます。コンポーネントクリアランスチェックのコントロールや 3D ビジュアライゼーションを可能にしています。
3D 外形オブジェクトは、コンポーネントフットプリントにおける STEP モデルのプレースホルダとして、また PCB に実装しないオブジェクト、ハウジングやアセンブリ等として活用できます。

デジグネータ

固有の識別子。PCBで、特定のコンポーネントをその他のコンポーネントから見分けるために使用します。デジグネータは、アルファベット、数値、またはその組み合わせで表すことができます。また、パッドでは、コンポーネントのピン番号に一致する固有のデジグネータが割り当てられます。

フットプリント

フットプリントは、PCB 上に実装するコンポーネントに必要なスペースを定義(または、モデル化)します。コンポーネントのフットプリントモデルは、PCB ライブラリに保存されます。フットプリントには、デバイスのピンへ接続するためのパッドと、シルク(オーバーレイ)レイヤ上にトラックまたはアークセグメントで作成されたパッケージの物理的な外形が含まれています。また、デバイスを実装する機能が含まれています。 
PCB ライブラリ内のフットプリントには、デジグネータ、またはコメントはありません。PCB シート上に配置し、デジグネータやコメントが割り当てられた時に、それらはコンポーネントになります。

ヒドゥンピン

コンポーネントには存在するが、表示する必要が無いピンです。一般的には、パワーピンです。指定したネットに自動的に接続されます。

ライブラリ

回路図ライブラリは、個々のシートに保存されたコンポーネントやそのパーツの一式です。PCB ライブラリは、コンポーネントフットプリントを含みます。各ライブラリタイプには、それ自身のエディタがあります。統合ライブラリは、回路図ライブラリを関連したモデルと結合させます。ライブラリエディタでは直接、編集できません。

オブジェクト

ライブラリエディタのワークスペースに配置できる個々のアイテムです。

パッド

パッドオブジェクトは、通常、フットプリントに使用され、コンポーネントピンの接続パッドを生成します。

パート

グラフィカルオブジェクトの集まりで、複数のデバイスを持つコンポーネントの 1 つを表します。パートは、回路図コンポーネントライブラリのコンポーネント内で個別のシートに保存されます。

ピン

コンポーネントのピンは、コンポーネントに電気的な属性を割り当てて、接続箇所を定義します。

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

You are reporting an issue with the following selected text
and/or image within the active document:
ALTIUM DESIGNER FREE TRIAL
Altium Designer Free Trial
Let’s get started. First off, are you or your organization already using Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

In that case, why do you need an evaluation license?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You actually don’t need an evaluation license for that.

Click the button below to download the latest Altium Designer installer.

Download Altium Designer Installer

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Please fill out the form below to get a quote for a new seat of Altium Designer.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

If you are on Altium Subscription, you don’t need an evaluation license.

If you are not an active Altium Subscription member, please fill out the form below to get your free trial.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Why are you looking to evaluate Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

You came to the right place! Please fill out the form below to get your free trial started.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Sounds exciting! Did you know we offer special discounted student licenses? For more information, click here.

In the meantime, feel free to request a free trial by filling out the form below.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

That’s great! Making things is awesome. We have the perfect program for you.

Upverter is a free community-driven platform designed specifically to meet the needs of makers like you.

Click here to give it a try!

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.