複数オブジェクトの編集

Modified by by Admin on May 10, 2019

 

このドキュメントでは、デザイン上の複数オブジェクトの編集を行う際のテクニックを紹介します。Find Similar Objects ダイアログと Inspector パネルを組み合わせての使用方法やパラメータマネージャとモデルマネージャについてもカバーしています。最後にデザインオブジェクトの検索と編集を行うためのクエリと List パネルを紹介します。 

エレクロニクス設計は、回路図上で論理的な設計を行い、その後 PCB のワークスペースで、実際のオブジェクトの集まりを表すプロセスです。小規模な回路であっても、回路図にはモデルやパラメータを含むコンポーネントが、PCB ワークスペースにはボードを構成するデザインオブジェクトが数多く使用されています。デザインプロセスでは、こうしたオブジェクトの属性を変更する必要が生じます。それは、設計者がデザインで要求される項目のバランスを取ろうとするためです。
多くのオブジェクトの編集作業をサポートするために、以前のアルティウムのデザインツールには、グローバル編集と呼ばれる機能が用意されていました。この機能の基本的な考えは、一つのオブジェクトを編集し、それを他のオブジェクトに適用させるという方法でした。 
DXP プラットフォームのリリースに伴い、グローバル編集の手法が変更されました。基本的な方法として、編集するオブジェクトを選択し、その属性を確認し、編集を行います。
この 選択 - 確認 - 編集 の手順を頭に入れ、各ステップを詳しく見て行きましょう。

複数オブジェクトの選択

図 1. 右クリックで Find Similar Objects を選択。

実際にオブジェクトを選択するには、いくつもの方法があります。 例えば、ウィンドウズの基本的なショートカットであるマウスのクリックも使用可能です。この方法は、選択するオブジェクトの数が少ない場合や、異なる種類のオブジェクトを同時に編集する場合には理想的です。

複数の回路図シートに渡って、多くのオブジェクトを選択するには、Find Similar Objects ダイアログを使用します。このダイアログを開くには、編集したいオブジェクトのどれか一つの上で右クリックを行い、ポップアップメニューから Find Similar Objects を選択します。 
サンプルを使用して、実際に手順を確認してみましょう。ここでは回路図のパワーネットの名称を VCC から 3V3 に変更します。これは全シート上の VCC パワーポートのネット属性を変更することになります。最初に回路図上の VCC パワーポートを見つけ、その上で右クリックを行い、ポップアップメニューから Find Similar Objects を選択します。

図 2. Find Similar Objects ダイアログに読み込まれたオブジェクトの属性。

図 2 は、回路図上のパワーポートで、右クリックを行った後に表示される Find Similar Objects ダイアログです。ダイアログには、クリックしたオブジェクトの属性が表示されます。このダイログの内容は、クリックしたオブジェクトによって異なりますので注意してください。
ダイアログには、2 つのカラムが確認できます。図 2 でハイライト表示されているのは、クリックしたオブジェクトの属性で、下側にネット名を示す Text が VCC となっています。
Find Similar Objects ダイアログの 2 番目のカラムは、その他のオブジェクトと何を一致させるかを指定します。オブジェクトの各属性の値を Same(同じ)、Different(異なる)、Any(条件なし)と指定することで、対象となるオブジェクトを指定できます。 

図 3. 一致させる条件として属性を指定。

図 3 では、Object Kind は Same で、ネット名を示す Text も Same に設定します。これによって、一致するオブジェクトは、ネット名 VCC のパワーオブジェクトになります。

次のステップでは、検索実行の範囲(スコープ)を設定します。 Current Document(現在編集中のドキュメント)だけか、あるいは、Open Documents(オープンしている全ドキュメント)かを選択します。ここではプロジェクト全体に適用するよう、図 4 に示す通り、Open Documents に設定します。この編集作業が全シートに適用されるように、ドキュメントを先にオープンしておく必要があります。
最後のステップでは、オープンしている全てのドキュメントでネット名 VCC のパワーオブジェクトを検索した後、どのようにするかを設定します。

図 4. 編集を適用するドキュメントを指定。

図 5 では、この編集操作の重要な設定を示しています。ハイライトされているオプションは、(全ての VCC パワーポートを選択するため)Select Matching と選択されたオブジェクトを読込み Inspector パネルを開くための Run Inspector です。
一致するパワーポートを選択するには、OK ボタンをクリックします。
Apply ボタンをクリックすると、一致するパワーポートを選択し Inspector が開きます(Find Similar Objects ダイアログは開いたままになります。一致する条件が定かでない場合、これを使用します)。

図 5. 検索したオブジェクトへ反映するための設定。

オブジェクトの確認

図 6. 選択されたオブジェクトの属性が SCH Inspector に表示された状態。

回路図と PCB エディタには、共に SCH Inspector と言うパネルが用意されています。Inspector の基本的な動作は、現在、選択されている全てのオブジェクトについて、その全属性を表示することです。選択されているオブジェクトが同じ種類のオブジェクトであれば、例えば、 図 6 のように 10 個のパワーポートの属性が表示されます。

選択されたオブジェクトの属性が全て同じであれば、その値が表示されます。例では、10 個のパワーポートの Orientation(角度)が全て 90 度になっています。 
各パワーポートの属性(例えば、位置 X1)が異なる値の場合は、<...> と表示されます。これは、10 個のオブジェクトが同じ場所 X1 でない、すなわち別の場所にあることを示しています。

図 6 の SCH Inspector の上部に 2 つのオプションがあります。2 番目の設定は特に重要で、どこからオブジェクトを検索したのか - カレントドキュメント(current document)か、オープンされている全ドキュメント(open documents)か、同じプロジェクトのオープンされている全ドキュメント(open documents of the same project)か、を設定します。選択した全パワーポートを Inspector に読み込むには、open documents か open documents of the same project に設定する必要があります。

オブジェクトの編集

図 7. ネット名に該当する Text の編集。 

編集したいオブジェクトを選択し、Inspector で属性を確認できました。次は編集を行います。
ネット名を編集するためにText をクリックすると、 ... と言う表示ボタンが、Text フィールドの終わりに表示されます。部分的な文字列の編集を行いたい場合に、このボタンをクリックすることができます。ここでは、文字全体を変更しますので、セルの全体の内容を新しいテキスト、3V3 に置き換えます。
Text 値に対して行った変更を選択した全オブジェクトに適用するには、ENTER キーを押すか、SCH Inspector 内の別のセルをクリックします。
編集中に気が変わった場合、ESC キーを押せば編集は中断します。編集のやり直し(アンドゥ)を行うには、メニューから Edit » Undo を選択します。複数の回路図シートに対して編集を適用させた場合は、各シートごとにアンドゥの操作を行ってください。
図 8 は、文字を変更し、ENTER キーを押した後のSCH Inspector パネルを示しています。その横は、編集されたパワーポートの 1 つです。
この方法を使用して、回路図エディタやPCB エディタで、あらゆる種類のオブジェクトの一括編集が可能です。
編集を実行した後は、回路図上のその他のオブジェクトが消えているか、あるいはマスクされているはずです。マスクされている場合は、編集することができません。マスク状態を解除するには、ワークスペース右下にある Clear ボタンをクリック [ショートカット: SHIFT + C] します。 

図 8. 更新された10個のパワーポートのうちの1つ。

グループオブジェクトの編集

図 9. 470uF 16V のコンデンサを検索。

先に行った編集は、プリミティブオブジェクトに対して行われました。プリミティブオブジェクトは、回路図エディタで使用されている基本的なオブジェクトの一つです。コンポーネントなど、より複雑なオブジェクトはグループオブジェクトと呼ばれ、これらは基本的にプリミティブなオブジェクトの集まりです。例えば、回路図上のコンポーネントは、ドローイングオブジェクト、文字、パラメータ、ピン及び参照するモデルの集まりです。グループオブジェクトに属するプリミティブオブジェクトは子オブジェクト、グループオブジェクトはそれらの親オブジェクトと呼ばれます。
一般的なグループオブジェクトの編集例を見て行きましょう。デザインに、いくつかの 470uF 16V のコンデンサがあり、フットプリントに MCCT-B が使用されている場合を考えます。現在、電圧値はコンポーネントのコメントの一部として指定されています。この電圧値をコンポーネントのパラメータとして定義し直し、回路図上にこのパラメータを表示させてみます。
これから実行する手順は次の通りです:
1. コンデンサを選択します。値は 470uF 16V 、フットプリントは MCCT-B です。
2. コメントを 470uF に変更します(16V の文字は削除)。
3. 新しいパラメータをこれらのコンポーネントに追加します。Voltage という名前で、値は16V です。 
4. 回路図にこのパラメータが表示されるように設定を変更します。
編集内容は複雑かもしれませんが、実際に手順に沿って操作してみましょう。

Step 1. コンデンサの選択

470uF 16V のコンデンサを選択するには、コンポーネントシンボルのいずれか一つの上で右クリックして、Find Similar Objects をポップアップメニューから選択します。 
以前の例と同じ手順で操作を行いますが、今回は、図 9 に示すように、同じ Part Comment 、同じ Current Footprint をコンポーネントに設定します。
また、デジグネータの文字列が C で始まるコンポーネントを一致条件にできることに注意してください。これは、コンポーネントのデジグネータの値を Find Similar Objects ダイアログで変更することで実行されます。値は C* にしてください(図 9)。OK ボタンをクリックして、一致するコンデンサを選択します 

Step 2. コメント文字の変更

図 10. Find Similar Objects の操作を実行した後の表示。シート上で3つのコンデンサが検索されました。

Find Similar Objects ダイアログを実行した後、SCH Inspector パネルが開きます(Find Similar Objects ダイアログ内のRun Inspector オプションを有効にしておいてください)。その背後には、回路図シート上で一致するオブジェクトが選択されて表示されます。Find Similar Object ダイアログで Zoom Matching と Mask Matching オプションが有効になっていれば、ズーム表示され、その他の一致しないオブジェクトは、消えているか、マスクされています。
図 10 にその結果が表示されています。このページでは、4 つのコンデンサが検索されています。 
SCH Inspector パネルの下部のステータスラインを確認すると、同じコンデンサが他のシート上にあることが確認できます。
コメント文字を変更するには、文字列から 16V を単に削除するだけです(図 11)。変更を確定させるには、ENTER キーを押します。

図 11. コンデンサの値が変更されました。

Step 3. コンポーネントへ新規パラメータを追加

次に行う変更では、これら 4 つのコンポーネントに Voltage と言う新しいパラメータを追加し、その値を 16V に設定します。これを行うには、SCH Inspector パネルの下部にある Add User Parameter 機能を使用します(図 12)。先に値を追加し、それからパラメータ名を入力することに注意してください。

図 12. ユーザ定義のパラメータを追加。

1. まず、新しいパラメータの値 16V を Inspector 内の Add User Parameter の欄に入力します。
2. 変更を適用するには、ENTER キーを押します。キーを押すと Add new parameter to XX objects ダイアログが表示されます。 
3. 新しいパラメータ名を入力し、OK ボタンをクリックします。
注記 : 各パラメータの横にある赤い十字 ( X) の上でクリックすると、削除になります。
これで SCH Inspector パネルには、値が 16V の新しい Voltage パラメータがリストの下部に追加されます(図 13)。この方法で、必要なパラメータをいくつでも追加していくことが可能です。

図 13. ユーザ定義のパラメータ。

Step 4. Voltage パラメータを表示するための設定

最後のステップは、新しい Voltage パラメータを表示するように 4 つのコンデンサに設定します。パラメータの表示は、コンポーネントではなく、パラメータ自身の属性になります。このため、この変更はコンポーネントの属性が表示されている SCH Inspector パネルからは、変更できません。
パラメータの属性にアクセスするには、SCH Inspector パネルの下部にある Parameters のリストで、ハイパーリンクが設定されているパラメータ名 Voltage をクリックします。これを実行すると、選択されているコンポーネントの Voltage パラメータの属性がSCH Inspector パネルに読み込まれ、編集可能になります。これは、SCH Inspector パネルの上部の Object Kind が、'Parameter' となることで確認できます。 

図 14. 新しいパラメータの表示設定を変更。

これで回路図に Voltage パラメータを表示させることができます。表示するには、図 14 に示すように Hide チェックボックスをオフにしてください。

他の属性を編集する等で、親オブジェクトであるコンポーネントに戻りたい場合は、図 15 に示すようにリンクが設定されている Owner をクリックします。

図 15. 親のコンポーネント属性へ戻る。

これでフットプリントが MCCT-B のコンデンサのコメントが 470uF に更新されました。また、Voltage と言う新しいパラメータが追加され、値を 16V に設定し、更にパラメータが表示されるようにしました。

異なる種類のオブジェクトに対する一括編集

PCB Inspector パネルは、複数の同じ種類のオブジェクトだけではなく、同じ属性を持った異なる種類のオブジェクトに対しても使用できます。

既存配線のネット名変更

最初の例として回路図で、あるネットから 1 つのピンを削除し、それを別のネットへ追加する変更があった場合を考えます。PCB を更新する際、そのネットが PCB 上で既に配線が終了した場合は、違うネット名が接続されていることになります。配線には、トラックやビア等、その他のオブジェクトも含まれます。
この状態を解消するのにいくつかの方法が考えられます。一番簡単な方法として、PCB Inspector パネルを使用します。その手順を見てみましょう。 

1. PCB で、ネット名を変更する必要がある配線の全プリミティブを Edit » Select » Connected Copper コマンド [ショートカット: CTRL + H] で選択します。
2. PCB Inspector パネルが表示されていなければ、表示します [ショートカット: F11]。
3. PCB Inspector パネルには、選択されたオブジェクトの共通の属性だけが表示されます。正しく選択されていれば、これらの属性の一つに Net 名があるはずです。これを変更するには、単にドロップダウンリストから新しいネット名を選択し、変更を適用するために ENTER キーを押すだけです。これで配線済みの異なる全オブジェクトのネット属性は変更されます。

図 16. 選択したトラックとビアのネット名変更。

異なるオブジェクトのレイヤ属性変更

別の例として、あるメカニカルレイヤから別のメカニカルレイヤへ全オブジェクトを移動する場合を考えてみます。これを行うには:
1. PCB エディタウィンドウの下部にある Layer タブをクリックして、カレントのメカニカルレイヤをアクティブにします。
2. Select » All on Layer コマンド [ショートカット: S, Y] で、そのレイヤの全オブジェクトをセレクトします。
3. PCB Inspector パネルが表示されていなければ、表示します [ショートカット: F11]。
4. Layer のリストから新しいレイヤ名を選択し、ENTER キーを押して変更を適用します。

図 17. 選択したオブジェクトのレイヤ変更。

設計オブジェクトのロック

設計オブジェクトには、ロックをかけて回路図ドキュメントやPCB ドキュメントでの移動や編集をできなくすることができます。ロックをかけるには、Locked を有効にします。例えば、特定オブジェクトの位置やサイズがとても重要な場合にロックをかけます。この Locked 属性は、設計オブジェクトの属性ダイアログで利用できます。または、SCH List や PCB List パネルでもまとめて設定できます。

回路図シートや PCB ドキュメント上の設計オブジェクトをロック

図 18. ワイヤ属性のロックを有効。

1. 回路図オブジェクトのグループをロックするには、SCH List パネルを使用して Locked オプションを切り替えます(図 18の右側)。PCB オブジェクトのグループについても PCB List パネルで同じように操作できます。
2. それぞれのオブジェクトをロックするには、オブジェクトをダブルクリックします。属性ダイアログが表示されるので、Locked オプションを有効にします(図 18の左側)。

図 19. ロックされた設計オブジェクトをグラフィカルに編集しようとした時の確認ダイアログ。

Locked 属性が有効になっているオブジェクトを移動させたり、回転させたりしようとすると、ダイアログが表示され、編集を続けるかどうか尋ねてきます(図 19)。
Preferences ダイアログ(回路図エディタや PCB エディタで、それぞれ Tools » Schematic Preferences または Tools » Preferences)のSchematic - Graphical Editing ページ(図 20)、またはPCB Editor - General ページにおいて、Protect Locked Objects オプションが有効で、デザインオブジェクトが locked に指定されている時は、このオブジェクトは選択したり、グラフィカルに編集したりすることはできません。Locked オブジェクトをダブルクリックして、Locked 属性を無効にします。または、Preferences ダイアログの中にあるSchematic フォルダの下側、Graphical Editing ページで Protect Locked Objects オプションを無効にして、グラフィカルに編集できるようにします。
その他のオブジェクトと一緒に、ロックされたオブジェクトを選択した場合、Protect Locked Objects オプションが有効なら、ロックされていないオブジェクトだけが選択でき、グループとして移動させることができるようになります。 

図 20. Preferences ダイアログの Schematic - Graphical Editing ページで、ロックされたオブジェクトを保護。 

デザイン全体にわたるフットプリント管理

図 29. フットプリントマネージャを使用して、デザイン全体のフットプリントの確認と管理。

Altium Designer の回路図エディタには、強力な Footprint Manager が用意されています。回路図エディタの Tools メニューから起動(Tools » Footprint Manager)すると、フットプリントマネージャによって、プロジェクト全体の各コンポーネントの全フットプリントが確認できます。複数のセレクトをサポートしていることで、複数のコンポーネントのフットプリントがどのようにリンクされているか、あるいはコンポーネントが保持している複数のフットプリント情報のうち、現在どれが割り当てられているか確認でき、フットプリントの割り当てを容易に編集できます。デザインの変更は、Altium Designer の標準的な ECO システムを介して適用され、必要に応じて回路図と PCB の両方を更新できます。

クエリを使用して複数オブジェクトの検索と編集

Altium Designer には、対象となるデザインオブジェクトを正確に特定するための強力なクエリエンジンが内蔵されています。クエリは、基本的にデザインデータ内で何かを検索するための記述です。

オブジェクト検索のためのフィルタリング

デザインデータに対してクエリを実行するには、いくつかの方法が用意されています。これらの一つとして、Filter パネルにクエリを入力する方法があります。デザインデータベースに対して、クエリを適用し、フィルタをかける場合、各オブジェクトは適用されるかどうかクエリによってテストされます。
図 28 は、回路図ライブラリの SCHLIB Filter パネルを示しています。クエリに IsPin が入力されています。このクエリが適用されると、(Whole Library オプションが有効になっているので、)全てのライブラリの各オブジェクトがチェックされ、ピンオブジェクトが集められて結果に追加されます。それ以外のオブジェクトにはフィルタがかかります。

図 30. SCHLIB Filter パネルを使用し、Library Editor 内のライブラリ全体のピンをクエリとして検索。

SCHLIB Filter パネル右側にあるオプションで結果の表示が変わります。図 30 で、(このケースでは)ピンがフィルタを通り、セレクト、ズームされます。それ以外の全オブジェクトはフィルタを通過せず、選択されず、マスクがかけらます(フェードアウトされ、編集不可になります)。
Select オプションが有効になっているので、ピンは SCH Inspector パネルに読み込まれます。このパネルは、選択されたオブジェクトの共通の属性を表示することができますが、コンポーネントのピンを編集するには、(長さを変更する以外)役に立ちません。
また、ピンは SCH List パネルにも表示されます。ここでは、デザインデータをリスト表示し、複数のオブジェクトを簡単に比較、編集できます。

Mask out オプションを有効にしてフィルタを適用すると、フィルタアウトされたオブジェクトは、フェードアウトし、編集ができない状態になります。フィルタを解除するには、ワークスペース右下にある Clear ボタンをクリックします[ショートカット: SHIFT + C]。

SCHLIB List パネルでの設計オブジェクトの編集

図 31. Schematic Library Editor の SCHLIB List パネルに表示されたコンポーネントのピン。

図 31 は、回路図ライブラリエディタの SCHLIB List パネルにピン情報が読み込まれた状態を示しています。パネルのトップにある from のオプションが今は、current component に設定されていることに注意してください。フィルタは、全てのライブラリから選択できるように設定されていました。スコープのコントロールは、SCHLIB Filter パネルと SCHLIB List パネルの両方にあります。これはフィルタリングと結果表示を別にコントロールするためです。これでライブラリ内の全てのピンを検索し、全てのピンを見たり、編集中のコンポーネントだけを見たりすることができます。
SCHLIB List パネルは表形式になっており、オブジェクトの確認と編集には理想的です。SCHLIB List パネル(左上にあるオプション)で Edit モード に設定すれば、キーボードのキーを使用した 'walk' around や編集が行えます。例えば、矢印キーでグリッド値に応じた移動ができ、F2 または Spacebar で選択しているセルを編集できます。 Enter キーで変更が適用され、セルがアクティブになっていれば、SPACEBAR でチェックボックスの切り替えができます。
SCHLIB List パネルはカスタマイズが可能です。カラム上で右クリックを実行し、ポップアップメニューから Choose Columns を実行するとカラムの追加や削除、順序の変更ができます。

デザインデータ編集のためにスプレッドシートを使用

SCHLIB List パネルでデータを直接編集できるだけではなく、複数のセルを選択して SCHLIB List パネルから任意のスプレッドシートエディタにコピーし、スプレッドシートから SCHLIB List パネルに編集したものを戻すことができます。例えば、新しいコンポーネントを作成する場合、メーカーが供給しているデータシートから全てのピンデータをスプレッドシートにコピーします。このデータを 1 ピンずつ回路図ライブラリエディタに入力するのではなく、次のような作業が行えます:
1. 新しく作成したコンポーネントで一つピンを配置し、それをコピーします。それから、Paste Array コマンドを使用し、必要な数だけ貼り付けます。
2. Filter パネルでクエリ IsPin を使用し、List パネルにこれらのピン情報を読み込みます。

図 32. クリップボードにコピーされたスプレッドシートエディタでのピンデータ。

3. ピンデータのカラムが、スプレッドシートエディタのカラムと一致するように適切な設定を行います。
4. スプレッドシートエディタに切り替え、ピンデータに必要なブロックを選択し、コピーします。
5. SCHLIB List パネルに戻り、同じセルのブロックをセレクトし、右クリックを行い、ポップアップメニューから Paste を選択します。
データがスプレッドシートでどのように表示されるか見るために、データのブロックを先に SCHLIB List パネルからスプレッドシートにコピーをしたいかもしれません。この手法を使用すると、ピン数が多いコンポーネントの新規作成を素早くできます。図 32 から 図 34 までは、この手順を示しています:

図 33. SCHLIB List パネル上でセルのブロックを選択し、右クリックから Paste を選択。

図 34. ピンデータが貼り付けられた後の SCHLIB List パネル。

スプレッドシートやテーブルからペーストしたデータの作成と編集

Smart Grid Paste ツールを使用すると、設計オブジェクトの属性を迅速に更新したり、プリミティブのグループを素早く簡単に作成したりできます。このツールは、回路図エディタや、PCB エディタの List パネルの右クリックメニューで有効になります。

Design Workspace でフィルタリングされたオブジェクトの動作について

図 35. フィルタリング/ハイライトのプロセス図。

図 35 は、デザインデータがどのようにしてフィルタリングされ、ハイライトされるかを示しています。Filter パネルでクエリを記述したり、Find Similar Objects (FSO) ダイアログ(実際には、背後でクエリが動作)の設定によって、あるいは Navigator パネルでオブジェクトを選択することによって、フィルタリングのプロセスがコントロールできることに注意してください。上図に PCB パネルは示されていませんが、Navigator パネルのように PCB ワークスペースで、データをフィルタすることが可能です。
ハイライトエンジンは、フィルタされたデータをどのようにして表示するかを決定します。
メインのグラフィカルな編集ウィンドウでフィルタされた表示データ(Display data)に対して(ハイライトエンジンにそれをセレクトするように指示すれば)Inspector から、あるいは List パネルからアクセスすることができます。

クエリ作成のヒント

  • クエリのキーワードに慣れるまでは Query Helper を使用してください。ヘルパーを表示するには、Filter パネルにある Helper ボタンをクリックします。
  • キーワード上で F1 キーを押すと、そのキーワードのオンラインヘルプが表示されます。
  • Query Helper ダイアログ下側にある Mask フィールドを使用して検索するキーワードの絞込みができます。* (ワイルドカード)を文字列の先頭に入力すると、全てのキーワードが表示されます。 
  • Query Helper ダイアログを閉じる前に Check Syntax ボタンをクリックし、チェックを行ってください。
  • 例えば、''DIP14' のように、変数はクオーテーションで囲んでください。
  • クエリが適用される優先順位の問題を解消するために、括弧()を使用し、正しい順序になるようにしてください。
Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

You are reporting an issue with the following selected text
and/or image within the active document:
ALTIUM DESIGNER FREE TRIAL
Altium Designer Free Trial
Let’s get started. First off, are you or your organization already using Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

In that case, why do you need an evaluation license?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You actually don’t need an evaluation license for that.

Click the button below to download the latest Altium Designer installer.

Download Altium Designer Installer

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Please fill out the form below to get a quote for a new seat of Altium Designer.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

If you are on Altium Subscription, you don’t need an evaluation license.

If you are not an active Altium Subscription member, please fill out the form below to get your free trial.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Why are you looking to evaluate Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

You came to the right place! Please fill out the form below to get your free trial started.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Sounds exciting! Did you know we offer special discounted student licenses? For more information, click here.

In the meantime, feel free to request a free trial by filling out the form below.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

That’s great! Making things is awesome. We have the perfect program for you.

Upverter is a free community-driven platform designed specifically to meet the needs of makers like you.

Click here to give it a try!

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.