その他の機能と改善点

Modified by by Admin on May 10, 2019

無制限の PCB メカニカル レイヤ

多くの PCB メカニカル レイヤを PCB に追加できます。また、メカニカル レイヤは、Layer Number の定義や Layer Type の設定を対応しています。以下に示すように、Layer Type オプションには 2 つのセット(個々のメカニカル レイヤのセットと、レイヤペアのセット)があります。

パッドやビアで定義したポリゴンのサーマル接続

ポリゴン接続Thermal Relief 形状は、配置したパッドやビアでの Properties パネルで指定できます。個々のパッド/ビアの Thermal Relief 設定は、Polygon Connect Style ルール で定義した形状より優先されます。

3D ビューモードで PCB Overlay ストリングを再配置

Overlay テキストストリングは、3D ビューモードで再配置できます。

PCB フットプリントに寸法線を含める

寸法線は、PCB ライブラリエディタで配置できます。コンポーネント フットプリントを基板上で使用する時、寸法線は、PCB エディタへ移行されません。

新しい Sign In メニュー

新しいアカウント/サーバメニューでは、一箇所から Altium Account や Altium server へサインインできます。また、ソフトウェアの License ManagementExtensions & Updates 画面へもアクセスできます。

作業領域の右上にある アイコンから Sign In メニューをクリックします。アカウントへサインインした時、利用できるローカル、クラウドサーバ サービスがリスト表示されます(接続するには、サーバエントリをクリックします)。 アイコンを選択して、サーバから切断できます。そして、必要な時、メニューの Custom オプションからサーバへ手動で接続できます。

新しい Open Project ダイアログ

更新した Open Project ダイアログ (File » Open Project) では、管理された、または管理されていないプロジェクトを 1 つの場所で検索、閲覧、開くことができます。

このダイアログを表示するには、File » Open Project を選択します。左の領域には、選択できるソースオプションのリストが表示されます:

  • Recent – ローカル、またはサーバソースから最近、開いたプロジェクトのリスト。ソースサーバが接続されていない/利用できない場合、サーバベースのプロジェクトのアイコンは、赤色で表示されます ()。
  • [Server] – 接続された 管理された content サーバ で利用できる管理されたプロジェクト。
  • Local Projects – 現在のデフォルトの場所(Preferences ダイアログの System – Default Locations ページで指定した)に保存されているプロジェクト。

ボタンは、標準の Windows の Open ダイアログでプロジェクトを閲覧したり、そこからプロジェクトを開くために利用できます。

新しい Create Project ダイアログ

新しいプロジェクトを作成するために使用するダイアログの機能と UI は、容易になり強化されました。以前の New Project ダイアログに相当する新しい Create Project ダイアログ (File » New » Project) では、以下の更新された機能を利用できます:

  • LOCATIONS 領域で、プロジェクトの目的の場所(サーバ、バージョンコントロール下のリポジトリ、ローカルフォルダ)を直接、選択します。この選択で、作成するプロジェクトのタイプ(Managed、VCS、file)が決まります。
  • Parameters ドロップダウンボックスからプロジェクトへカスタム Parameters を追加する機能。追加したプロジェクトパラメータは、Options for Project ダイアログ (Project » Project Options)(管理されたプロジェクトの場合、Server Parameters タブ(読み取り専用)で、ローカル、またはバージョンコントロール プロジェクトの場合、Parameters で)で利用できます。

  • 利用できるテンプレートは、Project Type のリストでプロジェクトのタイプと階層形式で表示されます。

 

Script と Integrated Library プロジェクトは、File » New » ScriptFile » New » Library メニューからそれぞれ作成します。

改善した Component Type の管理

管理されたコンポーネントに関連する Component Type パラメータにより、Altium Designer の複数の場所でコンポーネントを容易に検索、分類できます。選択したコンポーネントの Component Type は、Component type ダイアログ(様々なエディタやパネルから利用できる)で割り当て、編集します。

Component type ダイアログの機能を更新し、割り当てられていないタイプのコンポーネントは正しく検出されます。そして、Component Types のリスト(現在、接続されているサーバの)は、Preferences で管理します。

Component Type のリストを管理するには、Preferences ダイアログ(Component type ダイアログ内の ボタンから直接、表示できます)の Data Management – Component Types ページを表示します。

Preferences 内でアルファベット順で表示された Component Types のリストは、以下の機能を使用して管理します:

  • ボタンを使用して、新しい Type エントリを含める(また、名称を付ける)、または既存のエントリを削除できます。使用中の Component Type(サーバコンポーネントへ割り当てられた)は、削除できません。また、重複する Component Type は許可されません。
  • ボタンを使用して、エントリの階層位置を整列できます。インデントしたエントリは、リスト内の次(より下)のエントリのサブタイプになります。
  • Component Type エントリを新しい位置へドラッグアンドドロップして、階層の位置を変更できます。エントリは、ドロップした時、他のサブタイプになります。
  • アルファベット順のリストで混乱した場合、ダイアログを閉じてから再度、開いて、アルファベット順のリストを復帰できます。

 

Data Management – Component Type プリファレンス設定は、現在、接続されている 管理された content サーバ へ適用されます。

Component type ダイアログは、以下から利用できます:

  • Components パネル – リスト内のコンポーネント エントリを右クリックし、メニューから Operations » Change Component Type を選択します。
  • Explorer パネル – コンポーネント エントリのレビジョンを右クリックし、メニューから Operations » Change Component Type を選択します。
  • Manufacturer Part Search パネル – 選択したコンポーネントを管理された content サーバから取得すると(右クリックメニューから Acquire を選択)、Component type ダイアログは自動で開き、適切な Component Type が選択されます。それから、コンポーネントは、サーバへリリースする前に、Single Component エディタで開きます。
  • Single Component Editor – コンポーネントをそのエディタで開くと、その Component Type 設定は、Advanced Settings オプション下の Type のドロップダウンメニューで指定します。 ボタンを選択して、Preferences Component Types リストを表示して管理できます。

Part Choice のランキング

Part Choice は、設計コンポーネントを manufacturer part(サプライチェーンを通して購入される)から切り離すメカニズムになっています。複数の Part Choice を追加することにより、設計コンポーネント パラメータでその情報を編集しないで、サプライチェーンの詳細を複数のパーツに追加できます。

Part Choice は、Part Choice を追加、または編集した場所でランク付けできます。例えば、Part Choice は、Single Component エディタでランク付けして、BOM で優先順位を設定できます。複数の Part Choice がある場合、それらの順番は、自動で現在のランキングに合わせて更新されます。

 

コンポーネント Part Choice ランキングは、Components パネルActiveBOM BomDoc でも利用できます。

SVN ライブラリのキャッシュの場所を設定

SVN データベース ライブラリのキャッシュフォルダの場所は、Preferences ダイアログの Data Management - SVN Libraries ページで指定できます。

 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

You are reporting an issue with the following selected text
and/or image within the active document:
ALTIUM DESIGNER FREE TRIAL
Altium Designer Free Trial
Let’s get started. First off, are you or your organization already using Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

In that case, why do you need an evaluation license?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You actually don’t need an evaluation license for that.

Click the button below to download the latest Altium Designer installer.

Download Altium Designer Installer

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Please fill out the form below to get a quote for a new seat of Altium Designer.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

If you are on Altium Subscription, you don’t need an evaluation license.

If you are not an active Altium Subscription member, please fill out the form below to get your free trial.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Why are you looking to evaluate Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

You came to the right place! Please fill out the form below to get your free trial started.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Sounds exciting! Did you know we offer special discounted student licenses? For more information, click here.

In the meantime, feel free to request a free trial by filling out the form below.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

That’s great! Making things is awesome. We have the perfect program for you.

Upverter is a free community-driven platform designed specifically to meet the needs of makers like you.

Click here to give it a try!

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.