Altium Designer Documentation

Концепция моделей, компонентов и библиотек

Последнее изменение: Pavel Demidov; 19.05.2019

Содержание

Полное содержание

Именно компоненты и их соединение между собой определяют ваше произведение – электронное устройство. Компоненты – это базовые строительные блоки устройства. Что же такое компонент, и где они хранятся?

В реальном мире компоненты являются осязаемыми объектами, и, следовательно, их легко опознать. Но в виртуальном мире проектирования компоненты абстрагируются в набор моделей, которые можно использовать в различных областях проектирования, или доменах. Компонент представляется символом на схеме, посадочным местом на плате, моделью SPICE для анализа, описанием целостности сигналов для анализа качества сигналов и трехмерной моделью для визуализации на плате. Один компонент – множество представлений для каждой области проектирования.

Для каждой области проектирования необходима специальная модель. Для ввода схемы моделью является схемный символ. Поскольку среда проектирования построена вокруг идеи, что проект начинается со схемы, схемный символ используется для связывания различных моделей вместе.

Затем, чтобы распознать физический компонент, с помощью параметров добавляется дополнительная информация, такая как мощность, допуск, информация для закупки, ссылки на даташиты и т.д.


Схемный символ ссылается на прочие модели для полного описания компонента для каждой области проектирования. 3D-модель фактически размещается в посадочном месте – подробнее об этом ниже.

Модели и библиотеки моделей

Модель или компонент любого типа необходимо хранить в файле модели или в библиотеке. Некоторые из них используют стандартизированный формат файлов, например SPICE, в то время как другие используют собственный формат, например, файл SchLib используется для хранения схемных символов или компонентов.

Некоторые типы моделей, такие как SPICE, хранятся в отдельных файлах, и такие файлы называются файлами моделей. Другие типы моделей, такие как посадочные места Altium, хранятся в файлах, которые могут содержать одно или множество посадочных мест, и такие файлы называются библиотеками моделей.

Обзор типов моделей и библиотек

Для решения широкого спектра задач, выполняемых в процессе разработки электроники, необходимы различные типы моделей и форматы библиотек.

Ниже приведен обзор по каждому типу моделей и библиотек.

Область проектирования Тип модели или библиотеки Расширение файлов Примечания
Ввод электрических схем Символ *.SchLib Схемный символ Altium – может быть просто символом, либо к нему могут быть добавлены модели и параметры для полного описания компонента.
Конструирование плат Посадочное место *.PcbLib Посадочное место определяет точки монтажа и соединения компонента на плате; может содержать как технологические элементы (контактные площадки, шелкографию, маску и т.д.), так и опциональное 3D-представление компонента.
3D-проектирование платы 3D-модель *.PcbLib Объект Altium – разместите одну или множество 3D-моделей компонента в библиотеке PcbLib.
STEP *.STEP, *.STP Стандартная 3D-модель в формате STEP – может быть импортирована в объект 3D-модели и размещена в посадочном месте в библиотеке PcbLib.
Parasolid 3D© *.X_T, *.X_B 3D-модель в формате Parasolid (ASCII или бинарный) – может быть импортирована в объект 3D-модели и размещена в посадочном месте в библиотеке PcbLib.
SOLIDWORKS 3D© *.SldPrt 3D-модель в формате SOLIDWORKS – может быть импортирована в объект 3D-модели и размещена в посадочном месте в библиотеке PcbLib.
Анализ цепей Модель SPICE3f5 / XSpice / PSpice *.mdl Файл модели SPICE 3f5 – описывает поведение компонента с помощью синтаксиса SPICE.
*.ckt Файл подцепи SPICE – список цепей в формате SPICE, описывающий цепь, которая моделирует поведение компонента.
Модель SimCode *.txt + *.mdl Файл/библиотека моделей ASCII Digital SimCode и промежуточный файл подключения моделей (MDL), необходимый для отображения цифровой модели в символ – используется для моделирования цифровых компонентов в аналого-цифровом анализе.
*.scb + *.mdl Файл/библиотека полных моделей Digital SimCode и промежуточный файл подключения моделей (MDL), необходимый для отображения цифровой модели в символ – используется для моделирования цифровых компонентов в аналого-цифровом анализе.
Анализ целостности сигналов Модель IBIS *.ibis Файл спецификации входных и выходных буферов (Input/output Buffer Information Specification) – поведенческая модель, которая описывает электрические характеристики входного или выходного вывода.
Создание компонентов Интегрированная библиотека Altium *.IntLib Компилированная библиотека – хранит в себе модели всех типов. Файл IntLib является результатом компиляции проекта LibPkg.
Создание компонентов Библиотека Altium на основе подключенной базы данных *.DbLink Файл подключения к базе данных – использует параметрические данные, которые хранятся в компонентах SchLib, для запроса подходящей записи во внешнем источнике данных ODBC (например, номер компонента или сопротивление, мощность и корпус). Данные из полей, отображаемых в DbLink, извлекаются и добавляются в компонент в процессе его размещения.
Создание компонентов Библиотека Altium на основе базы данных *.DbLib Файл библиотеки на основе базы данных – представляет внешний источник данных ODBC в качестве библиотеки компонентов Altium, что позволяет размещать компоненты непосредственно из базы данных. Данные из полей, отображаемые в DbLib, извлекаются и добавляются в компонент в процессе его размещения. В каждой записи базы данных должны быть указаны модели Altium (символ, посадочное место и т.д.).
*.SVNDbLib DbLib под управлением системы контроля версий – взаимодействует с репозиторием SVN для контроля версий моделей схемы и платы.
Создание компонентов Компонент Vault *.CmpLib Файл определения компонента Altium Vault – объединяет модели и параметрические данные Vault; при выпуске происходит создание объекта компонента в Vault.

Компонент

Компонент может быть простым, как резистор с двумя выводами, так и очень сложным, как большая ПЛИС с сотнями выводов. Для обеспечения гибкости организации компонентов на листах схем система включает в себя ряд полезных функциональных возможностей.

Символ или компонент?

После того, как к символу подключены прочие доменные модели и к нему добавлены параметры, он становится компонентом. Многие проектировщики продолжают называть его символом, когда видят его на схеме (поскольку именно в виде символа компонент отображается на схеме), но когда к этому символу присоединены другие доменные модели и параметры, он определяется как компонент. В этой статье термин символ используется для описания графического объекта и выводов, размещенных в редакторе схемных библиотек, в прочих ситуациях он называется компонентом.

 
Символ является набором графических объектов и выводов (изображение слева). После того, как к нему подключаются посадочное место и модели и добавляются параметры, он становится компонентом (изображение справа).

Символ создается в редакторе схемных библиотек. После того, как к нему добавляются ссылки на модели и параметры, он становится компонентом. Информация о компоненте может быть добавлена в редакторе схемных библиотек, либо, если вы используете библиотеку типа DbLink или DbLib, эта информация может быть извлечена из базы данных и добавлена в символ в процессе его размещения на схеме (подробнее об этом ниже). Либо эту информацию можно добавить после размещения символа на листе схемы.

Символ

Символ создается в редакторе схемных библиотек. Его создание осуществляется путем размещения графических объектов для задания нужной формы, после чего добавляются выводы. Именно выводы задают электрические свойства компонента, они являются тем, что система распознает как точки электрических соединений, и они отображаются в контактные площадки посадочного места.

 
Символы могут быть простыми и маленькими, как этот MOSFET, либо быть большими компонентами со множеством выводов, как ПЛИС, созданная из множества секций.

Замечания о создании символов:

  • Объекты, размещаемые в редакторе библиотек, располагаются и отображаются в том порядке, в котором они размещаются. Используйте команды меню Edit » Move для изменения порядка отображения, если выводы перекрываются телом компонента.
  • Только один конец вывода является электрическим, который также называется электрической точкой – убедитесь, что электрическая точка (конец, который закрепляется на курсоре мыши при перемещении вывода) направлена от тела компонента. Для получения более подробной информации перейдите на страницу объекта Pin.
  • В редакторе схемных библиотек свойства компонента, такие как позиционное обозначение по умолчанию и описание, редактируются в интерактивной панели Properties, открытой в режиме Component. Дважды щелкните мышью по названию компонента в панели SCH Library или нажмите кнопку Edit под списком компонентов, чтобы открыть панель свойств в режиме редактирования компонента. Если дважды щелкнуть мышью по примитиву, размещенному в качестве элемента символа, в панели Properties будут отображены свойства этого примитива, а не свойства родительского компонента.
  • На изображениях на этой странице позиционное обозначение и комментарий отображаются на листе редактора библиотек. Этот параметр можно включить/отключить для текущей библиотеки в режиме Library Options панели Properties – панель отображается в этом режиме, когда нет выделенных объектов (дважды щелкните по пустому пространству, чтобы отобразить панель в этом режиме).
  • Шрифты можно настроить отдельно для каждого объекта при их размещении, либо вы можете задать предварительные настройки шрифтов для новых объектов путем редактирования соответствующих примитивов на странице Schematic - Default Primitives диалогового окна Preferences.
  • В текущий компонент можно импортировать множество выводов из электронной таблицы с помощью команд Smart Grid контекстного меню панели SCHLIB List.
  • Установите дополнительный программный модуль Schematic Symbol Generation Wizard, чтобы быстро создавать компоненты с большим количеством выводов. Это средство также поддерживает импорт информации о выводах из электронной таблицы через контекстное меню.

Обратитесь к страницам:

Перед тем, как начать создавать схемные символы, лучше потратить некоторое время на настройку параметров по умолчанию. Настройки по умолчанию для всех схемных объектов (для редактора библиотек и редактора схем) задаются на странице Schematic - Default Primitives диалогового окна Preferences. Когда открыта страница диалогового окна, нажмите F1 для получения более подробной информации по ней.

В процессе установки новой версии системы у вас будет запрошена загрузка настроек по умолчанию из предыдущей версии. Вы также можете сохранить/загрузить их в/из файла (или сервера Altium), что удобно при переносе настроек на другой компьютер.

Режимы отображения – множество представлений одного компонента

Система поддерживает различные представления одного и того же компонента. Например, одни ваши заказчики могут хотеть, чтобы резисторы изображались прямоугольником, а другие – чтобы они изображались волнистой линией.

Каждое из этих представлений называется режимом отображения – Mode. Вы можете задавать дополнительные представления символа путем добавления новых режимов Mode из меню Tools редактора схемных библиотек либо через панель инструментов Mode (щелкните ПКМ по строке меню, чтобы управлять отображением панелей инструментов).


Резистор, созданный с двумя режимами отображения. Редактор библиотек включает в себя панель инструментов Mode, которую можно использовать для добавления/удаления режимов и переключения между ними.

Выбор нужного режима для размещенного из библиотеки компонента осуществляется с помощью переключателя Mode в панели Properties. Режимом отображения по умолчанию является тот режим, который был активен при последнем сохранении библиотеки.

Каждый режим отображения должен включать в себя один и тот же набор выводов, чтобы при компиляции проекта не возникало предупреждения. Это требуется, поскольку можно определить только один набор отображений выводов в контактные площадки для каждого посадочного места, связанного с компонентом. Выводы не должны обязательно располагаться в одних и тех же местах в различных режимах.

Разделение компонентов на множество секций

В некоторых случаях более целесообразно разделить компонент на несколько символов, каждый из которых называется секцией – Part. Примеры: резисторы в резисторной матрице, катушка и набор контактов в реле, банки входа/выхода в большой ПЛИС, выводы в соединителе, если вы, например, хотите разместить выводы соединителя в различных местах листа вместо того, чтобы вести линии связи к единому символу.

Такие компоненты называются многосекционными. Каждая секция создается в редакторе схемных библиотек отдельно, и в них соответствующим образом добавляются выводы. На изображении ниже показана одна и та же резисторная матрица как единый символ и как четыре отдельных секции.


Одна и та же резисторная матрица как единый символ слева и как четыре отдельных секции справа.

Замечания по работе с многосекционными компонентами:

  • В редакторе библиотек используйте команду Tools » New Part для добавления секции в текущий компонент.
  • Используйте панель SCH Library для перехода между секциями многосекционного компонента, как показано ниже.

  • Позиционное обозначение многосекционного компонента включает в себя суффикс для обозначения каждой ячейки. Суффикс может быть буквенным или числовым. Задайте нужный режим с помощью параметра Alpha Numeric Suffix на странице Schematic - General диалогового окна Preferences. Обратите внимание, что этот параметр является настройкой среды и он не хранится в файле библиотеки или схемы, поэтому он не передается с проектными файлами.
  • Многосекционные компоненты считаются гомогенными, поэтому все секции являются эквивалентными при аннотировании проекта, и потенциально можно провести эквивалентную замену в процессе аннотирования. Например, катушку реле можно поменять местами с набором контактов реле, в зависимости от их относительного расположения на листе схемы. Чтобы заблокировать определенную секцию размещенного компонента, включите параметр Locked в панели Properties (показано ниже).

  • В процессе аннотирования схемы, секции многосекционного компонента упаковываются для завершения компонента в соответствии с настройками Matching Options в диалоговом окне Annotate (как показано ниже). Выставленные флажки в левой части определяют, какие свойства компонентов должны совпадать, чтобы секции были упакованы вместе. Если необходимо управлять упаковкой определенных секций, чтобы они были вместе в одном физическом компоненте, например, пара операционных усилителей в проекте фильтра, и вы не хотите назначать и блокировать эти секции вручную, добавьте дополнительный параметр этому компоненту и введите значение, которое определяет, какие секции должны быть упакованы вместе. На изображении ниже показаны настройки соответствия в диалоговом окне Annotation. Включенные параметры используются для определения соответствия для многосекционных компонентов, и чтобы управлять упаковкой резисторов, был добавлен параметр ResPack – когда секции имеют одно и то же значение этого параметра, они будут упакованы в один и тот же физический компонент. Обратите внимание на параметр Strictly – если этот параметр включен, то у секций должен присутствовать этот параметр, чтобы они были упакованы вместе. Будьте внимательны с этой настройкой, поскольку если в проекте присутствуют многосекционные компоненты различных типов, упаковкой которых вы хотите управлять, то у них всех должен присутствовать этот параметр, если настройка Strictly включена.

  

  • Эквивалентная замена секций на печатной плате возможна только для компонентов, секции которого определены как многосекционный компонент. Чтобы узнать подробнее, перейдите на страницу Эквивалентная замена выводов и секций.

Более ранние версии систем Altium позволяли скрывать выводы в редакторе библиотек и предварительно назначать цепи скрытым выводам. Это больше не считается хорошим подходом и не поддерживается в новых проектах. Старые проекты, в которых использовалась эта возможность, будут формировать корректный список цепей, и скрытые выводы можно отобразить, включив параметр Show All Pins на вкладке Pins панели Properties (в режиме Component).

Тип компонента

В среде проектирования вам может понадобиться создавать объекты, которые будут монтироваться на плату, но не обязательно должны быть компонентами. Например, может присутствовать внешний модуль, который соединяется с платой, и вы хотите создать его как компонент и добавить его на схему для ясности проекта, но при этом не нужно, чтобы этот компонент входил в состав изделия платы. Либо могут присутствовать механические детали, такие как радиаторы или крепеж, которые должны быть включены в состав изделия, но вы не хотите включать их на схему.

Управление подобными ситуациями осуществляется заданием компоненту нужного типа, т.е. значения параметра Type. В описанном примере компоненту необходимо задать тип Graphical. Другим особым классом компонентов являются тестпойнты – этот компонент нужен как на схеме, так и на плате, и он должен быть включен в процессе синхронизации проекта, но он не должен присутствовать в составе изделия. В этом случае, необходимо задать тип компонента Standard (No BOM).


Для компонентов нестандартных типов задайте соответствующий тип.

Поле Type используется для определения того, должен ли компонент быть включен в состав изделия, а также для управления компонентом при синхронизации. Типы Standard, Net Tie и Jumper синхронизируются полностью, т.е. компоненты передаются из схемы в плату, и при этом проверятся связность цепей. Для типов Mechanical и Graphical Types компонент не передается из схемы в плату. Если компонент одного из этих типов был размещен в плате вручную и был задан соответствующий тип, то будет осуществлена синхронизация на уровне компонентов, но проверки на уровне цепей проводиться не будут.

Использование параметров компонентов

Много информации, которая описывает компонент, задается в качестве параметров. Они позволяют определить дополнительную текстовую информацию о компоненте. Параметры могут включать в себя электрические характеристики (например, мощность или допуск), информацию о цене или запасах, примечания проектировщика, ссылки на даташиты и любую другую информацию, необходимую проектировщику.

Параметры могут быть заданы в редакторе схемных библиотек в процессе создания компонента, могут быть добавлены автоматически в процессе размещения компонента из библиотеки на основе базы данных (подробнее об этом ниже) или могут быть добавлены вручную после того, как компонент размещен на схеме.

Добавление параметров компоненту

Для отдельного компонента параметры добавляются на вкладке Parameters панели Properties (режим Component). Как упоминалось, это можно сделать в библиотеке или после размещения компонента на листе схемы.


Параметры задают дополнительную информацию компоненту.

Параметры, заданные пользователем, можно отобразить на схеме вместе с компонентом, если это необходимо, нажав по иконке видимости рядом с именем параметра. Отредактируйте видимый параметр, чтобы также включить отображение имени параметра.

Определение интерактивных ссылок на справочную информацию

Вкладка General панели Properties (в режиме Component) также включает в себя раздел Links. Эту возможность можно использовать для добавления, например, ссылок на даташит или веб-сайт производителя. Компоненту может быть задано любое количество ссылок.

Ссылки, отображаемые в панели, являются интерактивными – при щелчке по тексту ссылки будет загружен URL в настроенном браузере. Для редактирования существующей ссылки щелкните где-нибудь в ячейке вне текста ссылки, затем нажмите по кнопке редактирования.

Ссылки можно открывать через контекстное меню размещенного на схеме компонента или через панель Libraries, как показано ниже.

  
Щелкните ПКМ по компоненту на листе схемы (изображение слева) или в панели Libraries (изображение справа), чтобы открыть ссылки компонента.

Ссылки также можно включить в сформированный из схемы файл PDF – либо через функцию Smart PDF, либо через PDF, сформированный из файла Output Job. На изображении ниже показан список параметров компонента в файле PDF – по тем из них, которые являются ссылками URL, можно щелкнуть мышью, чтобы перейти в заданное расположение из файла PDF.

Параметры компонентов и ссылки также можно включить в файл PDF, включив параметр Include Component Parameters в мастере Smart PDF или в настройках вывода документа в файле OutputJob.

Файлы PDF можно сформировать непосредственно из редактора схем через мастер Smart PDF Wizard или через OutputJob. Щелкните по компоненту в файле PDF, чтобы отобразить его параметры, как показано ниже.


Щелкните по компоненту в файле PDF, чтобы отобразить его параметры. Щелкните по параметру, который является ссылкой, чтобы открыть эту ссылку.

Более ранние версии систем Altium также поддерживали специальный параметр под названием HelpURL. Если компонент включал в себя этот параметр, то при нажатии клавиши F1 при наведении курсора на компонент ссылка, заданная в параметре HelpURL, будет передана в Windows, где будет открыт соответствующий URL или файл. Эта возможность больше не поддерживается, и если у компонента есть параметр HelpURL, он должен быть заменен на ссылку компонента, как описано выше.

Отображение комментария в поле Comment компонента

Параметрами компонента по умолчанию, отображаемыми на схеме, являются позиционное обозначение Designator и комментарий Comment. При передаче проекта из редактора схем в редактор плат, строки Designator и Comment также являются строками по умолчанию, которые можно легко отобразить на плате.

Чтобы позволить проектировщику отображать значение любого параметра компонента на схеме и плате, например, отображать значение параметра под названием Capacitance, вы можете отобразить любой параметр компонента в поле Comment компонента с помощью способа, известного как косвенная адресация строки.

Это осуществляется путем ввода имени параметра в виде =ИмяПараметра. Например, для отображения значения параметра Capacitance компонента в поле Comment компонента, введите строку =Capacitance в поле Comment в панели Properties, как показано ниже. Строка, заданная таким синтаксисом, называется специальной строкой.

Специальные строки автоматически преобразуются для отображения на экране. Если параметру, который отображается в качестве специальной строки, не задано значение, то вместо него будет показано имя параметра в сером цвете, если на странице Schematic - Graphical Editing диалогового окна Preferences включен параметр Display Names of Special Strings that have no value defined. Если этот параметр отключен, ничего не будет показано.


Используйте специальные строки для отображения значений любых параметров в комментарий компонента.

Специальные строки позволяют отображать любые параметры в любые строки. Эта строка может быть строкой компонента, свободной строкой, размещенной на листе схемы, или строкой, размещенной в шаблоне листа. Параметр может быть параметром компонента, параметром документа или параметром проекта. Чтобы получить более подробную информацию по специальным строкам, перейдите на страницу объекта Text String.

Добавление параметров множеству компонентов

Параметры являются ключевыми элементами любых компонентов, и, как правило, многие параметры используются во множестве компонентов. Кроме добавления параметров отдельно каждому компоненту, вы также можете использовать команду Parameter Manager для добавления параметров множеству компонентов. Помимо добавления и удаления параметров, также можно редактировать значения параметров для множества компонентов.


Диалоговое окно Parameter Table Editor можно использовать для редактирования параметров множества компонентов.

Замечания по редактированию множества параметров:

  • Параметры можно редактировать для компонентов в библиотеке или для компонентов, используемых в схеме, используя один и тот же процесс. Выберите команду Tools » Parameter Manager в редакторе схем или редакторе схемных библиотек, чтобы запустить этот процесс.
  • Поскольку параметры можно добавлять множеству различных объектов, первым шагом нужно выбрать в диалоговом окне Parameter Editor Options, в объектах каких типов необходимо редактировать параметры.
  • Редактирование параметров осуществляется в диалоговом окне Parameter Table Editor. Поскольку диалоговое окно можно открыть различными способами, его заголовок может отличаться. Тем не менее, способ работы в диалоговом окне остается неизменным: используйте стандартные сочетания клавиш Windows для выделения необходимых ячеек, затем щелкните ПКМ и выберите необходимую операцию редактирования.
  • Изменения применяются не сразу, а через механизм Engineering Change Orders (ECOs).
  • Каждая измененная ячейка помечается маленькой цветной иконкой. Обратитесь к странице диалогового окна Parameter Table Editor за описанием каждой из этих иконок.

Связывание компонентов с внешними данным о цепочке поставок

Главная страницаe: Связывание с данными поставщиков

С точки зрения проектировщика электроники, одним из самых важных аспектов создания компонента является связывание этого компонента с реальным, физическим компонентом, который он представляет. Это связывание может осуществляться как простым вводом номера компонента в качестве параметра, так и связыванием с приобретенным компонентом в базе данных предприятия через DbLink или DbLib (подробнее об этом ниже). Другим подходом является непосредственная связь компонента с его поставщиком через функциональные возможности связывания с данными поставщиков.

Ключевым элементом связывания с данными поставщиков является пара параметров компонента под названием Supplier n и Supplier Part Number n. С их помощью система подключается к облачным службам Altium, где она может получить доступ к подробной информации о компоненте, такой как производитель, номер компонента производителя, цена, рабочее напряжение и т.д. У системы есть прямой доступ к информации для ряда основных поставщиков компонентов, настройка которых осуществляется на странице Data Management - Parts Providers диалогового окна Preferences.

Интерфейсом функциональной возможности связывания с данными поставщиков является панель Part Search. Нажмите кнопку  в нижней правой части окна, чтобы отобразить панель.


Панель Part Search обеспечивает прямой доступ к актуальным данным о компонентах.

Для работы с панелью:

  • Нажмите кнопку , чтобы открыть страницу Data Management - Supplier диалогового окна Preferences, где вы можете включить нужных поставщиков. Обратите внимание, что настройки также включают в себя параметры ключевых слов и параметры импорта, которые используются для отображения именования поставщиков в предпочтительные имена параметров. Параметры можно исключить при необходимости, и к ним может быть добавлен числовой суффикс. Используйте это, если вы планируете добавлять множество ссылок на поставщиков одному компоненту.
  • В панели Supplier Search нажмите кнопку , чтобы настроить параметры фильтров (Filter).
  • Введите строку поиска в поле Keywords в верхней части панели и нажмите клавишу Enter или кнопку Search.
  • Результаты поиска перечисляются в панели. Щелкните по результату, чтобы отобразить подробную параметрическую информацию об этом компоненте в нижней части панели.
  • Перетащите результат мышью из панели на схему или щелкните ПКМ по компоненту в списке результатов и выберите:
    • Add Supplier Link to Part – добавить в компонент только параметры Supplier n и Supplier Part Number n.
    • Add Supplier Link and Parameters to Part – добавить в компонент все доступные параметры, в том числе Supplier n и Supplier Part Number n.
  • Если вы не хотите добавлять все параметры, выберите нужные параметры с помощью стандартных методов выделения Windows, затем щелкните ПКМ по одному из выбранных параметров и запустите команду Add Parameters to Part.


При необходимости параметры можно добавлять выборочно.

Ссылки на поставщиков могут быть добавлены в существующий компонент, либо можно создать новый компонент, настроив рабочую область как описано ниже, щелкнув ПКМ по компоненту в панели Supplier Search и выбрав соответствующую команду.

Для работы между панелью и...

  • схемной библиотекой – добавьте параметры в текущий компонент либо добавьте новый компонент в схемную библиотеку. Либо перетащите результат мышью из панели на символ или на имя компонента в панели SCH Library, чтобы добавить параметры этому компоненту.
  • библиотекой DbLib / SVNDbLib – включите отображение Table Browser, затем добавьте параметры выбранной записи компонента либо добавьте новую запись компонента в базу данных.
  • компонентом на листе схемы – выберите одну из контекстных команд панели Supplier Search. При перемещении курсора по листу схемы он изменит свой вид на перекрестие – щелкните мышью по нужному компоненту на схеме. Либо перетащите результат мышью из списка компонентов в панели на компонент на листе схемы.

Информацию о цепочке поставок также можно добавить на любом этапе процесса проектирования с помощью редактора ActiveBOM. Помимо поддержки функциональной возможности связывания с поставщиками, ActiveBOM также можно настроить на поиск компонентов по имени и номеру компоненту производителя, которые можно добавить в параметры компонента. Для получения более подробной информации перейдите на страницу Управление составом изделия с ActiveBOM.

Добавление моделей в компонент

На этапе формирования схемы проект является набором компонентов, которые необходимо логически соединить. Чтобы провести анализ или продолжить разработку, например, провести имитацию цепи, сконструировать плату, провести анализ целостности сигналов и т.д., проект необходимо передать в другую область проектирования. Для этого должны быть модели компонентов, необходимые для целевой области проектирования.

  • Посадочные места подключаются к схемному компоненту путем их добавления в раздел Footprint панели Properties.
  • Модели подключаются к схемному компоненту путем их добавления в раздел Models панели Properties.


Модели добавляются в панель Properties. Модель каждого типа открывается в собственном редакторе.

В процессе подключения модели, информация о компоненте должна быть отображена из схемы в целевую модель.

В редакторе схемных библиотек посадочные места и прочие модели можно добавить с помощью панели Properties и области моделей главного окна редактора, отображаемого в его нижней части.

3D-модель не подключается непосредственно к символу компонента, а размещается в посадочном месте, поскольку ее необходимо корректно повернуть, выровнять и разместить относительно посадочного места, поэтому разумно это делать в редакторе посадочных мест. Чтобы узнать подробнее о работе с 3D-моделями и их размещении в посадочном месте, обратитесь к странице Создание посадочного места.

Отображение модели в символ

Информация для определенных областей проектирования содержится в файлах моделей предопределенного формата, таких как файлы IBIS, MDL и CKT. Системе нужны другие данные для доступа к этой информации, например, отображение выводов и список цепей между схемным символом и моделью. Эта информация определяется в редакторах моделей, которые открываются при добавлении или редактировании модели, как показано в примерах на изображении выше. Помимо ссылки на файл модели, также включается информация об отображении моделей или списке цепей, необходимая для моделей этого типа.

Для получения информации об отображении модели в символ нажмите F1, когда открыто соответствующее диалоговое окно модели.

Существует ряд предопределенных моделей аналоговых устройств, встроенных в SPICE. Для компонентов этих типов нет отдельного файла модели. Вся информация, необходимая для их моделирования, настраивается в редакторе SIM Model.

Где производится поиск модели

В верхней части каждого диалогового окна модели находится поле Name, которое должно содержать имя файла модели. Вы можете ввести имя или использовать команду Browse для поиска модели. В нижней части диалогового окна находится строка, которая показывает, где эта модель была найдена.


Когда модель найдена, появляется модель и отображается информация о том, где она была найдена.

Возможность системы находить модель зависит от настроек, которые определяют, где система может искать модель. Они находятся сразу под именем модели. Название этой области диалогового окна зависит от типа модели – для посадочного места, показанного на изображении выше, она называется PCB Library. Доступные опции: от Any, что означает поиск модели во всех доступных библиотеках, до Integrated Library или Vault, что означает, что может использоваться модель только из указанной интегрированной библиотеки или Vault.

Диалоговые окна редактирования моделей включают в себя следующие опции, с некоторыми небольшими отличиями в зависимости от типа модели.

Опция Поведение Настройка диалогового окна
Any
(Любая библиотека)
Поиск подходящей модели во всех доступных библиотеках.
Library name
(Название библиотеки)
Поиск подходящей модели только в доступных библиотеках с этим названием.
Library path
(Путь к библиотеке)
Поиск подходящей модели только в библиотеке с этим названием в этом расположении.
Integrated library
(Интегрированная библиотека)
Поиск модели только в интегрированной библиотеке, из которой был размещен компонент. Интегрированная библиотека должна быть доступна.
Vault Поиск модели только в Altium Vault, из которого был размещен компонент. Система должна быть подключена к этому Vault.

Выпадающее меню включает в себя библиотеки проекта и установленные библиотеки (доступные библиотеки).

Доступные библиотеки

Управляемые компоненты размещаются непосредственно из Altium Content Vault. После настройки подключения к Content Vault в диалоговом окне Preferences вы можете просматривать и искать компоненты в панели Explorer. Для управляемого компонента, настройка расположения модели заблокирована на Use <ТипМодели> from component library <ИмяVault> (Использовать <ТипМодели> из библиотеки компонентов <ИмяVault>).

Наиболее распространенным подходом для традиционных моделей библиотечных компонентов является их получение из любых доступных в данный момент библиотек. Для этого выставляется описанная выше опция Any, при которой поиск модели с указанным именем осуществляется во всех доступных библиотеках.

Панель Libraries отображает доступные библиотеки в своем выпадающем меню, как показано на изображении.

Обратите внимание, что у выпадающего меню есть фильтр, доступный по нажатию кнопки . Используйте его для показа/скрытия библиотек посадочных мест и устаревших библиотек PCB3D.

Управление расположениями поиска библиотек и доступными библиотеками

Управление списком доступных моделей и библиотек осуществляется в диалоговом окне Available Libraries. Чтобы открыть диалоговое окно, нажмите кнопку Libraries в панели Libraries. Панель можно открыть с помощью кнопки Panels или команды Design » Browse Library в редакторе схем.

Диалоговое окно содержит три вкладки. Все расположения библиотек и моделей, определенные на этих вкладках, составляют список доступных библиотек. При осуществлении действия, требующего поиска модели, такого как передача проекта из схемы на плату, поиск по библиотекам осуществляется в порядке, в котором представлены вкладки и в котором на них перечислены библиотеки/модели. Как только нужная модель найдена, процесс поиска прекращается.

Библиотеки проекта

Библиотеки, которые являются частью текущего проекта, перечисляются на вкладке Project диалогового окна Available Libraries, когда этот проект является активным. Преимуществом библиотек проекта является то, что при открытии проекта модели/библиотеки автоматически становятся доступными. Недостатком является то, что если модели/библиотеки не хранятся в той же структуре папок, что и файлы проекта, то их можно легко забыть при перемещении файлов проекта.


На вкладке Project приводится список доступных библиотек текущего проекта.

Любая библиотека может быть библиотекой проекта, их не нужно хранить в папке проекта. Щелкните ПКМ по имени проекта в панели Projects и выберите команду Add Existing to Project, чтобы включить библиотеки в проект.

Установленные библиотеки

Библиотеки и модели, которые были сделаны доступными для установки системы, называются установленными библиотеками. Они перечисляются на вкладке Installed диалогового окна Available Libraries. Эти модели/библиотеки доступны в любых проектах, открытых в установке системы. Обратите внимание, что этот список сохраняется в среде, а не в открытых проектах.

Установленные библиотеки могут быть перечислены с использованием абсолютного пути или пути, относительного настройки Library Path Relative To:. Преимуществом использования относительного пути является то, что вы можете создать общую под-среду на множестве компьютеров и легко перемещать проектные файлы между ними. Кроме того, вы можете временно деактивировать установленные библиотеки, сняв их флажки Activated, вместо того, чтобы удалять их.


На вкладке Installed перечислены библиотеки, которые были сделаны доступными для этой установки системы Altium.

Путь поиска

На вкладке Search Path представлен список библиотек, которые были найдены согласно настройкам пути, заданным на вкладке Search Path диалогового окна Options for Project, которое можно открыть с помощью кнопки Paths на вкладке Search Path диалогового окна Available Libraries. Каждый путь поиска определяет папку и может включать в себя подпапки, если включен параметр Recursive (доступного при определении пути). Все файлы моделей и библиотек, найденные по пути поиска, станут доступными. Пути поиска сохраняются вместе с проектом.

Извлечение моделей с помощью путей поиска может быть медленным, если в папках путей поиска находится большое количество файлов. По этой причине не рекомендуется использовать этот подход для библиотек посадочных мест, поскольку они могут быть большими файлами, содержащими множество посадочных мест. Эта функциональная возможность была разработана для обеспечения ссылок на доступные имитационные модели и модели целостности сигналов.


Использование Search Path для поиска имитационных моделей и моделей целостности сигналов.

Поскольку система обеспечивает гибкость и контроль над расположениями определенных моделей/библиотек, для моделей каждого типа необходимо использовать корректное расширение файлов. Например, посадочное место может быть найдено, только если оно находится в файле с расширением .Lib или .PcbLib. Аналогично, SPICE .SUBCKT может быть найден только в файле .ckt, а SPICE .MODEL – только в файле .mdl. Если модель не удается найти, в панели Messages появится ошибка.

Перемещение проекта из одного места в другое

При размещении компонента в проекте из библиотеки он кэшируется в проектом файле, поэтому документ может быть открыт из любого расположения без необходимости загрузки исходных библиотек. Это полезно при перемещении проекта из одного места в другое, поскольку нет необходимости в перемещении библиотек. Обратите внимание, что название изначальной исходной библиотеки и названия моделей также сохраняются в свойствах размещенного компонента.

С помощью меню Design соответствующего редактора вы можете сформировать схемную библиотеку из всех компонентов, размещенных в документах схем текущего проекта, либо библиотеку посадочных мест из всех посадочных мест, размещенных в текущем документе платы.

Библиотеки

Теперь, когда вы разобрались в моделях и компонентах, рассмотрим варианты их хранения.

Модели и компоненты хранятся в библиотеках, и системы Altium поддерживают ряд библиотек различных типов. Как решить, какой тип библиотек наилучшим образом соответствует потребностям вашего предприятия?

Библиотеки схемных символов, посадочных мест и моделей

На начальных этапах автоматизации проектирования электроники существовало две области проектирования: ввод электрических схем и конструирование плат. Выходными документами ввода схем был набор распечаток листов схем, а выходными документами конструирования плат были файлы для изготовления печатной платы и печатного узла.

Для этого проектировщиками было необходимо создавать и хранить схемные символы, готовые к размещению на листы схем. Информация, такая как номинал компонента, напряжение, мощность и т.д., зачастую добавлялась после размещения символа из библиотеки на лист схемы.

Редактирование посадочных мест заключалось в создании конструкции в качестве набора слоев, содержащего фигуры, необходимые для фотошаблонов. Этот подход, ориентированный на выходные документы, определял поддерживаемые фигуры, вплоть до шрифта, используемого для позиционных обозначений и прочих строк на слое шелкографии.

Эти простые символы и посадочные места создавались и хранились в библиотеках, оба типа которых изначально имели расширение файлов .Lib. После того, как в Windows было снято ограничение на трехсимвольное расширение файлов, они были изменены на .SchLib для схемных символов и .PcbLib для посадочных мест.


Библиотеки схемных символов и посадочных мест являются местом хранения соответствующих моделей. Наведите курсор на изображение, чтобы отобразить библиотеку посадочных мест.

IntLib – Интегрированная библиотека

Главная страница: Работа с интегрированными библиотеками

Со временем стала возрастать необходимость в разделении процесса создания компонентов от проектирования. Вместо того, чтобы добавлять информацию о компонентах после их размещения на лист схемы, проектировщикам требовалось полностью определять компоненты в библиотеке. Прочие области проектирования, такие как имитация цепей, также развивались, и нужно было поддерживать модели для этих областей. В процессе создания готовых к использованию компонентов также возникала необходимость проверки отображения символа в модель и последующего добавления этих компонентов в единый, готовый к использованию файл библиотеки.

Для удовлетворения этих требований были разработаны интегрированные библиотеки (.IntLib). Интегрированная библиотека содержит модели всех типов в одном файле. Источником интегрированной библиотеки является пакет библиотеки (.LibPkg) – проект, который объединяет исходные символы, посадочные места и модели. При компиляции проекта пакета библиотеки проверяется отображение символов в модели и создается интегрированная библиотека. Использование IntLib означает, что библиотека становится чем-то, откуда вы просто размещаете компоненты, что является хорошим решением для средних и больших предприятий, которые хотят разделить процессы создания компонентов и проектирования.


При компиляции LibPkg осуществляется проверка подключения моделей и создание файла интегрированной библиотеки (IntLib).

DbLink – Связывание компонентов с базой данных предприятия

Главная страница: Работа с библиотеками на основе баз данных

Интегрированная библиотека является хорошей альтернативой простым библиотекам моделей и решает задачу управления данными компонентов отдельно от процесса проектирования. Но это не удовлетворяло все возрастающую необходимость объединения области проектирования электроники с системами управления данными компонентов предприятия. Для решения этой задачи был необходим способ связывания компонента с базой данных предприятия.

Решение этой проблемы не тривиально, поскольку нет единого подхода к определению, хранению и управлению большими объемами данных компонентов. Предприятиями используются разнообразные базы данных, которые зачастую являются уникальными, соответствующими требованиям этого предприятия. Для того, чтобы обеспечить подключение среды электронного проектирования к базе данных предприятия, был выбран стандарт ODBC.

Интерфейс Open Database Connectivity (ODBC) является стандартом открытого программного интерфейса (API) доступа к базам данных. Используя в программе операторы ODBC, вы можете получать доступ к файлам в различных базах данных, таки как Access, dBase, DB2, Excel и Text.

Для создания подключения был разработан новый файл интерфейса под названием Database Link (.DbLink). Строго говоря, это не библиотека, а файл настроек проекта, который обеспечивает интерфейс между параметрическими данными компонентов (которые хранятся в стандартных библиотеках моделей) и записями в базах данных. Записи в базе данных могут быть опрошены либо с помощью поиска по одному ключу, такого как номер компонента, либо с помощью пользовательского запроса Where. При использовании запроса Where проектировщику нет необходимости проводить поиск в базе данных, находить номер компонента и включать его в схемный компонент. Вместо этого, проектировщик определяет запрос, который опрашивает базу данных по данным компонента, таким как номинал, напряжение, ток, посадочное место и т.д.

Файл DbLink определяет:

  • Целевую базу данных и метод подключения
  • Метод поиска (по одному ключу или по запросу Where)
  • Отображение между требуемой ячейкой базы данных и параметром Altium

При использовании этого подхода у проектировщика могут быть простые библиотеки, в частности, для дискретных компонентов. Например, библиотека конденсаторов может содержать конденсатор. Проектировщик размещает конденсатор на схеме, вводит его емкость, напряжение и допуск и выбирает посадочное место из списка предварительно заданных посадочных мест. После этого он опрашивает базу данных. Запрос Where, определенный в файле DbLink, используется для создания запроса ODBC, база данных опрашивается, и она возвращает данные из найденной записи, такие как номер компонента, данные состава изделия и другие, которые добавляются в размещенный компонент.

Размещенный простой общий компонент теперь полностью описан для состава изделия.


В компоненте определяются значения, по которым будет производиться поиск в базе данных, после чего происходит опрос базы данных.


DbLink осуществляет опрос базы данных в соответствии с настройками поиска (запрос Where в этом примере). При нахождении соответствия, возвращаются отображаемые значения записи, которые загружаются в редактор параметров.


Появляется редактор таблицы параметров, где можно проверить изменения параметров. При принятии этих изменений они применяются к этим компонентам через механизм ECO.
Общий компонент теперь полностью описан.

Преимуществом этого подхода является то, что он дает представление о базе данных компонентов предприятия, без необходимости ввода данных в эту базу. Возможность использования запроса Where также означает, что проектировщик может беспрепятственно разместить общий компонент, не определенный до проведения опроса. Опрос базы данных может быть осуществлен в любой момент процесса проектирования, в том числе при формировании состава изделия, когда также могут быть добавлены дополнительные параметры из базы данных.

DbLib – Размещение компонента из базы данных предприятия

Главная страница: Работа с библиотеками на основе баз данных

Файл Database Link является прекрасным решением для подключения данных компонентов предприятия непосредственно к проектным компонентам. Тем не менее, для компаний, которые хотят создать однозначную ссылку между записью компонента предприятия и проектного компонента (с помощью поиска по одному ключу, такому как номер компонента), использование файла DbLink требует от библиотекаря или проектировщика ручного просмотра базы данных, извлечение номера компонента и его добавление в каждый проектный компонент.

Таким компаниям необходимо решение, ориентированное на данные, а не программное обеспечение для проектирования, которое предлагает файл DbLink.

Для удовлетворения этой потребности была разработана библиотека Database Library (.DbLib). DbLib позволяет записи компонента в базе данных быть компонентом. Вместо того, чтобы выступать в роли файла, который связывает библиотеку электронных компонентов и базу данных компонентов, файл DbLib устанавливается как библиотека, которая получает данные из базы данных предприятия и отображает их непосредственно в панели Libraries.

Файл DbLib устанавливается таким же образом, что и схемная или интегрированная библиотека. Выступая в роли интерфейса между средой проектирования и базой данных предприятия, файл отображает в среде проектирования данные, получаемые непосредственно из базы данных предприятия. С помощью DbLib проектировщик может просматривать или искать записи компонентов и размещать компоненты в проекте непосредственно из базы данных. При нажатии на кнопку Place происходит поиск в библиотеке SchLib символа, на который ссылается эта запись, и отображаемые данные загружаются в параметры компонента. По сути, в процессе размещения компонента на схеме происходит его сборка.

Для этого подхода необходимо, чтобы записи базы данных включали в себя ссылки на модели (символ, посадочное место, имитационная модель и т.д.). Сами модели продолжают храниться в стандартных библиотеках Altium, таких как SchLib и PcbLib.


Библиотека DbLib отображает данные из базы данных в панель Libraries. Она также используется для отображения данных выбранной записи в параметры компонента в процессе его размещения.

Файл DbLib выступает в роли интерфейса с базой данных предприятия, поля которой отображаются в компоненты.

SVNDbLib – Библиотека на основе баз данных в системе контроля версий

Главные страницы: Работа с библиотеками на основе баз данных, Управление версиями и проектные репозитории, Средства преобразования библиотек на основе баз данных

Другой общей потребностью крупных компаний является возможность управления версиями интеллектуальной собственности, которой эти компании создают. Системы управления версиями (Version Control System – VCS) являются хорошим способом управления изменениями данных, а также хранения надежной копии последней зафиксированной версии данных. Они также позволяют откатиться к любой более ранней версии.

По сути, работа с SVNDbLib аналогичная работе с DbLib – вы устанавливаете SVNDbLib как библиотеку в панели Libraries. Разница заключается лишь в том, что модели находятся под управлением версий. Это означает, что модели должны храниться в репозитории, а рабочая копия должна быть выгружена. Именно рабочая копия отображается в панели Libraries и используется при нажатии на кнопку Place.

Использование моделей под управлением версий прозрачно – вы просто размещаете нужный компонент из панели Libraries. Чтобы обеспечить размещение самой новой ревизии модели при нажатии на кнопку Place, осуществляется опрос репозитория и, если необходимо, рабочая копия модели автоматически обновляется. Рабочую копию также можно в любой момент обновить через контекстное меню панели Libraries.

Управлять моделями под контролем версий также просто. Вы можете отредактировать модель через контекстное меню в панели Libraries. Щелкните ПКМ по компоненту в списке, чтобы отредактировать символ, щелкните ПКМ по посадочному месту в списке моделей, чтобы отредактировать это посадочное место. По завершении редактирования файл модели сохраняется, и вы можете щелкнуть ПКМ по названию модели в панели Projects и использовать подменю Version Control, чтобы зафиксировать изменения в репозитории. Изменения будут сразу отображены в панели Libraries.

Ключевым требованием к использованию SVNDbLib является хранение каждой модели в отдельном файле. Это необходимо для обновления отдельных моделей и фиксации новых версий этих обновленных моделей в репозиторий VCS. Для упрощения этого процесса система включает в себя мастер Library Splitter Wizard, который может быстро разделить существующую библиотеку на набор файлов, которые хранят в себе по одной модели.

 
Модели под управлением версий можно редактировать непосредственно из панели (изображение слева), сохранять и фиксировать в репозитории (изображение справа).

SVN в расширении файлов SVNDbLib означает Subversion – популярную бесплатную систему управления версиями. Программное обеспечение Altium включает в себя Subversion и клиент SVN, поэтому оно может создавать новые репозитории и проводить все стандартные для VCS действия, такие как фиксация (возврат), обновление (извлечение) и другие. Многие проектировщики предпочитают также устанавливать внешний клиент SVN. Популярным является бесплатный клиент TortoiseSVN, так как он обладает превосходными функциональными возможностями и является простым в использовании.

Управляемые компоненты

Главная страница: Работа с управляемыми компонентами

Каждая из систем хранения компонентов, описанная до сих пор, требует от проектировщиков организации различных элементов, таких как создание моделей, компонентов и библиотек, управление их версиями и историей, поддержка связи с цепочкой поставок. По этой причине, такие компоненты называются неуправляемыми, поскольку система не обеспечивает встроенной поддержки управления всеми этими задачами.

Altium понимает, что проектирование может быть намного более эффективным, если бы были программные решения, которые объединяли бы эти различные элементы, в частности, когда проектировщики являются частью большой распределенной группы. Было разработано интегрированное решение, и так появилась концепция управляемых компонентов.

Для обеспечения управляемых компонентов (и других проектных данных) необходимо следующее:

  • Управляемый доступ к общему содержимому, которое может включать в себя компоненты и модели, шаблоны, проектные файлы и выходные данные.
  • Возможность однозначного определения каждого проектного объекта (компонента, проекта, шаблона и т.д.) и каждой ревизии объекта.
  • Видимость истории каждого проектного объекта, с прозрачной автоматической системой ведения этой истории.
  • Возможность управления жизненным циклом объекта; например, возможность помечать проект как прототип или компонент как снятый с производства.
  • Возможность управления проектными данными, создания их резервных копий и их восстановления.
  • Возможность интеграции данных более высокого уровня, такой как даташиты и информация о цепочке поставок.

Altium разрабатывает полнофункциональную, глобально доступную, ориентированную на разработку электроники систему хранения и доступа к данным, соответствующую всем этим требованиям. Ее ранние версии назывались Altium Vault. Эта технология лежит в основе Altium Content Vault – онлайн-сервера управляемых компонентов. Altium Content Vault, доступный через панель Explorer, предоставляет проектировщикам прямой доступ к свыше 1 миллиона компонентов.


Компоненты Vault доступны через панель Explorer. Используйте адресную строку для поиска компонента, выберите вкладку Preview внизу, чтобы просмотреть подробную информацию о нем.
Перейдите на вкладку Supply chain, чтобы увидеть актуальные данные о цене и доступности. Наведите курсор на изображение, чтобы показать пример.

Чтобы получить доступ к Altium Content Vault, включите его на странице Data Management - Servers диалогового окна Preferences. После этого используйте панель Explorer для просмотра содержимого.

Управляемый компонент включает в себя не только все необходимые доменные модели, с видимой и отслеживаемой историей и статусом жизненного цикла, но и информацию о цепочке поставок. Каждый компонент в Altium Content Vault включает в себя данные производителя, и они подключены к доступным поставщикам через службу Altium Parts Provider. Поставщик, цена, уровни запасов, минимальные объемы заказа – вся эта типовая информация о цепочке поставок доступна для управляемых компонентов. Проектировщик может затем добавить эти актуальные данные непосредственно в состав изделия с помощью ActiveBOM.

Понимая важность решения задачи управления компонентами, компания Altium развивает технологии хранения данных и управления компонентами.

Чтобы узнать больше о создании управляемых компонентов и управления ими, перейдите на страницу Работа с управляемыми компонентами.

Чтобы узнать больше о создании управляемого содержимого и работы с ним, перейдите на страницу Работа с сервером управляемых данных.

Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе:
Бесплатная пробная версия Altium Designer
Бесплатная пробная версия Altium Designer
Давайте приступим. Для начала, Вы или Ваше предприятие уже используете Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

В таком случае, для чего Вам необходима пробная лицензия?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вам для этого не нужна пробная лицензия.

Нажмите кнопку ниже, чтобы загрузить установщик самой новой версии Altium Designer

Загрузить установщик Altium Designer

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Пожалуйста, заполните форму ниже, чтобы получить ценовое предложение.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Если Ваша подписка Altium активна, у Вас нет необходимости в пробной лицензии.

Если у Вас нет активной подписки Altium, пожалуйста, заполните форму ниже, чтобы получить пробную версию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Для чего Вы хотите попробовать Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы нашли нужное место! Пожалуйста, заполните форму ниже, чтобы начать использование пробной версии.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Отлично! Знаете ли Вы, что мы предлагаем для студентов специальные скидки на лицензии? Для получения более подробной информации нажмите здесь.

А пока что Вы можете запросить пробную лицензию, заполнив форму ниже.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Замечательно! Создавать новое - отличное занятие. У нас есть превосходная программа для Вас.

Upverter - бесплатная платформа, разработанная специально для любителей проектирования.

Нажмите здесь, чтобы попробовать!

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.