Altium Designer Documentation

Новый интерфейс пользователя

Последнее изменение: Pavel Demidov; 10.09.2018

Содержание

Полное содержание

Altium Designer 18.0 является большим обновлением одной из самых популярных систем проектирования электронных устройств в мире. В эту версию включен не только ряд новых функций и улучшений – были также проведены большие изменения, повышающие производительность конструктора.

Altium Designer 18.0 повышает эффективность благодаря следующим улучшениям:

  • Существенное повышение производительность – значительно более быстрое выполнение таких ресурсоемких задач, как трассировка 100 цепей с помощью ActiveRoute или анализ сложной цепи «земля».
  • Улучшенная плавность при повороте и масштабировании платы в 3D.
  • Комплексная переработка интерфейса пользователя.

Altium Designer 18.0 выглядит и ощущается совершенно по-новому; от цветовой схемы главных сред до новых панелей и более быстрому доступу к настройкам и серверу управляемых данных – все это обеспечивает более последовательную и эффективную работу в новой версии Altium Designer.

Вот некоторые изменения:

  • Новая цветовая схема Altium Designer – светлый текст на темном фоне. Исследования показывают, что интерфейсы, где преобладает текст, как правило, работают лучше с темным текстом на светлом фоне, но интерфейсы, где обычно нужно работать с графической информацией, лучше для глаз при светлом содержимом на темном фоне.
  • Новая панель Properties (Свойства) устраняет потребность в диалоговых окнах для объектов, что значительно ускоряет и упрощает их размещение и редактирование. В этой новой панели собираются все родительские и дочерние свойства, что делает ее оптимальной точкой доступа к этим свойствам.
  • На новой панели инструментов Active Bar собраны элементы управления для размещения объектов в редакторе платы, редакторе схемы, Draftsman и документах библиотек.
  • Некоторые редко используемые панели и настройки были исключены.
  • Панель Vaults была переименована в панель Explorer.

Цель этого документа – предоставить обзор ключевых изменений интерфейса пользователя Altium Designer 18.0. Подробную информацию по новым возможностям, а также по улучшениям существующих функций вы можете найти в прочих документах раздела. Прочтите этот документ, чтобы узнать о ключевых изменениях внешнего вида системы и о том, какие преимущества эти изменения предлагают для повышения вашей производительности.

Новая цветовая схема

Для повышения эффективности рабочего пространства общая цветовая схема Altium Designer была изменена на темную. Цветовая схема панелей и некоторых диалоговых окон также обновлена.


Новое рабочее пространство Altium Designer

      Новая цветовая схема панелей Altium Designer (в качестве примеров приведены панели Projects и PCB List)


Новая цветовая схема применена к некоторым диалоговым окнам (в качестве примера приведено окно Project Options)

Изменения меню

Меню DXP удалено

Меню DXP было удалено – теперь наиболее часто используемые элементы меню добавлены в качестве кнопок и команд в более доступные расположения. Наиболее значительные изменения описаны ниже.

Страница My Account переименована в License Management

Название страницы My Account (Моя учетная запись), где осуществляется настройка использования лицензии, было изменено на License Management (Управление лицензиями), что лучшим образом отражает назначение этой страницы.

Доступ к настройкам

Настройки Altium Designer легко открыть нажатием по кнопке , расположенной в верхнем правом углу рабочего пространства, как показано на рисунке ниже.

Нажмите кнопку, выделенную на рисунке, чтобы открыть диалоговое окно настроек Preferences


Доступ к настройкам Altium Designer

Доступ к управлению лицензиями

Чтобы открыть страницу License Management (Управление лицензиями), выберите команду License Management из выпадающего меню в правом верхнем углу рабочего пространства, как показано на рисунке ниже.


Выберите команду License Management из выпадающего меню, чтобы открыть страницу License Management

Доступ к управлению лицензиями

Доступ к расширениям и обновлениям

Чтобы открыть страницу Extensions & Updates (Расширения и обновления), выберите команду Extensions and Updates из выпадающего меню в правом верхнем углу рабочего пространства, как показано на рисунке ниже.

Выберите команду Extensions and Updates из выпадающего меню, чтобы открыть страницу Extensions & Updates

Доступ к расширениям и обновлениям

Доступ к серверу управляемых данных

Вход и выход с сервера управляемых данных​

Чтобы войти на сервер управляемых данных, выберите команду Sign in из выпадающего меню в правом верхнем углу рабочего пространства, как показано на рисунках ниже.


Вход на сервер

После входа на сервер, в верхнем правом углу будет указана ваша учетная запись, как показано на рисунке ниже.


При входе на сервер указывается ваша учетная запись

Чтобы выйти с сервера, выберите команду Sign out из выпадающего меню в правом верхнем углу рабочего пространства, как показано на рисунках ниже.


Выход с сервера

Доступ к серверу управляемых данных

После входа на сервер вы можете открыть панель с новым названием Explorer, выбрав свой сервер управляемых данных из выпадающего меню в верхнем правом углу рабочего пространства.

Панель Explorer также можно открыть, выбрав вкладку Panels в нижнем правом углу и нажав Explorer.

Доступ к форумам Altium

Форумы Altium, где вы можете задать вопрос по использованию и работе в Altium Designer, а также дать обратную связь, теперь можно открыть через строку меню, выбрав Help » User Forums, как показано на рисунке ниже.


Доступ к форумам пользователей

Доступ к поиску

Поиск (Search) теперь расположен в верхнем правом углу рабочего пространства, как показано на рисунке ниже.

Расположение строки поиска

Дополнительные команды

  • Команда Customize (Настроить) теперь доступна по нажатию правой кнопкой мыши по строке меню.
  • Команда Run Process (Запустить процесс) была удалена из-за редкого использования.

Удаленные команды меню редактора схем

Далее представлен список команд редактора схем, которые были удалены, с указанием причины удаления. В некоторых случаях, команды была перенесена в панели, что также указано ниже.

  • Design » Add/Remove Library (Проект » Добавить/удалить библиотеку) – функция расположена в панели Libraries (Библиотеки).
  • Design » Document Options (Проект » Настройки документа) – меню расположено в панели Properties (Свойства) и отображается, если ничего не выбрано.
  • Edit » Change (Редактировать » Изменить) – заменено выбором одного или нескольких объектов для редактирования в панели Properties (Свойства).
  • Edit » Clear (Редактировать » Очистить) – удалена из-за редкого использования.
Поскольку команда Clear была исключена, ее фукциональные возможности были добавлены в переработанную существующую команду Delete, которая доступна в Edit, как и ранее. Команда Delete теперь работает в двух режимах, в зависимости от того, есть ли в рабочем пространстве выделенные объекты или нет:
Объекты выделены - они будут удалены из документа.
Нет выделенных объектов - курсор изменяется на перекрестие, и вы выбираете объекты в режиме удаления. Наведите курсор на объект и щелкните по нему или нажмите Enter, чтобы удалить его. Продложайте удалять объекты, либо щелкните правой кнопкой мыщи или нажмите Esc, чтобы выйти из режима удаления объектов.
  • Edit » Duplicate (Редактировать » Создать дубликат) – избыточна, дублирует команду Rubber Stamp (Штамп).
  • Edit » Rubber Stamp (Редактировать » Штамп) – измененная команда Duplicate (Создать дубликат).
  • File » Link Sheet to Vault (Файл » Связать лист с Vault) – вытеснена подходом прямого редактирования.
  • File » Release Manager (Файл » Диспетчер выпуска) – вытеснена подходом прямого редактирования.
  • Place » Manual Junction (Поместить » Ручное соединение) – соединения добавляются автоматически.
  • Place » Hyperlink (Поместить » Гиперссылка) – функциональность теперь является частью объекта Text String (Текстовая строка).
  • Place » Directives » PCB Layout (Поместить » Директивы » Конструкция платы) - удалена из-за редкого использования.
  • Place » Directives » Net Class - теперь можно выполнить с помощью общей команды Place » Directives » Parameter Set (Поместить » Директивы » Настройка параметра).
  • Place » Directives » Stimulus (Поместить » Директивы » Входной сигнал) - удалена из-за редкого использования.
  • Place » Directives » Test Vector Index (Поместить » Директивы » Индекс тестового вектора) – удалена из-за редкого использования.
  • Place » Directives » Probe (Поместить » Директивы » Пробник).
  • Place » Directives » Instrument Probe (Поместить » Директивы » Измеритель пробника).
  • Place » Drawing Tools » Bezier (Поместить » Инструменты черчения » Кривая Безье) – удалена из-за редкого использования.
  • Place » Drawing Tools » Pie Chart (Поместить » Инструменты черчения » Круговая диаграмма) – удалена из-за редкого использования.
  • Place » Drawing Tools » Elliptical Arc (Поместить » Инструменты черчения » Эллиптическая дуга) – удалена из-за редкого использования.
  • Place » Notes » Ellipse (Поместить » Примечания » Эллипс) – удалена из-за редкого использования.
  • Place » Notes » Rectangle (Поместить » Примечания » Прямоугольник) – удалена из-за редкого использования.
  • Place » Notes » Polygon (Поместить » Примечания » Полигон) – удалена из-за редкого использования.
  • Tools » NoERC Manager (Инструменты » Диспетчер NoERC) – удалена из-за редкого использования.
  • Tools » Harness Definition Problem Finder (Инструменты » Поиск проблем задания жгута) – удалена из-за редкого использования.

Удаленные команды меню редактора плат

Далее представлен список команд редактора плат, которые были удалены, с указанием причины удаления. В некоторых случаях, команды была перенесена в панели, что также указано ниже.

  • Edit » Build Query (Shift+B) (Редактировать » Создать запрос (Shift+B)) – удалена из-за редкого использования; функция доступны при работе правилами и фильтрами.
  • Edit » Clear (Редактировать » Очистить) – удалена из-за редкого использования.
Поскольку команда Clear была исключена, ее фукциональные возможности были добавлены в переработанную существующую команду Delete, которая доступна в Edit, как и ранее. Команда Delete теперь работает в двух режимах, в зависимости от того, есть ли в рабочем пространстве выделенные объекты или нет:
Объекты выделены - они будут удалены из документа.
Нет выделенных объектов - курсор изменяется на перекрестие, и вы выбираете объекты в режиме удаления. Наведите курсор на объект и щелкните по нему или нажмите Enter, чтобы удалить его. Продложайте удалять объекты, либо щелкните правой кнопкой мыщи или нажмите Esc, чтобы выйти из режима удаления объектов.
  • Edit » Change (Редактировать » Изменить) – удалена из-за редкого использования.
  • Edit » Rubber Stamp (Редактировать » Штамп) – переименованная команда Duplicate.
  • Place » Coordinate (Поместить » Координата) – заменено инструментами Draftsman.
  • View » Net Color Override (Вид » Переопределить цвет цепи) – теперь находится в панели View Configuration (Настройки вида), вкладке View Options (Параметры вида), раздел Additional Options (Дополнительные параметры).

  • Tools » Component Placement » Auto Placer (Инструменты » Размещение компонентов » Автоматическое размещение) – устаревшая технология.
  • Tools » Component Placement » Stop Auto Placer (Инструменты » Размещение компонентов » Остановить автоматическое размещение) – устаревшая технология.
  • Tools » Component Placement » Shove (Инструменты » Размещение компонентов » Вставка) – устаревшая технология.
  • Tools » Component Placement » Shove Depth (Инструменты » Размещение компонентов » Глубина вставки) – устаревшая технология.
  • Tools » Density Map (Инструменты » Диаграмма плотности) – устаревшая технология.
  • Tools » Grid Manager (Инструменты » Диспетчер сеток) – сетки теперь задаются в разделе Grid Manager панели Properties (Свойства) в режиме Board (Плата), т.е. когда не выбрано никаких объектов.

  • Tools » Guide Manager (Инструменты » Диспетчер направляющих) – направляющие теперь задаются в разделе Guide Manager панели Properties (Свойства) в режиме Board (Плата), т.е. когда не выбрано никаких объектов.

  • Tools » Legacy Tools (Инструменты » Устаревшие инструменты) – заменены более новыми инструментами.
  • Design » Board Layers & Colors (Проект » Слои и цвета платы) – функции теперь доступны на панели View Configuration (Настройки вида).
  • Design » Board Options (Проект » Параметры платы) – некоторые параметры меню перенесены в панель Properties (Свойства) или заменены инструментами Draftsman.
  • Reports » Board Information (Отчеты » Информация о плате) – представлена в разделе Board Information панели Properties (Свойства) в режиме Board (Плата), т.е. когда не выбрано никаких объектов.

Меню File

Меню File (Файл), доступное из строки меню, было оптимизировано, чтобы в нем содержались только команды, относящиеся к файлам.

Пример меню File документа схемы

Улучшенные команды создания проекта

Подменю создания нового проекта (File » New » Project) было реорганизовано и сокращено, чтобы здесь отображались только основные типы проектов:

  • PCB Project (Проект платы) – выберите, чтобы создать новый проект платы. В панели Projects (Проекты) появится новая запись PCB_Project.PrjPCBd.
  • Multi-board Design Project (Проект многомодульной конструкции) – выберите, чтобы создать новый проект многомодульного устройства. В панели Projects(Проекты) появится новая запись MultiBoard_Project.PrjMbd.
  • Integrated Library (Интегрированная библиотека) – выберите, чтобы создать новый проект интегрированной библиотеки. В панели Projects (Проекты) появится новая запись Integrated_Library.LibPkg.
  • Project (Проект) – если вы выберите этот вариант, появится диалоговое окно New Project (Новый проект), где вы можете указать подробную информацию по новому проекту.

Типы новых файлов, которые можно создать

  • Multi-board Schematic (Схема многомодульной конструкции, *.MbsDoc) – доступен, если активным документом является проект многомодульной конструкции.
  • Mutli-board Assembly (Сборка многомодульной конструкции, *.MbaDoc) – доступен, если активным документом является проект многомодульной конструкции.

Удаленные типы новых файлов

  • Text Document (Текстовый документ, *.txt)
  • Component Library (Библиотека элементов, *.CmpLib)
  • PCB3D Library (Библиотека PCB3D, *.PCB3DLib) – вытеснена мощной средой 3D-редактирования.
  • Java Script Unit (Блок Java, *.js)
  • Java Script Form (Форма Java, *.js)
  • TCL Script Unit (Блок TCL, *.tcl)
  • Enable Basic Script Unit (Блок Basic, *.bas)
  • VB Script Unit (Блок VB, *.vbs)
  • VB Script Form (Форма VB, *.vbs)
Файлы этих типов больше не возможно создать через File » New, но их можно редактировать, если они использовались в предыдущих проектах.

Изменения контекстного меню

Контекстные меню редакторов схем и плат были оптимизированы – теперь здесь остались лишь необходимые команды. Наведите курсор мыши на изображение, чтобы увидеть контекстное меню из предыдущей версии.


Контекстное меню, доступное по щелчку правой кнопкой мыши по пустому пространству, в редакторе схем (слева) и плат (справа).

Удаленные команды контекстного меню редактора схем

  • Refactor (Рефакторинг)
  • Grid (Сетка)
  • View (Вид)
  • Workspace Panels (Панели рабочего пространства)
  • Find Component (Найти элемент)
  • Place Part (Поместить компонент)
  • Options (Параметры)
Удаленные команды контекстного меню проводника
  • Wire (Проводник)
  • Bus Entry (Шинные входы)
  • Break Wire (Разрыв проводника)

Удаленные команды контекстного меню шины

  • Bus (Шина)
  • Bus Entry (Шинные входы)
  • Break Wire (Разрыв проводника)

Удаленные команды контекстного меню жгута

  • Break Wire (Разрыв проводника)

Добавленные команды контекстного меню редактора схем

  • Project Options (Параметры проекта) – открывает диалоговое окно Project Options.
  • Preferences (Настройки) – открывает диалоговое окно Preferences.

Изменения в настройках

Новые страницы настроек

Data Management - Servers (Управление данными - Серверы)

На странице Data Management - Servers диалогового окна Preferences вы можете настроить использование текущего сервера управляемых данных и параметры выпуска проектов.


Страница Data Management - Servers диалогового окна Preferences

Data Management - Component Rule Checks (Управление данными - Проверка правил элементов)

На странице Data Management - Component Rule Checks диалогового окна Preferences вы можете настроить сообщения об ошибках компонентов.

0.
Страница Data Management - Component Rule Checks диалогового окна Preferences

Multi-board Schematic - Defaults (Схема многомодульной конструкции – Настройки по умолчанию)

На странице Multi-board Schematic - Defaults диалогового окна Preferences вы можете настроить примитивы по умолчанию для схемы многомодульной конструкции.


Страница Multi-board Schematic - Defaults диалогового окна Preferences (выбран пункт Text)

Multi-board Assembly - General (Сборка многомодульной конструкции – Общие настройки)

На странице Multi-board Assembly - General диалогового окна Preferences вы можете настроить, какие элементы будут импортироваться из платы.


Страница Multi-board Assembly - General диалогового окна Preferences

Multi-board Assembly - View Configuration (Сборка многомодульной конструкции - Настройка вида)

На странице Multi-board Assembly - View Configuration диалогового окна Preferences вы можете настроить параметры цветов и отображения.


Страница Multi-board Assembly - View Configuration диалогового окна Preferences

Обновленные страницы настроек

Страницы Defaults (Настройки по умолчанию)

Страницы Defaults теперь включают в себя настройки по умолчанию для большинства примитивов. На рисунке ниже показан пример настройки примитива Blanket (Область) на странице Schematic - Defaults (Схема - Настройки по умолчанию).


Задание примитиву Blanket настроек по умолчанию на странице Schematic - Defaults диалогового окна Preferences

System - General (Система - Общие настройки)

Наведите курсор мыши на изображение, чтобы увидеть предыдущую версию страницы System - General диалогового окна Preferences

  • Удален параметр Open Home Page if no documents open (Открывать домашнюю страницу, если нет открытых документов) из области Startup (Запуск).
  • Удален параметр Enable debug memory manager (Включить диспетчер отладки памяти) из области General (Общие настройки).
  • Добавлена кнопка Advanced (Расширенные настройки) для открытия диалогового окна Advanced Settings, где вы можете задать параметры, показанные на рисунке ниже.


Диалоговое окно Advanced Setting

Как сказано в этом диалоговом окне, изменение этих настроек может повлиять на стабильность Altium Designer. Вносите изменения с осторожностью.

System - View (Система - Вид)

Наведите курсор мыши на изображение, чтобы увидеть предыдущую версию страницы System - View диалогового окна Preferences

  • Удален параметр Exclusions (Исключения) из области Desktop (Рабочий стол).
  • Вы можете загружать, сохранять и сбрасывать расположение элементов на вкладке Desktop (Рабочий стол).
  • Удалена область Show Navigation Bar As (Отображать строку навигации как).
  • Удален параметр Show full path in title bar (Показывать полный путь в строке названия) из области General (Общие настройки).
  • Удален параметр Favorites panel (Панель Избранное), т.к. удалена панель Favorites.
  • Удалены параметры Auto-hide the documents bar (Автоматически скрывать строку документов) и Multiline documents bar (Перенос строки документов) из области Documents Bar (Строка документов).
  • Добавлена область UI Theme (Тема интерфейса пользователя), где вы можете настроить тему и предварительно просмотреть результат.

System - Navigation (Система - Навигация)

Наведите курсор мыши на изображение, чтобы увидеть предыдущую версию страницы System - Navigation диалогового окна Preferences

  • Удален параметр Masking (Маскирование)– теперь он доступен на панели SCH Filter.
  • Добавлен параметр Dimming (Затемнение) с ползунком для настройки затемнения.
  • Параметр Masking (Маскирование) из области Cross Select Mode (Режим перекрестного выделения) переименован в Dimming.

System - Projects Panel (Система - Панель Projects)

Наведите курсор мыши на изображение, чтобы увидеть предыдущую версию страницы System - Projects Panel диалогового окна Preferences

  • Удалены параметры Show open/modified status (Показывать состояние открытия/изменения) и Show Grid (Показывать сетку) из области General (Общие настройки).
  • Область Grouping (Группирование) переименована в Documents Grouping (Группирование документов). Параметры остались неизменными.
  • Удалена область Structure View (Структурный вид).
  • Добавлена новая область Components Grouping (Группирование элементов). Параметры этой области позволяют группировать компоненты по позиционному обозначению, комментарию, владельцу листа или не группировать вовсе.

System - New Document Defaults (Система - Настройки нового документа по умолчанию)

Наведите курсор мыши на изображение, чтобы увидеть предыдущую версию страницы System - New Document Defaults диалогового окна Preferences

  • Настройки по умолчанию, относящиеся к документам ПЛИС, удалены.

Data Management - Version Control (Управление данными - Контроль версий)

Наведите курсор мыши на изображение, чтобы увидеть предыдущую версию страницы Data Management - Version Control диалогового окна Preferences

  • Удалена опция CVS - Concurrent Versions System.

Data Management - Parts Providers (Управление данными - Поставщики компонентов)

Наведите курсор мыши на изображение, чтобы увидеть предыдущую версию страницы Data Management - Parts Providers (Suppliers) диалогового окна Preferences.

  • Заголовок страницы Data Management - Suppliers диалогового окна Preferences изменен на Data Management - Parts Providers для соответствия расширению Altium Parts Providers.
  • Удалены параметры Move Up/Down (Переместить вверх/вниз) и Filter (Фильтр) в области Altium Parts Options (Параметры элементов Altium).

Schematic - General (Схема - Общие настройки)

Наведите курсор мыши на изображение, чтобы увидеть предыдущую версию страницы Schematic - General диалогового окна Preferences.

  • Добавлены параметры Units (Единицы измерения), которые раньше находились на странице Schematic - Default Units. Только параметры Mils (Милы) и Millimeters (Миллиметры).

Схемы, созданные в предыдущих версиях в имперских единицах, откроются в милах. Схемы, созданные в предыдущих версиях в метрических единицах, откроются в миллиметрах.

  • Удалены параметры No-ERC Markers (Маркеры NoERC) и Notes (Примечания) из параметров Include with Clipboard (Включить в буфер обмена). Эти параметры будут включены в буфер обмена по умолчанию, если включен родительских элемент.
  • Удален параметр Document scope for filtering and selection (Область действия документа для фильтрации и выделения), поскольку текущий документ выбран по умолчанию.

Schematic - Graphical Editing (Схема - Графическое редактирование)

Наведите курсор мыши на изображение, чтобы увидеть предыдущую версию страницы Schematic - Graphical Editing диалогового окна Preferences.

  • Удален параметр Convert Special Strings (Преобразовывать специальные строки), поскольку строка отображается всегда. В случае пустой строки отображается название параметра.
  • Добавлен параметр Display Names of Special Strings that have No Value Defined (Отображать имена специальных строк без заданных значений). Вы можете выбрать цвет этих строк в области Color Options (Настройки цвета) в параметре Special Strings with No Value.
  • Удален параметр Double Click Runs Inspector (Запускать Инспектор двойным щелчком), поскольку удалены панели Inspector.
  • Добавлен параметр Enable Auto Pan (Включить автоматическое панорамирование) в область Auto Pan Options (Параметры автоматического панорамирования).
  • Удалена область Undo/Redo (Отменить/повторить действие). Теперь настройки задаются с помощью параметров Value (Значение) и Default Value (Значение по умолчанию) для Schematic.UndoStackSize в диалоговом окне Advanced Settings (открывается по нажатию кнопки Advanced на странице System - General диалогового окна Preferences).

Schematic - Compiler (Схема - Компилятор)

Наведите курсор мыши на изображение, чтобы увидеть предыдущую версию страницы Schematic - Compiler диалогового окна Preferences

  • Удалены параметры Manual Junctions Connection Status (Отображение состояния ручных соединений).
  • Удален ползунок Dim level for read-only objects in compiled documents tabs (Уровень затемнения для нередактируемых объектов в строках скомпилированных документов). Элемент управления Dimming (Затемнение) для вкладки Editor схемы расположен на странице System - Navigation диалогового окна Preferences.

Schematic - AutoFocus (Схема - Автоматическая фокусировка)

Наведите курсор мыши на изображение, чтобы увидеть предыдущую версию страницы Schematic - AutoFocus диалогового окна Preferences

  • Удален ползунок Dim Level (Уровень затемнения) из области Dim Unconnected Objects (Затемнять несоединенные элементы).

     

Schematic - Grids (Схема - Сетки)

Наведите курсор мыши на изображение, чтобы увидеть предыдущую версию страницы Schematic - Grids диалогового окна Preferences

  • Добавлена опция Snap Distance (Расстояние присоединения).
  • Удалена опция Electrical Grid (Электрическая сетка).

PCB Editor - General (Редактор плат - Общие настройки)

Наведите курсор мыши на изображение, чтобы увидеть предыдущую версию страницы PCB Editor - General диалогового окна Preferences

  • Удален параметр Double Click Runs Inspector (Запускать Инспектор двойным щелчком), поскольку удалены панели Inspector.
  • Удалена область Undo/Redo (Отменить/повторить действие) из области Other (Остальное). Теперь настройки задаются с помощью параметров Value (Значение) и Default Value (Значение по умолчанию) для PCB.UndoStackSize в диалоговом окне Advanced Settings (открывается по нажатию кнопки Advanced на странице System - General диалогового окна Preferences).
  • Добавлен параметр Enable Auto Pan (Включить автоматическое панорамирование) в область Autopan Options (Параметры автоматического панорамирования). Если параметр включен, то при выполнении любого редактирования и при активном перекрестии курсора, перемещение курсора за край документа приведет к панорамированию документа в соответствующем направлении.
  • Добавлен параметр Repour all dependent polygons after editing (Перезалить все зависимые полигоны после редактирования) в области Polygon Rebuild (Перестроение полигонов).

     

  • Удален параметр DXP App Server из области Collaboration (Взаимодействие).

     

PCB Editor - Display (Редактор плат - Отображение)

Наведите курсор мыши на изображение, чтобы увидеть предыдущую версию страницы PCB Editor - Display диалогового окна Preferences

  • Удалены параметры Default PCB View Configurations (Настройки отображения платы по умолчанию) и 3D Bodies (3D-тела). Отображение и 3D-тела теперь зависят от параметров General Settings (Общие настройки) на вкладке View Options (Параметры отображения) в панели View Configuration (Настройка вида).

  • Удалены параметры Flyover Zoom (Масштабирование при проходе), Alpha Blending (Альфа-смешивание) и Ordered Blending (Упорядоченное смешивание).
  • Теперь вы можете использовать параметр Antialiasing On/Off, чтобы включать и отключать 3D-сглаживание.
  • Добавлена область Layer Drawing Order (Порядок отрисовки слоев) для задания порядка слоев.

PCB Editor - Board Insight Display (Редактор плат - Отображение платы)

Наведите курсор мыши на изображение, чтобы увидеть предыдущую версию страницы PCB Editor - Board Insight Display диалогового окна Preferences

  • Сокращены параметры Live Highlighting (Динамическая подсветка). Включите параметр Live Highlighting only when Shift Key Down, чтобы включить динамическую подсветку только при зажатой клавише Shift.

PCB Editor - DRC Violations Display (Редактор схем – Отображение нарушений проверки проектных правил)

Наведите курсор мыши на изображение, чтобы увидеть предыдущую версию страницы PCB Editor - DRC Violations Display диалогового окна Preferences

  • Удалена область Show Violation Detail (Отобразить подробную информацию по нарушению).

Удаленные страницы настроек

  • System - Altium Vault (Система - Altium Vault) – параметры теперь расположены на новой странице Data Management - Servers (Управление данными - Серверы) диалогового окна Preferences.
  • System - Desktop Layouts (Система - Слои рабочего стола) – более интуитивно понятные параметры расположены в меню View (Вид).
  • Data Management - Vaults (Управление данными - Vault) – параметры теперь расположены на новой странице Data Management - Servers (Управление данными - Серверы) диалогового окна Preferences.
  • Schematic - Default Units (Схема - Единицы измерения по умолчанию) – параметры теперь расположены на странице Schematic - General (Схема – Общие настройки) диалогового окна Preferences.
  • PCB Editor - Board Insight Lens – удалена из-за редкого использования.
  • PCB Editor - PCB Legacy 3D – устаревший элемент.
  • Все страницы Wave – удалены из-за редкого использования.

Изменения в настройках проекта

  • С вкладки Error Reporting (Отчет об ошибках) удалены параметры, относящиеся к ПЛИС, поскольку из системы удалены функциональные возможности проектирования ПЛИС. Наведите курсор мыши на изображение, чтобы увидеть предыдущую версию вкладки Error Reporting.

Наведите курсор мыши на изображение, чтобы увидеть предыдущую версию вкладки Error Reporting, с удаленными элементами, помеченными красными крестиками.

Список удаленных элементов:

  • Элементы, удаленные из области Violations Associated with Buses (Нарушения, связанные с шинами):
    • Arbiter loop in OpenBus document (Цикл разрешения нарушения в документе OpenBus)
    • Cascaded interconnects in OpenBus document (Каскадные межсоединения в документе OpenBus)
    • Forbidden OpenBus Link (Запретить ссылку OpenBus)
    • Mismatching Address/Data Widths of OpenBus Ports (Несоответствие адреса/разрядности данных в портах OpenBus)
  • Область Violations Associated with Code Symbols (Нарушения, связанные с символами кода) – все элементы.
  • Область Violations Associated with Configuration Constraints (Нарушения, связанные с настройками ограничений) – все элементы.
  • Элементы, удаленные из области Violations Associated with Documents (Нарушения, связанные с документами):
    • Conflicting Constraints (Конфликты ограничений)
    • HDL Identifier Renamed (Переименованные идентификаторы HDL)
    • Missing child HDL entity for sheet symbol (Потерянный дочерний элемент HDL символа листа)
    • Missing Configuration Target (Потерянная цель настройки)
    • Missing sub-Project sheet for component (Потерянный лист подпроекта для элемента)
    • Multiple Configuration Targets (Потерянные цели настройки)

Изменения панелей

Открытие панелей

Чтобы открыть панель, доступную для текущего редактора (платы, схемы, Draftsman, библиотеки и т.д.), используйте вкладку Panels (Панели) в нижнем правом углу рабочего пространства.


Доступ к панелям через вкладку Panels.

Доступ к панелям также можно получить через меню View » Panels.

Фильтр выбранных элементов

Новый инструмент фильтра добавлен в верхнюю правую часть панелей, как показано на рисунке ниже.

Этот инструмент позволяет вам отфильтровывать информацию, отображенную на открытой панели. Выберите кнопку рядом с иконкой фильтра, чтобы открыть выпадающее меню, как показано на рисунке ниже.

Вы можете снять выделение объектов в выпадающем меню, как показано на рисунке ниже, и эти объекты будут скрыты в панели.

Фильтр можно полностью включить/отключить, щелкнув по самой иконке фильтра, как показано на рисунке ниже.

Новые панели

Панель Properties (Свойства)

     Панель Properties, где в качестве примеров показаны настройки элемента схемы и платы.

В новой панели Properties (Свойства) содержится информация и элементы управления, которые относятся к выбранному в рабочем пространстве элементу. Если в рабочем пространстве ничего не выбрано, то отображаются параметры платы (в документе платы), схемы (в документе схемы), библиотеки (в документе библиотеки) или многомодульной конструкции (в документе многомодульной конструкции). На панели также представлен активный документ BOM (*.BomDoc). Это позволяет быстро, на лету изменять общие параметры документа. Эта панель также появляется при размещении объекта (дуги, текстовой строки, проводника и т.д.) в рабочем пространстве. Вы можете использовать панель Properties, чтобы настроить объект перед его размещением. В разделе Selection Filter (Фильтр выбора) вы можете управлять тем, что можно и что нельзя выбрать в рабочем пространстве.

Размещение объектов

При размещении объекта с помощью команды Place или с помощью новой панели инструментов Active Bar, вы можете нажать клавишу Tab после того, как выбрали объект для размещения, чтобы открыть панель Properties (Свойства) и выполнить необходимые изменения перед размещением. Когда вы готовы покинуть «режим размещения», нажмите символ паузы в рабочем пространстве.

Функция Search (Поиск) в верхней части панели Properties (выделен на рисунке ниже) позволяет найти необходимые элементы в панели.

Чтобы управлять содержимым панели, вы можете использовать две кнопки в верхнем правом углу панели Properties.

Нажмите кнопку (кнопка слева), чтобы включить в панель Properties все типы объектов со всех открытых документов одного проекта.

Нажмите кнопку (кнопка справа), чтобы включить в панель Properties все типы объектов только текущего документа.

Панель View Configuration (Настройка вида)

Панель View Configuration (Настройка вида) позволяет редактировать и управлять слоями платы, связанными с ними цветами и настройками, изменять параметры видимости, настройки 3D и маскирования. Панель также упрощает использование более сложных функций, таких как пары слоев.

Панель View Configuration включает в себя элементы управления для настройки слоев документа платы

Функция Search (Поиск) в верхней части панели позволяет найти необходимые элементы в панели.

Включение/выключение слоев

Вы можете включить или отключить слой, множество слоев или все слои с помощью элементов управления в каждой группе слоев, как показано на рисунке ниже.


Используйте выделенные элементы управления, чтобы включать и отключать группы слоев. В этом примере Component Layers (Слои элементов) показаны включенными.

Используйте элемент управления на верхнем уровне, чтобы включать/отключать весь слой, как показано на рисунке ниже.


Используйте выделенный элемент управления, чтобы включать и отключать всю группу. На рисунке все элементы Component Layers выключены

Вы также можете включать или отключать отдельные элементы в каждой группе с помощью элемента, показанного на рисунке ниже.


Выделенные элементы группы Component Layers выключены

Object Visibility (Видимость объектов)

Управляйте прозрачностью объектов в области Object Visibility (Видимость объектов) на вкладке View Options (Параметры вида).

3D Settings (Настройки 3D)

В области 3D Settings (Настройки 3D) на вкладке View Options (Параметры вида) вы можете настроить параметры отображения 3D.

Чтобы открыть область 3D Settings, параметр 3D в области General Settings (Общие настройки) должен быть включен (On), как показано ниже.

Mask and Dim Settings (Настройки маскирования и затемнения)

Для настройки маскирования, затемнения и подсвечивания используйте параметры в области Mask and Dim Settings вкладки View Options (Параметры вида).

Additional Options (Дополнительные настройки)

Область Additional Options (Дополнительные настройки) на вкладке View Options (Параметры вида) содержит элементы управления для различных настроек отображения, в том числе Net Color Override (Переопределение цвета цепи).

Изменения в существующих панелях

Панель Projects (Проекты)

  • Панель Projects (Проекты) теперь включает в себя многие функции, также расположенные в панели Navigator (Навигатор).
  • Новые элементы управления, расположенные в верхнем левом углу панели Projects, позволяют запускать функции в одно нажатие.

Элементы управления панели Projects

  • Используйте кнопку , чтобы сохранить текущий документ. Этот параметр доступен только когда, в текущем документе были проведены изменения.
  • Используйте кнопку , чтобы скомпилировать текущий проект.
  • Используйте кнопку , чтобы открыть диалоговое окно Project Options (Параметры проекта).
  • Используйте кнопку , чтобы открыть выпадающее меню (показано ниже) для настройки панели.

  • Новая функция Search (Поиск) позволяет найти определенный документ в панели. Функция работает как «фильтр» по мере ввода текста в поле.

    Новая возможность Search (Поиск) в панели Projects (слева); функция Search в действии (справа).

  • Папки Components (Элементы) и Nets (Цепи) отобразится в панели Projects после компиляции проекта.


Отображение папок Components и Nets в панели Projects после компиляции проекта

  • Состояние документа – индикаторы справа от названия документа, указывающие состояние его открытия и изменения, удалены.

Контекстное меню панели Projects

Контекстные меню панели Projects были оптимизированы – теперь они включают в себя команды, относящие к элементу, по которому был выполнен щелчок правой кнопкой мыши.

  • Контекстное меню для Workspace

  • Контекстное меню для Project

  • Контекстное меню для документа схемы

  • Контекстное меню для документа платы

  • Вы можете отобразить обе панели Properties для открытых документов схемы и платы. Это особенно полезно при работе на двух мониторах – на одном мониторе открыта схема, на другом – плата. Отдельно открытые панели Properties каждого документа позволяют проводить изменения и отображать их в каждом документе в режиме реального времени.

Панель PCB ActiveRoute


Более эффективная панель PCB ActiveRoute

Эффективность панели PCB ActiveRoute была улучшена для более комплексного процесса трассировки.

Панель SCH Filter

 

  • Для управления уровнем параметра Mask out (Маскировать) добавлен ползунок.

Удаленные панели

  • 3D Visualization (3D-визуализация) – удалена из-за редкого использования.
  • Board Insight (Отображение платы) – удалена из-за редкого использования.
  • Clipboard (Буфер обмена) – удалена из-за редкого использования.
  • Compiled Object Debugger (Отладчик скомпилированного объекта) – удалена из-за редкого использования.
  • Favorites (Избранное) – удалена из-за редкого использования.
  • Files (Файлы) – удалена из-за редкого использования.
  • PCB Inspector (Инспектор платы) – вытеснена панелью Properties.
  • PCBLIB Inspector (Инспектор библиотеки платы) – вытеснена панелью Properties.
  • Sch Inspector (Инспектор схемы) – вытеснена панелью Properties.
  • SCHLIB Inspector (Инспектор библиотеки схемы) – вытеснена панелью Properties.
  • Sheet (Лист) – удалена из-за редкого использования.
  • Shortcuts (Сочетания клавиш) – контекстно-зависимые сочетания клавиш теперь приводятся в панели Properties.
  • To-Do (Схема) – удалена из-за редкого использования.

Удаленные объекты

Удаленные объекты схемы

  • Hyperlink (Гиперссылка) – удален из-за редкого использования. Функциональность добавлена в объект Text String (Текстовая строка).
  • Elliptical Arc (Эллиптическая дуга) – удален из-за редкого использования.
  • Manual Junction (Ручное соединение) – удален из-за редкого использования.
  • Test Vector Index Directive (Директива индекса тестового вектора) – удален из-за редкого использования.
Эти объекты нельзя больше разместить в схеме. Но если эти объекты есть в проекте, созданном в предыдущей версии, они будут существовать, но их свойства будут нередактируемыми.

Удаленные объекты платы

  • Coordinate (Координата)
  • Design View (Вид проекта)

Удаленные объекты Dimension (Размер):

  • Baseline Dimension (Размер от базы)
  • Center Dimension (Размер от центра)
  • Datum Dimension (Привязочный размер) – заменен объектом Ordinate dimension (Ордината).
  • Linear Diameter Dimension (Линейный диаметр)
  • Radial Diameter Dimension (Радиальный диаметр)

Удалено свойство Flipped on Layer

Свойство Flipped on Layer (Перевернут на слое) было удалено из свойств компонента. Ориентация компонента для слоя теперь задается параметром Orientation в диалоговом окне Layer Stack Manager.

Элементы управления для работы с вариантами

Управление вариантами теперь осуществляется через панель Projects (панель инструментов Variants удалена). Также как раньше, открыть диалоговое окно Variant Management (Управление вариантами) можно щелчком правой кнопкой мыши по нужному проекту в панели Projects и выбором команды Variants из контекстного меню. Задайте варианты необходимым образом и нажмите OK. В проект будет добавлена папка Variants. Папка содержит базовый проект ([No Variations]) и все заданные варианты. Текущий вариант отображен жирным белым шрифтом, как показано на рисунке ниже. Чтобы сделать вариант из списка активным, дважды щелкните по нему в панели либо нажмите по нему правой кнопкой мыши и выберите команду Set as current (Сделать текущим).

Текущий вариант отображен жирным белым шрифтом в панели Projects

Панель инструментов Active Bar

Теперь некоторые часто используемые команды для размещения и трассировки доступны на панели инструментов Active Bar. Эта панель позволяет легко разместить объекты в документах схемы, платы, Draftsman и библиотеки и выполнить трассировку на плате – в один клик, без использования главного меню. Набор элементов управления на панели зависит от текущего редактора (примеры приведены на рисунках ниже). Панель отображается в верхней части рабочего пространства, по центру.

При выборе элемента на панели инструментов вы сразу переходите в режим размещения, а курсор изменяет свой вид на перекрестие.

Чтобы открыть выпадающее меню элемента управления, обозначенное маленьким треугольником в нижнем правом углу, нажмите правой кнопкой мыши по элементу или зажмите на нем левую кнопку мыши. Вы сможете выбрать любую из доступных опций. Курсор изменит вид на перекрестие для размещения.

После использования объекта с панели Active Bar его кнопка становится активной/видимой.


Новая панель Active Bar документа схемы с раскрытым меню Place Wire (Поместить проводник)


Панель Active Bar документа платы с раскрытым меню Place Polygon (Разместить полигон)


Панель Active Bar документа Draftsman с раскрытым меню Line (Отрезок)


Панель Active Bar документа библиотеки схемы с раскрытым меню Place Line (Разместить отрезок)

Панель быстрого доступа

Панель быстрого доступа размещена в верхнем левом углу рабочего пространства. На этой панели вы можете быстро получить доступ к таким часто используемым командам, как сохранение активного документа, открытие документа, отмена и повтор действия. Также вы можете сохранить все документы в одно нажатие с помощью кнопки .

С помощью панели быстрого доступа быстро сохраняйте и открывайте документы, отменяйте и повторяйте действия.

Системные уведомления

Новая кнопка Notifications (Уведомления) доступна в верхнем правом углу рабочего пространства, как показано на рисунке ниже. Нажмите кнопку , чтобы открыть системные уведомления Altium Designer. Если есть уведомления, возле иконки будет отображено количество уведомлений.


Откройте системные уведомления с помощью кнопки Notifications

Дополнительные изменения интерфейса пользователя

  • Из редактора плат удалена кнопка Snap (Привязать). Параметры привязки Snap Options теперь задаются в панели Properties в режиме Board, когда в рабочем пространстве нет выбранных объектов.


Параметры привязки Snap Options в панели Properties

  • Затемнение (Dimming) для вкладки Editor схемы теперь определяется в области Highlight Methods (Методы выделения) на странице System - Navigation диалогового окна Preferences.

  • Из редактора плат удалена кнопка Mask Level (Уровень маскирования). Маскирование (а также затемнение и выделение на плате) теперь задаются в области Mask and Dim Settings (Настройки маскирования и затемнения) на вкладке View Options (Параметры вида) в панели View Configuration.


Настройки маскирования и затемнения Mask and Dim Settings в панели View Configuration

  • Удален параметр Linked To (Связать с) листа для механических слоев.
  • ​Удалена возможность скрывать документ(ы) из контекстного меню вкладки документа.
  • Удалена кнопка Clear (Очистить).
  • Удалена кнопка Home (Домой) и, как следствие, вкладки Start, Workspace, Documentation и Admin. Перейдите в раздел Доступ к управлению лицензиями этого документа, чтобы получить сведения по тому, что раньше было расположено на вкладке Admin.
Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе:
Бесплатная пробная версия Altium Designer
Бесплатная пробная версия Altium Designer
Давайте приступим. Для начала, Вы или Ваше предприятие уже используете Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

В таком случае, для чего Вам необходима пробная лицензия?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вам для этого не нужна пробная лицензия.

Нажмите кнопку ниже, чтобы загрузить установщик самой новой версии Altium Designer

Загрузить установщик Altium Designer

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Пожалуйста, заполните форму ниже, чтобы получить ценовое предложение.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Если Ваша подписка Altium активна, у Вас нет необходимости в пробной лицензии.

Если у Вас нет активной подписки Altium, пожалуйста, заполните форму ниже, чтобы получить пробную версию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Для чего Вы хотите попробовать Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы нашли нужное место! Пожалуйста, заполните форму ниже, чтобы начать использование пробной версии.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Отлично! Знаете ли Вы, что мы предлагаем для студентов специальные скидки на лицензии? Для получения более подробной информации нажмите здесь.

А пока что Вы можете запросить пробную лицензию, заполнив форму ниже.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Замечательно! Создавать новое - отличное занятие. У нас есть превосходная программа для Вас.

Upverter - бесплатная платформа, разработанная специально для любителей проектирования.

Нажмите здесь, чтобы попробовать!

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.