Altium Designer Documentation

Обзор нововведений

Modified by Pavel Demidov on May 23, 2018

FPGA Pin Mapper – Распределитель выводов ПЛИС

FPGA Pin Mapper в данный момент находится на стадии бета-тестирования.

Функциональная возможность распределения выводов ПЛИС FPGA Pin Mapping разработана для определения оптимальной топологии выводов программируемых устройств на плате. Эта возможность предоставляет интерактивный механизм обмена данными определения выводов/цепей между ПЛИС (или микроконтроллером) и платой посредством файлов формата csv, содержащими информацию по выводам.

Этот механизм представлен в Altium Designer в виде диалогового окна Pin Mapper, и он позволяет указать ссылки между схемным компонентом и внешним файлом *.csv с данными по выводам, созданный в среде разработки ПЛИС. Altium Designer обнаружит изменения, внесенные в файл, и предложит ряд вариантов для синхронизации данных по выводам, в том числе обновление внешнего файла для достижения соответствия названий цепей выводов в Altium Designer.

Таким образом, обмен данными о выводах между является двунаправленным, что обеспечивает итеративный, кооперативный подход к распределению выводов с помощью их эквивалентной замены и позволяет избежать ошибок при ручном обмене данными о выводах.

► Для обзора возможностей распределения выводов ПЛИС см. Руководство по FPGA Pin Mapper.

Обновления

Создание классов дифференциальных пар из редактора схем

Классы дифференциальных пар теперь можно задавать на уровне схемы с помощью добавления нового типа классов Diff.PairNetClass к директиве дифференциальной пары через панель свойств Properties.

Когда класс перейдет на плату через механизм внесения инженерных изменений (ECO), к нему можно применить правила трассировки дифференциальных пар. Параметры управления над классами дифференциальных пар можно указать на вкладках Comparator (Механизм сравнения) и ECO (Внесение инженерных изменений) диалогового окна Options for PCB project (Опции проекта платы) (Project » Project Options).

Улучшенная поддержка обратного высверливания

Сверловка управляемой глубины, или обратное высверливание, была улучшена в Altium Designer – теперь поддерживается технология удаления отрезков переходных отверстий для любых заданных пар обратного высверливания. Наряду с возможностью обратного высверливания от поверхности платы до любого внутреннего слоя, этот процесс и его правила проектирования теперь распознают соединения слоев с такими проводящими объектами, как полигоны, заполнения и регионы.

Привязка 3D-моделей

Чтобы повысить удобство и точность размещения 3D-моделей, была добавлена поддержка новых опорных точек. Также улучшены функции измерения критических расстояний привязки в 3D-объектах.

Дополнительные опорные точки:

  • Центры отверстий.
  • Точки пересечения ортогональных осей с ребром отверстия.
  • Середина ребра.
  • Центры линий между двумя точками привязки.
  • Оси тела модели.

Экспорт 3D-платы без свободных моделей

При экспорте 3D-модели печатного узла в САПР механической части изделия (MCAD) часто бывает необходимо исключить свободно размещенные 3D-тела, такие как корпуса, которые были импортированы из MCAD ранее.

Теперь доступен параметр Skip Free 3D Bodies (Игнорировать свободные 3D-тела) в диалоговом окне Export Options, открытие которого осуществляется с помощью команды File » Export » [формат] где формат – это PARASOLID, STEP 3D или VRLM. Этот параметр также доступен при добавлении экспорта в 3D-формат (Export Output) в файле выходной документации Output Job.

Точное преобразование шрифтов True Type в выходных файлах PDF

Обновлен генератор PDF-документации – теперь поддерживаются векторные шрифты True Type вместо растровых, что обеспечит четкую визуализацию шрифтов в выходных файлах PDF и позволит проводить поиск и выделение текста во внешних средствах просмотра файлов PDF.

При настройке файла OutJob для вывода PDF-документации, содержащей шрифты True Type, включите параметр печати TT fonts в диалоговом окне PCB Printout Properties, чтобы включить полную поддержку шрифтов True Type.

Обратите внимание, что Acrobat Reader сохраняет результаты предыдущих поисковых запросов, поэтому при обновлении существующего документа PDF из Altium Designer можно не получить ожидаемые результаты поиска. Чтобы исправить это, очистите кэш Acrobat Reader с помощью кнопки Purge Cache Contents (Очистить содержимое кэша) в разделе Search диалогового окна Preferences в Adobe Reader.

Выбор светлой/темной темы интерфейса

Altium Designer теперь включает в себя параметр для переключения между «темной» темой интерфейса (по умолчанию) и новой светло-серой темой (Altium Light Gray). Параметр доступен в выпадающем меню Current (Текущая тема) на странице System – View диалогового окна Preferences.

Конфигурации перечня компонентов ActiveBOM

Одним из основных требований к созданию перечня компонентов является возможность вывода разных вариантов этого перечня, каждый из которых отображает набор данных для различных процессов, следующих за этапом проектирования: закупка, подготовка к сборке и т.п.

ActiveBOM теперь поддерживает конфигурации (BOM Sets), каждая из которых определяет состояние таблицы объектов в перечне, сохраняя ее под отдельным названием. Можно задать любое количество BOM Sets; нажмите на иконку , чтобы применить конфигурацию BOM Set.

Настройка конфигураций BOM осуществляется в панели свойств ActiveBOM.

Поддержка выбора конфигурации BOM Set в процессе создания перечня будет добавлена в следующих версиях.

Улучшенная работа с псевдонимами в Draftsman

В таблице перечня компонентов Bill of Materials (BOM) в Draftsman есть возможность заменить стандартные заголовки столбцов на заданные пользователем псевдонимы (Alias), что позволяет настроить эту таблицу в соответствии с требованиями предприятия. Псевдонимы BOM могут быть заданы как в таблице BOM в Draftsman, так и в документе ActiveBOM проекта, при этом настройки проекта будут переопределять настройки документа Draftsman.

Обновленное взаимодействие с различными расположениями настроек псевдонимов происходит следующим образом:

  • Источником данных перечня BOM для чертежа Draftsman является документ ActiveBOM, если таковой доступен в проекте платы и в качестве параметра Data Source (Источник данных) в панели свойств Properties перечня BOM задан Project. В таблицу BOM редактора Draftsman перейдут настройки псевдонимов, заданные в исходном документе ActiveBOM, и они будут заданы только для чтения.
  • Если документ ActiveBOM отсутствует в проекте или в качестве параметра Data Source таблицы BOM в Draftsman задан Board, псевдонимы можно добавлять и редактировать на вкладке Columns (Столбцы) панели Properties , которая открывается, если выбрана таблица BOM.

Обратите внимание, что с помощью команды Tools » Update board можно обнаружить, был ли добавлен, удален или изменен документ ActiveBOM, а затем обновить состояние псевдонимов таблицы BOM в Draftsman соответствующим образом.

Формулы и умное редактирование в панели Properties

В панель Properties редакторов схемы и платы была добавлена возможность изменять строки данных с помощью формул и массовой замены. Формулы и выражения позволяют изменять параметры множества выбранных объектов для обновления их расположений или значений, такие как обозначение и комментарий.

► См. информацию по формулам и массовой замене (документация по панели List).

У некоторых строк параметров есть доступ к диалоговому окну Smart Edit (кнопка ), если выбрано множество объектов.

Глобальные настройки отображения компонентов на сборочном виде Draftsman

При выборе сборочного вида (Board Assembly View) в документе Draftsman, в разделе Component Display Properties (Свойства отображения компонентов) панели Properties теперь доступны настройки для всех компонентов этого вида. Изменения свойств отображения, таких как видимость тела компонента (параметр Component Body, ранее известный как Geometry Source) или обозначения (Designator), глобальны для выбранного сборочного вида.

Если на сборочном виде выбран компонент, то настройки Component Display Properties будут применены только к выбранному компоненту (как в предыдущих версиях Draftsman). Чтобы провести изменения определенного набора компонентов, используйте диалоговое окно Component Display Properties.

Теперь также доступна настройка для изменения цвета обозначения (Designator) с помощью кнопки , причем как в режиме глобального редактирования компонентов вида, так и при выборе одного компонента.

Индикаторы состояния документов в панели Projects

Для визуализации состояния документов открытого проекта были добавлены иконки файлов в панель Projects.

Если включено блокирование файлов (см. Data Management – File Locking), иконки документов в панели показывают, был ли документ открыт (), изменен (), открыт и заблокирован текущим экземпляром Altium Designer (), открыт и заблокирован другим экземпляром Altium Designer (). Независимо от того, включено блокирование файлов или нет, измененный документ обозначается звездочкой (*) возле имени файла.

Выбор формата Subversion для рабочей копии

Чтобы улучшить совместимость с существующими внешними системами контроля версий Subversion, Altium Designer теперь можно настроить на создание рабочих копий файлов SVN в одном из трех общих форматов версий SVN.

Если политика предприятия предписывает использование более ранней версии Subversion, например, версию 1.7, Altium Designer можно настроить для этой версии на странице Data Management – Version Control диалогового окна Preferences. Таким образом, будет задана версия рабочих версий файлов, созданных репозиторием SVN, что обеспечит совместимость с внешними клиентами и инструментами Subversion.

При создании нового набора рабочих копий файлов указанной версии, если Altium Designer обнаружит существующую рабочую копию, то система перезапишет набор файлов в ту же версию. Например, если предпочтительной версий SVN является 1.9, а в процессе передачи обнаружена существующая рабочая копия версии 1.8, то будет создана копия версии 1.8.

Рекомендованной версией SVN является 1.9 – она же задана в Altium Designer по умолчанию.

Метки идентификации специальных строк

Чтобы помочь в распознавании специальных строк , размещенных на плате или в легенде шаблона, в панель View Configuration добавлен параметр Special Strings (Специальные строки). Если этот параметр включен, то на строки, полученные преобразованием специальных строк, будут наложены названия непреобразованных специальных строк.

Приблизьте строку, чтобы увидеть ее метку.

Поддержка высоты запретных зон при импорте IDF

Транслятор формата обмена данными IDF (Intermediate Data Format) Altium Designer теперь поддерживает ограничения высоты в запретных зонах Keepout.

Определения зон Keepout в формате IDF могут включать дополнительный атрибут, задающий их максимальную высоту. При импорте платы, Altium Designer создает соответствующую комнату и связанное правило ограничения высоты. Ограничение высоты в новом правиле для комнаты соответствует атрибуту высоты зоны Keepout в исходном файле IDF.

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Связаться с нами

Связаться с нашими Представительствами напрямую

You are reporting an issue with the following selected text
and/or image within the active document:
Request Free Trial

Complete this form to request a free 15 day trial of Altium Designer: